Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2] » Le 24/09/2013, à 23:40

chiron
Réponses : 695

Bonsoir,

J'ai un gros souci sous multisystem que je fais tourner dans une VM virtualbox.
Il est impossible de rajouter une iso à la clef.

Système hote: Manjaro linux
Système invité (la VM): ubuntu 12.04 LTS, install fraîche, avec juste les mises à jour système, les additions invité de virtualbox, le dépot multisystem, et bien sûr multisystem
- Je rajoute mon user dans le groupe vboxsf et je vérifie, oui j'ai bien les droits RW dans les répertoires partagés depuis la VM.
- je branche une clef usb de 2go avec juste une partition fat32 vide.
- elle est bien reconnue dans la VM, et je peux lire / écrire dedans

Je lance multisystem, il me dit que ma clef n'a pas d'étiquette, ensuite il me prévient qu'il va installer grub, mais ensuite quand je veux ajouter une iso, multisystem ne me demande pas mon mot de passe root, et rien de plus ne se passe, multisystem reste figé. Y a t'il moyen de trouver un log quelconque pour le poster ici?

--------------------------------------
Pendant que j'écris ce post, je furète: je me rends compte qu'une bonne âme a porté le script sur AUR (manjaro est dérivée d'archlinux). Un petit coup de "yaourt multisystem"  et ça n'a pas l'air mal, juste que je dois mettre l'étiquette MULTISYSTEM à la mimine sur le clef. sinon j'arrive à ajouter une manjaro openbox et un gparted dessus sans trop de problème. Le temps de rebooter pour essayer et je vous dis.

#1 -1 »  syslog-ng + UFW + mysql + loganalyzer » Le 16/06/2014, à 14:20

chiron
Réponses : 0

Bonjour,

Je dois mettre en oeuvre le tryptique syslog-ng, mysql, loganalyzer pour pouvoir analyser des logs d'UFW.

UFW fonctionne bien.

Je n'arrive pas à savoir par quel bout prendre le problème. Comment faire pour:

- Configurer une base de données utilisable par loganalyzer
- Configurer syslog-ng pour qu'il alimente la dite base.

thanks. smile

#2 -1 »  [Résolu] wlan0 au démarrage » Le 12/05/2014, à 23:24

chiron
Réponses : 2

Bonjour à tous.

Sur mon serveur 12.04.4 j'ai monté un point d'accès avec une clef usb wifi TP-link TL-WN722N.
Tout fonctionne au poil, sauf que ça ne s'exécute pas au démarrage.

un ip addr me montre que wlan0 est down, donc à fortiori hostapd n'aura pas démarré, et le pool dhcpd non plus.
Je suis obligé de tout lancer manuellement:

sudo ifconfig wlan0 192.168.51.1 netmask 255.255.255.0 up
sudo hostapd /etc/hostapd/hostapd.conf &
sudo dhcpd wlan0

J'ai un autre pool dhcp dans le réseau 192.168.50.0/24, et là tout fonctionne bien

Y-a--t'il un truc qui cloche dans ma config?

user1@server1:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet dhcp
auto eth0
iface eth0 inet static
address 192.168.50.1
netmask 255.255.255.0

iface wlan0 inet static
address 192.168.51.1
netmask 255.255.255.0

gateway <mon ip publique>
dns-nameservers 8.8.8.8

#3 Re : -1 »  [Résolu] wlan0 au démarrage » Le 13/05/2014, à 13:55

chiron
Réponses : 2
jacobus77 a écrit :

auto wlan0 ?

Oups! roll

Merci beaucoup, problème résolu.
Pour ce qui est de dhcpd et de hostapd, j'ai créé un script de démarrage dans init.d

#4 Re : -1 »  MultiSystem, Créez votre LiveUSB MultiBoot simplement! » Le 08/12/2012, à 22:10

chiron
Réponses : 2566

Bonjour,

Je viens de passer à opensuse et KDE, et je n'arrive pas à faire fonctionner le script. J'ai résolu un certain nombre de dépendances, y compris en installant gtkdialog-0.8.2 depuis les sources, mais je bloque.

jyl@JYL-E6400:~/Téléchargements/multisystem> ./gui_multisystem.sh
Gtkdialog version: 0.8.2
LANG:fr_FR.UTF-8
LANGUAGE:fr_FR.UTF-8
LANGSEL:French|fr|fr_FR.UTF-8|Fabre François|liveusb@gmail.com
 Erreur il manque: update-grub2 kvm gksudo fatresize mksquashfs

Une idée?

#5 -1 »  [résolu] Ecrire données EXIF dans une série de fichiers » Le 24/08/2011, à 21:41

chiron
Réponses : 3

bonsoir,

Je suis confronté à un petit dilemne, je n'ai pas trouvé d'outil GUI ou ligne de commande pour faire le job:

J'ai une série de "vieux" JPG sans données exif. Le but du jeu est de mettre la date et heure de dernière modification du fichier comme donnée exif,et de répéter l'opération pour les 500 fichiers. Possible ou pas possible? wink

#6 Re : -1 »  [résolu] Ecrire données EXIF dans une série de fichiers » Le 03/09/2011, à 23:11

chiron
Réponses : 3

Oui, en partie merci smile . l'utilitaire stat en ligne de commande permet d'afficher les attributs d'un fichier, mais je n'ai pas encore trouvé comment récupérer la date de modif d'un fichier dans une variable...

#7 Re : -1 »  [résolu] Ecrire données EXIF dans une série de fichiers » Le 07/09/2011, à 22:13

chiron
Réponses : 3

J'ai ouvert un autre sujet dans la section programmation. Résolu. smile

#!/bin/bash
#
cd /home/jyl/Bureau/int
for filename in $(ls -1); do
modif=$(stat -c '%y' $filename)
heure=${modif#* }
heure=${heure%.*}
year=${modif%%-*}
base=${modif%% *}
day=${base##*-}
month=${base#*-}
month=${month%-*}
exiv2 -M"set Exif.Image.DateTime $year:$month:$day $heure" $filename
done
# http://www.exiv2.org/tags.html
cd /home/jyl

#8 -1 »  [résolu] BASH: Date de modification d'un fichier dans une variable » Le 06/09/2011, à 21:30

chiron
Réponses : 4

Bonsoir,

J'ai une série de "vieux" JPG sans données exif. Le but du jeu est de mettre la date et heure de dernière modification du fichier comme donnée exif de création de photo (avec exiv2),et de répéter l'opération pour les 500 fichiers. Le problème c'est que je n'arrive pas à récupérer la date de modif d'un fichier pour la mettre dans une variable. Je n'arrive à rien avec stat ou ls. Quelqun a une astuce?

#9 Re : -1 »  [résolu] BASH: Date de modification d'un fichier dans une variable » Le 06/09/2011, à 22:39

chiron
Réponses : 4

Merci, ça donne:

jyl@E6400:~/Bureau/int$ perl -MFile::stat -e 'print scalar localtime stat("1.jpg")->mtime, "\n"'
Sat Nov 19 15:19:26 2005

mais la chose se corse, de par le format des paramètres exigés par exiv2

   -a time Time adjustment in the format [-]HH[:MM[:SS]]. This option
           is only used with the 'adjust' action.
   -Y yrs  Year adjustment with the 'adjust' action.
   -O mon  Month adjustment with the 'adjust' action.
   -D day  Day adjustment with the 'adjust' action.

Comment extraire chaque valeur?

#10 Re : -1 »  [résolu] BASH: Date de modification d'un fichier dans une variable » Le 07/09/2011, à 22:10

chiron
Réponses : 4

Un grand merci. smile
Je suis arrivé à mes fins.

#!/bin/bash
#
cd /home/jyl/Bureau/int
for filename in $(ls -1); do
modif=$(stat -c '%y' $filename)
heure=${modif#* }
heure=${heure%.*}
year=${modif%%-*}
base=${modif%% *}
day=${base##*-}
month=${base#*-}
month=${month%-*}
exiv2 -M"set Exif.Image.DateTime $year:$month:$day $heure" $filename
done
# http://www.exiv2.org/tags.html
cd /home/jyl

#11 -1 »  serveur UPNP inaccessible » Le 12/08/2011, à 23:08

chiron
Réponses : 1

Bonsoir,

J'ai un serveur multimédia upnp dlna qui fonctionne comme un charme avec ma freebox, mais sur ma machine ubuntu 11.04, pas moyen de voir le serveur que ce soit avec vlc, totem avec le plugin coherence, ou xbmc. Rien à faire! ufw est inactif, donc je pense ne pas avoir de souci du côté des tables de routage.
Quelqun peut me filer un coup de main pour diagnostiquer le problème?

Merci beaucoup. smile

#12 Re : -1 »  serveur UPNP inaccessible » Le 24/08/2011, à 23:21

chiron
Réponses : 1

up?
J'ai testé depuis une machine virtuelle avec une installation toute fraiche. Je vois le serveur upnp sans problème...

#13 -1 »  Récupérer un chemin dans une variable? » Le 19/06/2011, à 22:57

chiron
Réponses : 7

Bonjour,

Dans un script bash j'ai une commande:

find / -maxdepth 3 -name essai2

qui me renvoie:

/volume1/video/essai2

Comment faire pour récupérer le chemin /volume1/video/ dans une variable pour le réutiliser plus tard?

J'ai essayé de me plonger dans le man de sed, mais euhh... roll

Merci à celui qui pourra me filer un petit coup de main... :-)

#14 Re : -1 »  Récupérer un chemin dans une variable? » Le 22/06/2011, à 10:50

chiron
Réponses : 7

Un grand merci à tous.
Je vous livre le fin fond de ma pensée. Je possède un synology DS110J, qui à priori ne gère pas l'uuid. Embêtant pour faire des sauvegardes automatisées (le point de montage pourrait changer si par exemple je débranche/rebranche en faisant du ménage).
J'ai fini mon morceau de bravoure. C'est la première fois que je me lance dans un script de cette ampleur.
J'ai utilisé une astuce, en testant la présence d'un fichier au nom unique sur les différents disques.
Je teste ensuite la présence de la source et de la sauvegarde (ainsi je ne risque pas d'écraser par mégarde ma sauvegarde), le retour du rsync, et un mail m'est envoyé systématiquement.
Les tests sont concluants, ça marche, y compris dans la crontab.
A votre avis, j'ai oublié quelque chose, il y a une faille?

#!/bin/ash
#
#
# Récupération des chemins des différents disques sources et de sauvegarde
# Cette moulinette teste la présence d'un fichier au nom unique sur chaque support et met le chemin dans une variable ad hoc
#
TestRsyncProgrammesSource=$(dirname $(find / -maxdepth 3 -name TestRsyncProgrammesSource | head -n1))           #Source des programmes
TestRsyncProgrammesDestination=$(dirname $(find / -maxdepth 3 -name TestRsyncProgrammesDestination | head -n1)) #Destination des programmes
TestRsyncVideoSource=/volume1/video                                                                             #Source des videos le chemin est toujours /volume1/video
TestRsyncVideoDestination=$(dirname $(find / -maxdepth 3 -name TestRsyncVideoDestination | head -n1))           #Destination des videos
TestRsyncVideo2Source=$(dirname $(find / -maxdepth 3 -name TestRsyncVideo2Source | head -n1))                   #Source des videos2
TestRsyncVideo2Destination=$(dirname $(find / -maxdepth 3 -name TestRsyncVideo2Destination | head -n1))         #Destination des videos2
#
#
# backup des programmes
#
rm -f /root/rapport-rsync.txt
#
#la source et la destination doivent exister sinon pas de sauvegarde
if [ -f $TestRsyncProgrammesSource"/"TestRsyncProgrammesSource ] &&  [ -f $TestRsyncProgrammesDestination"/"TestRsyncProgrammesDestination ] ; then
echo "programmes: test source et destination ok"
/usr/syno/bin/rsync -rltgoDv --del --ignore-errors --progress --stats --force --exclude "TestRsyncProgrammesSource" --exclude "TestRsyncProgrammesDestination" $TestRsyncProgrammesSource"/" $TestRsyncProgrammesDestination"/" >/root/rapport-rsync.txt
        if [ $? == 0 ] ; then
        echo "retour rsync $?"
        /opt/bin/nail -s "OK Backup programmes de $TestRsyncProgrammesSource vers $TestRsyncProgrammesDestination" mymail@free.fr < /root/rapport-rsync.txt
        else
        /opt/bin/nail -s "NOK Backup programmes de $TestRsyncProgrammesSource vers $TestRsyncProgrammesDestination" mymail@free.fr < /root/rapport-rsync.txt
        fi
else
echo " "
fi
if [ -f $TestRsyncProgrammesSource"/"TestRsyncProgrammesSource ] ; then
echo " "
else
echo "TestRsyncProgrammesSource nok"
/opt/bin/nail -s "ERREUR! sur TestRsyncProgrammesSource" mymail@free.fr < /root/erreur-USB
fi
if [ -f $TestRsyncProgrammesDestination"/"TestRsyncProgrammesDestination ]; then
echo " "
else
echo "TestRsyncProgrammesDestination nok"
/opt/bin/nail -s "ERREUR! sur $TestRsyncProgrammesDestination" mymail@free.fr < /root/erreur-USB
fi
#
# backup des vidéos
#
rm -f /root/rapport-rsync.txt
if [ -f $TestRsyncVideoSource"/"TestRsyncVideoSource ] &&  [ -f $TestRsyncVideoDestination"/"TestRsyncVideoDestination ] ; then
echo "videos: test source et destination ok"
/usr/syno/bin/rsync -rltgoDv --del --ignore-errors --progress --stats --force --exclude "05-Séries" --exclude "TestRsyncVideoSource" --exclude "TestRsyncVideoDestination" $TestRsyncVideoSource"/" $TestRsyncVideoDestination"/" >/root/rapport-rsync.txt
        if [ $? == 0 ] ; then
        echo "retour rsync $?"
        /opt/bin/nail -s "OK Backup videos de $TestRsyncVideoSource vers $TestRsyncVideoDestination" mymail@free.fr < /root/rapport-rsync.txt
        else
        /opt/bin/nail -s "NOK Backup videos de $TestRsyncVideoSource vers $TestRsyncVideoDestination" mymail@free.fr < /root/rapport-rsync.txt
        fi
else
echo " "
fi
if [ -f $TestRsyncVideoSource"/"TestRsyncVideoSource ] ; then
echo " "
else
echo "TestRsyncVideoSource nok"
/opt/bin/nail -s "ERREUR! sur TestRsyncVideoSource" mymail@free.fr < /root/erreur-USB
fi
if [ -f $TestRsyncVideoDestination"/"TestRsyncVideoDestination ]; then
echo " "
else
echo "TestRsyncVideoDestination nok"
/opt/bin/nail -s "ERREUR! sur $TestRsyncVideoDestination" mymail@free.fr < /root/erreur-USB
fi
#
# backup des vidéos2
#
rm -f /root/rapport-rsync.txt
if [ -f $TestRsyncVideo2Source"/"TestRsyncVideo2Source ] &&  [ -f $TestRsyncVideo2Destination"/"TestRsyncVideo2Destination ] ; then
echo "videos2: test source et destination ok"
/usr/syno/bin/rsync -rltgoDv --del --ignore-errors --progress --stats --force --exclude "TestRsyncVideo2Source" --exclude "TestRsyncVideo2Destination" $TestRsyncVideo2Source"/" $TestRsyncVideo2Destination"/" >/root/rapport-rsync.txt
        if [ $? == 0 ] ; then
        echo "retour rsync $?"
        /opt/bin/nail -s "OK Backup videos2 de $TestRsyncVideo2Source vers $TestRsyncVideo2Destination" mymail@free.fr < /root/rapport-rsync.txt
        else
        /opt/bin/nail -s "NOK Backup videos2 de $TestRsyncVideo2Source vers $TestRsyncVideo2Destination" mymail@free.fr < /root/rapport-rsync.txt
        fi
else
echo " "
fi
if [ -f $TestRsyncVideo2Source"/"TestRsyncVideo2Source ] ; then
echo " "
else
echo "TestRsyncVideo2Source nok"
/opt/bin/nail -s "ERREUR! sur TestRsyncVideo2Source" mymail@free.fr < /root/erreur-USB
fi
if [ -f $TestRsyncVideo2Destination"/"TestRsyncVideo2Destination ]; then
echo " "
else
echo "TestRsyncVideo2Destination nok"
/opt/bin/nail -s "ERREUR! sur $TestRsyncVideo2Destination" mymail@free.fr < /root/erreur-USB
fi

#15 -1 »  fstab et hub usb » Le 15/09/2010, à 21:52

chiron
Réponses : 2

Bonjour, smile

J'ai un petit souci:

Je fais tourner une ubuntu server 10.04 sur un laptop inutilisé par ailleurs et j'ai 3 disques usb, branchés sur les ports usb du portable, dont 2 disques dans un boitier double. ( http://www.ldlc.com/fiche/PB00095089.html ) Tous les boitiers ont une alimentation spécifique.
mon fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=0cf570c4-6a66-440a-97d4-95b9038b90fb /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=988e987d-d9d0-4d71-8428-ba0065ffafe8 none            swap    sw              0       0
UUID="23093d77-b24a-4c8f-acea-e65252003ed3" /home/jyl/USB/USB1 ext3 defaults 0 0
UUID="6052c542-1bc2-4a44-9854-34f92801c00d" /home/jyl/USB/USB2 ext3 defaults 0 0
UUID="0cf1955c-f9c4-4575-85fa-8b3bd4a8092a" /home/jyl/BACKUP-DISK ext3 defaults 0 0
root@PHOLOS:~# mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sdb1 on /home/jyl/USB/USB1 type ext3 (rw)
/dev/sdc1 on /home/jyl/USB/USB2 type ext3 (rw)
/dev/sdd1 on /home/jyl/BACKUP-DISK type ext3 (rw)
root@PHOLOS:~#

A intervalles plus ou moins réguliers les disques se "démontent", je n'ai plus accès aux données. Je soupçonne le boitier double de tirer aussi sur l'alim usb du portable et je voudrais le mettre sur un hub usb avec une alim externe.
J'ai démonté les disques par umount , branché mon hub, mes disques dessus , puis fait un mount -a . Tout fonctionne.

Le problème est que lors d'un reboot les disques ne se montent pas, et bloquent le boot. On dirait que fstab se lance avant la reconnaissance du hub.

Une idée pour résoudre / contourner le problème ?

#16 Re : -1 »  fstab et hub usb » Le 16/11/2010, à 09:20

chiron
Réponses : 2

Finalement, j'ai fait un essai: installer une version desktop à la place de la version serveur. Ca fait maintenant un mois que ça tourne comme une horloge. Une version desktop plus stable que la version serveur? Un comble! roll smile

#17 Re : -1 »  Retrouver adresse MAC dans mes logs » Le 05/11/2010, à 00:12

chiron
Réponses : 3

Si tu es en dhcp avec réservation de bail sur ton réseau local, il suffit de regarder la config de ton serveur dhcp. Sinon essaie de voir les logs de ton serveur nas pour voir ce que tu peux en tirer...
les préfixes d'apple, et il y en a plusieurs, courage...

#18 -1 »  Mediatomb perd la mémoire au reboot » Le 11/10/2010, à 20:42

chiron
Réponses : 1

Bonsoir, smile

Mon serveur mediatomb fonctionne très bien, je peux ajouter des fichiers par http://myserver:49152 , avec scan récursif et avec intervalle de temps donné. Le seul problème est que si je reboote, je perds tout, et je dois tout refaire. Comment indiquer à mediatomb de se rappeler de mes paramétrages?

#19 Re : -1 »  Mediatomb perd la mémoire au reboot » Le 15/10/2010, à 22:10

chiron
Réponses : 1

Bon, j'ai réussi plus ou moins pour l'instant. J'ai rajouté un autoscan des répertoires où sont les films dans le fichier de configuration, avec une valeur de 2mn entre chaque scan. Je n'ai pas réussi à lui faire faire un scan initial, puis un scan toutes les heures. Peut-être une sauvegarde programmée de la base de données, qu'il pourrait relire au reboot? A suivre, car je n'aime pas faire trop travailler les disques...

#20 Re : -1 »  Backuppc, sauvegarde impossible de localhost » Le 28/07/2010, à 09:17

chiron
Réponses : 10

Bon j'ai réussi à contourner un peu le problème:

http://forum.ubuntu-fr.org/viewtopic.php?id=389773

Bonjour,

Finalement en poursuivant les recherches sur le Net, j'ai trouvé la solution suivante, qui a résolu ce problème.

Il s'agissait d'ajouter --ignore-failed-read, à la fin de la ligne de $Conf{TarClientCmd} dans Serveur et dans LocalHost.
source : https://bugs.launchpad.net/ubuntu/+sour … bug/497732

Espérant que cela pourra servir à d'autres.

Par contre pour rsync le mystère reste entier. Help! smile

#21 Re : -1 »  Backuppc, sauvegarde impossible de localhost » Le 28/07/2010, à 09:52

chiron
Réponses : 10

En fait, tar ne fonctionne pas non plus, seul le répertoire /etc est sauvegardé. Pour le reste, le log est plein de "permission denied"

#22 Re : -1 »  Backuppc, sauvegarde impossible de localhost » Le 28/07/2010, à 11:07

chiron
Réponses : 10

Rsync ou tar sont utilisés par backuppc sur un serveur, et c'est ce même serveur que je veux sauvegarder, (localhost).

#23 Re : -1 »  Backuppc, sauvegarde impossible de localhost » Le 28/07/2010, à 18:40

chiron
Réponses : 10

Bon ça donne:

2010-07-28 18:39:02 User backuppc requested backup of localhost (localhost)
2010-07-28 18:39:02 Started full backup on localhost (pid=2421, share=/)
2010-07-28 18:39:08 Backup failed on localhost (Unable to read 4 bytes)

#24 Re : -1 »  Backuppc, sauvegarde impossible de localhost » Le 02/08/2010, à 09:55

chiron
Réponses : 10

Bon bref, après quelques dizaines de RTFM indigestes, un premier jet, depuis mon serveur VM de test. Je ferai un topo plus détaillé quand tous les problèmes seront réglés.

1: Pour sauvegarder la racine de localhost il faut rajouter dans visudo

backuppc ALL = NOPASSWD: /bin/tar
backuppc ALL = NOPASSWD: /usr/bin/rsync

2: SSH doit être correctement configuré (échange de clefs entre utilisateur root et backuppc), sinon rsync ne pourra ni sauvegarder ni restaurer, et tar ne pourra pas restaurer.

3: A noter, la fonction téléchargement de fichiers dans la sauvegarde au format ZIP, est bugué, par contre le télechargement au format tar fonctionne

4: les valeurs écrites dans le champ BackupFilesExclude doivent être entre guillemets, par exemple: "home/jyl/sdb1"