Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

nombre réponses : 25

#0 -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 02/09/2018, à 01:37

claudiux
Réponses : 21

Bonjour,

C'est le casse-tête de la rentrée pour les profs qui doivent utiliser le Client Pronote sous Linux.

Voici comment installer le Client Pronote 2018 avec la dernière version de Wine. Tout fonctionne parfaitement.

Pronote 2018 avec Wine

Cette méthode fonctionne aussi pour Pronote 2019 ! Si vous l'avez déjà utilisée pour installer Pronote 2018, c'est encore plus simple !

#1 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 07/09/2018, à 21:01

claudiux
Réponses : 21

Merci à vous @pedrogaza et @taupe-pictave. J'avais déjà installé bison et cabextract avant de faire ces manips et donc n'en ai pas vu la nécessité. Je prends en compte vos remarques immédiatement.

#2 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 08/09/2018, à 01:48

claudiux
Réponses : 21
taupe-pictave a écrit :

Tout semble fonctionner, malgré un message d'erreur à l'ouverture de Pronote :

Le composant ICU (International Components for Unicode) est nécessaire pour ce système.
Voulez-vous le télécharger maintenant ?

Je réponds non à chaque fois et je n'ai pas de soucis jusqu'à présent.

On peut répondre Oui sans problème. Ce message disparaîtra.

taupe-pictave a écrit :

Un grand merci pour ce tutoriel.

Merci de l'avoir utilisé et apprécié. Je l'ai corrigé en tenant compte de vos remarques.

J'en avais assez de toujours compiler la version 1.8.4 de Wine, préconisée dans la FAQ de Pronote, mais que Winetricks ne supporte plus. J'ai voulu tester avec la dernière version de Wine et cela a fonctionné.

J'ai rajouté la démarche pour que l'ouverture des fichiers MS Office et LibreOffice, joints dans les messages sur Pronote, se fasse avec le LibreOffice de Linux.

#3 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 17/09/2018, à 21:19

claudiux
Réponses : 21
jlc a écrit :
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

Comment puis je sortir de ce guépier ?

Bonjour,

Avez-vous bien effectué ceci ?

sudo dpkg --add-architecture i386
apt update
apt install libx11-dev:i386 libfreetype6-dev:i386 libxml2-dev:i386 libxslt1-dev:i386 libgnutls28-dev:i386 libjpeg-dev:i386 libldap2-dev:i386

En espérant que cela résoudra votre problème.

Claudiux

#4 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 01/10/2018, à 18:04

claudiux
Réponses : 21

Un petit plus bien agréable : un raccourci direct vers votre établissement, ou chacun de vos établissements, dans votre menu Wine. Avec l'icône idoine.

https://linux.claudeclerc.fr/linuxaddic … blissement

#5 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 02/11/2018, à 20:08

claudiux
Réponses : 21

Si vous ne parvenez pas à ouvrir les liens http et https contenus dans les messages (cela est arrivé chez certains utilisateurs) :

https://linux.claudeclerc.fr/linuxaddic … sous_linux

#6 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 02/11/2018, à 20:10

claudiux
Réponses : 21
lm1998 a écrit :

Merci

J'ai suivi votre procédure et pour une fois installer pronote est facile.

Merci à vous. Les encouragements sont toujours bienvenus.

#7 Re : -1 »  [Résolu] Installation du Client Pronote 2018 avec Wine » Le 01/09/2019, à 15:03

claudiux
Réponses : 21

Cette méthode fonctionne aussi pour Pronote 2019 ! Si vous l'avez déjà utilisée pour installer Pronote 2018, c'est encore plus simple ! https://linux.claudeclerc.fr/linuxaddict:logiciels:pronote2018wine

#8 Re : -1 »  Commandes pour purger les kernels » Le 14/01/2018, à 23:15

claudiux
Réponses : 53

Je regrette profondément ce "nettoyage" arbitraire de la page kernel. Cette astuce m'est encore utile sur certains ordinateurs et c'est sur cette page que je viens la chercher.

#9 Re : -1 »  Commandes pour purger les kernels » Le 20/06/2018, à 03:25

claudiux
Réponses : 53
malbo a écrit :

YannUbuntu ferait bien mieux de s'occuper d'autre chose que de sabrer dans la doc.

+1

#10 Re : -1 »  Supprimer les old-dkms inutiles » Le 14/01/2018, à 23:06

claudiux
Réponses : 5

Je suis "l'ancien contributeur" et suis très déçu (le mot est faible) de voir ma contribution déplacée dans un fil de discussion du forum, alors que je viens de m'y référer pour libérer de la place sur le disque dur d'un ami.

Merci de l'y remettre. Dans le cas contraire, je m'abstiendrai à l'avenir de contribuer aux docs d'Ubuntu-fr.

#11 Re : -1 »  Supprimer les old-dkms inutiles » Le 20/06/2018, à 04:06

claudiux
Réponses : 5

Bonjour.

YannUbuntu a écrit :

Bonjour
Tout d'abord merci pour votre contribution.

De rien. C'est aussi pour me remercier que vous avez supprimé mon pseudo de la liste des contributeurs ?

YannUbuntu a écrit :

Par contre, supprimer des fichiers système est un sujet trop sensible pour l'intégrer à la doc sans approbation collective.

Et supprimer des contributions sans approbation collective, on peut ? Je pourrais, par exemple, supprimer toutes les miennes ?

YannUbuntu a écrit :

De plus, on évite de mettre des scripts dans la doc pour des raisons de maintenabilité (par ex, n'importe-qui peut y glisser à tout moment des commandes malicieuses). Le forum est plus approprié pour partager un script.

Elle va devenir super intéressante, la doc Ubuntu-fr ! L'utilisateur va être obligé de naviguer entre la doc et les forums. On en rêve !

YannUbuntu a écrit :

2 questions:
- à quoi servent les fichiers *.old-dkms ?
- dans quelles conditions apparaissent-ils?  (je n'en ai ni sur Xenial ni sur Artful)

Quand on ne sait pas, on ne supprime pas en croyant que parce qu'on n'est pas soi-même concerné, personne ne peut l'être. Quant aux réponses, elle sont données dans ce forum. Je vous laisse chercher.

#12 Re : -1 »  Internet via un VPN et imprimantes locales en wifi » Le 15/11/2017, à 03:23

claudiux
Réponses : 9

Bonjour,

Je déterre ce sujet parce que j'ai longtemps été confronté au même problème.

Si, si, il y a une piste... Mon imprimante réseau multi-fonction HP8610 n'était pas joignable une fois que j'étais connecté à un VPN. Maintenant elle l'est : scanner et imprimantes fonctionnent, que je sois connecté ou non au VPN.
Voici la solution.

En espérant que cela aidera.

#13 Re : -1 »  Internet via un VPN et imprimantes locales en wifi » Le 20/06/2018, à 03:16

claudiux
Réponses : 9

Pourtant cela fonctionne chez moi sans erreur, mais je n'ai pas la même version de hp-setup.

$ sudo hp-setup
[sudo] Mot de passe de claudiux : 

HP Linux Imaging and Printing System (ver. 3.16.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


Done.

#14 Re : -1 »  Installation du client Pronote 2016 sur Ubuntu 16.04 64Bits » Le 01/09/2017, à 21:52

claudiux
Réponses : 71
Tehcage a écrit :

Bonjour Labono
Ton message me rassure, je ne dois pas être loin de la solution... Mais le message : erreur lors du chargement de la base s'affiche (message : problème de lecture de base).
Une idée afin de pouvoir débloquer la situation ?
Merci pour votre aide

Bonjour, j'ai exactement le même problème, alors que le chargement de la base se fait sans problème sous Zindoze ; cela ne provient donc pas du serveur, mais bien de l'installation.

Quelqu'un a-t-il essayé avec une version plus récente de wine que la 1.8.4 ?

#15 Re : -1 »  [abandonné] Vpnautoconnect 2.X(Nouvelle version) » Le 28/01/2013, à 20:10

claudiux
Réponses : 127

Bonjour,

J'avais le même problème : depuis mon passage à la 12.04, vpnautoconnect (2.2.0) ne remplissait plus son office.

J'ai réussi à le faire fonctionner de nouveau. Voici comment.

Quitter vpnautoconnect (clic-droit sur l'icone, Quitter).

Supprimer toute référence à vpnautoconnect dans Applications au démarrage.

Désinstallation complète :

sudo apt-get remove --purge vpnautoconnect

Suppression de tout fichier de conf :

rm -rf ~/.vpnautoconnect

Suppression des paquets inutiles, nettoyage et mise à jour de la base apt :

sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get clean && sudo apt-get update

Vérification des configurations des connections VPN : par précaution, une seule doit avoir la case "Connecter automatiquement" cochée.

Redémarrage de l'ordi (je sais, je sais...)

Une fois connecté à votre session :

sudo apt-get install vpnautoconnect

Alt-F2 puis vpnautoconnect.

Configurer vpnautoconnect (clic droit sur l'icone, Préférences). Ne rien toucher dans l'onglet Général. Dans l'onglet Options appArmor, ajouter les éventuelles applications à désactiver en cas de déconnexion (ex : /usr/bin/amule et/ou usr/bin/qbittorrent). Dans Ajouter une connexion VPN, choisissez la connexion parente (en général : Connexion filaire 1) et votre connexion VPN favorite, cochez les cases de la colonne Autorisé. Sauver.

Ajouter /usr/bin/vpnautoconnect dans les Applications au démarrage.

Se connecter au VPN.

Redémarrer l'ordi. Une fois la session ouverte, vpnautoconnect remplit son office : la connexion au VPN favori se fait automatiquement. J'ai pu vérifier que la reconnexion automatique, suite à une déconnexion non désirée, se faisait correctement.

En espérant que ceci sera utile à certain-e-s.

Cordialement,

Claudiux

#16 Re : -1 »  [abandonné] Vpnautoconnect 2.X(Nouvelle version) » Le 24/01/2018, à 15:10

claudiux
Réponses : 127

Bonjour,

À toutes celles et tous ceux qui regrettent l'abandon de VpnAutoConnect, je signale ici que si votre interface est Cinnamon (présente notamment dans Linux Mint) vous pouvez utiliser l'applet VPN Look-Out que j'ai écrite et dont vous pourrez trouver la description ici : https://cinnamon-spices.linuxmint.com/applets/view/305.

Le mieux, pour l'installer, est d'utiliser le gestionnaire d'applets de Cinnamon (clic-droit sur un tableau de bord -> Ajouter une applet...).

Bonne utilisation !

Claudiux

#17 Re : -1 »  Qarte arte.tv browser (ex Qarte+7) » Le 18/10/2012, à 15:48

claudiux
Réponses : 1 342

Merci et bravo pour cet excellent Qarte !

#18 Re : -1 »  Virtualbox et USB3 » Le 12/09/2016, à 18:33

claudiux
Réponses : 8

Merci Alain47, cela m'a été très utile !

Et, non, je ne suis pas le roi de Prusse smile

Claudiux

#19 Re : -1 »  [Script Bash]Liste Paquets installés manuellement après l'installation » Le 06/09/2012, à 20:47

claudiux
Réponses : 52

Voici un script python qui utilise pour une large part celui de quent57, et l'une des commandes bash que j'ai données au #35.

Il est prévu pour fonctionner sur Maverick. Je vais faire des tests pour voir si cela fonctionne sur une réinstall de Maverick ; il reste à sauver les clés PGP des dépôts PPA, la liste de ceux-ci en adaptant le nom de la distrib (remplacer maverick par precise, si le dépôt contient bien des paquets pour precise), puis créer les scripts pour ré-installer les dépôts, clés et paquets existants sur une Precise.

#!/usr/bin/python
# -*- coding: utf-8 -*-

import subprocess
import os, os.path
import re


### Liste des paquets installés automatiquement (i.e non installés manuellement) ###
# Sous Maverick (Ubuntu 10.10) apt-mark ne connait pas l'option showmanual.
proc = subprocess.Popen(["apt-mark","showauto"], stdout=subprocess.PIPE)
autoInstalls,err = proc.communicate() 

autoInstallsList = []
for autoInstall in str.split(autoInstalls,'\n'):
  autoInstallsList.append(autoInstall)

## debug:
#print "autoInstallsList: %i" %len(autoInstallsList)

### Liste de tous les paquets installés ###
# S'il n'existe pas, on crée un script bash qui nous donne cette liste.
# (Pas élégant, mais ça fonctionne et c'est rapide !)
if not os.path.exists(os.path.abspath('')+'/allpackages.sh'):
  allpackagescript=open(os.path.abspath('')+'/allpackages.sh', 'w')
  allpackagescript.write("dpkg --get-selections | grep -v deinstall | awk '{print $1}'")
  allpackagescript.close()
# On utilise ce script :
proc=subprocess.Popen(["/bin/sh",os.path.abspath('')+"/allpackages.sh"], stdout=subprocess.PIPE)
allInstalls,err = proc.communicate()

allInstallsList = []

# Filtre pour les paquets dont le nom commence par 'linux-' et contient
# au moins un chiffre, comme linux-image-3.2.0-23-generic
# ou linux-headers-3.2.0-23-generic. Ces paquets sont inutiles dans la liste,
# car leurs dernières versions sont installées par des meta-paquets tels linux-generic,
# linux-headers-generic, etc.
linuxchiffres=re.compile(r'linux-.*\d+')

for allInstall in str.split(allInstalls,'\n'):
  if not linuxchiffres.match(allInstall): # on écarte les paquets filtrés.
    allInstallsList.append(allInstall)

## debug:
#print "allInstallsList: %i" %len(allInstallsList)

### Liste de tous les paquets installés manuellement ###
# C'est la différence entre la liste des paquets installés et celle des paquets auto.
manualInstallList = filter(lambda x:x not in autoInstallsList,allInstallsList)

# Suppression des paquets réinstallés automatiquement

dependsList=[]

depends=re.compile("Depends: ([^\n/]*)")
section=re.compile("Section: ([^\n/]*)") 

for pkg in manualInstallList:
  proc=subprocess.Popen(["apt-cache","show",pkg], stdout=subprocess.PIPE)
  res,err = proc.communicate()
  """
  #1ere idée : Suppression des paquets dont dependent les meta-paquets (tels ubuntu-minimal et ubuntu-desktop) :
  sct=section.search(res)
  if sct.group(1).startswith("metapackages"):
    #print "META : %s" %pkg
    deps=depends.search(res)
    deps=deps.group(1).replace("," , "")
    pkgsList=str.split(deps, " ")
    dependsList=dependsList + filter(lambda x:x not in dependsList,pkgsList)
  """
  # 2nde idée : Finalement, supprimer tous les paquets qui seront réinstallés automatiquement du fait des dépendances :
  deps=depends.search(res)
  if deps is not None:
    deps=deps.group(1).replace("," , "")
    pkgsList=str.split(deps, " ")
    dependsList=dependsList + filter(lambda x:x not in dependsList,pkgsList)

# On supprime ces paquets de la liste des paquets installés manuellement :
manualInstallList=filter(lambda x:x not in dependsList,manualInstallList)

# debug:
#print "manualInstallList: %i" %len(manualInstallList)

for install in manualInstallList:
  print install

EDIT (08/09/2012) : J'ai adapté le script ci-dessus pour qu'il fonctionne aussi sur les versions suivant la 10.10 d'Ubuntu (testé sur 12.04.1).

#20 Re : -1 »  [RESOLU] Driver TI-83 Premium CE » Le 27/04/2015, à 20:45

claudiux
Réponses : 11

Bonjour,

J'ai longtemps cherché pourquoi la commande lsusb ne faisait pas apparaître ma TI-83 Premium CE.

C'était tout simplement parce que le câble micro-usb n'était pas suffisamment enfoncé dans la calculatrice !

hmm

Si je peux avec Tilp sauvegarder des programmes ou faire des copies d'écran, je ne peux par contre pas enregistrer la ROM ! (Dans le but d'un usage privé, bien sûr.)

#21 -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 05/11/2015, à 22:40

claudiux
Réponses : 4

Bonjour à toutes et tous,

Sur la page concernant l'ASUS R511LJ j'ai décrit comment je suis parvenu à pallier la non-détection de certaines touches spéciales.

Mais la méthode ne me convient pas, parce qu'il faut faire appel à la gestion des raccourcis-clavier pour remplacer la touche Fn par la touche Super. La méthode fonctionne mais manque d'élégance et perturbe les utilisateurs qui ont un dual-boot (pas les mêmes raccourcis sous Ubuntu et sous Windoz).

J'ai fait de multiples recherches, sans trouver de solution. Il semble que le noyau 3.19 ne détecte pas certaines combinaisons de touches, car Fn+F5 et Fn+F6 (baisse et augmentation de la luminosté) fonctionnent avant le chargement du noyau, mais plus pendant ni après.

Pourriez-vous m'aider ?

Grand merci à vous !

#22 Re : -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 06/11/2015, à 05:23

claudiux
Réponses : 4

Merci rtst-2 pour ta prompte réponse. J'ai tenté de modifier dans ''/etc/default/grub'' la ligne

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='Linux' i8042.nomux"

et bien sûr mis à jour Grub par un

sudo update-grub

comme tu recommandais, mais cela n'a eu aucun résultat.

La commande ''dmesg | grep i8042'' me retourne :

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=570da9b9-28de-4520-b32c-eb7eafd87460 ro quiet splash acpi_osi=Linux i8042.nomux vt.handoff=7
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=570da9b9-28de-4520-b32c-eb7eafd87460 ro quiet splash acpi_osi=Linux i8042.nomux vt.handoff=7
[    0.591862] i8042: PNP: PS/2 Controller [PNP030b:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
[    0.594296] serio: i8042 KBD port at 0x60,0x64 irq 1
[    0.594299] serio: i8042 AUX port at 0x60,0x64 irq 12
[    0.633732] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[   16.270596] input: PS/2 FocalTech FocalTech Touchpad as /devices/platform/i8042/serio1/input/input6

J'ai donc bien ce type de clavier.

#23 Re : -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 06/11/2015, à 20:16

claudiux
Réponses : 4

Hélas, cela ne fonctionne pas non plus.

J'ai successivement testé :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux video.use_native_backlight=1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='Linux' i8042.nomux"
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"

sans succès.

Mon noyau est le 3.19.0-32-generic.

Je continue à chercher. Merci pour ton aide ! N'hésite pas à me proposer d'autres options.

#24 Re : -1 »  [Résolu] Caribou dans application au démarrage » Le 27/02/2014, à 20:47

claudiux
Réponses : 4

Attention à ne pas supprimer Caribou si vous utilisez Cinnamon.