Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Valve : Steam sous Linux (2) » Le 15/02/2016, à 09:52

billou
Réponses : 2 348

J'ai récupéré Xcom2 via le partage de jeux Steam entre amis, quelqu'un sait comment le passer de qwerty à Azerty simplement ? (Pour l'ami en question)
Le jeu n'est compatible qu'avec le gamepad hybride de Valve ou le clavier et la souris... (le support des autres pads est incomplet !)

Sur Windows on peut faire ALT-G+MAJ pour switcher, et normalement sous Linux (Gnome Shell en tout cas) MAJ+SUPER+ESPACE, mais ça ne change rien, et devoir se coltiner tous les changements de touches manuellement, misère... Comment peut on prévoir une localisation Française dans tout le jeu, sauf pour le clavier ?..

#1 Re : -1 »  helly est mort ! :o » Le 12/05/2016, à 16:04

billou
Réponses : 1 835

J'ai été lui rendre hommage avant-hier ayant été de passage à Fondettes (et mon arrière grand mère étant dans son voisinage proche), sa sépulture est simple, sans message, mais pleine de fleurs, il ne souhaitait pas avoir de plaque j'imagine ?

En y repensant, j'avais un peu les boules, sachant qu'il était proche en plus, j'aurais aimé le connaître IRL... Mais bon, ceux qui étaient là aussi lors de ses funérailles ont du s'apercevoir que ma santé à l'époque n'était pas au top non plus...

#2 Re : -1 »  Achat d'une liseuse e-books ? » Le 12/07/2016, à 13:47

billou
Réponses : 34

Je plussoie, ma copine a une Pocket Book Touch Lux 3 depuis deux semaines, c'est une bonne petite bestiole tournant sous Linux et acceptant foultitude de formats, on regrette juste l'absence du support du format OpenDocument, et des CBZ. smile

#3 Re : -1 »  Firefox, vraiment aussi stable sous Android que les autres OS ? » Le 11/07/2016, à 21:43

billou
Réponses : 15

Hum... À matériel égal je peux justement comparer, j'ai une tablette sous Atom x64 Z83000 avec Android/Windows/Linux en triple boot.

Sur Windows 10 : des lags énormes sur Firefox

Sous Linux (Noyau 4.6 + paquets les plus récents) : un peu moins de lags, mais ça reste encore le jour et la nuit comparé à Chromium...

Sous Android : la fluidité et le chargement des pages explose tous les navigateurs desktop, y compris en simulant un user agent de version desktop.

Les 3 systèmes bénéficient de l'accélération graphique, navigateurs y compris, et j'ai testé toutes extensions désactivées...

Ma conclusion : Firefox est très bon sous Android, et a globalement une excellente gestion côté mémoire... Mais sur les versions desktop, c'est un gouffre à CPU comparé à d'autres navigateurs !

#4 Re : -1 »  Firefox, vraiment aussi stable sous Android que les autres OS ? » Le 12/07/2016, à 12:18

billou
Réponses : 15
JLK a écrit :
billou a écrit :

Hum... À matériel égal je peux justement comparer, j'ai une tablette sous Atom x64 Z83000 avec Android/Windows/Linux en triple boot.

Sur Windows 10 : des lags énormes sur Firefox

Sous Linux (Noyau 4.6 + paquets les plus récents) : un peu moins de lags, mais ça reste encore le jour et la nuit comparé à Chromium...

Sous Android : la fluidité et le chargement des pages explose tous les navigateurs desktop, y compris en simulant un user agent de version desktop.

Les 3 systèmes bénéficient de l'accélération graphique, navigateurs y compris, et j'ai testé toutes extensions désactivées...

Ma conclusion : Firefox est très bon sous Android, et a globalement une excellente gestion côté mémoire... Mais sur les versions desktop, c'est un gouffre à CPU comparé à d'autres navigateurs !

Sous Android, tu parles d'une tablette ou plutôt d'un smartphone ?
Sur mon smartphone, c'est la galère avec tous les crashes (je pense qu'il n'y a peut-être plus assez de mémoire vive quand Firefox est lancé, surtout à la lecture des vidéos).

Sur Tablette, je l'avais dit dès le début. Et j'ai déjà eu sur smartphone, Sur un vieux Wiko il y avait des crashs, puis je suis passé sur un smartphone Asus x64 avec 4Gb de ram, aucuns soucis, et après sa disparition, je suis pour le moment sur un Galaxy S2 mis à jour sous Cyanogenmod 13, avec 1Gb de ram c'est pas la panacée mais ça tourne, aucun crash à l'horizon. smile

Tu as quoi comme smartphone ?

#5 Re : -1 »  Firefox, vraiment aussi stable sous Android que les autres OS ? » Le 24/07/2016, à 10:03

billou
Réponses : 15
JLK a écrit :
billou a écrit :
JLK a écrit :

Sous Android, tu parles d'une tablette ou plutôt d'un smartphone ?
Sur mon smartphone, c'est la galère avec tous les crashes (je pense qu'il n'y a peut-être plus assez de mémoire vive quand Firefox est lancé, surtout à la lecture des vidéos).

Sur Tablette, je l'avais dit dès le début. Et j'ai déjà eu sur smartphone, Sur un vieux Wiko il y avait des crashs, puis je suis passé sur un smartphone Asus x64 avec 4Gb de ram, aucuns soucis, et après sa disparition, je suis pour le moment sur un Galaxy S2 mis à jour sous Cyanogenmod 13, avec 1Gb de ram c'est pas la panacée mais ça tourne, aucun crash à l'horizon. smile

Tu as quoi comme smartphone ?

Galaxy S3 (1Go de RAM) sous Android 4.3 avec l'interface lourde de TouchWiz de Samsung par défaut.

Tente une upgrade sur CyanogenMod 13 basée sur Android 6.X, ça devrait lui faire énormément de bien, de mon côté c'était le jour et la nuit par rapport à la version d'origine avec Touchwizz.
J'y ai associé l'écran d’accueil "Smart Launcher", très léger, ça tourne vraiment au poil.

#6 Re : -1 »  Ubuntu va abandonner le 32 bits, qu'en pensez vous ? » Le 10/07/2016, à 16:01

billou
Réponses : 24
Oni_Shadow a écrit :
Bougron a écrit :

Si on achète un 32 bits en 2027, et si ubuntu n'a pas été absorbé par windows, on devrait toujours pouvoir installer la version  ubuntu 16.04 qui sera disponible dans cet espace http://old-releases.ubuntu.com/releases/    ou une plus ancienne si cette version est "trop récente" pour les écrans graphiques.

Heureusement que je dispose de windows XP qui est opérationnel. Je ne risque pas d'avoir des mises à jour qui empêchent l'ordinateur de mettre en route!!!!!!!!!!!!!!!!!

CA existe encore le 32 but sur le neuf? Depuis 2005 je n'ai eu que du 64 personnellement

Ça existe oui, sur des tablettes équipé d'un processeur x64 avec 2/4Go de ram, il arrive encore qu'on tombe sur un UEFI limité au 32bits... Et de facto, Windows 10 x86 installé...

Par contre celles proposant Android en dual Boot sont généralement full x64, sauf qu'Android est compilé 32bits, avec un noyau 64bits. lol

#7 -1 »  Convergence des noyaux entre Ubuntu et Android ? » Le 12/07/2016, à 13:57

billou
Réponses : 0

Bonjour

J'ai une tablette équipée d'un SOC Intel Atom Z83000 x64, proposant de base un dualBoot Android 5.1 stock, et Windows 10.

Problème, pas mal de choses ne sont pas supportées sur le noyau Linux de base, écran tactile, chipset sonore, chipset wifi, etc... Tout le problème étant que l'UEFI A.M.I de la tablette fait passer presque tous les appels vers le matériel via la table ACPI (DSDT, etc...), et non PCI, si ce n'est quelques éléments de base composant le SOC.

Par contre évidemment, le noyau Linux d'Android tourne parfaitement, et tous les modules sont déjà intégré et compilés en *.ko, l'appareil est entièrement fonctionnel.

La question étant, existe il ne serait ce qu'une méthode pour pouvoir utiliser ces modules sur une distribution Desktop ? Je sais que d'expérience je n'ai jamais réussi à charger un module compilé pour une version de noyau X sur une version de noyau Y, mais je demande au cas où...

Évidemment, j'ai bien demandé les sources dudit noyau Linux et des drivers modifiés (au moins ceux étant libres de base, soit la quasi totalité, seul l'écran tactile fait exception) à l'entreprise manufacturant la tablette, qui a refusé. J'ai tenté de contacter Intel vu que c'est leur build et leur code qui sont exploités, l'entreprise semblait prendre acte de cette violation de leur propriété intellectuelle, puis plus de réponse, je recontacte de nouveau on me signale qu'on refait monter en interne, sans suites.
Même chose du côté de Google.

Pour ceux qui seraient curieux, j'ai décompilé la table ACPI (DSDT) et uploadé tout ça ici : http://vavar60.online.fr/share/tablet/c … dt.dsl.txt

#8 Re : -1 »  [Résolu] La taxe Canonical sur les VPS Ubuntu ? » Le 26/06/2016, à 15:35

billou
Réponses : 13

Perso j'ai viré le noyau d'OVH de toute façon, pas moyen de compiler des modules spécifiques avec, et j'avais besoin d'utiliser VirtualBox dessus via une session à distance sur mon serveur, donc j'ai réinstallé le noyau proposé par Ubuntu, et upgradé de la 14.04 à 16.04.

#9 Re : -1 »  [tuto] 16.04 - Installation Apache Mysql PHP phpmyadmin (+ vidéo) » Le 12/05/2016, à 16:20

billou
Réponses : 15

Un petit tutoriel pour configurer un/des noms de domaines, activer openSSL, et postfix + courier-imapd-ssl afin d'avoir son propre serveur mail + adresse mail, serait pas mal, je galère un peu, mais dès que j'arrive à résoudre tous mes soucis, si ce n'est pas fait d'ici là je "coucherais tout ça sur papier". smile

#10 -1 »  [Dev licence libre?] Comment automatiquement modifier une URL ? » Le 08/05/2016, à 12:02

billou
Réponses : 4

Salut tout le monde, j'aurais bien besoin d'un conseil, j'ai mis un site avec un wiki Dokuwiki et un forum Fluxbb en place, sur mon serveur, hors je ne compte jamais intégrer de publicités dessus (ayant horreur de ça), j'ai testé l'intégration (bien faite) de cashlinks non polluants, manuellement, ce qui semble convenir à tout le monde et fonctionner suffisamment bien, mais c'est long et fastidieux, y aurait il un moyen pour rajouter un identifiant particulier à la fin d'une url d'un nom de domaine particulier, automatiquement sur les liens, via du PHP ou (plus globalement sur tous les domaines/sous domaines) via une configuration type htaccess ? smile

Par exemple, si je postais un lien amazon sur mon wiki, il faudrait qu'il passe de :

https://www.amazon.fr/dp/B00WSJK7BS?ie=UTF8

à

https://www.amazon.fr/dp/B00WSJK7BS?ie=UTF8&tag=ubuntu-21

On voit bien l'ajout de "&tag=ubuntu-21"


Je fréquente un site nommé dealabs qui modifie automatiquement les url pour les rediriger vers une page qui leur est propre, qui redirige ensuite vers le lien modifié, ça pourrait être une bonne solution aussi...

Dans leur cas, l'url :

http://www.amazon.de/dp/B00WIMBNGI?m=A3JWKAKR8XB7XF

passe par

http://www.dealabs.com/url/?e=ccHf4xTB73zBDDOA4p43oF14oKZq5W7P3sIfshp7un4Y7BWC6KvGWVmWfDeCCA2FJnAEOY4BhFY%3D&w=all&l=deal

avant de mener au lien en question qui a été posté, mais leur ID de cashlink aura été rajouté au passage sur l'url de base, quel que soit le site marchand proposant ce genre de parrainage, qu'il soit en fin d'url, juste après le nom de domaine, ou au milieu, c'est exactement ce qui m'intéresserait . smile

Bien évidemment, dans le cas d'un script, ce serait franchement cool si quelqu'un pouvait proposer quelque chose de fonctionnel, sous licence libre ! smile

-----

PS : je peux passer le lien de mon site avec l'intégration en question, mais je ne suis pas là pour faire de publicité, donc ça sera sur demande. smile

#11 Re : -1 »  [Dev licence libre?] Comment automatiquement modifier une URL ? » Le 19/05/2016, à 18:18

billou
Réponses : 4

Simple, si l'id de mon compte est rajouté, il y a une petite rémunération (%) pour chaque chose achetée via ce lien. smile

#12 -1 »  [Résolu] Comment configurer/activer SSL pour des sous domaines » Le 12/05/2016, à 16:16

billou
Réponses : 9

Salut, je suis quelque peu paumé, j'ai trouvé de très bon tutos pour générer des certificats valides avec letsencrypt, comment partager le port 443 utilisé par le service OpenVPN sur le port 4443 pour openSSL, configurer ce dernier pour l'utiliser, et enfin, configurer le virtuahost d'openSSL pour quemon nom de domaine principal pour que la connexion soit chiffrée.

[EDIT] Pour les curieux, voici les options pour activer le port 443 sur le serveur openvpn et partager ce dernier sur le port 4443 pour OpenSSL :
Éditer /etc/openvpn/server.conf

mode server
proto tcp
proto tcp-server
port-share 37.187.2.144 4443
port 443
port-share IP.DU.SER.VEUR 4443
dev tun

Mais à partir de là je bloque, plutôt que de faire une arborescence type :

osremix.com/forum ou osremix.com/wiki

J'ai choisi :

forum.osremix.com ou wiki.osremix.com

Et j'ai beau tenter d'activer SSL pour ces derniers, je n'y arrive pas, j'ai un message "Échec de la connexion sécurisée" qui apparaît au chargement de la page.

Voilà le contenu de mon "/etc/apache2/sites-available/default-ssl.conf", auriez vous des conseils/corrections à me proposer ?

<IfModule mod_ssl.c>
        <VirtualHost _default_:4443>
                ServerAdmin webmaster@localhost

                DocumentRoot /var/www/osremix.com/
                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on

                SSLCertificateFile      /etc/letsencrypt/live/osremix.com/fullchain.pem
                SSLCertificateKeyFile /etc/letsencrypt/live/osremix.com/privkey.pem
                SSLCertificateChainFile /etc/letsencrypt/live/osremix.com/chain.pem

                <FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>
        </VirtualHost>

<VirtualHost *:4443>
DocumentRoot /var/www/osremix.com-wiki/
ServerName wiki.osremix.com
ServerAlias wiki.osremix.com
SSLCertificateFile      /etc/letsencrypt/live/wiki.osremix.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/wiki.osremix.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/wiki.osremix.com/chain.pem
</VirtualHost>

<VirtualHost *:4443>
DocumentRoot /var/www/osremix.com-forum/
ServerName wiki.osremix.com
ServerAlias wiki.osremix.com
SSLCertificateFile      /etc/letsencrypt/live/forum.osremix.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/forum.osremix.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/forum.osremix.com/chain.pem
</VirtualHost>

</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

#13 Re : -1 »  [Résolu] Comment configurer/activer SSL pour des sous domaines » Le 18/05/2016, à 12:31

billou
Réponses : 9
bobe a écrit :

As-tu essayé en ajoutant "SSLEngine on" dans tes virtualhost ?

ps : Utilise cert.pem dans la commande "SSLCertificateFile". fullchain.pem inclut ton certificat + le certificat letsencrypt intermédiaire alors que tu le fournis déjà avec "SSLCertificateChainFile".

J'ai fait les changements que tu m'as indiqué, et autant le domaine osremix.com fonctionne sans soucis avec https, autant pour les sous domaines, j'ai une belle erreur.

La connexion n'est pas sécurisée

Les propriétaires de forum.osremix.com ont mal configuré leur site web. Pour éviter que vos données ne soient dérobées, Firefox ne s'est pas connecté à ce site web.
forum.osremix.com uses an invalid security certificate. The certificate is only valid for osremix.com Error code: SSL_ERROR_BAD_CERT_DOMAIN

Et si j'accepte d'outrepasser le problème avec cette erreur de certificat, sur le sous domaine, j'ai la page d’accueil du domaine principal qui s'affiche...

zététix a écrit :

Bonjour,

es-tu certain qu'apache écoute sur le port 4443 ? Par défaut ce serait plutôt 443. Regarde du côté de la directive Listen et NameVirtualHost.
D'autre part, si tu veux que ton certificat soit bien reconnu par les navigateurs sur les sous domaines, il te faut un certificat type Wildcard sinon tu auras une erreur du type "site malveillant".

Oui j'en suis certain, regarde le fichier de configuration fourni, d'ailleurs le domaine principal fonctionne correctement sans soucis sur ce port en https.

Quand au certificat, je l'ai généré avec letsencrypt, ça fonctionne très bien avec le domaine principal, mais j'ai une erreur avec les sous domaines.

#14 Re : -1 »  [Résolu] Comment configurer/activer SSL pour des sous domaines » Le 18/05/2016, à 14:26

billou
Réponses : 9

Merci pour la piste, c'est bon, ça fonctionne enfin ! smile

J'ai dû lancer cette commande pour générer un certificat commun au domaine principal et sous domaines :

sudo letsencrypt certonly -d osremix.com -d wiki.osremix.com -d forum.osremix.com --rsa-key-size 4096

Et j'ai édité le /etc/apache2/sites-available/default-ssl.conf comme il suit, au propre :

<IfModule mod_ssl.c>

###################
### osremix.com ###
<VirtualHost _default_:4443>

ServerAdmin webmaster@localhost

DocumentRoot /var/www/osremix.com/
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLEngine on
SSLCertificateFile      /etc/letsencrypt/live/osremix.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/osremix.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/osremix.com/chain.pem

<FilesMatch "\.(cgi|shtml|phtml|php)$">
        SSLOptions +StdEnvVars
</FilesMatch>
<Directory /usr/lib/cgi-bin>
        SSLOptions +StdEnvVars
</Directory>

</VirtualHost>

########################
### wiki.osremix.com ###
<VirtualHost *:4443>
SSLEngine on
DocumentRoot /var/www/osremix.com-wiki/
ServerName wiki.osremix.com
ServerAlias wiki.osremix.com
SSLCertificateFile      /etc/letsencrypt/live/osremix.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/osremix.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/osremix.com/chain.pem
</VirtualHost>

#########################
### forum.osremix.com ###
<VirtualHost *:4443>
SSLEngine on
DocumentRoot /var/www/osremix.com-forum/
ServerName forum.osremix.com
ServerAlias forum.osremix.com
SSLCertificateFile      /etc/letsencrypt/live/osremix.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/osremix.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/osremix.com/chain.pem
</VirtualHost>

</IfModule>

Pour forcer SSL/HTTPS sur les sites, j'ai rajouté un .htaccess à la racine de chaque domaine :

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} !on
RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Pour le renouvellement automatique des certificats letsencrypt :

sudo nano /usr/local/sbin/le-renew-webroot

Puis copier et enregistrer comme ci dessous.

#!/bin/bash

web_service='apache2'

FILES=/etc/letsencrypt/renewal/*.conf
for f in $FILES
do
    echo "Renewing for $f file..."
    config_file="$f"


    le_path='/etc/letsencrypt'
    exp_limit=30;

    if [ ! -f $config_file ]; then
            echo "[ERROR] config file does not exist: $config_file"
            exit 1;
    fi

    domain=`grep "^\s*domains" $config_file | sed "s/^\s*domains\s*=\s*//" | sed 's/(\s*)\|,.*$//'`
    cert_file="/etc/letsencrypt/live/$domain/fullchain.pem"

    if [ ! -f $cert_file ]; then
            echo "[ERROR] certificate file not found for domain $domain."
    fi

    exp=$(date -d "`openssl x509 -in $cert_file -text -noout|grep "Not After"|cut -c 25-`" +%s)
    datenow=$(date -d "now" +%s)
    days_exp=$(echo \( $exp - $datenow \) / 86400 |bc)

    echo "Checking expiration date for $domain..."

    if [ "$days_exp" -gt "$exp_limit" ] ; then
            echo "The certificate is up to date, no need for renewal ($days_exp days left)."
            continue;
    else
            echo "The certificate for $domain is about to expire soon. Starting webroot renewal script..."
            $le_path/letsencrypt-auto certonly -a webroot --agree-tos --renew-by-default --config $config_file
            echo "Renewal process finished for domain $domain"
            continue;
    fi
done
echo "Reloading $web_service"
/usr/sbin/service $web_service reload

Enfin un petit coup de crontab pour executer le script à intervalle régulière :

sudo crontab -e

Et on y rajoute la ligne suivante pour l'execution régulière et des logs :

30 2 * * 1 /usr/local/sbin/le-renew-webroot >> /var/log/le-renewal.log


Merci beaucoup pour vos conseils éclairés ! smile

#15 Re : -1 »  [Résolu] Comment configurer/activer SSL pour des sous domaines » Le 19/05/2016, à 15:49

billou
Réponses : 9
bobe a écrit :
billou a écrit :

Pour forcer SSL/HTTPS sur les sites, j'ai rajouté un .htaccess à la racine de chaque domaine :

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} !on
RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Je privilégierais plutôt un virtualhost. Plus simple, évite l'utilisation du mod rewrite et d'un htaccess :

<VirtualHost *:80>
    ServerName mydomain.tld
    Redirect / https://mydomain.tld/
</VirtualHost>

Je vais essayer ça, merci pour l'astuce ! smile

#16 -1 »  Une tablette/convertible laptop sous Ubuntu nativement ? » Le 17/05/2016, à 11:49

billou
Réponses : 0

Salut, je viens de tomber sur ça un projet Indiegogo, pour plusieurs modèles de tablettes tournant nativement sous Linux, qui pourraient être pas mal... Installer Linux sur tablette, même avec un UEFI, y compris 64bits, pose bien trop souvent des problèmes de drivers...

foky43c7upbziuftgx85.png
fcuep8okzbes66wmqq1l.png

https://www.indiegogo.com/projects/worl … 4-tablet#/


Les spécifications sont plutôt alléchantes par rapport au prix !

3-MJTechnology-Katana_dxld4y.png
2-MJTechnology-Wakizashi_hvxsus.png
1-MJTechnology-Tanto_ggsbib.png

#17 Re : -1 »  [Résolu] depuis Ubuntu 16.04 le serveur Apache ne se lance plus. » Le 08/05/2016, à 11:47

billou
Réponses : 9

Étrange, de mon coté l'upgrade d'ubuntu 14.04 vers la 16.04 s'est relativement bien passé, c'est mon serveur mail qui est passé à la trappe, et j'ai du désactiver php7 pour rétrograder vers php5, reconfigurer quelques petites choses avec les protocoles openvpn et pptp, mais à part ça...

#18 -1 »  [Résolu] Internet via serveur OpenVPN sur port 443 sous Ubuntu 16.04 ? » Le 08/05/2016, à 03:53

billou
Réponses : 1

J'ai un souci avec mon serveur OpenVPN, les clients se connectent sans soucis, mais je ne peux charger aucune page, rien ne répond.


Logs :

$ sudo tail -f /var/log/openvpn.log 
Sun May  8 01:38:47 2016 37.161.225.238:22045 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Sun May  8 01:38:47 2016 37.161.225.238:22045 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun May  8 01:38:47 2016 37.161.225.238:22045 Control Channel: TLSv1.2, cipher TLSv1/SSLv3 DHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
Sun May  8 01:38:47 2016 37.161.225.238:22045 [mon-serveur-vpn] Peer Connection Initiated with [AF_INET]37.161.225.238:22045
Sun May  8 01:38:47 2016 mon-serveur-vpn/37.161.225.238:22045 MULTI_sva: pool returned IPv4=10.8.0.6, IPv6=(Not enabled)
Sun May  8 01:38:47 2016 mon-serveur-vpn/37.161.225.238:22045 MULTI: Learn: 10.8.0.6 -> mon-serveur-vpn/37.161.225.238:22045
Sun May  8 01:38:47 2016 mon-serveur-vpn/37.161.225.238:22045 MULTI: primary virtual IP for mon-serveur-vpn/37.161.225.238:22045: 10.8.0.6
Sun May  8 01:38:49 2016 mon-serveur-vpn/37.161.225.238:22045 PUSH: Received control message: 'PUSH_REQUEST'
Sun May  8 01:38:49 2016 mon-serveur-vpn/37.161.225.238:22045 send_push_reply(): safe_cap=940
Sun May  8 01:38:49 2016 mon-serveur-vpn/37.161.225.238:22045 SENT CONTROL [mon-serveur-vpn]: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 8.8.8.8,dhcp-option DNS 8.8.4.4,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5' (status=1)

Le fichier de configuration /etc/openvpn/server.conf :

# Serveur TCP/443
mode server
proto tcp
port 443
dev tun

# Clés certificats
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
tls-auth ta.key 1
key-direction 0
cipher AES-256-CBC

# Réseau
server 10.8.0.0 255.255.255.0
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
keepalive 10 120

# Sécurité
user nobody
group nogroup
chroot /etc/openvpn/jail
persist-key
persist-tun
comp-lzo

# Logs
verb 3
mute 20
status openvpn-status.log
log-append /var/log/openvpn.log

À noter que je souhaite conserver le service sur le port 443 pour profiter d'un accès même sur les bornes wifi limitées aux ports 80/1080/443. smile

Si vous avez la moindre idée de ce qui cloche ?.. Via le protocole pptp je me connecte et profite d'un accès au net sans soucis, mais cette méthode ne me convient pas, d'autant qu'on ne peut pas fixer le vpn sur le port 443.

#19 Re : -1 »  [Résolu] Internet via serveur OpenVPN sur port 443 sous Ubuntu 16.04 ? » Le 08/05/2016, à 10:27

billou
Réponses : 1

J'ai enfin fini par trouver !

Déjà j'ai rajouté quelques options tel que précisé sur un tutoriel pour le raspberry PI

# Serveur TCP/443
mode server
proto tcp
proto tcp-server
port 443
dev tun

# Clés certificats
ca ca.crt
cert server.crt
key server.key
dh dh2048.pem
tls-auth ta.key 1
key-direction 0
cipher AES-256-CBC

# Réseau
server 10.8.0.0 255.255.255.0
ifconfig 10.8.0.1 10.8.0.2
push "route 10.8.0.1 255.255.255.255"
push "route 10.8.0.0 255.255.255.0"
push "route IP-DE-MON-SERVEUR 255.255.255.0"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
push "redirect-gateway def1 bypass-dhcp"
client-to-client
duplicate-cn
keepalive 10 120

# Sécurité
user nobody
group nogroup
#chroot /etc/openvpn/jail
persist-key
persist-tun
comp-lzo

# Log
verb 3
mute 20
status openvpn-status.log
log-append /var/log/openvpn.log

Et surtout, je devais rajouter une règle dans le par-feu pour l'accès aux requêtes DNS (le ping sur IP passait, mais pas sur les noms de domaines)

sudo iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -o eth0 -j SNAT --to-source IP-DE-MON-SERVEUR

Puis enfin on sauvegarde ces règles Iptables pour la prise en compte de cette règle à chaque redémarrage du système.

iptables-save > /etc/iptables.rules

Un petit tour pour vérifier mon IP, j'ai bien celle de mon serveur sur ma machine cliente, et l'accès à internet via des noms de domaines fonctionne, le tout sur un port 443, ce qui permet de faire sauter toutes les limitations de ports des bornes wifi publiques ! smile

Edit : Au cas où ça pourrait servir à quelqu'un, voilà le fichier de configuration *.ovpn pour les machines clientes, sans login ni mot de passe :

# Client
client
dev tun
proto tcp-client
remote IP-DE-MON-SERVEUR 443
resolv-retry infinite
cipher AES-256-CBC
 
# Clé
ca /CHEMIN-DE-MON/ca.crt
cert /CHEMIN-DE-MON/mon-serveur-vpn.crt
key /CHEMIN-DE-MON/mon-serveur-vpn.key
tls-auth /CHEMIN-DE-MON//CHEMIN-DE-MON/ta.key 1
key-direction 1
 
# Sécurité
nobind
persist-key
persist-tun
comp-lzo
verb 3

#20 Re : -1 »  [Resolu] Augmenter la taile de data.img dans Remix OS » Le 18/01/2016, à 13:11

billou
Réponses : 12

Ah Ah, je n'en demande pas tant, juste assez pour mes projets, le reste redistribue le de façon égale à d'autres personnes recherchant une certaine autonomie/autosuffisance ! tongue

Pour les commandes, si, tu adaptes à la taille que tu veux rajouter au fichier data.img !

"#rajouter de l'espace disque à cette dernière => count=1024 = +1Go, pour 2Go remplacer 1024 par 2048, et ainsi de suite." wink

#21 Re : -1 »  [Resolu] Augmenter la taile de data.img dans Remix OS » Le 19/01/2016, à 01:32

billou
Réponses : 12

Tu t'es bien déplacé dans le bon dossier à l'aide de la commande "cd" ?..

#22 Re : -1 »  [Resolu] Augmenter la taile de data.img dans Remix OS » Le 19/01/2016, à 10:50

billou
Réponses : 12

Tu es excusé, rajoute [Résolu] devant le titre de ton sujet, et change ce dernier par quelque chose comme "Augmenter la taille du fichier data.img sur RemixOS" histoire que lors d'une recherche, les gens puissent trouver ces réponses plus facilement. wink

#23 Re : -1 »  [Resolu] Augmenter la taile de data.img dans Remix OS » Le 02/02/2016, à 10:01

billou
Réponses : 12

Le FAT32 limite le moindre fichier à 4Go max, tu ne pourras pas aller au dessus de toute façon.

#24 Re : -1 »  Investir dans un petit chez soi ? » Le 19/01/2016, à 10:56

billou
Réponses : 27
src a écrit :
Dafyd a écrit :

C'est fou que dans un pays comme le notre, se targuant d'être libre et fraternel, tout individu ayant des projets sortant un peu du moule se retrouvent massacrés à coup de normes improbables, refus des Bâtiments de France pour des raisons à la con (dans mon bled, on a un porche d'église qui date du XIIIe siècle. Résultat, à 1km a la ronde, rien d'un peu spécial ne peut sortir de terre. Pour un pauvre porche dont tout le monde (le curé comprit) se fou...)
J'ai pris un type en stop une fois, c'était un gars un peu hippie, qui vivait dehors par choix. Le gars était ingénieur en matériaux, et planchait sur des matériaux de construction novateurs. Jamais il n'a eu le droit de construire son projet, et en plus personne ne l'a jamais pris au sérieux, malgré un nombre colossal de démarches administratives en tout genre...

Oui enfin ces "normes" servent la plupart du temps à protéger les gens qui vivent dedans...

Je pense qu'il fait la distinction entre d'un côté les normes de sécurité, et de l'autre l'apparence.
Les permis de construire se fichent pas mal du matériau utilisé, tant que le rendu final extérieur ressemble en tout point à ce qui est attendu par la DDE en fonction de règles locales...
Le problème, c'est que derrière, tout ce qui sort du lot ne sera pas accepté, quand bien même ces méthodes de construction pourraient être plus abordables, plus fiables, plus écologiques.

Les lobbys&syndicats du bâtiments sont également tels, ainsi que le vivier d'emploi, qu'aucune volonté politique d'un changement en la matière ne peut émerger, trop d'intérêts sont en jeux, et tant pis pour ceux qui devront s'endetter durant des décennies alors qu'il aurait pu en être autrement.