Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 3

#0 -1 »  Ubuntu 12.04 Bug logithèque et Tableau de bord->Applications. » Le 09/05/2012, à 17:22

Zorino
Réponses : 5

Bonjour,

Je suis depuis peu sur la dernière LTS Ubuntu, et, comme vous pouvez le constater dans le titre de la discussion ; je rencontre des problèmes avec ma logithèque, ainsi qu'avec l'accès à mes logiciels via le tableau de bord.

Petite mise en contexte :

Ces problèmes sont survenus peu après que j'aie essayé d'installer "eid", qui est un logiciel de lecteur de carte d'identité belge (remplir déclaration impôt on-line)
j'ai une première fois essayé de l'installer via le premier lien qui se trouve sur cette page :
Ubuntu(32) / Debian(32) (oui oui, mon ubuntu est un 32bits), en ouvrant le .deb directement avec la logithèque.
La logithèque ne répond pas... -> forcer à quitter.
Je recommence, en prenant cette fois le soin de d'abord enregistrer le . deb sur mon disque dur avant de l'ouvrir avec la logithèque.
La logithèque ne répond pas... -> forcer à quitter.

Je ferme firefox (ou chromium, je ne sais plus... soit) et j'essaye de simplement ouvrir la logithèque en cliquant sur son icône dans le lanceur
La logithèque ne répond pas... -> forcer à quitter.

Ctrl+alt+t :

sudo apt-get update

je lance les dernières mises à jour -> il n'y en a pas encore.

sudo apt-get remove --purge software-center
sudo apt-get install software-center

Je désinstalle et ré- installe la logithèque

gksudo software-center

et toujours dans le terminal, je lance la logithèque.

ÇA MARCHE ! chouette.
Je recherche Eid directement via la logithèque, je le trouve et l'installe.
Je ferme la logithèque et essaie d'ouvrir Tableau de bord -> applications.
BUG le tableau de bord s'ouvre, fonctionne normalement dans tous les menus SAUF pour les applications, il ne trouve rien. pas plus quand je lance une recherche. même le meni "filtrer les résultats" ne s'affiche pas

J'essaie de ré-ouvrir la logithèque via le lanceur
la logithèque ne répond pas -> forcer à quitter.
Je lance la logithèque via terminal, la logithèque s'ouvre.
J'essaie d'ouvrir l'onglet "logiciels installés"
problème logiciel détecté -> signaler un bogue
la logithèque ubuntu a quité de façon inatendue -> envoyer un rapport d'anomalie pour résoudre ce problème -> relancer
collecte des données.

évidement le bug se reproduit quand la logithèque se relance

Je relance la logithèque via terminal et je supprime eid. et je recommence la dernière phase :
J'essaie de ré-ouvrir la logithèque via le lanceur
la logithèque ne répond pas -> forcer à quitter.
Je lance la logithèque via terminal, la logithèque s'ouvre.
J'essaie d'ouvrir l'onglet "logiciels installés"
problème logiciel détecté -> signaler un bogue
la logithèque ubuntu a quité de façon inatendue -> envoyer un rapport d'anomalie pour résoudre ce problème -> relancer
collecte des données.
rebug

le tableau de bord ne fonctionne toujours pas non plus

Voilà, j'en suis là.

La seule chose que j'ai fait et qui pourrait éventuellement causer problème (enfin, je sais pas... enfin, peut-être...:) : j'ai un peu modifié certains effets avec compizconfig...

merci d'avance pour les conseils

Bien à vous

Zorino

#1 Re : -1 »  Ubuntu 12.04 Bug logithèque et Tableau de bord->Applications. » Le 09/05/2012, à 20:33

Zorino
Réponses : 5

Pas de solution pour le moment sans doute...
À ma place vous feriez quoi?
La solution la plus radicale étant de réinstaller UBUNTU. Dois-je aller jusque là?

#2 Re : -1 »  Ubuntu 12.04 Bug logithèque et Tableau de bord->Applications. » Le 10/05/2012, à 11:01

Zorino
Réponses : 5

Je ne sais pas si ça peut aider quelqu'un :

rascarcapac@Banane:~$ gksudo software-center
2012-05-10 10:56:51,104 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Opération non prise en charge'
2012-05-10 10:57:06,152 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Opération non prise en charge'
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/viewswitcher.py", line 149, in config_view
    pane = vm.set_active_view(view_id)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 149, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 145, in init_view
    self.oneconf_handler = get_oneconf_handler(self.oneconf_viewpickler)
  File "/usr/share/software-center/softwarecenter/backend/oneconfhandler/__init__.py", line 32, in get_oneconf_handler
    oneconf_handler = OneConfHandler(oneconfviewpickler)
  File "/usr/share/software-center/softwarecenter/backend/oneconfhandler/core.py", line 56, in __init__
    self.oneconf = DbusConnect()
  File "/usr/lib/python2.7/dist-packages/oneconf/dbusconnect.py", line 142, in __init__
    HOSTS_OBJECT_NAME)
  File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 241, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 248, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 180, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 278, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/share/oneconf/oneconf-service exited with status 1
2012-05-10 10:57:20,804 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-05-10 10:57:20,805 - softwarecenter.db.database - INFO - reopen() database
2012-05-10 10:57:20,805 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 685, in on_db_reopen
    self._refresh_on_cache_or_db_change()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 680, in _refresh_on_cache_or_db_change
    self.refresh_apps(keep_state=True)
  File "/usr/share/software-center/softwarecenter/utils.py", line 118, in wrapper
    f(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 652, in refresh_apps
    self._build_categorised_installedview(keep_state)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 369, in _build_categorised_installedview
    model = self.base_model  # base model not treefilter
AttributeError: 'InstalledPane' object has no attribute 'base_model'
2012-05-10 10:58:19,152 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Opération non prise en charge'
2012-05-10 10:58:36,151 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Opération non prise en charge'
2012-05-10 10:58:48,152 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Opération non prise en charge'
rascarcapac@Banane:~$