Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  Idée projet Logiciel RDM Eurocodes Structures Bois, Acier, Béton... » Le 14/01/2010, à 20:15

gtkshroom
Réponses : 80

Bonsoir,

Je suis étudiant en BTS Systèmes Constructifs Bois et Habitat, et j'aimerais dire Bravo pour ce projet qui s'annonce très prometteur et qui me concerne tout particulièrement.

En revanche, comme je ne suis qu'en première année et que je n'ai jamais étudié le matériau bois auparavant, il y a encore des notions qui me sont inconnues. On a commencé la RdM (là-dessus je suis pas trop dépaysé, je viens d'un BAC S Sciences de l'Ingénieur) et on a pas mal mis en application sur les ossatures et les charpentes, ça reste que le début. smile Dimensionnement, pas encore vu. Mais ça ne saurait tarder.

Point de de vue programmation, je suis encore au stade "Quiche" en Python et GUI avec Glade, en conséquence je ne peux pour le moment que soutenir moralement l'outil en développement. neutral

Bon courage pour la continuation de ton programme. Je suis agréablement surpris d'avoir découvert ce sujet. wink

C'est une perle rare et ça promet de me servir plus d'une fois au cours de mes deux ans d'études dans le domaine.

#1 Re : -1 »  Idée projet Logiciel RDM Eurocodes Structures Bois, Acier, Béton... » Le 14/01/2010, à 21:14

gtkshroom
Réponses : 80

Je fais mon BTS à Remiremont (Vosges) au Lycée A. Malraux. Une bonne filière, je suis très content. smile

#2 Re : -1 »  [PCSX] : SDL, le son craque » Le 01/11/2010, à 15:28

gtkshroom
Réponses : 36

Pour OSS je conseille ce tuto assez complet sur le sujet:

http://www.ubuntugeek.com/howto-install … ality.html (en anglais)

Je viens de faire l'installation pour un jeu qui tourne avec un moteur Unreal qui a en résumé besoin d'OSS pour fonctionner correctement et aucun soucis jusque-là.

Le son marche nickel après installation. smile

#3 Re : -1 »  [PCSX] : SDL, le son craque » Le 01/11/2010, à 15:56

gtkshroom
Réponses : 36

Ok.

Ça doit dépendre de la carte son et ça pas sûr à 100% comme méthode.

#4 Re : -1 »  Arte +7 recorder version 4 » Le 09/12/2009, à 23:03

gtkshroom
Réponses : 886

En fait le problème c'est que quand tu as ajouté le dépôt, tu as oublié de modifier la partie qui concerne ta version d'Ubuntu.

#Arte+7 recorder
deb http://ppa.launchpad.net/arte+7recorder/ppa/ubuntu YOUR_UBUNTU_VERSION_HERE main

Il faut remplacer YOUR_UBUNTU_VERSION_HERE par karmic dans le cas de la 9.10

#5 -1 »  [HP 6735s] Touches Fn+F8 et F9 ne marchent plus (luminosité) » Le 02/07/2011, à 18:56

gtkshroom
Réponses : 2

Bonjour,

Je viens de réinstaller Ubuntu sur mon ordi portable HP 6735s, la version 11.04 et je remarque que les touches qui permettent de régler la luminosité ne marchent plus alors que sur des versions antérieures il n'y avait aucun problème. Les autres touches Fn marchent en revanche.

De plus, quand je suis sur secteur sans batterie, la luminosité n'est pas au maximum ce qui est plutôt gênant.

Vous auriez des pistes sur ce problème ?

Merci d'avances pour vos réponses. smile

EDIT: En fait, ça marche seulement quand ça le veut bien. Certains démarrages les touches reviennent puis à un autre elles plantent.

#6 -1 »  Minecraft bloque clavier et/ou souris après quelques minutes de jeu. » Le 14/02/2012, à 16:26

gtkshroom
Réponses : 5

Bonjour,

J'ai un problème récurrent et plutôt gênant à chaque fois que je joue à Minecraft, au bout de plusieurs minutes de jeu mon clavier ou ma souris se bloque sans raison apparente. Les symptômes sont pour la souris : aucune possibilité de bouger le curseur ni de cliquer ; ainsi que pour le clavier : les touches sont toutes bloquées, aucune ne réagit et il se verrouille sur la dernière touche appuyée.

Pour me sortir temporairement de cette situation j'utilise un clavier et une souris de secours afin de reprendre le contrôle et rebooter pour effacer le souci. Mais il ne fait que revenir à chaque session de jeu..

Je suis sur Ubuntu Oneiric Ocelot 11.10 (Linux 3.0.0-16-generic).

J'ai lancé Minecraft en terminal pour voir ce qu'il me raconte, voici ce qui est en sortie :

Loading: net.java.games.input.LinuxEnvironmentPlugin
Failed to open device (/dev/input/event4): Failed to open device /dev/input/event4 (13)

Failed to open device (/dev/input/event3): Failed to open device /dev/input/event3 (13)

Failed to open device (/dev/input/event2): Failed to open device /dev/input/event2 (13)

Failed to open device (/dev/input/event1): Failed to open device /dev/input/event1 (13)

Failed to open device (/dev/input/event0): Failed to open device /dev/input/event0 (13)

Linux plugin claims to have found 0 controllers

Starting up SoundSystem...
Initializing LWJGL OpenAL
    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
OpenAL initialized.

L'erreur concernant /dev/input/eventX aurait-elle un rapport ?

En ce qui concerne mon matos, le clavier et la souris sont tout deux Logitech couplés à un récepteur Unifying. Les références sont :

  • Logitech Wireless Keyboard K350

  • Logitech Performance Mouse MX

Je n'ai aucune raison de penser que mes périphériques sont en cause niveau matériel, je ne rencontre aucun problème sur ma partition Windows 7 avec le même jeu.

Le détail d'un "java -version", j'ai désinstallé OpenJDK et j'ai réinstallé le Sun Java 6 :

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

Du côté de LWJGL j'ai changé les différents fichiers .jar (lwjgl.jar, lwjgl_util.jar et jinput.jar) et le dossier "natives" avec ceux de la dernière version en date : 2.8.3

J'ai aussi fouillé dans les journaux systèmes mais rien d'anormal à priori.

[    1.833244] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:04.0/usb4/4-3/4-3:1.0/input/input3
[    1.833300] generic-usb 0003:046D:C52B.0001: input,hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-0000:00:04.0-3/input0
[    1.840314] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:04.0/usb4/4-3/4-3:1.1/input/input4
[    1.840409] generic-usb 0003:046D:C52B.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:04.0-3/input1
[    1.852129] generic-usb 0003:046D:C52B.0003: hiddev0,hidraw2: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:04.0-3/input2

Je vous remercie à l'avance pour toute l'aide que vous pourrez m'apporter, en fait ça m'énerve beaucoup de jouer à ce jeu sur Windows parce que le jeu rame plus que sur Ubuntu, maudite fenêtre ! big_smile

#7 Re : -1 »  Minecraft bloque clavier et/ou souris après quelques minutes de jeu. » Le 14/02/2012, à 16:48

gtkshroom
Réponses : 5

Alors quand je rappuie sur la touche verrouillée rien ne se passe. Passer le clavier bloqué/souris bloquée en ON/OFF ne change rien. Le récepteur Unifying, si je le débranche/rebranche (je viens d'essayer) alors là tout plante, la souris qui marchait à l'instant ne répond plus. Je voulais d'ailleurs essayer de rebrancher une filaire en USB pour rebooter, la souris ne s'est même pas mise en route... Le clavier de sauvetage vu qu'il est en port série, j'ai pu faire un Ctrl + Alt + F1 pour rebooter à peu près proprement.

Le récepteur serait-il la cause à isoler ?

#8 Re : -1 »  Minecraft bloque clavier et/ou souris après quelques minutes de jeu. » Le 14/02/2012, à 17:10

gtkshroom
Réponses : 5

Le récepteur USB est branché au bout de la rallonge fournie avec la souris. J'ai mis la rallonge parce que j'avais d'horribles bugs de réception qui se traduisait par exemple par un retard de saisie du texte au clavier (certaines lettres passaient à la trappe, là aussi un bug très agaçant), sûrement des interférences. Depuis que le Unifying est à 3 cm du clavier et ni trop loin de la souris, je n'ai plus de problèmes de ce côté-là, mais ce blocage dans Minecraft est très agaçant.

Je vais essayer de rebooter en débranchant le récepteur avant le démarrage.

#9 Re : -1 »  Minecraft bloque clavier et/ou souris après quelques minutes de jeu. » Le 15/02/2012, à 19:53

gtkshroom
Réponses : 5

Ça ne semble pas résoudre le problème...
Le blocage survient à des durées de jeu différentes, c'est plutôt bizarre.
Je ne sais plus où chercher, vous auriez encore une idée ? sad

Merci.

#10 -1 »  [Jeux, vidéos flash] Ralentissements puis écran noir, hard-reboot » Le 02/07/2011, à 20:22

gtkshroom
Réponses : 6

Bonjour,

Je suis sur mon ordinateur portable HP6735s qui dispose d'une Radeon Mobile HD3200 et quand je lance Minecraft (avec OpenJDK 6) je lance une partie solo, je joue une petite minute, je vois la mémoire allouée s'affoler (qui commence à pas mal grimper) dans les stats disponibles via la touche F3 et puis après ce n'est pas le jeu qui plante mais le système complètement : disparition de l'écran, noir complet et plus aucune commande ne répond.

Dois-je passer sur la version Sun Java plutôt que OpenJDK ou c'est un autre problème ? (sachant que sur mon ordi fixe, le jeu avec OpenJDK marche très bien). Sur cet ordi portable j'étais sur Win7 avant et Minecraft marchait donc il n'y a pas de raison. Dois-je tester avec Java officiel ? Je vais faire le test mais au cas où cette solution ne marcherait pas je demande toutefois si vous avez d'autres pistes. smile

Merci d'avance pour vos réponses. Bonne soirée.

#11 Re : -1 »  [Jeux, vidéos flash] Ralentissements puis écran noir, hard-reboot » Le 02/07/2011, à 21:22

gtkshroom
Réponses : 6

Oui j'utilise le pilote proprio proposé au premier démarrage d'une install fraîche.

Je viens de regarder une vidéo sur le net et le même plantage vient de se produire. Quelques minutes puis paf ! Black screen...

#12 Re : -1 »  [Jeux, vidéos flash] Ralentissements puis écran noir, hard-reboot » Le 03/07/2011, à 09:11

gtkshroom
Réponses : 6

J'ai viré tous les bazars de mise en veille. Je viens de démarrer Minecraft à froid, j'ai réussi à jouer un peu plus longtemps qu'après quelques heures d'utilisation du PC.

J'élimine donc la cause de la mise en veille vu qu'avant que je vire ces paramètres l'ordi arrivait à récupérer sans problème.

EDIT: Je vais mettre ça sur le dos du 64-bit et tenter une réinstallation sous un 32-bit. De toute manière, je ne serai pas pénalisé dans une quelconque sauvegarde car je viens tout juste d'installer cette version 64-bit. Je vous en dis plus dès que c'est réinstallé. smile

#13 -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 31/10/2010, à 10:27

gtkshroom
Réponses : 8

Bonjour,

J'essaie d'installer le Postal Fudge Pack avec l'installeur fourni dans le DVD autrement dit le fichier linux_installer.sh mais je ne parviens pas à l'exécuter sans que je tombe sur cette erreur:

Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing The Postal Fudge Pack for x86 GNU/Linux.................................................................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Impossible de charger 'setup.data/setup.xml'

À ce que me dit Google quand je lui soumets l'erreur, celle-ci est commune à l'installation de Google Earth sur des systèmes Linux avec le fichier .bin mais la solution proposée par les divers liens est applicable uniquement à ce programme. Comme je ne peux pas modifier l'installeur avec un éditeur de texte, qu'est-ce que je pourrais envisager sans passer par l'installeur Windows et Wine ?

Merci d'avance pour votre aide. smile

Mon système: Ubuntu 10.10, mes pilotes graphiques à jour.

#14 Re : -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 31/10/2010, à 14:43

gtkshroom
Réponses : 8

Désolé double post mais ça a son intérêt:

Le fichier setup.xml en question se trouve dans /home/login/Bureau/Postal/Mac OS X Installer.app/Contents/MacOS et /home/login/Bureau/Postal/Mac OS X Installer.app/Contents/MacOS/setup.data (en tenant compte du fait que j'ai copié le contenu du DVD sur le Bureau).

Affiché avec Vim, voici la partie "lisible" du code source du fichier linux_installer.sh: http://pastebin.com/ett0TBs7 (seulement je ne vois pas trop où ça peut planter et quel rapport ça a avec une erreur de parseur XML)

Sinon, je vais tenter l'installation sur une openSUSE virtualisée, j'ai vu sur certains forums que l'installation s'était passé sans problème sur ce système.

Voilà pour le compléments d'informations. smile

BIGEDIT

L'installation sur openSUSE s'est déroulée avec succès.
1288600490.png

Maintenant, voilà ma manipulation: une fois l'installation sur l'OS virtualisé finie, j'ai copié le répertoire installé postal_fudge_pack dans un partage monté au préalable puis dans mon répertoire personnel comme si je l'avais installé sur Ubuntu.

Résultat: l'exécution du jeu par la commande ./postal2 ne donne rien même avec la résolution du Default.ini et DefUser.ini (affichage du splash de démarrage puis crash)

Can't find file for package 'WinDrv'

History: 

Exiting due to error

Je peux en revanche démarrer le jeu avec la commande ./postal2aw(extension Apocalypse Weekend) mais qu'à moitié car le son plante.

Postal 2
Copyright 2003 Running With Scissors, Inc.
Unreal Engine
Copyright 2001 Epic Games, Inc.
open /dev/[sound/]dsp: No such file or directory

Cette dernière erreur serait apparemment due au fait que l'émulation OSS a été retiré du noyau dans cette nouvelle version d'Ubuntu ce qui implique également l'inexistence de ce fameux /dev/dsp que les jeux basés sur un moteur Unreal nécessitent.

Je continue mes expériences.

#15 Re : -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 01/11/2010, à 15:10

gtkshroom
Réponses : 8

Alors pour le problème de son c'est également résolu mais pas sans bricolage.

J'ai réinstallé OSS avec cette méthode et le son marche sans problème pour le jeu:

http://www.ubuntugeek.com/howto-install … ality.html

Si je résume pour ceux qui voudraient faire fonctionner à peu près normalement le Postal Fusge Pack en natif:

  • Installer avec VirtualBox un openSUSE et monter un dossier partagé;

  • Dans openSUSE, lancer l'installation du jeu et copier les répertoires installés dans son dossier personnel Ubuntu via le partage;

  • Comme décrit ici, installer et configurer OSS sur Maverick;

Le jeu est prêt à l'emploi. smile

C'est laborieux mais ça permet de jouer sans passer par un système complet openSUSE.

#16 Re : -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 01/11/2010, à 16:05

gtkshroom
Réponses : 8

N'étant pas sûr de toutes les solutions proposées et surtout que je n'ai pas essayées, je te donne le lien de la recherche Google sur cette erreur.

Lien

Les solutions sont dans les premières résultats.

En gros tu as le choix entre:

Google a écrit :

Le dépôt à rajouter:

deb http://ftp.debian.org/debian/ testing main contrib non-free

Dans un terminal:

sudo apt-get update
sudo apt-get install googleearth-package
make-googleearth-package

Un fichier *.deb est créé, il faut l'installer. Dans le terminal toujours:

sudo dpkg -i googleearth*.deb

OU

Google a écrit :

Dans un terminal:

./GoogleEarthLinux.bin --target /tmp/ge
cd /tmp/ge/setup.data/bin/Linux/x86/
mv setup.gtk setup.gtk2
cd /tmp/ge
./setup.sh

#17 Re : -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 01/11/2010, à 18:57

gtkshroom
Réponses : 8

Tu dois avoir le terminal ouvert en même temps que le gestionnaire de paquets Synaptic, je me trompe ? Ferme Synaptic quand tu installes des paquets en passant par la ligne de commande, sinon ça retourne ce genre d'erreur.

#18 Re : -1 »  [Résolu] Installation Linux de Postal Fudge Pack » Le 03/11/2010, à 14:38

gtkshroom
Réponses : 8

Alors, pour ceux qui veulent parvenir à jouer au jeu principal(Share the Pain), j'avais la solution sous le nez et j'ai pas cherché plus loin jusqu'ici.

Voici la solution au problème de l'erreur du WinDrv: https://bugzilla.icculus.org/show_bug.cgi?id=2955

Plus simplement, téléchargez cette archive que je vous ai préparée ici et décompressez-là dans votre répertoire de jeu /home/login/postal_fudge_pack/postal2game/System/ ou /usr/game/postal_fudge_pack/postal2game/System/ si vous l'avez installé en root.

Apocalypse Weekend, A Week in Paradise et Eternal Damnation s'exécutent sans problème, il y a juste Share the Pain qui fait des caprices.

#19 -1 »  [Wine] Creatures Village ne se lance pas. » Le 25/12/2009, à 12:00

gtkshroom
Réponses : 1

Bonjour,

Dans la série des jeux Creatures, ça tourne généralement assez bien sous Linux (j'ai déjà avec succès fait marcher Creatures 3 et Docking Station, un lanceur était même prévu pour Linux, j'ai fait une doc ubuntu à ce sujet) mais avec ce petit dernier, je vois pas comment le manipuler pour l'exécuter.

Pour Creatures Village, j'utilise wine-1.2 installé par Synaptic avec la configuration par défaut, et seule cette erreur me tombe dessus.
Capture-App_ProcessCommandLine.png

Apparemment il faut rajouter un paramètre dans le genre --autokill ou --autostop, mais je ne vois déjà pas comment le rajouter à l'exécutable du jeu afin de voir si ça fonctionne.

De plus, Google n'est pas mon meilleur ami dans ce cas-là.

Vous auriez une idée pour contourner cette erreur ?

Merci d'avance pour votre aide et joyeux Noël. smile

EDIT: C'est bon pour cette erreur. Il fallait faire un lanceur avec le chemin de l'exécutable et rajouter l'argument --autokill Creatures Village.

Mais maintenant j'ai deux autres erreurs:

Capture-MainCamera_StartDisplayEngine.png

Capture-MainWindowProc.png

#21 -1 »  [Install] AVCHDVC Video Converter plante au démarrage » Le 28/11/2009, à 17:48

gtkshroom
Réponses : 5

Bonjour,

J'ai récemment installé AVCHDVC Video Converter en suivant le tuto de lprod (lien) afin de pouvoir ré-encoder mes fichiers .mts difficilement utilisables dans ce format.

J'ai Ubuntu 9.10 Karmic Koala et toutes les dépendances relatives au programme sont installées, mais pourtant j'obtiens cette erreur:

$ avchdvc 

* Détection du système:
-----------------------
Système:  Linux
Noyau:  2.6.31-15-generic
Architecture:  i686 ( 32bit )

* Python:
---------
Version de Python:  2.6.4
Compilateur Python:  GCC 4.4.1

* Dépendances:
--------------
* PyQt4 N'EST PAS INSTALLE, AVCHD Video Converter NE PEUT PAS DEMARRER !!!

Le paquet python-qt4 est bel et bien installé mais le programme ne parvient pas à démarrer. sad

Merci d'avance pour votre aide.

#22 Re : -1 »  [Install] AVCHDVC Video Converter plante au démarrage » Le 29/11/2009, à 09:38

gtkshroom
Réponses : 5

Il doit me manquer un peu plus car le répertoire site-packages de /usr/lib/python2.6 n'existe visiblement pas... neutral

J'ai également fait un tour dans les voisins Python2.4 (où il y a un répertoire site-packages) et Python2.5 mais aucun des deux ne disposent de Qt.so.

#23 Re : -1 »  [Install] AVCHDVC Video Converter plante au démarrage » Le 29/11/2009, à 11:02

gtkshroom
Réponses : 5

En fait, j'ai regardé les propriétés du paquet python-qt4 dans Synaptic et voici où le fichier dont j'ai besoin s'installe. hmm

capturepythonqt4proprit.png

#24 Re : -1 »  [Install] AVCHDVC Video Converter plante au démarrage » Le 29/11/2009, à 16:54

gtkshroom
Réponses : 5

C'est aussi ce que je pensais faire, jusqu'à ce que je me rende compte qu'étrangement ça vient de marcher sans effectuer cette manipulation. big_smile

Pour l'instant, tout fonctionne mais si jamais Qt.so redevenait introuvable, je garde ton lien symbolique en réserve wido.

Merci de ton aide malgré l'auto-résolution de ce mystérieux problème. neutral