Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Qarte arte.tv browser (ex Qarte+7) » Le 18/10/2012, à 15:48

claudiux
Réponses : 1 321

Merci et bravo pour cet excellent Qarte !

#1 Re : -1 »  Ubuntu-fr: signaler des erreurs et aider à améliorer le site » Le 05/09/2012, à 12:50

claudiux
Réponses : 2 259

Bonjour,

Pourquoi le lien projets.ubuntu-fr.org mène-t-il sur un site qui n'a rien à voir avec Ubuntu-fr et lesdits projets ? Impossible de me rendre sur projets.ubuntu-fr.org/iso_fr/ (projet de francisation d'Ubuntu).

Piratage ? Dysfonctionnement ?

#2 Re : -1 »  [Script Bash]Liste Paquets installés manuellement après l'installation » Le 05/09/2012, à 19:52

claudiux
Réponses : 52

Si ça peut être utile, j'utilise la commande suivante pour connaitre la liste des paquets installés :
  dpkg --get-selections | grep -v deinstall | awk '{print $1}'

et celle des paquets désinstallés :
  dpkg --get-selections | grep deinstall | awk '{print $1}'

#3 Re : -1 »  [Script Bash]Liste Paquets installés manuellement après l'installation » Le 06/09/2012, à 14:26

claudiux
Réponses : 52
quent57 a écrit :

Liste des paquets installés manuellement :
apt-mark showmanual
wink

Dommage que Sous Ubuntu 10.10 (maverick) la commande apt-mark ne connaisse pas l'option showmanual. Je vais essayer d'adapter ton script, car j'ai plusieurs ordis à faire migrer de 10.10 à 12.04.1.

#4 Re : -1 »  [Script Bash]Liste Paquets installés manuellement après l'installation » Le 06/09/2012, à 20:47

claudiux
Réponses : 52

Voici un script python qui utilise pour une large part celui de quent57, et l'une des commandes bash que j'ai données au #35.

Il est prévu pour fonctionner sur Maverick. Je vais faire des tests pour voir si cela fonctionne sur une réinstall de Maverick ; il reste à sauver les clés PGP des dépôts PPA, la liste de ceux-ci en adaptant le nom de la distrib (remplacer maverick par precise, si le dépôt contient bien des paquets pour precise), puis créer les scripts pour ré-installer les dépôts, clés et paquets existants sur une Precise.

#!/usr/bin/python
# -*- coding: utf-8 -*-

import subprocess
import os, os.path
import re


### Liste des paquets installés automatiquement (i.e non installés manuellement) ###
# Sous Maverick (Ubuntu 10.10) apt-mark ne connait pas l'option showmanual.
proc = subprocess.Popen(["apt-mark","showauto"], stdout=subprocess.PIPE)
autoInstalls,err = proc.communicate() 

autoInstallsList = []
for autoInstall in str.split(autoInstalls,'\n'):
  autoInstallsList.append(autoInstall)

## debug:
#print "autoInstallsList: %i" %len(autoInstallsList)

### Liste de tous les paquets installés ###
# S'il n'existe pas, on crée un script bash qui nous donne cette liste.
# (Pas élégant, mais ça fonctionne et c'est rapide !)
if not os.path.exists(os.path.abspath('')+'/allpackages.sh'):
  allpackagescript=open(os.path.abspath('')+'/allpackages.sh', 'w')
  allpackagescript.write("dpkg --get-selections | grep -v deinstall | awk '{print $1}'")
  allpackagescript.close()
# On utilise ce script :
proc=subprocess.Popen(["/bin/sh",os.path.abspath('')+"/allpackages.sh"], stdout=subprocess.PIPE)
allInstalls,err = proc.communicate()

allInstallsList = []

# Filtre pour les paquets dont le nom commence par 'linux-' et contient
# au moins un chiffre, comme linux-image-3.2.0-23-generic
# ou linux-headers-3.2.0-23-generic. Ces paquets sont inutiles dans la liste,
# car leurs dernières versions sont installées par des meta-paquets tels linux-generic,
# linux-headers-generic, etc.
linuxchiffres=re.compile(r'linux-.*\d+')

for allInstall in str.split(allInstalls,'\n'):
  if not linuxchiffres.match(allInstall): # on écarte les paquets filtrés.
    allInstallsList.append(allInstall)

## debug:
#print "allInstallsList: %i" %len(allInstallsList)

### Liste de tous les paquets installés manuellement ###
# C'est la différence entre la liste des paquets installés et celle des paquets auto.
manualInstallList = filter(lambda x:x not in autoInstallsList,allInstallsList)

# Suppression des paquets réinstallés automatiquement

dependsList=[]

depends=re.compile("Depends: ([^\n/]*)")
section=re.compile("Section: ([^\n/]*)") 

for pkg in manualInstallList:
  proc=subprocess.Popen(["apt-cache","show",pkg], stdout=subprocess.PIPE)
  res,err = proc.communicate()
  """
  #1ere idée : Suppression des paquets dont dependent les meta-paquets (tels ubuntu-minimal et ubuntu-desktop) :
  sct=section.search(res)
  if sct.group(1).startswith("metapackages"):
    #print "META : %s" %pkg
    deps=depends.search(res)
    deps=deps.group(1).replace("," , "")
    pkgsList=str.split(deps, " ")
    dependsList=dependsList + filter(lambda x:x not in dependsList,pkgsList)
  """
  # 2nde idée : Finalement, supprimer tous les paquets qui seront réinstallés automatiquement du fait des dépendances :
  deps=depends.search(res)
  if deps is not None:
    deps=deps.group(1).replace("," , "")
    pkgsList=str.split(deps, " ")
    dependsList=dependsList + filter(lambda x:x not in dependsList,pkgsList)

# On supprime ces paquets de la liste des paquets installés manuellement :
manualInstallList=filter(lambda x:x not in dependsList,manualInstallList)

# debug:
#print "manualInstallList: %i" %len(manualInstallList)

for install in manualInstallList:
  print install

EDIT (08/09/2012) : J'ai adapté le script ci-dessus pour qu'il fonctionne aussi sur les versions suivant la 10.10 d'Ubuntu (testé sur 12.04.1).

#5 Re : -1 »  [RESOLU] Driver TI-83 Premium CE » Le 27/04/2015, à 20:45

claudiux
Réponses : 11

Bonjour,

J'ai longtemps cherché pourquoi la commande lsusb ne faisait pas apparaître ma TI-83 Premium CE.

C'était tout simplement parce que le câble micro-usb n'était pas suffisamment enfoncé dans la calculatrice !

hmm

Si je peux avec Tilp sauvegarder des programmes ou faire des copies d'écran, je ne peux par contre pas enregistrer la ROM ! (Dans le but d'un usage privé, bien sûr.)

#6 Re : -1 »  Vpnautoconnect 2.X(Nouvelle version ,bugs, demande d'aide: c'est ici!) » Le 28/01/2013, à 20:10

claudiux
Réponses : 113

Bonjour,

J'avais le même problème : depuis mon passage à la 12.04, vpnautoconnect (2.2.0) ne remplissait plus son office.

J'ai réussi à le faire fonctionner de nouveau. Voici comment.

Quitter vpnautoconnect (clic-droit sur l'icone, Quitter).

Supprimer toute référence à vpnautoconnect dans Applications au démarrage.

Désinstallation complète :

sudo apt-get remove --purge vpnautoconnect

Suppression de tout fichier de conf :

rm -rf ~/.vpnautoconnect

Suppression des paquets inutiles, nettoyage et mise à jour de la base apt :

sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get clean && sudo apt-get update

Vérification des configurations des connections VPN : par précaution, une seule doit avoir la case "Connecter automatiquement" cochée.

Redémarrage de l'ordi (je sais, je sais...)

Une fois connecté à votre session :

sudo apt-get install vpnautoconnect

Alt-F2 puis vpnautoconnect.

Configurer vpnautoconnect (clic droit sur l'icone, Préférences). Ne rien toucher dans l'onglet Général. Dans l'onglet Options appArmor, ajouter les éventuelles applications à désactiver en cas de déconnexion (ex : /usr/bin/amule et/ou usr/bin/qbittorrent). Dans Ajouter une connexion VPN, choisissez la connexion parente (en général : Connexion filaire 1) et votre connexion VPN favorite, cochez les cases de la colonne Autorisé. Sauver.

Ajouter /usr/bin/vpnautoconnect dans les Applications au démarrage.

Se connecter au VPN.

Redémarrer l'ordi. Une fois la session ouverte, vpnautoconnect remplit son office : la connexion au VPN favori se fait automatiquement. J'ai pu vérifier que la reconnexion automatique, suite à une déconnexion non désirée, se faisait correctement.

En espérant que ceci sera utile à certain-e-s.

Cordialement,

Claudiux

#7 -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 05/11/2015, à 22:40

claudiux
Réponses : 4

Bonjour à toutes et tous,

Sur la page concernant l'ASUS R511LJ j'ai décrit comment je suis parvenu à pallier la non-détection de certaines touches spéciales.

Mais la méthode ne me convient pas, parce qu'il faut faire appel à la gestion des raccourcis-clavier pour remplacer la touche Fn par la touche Super. La méthode fonctionne mais manque d'élégance et perturbe les utilisateurs qui ont un dual-boot (pas les mêmes raccourcis sous Ubuntu et sous Windows).

J'ai fait de multiples recherches, sans trouver de solution. Il semble que le noyau 3.19 ne détecte pas certaines combinaisons de touches, car Fn+F5 et Fn+F6 (baisse et augmentation de la luminosté) fonctionnent avant le chargement du noyau, mais plus pendant ni après.

Pourriez-vous m'aider ?

Grand merci à vous !

#8 Re : -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 06/11/2015, à 05:23

claudiux
Réponses : 4

Merci rtst-2 pour ta prompte réponse. J'ai tenté de modifier dans ''/etc/default/grub'' la ligne

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='Linux' i8042.nomux"

et bien sûr mis à jour Grub par un

sudo update-grub

comme tu recommandais, mais cela n'a eu aucun résultat.

La commande ''dmesg | grep i8042'' me retourne :

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=570da9b9-28de-4520-b32c-eb7eafd87460 ro quiet splash acpi_osi=Linux i8042.nomux vt.handoff=7
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=570da9b9-28de-4520-b32c-eb7eafd87460 ro quiet splash acpi_osi=Linux i8042.nomux vt.handoff=7
[    0.591862] i8042: PNP: PS/2 Controller [PNP030b:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
[    0.594296] serio: i8042 KBD port at 0x60,0x64 irq 1
[    0.594299] serio: i8042 AUX port at 0x60,0x64 irq 12
[    0.633732] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[   16.270596] input: PS/2 FocalTech FocalTech Touchpad as /devices/platform/i8042/serio1/input/input6

J'ai donc bien ce type de clavier.

#9 Re : -1 »  Raccourcis Fn+F5, Fn+F6 (luminosité) sur portable ASUS R511LJ » Le 06/11/2015, à 20:16

claudiux
Réponses : 4

Hélas, cela ne fonctionne pas non plus.

J'ai successivement testé :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux video.use_native_backlight=1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='Linux' i8042.nomux"
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"

sans succès.

Mon noyau est le 3.19.0-32-generic.

Je continue à chercher. Merci pour ton aide ! N'hésite pas à me proposer d'autres options.

#10 Re : -1 »  [Résolu] Caribou dans application au démarrage » Le 27/02/2014, à 20:47

claudiux
Réponses : 4

Attention à ne pas supprimer Caribou si vous utilisez Cinnamon.

#11 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 18/12/2010, à 18:31

claudiux
Réponses : 726

Môaaaaa !!! Où la télécharge-t-on ?

J'ai hâte ! big_smile

#12 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 22/12/2010, à 12:05

claudiux
Réponses : 726

Salut MasterGB,

... et bravo ! En trois minutes, je viens de télécharger, installer et paramétrer VPNAutoConnect 1.1. Et ça fonctionne nickel-chrome ! smile

L'interface est agréable mais, sans qu'il y ait besoin d'une aide détaillée, il faudrait que soit explicité l'onglet Apparmor, et expliquer que si une appli est autorisée pour un VPN, elle est interdite d'accès réseau sans ce VPN.

Du beau et bon boulot vraiment ! Un grand merci à toi !

Pourquoi ne pas proposer d'intégrer VPNAutoConnect à Ubuntu ? Ça serait le top du top ! cool

#13 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 23/12/2010, à 17:52

claudiux
Réponses : 726
mastergb a écrit :

J'ai clairement pas le courage

C'est vraiment dommage ! Surtout que tu as fait le plus gros du boulot : créer les paquets .deb.

Quant à l'aide intégrée, une simple image en forme de point d'interrogation qui fournit une bulle lorsqu'on passe la souris dessus... Ou mieux : un onglet supplémentaire, intitulé... Aide smile

#14 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 26/12/2010, à 20:35

claudiux
Réponses : 726

J'ai eu un problème dont j'ai cru que VPNAutoconnect était la cause, mais en fait il n'en est rien ; c'est pour cela que je vous en fait part.

La connexion à mon VPN favori ne se faisait qu'aléatoirement, et j'ai d'abord cru à un bug. Puis je me suis aperçu que depuis que je suis passé à Ubuntu Maverick (10.10) j'avais 2 connexions ethernet possibles : l'ancienne nommée "Auto eth0", et une nouvelle nommée "Ethernet automatique" ; et les deux devaient se connecter automatiquement !

Dans le Network Manager, j'ai décoché la case idoine ("Connecter automatiquement") pour la connexion "Ethernet automatique", et l'ai laissé cochée pour la connexion "Auto eth0".

Dans les préférences de VPNAutoconnect, j'ai vérifié que la connexion parente de mon VPN est bien "Auto eth0".

Et ça roule !

Remarque : on peut aussi faire le contraire (désactiver "Auto eth0" au lieu de "Ethernet automatique"), à vous de choisir.

#15 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 30/01/2011, à 01:08

claudiux
Réponses : 726

@algury : Au lieu de Deluge, dont j'ai un souvenir de lourdeur et d'instabilité (pareil que toi, plantages inexpliqués de l'ordi), je te conseille qBittorrent (comme on me l'a conseillé alors), bien plus léger tout en ayant les mêmes fonctionnalités. De plus, qBittorrent possède des moteurs de recherche de torrents, et tu peux lui en adjoindre d'autres : https://sourceforge.net/apps/mediawiki/ … ne_plugins

Il vaut mieux installer qBittorrent à partir du PPA de l'auteur, ainsi tu bénéficieras de la dernière version dès parution. Je n'ai jamais eu de problème avec ce PPA, l'auteur de qBittorrent sait ce qu'il fait ! http://doc.ubuntu-fr.org/qbittorrent

Attention, qBittorrent, dans ses options avancées, propose de ne fonctionner que sur une interface réseau bien définie (par exemple tap0). Je déconseille d'utiliser cette option conjointement avec l'apparmor. Un peu comme les anti-virus, (si vous avez des windoziens dans votre entourage, vous devez en entendre parler wink) vaut mieux pas en avoir deux en même temps.

Donc j'utilise uniquement VPNautoconnect pour gérer, avec apparmor, l'accès au net de toutes mes applis, y compris qBittorrent.

#16 Re : -1 »  Connexion VPN automatique (NetworkManager) » Le 05/09/2012, à 23:34

claudiux
Réponses : 726

@Anzuz : Tu as rajouté de nouvelles connexions, vérifie qu'il n'y a bien qu'une seule qui a le status "Connecter automatiquement". Attention également à la coche "Disponible pour tous les utilisateurs" (qui doit être décochée).

#17 Re : -1 »  Fusible, une interface pour FUSE » Le 24/01/2011, à 18:12

claudiux
Réponses : 26

Bonjour spomky,

Il n'y a pas de dépôt pour maverick ? Je vais essayer avec le dépôt lucid...

Mais tout de même, ça serait mieux si.

Cordialement.

#18 Re : -1 »  [Résolu]Problème de conversion avec WinFF » Le 14/11/2011, à 18:54

claudiux
Réponses : 16

Un petit up pour dire que sous Oneiric (Ubuntu 11.10), c'est le paquet libavcodec-extra-53 de medibuntu qui m'a sauvé.

Merci pour cette piste.

#19 Re : -1 »  [Résolu] Décrypter home » Le 22/11/2011, à 00:27

claudiux
Réponses : 12

Grand merci car je n'arrivais pas à récupérer mes données !

J'avais lu un tuto analogue, mais j'avais oublié qu'à la question

Filename Encryption Key (FNEK) Signature [dca4db72486e99f2]:

il fallait répondre par le second nombre donné par la commande

$ sudo ecryptfs-add-passphrase --fnek

(je me contentais de valider, croyant à un choix par défaut.)

#20 Re : -1 »  [problème] Ubuntu 9:10 : Défauts d'impression sur brother HL-6050D » Le 16/12/2011, à 12:28

claudiux
Réponses : 11

Je déterre ce vieux topic, car j'ai trouvé, me semble-t-il, la solution :

J'ai d'abord installé les paquets suivants :
a2ps
brother-cups-wrapper-laser1
brother-lpr-drivers-common
brother-lpr-drivers-laser1
psutils

Dans l'administration de l'impression, j'ai supprimé l'imprimante HL-6050DN existante. J'en ai recréé une nouvelle de type AppSocket / HP JetDirect, en renseignant juste son adresse IP (port laissé à 9100).
Comme pilote, j'ai sélectionné HL-6050D/DN OpenPrinting LSB 3.2.

Ensuite, dans les propriétés de l'imprimante : Options des tâches : Copies : 1 (c'était à 0, donc pas de copies !)

Et hop ! smile

#21 Re : -1 »  AWN sur mon écran de droite? » Le 03/10/2011, à 20:25

claudiux
Réponses : 26
SyntheticM a écrit :

Salut tout l'monde !


J'ai téléchargé et installé AWN mais impossible de mettre le doc sur mon écran de droite (mon principal).

Il se met d'office en bas, sur celui de gauche.


Merci d'avance.

J'ai posté la solution ici : http://doc.ubuntu-fr.org/avant-window-n … _multiples

Enjoy !

#22 Re : -1 »  Texas Instrument TI 83 plus et TILPt » Le 04/09/2011, à 12:40

claudiux
Réponses : 3

Réponse tardive, mais je viens d'acquérir une TI83+.fr :
lancer tilp avec les droits root :

sudo tilp

et tout marche nickel !

#23 Re : -1 »  Probleme avec Language-pack-gnome-fr » Le 01/07/2011, à 05:54

claudiux
Réponses : 70

Bonjour,

Une telle gestion des paquets et des dépôts, sur une version LTS qui devrait être un exemple de stabilité, laisse rêveur...

Mais foin de troll poilu, voici comment j'ai résolu mon problème, un peu "à la bourrine" comme proposé par olyHDN en page 2 de ce fil.

J'ai ouvert dans Firefox les 4 onglets suivants :
http://archive.ubuntu.com/ubuntu/pool/m … e/?C=M;O=D
http://archive.ubuntu.com/ubuntu/pool/m … r/?C=M;O=D
http://archive.ubuntu.com/ubuntu/pool/m … e/?C=M;O=D
http://archive.ubuntu.com/ubuntu/pool/m … r/?C=M;O=D

Les fichiers sont affichés du plus récent au plus ancien. J'ai téléchargé, dans un même dossier que j'ai appelé language-pack, la dernière version des .deb pour Ubuntu 10.04 (puisque c'est lucid qui nous concerne) toutes datées du 08-Feb-2011 ou du 09-Feb-2011 à ce jour :
language-pack-fr-base_10.04+20110204_all.deb
language-pack-fr_10.04+20110204_all.deb
language-pack-gnome-fr-base_10.04+20110204_all.deb
language-pack-gnome-fr_10.04+20110204_all.deb

J'ai ensuite ouvert un terminal dans ce dossier language-pack, et appliqué la formule magique :

sudo dpkg -i *.deb

(Attention, synaptic et le gestionnaire de mises à jour doivent être fermés, sinon un verrou bloque l'exécution de cette commande.)

Voilà, tout ces paquets, pris dans le dépôt main, semblent satisfaire synaptic.

Pour ne plus avoir ce type de problème avec ces paquets, on peut dans synaptic :

  • faire une recherche rapide sur "language-pack-"

  • trier le résultat de la recherche par "Version installée"

  • sélectionner les 4 paquets en question (les premiers de la liste, normalement)

  • dans le menu Paquet, choisir de Bloquer la version.

Mais, je le répète, ce genre de rustine est intolérable, surtout dans une version LTS !

Bien cordialement

#24 Re : -1 »  [Resolu] Applet Gestionnaire reseau disparu » Le 09/03/2011, à 04:41

claudiux
Réponses : 10

Toutes ces manipulations n'ayant pas résolu mon problème de disparition de l'applet de network manager, j'ai creusé, et j'ai fini par trouver la solution !

Editer le fichier /etc/NetworkManager/nm-system-settings.conf :

 sudo gedit /etc/NetworkManager/nm-system-settings.conf

Remplacer false par true à la ligne managed de la section ifupdown :

[ifupdown]
managed=true

Rebooter (je sais ça fait pas sérieux). Une fois connecté, exécuter dans un terminal :
 

nm-applet

... et l'applet apparaît enfin !

Ouf !