Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  Windows 8 inutilisable après install de Kubuntu » Le 07/05/2013, à 13:50

TGM
Réponses : 76

Bonjour,

j'ai bien galéré aussi ...
je m'en suis sorti comme ça SVZ13 Ubuntu W8 et UEFI
Voir en bas de page

#1 Re : -1 »  Windows 8 inutilisable après install de Kubuntu » Le 07/05/2013, à 17:05

TGM
Réponses : 76

Ca n'a rien de très compliqué quand on a trouvé la/une solution.
Me concernant : le SSD initialement en Raid0 est découpé en 2 (128*2), je n'ai pas voulu m'embêter avec mdadm dans un premier temps.
Une fois l'installation faite (Ubuntu standard eg. Unity que je n'aime pas trop mais bon ...), le PC affiche bien grub.
J'ai lancé Ubuntu, installé Boot repair et l'ai lancé.
Si ubuntu fonctionne normalement, W8 se plante car il ne trouve pas le fichier efi correspondant (no such device)
j'ai trouvé la solution sur Archlinux, en recherchant sur les codes d'erreur affichés sur Internet :
Chargement des modules,
Remplacement de l'adressage relatif $root (voir la syntaxe) par le chemin absolu, dans le fichier custom de /etc/grub.d a priori créé par boot_repair
Attention au nommage de la partition GPT (hd0, gptn), n correspondant au numéro de ta partition EFI, SDA2 pour moi, généralement sda1 soit (hd0, gpt1)
Au boot, le lancement de l'EFI correspondant à l'OS se fait normalement et tout fonctionne bien maintenant.
Je n'ai pas supprimé les fichiers bckxxxxx créés par boot repair

'It just work", tout le monde dit ça, quel que soit l'OS ... ou le matériel (quel qu'il soit)
Si quelqu'un trouve plus simple, je suis preneur.
Peut être à voir avec son créateur (de boot repair)

#2 Re : -1 »  Boot-Repair pour Ubuntu 14.04 » Le 21/04/2014, à 16:24

TGM
Réponses : 10

Bonjour,

Boot repair n'est-il pas installé par défaut ?
Ubuntu Portal
J'ai fait la mise à jour sur mon disque externe, apparemment, c'est OK

#3 Re : -1 »  Résolu : Dual Boot Windows 8 / Ubuntu 13.04 + SSD + HDD » Le 03/05/2013, à 23:34

TGM
Réponses : 36

Bonsoir,

Sous Linux (en live usb), peux tu faire un sudo parted -l et nous donner le résultat.
De prime abord, je dirais que les 2 premières partitions sont réservées au démarrage, la première pour l'UEFI, la seconde comme extension (Disque 0)
OS(C:) est la partition pour Windows8
D: partition pour mettre tes données
La dernière partition pour disque 0 serait une partition de récupération du système, même si sa taille me semble un peu importante

Disque 1 : je suppose que c'est le SSD de 24Go couplé au HDD de 500Go.
Regarde les essais sur ce type de configuration. je ne suis pas certain qu'il faille supprimer les partitions de ce disque. Asus les utilise pour améliorer les performances de la machine comme cela est indique dans le lien que tu as fourni en début de fil :

Côté stockage, Asus a choisi un compromis entre vitesse et capacité de stockage. Un disque dur de 500 Go est en charge de stocker les données pendant qu'un SSD de 24 Go est utilisé en cache pour améliorer la vitesse des transferts de données et réduire le temps de démarrage (il ne sert pas pour le stockage à proprement parler).

Cela ressemble, toutes proportions gardées, aux disques hybrides tels que ceux proposés par Seagate par exemple, avec un cache plus gros.

En premier lieu, fais les DVD de restauration.
De ce que j'ai lu ici et là, certains auraient refait leur configuration avec Disque (1) réservé à W8 (UEFI + partition en GPT) mais sur un modèle différent. A priori, je ne te le conseille pas. Installe Ubuntu sur le Disque0 qui sera alors découpé de façon classique, une partie pour les données sous windows, l'autre partie découpée pour un Linux, intégrant le swap, le /boot, le / et le /home.
Mais ça, tu sais le faire.
Ton disque étant certainement en GPT, tu n'as pas le souci des partitions extended.
Tu peux redimensionner tes partitions avec l'utilitaire de disque fourni avec W8 ou directement avec un live gparted

#5 Re : -1 »  Résolu : Dual Boot Windows 8 / Ubuntu 13.04 + SSD + HDD » Le 04/05/2013, à 10:05

TGM
Réponses : 36

Bonjour,

De ce que j'ai compris, il veut un dual boot.
Ne rien toucher sur le SSD
Utiliser le HDD comme tu le fais habituellement.

<complétement HS>
J'utilise (aussi) windows 8 au quotidien (je suis passé de XP à W8 d'un coup). Même si je ne suis pas d'accord avec la politique de dépendance sous laquelle l'éditeur maintient ses clients, dès le plus jeune âge, le produit est pas mal, stable et plutôt performant.
Les outils de partitionnement fournis avec sont des outils à minima, comme ce qui est fourni sur ce système en standard depuis le début. A l'époque, sous MS-DOS, il fallait trouver le stack IP qui n'était pas fourni mais c'est une autre histoire.
La cible d'utilisation n'est pas la même
<\complétement HS>

Maintenant, au vu du titre du sujet, j'avais raté le résolu, je pense que ce fil est clos

#6 Re : -1 »  Résolu : Dual Boot Windows 8 / Ubuntu 13.04 + SSD + HDD » Le 07/05/2013, à 21:44

TGM
Réponses : 36

Eventuellement, à désactiver dans le bios. Si non, tu fais " e " sur la ligne du grub "essayer ..." et tu ajoutes acpi=on ou off en fonction de ce que tu cherches à faire. F10 pour booter ensuite.

#7 Re : -1 »  Portable Sony Vaio Z 2011 (aka VPCZ2) » Le 17/05/2013, à 21:03

TGM
Réponses : 37

Bonjour,

Ce fil est un peu éteint maintenant mais on ne sais jamais. J'ai le successeur de votre machine (svz1311, I7 en Ivy bridge). Après avoir bien galéré pour avoir le dual boot en UEFI avec W8, je fais la chasse au gaspi ... Environ 1h40 en lecture vidéo avec VLC, tout réseau éteint, c'est pas terrible. Je ne sais si la ligne de modification de grub/default proposée à la page précédente fonctionne pour cause d'évolution du chipset. le touchpad ne fonctionne pas correctement (pour pointer un objet, c'est du sport, surtout en 1920*1080), je n'ai pas essayé le lecteur d'empreinte ni le BT que je n'utilise pas. le Wifi et le réseau filaire fonctionnent dès l'installation. J'ai supprimé le raid 0 et fonctionne avec maintenant deux disques de 128 (256 raid 0).
Du coup, j'ai rajouté une ligne dans la liste des portables Sony

J'ai l'impression que la machine, assez rare déjà sur le marché, l'est encore plus sous linux en dual boot !

Bien à vous

#8 Re : -1 »  Grub Customizer et EFI » Le 22/07/2013, à 17:28

TGM
Réponses : 3

Bonjour,

je l'ai utilisé sans soucis, mais ma configuration est peut être un peu "exotique" Vaio Z UEFI GPT et MBR. je n'ai pas le temps pour le moment de modifier ma configuration, c'est ma machine professionnelle.
Me concernant, la modification ne porte que sur l'image de fond et les couleurs du menu.

#9 Re : -1 »  [RESOLU] Vaio SVZ13, W8 et Ubuntu » Le 01/05/2013, à 22:41

TGM
Réponses : 9

Bonsoir,
Finalement, j'y suis arrivé ...

Ce que j'ai constaté :
Il semble que sur un disque en GPT, lors du partitionnement à l'installation, quelque chose ne s'écrit pas correctement dans la partition.
Dans mon contexte, j'ai deux disques : /dev/sda en GPT et /dev/sdb en MBR
Je doit passer systématiquement par gdisk après l'installation pour remettre en état le backup du GPT.

Concernant l'installation elle même :
Première installation, reboot : grub absent, démarrage sous W8
J'ai fait quelques essais avec le live-usb et boot repair, même résultat apparent

J'ai donc relancé l'installation (13.04/64). En fin d'installation, j'ai installé boot-repair et l'ai lancé.

Au démarrage, j'ai le menu de grub avec 3 options : Ubuntu (menu principal déclenchant un sous menu) et deux lignes W8
Le choix de l'une ou l'autre entraîne une erreur avec un message du type :
Windows boot UEFI Loader
/EFI/boot/bkpbootx64.efi non disponible
error no such device C4AF-CD41

Apparemment, grub ne n'arrive pas à monter la partition pour lancer le bootloader.
En cherchant par ci par là, j'ai trouvé la solution

Dans /etc/grub.d, j'ai modifié 25_custom

Contenu initial :

#!/bin/sh 
exec tail -n +3 $0 

menuentry "Windows UEFI bkpbootmgfw.efi" { 
search --fs-uuid --no-floppy --set=root C4AF-CD41 
chainloader (${root})/EFI/Microsoft/Boot/bkpbootmgfw.efi 
} 

menuentry "Windows Boot UEFI loader" { 
search --fs-uuid --no-floppy --set=root C4AF-CD41 
chainloader (${root})/EFI/Boot/bkpbootx64.efi 
}

Par :

#!/bin/sh 
exec tail -n +3 $0 

menuentry "Windows 8 UEFI sur /boot/bkpbootx64.efi" { 
    insmod part_gpt 
    insmod fat 
    insmod search_fs_uuid 
    insmod chain 
    search --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 C4AF-CD41 
    chainloader /EFI/Boot/bkpbootx64.efi 
}

Pour information : gpt2 correspond chez moi à sda2, la partition UEFI
Les options viennent d'un forum archlinux

Il y a peut-être moyen de faire plus simple, en tout cas, ça marche.

Pour les intéressés ...

Merci aux deux participants du fil Asus Efi et Boot repair qui m'ont mis sur la voie

#10 Re : -1 »  [RESOLU] Vaio SVZ13, W8 et Ubuntu » Le 10/06/2013, à 21:42

TGM
Réponses : 9

Bonsoir,

Quelqu'un a-t-il essayé cette solution ?
Quel en est le retour ?
Est-il possible de faire plus simple ?

#11 Re : -1 »  [RESOLU] Vaio SVZ13, W8 et Ubuntu » Le 12/06/2013, à 20:04

TGM
Réponses : 9

Bonsoir Malbo,

le voici : Boot-Info

#12 Re : -1 »  [RESOLU] Vaio SVZ13, W8 et Ubuntu » Le 14/06/2013, à 14:58

TGM
Réponses : 9

Bonjour Malbo,

J'ai installé W8 from scratch après avoir supprimé le fake raid 0 qui me posait problème à l'installation d'ubuntu.
Je peux toujours convertir le second disque en GPT pour voir ... pendant une période creuse.
La dernière solution, est de rétablir le raid 0 et de tout réinstaller ... pour voir.
Je ne sais pas si, après une sauvegarde intégrale avec l'utilitaire de windows, je retrouverai un système pleinement opérationnel, ce qui me fait hésiter (trop de temps déjà perdu)
Ayant déjà bien galéré (une semaine complète de réinstallation, entre W7, W8 et Ubuntu, sans compter les essais préalables) tant que ça fonctionne, même si ce n'est pas le plus optimal ...

Le problème qui se posait était que si ubuntu démarrait très bien, le démarrage de windows se plantait car il ne trouvait pas le fichier de démarrage.
Je pense que cela a été résolu avec les insmod.
je peux essayer de repositionner les anciens paramètres de grub, après un boot repair par exemple, puis d'ajouter les lignes d'insmod une à une pour vérifier ce qui est inutile, nécessaire, indispensable

Enfin, d'après ce que j'ai pu lire, je ne souhaitais pas un Raid1 de 128go mais, au mieux, utiliser les deux disques en raid 0 (256 go)
J'ai du perdre un peu de performance en le supprimant mais c'est très certainement imperceptible.
Ce qui m'étonne, c'est de voir qu'apparemment le problème de file not found sur la ligne de boot de W8, quand elle est choisie au démarrage de grub, semble très fréquemment rencontrée, pour avoir parcouru différents forum, notamment celui ci régulièrement

C''était l'objet de ma question par rapport à la solution mise en oeuvre
Merci pour tes informations

#13 Re : -1 »  Impossible de démarrer Windows 8 » Le 11/05/2013, à 11:51

TGM
Réponses : 9

Bonjour Florian,

De ce que je comprends de ta situation :
sda1 : réservé pour /par windows
sda2 : la partition EFI, normalement, l'installateur la détecte automatiquement. Lors de l'installation, choisir autre chose, je pense que c'est ce que tu as fais. Gparted te propose alors la liste de tes partitions. A priori, c'est OK
sda3 : msftres c'est une partition réservée par Windows pour l'extension de UEFI (sda2) si besoin
sda4 : correspond normalement à ton disque C sous W8
sda5 : ta partition linux qui, a priori, comprend, tout (/ et /home)
sda6 : la partition de restauration de ton samsung
sda7 : une partition réservée par Samsung, je suppose aussi pour la restauration.

Concernant la partir démarrage :

Il faut que tu vérifie dans ton bios que le mode de démarrage (boot mode) est bien en UEFI et non pas Legacy.
je ne connais pas le bios des Samsung, mais je pense que tu devrais trouver de plus amples informations sur ce forum.

Néanmoins :

Est-ce que ton PC démarre bien sur Ubuntu ?
Si tel est le cas, installes Boot-repair (cf. la doc associée)

Une fois que boot-repair est installé, suis les instructions.

Un conseil au préalable :

dans un terminal, tape les commandes suivantes (merci de me corriger (les chefs) le cas échéant) :

sudo mkdir /mnt/uefi
sudo mount /dev/sda2 /mnt/uefi

tu te positionne dans ton répertoire $HOME/Documents (cd $HOME/Documents)
Tu crées dedans un répertoire de sauvegarde eg.

mkdir uefiSave

tu sauvegarde ensuite ton répertoire d'origine

sudo cp -R /mnt/ueft $HOME/Documents/uefiSave

Maintenant, tu peux effectuer la réparation par boot-repair (sudo boot-repair dans un terminal)

Il va te proposer de remettre de l'ordre dans ton grub. n'oublie pas de noter les références de boot info

Une fois cela effectué, ton PC devrait redémarrer sous Ubuntu.
Il va te proposer plusieurs options de démarrage aux noms un peu ésotériques.

A priori, tu devrais avoir deux entrées pour W8 et une dernière faisant référence à ta partition de restauration.
Il serait intéressant de savoir ce qui se passe sur l'une ou l'autre de tes options W8. Il y a de fortes chances pour qu'il t'affiche un message de type "error no such device" ou équivalent.
Si tel est le cas, regarde comment je m'en suis sorti ici, le dernier post.

Bon courage, procède posément.

#14 Re : -1 »  Impossible de démarrer Windows 8 » Le 13/05/2013, à 20:58

TGM
Réponses : 9

Bonsoir Florian, désolé, je suis en déplacement, je n'ai pas trop de temps.
Je ne comprends pas ce que fait ton entrée Ubuntu dans le bios.
A mon sens, tu devrais avoir ton HDD en premier pour le démarrage. Ubuntu est-il un autre disque, une clé usb ou un CD/DVD ?
La troisième option affichée par grub correspond à ta partition de réparation.

Peux tu nous donner le contenu de 40-custom. Je pense que c'est ce qui est modifié par boot-repair quand tu le lances.
Il faudrait aussi donner une idée du contenu de ta partition uefi, par exemple, qu'as tu dans ton répertoire /EFI/Boot

#15 Re : -1 »  Impossible de démarrer Windows 8 » Le 14/05/2013, à 20:39

TGM
Réponses : 9

Il serait nécessaire que tu demande au modérateur de regrouper tes deux fils de discussion, celui là et celui auquel Malbo t'a répondu.
Les explications sont dans le lien que je t'ai donné.
D'autre part, si tu redémarre ton PC avec le DVD de W8 dedans, il est normal que celui ci te demande de faire l'installation, le DVD est en première position dans ton bios.

Je te propose de regarder les différents fils liés au pb de dual boot en UEFI, il y a des réponses à plusieurs questions que tu (peux) te pose(r)

Si ta machine est clean et stock, avec W8 installé proprement, en UEFI et GPT, tu ne devrais pas avoir par exemple le problème évoqué par Malbo dans ton autre fil

#16 Re : -1 »  [Resolu] Problemes suite à une installation en UEFI » Le 05/05/2013, à 22:18

TGM
Réponses : 17

Bonsoir,
je suppose que c'est un PC Asus ?

#17 Re : -1 »  [Resolu] Problemes suite à une installation en UEFI » Le 06/05/2013, à 21:08

TGM
Réponses : 17

Bonsoir,
je suppose que ton PC Médion à la même architecture que les machines du type Asus.
le SSD joue le rôle d'un cache pour le HDD.
je ne sais pas si ton PC est neuf ou relativement ancien.
Dans le premier cas, je te conseille de faire une restauration complète, après avoir sauvegardé tes données.
Lors de l'installation, tu choisis "autre chose" et tu repartitionne ton disque SDB comme tu le souhaites. je dirais /boot 300 à 500 Mo, en ext2 (la journalisation n'est pas utile), / avec environ 20 à 25 Mo, en fonction de ce que tu installes et le /home en fonction de tes besoins. Si ton disque est en GPT, il y a de fortes chances pour que ton système soit en mode boot UEFI. A vérifier dans le bios, paramètres de démarrage
A ma connaissance et à mon sens, oublie le SDA qui doit apparaître comme "disque1" dans le gestionnaire de disques de windows. Comme le dit Hopper, de ce que j'ai lu, l'architecture s'apparente à un disque hybride, au moins dans le contexte windows.
Je pense que ton HDD est en GPT.

Concernant parted -l, il faut le lancer avec sudo

sudo parted -l

une fois que ton Ubuntu est installé, au redémarrage, installe boor-repair (cf. doc ubuntu).

Ca t'évitera de galérer.

#18 Re : -1 »  [Resolu] Problemes suite à une installation en UEFI » Le 07/05/2013, à 21:41

TGM
Réponses : 17

Bonsoir,

Bon, hé bien, tu en vois le bout !
Me concernant, je fais le partitionnement suivant :

/boot d'environ 500 Mo mais c'était avant l'UEFI ...
/ d'environ 20 Mo, ce que tu as mis sur /dev/sda (la totalité du disque ce qui est logique dans ton cas). A mon sens, tu aurais pu aussi mettre ta partition UEFI sur /dev/sda, ce qui aurait été plus logique, ayant un SSD
Le /home et le swap (la taille est sujette à grande discussion, normalement, la taille de la mémoire, certains disent le double, d'autres la moitié, ou, enfin, pas du tout. J'ai 8 go de RAM, j'ai mis 1go de swap, vraiment pour dire parce je l'avais supprimé déjà bien avant, même sur mon vieil HP et ses 4Go) étant sur le /dev/sdb
L'intérêt étant de pouvoir le changer ton HDD pour un SSD plus tard si tu en as envie

Récapitulons, le tout en GPT
/dev/sda1 : partition efi, fat32, mets 300 Mo, on ne va pas mégoter
/dev/sda2 : ton / en ext4

/dev/sdb1 : ton swap taille n
/dev/sdb2 : /home avec le reste

Si tu souhaites réinstaller W8, il faudra revoir ton découpage.
je ferais comme suit :
/dev/sda1 : uefi comme ci dessus
/dev/sda2 : ntfs, ton disque C de W8 avec le reste de la place disponible. Pour le partitionnement sur le SSD, vérifie l'alignement avec gParted

le reste sur /dev/sdb avec dans l'ordre le swap, le / (20 à 25 Mo) et le /home

Voilà, tu es armé pour la suite

#19 Re : -1 »  [Resolu] Problemes suite à une installation en UEFI » Le 18/05/2013, à 09:27

TGM
Réponses : 17

Et comment ça fonctionne maintenant ?

#20 Re : -1 »  [Abandonné] /boot/efi n'existe pas - Ubuntu 13.04 - Asus UX31A » Le 06/05/2013, à 21:14

TGM
Réponses : 30

Solution possible :
Restairation complète de W8.
Ta partition UEFI sera restaurée.
Installe normalement ensuite. Dans le pire des cas, laisse une partition W8 (le C:) a minima, en fonction de la place disponible sur ton disque. Cela permet parfois de se dépatouiller. J'ai été surpris (agréablement) de l'utilitaire de réparation ...
Con cernant le message /boot/efi, il faudrait savoir comment tu a recréé cette partition qui semble un peu subtile. A ma connaissance, elle devrait être la première sur le disque, suivie d'une partition réservée pour son extention (sda2). Ce n'est pas une règle générale, la miène étant en seconde position.
A l'installation, ton /boot doit être monté en /boot/efi.

Si tu n'a rien installé/effectué comme travaux depuis, fais une réinstallation complète, en choissant "autre chose" pour repartitionner ton disque et en installant les mise à jour en cours d'installation.

#21 Re : -1 »  [Abandonné] /boot/efi n'existe pas - Ubuntu 13.04 - Asus UX31A » Le 14/05/2013, à 21:14

TGM
Réponses : 30

Je en suis pas certain que la sauvegarde de ta partition et sa restauration soient suffisantes. Normalement, cela fonctionne correctement à partir où l'on crée un support de restauration à partir des outils fournis avec le système pré installé.
Si ton ami à la même machine que toi, demande lui de te faire un support de restauration pour remettre ton PC "en configuration d'origine".
Une fois cela fait, tu peux repartir pour une nouvelle installation.
A priori, pour installer from scratch ubuntu uniquement, tu as les partitions suivantes à créer :
une partition en début de disque d'environ 500Mo en fat32 qui sera montée en /boot/efi
ton swap
ton / environ 20 à 25 mo
ton /home avec le reste, dans le cas où tu souhaites un /home séparé.
Normalement, tout devrait se passer correctement.

Si tu souhaites conserver W8, cf. ci dessus ...

Bon courage

#23 Re : -1 »  Dual Boot Windows 8 Ubuntu 13.04 UEFI » Le 03/05/2013, à 17:42

TGM
Réponses : 5

Bonjour, si ça peut t'aider Ubuntu et W8. Voir aussi les différents sujets sur ce thème

#24 Re : -1 »  Installation Ubuntu 12.10 avec Windows 8 désormais possible » Le 22/02/2013, à 00:13

TGM
Réponses : 4

J'ai suivi globalement cette procédure.
Au redémarrage j'ai eu W8.
J'ai rebooté sur ma clé, installé boot-repair et lancé la chose (EFI détecté).
Je n'avais plus accès à W8
J'ai été obligé de passer par l'outil de réparation.
J'ai essayé avec rEFInd. Le boot loader ne marche pas, en ce sens que c'est toujours W8 qui se lance.
Pour le moment, c'est complètement KO
Un petit point ici