Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  Nouveautés dans Wily » Le 04/05/2015, à 20:10

Malizor
Réponses : 266

Si tôt descendu de son arbre, notre vervet vif se fait voler la vedette par un loup garou rusé.

Même si on ne s'attend toujours pas à de grandes nouveautés du côté du bureau Ubuntu par défaut, c'est principalement du côté de Unity 8 et de « Ubuntu Desktop Next » que les choses sérieuses devraient se faire sentir.

Ubuntu 15.10 est attendu pour octobre prochain.

Liste des principales nouveautés attendues/potentielles :

  • Retouches sur Unity 7 (suite du travail de fiabilisation, qui a déjà bien porté ses fruits dans les versions précédentes)

  • Première version « utilisable au quotidien » de Unity 8 sur le desktop

  • Gnome 3.16

  • Mesa 11

  • Noyau 4.1 voir 4.2

Ce sujet est dédié au suivi du développement d'Ubuntu 15.10.

#1 Re : -1 »  Nouveautés dans Wily » Le 20/05/2015, à 16:00

Malizor
Réponses : 266

Je table plutôt sur un noyau 4.2 dans Wily, vu que la 4.1 est déjà en rc4.

#2 Re : -1 »  Nouveautés dans Wily » Le 08/06/2015, à 14:17

Malizor
Réponses : 266

Xylolink était plus connu pour ses posts difficilement lisibles/compréhensibles que pour la qualité de ses contributions. Je ne pense pas qu'il soit nécessaire de s’étendre sur la question.

Du point de vue des nouveautés, je vous propose un petit point du côté des téléphones.
Déjà, après beaucoup de retard, tous les heureux propriétaires d'Ubuntu phones vont migrer vers Vivid cette semaine voir la semaine prochaine.

Sur Wily, Systemd devrait également remplacer Upstart sur les téléphones. C'est apparemment un prérequis pour le développement de futurs fonctionnalités (si quelqu'un a des détails...).

Un nouvel Ubuntu phone devrait être disponible des demain (9 juin) : le BQ e5. Il est très similaire au précédent e4.5, en un peu plus grand et puissant et donc un peu plus cher.
Le Meizu MX4 devrait quand à lui être disponible d'ici une ou deux semaines.

Un autre téléphone, toujours par BQ, a été teasé pour la fin de l'année. On parle ici d'un téléphone créé spécifiquement pour Ubuntu (même si une version Android sera aussi disponible) et qui devrait être le premier téléphone réellement convergent.
Les démos que nous avions vu précédemment utilisaient un code expérimental. Celui-ci est en train d'être revu et sera intégré aux versions par défaut de Mir et Unity 8 dans les semaines à venir.

#3 Re : -1 »  Nouveautés dans Wily » Le 08/06/2015, à 15:24

Malizor
Réponses : 266

Oui d'ailleurs j'ai pas très bien compris pour le coup.
Il me semblait que Snappy était la généralisation de Click et du système d'images système mis en place pour les téléphones.
Mais effectivement, vu que l'un des objectifs de Willy est de « passer les téléphones sur Snappy », j'imagine qu'il y a quand même des différences.

D'ailleurs, quelqu'un a testé Snappy ici ? Ça fait longtemps que j'ai envie d'essayer, mais j'ai pas encore eu l'occasion…

#4 Re : -1 »  Nouveautés dans Wily » Le 08/06/2015, à 17:44

Malizor
Réponses : 266

@didrocks : merci pour ta réponse.

Un truc qui me fait peur avec Snappy sur le desktop/serveur, c'est que pour le moment la mise à jour des images système sur le téléphone nécessite deux reboot (un pour remonter la partition système en écriture et upgrader puis un autre pour revenir en mode « normal »).
Autant ça ne me pose pas de soucis sur un téléphone qu'on upgrade une fois par mois, autant ça me parait être une régression sur un poste de travail ou serveur.

Par exemple le jour ou il y a une mise à jour d'OpenSSL on est obligé de tout rebooter alors qu'avant un upgrade simple suffisait.
C'est vraiment sensé marcher comme ça ou pas ?

#5 Re : -1 »  Nouveautés dans Wily » Le 08/06/2015, à 20:59

Malizor
Réponses : 266

@seb24 : sur la vidéo c'est LXD, pas Snappy.
LXD c'est un hyperviseur (comme KVM/Xen) mais dédié aux conteneurs. Ça n'a pas de rapport avec Snappy.

Sinon ton argument est pertinent, mais c'est plus un objectif qu'autre chose. En pratique dans les boites de tous les jours on a rarement ça. Et dans les startup on a pas forcément les moyens d'avoir des serveurs en rab pour faire ce genre de choses.
Je pense toujours qu'apt a de l'avenir sur beaucoup de serveurs. La question est donc de savoir si Ubuntu restera tout aussi pertinent sur ces machines si la maintenance des .deb était éventuellement délaissée par les devs.

#6 Re : -1 »  Nouveautés dans Wily » Le 09/06/2015, à 18:18

Malizor
Réponses : 266

Pour info, Snappy ressemble énormément à l'approche que cherche à mettre en place les gens de systemd/redhat.
http://0pointer.net/blog/revisiting-how … stems.html

Donc oui, le concept derrière Snappy a de l'avenir.
Maintenant, est-ce que toutes les distribs finiront par utiliser Snappy ou un éventuel futur concurrent, il est trop tôt pour le savoir.
Ubuntu est à l'avant garde pour le coup.

@SilentStorm : il y a déjà des isos disponibles pour tester. Il y a une iso minimale et, je ne sais pas si c'est déjà le cas, l'iso Ubuntu-desktop-next devrait être basée sur Snappy.

#7 Re : -1 »  Nouveautés dans Wily » Le 08/06/2015, à 19:04

Malizor
Réponses : 266

Comme tu le dis, on pouvais en effet redémarrer les services à la main si nécessaire. Et il y a « checkrestart » pour savoir ceux qui sont concernés.
Disons que je pourrai me laisser convaincre de l'utilité de Snappy sur le desktop (qui sont régulièrement éteins/redémarrés de toute façon).
Même si je pense que M. Michu se plaindra des demandes de reboot intempestives, il devrait en effet y avoir un gain de fiabilité appréciable.

Mais je suis dubitatif concernant les serveurs, où l'uptime est important.
Et quand on sait qu'il y a des serveurs Dell récents qui restent plus de 30 secondes sur le bios, on comprend pourquoi les admins cherchent à minimiser les reboots…
Alors on nous dit que Snappy ne sera pas obligatoire, donc il suffit de ne pas l'utiliser quand il apporte plus d'inconvénients que d'avantages.
Mais est-ce qu'il y aura toujours autant de main d'œuvre pour la maintenance des bon vieux .deb ?

#8 Re : -1 »  Nouveautés dans Wily » Le 31/07/2015, à 16:43

Malizor
Réponses : 266

@Oni_Shadow : déconnecte/reconnecte toi du forum. Ça devrait régler ton problème de messages en double.

#9 Re : -1 »  Nouveautés dans Wily » Le 01/08/2015, à 11:22

Malizor
Réponses : 266

La gestion du ventilateur de ma carte graphique (radeon 7970) fonctionne sous Wily, du coup je vais enfin pouvoir passer au pilote libre sans que ça fasse un bruit de moteur d'avion en permanence smile
Rien que pour ça, Wily sera forcément une excellente release en ce qui me concerne.

Sinon je n'ai pas vu beaucoup de nouveautés. Unity 7 est toujours là par défaut, toujours stable. Quelques composants Gnome ont été mis à jour en 3.16.
Tout se passe plutôt sous le capot, avec le passage à Python 3.5 et surtout à GCC 5, qui réclame énormément de travail aux développeurs (3500 paquets à recompiler, un certain nombre d'entre eux nécessitant d'être patchés).

Concernant les téléphones, le gros du travail continue sur Vivid, via un PPA qui vient en surcouche des dépôts habituels. Toutes les nouvelles fonctionnalités sont évidemment aussi poussées dans Willy, vu que tous les Ubuntu phones y migreront d'ici la fin de l'année.
Techniquement, Ubuntu Touch est effectivement une rolling release, avec une nouvelle version toutes les 6 semaines (au moins).

#10 Re : -1 »  Nouveautés dans Wily » Le 10/08/2015, à 22:56

Malizor
Réponses : 266

C'est toujours jouable pour Linux 4.2. Perso j'y crois.
Pour LibreOffice, actuellement c'est la 4.4.4 qui est inclue. Je ne sais pas s'il est prévu de passer en 5.0, mais ça ne m’étonnerait pas non plus.

N'oublions pas que Wily est une version pré-LTS, donc la logique est en général d'être le plus à jour possible pour pouvoir consacrer plus de temps à la stabilisation dans le cycle suivant.

#11 Re : -1 »  Nouveautés dans Wily » Aujourd'hui à 20:06

Malizor
Réponses : 266

Le 4.2 est déjà dans Wily/proposed.

Perso ce que j'aimerai c'est l'inclusion de Mesa 11, qui apporte de l'OpenGL 4+ pour les pilotes libres ainsi que de grosses améliorations de performances sur certaines cartes (ATI entre autre).
Upstream est toujours en RC2, mais la release est prévue ce mois-ci. Du coup je croise les doigts, même si au pire ça se met à jour à posteriori avec un PPA.

#12 Re : -1 »  Valve : Steam sous Linux (2) » Le 09/05/2015, à 15:40

Malizor
Réponses : 2169

Pour la démo je ne sais pas, mais pour le jeux complet chez moi c'est bien plus stable quand je lance la version 64 bits (mettre « %command%_64 » dans les options de lancement).

#13 Re : -1 »  Radio FM et d'autres questions » Le 24/06/2015, à 22:15

Malizor
Réponses : 9

1/ Que je sache, il n'y a pas de récepteur FM sur le e5. De toute façon, j'ai cru comprendre que le système ne le supportait pas encore.
2/ Il y a l'application Podbird dans le store. En cherchant "radio france" dedans on trouve bien plusieurs podcasts. J'en ai écouté un au pif et ça semble très bien fonctionner smile
3/ Je n'ai pas eu l'occasion d'utiliser le GPS. L'application Here est préinstallée sur les téléphones du commerces. Il y a plusieurs autres appli disponibles dans le store.
4/ Pas de libreoffice pour le moment. Il y a un visionneur de document, mais il ne fonctionne que pour les PDF.

#14 Re : -1 »  Radio FM et d'autres questions » Le 21/08/2015, à 19:38

Malizor
Réponses : 9

Ubuntu Touch ne supporte pas encore les tuner FM.
Je parle du système là, ce qu'il veut dire qu'il n'est même pas encore possible de créer une application FM, vu qu'il n'y a pas de moyen pour communiquer avec le tuner.

Cette fonctionnalité viendra bien un jour ou l'autre, mais je n'ai aucune idée de quand.

#15 Re : -1 »  Problème de synchronisation de l'audio sur certaine vidéo » Le 27/08/2015, à 14:55

Malizor
Réponses : 6

Bonjour,

Est-ce que le problème se produit depuis la mise à jour, ou était-ce le cas déjà avant ?
Si c'est une régression (et que tu parles un peu anglais), je t'invite à rapporter un bug et/ou a envoyer un mail sur ubuntu-phone@lists.launchpad.net.

#16 Re : -1 »  Problème de synchronisation de l'audio sur certaine vidéo » Le 27/08/2015, à 15:02

Malizor
Réponses : 6

Et les mêmes vidéos se lisent correctement sur un ordinateur Ubuntu (via Totem par exemple, qui utilise GStreamer comme les téléphones) ?

#17 Re : -1 »  Problème de synchronisation de l'audio sur certaine vidéo » Le 27/08/2015, à 20:52

Malizor
Réponses : 6

Il faut que tu rapportes un bug sur Launchpad alors.
Au préalable, essaye de voir s'ils y a un point commun entre les vidéos problématiques et si l'une d'elle est libre de droit (pour la donner aux développeurs pour qu'ils puissent reproduire le problème).

#18 Re : -1 »  [RESOLU]Virtualisation Ubuntu Touch » Le 20/08/2015, à 21:03

Malizor
Réponses : 2

Bonjour,

Si tu parles simplement d'un émulateur, il y en a un qui vient avec l'environnement de développement.
Il y a de la doc ici (en anglais).
Lors du choix du channel, choisi plutôt stable ou rc-proposed au lieu de devel (qui ne marche pas en ce moment il me semble).

Amuse toi bien !

#19 Re : -1 »  format audio » Le 11/08/2015, à 23:57

Malizor
Réponses : 2

Oui. Aucun souci pour lire les fichiers Flac. smile

#20 Re : -1 »  Nouveautés dans Vivid » Le 04/05/2015, à 16:37

Malizor
Réponses : 416

Ubuntu 15.10 « Wily Werewolf »

#21 Re : -1 »  Nouveautés dans Vivid » Le 04/05/2015, à 18:37

Malizor
Réponses : 416

Les ««««« paquets »»»»» Snappy sont générés à partir des paquets Debian. Snappy est une abstraction de plus haut niveau si vous préférez, mais ça ne remplace pas les paquets Debian.

#22 Re : -1 »  Greffon Arte+7 pour totem » Le 02/05/2015, à 17:52

Malizor
Réponses : 318

Même chose après avoir redémarré ?

#23 Re : -1 »  Greffon Arte+7 pour totem » Le 02/05/2015, à 17:59

Malizor
Réponses : 318

Pour moi ça n'a aucun rapport avec le greffon. Tu peux toujours essayer de le supprimer pour voir, mais a mon avis ça ne changera rien.

#24 Re : -1 »  Greffon Arte+7 pour totem » Le 02/05/2015, à 18:04

Malizor
Réponses : 318

Juste par acquis de conscience, quelle est la version de ton paquet « totem » ?
la sortie de « apt-cache policy » pourrait servir également.