Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  Client VPN avec accès au réseau local » Le 17/07/2012, à 15:00

tuxik
Réponses : 0

Bonjour,

J'ai configuré via network manager un VPN sur ma machine Ubuntu. Malheureusement, dès lors que j'active le VPN, la machine n'est plus accessible depuis mon réseau local (j'imagine que tout mon traffic de réseau local est déporté sur le VPN).

Je souhaiterais pouvoir laisser tourner ma machine connecté sur le VPN et de temps en temps l'administrer en passant par mon réseau local (SSH). Est ce que c'est possible ?
Que faut-il faire pour que cela fonctionne ?

Je vous remercie par avance,

Tuxik

#1 -1 »  [resolu] Script qui ne se lance pas dans programme au démarrage » Le 30/06/2012, à 15:18

tuxik
Réponses : 2

Bonjour,

Je souhaiterais lancer la commande suivante au démarrage de ma session :
nmcli con up id <ma_connexion_VPN>

Malheureusement, cela ne marche pas si je mets cette ligne dans "Applications au démarrage". J'ai donc créé un script pour lancer cette ligne de la même façon et stocker dans un fichier le résultat de ma commande (pour voir ce qu'il se passe). Mais je n'ai rien qui se passe.
Pourtant quant je lance le script depuis un terminal, le fichier est bien créé.

Voici le code de mon script :
#!/bin/bash
nmcli con up id "ma_connexion_VPN"  > vpn_access.log

J'ai paramétré ma session pour que je sois loggé automatiquement est ce que cela peut venir de la ?

Je vous remercie par avance pour votre aide.

Tuxik

#3 Re : -1 »  [nvidia 8500 gt]message erreur » Le 24/04/2012, à 13:10

tuxik
Réponses : 3

Problème identique.

A noter que dans mon cas, suite à la mise à jour de tout un tas de truc (dont le kernel en 3.0 !) je n'avais plus d'accéleration 3D. Lorsque j'ai réessayé d'installé les drivers qui fonctionnaient auparavant (ceux que Ubuntu propose via Accéleration materiel dans le panneau de config) 3 versions sur 4 ne marchaient pas (Erreur lors de l'installation).

#4 -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 15:18

tuxik
Réponses : 17

Bonjour à tous,

Je suis en pleine recopie de mon installation toute bien paramétré vers un nouveau disque dur tout neuf. Ma problématique est la suivante. J'ai utilisé la commande dd afin de procéder à la recopie

dd if=/dev/sdc1 of=/dev/sdb1 bs=4096

Je copie une installation faite sur une partition de 500Go (HDD) vers un autre disque avec une partition de 60Go (SSD) d'ou l'utilisation de cette instruction. Néanmoins, mon problème n'est pas la.

Suite )à cette manip. je me suis apercu que j'avais oublié de nettoyer le contenu de certain dossier (mon /home en faite) et que je dépassais les 55 Go alloué à la partition cible. Le dd c'est donc arrêté après avoir intégralement remplis mon disque.

J'ai vérifié si l'UUID de mon disque cible avait été écrasé par le dd et c'est bien le cas, je me retrouve donc avec deux UUID identiques.

J'ai voulut modifier l'UUID avec l'instruction :

sudo tune2fs -U mon_uuid  /dev/sdb1

Je n'ai aucune erreur et pourtant quant je relance :

sudo blkid

je ne vois pas de changement. Mes deux partitions ont toujours le même UUID.

Y a t-il une limitation avec ext4 pour la commande tune2fs ?
Existe-il une autre solution pour modifier mon UUID ?

Je n'ai pas encore "osez" redémarrer la machine de peur quelle ne se remonte pas avec ces deux UUID identiques.

#5 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 16:08

tuxik
Réponses : 17

Bonjour,

Merci pour cette réponse rapide !

Effectivement tu as raison, blkid a bien un cache. J'ai tenté de le flusher avec l'option -g et -c /dev/null :

Options vue dans le man :
-c cachefile

Read from cachefile instead of reading from the default cache file /etc/blkid/blkid.tab. If you want to start with a clean cache (i.e. don't report devices previously scanned but not necessarily available at this time), specify /dev/null.
-g
Perform a garbage collection pass on the blkid cache to remove devices which no longer exist.

Mais j'ai toujours la même chose. Mes deux partitions ont le même UUID.

#6 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 16:22

tuxik
Réponses : 17

Voici ce que j'ai exactement en faisant la manip :
L'UUID à été généré avec uuidgen

$ uuidgen -t
f78790ea-2985-11e1-b8d0-00241d71f123

Je tente de modifier l'UUID :

~$ sudo tune2fs -U f78790ea-2985-11e1-b8d0-00241d71f123 /dev/sdb1
tune2fs 1.41.14 (22-Dec-2010)

Visualisation des UUID 1 à 1 :

~$ sudo blkid /dev/sdc1
/dev/sdc1: UUID="f851d3a5-e552-4650-b6e0-edb75134bf1f" TYPE="ext4"
~$ sudo blkid /dev/sdb1
/dev/sdb1: UUID="f851d3a5-e552-4650-b6e0-edb75134bf1f" TYPE="ext4"

Résultat sdb1 n'a pas changé d'UUID. C'est vraiment bizarre, hormis redémarrer pour potentiellement purger un cache, je vois pas. Est ce que le redémarrage peut poser un problème ?

#7 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 16:50

tuxik
Réponses : 17

Hallucinant, c'est pareil ca fait rien. Comme si il y avait un problème de droit d'écriture quelque part !

$ sudo tune2fs -U random  /dev/sdb1
tune2fs 1.41.14 (22-Dec-2010)
$ sudo blkid -c /dev/null
/dev/sdb1: UUID="f851d3a5-e552-4650-b6e0-edb75134bf1f" TYPE="ext4"
/dev/sdc1: UUID="f851d3a5-e552-4650-b6e0-edb75134bf1f" TYPE="ext4"

#8 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 16:55

tuxik
Réponses : 17

Je viens de m'apercevoir d'un truc, lorsque je lance la commande suivante :

$ sudo ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2011-12-18 14:01 39d4f4b0-63b1-4b2f-b4b5-f6c989b435f2 -> ../../sda2
lrwxrwxrwx 1 root root 10 2011-12-18 14:01 3cfb4879-b5b6-43e7-ab20-03c45485b238 -> ../../sdb2
lrwxrwxrwx 1 root root 10 2011-12-18 14:01 b347084e-564b-4547-b987-2412040ef4a2 -> ../../sdc5
lrwxrwxrwx 1 root root 10 2011-12-18 14:01 b81f77d4-1e70-4b2f-90f8-04adc01892ac -> ../../sda1
lrwxrwxrwx 1 root root 10 2011-12-19 16:47 f851d3a5-e552-4650-b6e0-edb75134bf1f -> ../../sdb1

Cette commande doit faire l'équivalent de blkid normalement.

Je ne vois pas mon disque sdc1 (la source de ma copie et donc l'actuelle partition de mon système Ubuntu). Est-ce normal d'après toi ? Ou bien est ce que cela ne soulignerai pas un problème d'autorisation sur un fichier quelconque ?

#9 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 17:01

tuxik
Réponses : 17

Je vois bien tous mes disques et partitions avec sudo fdsik -l

#10 Re : -1 »  [Résolu] tune2fs et ext4 » Le 19/12/2011, à 17:17

tuxik
Réponses : 17

Ok je vais regarder ça a tête reposer ce soir, histoire de pas faire de bêtise.

Merci en tout cas pour ces retours très constructifs.

#11 Re : -1 »  [Résolu] tune2fs et ext4 » Le 20/12/2011, à 10:12

tuxik
Réponses : 17

Après quelques heures de bidouillage intensif et de débroussaillage du net grace à Google, j'ai fini par identifier la cause la plus probable de la non modification de mon UUID lorsque je tape la commande tune2fs.
Ma table de partition a été modifiée lors du dd. Je me retrouve donc avec une table complètement incohérente sur mon disque cible. Pour rappel, mon disque cible est bien plus petit que le disque source, du coup je pense que tune2fs qui doit se baser la dessus ne comprend pas ce que je lui demande.

Je suis tombé sur un post de forum ( http://gparted-forum.surf4.info/viewtopic.php?id=14172) qui traite d'un problème similaire. L'idée est d'exporté la table de partition dans un fichier texte, de remettre les bonne valeurs dans le fichier texte puis de recharger la table de partition sur le disque. Le problème c'est que je ne suis pas capable de définir les bonnes valeurs. Je ne suis pas dans un cas aussi simple que le post car mon disque contient 2 partitions (une swap et une ext4) et je ne sais pas comment retrouver les valeurs pour ces deux partitions.

Je suis donc passé à une autre idée, reformater ma partition. Mon disque source étant encore remplis des données nécessaires, je n'ai pas de nécessité particulière à garder le contenu de mon disque cible.

Mon problème est par contre qu'avec Gparted, j'ai une erreur, il ne s'en sort pas et je n'ai pas accès à l'option permettant de supprimer les partitions du disque ou même de faire une quelconque action. Je suis en train de chercher comment faire avec parted en ligne de commande, mais je ne suis pas sur que cela donnera beaucoup plus de résultats.

Si par hasard, quelqu'un passant par ici aurait déjà rencontré ce type de problème et aurait une solution je suis preneur, sinon, je vous tiens au courant.

#12 Re : -1 »  [Résolu] tune2fs et ext4 » Le 26/12/2011, à 13:35

tuxik
Réponses : 17

Bonjour,

J'ai donc pu résoudre mon problème.

Le problème de Tune2fs qui ne faisait rien sans me sortir une erreur était lié au faite que ma table de partition du disque était inconsistante (le nombre de secteurs et de blocs étaient bien au dessus de la taille du disque et ce car la commande dd que j'avais fait au préalable a écraser ma table de partition avec celle contenu sur le disque source). J'ai donc fait :


Sauvegarde de la table de partition :

 sudo sfdisk -d /dev/sdb > PT.txt 

Editer le fichier PT.txt avec un éditeur de fichier classique
Mettre des valeurs cohérentes pour start et size de chaque partition (à voir en fonction de la tyaille de chaque disque)
Reécrire la table de partition sur le disque :

sudo sfdisk -f /dev/sdb -O PT.save < PT.txt

Ensuite tout devrait remarcher.

Merci aux personnes qui ont répondu et qui ont ainsi pu m'aider à mieux cerner mon problème.

A+

#13 -1 »  Erreur lors de l'installation de lirc » Le 05/07/2011, à 15:43

tuxik
Réponses : 6

Bonjour,

J'ai une erreur à l'installation du paquet LIRC (Gestion des télécommandes infrarouge).

Paramétrage de lirc (0.8.7-0ubuntu4.2) ...                                                                                                                                                                                           
dpkg : erreur de traitement de lirc (--configure) :                                                                                                                                                                                  
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 20

Y a t-il d'autres personnes dans mon cas ? Y aurait-il des gens qui aurait trouvé une solution ?

Je suis sous Ubuntu 11.04 kernel : 2.6.38-10-generic

#14 Re : -1 »  Erreur lors de l'installation de lirc » Le 05/07/2011, à 16:18

tuxik
Réponses : 6

lirc_0.8.7-0ubuntu4.2_i386.deb

A noter que j'ai vaguement essayé d'installer depuis la version 0.9.0_i386 dispo. ici (version a priori intégrée dans la prochaine version de ubuntu
Sans succès pour le moment.

#15 Re : -1 »  Erreur lors de l'installation de lirc » Le 05/07/2011, à 18:51

tuxik
Réponses : 6

Hello,

J'ai eu un semblant d'espoir avec ta solution. Effectivement je ne l'avais pas encore fait et ce type de manipulation m'avait déjà dépanné par le passé.
Mais ....

~$ sudo apt-get install lircLecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  lirc-modules-source lirc-x
Les NOUVEAUX paquets suivants seront installés :
  lirc
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/545 ko dans les archives.
Après cette opération, 2 716 ko d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
Sélection du paquet lirc précédemment désélectionné.
(Lecture de la base de données... 409837 fichiers et répertoires déjà installés.)
Dépaquetage de lirc (à partir de .../lirc_0.8.7-0ubuntu4.2_i386.deb) ...
Traitement des actions différées (« triggers ») pour « doc-base »...
Processing 1 added doc-base file(s)...
Registering documents with scrollkeeper...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « hal »...
Regenerating hal fdi cache ...
Traitement des actions différées (« triggers ») pour « ureadahead »...
Paramétrage de lirc (0.8.7-0ubuntu4.2) ...
dpkg : erreur de traitement de lirc (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 20
Des erreurs ont été rencontrées pendant l'exécution :
 lirc
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et ça avec la deuxième comme la première solution.

Je me rappel que le fichier devait être post fixer par "postinst" ou par autre chose en fonction du code retour mais impossible de remettre la main sur le document ou j'avais lu ca.

#16 Re : -1 »  Erreur lors de l'installation de lirc » Le 05/07/2011, à 19:10

tuxik
Réponses : 6

Le fichier status-old était bien présent.

J'ai donc fait comme indiqué

  499  cp /var/lib/dpkg/status /var/lib/dpkg/status-back
  500  sudo cp /var/lib/dpkg/status /var/lib/dpkg/status-back
  501  sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
  502  sudo apt-get remove lirc
  503  sudo apt-get install lirc
  504  history 

Mais j'ai le même problème.  Pourtant je continue de croire que c'est le paquet qui a un soucis.

En tout cas merci pour ton aide.

#17 -1 »  Résolution écran incorrect » Le 13/09/2010, à 18:24

tuxik
Réponses : 0

Hello,

J'ai branché mon PC sur ma TV écran plat via un cable HDMI.

Ça a marché sans plus de config. que ça de ma part. J'ai par contre un petit soucis. Une partie de l'écran n'est pas affiché (tous les bords de mon écran en faite). Le changement de résolution ne donne rien, j'ai toujours mes coin qui sont cachés même si toute la superficie de l'écran n'est pas utilisé (bandes noires).

Pourtant si je me connecte sur une session à distance via un utilitaire type VNC, j'affiche bien la totalité de mon écran.

J'ai installé les drivers proprio idem. Pas de changement. Est ce que l'un de vous aurait il une piste ?

Merci

Tuxik

#18 -1 »  [Resolu] Paquet cassé impossible à supprimer » Le 22/08/2010, à 16:06

tuxik
Réponses : 2

Bonjour,

Je rencontre un problème avec le paquet mediatomb-daemon. Il est cassé, j'ai donc essayé de le supprimer mais impossible.

L'erreur retournée est la suivante :

E: mediatomb-daemon: le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 2

Le détail de l'erreur :

(Lecture de la base de données... 190944 fichiers et répertoires déjà installés.)
Suppression de mediatomb-daemon ...
dpkg (sous-processus) : impossible d'exécuter script pre-removal installé: Erreur de format pour exec()
dpkg : erreur de traitement de mediatomb-daemon (--remove) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 2
dpkg (sous-processus) : impossible d'exécuter script post-installation installé: Erreur de format pour exec()
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
 mediatomb-daemon
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :

Je suis sous Ubuntu 9.10  kernel 2.6.31.21

Merci d'avance pour votre aide.

Tuxik

#19 Re : -1 »  [Resolu] Paquet cassé impossible à supprimer » Le 22/08/2010, à 16:23

tuxik
Réponses : 2

Ok Merci beaucoup, je n'avais pas vue cette page.

Il m'a par contre fallut modifier les fichiers .postrm et .prerm avec les éléments suivants :
#!bin/sh
set -e
exit 0

#20 Re : -1 »  Installation minimal gnome sur un serveur » Le 26/03/2010, à 20:52

tuxik
Réponses : 18
Screamer@onthelan a écrit :

crée en un manuellement:

sudo /etc/init.d/gdm stop
sudo Xorg -configure
sudo /etc/init.d/gdm restart

Bon alors, déjà ça m'aide un peu car je me suis aperçu que gdm n'était pas installer (pourtant il me semblait l'avoir fait...)
Du coup je l'ai installer avec ses dépendances.

Ensuite, au démarrage de gdm j'ai ca

gdm-binary[3863]: WARNING: Unable to load file '/etc/gdm/custom.conf': Aucun fichier ou dossier de ce type
gdm-binary[3863]: WARNING: Unable to find users: no seat-id found
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,122313 seconds
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,135612 seconds
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,123727 seconds
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,124081 seconds
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,131210 seconds
gdm-binary[3863]: WARNING: GdmDisplay: display lasted 0,128250 seconds
gdm-binary[3863]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors

#21 Re : -1 »  Installation minimal gnome sur un serveur » Le 26/03/2010, à 21:12

tuxik
Réponses : 18
Screamer@onthelan a écrit :

pour retirer gdm des processus lancés au boot

sudo update-rc.d gdm remove

le remettre

sudo update-rc.d gdm default

pour ton message d'erreur concernant gdm, pas d'idée. Si ce n'est qu'il cherche un default fichier qui ne semble pas etre présent..
Regarde tes logs pour avoir plus d'informations.

Ca veut dire que je l'ai viré ou pas  ?

update-rc.d: /etc/init.d/gdm exists during rc.d purge (use -f to force)

#22 Re : -1 »  Installation minimal gnome sur un serveur » Le 26/03/2010, à 21:17

tuxik
Réponses : 18
Qid a écrit :
Screamer@onthelan a écrit :

pour retirer gdm des processus lancés au boot[...]

évidemment vu comme ça ... enfin je maintiens que si c'est pour le desactiver du boot autant ne pas l'avoir dutout wink

C'est juste pour être sur que le serveur ne plante pas au prochain redémarrage. Sans écran sinon c'est compliqué big_smile

#23 Re : -1 »  Installation minimal gnome sur un serveur » Le 26/03/2010, à 21:59

tuxik
Réponses : 18
Qid a écrit :
tuxik a écrit :

Je souhaiterais maintenant disposer d'un environnement gnome afin de me connecter via VNC (la machine n'a pas décran).

toujours la meme question ultime : t'a cherché un peu sur notre amis le gogole ?
parce que moi je viens de faire la recherche "lancer un serveur X sans écran"
et en tete de la 3ieme page des réponses obtenues je suis tombé sur un article
qui semble répondre à tes attentes et meme plus ... d'ailleurs j'adore son titre :
"pas-d-ecran-pas-de-chocolat" big_smile

Effectivement ça semble parfait.

Je suis partis sur l'installation du paquet X11vnc.

Mais je bloque à la configuration de gdm.conf. Ce fichier n'existe pas. Pourtant gdm est bien installé.

#24 Re : -1 »  Installation minimal gnome sur un serveur » Le 26/03/2010, à 22:15

tuxik
Réponses : 18
Screamer@onthelan a écrit :

essaye

sudo dpkg --configure gdm

il va tenter de relancer le process de configuration initial.

Merci pour la commande.

Ca génére une erreur (impossible de configurer gdm). J'ai regardé dans syslog et j'ai ca :

Mar 26 22:01:01 HomeServer kernel: [ 1084.157330] [drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22
Mar 26 22:01:01 HomeServer gdm-simple-slave[2736]: WARNING: Unable to load file '/etc/gdm/custom.conf': Aucun fichier ou dossier de ce type
Mar 26 22:01:01 HomeServer kernel: [ 1084.253358] [drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22
Mar 26 22:01:01 HomeServer gdm-binary[2714]: WARNING: GdmDisplay: display lasted 0,131672 seconds
Mar 26 22:01:01 HomeServer kernel: [ 1084.289326] [drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22
Mar 26 22:01:01 HomeServer gdm-simple-slave[2741]: WARNING: Unable to load file '/etc/gdm/custom.conf': Aucun fichier ou dossier de ce type
Mar 26 22:01:01 HomeServer kernel: [ 1084.385423] [drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22
Mar 26 22:01:01 HomeServer gdm-binary[2714]: WARNING: GdmDisplay: display lasted 0,127678 seconds
Mar 26 22:01:01 HomeServer gdm-binary[2714]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
Mar 26 22:01:01 HomeServer kernel: [ 1084.417330] [drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22

Visiblement le faite que je n'ai pas d'écran bloque la création de se fichier.