Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 4

#0 -1 »  Flash et Ubuntu 8.10 64 bits » Le 01/11/2008, à 14:33

Jmgr
Réponses : 37

Salut à tous,

je suis passé d'Ubuntu 8.04 (64bits également) à la 8.10, et hélas cela a provoqué l'arrêt du fonctionnement de flash pour Firefox.

J'ai tenté de multiples manipulations à partir de tutos trouvés sur Google et dans la doc, mais sans succès.
Mon dernier essai en utilisant nspluginwrapper et la version 10 de flash d'Adobe se solde par un échec avec le message

LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so: mauvaise classe ELF: ELFCLASS32

lors du chargement de pages avec du Flash...

Donc voila je suis un peu désespéré, j'aimerais cambrioler les locaux d'Adobe pour compiler leur plugin en 64 bits (ça doit pouvoir se faire en 5 min), mais bon cela ne me semble pas trop possible.

Bref si quelqu'un a une idée...

#1 Re : -1 »  Flash et Ubuntu 8.10 64 bits » Le 02/11/2008, à 12:15

Jmgr
Réponses : 37

Ah oui bonne idée, donc moi j'ai :
Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

Shockwave Flash
Nom de fichier : npwrapper.libflashplayer.so
Shockwave Flash 10.0 r12

#2 Re : -1 »  Flash et Ubuntu 8.10 64 bits » Le 02/11/2008, à 23:23

Jmgr
Réponses : 37

Hm ça ne marche pas mieux chez moi, maintenant dans about:plugins j'ai :

Shockwave Flash

    Nom de fichier : npwrapper.libflashplayer.so
    Shockwave Flash 10.0 r12

Type MIME     Description     Suffixes     Autorisé
application/x-shockwave-flash     Shockwave Flash     swf     Oui
application/futuresplash     FutureSplash Player     spl     Oui

Ya un moyen simple de "faire le vide" de tous les plugins FF liés au flash pour repartir sur de bonne bases ?

#3 Re : -1 »  Flash et Ubuntu 8.10 64 bits » Le 03/11/2008, à 00:19

Jmgr
Réponses : 37

Bon, j'ai recherché et renommé tous les libflashplayer.so en libflashplayer.so.old et j'ai réussi à avoir FF sans plugin Flash. J'ai ensuite réinstallé flashplugin-nonfree.

Maintenant quand je veux lire du flash j'ai droit à ça :

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x500001a unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000019 unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000018 unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000003 unexpectedly destroyed

(npviewer.bin:30273): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 232 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(firefox:30246): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed
*** NSPlugin Wrapper *** ERROR: NPP_NewStream() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_Destroy() invoke: Connection closed

(firefox:30246): GLib-CRITICAL **: g_hash_table_remove_internal: assertion `hash_table != NULL' failed
*** NSPlugin Wrapper *** ERROR: NPObject 0x3f501a0 is not valid!

Je crois que je vais tenter la méthode qui consiste à installer une version 32 bits de FF...