Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  Annuaire de réparateurs ? » Le 27/06/2015, à 10:34

nagadoudi
Réponses : 12

Bonjour,

Existe-t-il un annuaire de professionnels du dépannage Linux ?

J'ai quelquefois des problèmes sur l'ordi, mais pas toujours la patience, le temps et les compétences pour le réparer moi-même. J'aimerais pouvoir le confier à un réparateur près de chez moi.

#1 Re : -1 »  Annuaire de réparateurs ? » Le 27/06/2015, à 11:25

nagadoudi
Réponses : 12

Oui, j'ai vu ça, mais ça ne répond pas à mon besoin. Il s'agit plus de petites annonces de vente d'ordi.

J'aimerais un annuaire de réparateurs par départements.

#2 Re : -1 »  Annuaire de réparateurs ? » Le 29/06/2015, à 10:14

nagadoudi
Réponses : 12

Merci pour vos réponses. En gros, pas de structures commerciales mais des bénévoles qui veulent bien. Sauf Tiramiseb qui a son entreprise.

tiramiseb a écrit :

Et si t'as la chance d'être à côté de chez moi, y'a moi

Je note ton adresse, merci.

tiramiseb a écrit :

t'es quand même pas mal plus au nord...

Merci aussi pour ta piqûre de rappel quant au non anyonymat sur le net. Depuis mon message tu as su retrouver mon adresse physique facilement.

#3 Re : -1 »  Annuaire de réparateurs ? » Aujourd'hui à 09:32

nagadoudi
Réponses : 12
Qid a écrit :

C'est le concept même du logiciel libre qui veux ça... mais en fait j'aurai pu aussi te répondre par une question : pour toi c'est quoi un professionnel?

Je pratique beaucoup les échanges de services avec les amis et j'adore ça. Mais quelquefois j'ai besoin que ça aille vite. Un professionnel c'est quelqu'un qui a une boutique, tu lui apportes le matos et il le fait rapidement. Tu sais que si tu lui apportes l'ordi le matin, tu peux le récupérer le soir. Puis tu te sens pas redevable parce que tu le paies.
Bref c'est une logique marchande qui peut aussi avoir ses avantages.

Ayral a écrit :

Et des photos de ta maison dans 3615 mavie !

Je suis foutu !

#4 Re : -1 »  [Résolu] SSHFS pédale dans la semoule » Le 19/05/2015, à 21:16

nagadoudi
Réponses : 8

Pour compléter, j'ai le même problème sur 2 ordi (Ubuntu et Xubuntu donc avec Thunar), quelle que soit la version du noyau.
Dans les 2 cas, sshfs -V indique :
    SSHFS version 2.5
    FUSE library version: 2.9.2
    fusermount version: 2.9.2
    using FUSE kernel interface version 7.19

#5 -1 »  [Résolu] SSHFS pédale dans la semoule » Le 19/05/2015, à 09:15

nagadoudi
Réponses : 8

Bonjour,

Depuis peu, mon montage de fichiers en SSHFS foire.

1. Je monte le système de fichiers distants comme d'hab.

bob@ordi:~$ sshfs bob@example.com: /media/sites/example.com
bob@example.com's password: 
bob@ordi:~$

2. Je liste le contenu du dossier en ligne de commande : OK.

bob@ordi:~$ ls /media/sites/example.com
bidule  logs          ml         piwik-archive.log  static  storage  www
datas   logs-encours  oldstatic  progs              stats   tmp      www.original
bob@ordi:~$

3. Je cherche à afficher le contenu avec nemo : il pédale dans le vide. Idem avec Nautilus.
Concrètement, il semble charger sans fin. Le curseur de la souris passe en mode « occupé » et la partie principale de la fenêtre reste vide au lieu d'afficher le contenu du dossier.

4. Après avoir tenté avec nemo ou nautilus, même la ligne de commande pédale dans le vide.

bob@ordi:~$ ls /media/sites/example.com

Il ne rend plus la main. Si j'appuie sur les touches « flèches » du clavier :

bob@ordi:~$ ls /media/sites/example.com
^[[C^[[D^[[B^[[A

5. Il n'y a plus qu'un moyen de récupérer les applis : démonter le dossier (en ouvrant une nouvelle console).

bob@ordi:~$ fusermount -u /media/sites/example.com
fusermount: failed to unmount /media/sites/example.com: Device or resource busy
bob@ordi:~$ fusermount -uz /media/sites/example.com
bob@ordi:~$ 

Je ne sais pas de quel côté chercher. Y a-t-il des logs à analyser (sshfs ? nemo ? côté serveur ?) Une manip à faire pour voir s'afficher d'éventuelles erreurs ? Merci de bien vouloir m'aider.

#6 Re : -1 »  [Résolu] SSHFS pédale dans la semoule » Le 20/05/2015, à 09:35

nagadoudi
Réponses : 8

Merci pour ta contribution michel_04. Ça semble donc lié à la version du client et non au serveur sur lequel je me connecte. Mais qui est en cause : sshfs, fuse library, fusermount... ? Et que faire pour avancer, sinon attendre qu'une mise à jour soit proposée (ça peut mettre du temps) ?

#7 Re : -1 »  [Résolu] SSHFS pédale dans la semoule » Le 20/05/2015, à 13:33

nagadoudi
Réponses : 8

Tu veux dire que tu n'as pas de bug ?

#8 Re : -1 »  [Résolu] SSHFS pédale dans la semoule » Le 20/05/2015, à 16:14

nagadoudi
Réponses : 8

Ah, OK, j'avais mal compris. Ça vient donc probablement du serveur sur lequel je me connecte.

Je vais vois ça. Merci !

#9 Re : -1 »  [Résolu] SSHFS pédale dans la semoule » Le 20/05/2015, à 16:17

nagadoudi
Réponses : 8

Je confirme. J'ai trouvé un autre serveur sur lequel me connecter en SSHFS et tout fonctionne. Je vais m'adresser au gérant du serveur qui bug. Ce fil de discussion est donc résolu !

Merci encore, michel_04.

#10 Re : -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 22:36

nagadoudi
Réponses : 6
jacobus77 a écrit :

Sinon tu ne fourni pas assez d'info pour que l'on puisse vraiment t'aider à cerner l'origine du pb.

Je ne sais pas si tu penses à des info en particulier ou non.
Sinon, je continue le test d'association du noyau et du disque externe. Pour l'instant, ça semble fonctionner avec un ancien noyau et le disque allumé.

#11 Re : -1 »  [RESOLU] Ordinateur très lent » Le 25/04/2015, à 11:07

nagadoudi
Réponses : 6
nagadoudi a écrit :

Je vais surveiller le comportement de l'ordi en fonction du disque du externe allumé ou éteint et de la version du noyau Linux sur laquelle j'ai démarré.

C'est bien le disque dur externe qui est en cause. Car lorsqu'il est allumé et branché, l'ordi rame comme pas possible, indépendamment de la version du noyau. Et lorsqu'il est éteint, tout va bien.

C'est un dysfonctionnement qui est apparu avec le temps, car jusqu'à peu, il fonctionnait bien et je m'en servais pour mes sauvegardes.

Merci encore pour ton aide, jacobus77. J'adore cette idée de la solidarité qui se vit tous les jours sur le net.

#12 -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 09:27

nagadoudi
Réponses : 6

Salut à tous et à toutes,

Ces derniers temps, l'ordi a tendance à devenir extrêmement lent au fur et a mesure de la session.
Ce n'est pas parce qu'il est vieux, car il reste rapide en début de session.
Ce n'est pas parce qu'il est trop chargé, car ça arrive aussi quand la mémoire vive est vide et le processeur inutilisé. Il reste pas mal de place sur le disque dur.

J'ai regardé du côté de dmesg après le ralentissement de la bécane :

$ dmesg | tail
[ 3760.308695]  [<ffffffff811f5ef1>] SyS_ioctl+0x81/0xa0
[ 3760.308703]  [<ffffffff8178c1ad>] system_call_fastpath+0x1a/0x1f
[ 3760.308709] ---[ end trace 8d5b9b265f903d68 ]---
[ 3950.801791] systemd-hostnamed[4705]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[ 4707.157372] audit: type=1400 audit(1429685709.749:46): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/mysqld" pid=7030 comm="apparmor_parser"
[ 4710.681074] audit: type=1400 audit(1429685713.273:47): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/mysqld" pid=7104 comm="apparmor_parser"
[ 7054.760311] systemd-hostnamed[7842]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[ 7857.157638] perf interrupt took too long (10012 > 10000), lowering kernel.perf_event_max_sample_rate to 12500
[ 8688.094278] 7z[8508]: segfault at 7fffbd039541 ip 00007f037eb04719 sp 00007ffebd0393e0 error 6 in 7z.so[7f037e9d6000+18f000]
[ 8692.105429] 7z[8511]: segfault at 7ffe03097c51 ip 00007f99b90b8719 sp 00007ffd03097af0 error 6 in 7z.so[7f99b8f8a000+18f000]

Et une autre fois :

$ dmesg | tail
[  250.829813] sd 2:0:0:0: [sdb] Write Protect is off
[  250.829832] sd 2:0:0:0: [sdb] Mode Sense: 38 00 00 00
[  250.836723] sd 2:0:0:0: [sdb] No Caching mode page found
[  250.836742] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[  250.952346]  sdb: sdb1
[  250.976842] sd 2:0:0:0: [sdb] Attached SCSI disk
[  253.765228] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[  259.001076] perf interrupt took too long (2526 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[  715.566736] perf interrupt took too long (5122 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 1830.788870] systemd-hostnamed[4378]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

C'est ça qui me questionne : “perf interrupt took too long (5122 > 5000), lowering kernel.perf_event_max_sample_rate to 25000”. Est-ce que ça pourrait en être la cause ? Comprenez-vous de quoi il s'agit ?

Ma config :
  - Distri : Ubuntu 14.10
  - Noyau / kernel : 3.16
  - Mémoire vive : 3,9 Gio
  - Processeur : Intel® Atom™ CPU D510 @ 1.66GHz × 4

#13 Re : -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 22:34

nagadoudi
Réponses : 6

Merci à toi jacobus77.

Je vais surveiller le comportement de l'ordi en fonction du disque du externe allumé ou éteint et de la version du noyau Linux sur laquelle j'ai démarré.

Je n'arrive pas à récupérer les infos SMART du disque dur externe, ni avec gnome-disks, ni avec smartmontools. Le 1er grise l'entrée du menu et le 2nd affiche ceci :

$ sudo smartctl --smart=on --offlineauto=on --saveauto=on /dev/sdb1 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.2.0-67-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
unable to enable Exception control and warning [unsupported scsi opcode]
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


$ sudo smartctl --smart=on --offlineauto=on --saveauto=on -T permissive /dev/sdb1 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.2.0-67-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
unable to enable Exception control and warning [unsupported scsi opcode]
Enable autosave (clear GLTSD bit) failed

Pour info, ça fonctionne bien pour mon disque dur interne dans les 2 cas.
→ C'est inquiétant ou non ? (C'est un Samsung HD103SI de 1 To.)

#14 Re : -1 »  [RESOLU] Ordinateur très lent » Le 28/04/2015, à 11:13

nagadoudi
Réponses : 6

D'autres diagnostics :
  - Sur mon autre ordinateur (Xubuntu 14.10), pas de soucis, le disque dur ne ralentit pas le système.
  - J'ai mis à jour mon ordi principal vers Ubuntu 15.04 (noyau 3.19) et le soucis est maintenant réglé ! C'était donc bien un dysfonctionnement lié au kernel.

(Le système de fichiers est EXT4.) Merci beaucoup pour tes pistes de réflexion jacobus77. C'est bon à prendre pour la culture G et si ce problème ou d'autres surviennent à nouveau.

#15 Re : -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 01/09/2014, à 23:17

nagadoudi
Réponses : 16
tiramiseb a écrit :

Alors tu as désinstallé le logiciel, mais son instance en fonctionnement, elle, elle était toujours là...

Je ne pense pas car j'ai redémarré plusieurs fois entre temps.

tiramiseb a écrit :

Il me semble que la logithèque ne propose pas la liste de tous les paquets, seulement ceux « orientés utilisateur ».

On a habituellement un lien « Voir les n éléments techniques » en bas. Je l'avais utilisé pour supprimer ces paquets non orientés utilisateurs.
Sur la capture, ce lien n'apparaît plus.
Je pense que pour la logithèque, zeitgeist était vraiment complètement supprimé.

f.x0 a écrit :

pour savoir quels paquets liés à zeitgeist sont réellement installés,
la commande est :

dpkg -l *zeitgeist* | grep "ii"

Merci. Ça annonce qu'il me reste libzeitgeist-1.0-1 et libzeitgeist-2.0-0:amd64, de simples biblio. Donc cette fois, c'est bon.

#16 Re : -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 02/09/2014, à 09:54

nagadoudi
Réponses : 16

Après avoir désinstallé le programme zeitgeist, j'ai supprimé le dossier ~/.local/share/zeitgeist car il contenait pas mal de données binaires (base de données) dont j'ignorais le contenu... probablement des infos liées à mon historique.

#17 -1 »  Dropbox en tant que super-utilisateur ? » Le 04/12/2014, à 11:56

nagadoudi
Réponses : 6

Bonjour,

Depuis quelques temps, une fenêtre « S'authentifier » apparaît à chaque ouverture de session et me demande le mot de passe super utilisateur pour le logiciel Dropbox.

J'aimerais savoir pourquoi ce logiciel fermé me demande le mot de passe root. Est-ce possible ? Le feriez-vous à ma place ?

À noter que si j'annule, Dropbox reste parfaitement fonctionnel. C'est juste pénible d'avoir ce message tous le jours.

Le message :

« Il est nécessaire de s'authentifier pour lancer le programme « /usb/bin/dropbox » en tant que super-utilisateur

Une application tente d'effectuer une action qui nécessite des privilèges. Pour effectuer cette action, il est nécessaire de s'authentifier. »

Capture du message

J'utilise une version de Dropbox à jour (v2.10.52)

Merci.

#18 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 04/12/2014, à 20:13

nagadoudi
Réponses : 6
tiramiseb a écrit :

As-tu lancé, à un moment ou à un autre, dropbox en root (avec sudo par exemple) ?

Salut,
Non

#19 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 05/12/2014, à 12:15

nagadoudi
Réponses : 6

Je pose la question sur le forum officiel...

Existe-t-il un outil qui me permette de surveiller ce qu'il fait si je valide sa demande ? Par exemple, va-t-il envoyer mes marque-pages à la maison mère, etc. ?

#20 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 05/12/2014, à 10:22

nagadoudi
Réponses : 6

C'est très agréable de se sentir pris en charge. Merci tiramiseb.

La commande donne ceci :

$ ls -lh .config/autostart
total 48K
-rw-rw-r-- 1 plop plop 169 janv.  9  2012 amule.desktop
-rw-rw-r-- 1 plop plop 175 oct.   5  2012 banshee.desktop
-rw-r--r-- 1 plop plop 235 déc.   5 08:02 dropbox.desktop
-rw-rw-r-- 1 plop plop 198 oct.   5  2012 exaile.desktop
-rw-rw-r-- 1 plop plop 195 oct.  21 22:41 gpodder.desktop
-rw-rw-r-- 1 plop plop 100 avril  4  2014 hubic.desktop
-rw-rw-r-- 1 plop plop 286 sept.  1 10:03 indicator-application.desktop
-rw-rw-r-- 1 plop plop 16K déc.   5 08:01 indicator-multiload.desktop
-rw-rw-r-- 1 plop plop 238 oct.   9  2013 transmission-gtk.desktop

Le contenu du fichier ~/.config/autostart/dropbox.desktop :

[Desktop Entry]
Name=Dropbox
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
Exec=dropbox start -i
Terminal=false
Type=Application
Icon=dropbox
Categories=Network;FileTransfer;
StartupNotify=false

Extrait de man dropbox :

dropbox start [-i]
  Starts the dropbox daemon, dropboxd. If dropboxd is already running, this will do nothing.
  options:
    -i --install  auto install dropboxd if not available on the system

La commande ps aux | grep dropbox donne quelque chose qui ressemble à ça :

USER PID %CPU %MEM   VSZ    RSS  TTY STAT START TIME COMMAND
plop 3375 0.7  2.5 2456100 103956 ?   Sl  08:01 0:31 /home/plop/.dropbox-dist/dropbox-lnx.x86_64-2.10.52/dropbox /newerversion

#21 -1 »  [résolu] Droits, dossier et lien symbolique » Le 16/09/2014, à 21:49

nagadoudi
Réponses : 6

Bonjour,

J'ai un bête problème de droits avec dossiers et liens symboliques, mais je bloque complètement.

L'élément /var/lib/backuppc est un lien symbolique vers le dossier /media/gaston/sauvegardes/backuppc :

root@pc:/var/lib# ll | grep backuppc
lrwxrwxrwx  1 backuppc   backuppc    31 sept. 16 21:00 backuppc -> /media/gaston/sauvegardes/backuppc/

Cette commande ne fonctionne PAS :

root@pc:/# sudo -u backuppc touch /var/lib/backuppc/test
touch: impossible de faire un touch «/var/lib/backuppc/test»: Permission non accordée

Pourtant, ces 2 commandes fonctionnent :

root@pc:/var/lib/backuppc# sudo -u backuppc touch test
root@pc:/media/gaston/sauvegardes/backuppc# sudo -u backuppc touch test

Pourquoi ?


Pour info, voici les droits sur les dossiers :

  • /var : root:root ; 755

  • /var/lib : root:root ; 755

  • /var/lib/backuppc : backuppc:backuppc ; 777 (c'est un lien symbolique)

  • /media : root:root ; 755

  • /media/gaston : root:root ; 750+

  • /media/gaston/sauvegardes : root:users ; 775

  • /media/gaston/sauvegardes/backuppc : backuppc:backuppc ; 775

L'utilisateur backuppc appartient au groupe users.

#22 Re : -1 »  [résolu] Droits, dossier et lien symbolique » Le 16/09/2014, à 22:30

nagadoudi
Réponses : 6

C'est quoi le flag -E ?

Le programme touch est un indicateur pour nous permettre de savoir si BackupPC écrit ou non dans un dossier.

#24 Re : -1 »  [résolu] Droits, dossier et lien symbolique » Le 17/09/2014, à 10:42

nagadoudi
Réponses : 6

C'est exactement ça !

Le dossier /media/gaston appartient à root:root...

root@pc:/media# ll /media/ | grep gaston
drwxr-x---+  5 root root  4096 sept. 17 10:08 gaston/

... mais l'utilisateur gaston y a un accès (c'est normal) géré avec les ACL.

root@pc:/media# getfacl gaston/
# file: gaston/
# owner: root
# group: root
user::rwx
user:gaston:r-x
group::---
mask::r-x
other::---

J'ai donc ajouté un accès à l'utilisateur backuppc.

root@pc:/media# setfacl --modify user:backuppc:rX gaston/

Résultat :

root@pc:/media# getfacl gaston/
# file: gaston/
# owner: root
# group: root
user::rwx
user:backuppc:r-x
user:gaston:r-x
group::---
mask::r-x
other::---

Et ma commande initiale fonctionne !

root@pc:/var/lib/backuppc# sudo -u backuppc touch /var/lib/backuppc/test

Merci Postmortem !