Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  erreur compilation nexttool » Le 13/11/2014, à 19:47

totola
Réponses : 0

Bonjour,
j'essaie de faire fonctionner un robot lego nxt et je dois compiler nexttool.
Je suis le tuto youtube http://www.youtube.com/watch?v=YqY5yG_KO2Q
Et je bloque à l'étape:

make -fnexttool.mak

Voilà l'erreur:

NeXTTool.dpr(30,3) Hint: Unit "math" not used in NeXTTool
Linking nexttool
/usr/bin/ld: Avertissement: link.res contient des sections de sortie; avez-vous oublié -T?
/usr/bin/ld: ne peut trouver -lusb
Error: Error while linking
Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make: *** [nexttool] Erreur 1

Merci de votre aide!

#1 -1 »  Alsamixer se bloque... » Le 27/10/2014, à 14:14

totola
Réponses : 5

Bonjour,
je suis sous ubuntu 14.04 et lorsque je règle les niveaux avec alsamixer, ça marche d'abord, puis très vite il se bloque et je n'ai plus de son... Tout marche bien si je ne touche pas à alsamixer... j'en ai pourtant besoin pour régler le niveau du micro et c'est pénible  de devoir redémarrer à chaque fois... hmm

lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 9840
.
.
.
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)

sinon, dans alsamixer, il y a écrit:

AlsaMixer v1.0.27.2 ─────────────────────────────┐
│    Carte: HD-Audio Generic                         F1:  Aide                 │
│     Puce: Realtek ALC282  

Mon PC est un HP touchsmart 11


Merci pour les idées! smile

#2 Re : -1 »  Alsamixer se bloque... » Le 08/11/2014, à 13:44

totola
Réponses : 5

Bonjour Bluedid29!
Merci pour ta réponse!
Non, je n'arrive pas à régler mon niveau d'entrée avec pulseaudio. Pourtant il fonctionne bien avec jack.
J'ai bien essayé de connecter les entrées dans jack mais le volume de l'entrée pulseaudio n'a aucun effet (j'ai toujours du signal qu'il soit au max ou au  min...), la seule solution est de régler par alsamixer.

Merci!
smile

#3 Re : -1 »  Alsamixer se bloque... » Le 08/11/2014, à 20:03

totola
Réponses : 5

Oui oui, tout est à jour...
J'ai déjà désinstallé et réinstallé pulseaudio.. (j'ai même déjà réinstallé ubuntu studio complètement)
En plus le problème est identique quelque soit la distrib (ubuntu 14.04, 14.10, ubuntu studio, tango studio ou même debian..)

#4 Re : -1 »  Alsamixer se bloque... » Le 14/11/2014, à 16:02

totola
Réponses : 5

Bonjour et désolé de la réponse tardive...
En effet, j'ai parfois des problèmes audio même avec ubuntu 14.04 normal... Des fois je n'ai pas de son, le plus simple est de redémarrer...
Malheureusement je n'ai pas d'autre carte son sous la main...
Je veux bien essayer d'installer un noyau plus récent mais lequel et comment? smile

Merci!

#5 -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 04/11/2014, à 19:35

totola
Réponses : 11

Bonjour,
j'utilise ubuntu studio 14.04 en double boot avec ubuntu 14.04 avec /home partagé (pas le choix question espace...), j'aimerais bien migrer vers ubuntu 14.10, mais il faut que je le fasse pour les deux...
Y a t-il un problème de mettre à niveau ubuntu studio vers 14.10? Comme la suppression du noyau lowlatency ou de la gestion du temps réel?
Merci!

#6 Re : -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 05/11/2014, à 13:19

totola
Réponses : 11

C'était pas ma question... Mais merci quand même de la réponse smile

Le truc, c'est que j'ai des problèmes audio (chipset audio non parfaitement fonctionnel et freeze/ralentissement graphique) avec la version 14.04...

Mais c'est vrai que j'aurais du le préciser.. smile
Je vais déjà tester en lveusb pour voir...
(je viens juste d'y penser...)
smile

#7 Re : -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 05/11/2014, à 19:47

totola
Réponses : 11

Bon, pas de changement avec 14.10 en liveusb, donc effectivement, pas d'intérêt de migrer!
smile

Merci pour vos conseils!

PS: oui, ubuntu studio utilise par défaut le noyau lowlatency.

#8 Re : -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 05/11/2014, à 19:49

totola
Réponses : 11

Et hop:
smile

$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 9840
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 0
00:02.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Functions 5:1
00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Functions 5:1
00:02.5 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Functions 5:1
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 01)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 39)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 39)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 39)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 39)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 3a)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.7 SD Host controller: Advanced Micro Devices, Inc. [AMD] FCH SD Flash Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Function 5
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
02:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
02:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

#9 Re : -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 05/11/2014, à 19:51

totola
Réponses : 11

En fait mon problème le plus gênant est audio et j'ai déjà lancé un fil ici:

http://forum.ubuntu-fr.org/viewtopic.php?id=1709731

smile

#10 Re : -1 »  ubuntu studio: mise à niveau vers 14.10? » Le 05/11/2014, à 19:54

totola
Réponses : 11

Oui oui... J'ai les drivers proprios, bon, pour la partie graphique, ça va je ne me plains pas trop, ça marche plutôt bien (même si je pense que ça pourrait être encore un peu mieux), en fait c'est surtout avec unity (avec xfce, c'est nickel).
Mais comme dit le plus gênant est mon problème d'alsamixer (lien plus haut...)

#11 -1 »  (Résolu)quelle solution pour filmer le bureau?(screencast) » Le 18/10/2014, à 21:05

totola
Réponses : 5

Bonjour,
Je souhaite effectuer des vidéos de mon pc en capturant le son...
J'ai vu que recordmydestop était souvent conseillé, néanmoins chez mou il ne fait que de buguer (il n'enregistre rien et produits plusieurs erreurs bizarres; j'ai un autre fil sans solution...)

En fouillant, j'ai trouvé un logiciel complet et qui marche mieux chez moi, c'est 'simple screen recorder', il permet de faire tout ce que je veux, mais il fait ramer terriblement le système, du coup la vidéo est moche...
Même à 10 frame/seconde, lorsque je lance top en console, le programme bouffe plus de 90% des ressources... Alors d'accord, mon pc n'est pas une bête de guerre mais quand même... (c'est unbhp toychsmart 11), quelque chose me dit que ce n'est pas normal...
Une idée? 

Ou une autre solution?
J'ai vu que c'était possible en ligne de commande, directement avec ffmpeg, mais je ne le trouve plus dans les dépôts, et les options ne fonctionnent pas avec avconv...
Merci de votre aide! smile

#12 Re : -1 »  (Résolu)quelle solution pour filmer le bureau?(screencast) » Le 20/10/2014, à 16:41

totola
Réponses : 5

Merci pour vos réponses,
j'ai pas encore testé kazam mais je vais le faire... smile
Pour byzanz, j'avais déjà testé, effectivement ça marche très bien en gif, par contre en vidéo je n'ai pas réussi. D'autre part il me faut le son sortant du serveur Jack, je ne sais pas si byzanz peut le faire?

#13 Re : -1 »  (Résolu)quelle solution pour filmer le bureau?(screencast) » Le 20/10/2014, à 20:49

totola
Réponses : 5

Bon, c'est résolu avec simplescreenrecorder... Il fallait juste installer les pilotes Ati de la carte graphique pour qu'il fonctionne correctement...
smile
Merci

#14 -1 »  (Résolu)recordmydesktop n'enregistre rien... » Le 18/10/2014, à 12:06

totola
Réponses : 4

Bonjour,
J'essaie de filmer mon bureau avec recordmydesktop mais il me fait une erreur au moment de démarrer l'enregistrement: du genre "spécification de   fenêtre incorrect" ... Pourtant le cadre ou la fenêtre est bien sélectionnée..?
Une idée?
Merci smile

[edit] en console, j'ai le message suivant:

gtk-recordmydesktop 
/usr/lib/python2.7/dist-packages/recordMyDesktop/rmdSelectThumb.py:79: GtkWarning: IA__gdk_image_put_pixel: assertion 'x >= 0 && x < image->width' failed
  im2.put_pixel(k/stride,i/stride,im1.get_pixel(k,i))
<_sre.SRE_Pattern object at 0x17dddc0>
_NET_FRAME_WINDOW:  no such atom on any window.

#15 Re : -1 »  (Résolu)recordmydesktop n'enregistre rien... » Le 20/10/2014, à 16:43

totola
Réponses : 4
Gemnoc a écrit :

Alors je te suggère d'essayer un autre logiciel, maintenu celui-là. Il y en a heureusement quelques uns. Hizoka, un membre du forum est l'auteur de Screencastor, un logiciel qui fonctionne bien. Il y a aussi SimpleScreenRecorder qui me semble intéressant, mais qui n'offre pas un bouton dans le tableau de bord.

http://doc.ubuntu-fr.org/capture#logici … screencast

Merci!

Je vais regarder screencastor... Pour SimpleScreenRecorder, il est très bien en effet, je l'ai testé, mais il me bouffe énormément de ressources... Plus de 90%, ça rame à mort et la vidéo n'est pas exploitable...

#16 Re : -1 »  (Résolu)recordmydesktop n'enregistre rien... » Le 20/10/2014, à 20:43

totola
Réponses : 4

Bon, c'est résolu avec simplescreenrecorder... Il fallait juste installer les pilotes Ati de la carte graphique pour qu'il fonctionne correctement...
smile
Merci

#17 Re : -1 »  Latex » Le 15/10/2014, à 19:30

totola
Réponses : 7

Salut,
Pour ma part j'utilise l'éditeur kile, il est dans les dépôts, bon a la base c'est pour kde, du coup il installé pas mal de lib kde si tu ne l'as pas, c'est le problème... Mais il est complet et j'ai pas trouvé d'équivalent...

#18 -1 »  configurer jackd » Le 07/10/2014, à 18:57

totola
Réponses : 9

Bonjour,
j'ai installé ubuntu studio 14.04 et j'essaie de démarrer le serveur de son jackd... J'ai cherché sur le net mais je ne trouve pas pourquoi ça ne fonctionne pas:

Tue Oct  7 19:52:49 2014: Starting jack server...
Tue Oct  7 19:52:49 2014: ERROR: `default' server already active
Tue Oct  7 19:52:49 2014: ERROR: Failed to open server
Tue Oct  7 19:52:50 2014: Saving settings to "/home/lavarenne/.config/jack/conf.xml" ...
19:53:03.679 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Erreur de communication serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot read socket fd = 21 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
19:53:34.154 DBUS : impossible de démarrer le serveur JACK. Désolé
Cannot read socket fd = 21 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
Tue Oct  7 19:53:34 2014: Starting jack server...
Tue Oct  7 19:53:34 2014: ERROR: `default' server already active
Tue Oct  7 19:53:34 2014: ERROR: Failed to open server
Tue Oct  7 19:53:35 2014: Saving settings to "/home/lavarenne/.config/jack/conf.xml" ...
19:53:44.621 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Erreur de communication serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot read socket fd = 21 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
19:54:54.846 DBUS : impossible de démarrer le serveur JACK. Désolé
Cannot read socket fd = 21 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
Tue Oct  7 19:54:54 2014: Starting jack server...
Tue Oct  7 19:54:54 2014: ERROR: `default' server already active
Tue Oct  7 19:54:54 2014: ERROR: Failed to open server
Tue Oct  7 19:54:56 2014: Saving settings to "/home/lavarenne/.config/jack/conf.xml" ...
19:55:04.037 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Erreur de communication serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot read socket fd = 21 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
(qjackctl:2393): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:2393): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

Une idée??

Merci

#19 Re : -1 »  configurer jackd » Le 07/10/2014, à 19:39

totola
Réponses : 9

Merci, en effet, c'est ce que j'utilise... Mais jackd refuse de démarrer...

#20 Re : -1 »  configurer jackd » Le 07/10/2014, à 19:49

totola
Réponses : 9
<?xml version="1.0"?>
<!--
JACK settings, as persisted by D-Bus object.
You probably don't want to edit this because
it will be overwritten next time jackdbus saves.
-->
<!-- Tue Oct  7 20:06:38 2014 -->
<jack>
 <engine>
  <option name="driver">alsa</option>
  <option name="realtime">true</option>
  <option name="realtime-priority">11</option>
  <option name="verbose">true</option>
  <option name="client-timeout">500</option>
 </engine>
 <drivers>
  <driver name="firewire">
  </driver>
  <driver name="alsa">
   <option name="device">hw:Generic_1,0</option>
   <option name="capture">hw:Generic_1,0</option>
   <option name="playback">hw:Generic_1,0</option>
   <option name="rate">44100</option>
   <option name="period">1024</option>
   <option name="nperiods">3</option>
   <option name="hwmon">false</option>
   <option name="hwmeter">false</option>
   <option name="duplex">true</option>
   <option name="softmode">false</option>
   <option name="monitor">false</option>
   <option name="dither">n</option>
   <option name="shorts">false</option>
  </driver>
  <driver name="net">
  </driver>
  <driver name="netone">
  </driver>
  <driver name="loopback">
  </driver>
  <driver name="dummy">
  </driver>
  <driver name="alsarawmidi">
  </driver>
 </drivers>
 <internals>
  <internal name="netmanager">
  </internal>
  <internal name="profiler">
  </internal>
  <internal name="audioadapter">
  </internal>
  <internal name="netadapter">
  </internal>
 </internals>
</jack>

#21 Re : -1 »  configurer jackd » Le 08/10/2014, à 16:37

totola
Réponses : 9

Ok, merci.
en attendant j'ai "réglé" le problème en désinstallant pulseaudio... Pour l'instant j'en ai pas besoin, j'ai installé ubuntu studio juste pour essayer les logiciels d'édition audio fonctionnant avec Jack...

#22 Re : -1 »  [Résolu] Laptop pour le lycée » Le 21/09/2014, à 16:15

totola
Réponses : 16

Obliger les élèves à venir en cours avec leur propre portable... :s  C'est limite je trouve... Je serais curieux de voir la tête du ou des profs s'il arrive quelque chose au dit portable durant la séance de cours (ou même dans le lycée)...

Sinon, il existe maintenant un certain nombre de petit 11'' qui sont pas mal du tout... avec un bon rapport taille/prix/performance je trouve.

#23 Re : -1 »  Spectromètre usb » Le 20/09/2014, à 15:23

totola
Réponses : 5

Sinon, j'ai essayé avec vmware, ça marche un peu mieux mais ce n'est pas encore ça... hmm

Pour virtualbox, il semblerait que ça fonctionne sur un seul de mes trois ports usb...

#24 Re : -1 »  virtualbox XP et spectrometre usb » Le 20/09/2014, à 16:45

totola
Réponses : 1

Bon, j'ai trois ports usb, il semblerait qu'un seul fonctionne correctement avec virtualbox??
Bizarre