Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  E117: Fonction inconnue : LaTeX_file » Le 27/08/2015, à 15:24

gigiair
Réponses : 14

Ton ficher test5.tex provient vraisemblablement d'un copié-collé, ou alors ta configuration est à revoir.
Le caractère «’» ressemble comme deux gouttes d'eau au caractère  «'» mais en réalité ce sont deux caractères différents.
Le premier est le caractère 8217, l'autre le caractère 39. Si tu regardes de plus près les glyphes sont différentes. Celle sur premier est légèrement courbe. Pour LaTeX pour qui un caractère est un nombre entier, ces deux caractères sont aussi différents que 8217 et 39. Le compilateur considère que \’ est une commande inconnue, alors que \' est une commande connue.
Remplace ton ficher test5.tex par celui ci

 \documentclass[a4paper,11pt,english,francais]{article}                                         
 \usepackage[T1]{fontenc}
 \usepackage{babel}
 \author{K\'evin JASON}
 \title{Un Exemple}
 \begin{document}
 \maketitle
 \tableofcontents
 \section{D\'ebut}
\`A \'ecrire\dots
\section{Suite et fin}
On verra plus tard.
\end{document}

Note que l'encodage TeX pour les accentués n'est nécessaire que pour qui veut échanger des fichiers en ASCII.
J'imagine que Vim permet de basculer de l'encodage TeX à l'encodage « normal » comme le fait Emacs,
Tu peux ajouter la commande
\usepackage[utf8]{inputenc} %ou latin1 en fonction de la configuration de ton éditeur.
et coder « normalement » tes fichiers. LaTeX ne fait aucune différence.

#1 Re : -1 »  Problème de distance connexion WIFI Atheros AR9285 » Le 21/08/2015, à 10:24

gigiair
Réponses : 8

J'ai eu ce problème avec un eeepc. J'ai acheté une antenne de récupération que j'ai montée à la place de celle d'origine qui était sectionnée au niveau de la charnière (pratiquement invisible). Depuis tout marche.

#2 Re : -1 »  Problème de distance connexion WIFI Atheros AR9285 » Le 21/08/2015, à 12:40

gigiair
Réponses : 8

Non, non, c'est une antenne interne qui fait un demi tour d'écran.
J'ai acheté l'antenne sur Ebay, mais je n'ai pas gardé l'adresse. Il y a de nombreuses boutiques qui proposent des pièces de récupération.
J'ai trouvé le  plan de démontage sur le ouaibe. Il faut être un peu soigneux, mais ça se fait. C'est moins facile que pour une tour. Avant de trouver la pièce exacte, j'avais utilisé une antenne d'un autre eeepc qui passait par un trou de vis. C'était un peu bricolo, mais ça marchait.

#3 Re : -1 »  Capture d'écran (une image, pas une vidéo) en jouant ? » Le 13/08/2015, à 20:08

gigiair
Réponses : 9

convert de Imagemagick fait le truc.
xwininfo (vient avec x11-utils) permet  d'identifier la fenêtre que tu veux capturer
Tu crée un répertoire de capture, par exemple ~/mescaptures
mktemp permet de générer une suite de noms tous distincts.
La commande suivante fait le truc pour une capture.

convert x:$(xwininfo|awk '/id:/ {print $4}') $(mktemp --suffix=.png -p ~/mescaptures capture-XXXX)

Tu cliques sur la fenêtre que tu veux capturer.
Et la capture est copiée dans le répertoire ~/mescaptures. Tu peux changer l'extension .png par celle de ton choix, acceptée par convert.
Pour plus de confort, tu peux éviter de cliquer sur la fenêtre à chaque fois en évaluant

xwininfo|awk '/id:/ {print $4}'

et en remplaçant $(xwininfo|awk '/id:/ {print $4}') par sa valeur.
Il est bien facile de rédiger un petit script qui automatise tout ça. Si tu n'aimes pas les noms donnés par mktemp, tu peux les générer par le script, il suffit de mettre en place un compteur.
Puis affecter la commande à une touche.
Si tu n'aimes pas les noms générés par mktemp, tu crée un compteur.
C'est juste des pistes, tu en fais ce que tu veux, tu peux demander à ce qu'on te mitonne un script aux petits oignons, ça peut servir à d'autres.

#4 Re : -1 »  rechercher&remplacer les sauts de § dans Libre Office Writer [résolu] » Le 28/07/2015, à 13:47

gigiair
Réponses : 5
Bruno93200 a écrit :

je me débrouille avec gedit, mais j'ai des gros fichiers qui bloquent
comment puis-je augmenter la mémoire tampon de gedit pour traiter les gros fichiers ?
B.

Emacs smile l'éditeur surpuissant. 512 Mb permis, et bientôt (Emac25) 2Gb.
Toutefois, si le texte contient des caractères non ascii, la capacité peut être réduite.

Pour gedit, je ne sais pas ,mais je suppose que pour augmenter la taille des fichiers à traiter, il faut recompiler « à la main ». Ça peut dépendre si la machine est en 32 bits ou en 64 bits. Faut essayer.
Je dis ça un peu sans savoir, ça m'arrive.

La recherche par regexp ne peut pas fonctionner sous LO puisqu'elle ne fonctionne que dans les paragraphes (c'est ce que j'ai lu) et le caractère $ (qu'il faut protéger) ne reconnaît que les fin de lignes.

#5 Re : -1 »  [résolu] Problème avec Latex » Le 26/07/2015, à 03:32

gigiair
Réponses : 13

Ce n"est pas un problème de LaTeX, c"est un problème avec ton éditeur.
La compilation est lancée avec --shell-escape ce qui n'est pas trop normal pour un fichier qui ne contient pas de commande shell. Ça ne gène pas, mais ça montre que la configuration de ton éditeur est particulière. Il peut y avoir un problème à ce niveau.
Il faudrait au moins nous dire quel éditeur tu utilises.

#6 Re : -1 »  [résolu] Problème avec Latex » Le 27/07/2015, à 09:51

gigiair
Réponses : 13

Je n'ai pas cette difficulté.
TeXstudio 2.9.4 (hg 5006:b43062855b2d) /Debian stretch

La première chose quand on crée un document LaTeX, c'est de lui donner un nom. Et de ne pas lui donner pour nom doc1 car c'est un nom donné automatiquement et qui ne permet pas de retrouver facilement son travail.
Si tu commences par créer un document  (Enregistrer sous) avant toute compilation, tu as toujours cette difficulté ?

#7 Re : -1 »  [résolu] Problème avec Latex » Le 28/07/2015, à 05:25

gigiair
Réponses : 13

Je ne suis pas devin. Je n'ai pas ce problème donc je ne peux pas savoir.
texstudio ne compile pas sans avoir préalablement enregistré. Il enregistre  dans /tmp/texstudio_xxxx.tex
Il peut y avoir un problème de droits dans le répertoire personnel.
Il me faudrait le compte-rendu d'exécution (affichage Messages/fichiers log)
messages et log complets.
Également la version de TS (menu Aide/apropos)

#8 Re : -1 »  [résolu] Problème avec Latex » Le 28/07/2015, à 20:43

gigiair
Réponses : 13
fred62 a écrit :

je vais essayer d'etre plus précis wink
Dans Texstudio lorsque je fais nouveau document , je tape le préambule ci dessus
je lance compilation (pdflatex) rapide flèche verte
le lecteur pdf interne me sort un fichier pdf nickel :
dont voici le fichier  log (partiel)
************************************************************************************************************************************************************
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex 2015.7.23)  28 JUL 2015 15:50
entering extended mode
\write18 enabled.
%&-line parsing enabled.
**texstudio_Ix2215.tex
(./texstudio_Ix2215.tex
LaTeX2e <2015/01/01>
Babel <3.9l> and hyphenation patterns for 79 languages loaded.
(/home/fred/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/home/fred/texlive/2015/texmf-dist/tex/latex/base/size10.clo
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)

Output written on texstudio_Ix2215.pdf (1 page, 38063 bytes).
PDF statistics:
17 PDF objects out of 1000 (max. 8388607)
11 compressed objects within 1 object stream
0 named destinations out of 1000 (max. 500000)
1 words of extra memory for PDF output out of 10000 (max. 10000000)
********************************************************************************************************************
par contre dès que j'enregistre ce fichier dans un sous dossier  de
mon répertoire personnel ou j'ai les droits cela ne fonction plus ... une idée ?

Non, vraiment aucune idée, le fait de savoir que ça marche quand on ne sauve pas n'est d'aucune utilité pour comprendre pourquoi ça ne fonctionne pas lorsque l'on le sauvegarde.
Il me semble que le fichier soi-disant sauvegardé ne l'est pas. Il doit bien y avoir un message d'erreur quand on demande la sauvegarde.
Essaye de lancer texsudio en ligne de commande avec un nom de fichier

texstudio exemple.tex

#9 Re : -1 »  je n'arrive plus à ping vers l'exterieur » Le 30/07/2015, à 19:16

gigiair
Réponses : 6

Essaye

ping 216.58.211.99

Si ça  répond, c'est ton serveur dns qui est mal configuré.

#10 Re : -1 »  Quel agenda utilisez-vous ? » Le 28/07/2015, à 20:35

gigiair
Réponses : 6

Org-mode de Emacs, c'est top. Un agenda tout en mode texte. Export vers LaTeX, HTML, odt, etc..
Org-mode est beaucoup plus qu'un agenda, c'est un GTD extensible à volonté.
Possibilité d'inclure toute sorte de code dans les documents produits (36 langages différents)
Communication avec un smartphone androïd ou iphone etc...

Il y a bien sûr une extension pour communiquer avec caldav, org-caldav installable par un gestionnaire d'extensions interactif, mais je ne l'utilise pas.
Voir les nombreuses démo sur le ouaibe.

#11 Re : -1 »  [Résolu] Remplacer les &#NN; par les diacritiques correspondants » Le 22/07/2015, à 22:38

gigiair
Réponses : 11

Si tu pouvais donner un exemple de texte, je pourrais essayer de le traiter.

#12 Re : -1 »  [Résolu] Remplacer les &#NN; par les diacritiques correspondants » Le 23/07/2015, à 18:18

gigiair
Réponses : 11

Personnellement, je ferais ça avec Emacs. Il suffit de faire une recherche et remplacement de regexp
"&#x\\([1-9A-F][0-9A-F]\\);" par l'évaluation  elisp de (string (string-to-number \1 16)) (soit "\,(string (string-to-number \11 16)"  )
On peut taper C-M-%  &#x\([1-9A-F][0-9A-F]\); <RET> \,(string(string-to-number \1 16)) <RET>
Valider les remplacements un à un, ou taper ! pour traiter tout le document.

Ça ne doit pas être trop difficile d'écrire une ligne en bash, j'imagine, mais comme je n'aime pas trop ça, je laisse aux amateurs le soin de le faire.

#13 Re : -1 »  [Résolu] Remplacer les &#NN; par les diacritiques correspondants » Le 23/07/2015, à 19:05

gigiair
Réponses : 11

Exact, j'ai testé. J'avais cherché dans cette direction, mais je n'avais pas vu.

#14 Re : -1 »  [Résolu] Remplacer les &#NN; par les diacritiques correspondants » Le 26/07/2015, à 11:21

gigiair
Réponses : 11

Comme j'ai parfois des problèmes de ce genre, j'ai rajouté dans mon init.el (Emacs)

(add-to-list 'format-alist     `(xml ,(purecopy "XML entités numériques")
	   nil
	   ,(purecopy "recode -f h0..utf-8")
	   ,(purecopy "recode -f ..h0") t nil))

Maintenant quand j'ai des codes de ce type, la commande M-x format-decode-buffer me propose xml qui fait le truc.

#15 Re : -1 »  LaTeX: le paquet mnsymbol "Insufficient symbol fonts" » Le 25/07/2015, à 17:40

gigiair
Réponses : 1

Tu ne devrais pas ignorer l'utilitaire texdoc, premier réflexe quand on a des difficultés avec un package (ou même si simplement on veut s'informer sur son usage).

texdoc mnsymbol
texdoc mnsymbol a écrit :

Interference with other packages. The MnSymbol package is incompatible with the amssymb and amsfonts packages. It automatically loads the amsmath and textcomp packages.

Or, je lis dans ton entête

\usepackage{amssymb}

C'est peut-être la clé du mystère.
Si ça coince encore, il faut fournir un exemple complet minimal (ECM) et le log correspondant. Je n'ai jamais utilisé mnsymbol, mais la plupart du temps, cette façon de faire permet le plus souvent de résoudre les problèmes, sinon d'amorcer un dialogue constructif.

#16 Re : -1 »  [Résolu] Aucun live-cd ne veut de mon ordinateur » Le 20/07/2015, à 08:36

gigiair
Réponses : 11

Je parle de mémoire car je n'ai pas de machine avec lecteur de CD sous la main. J'ai souvent fait des installations Debian à partir de CD. Il y avait pas mal d'options de démarrage. Une en particulier était de désactiver l'ACPI. Tu les as toutes essayées ? (je ne sais pas s'il y a les mêmes avec un Ubuntu, mais je l'imagine).

#17 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 09/07/2015, à 22:15

gigiair
Réponses : 30

Le fichier fontec.sty n'existe pas. C'est dit dans le log, c'est donc vrai.
C'est sans doute fontenc.sty qui est désiré. La commande \usepackage[T1]{fontenc} est obligatoire en latex ou pdflatex pour utiliser les caractères accentuer.
Pour savoir à quel emplacement se trouve ce fichier

$ debjjr@grml:~$ kpsewhich fontenc.sty
/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
debjjr@grml:~$ 

donner l'extension .tex au fichier est vivement recommandé, sauf si l'on sait très bien pourquoi on he le fait pas et quelles en seront les conséquences. Par contre, pour l'appel de la compilation il est inutile de préciser  l'extension .tex qui est sous-entendue par défaut.

#18 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 08:05

gigiair
Réponses : 30

Le package frenchb.ldf n'est pas trouvé. C'est le signe certain que l'installation est incomplète.
il faut (re)installer le package  texlive-lang-french.
La commande suivante doit renvoyer l'URI de frenchb.ldf :

debjjr@grml:~$ kpsewhich frenchb.ldf
/usr/share/texlive/texmf-dist/tex/generic/babel-french/frenchb.ldf
debjjr@grml:~$ 

#19 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 09:45

gigiair
Réponses : 30
tiramiseb a écrit :

Tu peux aussi faire :

dpkg -S frenchb

Ça interroge la base des paquets installés pour voir s'il y a un fichier comprenant "frenchb" installé par un paquet, quelque part sur ton système...

Ça va sortir tous les fichiers frenchb.*. y compris ceux qui proviennent de texlive-latex-extra et qui n'ont pas grand chose à voir dans le débat.

Celui qui est utilisé par le compilateur est frenchb.ldf. Le moyen le plus sûr de vérifier sa présence est de faire appel à l'utilitaire kpsewhich (ou kpsewhere) de la bibliothèque kpathsea. C'est fait pour ça.

#20 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 11:01

gigiair
Réponses : 30
gl38 a écrit :

remarque : je ne vois pas l'intérêt d'utiliser des options de français, si on ne met pas d'espace avant un !

Justement, l'option français va automatiquement placer l'espace obligatoire dans la typographie française.
C'est si on en met un que l'option n'a éventuellement pas d'intérêt. Encore que l'espace insérée par frenchb est insécable, et un peu plus courte que l'espace «normale» ce qui est la norme dans la typographie française

C'est moi qui est composé  ce fichier minimal il permet de vérifier le fonctionnement de l'installation LaTeX.

#21 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 11:12

gigiair
Réponses : 30
tiramiseb a écrit :

Tu peux aussi faire :

dpkg -S frenchb

Ça interroge la base des paquets installés pour voir s'il y a un fichier comprenant "frenchb" installé par un paquet, quelque part sur ton système...

Ça va aussi détecter les fichiers frenchb.* contenus dans texlive-latex-extra qui n'ont rien à voir dans la bagarre, et ça peut induire en erreur. En plus, la recherche est beaucoup plus longue qu'avec les utilitaires kpsewhich et kpsewhere de la bibliothèque de recherche kpathsea de TeXlive.

info kpathsea

#22 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 12:22

gigiair
Réponses : 30

Justement, ce qui importe, ce n'est pas que frenchb.ldf, c'est qu'il soit trouvé par kpathsea. Sinon pour LaTeX, c'est comme s'il n'était pas présent.
Ceci étant dit, si TeXLive vient de l'installateur Ubuntu, s'il est installé, il sera au bon endroit et trouvé par kpsewhich.
Ta commande est certainement très intéressante pour débeuguer une application en général, mais pas pour un système comme texlive qui a son propre système de recherche des fichiers.

#23 Re : -1 »  [RESOLU]Erreur Latex premier script » Le 10/07/2015, à 21:55

gigiair
Réponses : 30

Tout à fait.
Si tu ne l'as déjà fait, je te conseille de live une petite initiation.
Un classique : Une courte introduction à latex2e.
On peut le consulter en tapant la commande

texdoc lshort-fr

vim inclus une documentation sur latex, mais c'est plutôt un aide mémoire. Ce n'est pas pertinent d'apprendre un langage avec un glossaire. Mais cette aide est très utile après avoir lu une introduction.

J'oubliais : quand on débute, on fait souvent beaucoup d'erreurs de syntaxe. Plutôt que de lancer une compilation qui risque de bloquer sur des messages d'erreur pas toujours adaptés, on peut vérifier la syntaxe avec la commande lacheck.
Il y a bien longtemps que je n'utilise plus cet utilitaire et je te souhaite de pouvoir l'abandonner rapidement. Sous vim on lance :! lacheck <nom du fichier>
L'extension .tex est facultative.

#24 Re : -1 »  ecrire une partition » Le 10/07/2015, à 18:39

gigiair
Réponses : 4

Je souscris à l'opinion de Dim83. Il vaut mieux être familier avec l'utilisation d'un compilateur, mais sinon, tout peut s'apprendre. La documentation est très bien faite et il y a une liste de diffusion très active.
Même pour des travaux simples, il vaut mieux utiliser un outil performant. s'il prend envie de faire des choses plus compliquées, lilypond sera là, pas besoin de changer de système.