Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  Client VPN sur serveur distant » Le 10/08/2012, à 20:34

Cramix
Réponses : 2

Hello tout le monde,

Je suis client chez vpnTunnel (que je pense changer pour BlackVPN). Je souhaite utiliser ce dernier sur mon serveur (dedibox). Le soucis est qu'une fois la connexion établie (donc openvpn maconf.conf), je perds la main en ssh et plus rien n'est accessible (serveur web, ftp, etc). Ce qui semble logique vu que tous les services passent via le vpn. Je suis donc obligé de redémarrer le serveur électriquement pour retrouver ma config d'origine (heureusement que j'avais viré openvpn d'update.rc tongue ). Ma question est donc la suivante : comment puis-je faire pour utiliser le vpn sur le serveur tout en gardant mon accès ssh et que tous les autres services soient accessible depuis l'ip "d'origine" ?

Y a-t-il quelqu'un pour éclaire ma lanterne smile ?

Je vous remercie d'avance.

#1 Re : -1 »  Client VPN sur serveur distant » Le 10/08/2012, à 23:11

Cramix
Réponses : 2

J'ai reformulé ma question, mon message n'était pas clair wink

#3 -1 »  Lancer plusieurs fois le même daemon » Le 13/02/2012, à 22:20

Cramix
Réponses : 5

Bonjour,

Je souhaite lancer plusieurs fois le même daemon mais à chaque fois avec un utilisateur différent. J'ai pour cela créé plusieurs fichiers d'init (/etc/init.d) qui permettent chacun de lancer un daemon avec un autre utilisateur. Mais lorsqu'un daemon est déjà lancé, il m'est impossible d'en lancer un deuxième.

Existe-t-il une façon de contourner cette limitation ?

Merci d'avance !

#4 Re : -1 »  Lancer plusieurs fois le même daemon » Le 13/02/2012, à 22:31

Cramix
Réponses : 5

Pardon j'ai oublié de mentionner ce détail.
J'ai bien plusieurs fichiers de confs qui lancent le daemon sur un port différent. Le service en question est transmission-daemon.
Admettons que je lance le daemon pour toto (le service sera donc executé en son nom) sur le port 1337, lorsque que je voudrai lancer le daemon pour tata sur le port 4242 on me dira que le transmission-daemon est déjà lancé.

#5 Re : -1 »  Lancer plusieurs fois le même daemon » Le 13/02/2012, à 22:53

Cramix
Réponses : 5

Au contraire, j'ai uniquement le daemon d'installé, je l'utilise comme seedbox sur ma dédibox mais je cherche à faire un système multi-utilisateurs d'où la nécessité de lancer plusieurs fois le service. Or j'ai bien mis des ports distincts dans mes fichiers de configuration, donc en pratique aucun soucis. C'est juste qu'il m'est impossible de lancer un deuxième daemon

root@team-saucisson:~# /etc/init.d/transmission-daemon_user1 start
Starting bittorrent daemon: transmission-daemon.
root@team-saucisson:~# /etc/init.d/transmission-daemon_user2 start
Starting bittorrent daemon: transmission-daemon_bastien/usr/bin/transmission-daemon already running.

Et mes deux fichiers init sont différents :

root@team-saucisson:~# cat /etc/init.d/transmission-daemon_user1
#!/bin/sh -e
### BEGIN INIT INFO
# Provides:          transmission-daemon
# Required-Start:    $local_fs $remote_fs $network
# Required-Stop:     $local_fs $remote_fs $network
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start or stop the transmission-daemon.
### END INIT INFO

NAME=transmission-daemon
DAEMON=/usr/bin/$NAME
USER=user1
# FIXME: no pidfile support; forks, so --make-pidfile doesn't work either
#PIDFILE=/var/run/$NAME.pid
STOP_TIMEOUT=3

export PATH="${PATH:+$PATH:}/sbin"

[ -x $DAEMON ] || exit 0

[ -e /etc/default/$NAME ] && . /etc/default/$NAME

. /lib/lsb/init-functions

start_daemon () {
    if [ $ENABLE_DAEMON != 1 ]; then
        log_progress_msg "(disabled, see /etc/default/${NAME})"
    else
        start-stop-daemon --start \
        --chuid $USER \
        --exec $DAEMON -- $OPTIONS
    fi
}

case "$1" in
    start)
        log_daemon_msg "Starting bittorrent daemon" "$NAME"
        start_daemon
        log_end_msg 0
        ;;
    stop)
        log_daemon_msg "Stopping bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON --retry $STOP_TIMEOUT \
            --oknodo
        log_end_msg 0
        ;;
    reload)
        log_daemon_msg "Reloading bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON \
            --oknodo --signal 1
        log_end_msg 0
        ;;
    restart|force-reload)
        log_daemon_msg "Restarting bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON --retry $STOP_TIMEOUT \
            --oknodo
        start_daemon
        log_end_msg 0
        ;;
    *)
        echo "Usage: /etc/init.d/$NAME {start|stop|reload|force-reload|restart}"
        exit 2
        ;;
esac

exit 0

root@team-saucisson:~# cat /etc/init.d/transmission-daemon_user2
#!/bin/sh -e
### BEGIN INIT INFO
# Provides:          transmission-daemon
# Required-Start:    $local_fs $remote_fs $network
# Required-Stop:     $local_fs $remote_fs $network
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start or stop the transmission-daemon.
### END INIT INFO

NAME=transmission-daemon
DAEMON=/usr/bin/$NAME
USER=user2
# FIXME: no pidfile support; forks, so --make-pidfile doesn't work either
#PIDFILE=/var/run/$NAME.pid
STOP_TIMEOUT=3

export PATH="${PATH:+$PATH:}/sbin"

[ -x $DAEMON ] || exit 0

[ -e /etc/default/$NAME ] && . /etc/default/$NAME

. /lib/lsb/init-functions

start_daemon () {
    if [ $ENABLE_DAEMON != 1 ]; then
        log_progress_msg "(disabled, see /etc/default/${NAME})"
    else
        start-stop-daemon --start \
        --chuid $USER \
        --exec $DAEMON -- $OPTIONS
    fi
}

case "$1" in
    start)
        log_daemon_msg "Starting bittorrent daemon" "$NAME"
        start_daemon
        log_end_msg 0
        ;;
    stop)
        log_daemon_msg "Stopping bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON --retry $STOP_TIMEOUT \
            --oknodo
        log_end_msg 0
        ;;
    reload)
        log_daemon_msg "Reloading bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON \
            --oknodo --signal 1
        log_end_msg 0
        ;;
    restart|force-reload)
        log_daemon_msg "Restarting bittorrent daemon" "$NAME"
        start-stop-daemon --stop --quiet \
            --exec $DAEMON --retry $STOP_TIMEOUT \
            --oknodo
        start_daemon
        log_end_msg 0
        ;;
    *)
        echo "Usage: /etc/init.d/$NAME {start|stop|reload|force-reload|restart}"
        exit 2
        ;;
esac

exit 0

Chacun se serviera d'un fichier de configuration dans le home de l'utilisateur (/home/user1/.config/transmission-daemon/settings.json ou /home/user2/.config/transmission-daemon/settings.json) et se lancera sur un port différent.
Mon seul soucis est que je ne peux pas lancer ces deux démons en même temps (voir erreur plus haut)

#6 -1 »  [rTorrent] un port par peer ? + configuration iptables » Le 12/02/2012, à 17:42

Cramix
Réponses : 0

Bonjour,

Je suis entrain de configurer rTorrent + ruTorrent sur mon serveur en multi-utilisateurs. J'ai dû allouer 5 ports par utilisateur pour les échanges avec les peers. Or je lis dans la documentation que rTorrent utilise un port pour chaque échange avec une paire. Càd ?
Imaginons que je suis entrain de télécharger un fichier, ce dernier dispose de 42 sources, je pourrai seulement recevoir des données de 5 sources à la fois ? Ou ais-je mal compris ?

De plus j'ai donc ouvert 5 ports pour chacun de mes 4 utilisateurs dans iptables (de 55995 à 56015), mais ruTorrent m'indique que les ports sont fermés alors que les téléchargements se font bien.

Merci d'éclairer ma lanterne !

#7 -1 »  Cherokee : interdire des ip » Le 28/01/2012, à 17:26

Cramix
Réponses : 4

Bonjour,

Je viens d'installer Cherokee sur mon serveur. Je souhaite que les pages web ne soient accessibles qu'à partir de certaines ip (whitelist), mais je ne trouve pas cette fonctionnalité dans l'interface web et les fichiers de conf sont vraiments mal foutus sad.

Si quelqu'un sait comment faire une telle chose avec Cherokee, merci d'éclairer ma lanterne big_smile

#8 Re : -1 »  Cherokee : interdire des ip » Le 28/01/2012, à 18:49

Cramix
Réponses : 4

Oui mais cela va interdire les ip pour tout le serveur. Alors que je veux que ça affecte que la partie web.

#9 -1 »  Améliorer vitesse de transfert sftp » Le 13/12/2011, à 19:42

Cramix
Réponses : 6

Bonjour,

J'utilise Ubuntu Server 11.04 sur mon VPS. Pour transférer des fichiers depuis ce dernier j'utilise sftp mais je n'arrive pas à dépasser le 1mo/s (pourtant je suis fibré et mon serveur dispose de 100Mbits) et je ne bride pas volontairement la connexion. Comment puis-je augmenter la vitesse de transfert et si ce n'est pas possible vers quel protocole me tourner ?

Merci d'avance smile

#10 Re : -1 »  Améliorer vitesse de transfert sftp » Le 13/12/2011, à 20:11

Cramix
Réponses : 6

Je ne pense pas vu que lorsque j'effectue un transfert, sftp & ssh n'utilisent que 2% du cpu sur le serveur. Et en local c'est ridicule aussi (je travaille sur un i5). Donc ça ne vient pas de là...

#11 Re : -1 »  Améliorer vitesse de transfert sftp » Le 16/12/2011, à 12:44

Cramix
Réponses : 6

J'ai installé pureftp, la vitesse de transfert reste la même.
De plus mon ssh n'est pas sur le port 22 mais 666 (evil inside big_smile ) et ce n'est pas la vitesse en upload qui est limité puisque je peux très bien uploader à 10 mo/s (je l'utilise comme client torrent).
Je ne trouve pas sad

#12 -1 »  Serveur OpenVPN : pas d'accès internet » Le 31/05/2011, à 21:43

Cramix
Réponses : 0

Bonjour,

J'ai installé un serveur OpenDNS sur mon VPS. Il fonctionne mais je n'ai pas accès à internet, uniquement à la machine. J'ai donc activé l'ip forwarding :

echo 1 > /proc/sys/net/ipv4/ip_forward

Et ajouté la ligne suivante à mon fichier /etc/rc.local :

iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -j MASQUERADE 

Et bien sûr activé le routage dans ma config openvpn :

push "redirect-gateway def1"

Mais ça ne fonctionne toujours pas, malgré toutes mes recherches je ne trouve pas de solution.
Si quelqu'un pouvait éclairer ma lanterne.

Merci d'avance smile

#13 Re : -1 »  Ubuntu 10.04 son très faible » Le 28/04/2010, à 12:36

Cramix
Réponses : 15
sudo apt-get install alsa

Il me semble.

#14 Re : -1 »  [Modif Titre]9.10 NBR puis 10.4 LTS: perte des clics » Le 14/11/2009, à 23:41

Cramix
Réponses : 86

Problème à peu près similaire sur un Acer Aspire One sad

#15 -1 »  [Résolu][10.04] Pas de son avec flash » Le 28/04/2010, à 12:40

Cramix
Réponses : 23

Bonjour,

Après le passage à la RC je n'ai plus de son sur les vidéos en flash (quelque soit le navigateur). J'ai essayé diverses solutions mais rien à y faire.

Quelqu'un pourrait-il m'éclairer ?

Merci d'avance.

#17 Re : -1 »  [Résolu][10.04] Pas de son avec flash » Le 30/04/2010, à 16:31

Cramix
Réponses : 23

Oui, de même, du son partout sauf pour les videos flash.

#18 Re : -1 »  [Résolu][10.04] Pas de son avec flash » Le 02/05/2010, à 14:40

Cramix
Réponses : 23

Cette astuce ne fonctionne pas pour moi.
Ca devient pénible de ne pas pouvoir regarder de vidéos sur le web sad

#19 Re : -1 »  [Résolu][10.04] Pas de son avec flash » Le 02/05/2010, à 16:52

Cramix
Réponses : 23

Passage de la RC à la version finale, problème résolu, je ne sais pas pourquoi, étrange.
Mais merci à tous pour vos réponses smile

#20 -1 »  [Résolu][Apache] Problème de permissions » Le 17/03/2010, à 18:34

Cramix
Réponses : 9

Bonjour,

Je viens d'installer un serveur LAMP mais je rencontre quelques difficultés. En effet, lorsque j'ajoute un fichier à mon dossier /var/www je n'ai aucun droit dessus, je dois donc me logger en root et donner les permissions aux utilisateurs. Il en va de même pour ajouter un fichier, passage par la case root obligatoire. De plus impossible de consulter les pages via le navigateur (forbidden). Cela devient ennuyeux à la longue, n'y-a-t'il pas un moyen d'y remédier (aller je suis sur big_smile)

Merci d'avance smile

#21 Re : -1 »  [Résolu][Apache] Problème de permissions » Le 17/03/2010, à 22:03

Cramix
Réponses : 9
bastien@Bastien-PC:/var/www$ ls -lha
total 20K
drwxrwxrwx  4 root    bastien 4,0K 2010-03-17 17:36 .
drwxr-xr-x 17 root    root    4,0K 2010-03-17 21:41 ..
drwxrwxrwx  6 bastien bastien 4,0K 2010-03-17 17:36 dvd
-rw-r--r--  1 root    root     177 2010-03-12 16:22 index.html
drwxrwxrwx  4 bastien bastien 4,0K 2010-03-12 16:32 tpe

J'ai installé lamp via synaptic (paquets apache + mysql + php)

Mais si je crée un user spécifique je devrais systématiquement utiliser ce dernier ? Alors que le but est d'utiliser mon compte actuel.

#22 Re : -1 »  [Résolu][Apache] Problème de permissions » Le 18/03/2010, à 19:31

Cramix
Réponses : 9

Ça marche super, merci à vous tous big_smile ! Je mets en résolu.
Mais dernière question : il m'est impossible d'accéder à webmin depuis un autre poste en local, pourtant le port est bien ouvert sur ma machine et j'utilise le protocole https je ne comprends pas ^o) ?

#23 Re : -1 »  [Résolu][Apache] Problème de permissions » Le 18/03/2010, à 21:09

Cramix
Réponses : 9

Oui https://192.168.1.14:1000 dans mon cas. Fonctionne parfaitement sur la machine en question mais pas sur un autre poste.