Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  Dire adieu à gmail, hotmail, yahoomail... » Le 12/07/2013, à 13:06

Herby
Réponses : 55

Bonjour à tous,

Pas certain que ce sujet aie sa place dans la rubrique sécurité, mais je me lance quand même.

Comme beaucoup j'utilise gmail et hotmail ; et, comme beaucoup, suite aux révélations sur le système PRISM, je cherche une solution pour échapper à ce flicage.
Je pense que la meilleure solution est de prendre un nom de domaine et d'avoir son propre serveur mail. Mais cela n'est pas (encore) dans mes cordes et, avant d'investir dans du matériel, acheter un nom de domaine et apprendre à paramétrer tout ça, je me demande s'il ne serait pas plus simple de simplement ouvrir un compte chez un concurrent qui garantit que ma vie privée reste privée.
Je me suis donc mis à la recherche de ce type de services et j'en ai trouvé pas mal ( genre mailoo ou hushmail). La question est donc de savoir lequel choisir ?
Mes besoins sont très basiques en terme de mail : j'utilise thunderbird pour gérer mes mails sur mon poste principal mais j'ai également besoin d'un webmail pour accéder aux mails persos pendant mes déplacements. Pas besoin d'une grosse capacité de stockage, quelques centaines de Mo devraient suffire, pas besoin non plus de calendrier ou de contacts. Autre critère important : la pérennité. Je souhaite garder cette adresse aussi longtemps que possible et être certain, autant que possible, que l’hébergeur ne disparaitra pas subitement pour X raisons.
Que me conseilleriez-vous ?

  • Utiliser un service en ligne équivalent aux mouchards cités plus haut. Dans ce cas, lequel choisir ?

  • Installer mon propre serveur. Dans ce cas, quel hébergeur et type de serveur choisir ?

#1 Re : -1 »  Dire adieu à gmail, hotmail, yahoomail... » Le 15/07/2013, à 17:03

Herby
Réponses : 55

Salut et merci à tous pour toutes ces réponses.
Après avoir lu tout ça et d'autres infos glanées ça et là, je penche de plus en plus pour un serveur mutualisé avec nom de domaine.

Et un vieux PC pour tester l'auto-hébergement ça peut le faire aussi.

A vrai dire, j'ai déjà un NAS synology qui pourrait très bien faire l'affaire en guise de serveur mail. Le problème, c'est que je n'ai pas une adresse IP fixe et qu'il y a de fréquentes coupures de courant là où je vis. Autant de choses qui me poussent à chercher une solution ailleurs.

Donc si on passe son temps à sécuriser pour envoyer à un correspondant qui utilise gmail, ça ne sert à rien...

Oui et non... En effet, google continuera de voir ce que j'envoie à des correspondants sur gmail mais ne verra plus rien du reste ; qui représente dans mon cas une large majorité de mes mails.

D'une manière général, dès que tu es sur Internet, cette partie de ta vie n'est plus privée.

Certes, mais si mes mails sont sur un serveur que je loue, à priori, moi seul peut y accéder, non ? A moins de se faire hacker, ou que l'hébergeur s'amuse à aller regarder. D'ailleurs, est-ce qu'un hébergeur a le droit et les moyens techniques de voir ce qu'il y a sur ses serveurs ? Et est-ce que les solutions proposées par la plupart des hébergeurs avec des serveurs livrés prêts à l'emploi sont vraiment bien protégées contre le flicage abusif ?
Je suis bien conscient qu'il est impossible d'être invisible sur le réseau. Mon idée est plus de limiter au maximum la quantité d'informations mise à la disposition des trousduc de la NSA qui nous lisent.

mais ce triplet Android - gmail - google n'arrange rien..

Je suis également utilisateur d'android. Il est possible d'utiliser une adresse gmail uniquement pour le store et jamais pour les correspondances. Dans mon cas, je ne l'utilise que très rarement pour mes mails persos, c'est principalement un outil pour le boulot. Donc ça ne me gêne pas de ne pas utiliser le compte gmail associé à l'android. Mais c'est une maigre consolation car, au final, cet objet reste une porte ouverte sur nos vies privées.

#2 -1 »  Empecher le montage des disques NTFS au boot » Le 23/01/2015, à 06:33

Herby
Réponses : 9

Bonjour,

J'ai migré sur Kubuntu 14.04 et depuis, mes disques NTFS sont montés automatiquement au démarrage. Or je préférerais qu'ils ne le soient pas pour éviter d'en modifier le contenu par mégarde.
J'ai vérifié le fichier FSTAB et ils ne s'y trouvent pas. Également vérifié la liste des disques montés au démarrage dans les options KDE, rien non plus sad.
J'ai 2 comptes utilisateur sur cette machine et ce problème n'est présent que sur un seul compte (le mien sad).

Après de nombreuses recherches sur le net et dans les différents panneaux de config, toujours rien. Qu'est-ce qui fait que ces disques sont montés automatiquement ???

#3 Re : -1 »  Empecher le montage des disques NTFS au boot » Le 23/01/2015, à 15:06

Herby
Réponses : 9

Merci de ta réponse Malbo.
Je doute réellement que ces disques ne soient pas réellement montés. Dans dolphin, dans le panneau de gauche, dans périphériques, je vois l’icône en forme de petite prise sur ces disques ; signe qu'ils sont montés. Par ailleurs, il faut entrer le password admin pour monter des disques or je n'ai jamais besoin de le rentrer pour accéder à ces disques. Alors que sur le 2è compte, il faut effectivement entrer le mot de passe pour accéder à ces disques.

Voici le retour de la commande mount :

herby@PC:~$ mount
/dev/sda3 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sdc1 on /media/DATA type ext4 (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
/dev/sdb1 on /media/herby/FS type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda1 on /media/herby/Réservé au système type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /media/herby/58F2BE3AF2BE1C66 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

Les partitions NTFS apparaissent dans les 3 dernières lignes (sda1, sda2 et sdb1).

#4 Re : -1 »  Empecher le montage des disques NTFS au boot » Le 25/01/2015, à 06:19

Herby
Réponses : 9

Je viens d'appliquer les modifs dans "10_gsettings-desktop-schemas.gschema.override" (le fichier est nommé ainsi sur ma machine) et la ligne de commande décrites ci-dessus. Malheureusement, cela n'a rien changé.

maxire a écrit :

En clair c'est le premier utilisateur connecté à un bureau qui prend le contrôle de ces partitions jusqu'à l'arrêt système si rien n'est fait pour les démonter.

A priori ce diagnostic n'est pas exact. Je viens de réessayer :
- En me connectant avec le compte du 2ème utilisateur au démarrage, les partitions NTFS ne sont pas montées.
- Si je me connecte directement sur mon compte, elles sont montées. Si je change ensuite de compte, elles restent montées.

Le mystère reste donc entier sad.

#5 Re : -1 »  Empecher le montage des disques NTFS au boot » Le 25/01/2015, à 19:10

Herby
Réponses : 9

Alors 10_gsettings-desktop-schemas.gschema.override :

[org.gnome.desktop.default-applications.terminal]
exec='x-terminal-emulator'
exec-arg='-e'

et

$ ls /usr/share/glib-2.0/schemas
10_gsettings-desktop-schemas.gschema.override        org.gnome.desktop.a11y.magnifier.gschema.xml        org.gnome.desktop.session.gschema.xml
10_libgtk-3-common.gschema.override                  org.gnome.desktop.a11y.mouse.gschema.xml            org.gnome.desktop.sound.gschema.xml
ca.desrt.dconf-editor.gschema.xml                    org.gnome.desktop.background.gschema.xml            org.gnome.desktop.thumbnail-cache.gschema.xml
com.ubuntu.update-manager.gschema.xml                org.gnome.desktop.datetime.gschema.xml              org.gnome.desktop.thumbnailers.gschema.xml
com.ubuntu.update-notifier.gschema.xml               org.gnome.desktop.default-applications.gschema.xml  org.gnome.desktop.wm.keybindings.gschema.xml
gschemas.compiled                                    org.gnome.desktop.enums.xml                         org.gnome.desktop.wm.preferences.gschema.xml
im.telepathy.MissionControl.FromEmpathy.gschema.xml  org.gnome.desktop.input-sources.gschema.xml         org.gnome.system.dns_sd.gschema.xml
org.freedesktop.ColorHelper.gschema.xml              org.gnome.desktop.interface.gschema.xml             org.gnome.system.gvfs.enums.xml
org.freedesktop.Telepathy.Logger.gschema.xml         org.gnome.desktop.lockdown.gschema.xml              org.gnome.system.locale.gschema.xml
org.gnome.crypto.cache.gschema.xml                   org.gnome.desktop.media-handling.gschema.xml        org.gnome.system.proxy.gschema.xml
org.gnome.crypto.pgp.gschema.xml                     org.gnome.desktop.notifications.gschema.xml         org.gnome.system.smb.gschema.xml
org.gnome.desktop.a11y.applications.gschema.xml      org.gnome.desktop.privacy.gschema.xml               org.gtk.Settings.ColorChooser.gschema.xml
org.gnome.desktop.a11y.gschema.xml                   org.gnome.desktop.screensaver.gschema.xml           org.gtk.Settings.FileChooser.gschema.xml
org.gnome.desktop.a11y.keyboard.gschema.xml          org.gnome.desktop.search-providers.gschema.xml

J'ai installé dconf-editor mais apparemment il ne fonctionne pas sur KDE et je n'ai pas trouvé d'équivalent.

#6 Re : -1 »  Empecher le montage des disques NTFS au boot » Le 26/01/2015, à 10:59

Herby
Réponses : 9

J'ai déjà fouillé dans les configurations système de KDE. Il y a bien une liste des périphériques disponibles à l'ouverture de session. Mes partitions NTFS sont évidemment décochées mais malgré cela, elles sont quand même montées.
Merci de ton aide malgré tout.
Je vais tenter ma chance sur le forum anglophone.

#7 Re : -1 »  Xfi Titanium configuration pour avoir le DTS digital » Le 04/01/2015, à 09:51

Herby
Réponses : 5

Comment ton X-Fi Titanium est elle connectée ? Si je comprends bien, elle est reliée au PC via un câble optique, c'est ça ?
Quel logiciel utilises-tu pour la lecture du son DTS ?

#8 Re : -1 »  Xfi Titanium configuration pour avoir le DTS digital » Le 04/01/2015, à 13:34

Herby
Réponses : 5

Si je comprends bien, Totem, c'est ça : http://apps.microsoft.com/windows/fr-fr … 676631487b
Je viens de jeter un coup d'oeil au tuto en lien dans ton 1er post et je crois que je comprends mieux ce que tu veux faire. Pour résumer, tu veux envoyer du son en SPDIF depuis la carte son de ton PC vers le X-Fi Titanium via un câble optique.

J'ai une config assez similaire. J'envoie le son en optique depuis la carte son intégrée à ma CM sur une SoundBlaster Extigy en PCM ou SPDIF selon les besoins.

Pour info, sous linux, la sortie SPDIF s'appelle IEC958.

Pour l'utiliser par exemple depuis VLC, dans Préférences -> Audio, utilises le module de sortie ALSA, coche la case "utiliser le SPDIF" et sélectionne le périphérique de ta carte son qui a IEC958 dans son nom.

#9 -1 »  [Résolu]Problème d'installation de ConkyClementine » Le 04/01/2015, à 08:41

Herby
Réponses : 1

Salut,

Je viens de migrer sur Kubuntu 14.04 avec une installation toute fraîche.
Je ne parviens à réinstaller ConkyClemanatine (petit script qui permet d'afficher des infos venant du lecteur Clementine dans le conky).

Je suis parti de ce tuto pour l'installation : http://ubuntuforums.org/showthread.php?t=1645481
En suivant la méthode 1:
sudo add-apt-repository ppa:conky-companions/ppa   ---> pas de soucis
sudo apt-get update me renvoie :

21,5 Mo réceptionnés en 1min 8s (314 ko/s)                                     
W: Impossible de récupérer http://ppa.launchpad.net/conky-companions/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/conky-companions/ppa/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found

W: Impossible de récupérer http://vn.archive.ubuntu.com/ubuntu/dists/trusty/universe/source/Sources  Somme de contrôle de hachage incohérente

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

sudo apt-get install conkyclementine renvoie :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet conkyclementine

Du coup, je teste la méthode 2 qui consiste à passer par ce .deb : https://launchpad.net/~conky-companions … 03_all.deb
Et qatp-deb-installer me dit "Erreur : impossible de satisfaire les dépendances".

Pour finir, j'ai testé la méthode 3 mais je ne parviens pas à faire fonctionner ce script.
J'ai conservé mon conky tel qu'il était sur ma précédente installation, modifié les chemins d'accès dans le script comme (vaguement) indiqué dans le tuto mais rien à faire, je ne vois rien apparaître dans mon conky sad.

En charchant un peu plus, il semble que ce problème a déjà été évoqué ici mais pas de solutions en vue :

J'ai d'ailleurs un soucis concernant conkyclementine. Le PPA n'est valable que pour Quantal. J'ai essayé d'installé le paquet en .deb, mais j'ai un problème de dépendance avec python-central.
Existe-t-il une solution?

#10 Re : -1 »  [Résolu]Problème d'installation de ConkyClementine » Le 04/01/2015, à 12:14

Herby
Réponses : 1

Ben je m'en suis sorti tout seul tongue.
Pour faire fonctionner le script, il suffit de décompresser le fichier tar.gz téléchargeable ici dans un répertoire. Perso, je l'ai mis dans mon home.
Il faut ensuite modifier la ligne suivante dans le script "conkyClementine" en renseignant le chemin d'accès au script :
pythonfile="/chemin/d'accès/conkyClementine.py"
Puis, dans le conkyrc, il faut ajouter également le chemin complet vers le script par exemple pour récupérer le titre du morceau :

${exec /chemin/d'accès/conkyClementine --datatype=TI --maxlength=23}

J'espère que je n'aurai pas d'autres mauvaises surprises en l'utilisant mais pour l'instant, ça roule !

#11 -1 »  Login impossible après MàJ » Le 30/12/2014, à 17:52

Herby
Réponses : 2

Bonjour,

Suite à  une grosse mise à jour aujourd'hui incluant une grosse partie des applications Kxxxx, je ne peux plus me logger. Après l’écran de login, j'arrive sur un écran noir et plus rien ne bouge. Du coup, je n'ai plus accès a quoi que ce soit et n'ai aucune idée pour me sortir de cette situation.
Pour info, je suis sur Kubuntu 12.04.5 LTS, KDE 4.8.2
Après un redémarrage en mode recovery, j'ai tenté de démarrer KDE en ligne de commande avec un "startx". Et il s’arrête sur :

Fatal server error:
Could not create lock file in /tmp/.tX0-lock


xinit: giving up
xinit: unable to connect to x server: Connection refused
xinit: server error
xauth error in locking authority file /root/.Xauthority

"rm -f /tmp/.tX0-lock" ne change rien. KDE refait la même erreur sad.
Il semble même que ce répertoire n'est même pas créé au démarrage.

#12 Re : -1 »  Login impossible après MàJ » Le 30/12/2014, à 19:45

Herby
Réponses : 2

je viens d'essayer en supprimant .Xauthority. Il est bien recréé et pour ce qui est des droits, il a -rw-------
Malheureusement, toujours pas moyen de me logger.

#13 -1 »  [Résolu]Impossible de sauvegarder taille et position des plasmoids » Le 07/11/2013, à 16:20

Herby
Réponses : 1

Salut,

Après avoir fait une petite modification de taille/position sur un des plasmoids de mon bureau, je me suis rendu compte que toutes les modifications apportées disparaissent après un logout/login.
Je parviens à ajouter/enlever des plasmoids, modifier leurs paramètres. Mon problème ne concerne apparemment que leurs tailles et positions sur le bureau.
J'ai vérifié les droits des fichiers plasma* dans ~/.kde/share/config et pas de soucis, je peux les modifier.
J'ai tenté cette commande :

herby@PC:~$ kquitapp plasma-desktop
herby@PC:~$ plasma-desktop 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusObjectPath: invalid path ""
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(4847)/libplasma Plasma::PackagePrivate::isValid: Could not find required file mainscript 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
RubyAppletScript::Applet#init mainScript: /home/herby/.kde/share/apps/plasma/plasmoids/stealth-cashew/contents/code/main.rb
RubyAppletScript::Applet#init instantiating: StealthCashew::Main
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
========================>  3 0
herby@PC:~$ plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()! 
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()! 
"/org/freedesktop/UDisks2/drives/ST3250318AS_5VMHH4M8" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/ST3500641AS_3PM02QDL" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/ST3500641AS_3PM02QDL" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/ST3500641AS_3PM02QDL" : property "Device" does not exist 
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:103: TypeError: Result of expression 'listView' [null] is not an object.
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:175: ReferenceError: Can't find variable: sectionsRepeater
file:///usr/lib/kde4/imports/org/kde/plasma/components/SectionScroller.qml:103: Error: Cannot assign [undefined] to QString
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.                                                                                                                                                                    
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.                                                                                                                                                                    
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.                                                                                                                                                                    
file:///usr/share/kde4/apps/plasma/plasmoids/notifier/contents/ui/devicenotifier.qml:224:13: QML QDeclarativeListView_QML_98: Boucle potentielle détectée dans les ancres pour le remplissage.                                                                                                                                                                    
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application                                                                      
"/org/freedesktop/UDisks2/drives/ST3250318AS_5VMHH4M8" : property "DeviceNumber" does not exist                                                                                    
"/org/freedesktop/UDisks2/drives/ST3250318AS_5VMHH4M8" : property "Device" does not exist                                                                                          
                                                                                                                                                                                   
(process:4847): GLib-GIO-WARNING **: Received property menu with type s does not match expected type o in the expected interface                                                   
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()!                                                                                        
plasma-desktop(4847) MessageIndicator::adjustViewSize: No parentWidget for applet widget()! 
plasma-desktop(4847)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x1e001ba
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x1e001ba

Il y a peut-être un début de solution à mon problème là-dedans mais c'est au-delà de mes compétences.

#14 Re : -1 »  [Résolu]Impossible de sauvegarder taille et position des plasmoids » Le 17/11/2013, à 11:46

Herby
Réponses : 1

Encore un auto-déterrage :
J'ai installé un widget qui s'appelle "Stealth Cashew" et qui sert à masquer le cashew permettant de changer d'activité. Vu que je n'utilise pas cette fonctionalité, je préfère ne pas le voir.
Je ne sais pas trop pourquoi mais ce widget était la cause du problème. Je l'ai désinstallé avant de faire mes modifications de plasmoids. Et, miracle, après un reboot, tous les plasmoids sont restés là où je les avais mis.
Réinstall de stealth cashew et retour à la vie normale smile
@+

#15 -1 »  [Résolu]Comment désactiver le gestionnaire de fenêtres (kwin)? » Le 06/11/2013, à 14:39

Herby
Réponses : 3

Bonjour,

Je souhaite stopper le gestionnaire de fenêtres KWIN sur mon écran externe (une TV LCD HD) qui ne me sert que pour XBMC.
Je parviens à le faire en tuant le processus via ksysguard mais, vu que je lance XBMC grâce à un script, j'aimerais pouvoir ajouter une ligne dans ce script pour arrêter ce processus au démarrage de XBMC automatiquement.
Quelle pourrait être cette ligne ?
Je sais démarrer ce processus avec la commande

DISPLAY=:0.1 kwin &

Mais je ne sais pas comment l'arrêter sad

#16 Re : -1 »  [Résolu]Comment désactiver le gestionnaire de fenêtres (kwin)? » Le 07/11/2013, à 12:33

Herby
Réponses : 3

Merci pour cette réponse.

kill <numéro du prossecus>

Cette commande devrait fonctionner mais est-ce que le numéro de processus est toujours le même, notamment après un reboot ? Je ne suis pas devant ma machine Linux maintenant. Je ferai un essai des que je suis dessus.

killall <nom du prossecus>

Par contre, cette 2eme commande va tuer tous les processus or je ne veux en arrêter qu'un. Sur un système avec 2 moniteurs en mode separate x screen, il y a 2 processus KWIN (un par moniteur).

#17 Re : -1 »  [Résolu]Comment désactiver le gestionnaire de fenêtres (kwin)? » Le 07/11/2013, à 17:31

Herby
Réponses : 3

Trouvé !
La ligne magique est :

kill -9 $(ps -ef | grep kwin |awk 'NR==2 {print $2}')

Et pour répondre à l'interrogation du post précédent, les PID changent après chaque login.

#18 -1 »  [Résolu]Conky n'affiche le bon pourcentage d'espace disque utilisé » Le 07/10/2013, à 16:04

Herby
Réponses : 5

Salut,

Pas sûr d'être au bon endroit pour demander de l'aide pour un conky, mais tant pis.
Je viens de remarquer que le pourcentage d'espace utilisé indiqué par mon conky est faux. Un df -h me renvoie :

Sys. de fichiers           Taille Utilisé Dispo Uti% Monté sur
/dev/sda3                     49G     18G   29G  39% /
/dev/sdb1                    337G    307G   13G  97% /media/DATA

Et le conky m'indique 36% de libre sur le sda3 et 91% pour sdb1.
Voilà la ligne en question sortie de mon conky.rc :

${fs_used_perc /}%${alignr}${offset -28}${fs_used_perc /media/DATA}%

J'ai cherché un peu mais je n'ai pas trouvé d'autres façons de procéder pour afficher cette valeur et je ne comprends pas d'où peut venir cet écart.

#19 Re : -1 »  [Résolu]Conky n'affiche le bon pourcentage d'espace disque utilisé » Le 07/10/2013, à 17:07

Herby
Réponses : 5
ljere a écrit :

conky a raison
307*100/337=91%

C'est vrai !
Mais d'un autre côté, si on regarde l'espace libre :
13*100/337=3% donc 97% libre !?! roll

Je viens de modifier mon conky en remplaçant fs_used_perc par fs_free_perc. Et ça me donne 3% de libre alors qu'il m'indiquait 91% utilisés.
Pour résumer, pour les 2 disques, en additionnant l'espace utilisé + l'espace libre, on arrive en dessous de la taille totale. Pourquoi ?
Pour info, ces 2 partitions sont en ext4.

#20 Re : -1 »  [Résolu]Conky n'affiche le bon pourcentage d'espace disque utilisé » Le 08/10/2013, à 14:56

Herby
Réponses : 5
tiramiseb a écrit :

Parce qu'il y a un pourcentage réservé à "root" : comme ça, si jamais un utilisateur (ou un programme) "remplit" le disque, eh bien en fait il n'est pas rempli : l'administrateur (root) peut réparer le système et n'a pas besoin de jongler avec des disques complètement pleins. C'est surtout utile sur un serveur.
Pour libérer cet espace disque, tu peux utiliser la commande tune2fs avec l'argument -m, surtout sur le disque de données qui n'est pas crucial de ce point de vue :

sudo tune2fs -m 0 /dev/sdb1

Pour le disque système (/dev/sda3), je conseille de laisser cette limite.

Merci beaucoup pour cette info et surtout pour cette commande.
Comme recommandé, je ne l'ai fait que sur mon disque DATA -> IMPECCABLE ! En plus, vu que ce disque est quasiment plein, ces quelques gigas supplémentaires sont vraiment les bienvenus.
Pour le disque système, cette partition est suffisamment grande pour ne jamais être remplie à plus de 50%, donc, effectivement, pas besoin.

Encore merci wink

#21 -1 »  [Résolu] Problème avec XBMC en mode fenêtré » Le 22/09/2013, à 06:55

Herby
Réponses : 4

Salut,

Depuis quelques jours (apparemment suite à une série de mises à jour), j'ai un souci bien énervant avec XBMC.
J'utilise XBMC sur un écran externe (une télé LCD) branché sur le port HDMI de ma CG. J'utilise le mode separate x screen dans les settings nvidia.
Lorque XBMC est en plein écran, il n'est plus possible de passer la souris sur l'autre écran. Il faut donc le mettre en mode fenêtré. Or, depuis quelques jours, lorsque je passe en mode fenêtré, la bordure de la fenêtre d'XBMC est absente et l'application n'apparaît pas dans la barre des tâches. Ce qui fait qu'il est impossible de redimensionner la fenêtre, de la déplacer ou de fermer l'application. Encore plus ennuyeux : même en cliquant dans la fenêtre, le clavier ne fonctionne plus et ne me permet plus de contrôler l'application. Je ne peux donc plus repasser XBMC en plein écran à moins d'arrêter la lecture en cours pour aller dans les réglages de XBMC à l'aide de la souris ou de la télécommande. Alors qu'avant, il suffisait d'appuyer sur une touche pour basculer du mode fenêtré au plein écran et inversement.
J'ai cherché l'origine du problème dans les réglages de fenêtre de KDE mais n'ai rien trouvé d'anormal. Et, vu que la bordure de l'application est absente, je ne peux pas accéder aux réglages spécifiques de cette fenêtre via un clic droit dans la barre de titre.
Bref, je ne sais plus trop où chercher une solution à ce problème.

#22 Re : -1 »  [Résolu] Problème avec XBMC en mode fenêtré » Le 22/09/2013, à 16:04

Herby
Réponses : 4

Bien vu classdroogies
En lisant ta réponse, je me suis souvenu que j'avais modifié la ligne de commande de lancement d'XBMC. Voici cette ligne :

SDL_VIDEO_FULLSCREEN_HEAD=1 DISPLAY=:0.1 xbmc -fs

J'ai essayé de lancer d'autres applications en DISPLAY=:0.1 et j'ai les mêmes soucis (pas de bordure et pas de clavier). Je vais creuser dans cette direction.
Je viens d'essayer l'astuce décrite dans ton lien et ça contourne à peu près le problème. Dans mon cas, il m'a suffi de changer la résolution de l'écran dans ~/.xbmc/userdata/guisettings.xml.
Maintenant, même en mode fenêtré, XBMC apparaît en plein écran sur ma télé cool
Il reste 2 problèmes tout de même :
- Le clavier ne marche pas. Dans l'absolu, ce n'est pas très gênant vu que j’utilise principalement la télécommande pour piloter XBMC. Sauf quand j'ajoute des films qu'il ne trouve pas dans les bases de données. Il faut alors entrer le titre du film et sans clavier -> galère. Mais cee n'est pas si fréquent et il est toujours possible de repasser XBMC en mode fullscreen le temps de faire la manip.
- En mode fenêtré, XBMC n'empêche pas la mise en veille de l'écran. Devoir rallumer l'écran toutes les 20 minutes quand je regarde un film, ce n'est pas concevable. Je vais donc chercher une solution pour ce 2ème souci.
Merci du coup de main.

#23 Re : -1 »  [Résolu] Problème avec XBMC en mode fenêtré » Le 22/09/2013, à 18:48

Herby
Réponses : 4

Encore une fois, tu as mis dans le mille !
J'ai simplement modifié la ligne de commande pour le lancement d'XBMC :

DISPLAY=:0.1 kwin & SDL_VIDEO_FULLSCREEN_HEAD=1 DISPLAY=:0.1 xbmc -fs

Et je retrouve le même comportement qu'avant... OUF !
Du coup, je vais peut-être lancer le gestionnaire de fenêtre sur le 2è écran à l'ouverture de session plutôt qu'au démarrage d'XBMC... à voir ; ou encore mieux, utiliser un script pour désactiver la gestion d'énergie au lancement d'XBMC et la réactiver à la fermeture. Je viens de créer ce script :

#!/bin/sh
 
#Disable PowerManager
xset -dpms
 
#Disable PowerManager
xset s off

# Start XBMC
SDL_VIDEO_FULLSCREEN_HEAD=1 DISPLAY=:0.1 xbmc -fs
 
# Enable ScreenSaver when XBMC closes
xset s on

# Enable PowerManager when XBMC closes
xset +dpms

Et apparemment, il fonctionne parfaitement.
En tout cas, j'ai maintenant toutes les options pour faire tourner XBMC comme avant et même mieux qu'avant.
Encore merci pour le coup de main wink

#24 -1 »  Caliop, un email sécurisé » Le 09/09/2013, à 11:00

Herby
Réponses : 1

Salut a tous,

Depuis les révélations concernant l'affaire PRISM (et étant un dangereux terroriste cool ), je cherche a virer mes comptes emails hébergés par les mouchards bien connus pour une solution plus 'respectueuse de la vie privée' (ou de ce qu’il en reste).
Je viens de découvrir le projet "Caliop" qui semble prometteur et pourrait être un digne successeur du feu lavabit.
Affaire à suivre...