Contenu | Rechercher | Menus

Annonce

Toute l'équipe d'ubuntu-fr vous souhaite un joyeux Noël et une bonne et heureuse année 2018.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 -1 »  Problème avec sudo » Hier à 09:25

tuxrouge
Réponses : 5

Bonjour à tout le monde

Je n'arrive pas à lancer un programme avec sudo ou en su
voilà le genre de message que j'obtiens

# gparted
Created symlink /run/systemd/system/-.mount → /dev/null.
Created symlink /run/systemd/system/boot-efi.mount → /dev/null.
Created symlink /run/systemd/system/home.mount → /dev/null.
Created symlink /run/systemd/system/run-user-1001.mount → /dev/null.
Created symlink /run/systemd/system/run-user-120.mount → /dev/null.
Created symlink /run/systemd/system/tmp.mount → /dev/null.
No protocol specified

(gpartedbin:4090): Gtk-WARNING **: cannot open display: :0
Removed /run/systemd/system/-.mount.
Removed /run/systemd/system/boot-efi.mount.
Removed /run/systemd/system/home.mount.
Removed /run/systemd/system/run-user-1001.mount.

[code]# unetbootin 
No protocol specified
unetbootin: cannot connect to X server :0
Removed /run/systemd/system/run-user-120.mount.
Removed /run/systemd/system/tmp.mount.[/code]
# synaptic
No protocol specified
Unable to init server: Impossible de se connecter : Connexion refusée

(synaptic:4366): Gtk-WARNING **: cannot open display: :0

bref impossible d'avoir une fenêtre quand je suis en tant que root.

Vous avez une idée de la solution ?

#1 Re : -1 »  Problème avec sudo » Hier à 11:52

tuxrouge
Réponses : 5

le problème se posait avec sudo aussi
mais la solution est dans le lien évoqué par cqfd93;

ON NE PEUT PAS LANCER D'APPLICATIONS GRAPHIQUES EN TANT QU'ADMIN
ET C'EST NORMAL, C'EST FAIT EXPRÈS

bon ben me reste plus qu'à trouver des alternatives

Pour info ces logiciels  ne se lancent pas non plus en tant qu'utilisateur chez moi

$ synaptic
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Erreur de segmentation (core dumped)
$ unetbootin 
$ Error copying '/home/moi/.Xauthority' to '/tmp/libgksu-w9dqhP': Aucun fichier ou dossier de ce type
$ gparted
Root privileges are required for running gparted.

pour gparted et synaptic j'ai la boite de dialogue qui demande le mot de passe puis, ça plante

#2 -1 »  ecran à l'enver ? » Le 25/11/2017, à 16:51

tuxrouge
Réponses : 12

bonjour à tous

lors de l'installation d'ubuntu (sur une asus t100) j'ai constaté un affichage dans le bons sens jusqu'au moment ou je suis connecté (gnome) alors, l'écran est à l'envers
et même l'interface tactile se comporte bizarrement, la souris ne point pas là où on pose le doigt.

il y a une astuce pour remédier au problème ?

#3 Re : -1 »  ecran à l'enver ? » Le 03/12/2017, à 14:31

tuxrouge
Réponses : 12

après une semaine en belgique dans un coin sans réseau (oui, ça existe encore)
la console me dit que --rotate doit être utilisé après --output

et xrandr --output --rotate inverted me dit que inverted n'est pas une option valable

#4 Re : -1 »  ecran à l'enver ? » Le 03/12/2017, à 18:37

tuxrouge
Réponses : 12

je n'avais pas compris la question

xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
DSI-1 connected primary 1366x768+0+0 inverted (normal left inverted right x axis y axis) 0mm x 0mm
...

cet "inverted" m'intrigue

#5 Re : -1 »  ecran à l'enver ? » Le 03/12/2017, à 20:55

tuxrouge
Réponses : 12

la commande fonctionne

par contre je suis sur une session  live donc je ne vais pas pouvoir logger grand chose
ce qui m'intrigue c'est que j'ai exactement le même problème avec une live de fedora

#6 Re : -1 »  ecran à l'enver ? » Le 03/12/2017, à 21:48

tuxrouge
Réponses : 12

les deux mon capitaine
mais j'avais recommencé une installation en pensant que je m'étais fourvoyé quelque part
en ce moment je suis sur une live

#7 Re : -1 »  ecran à l'enver ? » Le 08/12/2017, à 00:12

tuxrouge
Réponses : 12

bon après quelques difficultés voici ubuntu installée sur la machine
le problème est identique
une différence cependant. L'écran est maintenant intitulé XWAYLAND0 et la commande indiquée (avec le changement qui va bien) ne produit aucun résultat (mais sans message d'erreur)

#8 -1 »  [resolu] Problème de connexion avec thunderbird » Le 03/10/2017, à 08:44

tuxrouge
Réponses : 2

Bonjour à tout le monde

Depuis hier après-midi je n'arrive plus à envoyer ni recevoir de mail.
J'ai essayé sur un autre poste (même configuration) et ça fonctionne

J'ai viré les comptes (en imap) dans l'idée de les recréer et au lancement de thunderbird. Quand je le relance et que je veux rentrer un nouveau compte, la procédure se passe bien (en automatique), me demande le mot de passe, m'indique qu'il est bon mais m'empêche de valider ("terminer" est grisé)
J'ai essayé avec un autre fournisseur (google, free), idem je ne peux créer de nouveau compte. Si je passe en configuration manuelle il m'est indiqué que le compte existe déjà !
et thunderird m'indique "envoi des informations pour la connexion sécurisé" mais rien ne se passe

Que se passe t'il  et comment puis-je y remédier ?

#9 Re : -1 »  [resolu] Problème de connexion avec thunderbird » Le 03/10/2017, à 10:03

tuxrouge
Réponses : 2

merci pour la réponse

effectivement en virant le profil j'ai pu recommencer. J'espère que ça ne se reproduira pas

#10 -1 »  reinitialisation carte sd » Le 16/04/2017, à 16:54

tuxrouge
Réponses : 12

bonjour à tous

j'ai un pb avec une carte sd sandisk ultra de 64 GO

gparted voit une seule partition de 27,48 GO
testdisk aussi

comment puis-je faire pour la remettre aux valeurs d'usine et retrouver mes 64 GO?

#11 Re : -1 »  reinitialisation carte sd » Le 16/04/2017, à 20:33

tuxrouge
Réponses : 12

bonjour erresse et merci pour la réponse

oui, je suis sûr de la taille de la carte, c'est marqué dessus et je l'utilise depuis plusieurs mois avec la "bonne" capacité

j'ai testé les manipulations indiquées mais ça n'a rien changé (j'obtiens toujours une partition de 27,48 GO et rien de plus)

dans les options de testdisk il trouve un problème d'architecture
si j'essaye de la formater depuis un appareil photo, l'appareil refuse en me disant que la carte n'est pas bonne

#12 Re : -1 »  reinitialisation carte sd » Le 17/04/2017, à 15:29

tuxrouge
Réponses : 12

la carte est une micro-sd insérée dans un adaptateur pour les raisons du test
écriture et modification des partions possible
résultat des commandes:

$ udisksctl info -b /dev/sdd
/org/freedesktop/UDisks2/block_devices/sdd:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sdd
    DeviceNumber:               2096
    Drive:                      '/org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532'
    HintAuto:                   true
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 false
    Id:                         
    IdLabel:                    
    IdType:                     
    IdUUID:                     
    IdUsage:                    
    IdVersion:                  
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sdd
    ReadOnly:                   false
    Size:                       0
    Symlinks:                   /dev/disk/by-id/usb-Lexar_RW047SDHC_Reader_AA00000000000532-0:0
                                /dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.4:1.0-scsi-0:0:0:0
$ ls -l /dev/sdd
brw-rw---- 1 root disk 8, 48 17 avril 16:18 /dev/sdd
$ udisksctl info -b /dev/sdd1
Error looking up object for device /dev/sdd1

concernant testdisk il me dit

TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/sdd - 29 GB / 27 GiB - CHS 28138 64 32
Current partition structure:
     Partition                  Start        End    Size in sectors

 1 P FAT32                    1   0  1 28137  63 32   57624576

Warning: Bad starting sector (CHS and LBA don't match)
No partition is bootable

#13 Re : -1 »  reinitialisation carte sd » Le 17/04/2017, à 15:38

tuxrouge
Réponses : 12

surprise avec l'appareil photo

une fois la carte formatée insérée il m'a demandé de la formater (directement depuis l'appareil).
tout va bien pour le nikon

J'extrais la carte pour la passer sur l'ordinateur et là, miracle, je vois une carte avec les dossiers créés automatiquement par l'appareil de ... 64 GO!
Prudent, je la démonte puis la remonte.
Un petit tour de gparted et ...

un espace non alloué de 4Mio est indiqué en début de carte puis ensuite la partition de 59,47 Gio/ Pourtant gparted m'indique que sdd est de 27,48 Gio.
les résultats avec les mêmes commandes que précédemment:

$ udisksctl info -b /dev/sdd
/org/freedesktop/UDisks2/block_devices/sdd:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sdd
    DeviceNumber:               2096
    Drive:                      '/org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532'
    HintAuto:                   true
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 false
    Id:                         
    IdLabel:                    
    IdType:                     
    IdUUID:                     
    IdUsage:                    
    IdVersion:                  
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sdd
    ReadOnly:                   false
    Size:                       29504831488
    Symlinks:                   /dev/disk/by-id/usb-Lexar_RW047SDHC_Reader_AA00000000000532-0:0
                                /dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.3:1.0-scsi-0:0:0:0
  org.freedesktop.UDisks2.PartitionTable:
    Type:               dos
$ ls -l /dev/sdd
brw-rw---- 1 root disk 8, 48 17 avril 16:31 /dev/sdd
$ udisksctl info -b /dev/sdd1
/org/freedesktop/UDisks2/block_devices/sdd1:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sdd1
    DeviceNumber:               2097
    Drive:                      '/org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532'
    HintAuto:                   true
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 false
    Id:                         
    IdLabel:                    
    IdType:                     
    IdUUID:                     
    IdUsage:                    
    IdVersion:                  
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sdd1
    ReadOnly:                   false
    Size:                       63860375552
    Symlinks:                   /dev/disk/by-id/usb-Lexar_RW047SDHC_Reader_AA00000000000532-0:0-part1
                                /dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.3:1.0-scsi-0:0:0:0-part1
  org.freedesktop.UDisks2.Filesystem:
    MountPoints:        /run/media/mathieu/NIKON D5000
  org.freedesktop.UDisks2.Partition:
    Flags:              0
    IsContained:        false
    IsContainer:        false
    Name:               
    Number:             1
    Offset:             4194304
    Size:               63860375552
    Table:              '/org/freedesktop/UDisks2/block_devices/sdd'
    Type:               
    UUID:               
TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/sdd - 29 GB / 27 GiB - CHS 28138 64 32
Current partition structure:
     Partition                  Start        End    Size in sectors

Warning: number of heads/cylinder mismatches 2 (FAT) != 64 (HD)
Warning: number of sectors per track mismatches 16 (FAT) != 32 (HD)
 1 P FAT32 LBA                4   0  1 60905  63 32  124727296 [NIKON D5000]

Warning: Bad ending sector (CHS and LBA don't match)
No partition is bootable

#14 Re : -1 »  reinitialisation carte sd » Le 17/04/2017, à 17:49

tuxrouge
Réponses : 12

tout d'abord merci pour l'aide apportée

ensuite, la galère continue
la carte se monte bien et dans ce cas gparted la voit mais me dit
"la partition ne peut pas être en dehors du disque"

si je démonte la carte alors, gparted ne la voit pas ?!

$ ls -l /dev/sdd?
ls: impossible d'accéder à '/dev/sdd?': Aucun fichier ou dossier de ce type

#15 Re : -1 »  reinitialisation carte sd » Le 17/04/2017, à 20:25

tuxrouge
Réponses : 12

Héhé je suis malheureusement assez vieux pour avoir connu le montage à la main des partitions (mount -t) et je ne faisais pas d'erreur de langage
ou alors, je suis neuneu (ce qui n'est jamais à exclure me concernant)

actuellement la carte n'est pas "mountée"

$ ls -l /run/media/mathieu/
total 0

j'ai encore loupé quelque chose ?

et gparted ne la voit pas

#16 Re : -1 »  reinitialisation carte sd » Le 17/04/2017, à 21:51

tuxrouge
Réponses : 12
[lun. avril 17 21:42:20 2017] usb 1-1.3: new high-speed USB device number 17 using ehci-pci
[lun. avril 17 21:42:21 2017] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[lun. avril 17 21:42:21 2017] scsi host7: usb-storage 1-1.3:1.0
[lun. avril 17 21:42:22 2017] scsi 7:0:0:0: Direct-Access     Lexar    RW047SDHC Reader 0100 PQ: 0 ANSI: 0 CCS
[lun. avril 17 21:42:22 2017] sd 7:0:0:0: Attached scsi generic sg4 type 0
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] 57626624 512-byte logical blocks: (29.5 GB/27.5 GiB)
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] Write Protect is off
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] Mode Sense: 4b 00 00 08
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] No Caching mode page found
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] Assuming drive cache: write through
[lun. avril 17 21:42:23 2017]  sde: sde1
[lun. avril 17 21:42:23 2017] sde: p1 size 124727296 extends beyond EOD, enabling native capacity
[lun. avril 17 21:42:23 2017]  sde: sde1
[lun. avril 17 21:42:23 2017] sde: p1 size 124727296 extends beyond EOD, truncated
[lun. avril 17 21:42:23 2017] sd 7:0:0:0: [sde] Attached SCSI removable disk

et un peu de monitoring pendant le branchement

22:42:57.799: Added /org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532
  org.freedesktop.UDisks2.Drive:
    CanPowerOff:                true
    Configuration:              {}
    ConnectionBus:              usb
    Ejectable:                  true
    Id:                         Lexar-RW047SDHC-Reader-AA00000000000532
    Media:                      
    MediaAvailable:             true
    MediaChangeDetected:        true
    MediaCompatibility:         
    MediaRemovable:             true
    Model:                      RW047SDHC Reader
    Optical:                    false
    OpticalBlank:               false
    OpticalNumAudioTracks:      0
    OpticalNumDataTracks:       0
    OpticalNumSessions:         0
    OpticalNumTracks:           0
    Removable:                  true
    Revision:                   0100
    RotationRate:               -1
    Seat:                       seat0
    Serial:                     AA00000000000532
    SiblingId:                  /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0
    Size:                       29504831488
    SortKey:                    01hotplug/1492461777799001
    TimeDetected:               1492461777799001
    TimeMediaDetected:          1492461777799001
    Vendor:                     Lexar
    WWN:                        
22:42:57.800: Added /org/freedesktop/UDisks2/block_devices/sde
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sde
    DeviceNumber:               2112
    Drive:                      '/org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532'
    HintAuto:                   true
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 false
    Id:                         
    IdLabel:                    
    IdType:                     
    IdUUID:                     
    IdUsage:                    
    IdVersion:                  
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sde
    ReadOnly:                   false
    Size:                       29504831488
    Symlinks:                   /dev/disk/by-id/usb-Lexar_RW047SDHC_Reader_AA00000000000532-0:0
                                /dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.3:1.0-scsi-0:0:0:0
  org.freedesktop.UDisks2.PartitionTable:
    Type:               dos
22:42:57.888: Added /org/freedesktop/UDisks2/block_devices/sde1
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sde1
    DeviceNumber:               2113
    Drive:                      '/org/freedesktop/UDisks2/drives/Lexar_RW047SDHC_Reader_AA00000000000532'
    HintAuto:                   true
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 false
    Id:                         by-label-NIKON\x20D5000
    IdLabel:                    NIKON D5000
    IdType:                     vfat
    IdUUID:                     
    IdUsage:                    filesystem
    IdVersion:                  FAT32
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sde1
    ReadOnly:                   false
    Size:                       29500637184
    Symlinks:                   /dev/disk/by-id/usb-Lexar_RW047SDHC_Reader_AA00000000000532-0:0-part1
                                /dev/disk/by-label/NIKON\x20D5000
                                /dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.3:1.0-scsi-0:0:0:0-part1
  org.freedesktop.UDisks2.Filesystem:
    MountPoints:        
  org.freedesktop.UDisks2.Partition:
    Flags:              0
    IsContained:        false
    IsContainer:        false
    Name:               
    Number:             1
    Offset:             4194304
    Size:               29500637184
    Table:              '/org/freedesktop/UDisks2/block_devices/sde'
    Type:               
    UUID:               
22:42:57.912: Added /org/freedesktop/UDisks2/jobs/39
  org.freedesktop.UDisks2.Job:
    Bytes:              0
    Cancelable:         true
    ExpectedEndTime:    0
    Objects:            ['/org/freedesktop/UDisks2/block_devices/sde1']
    Operation:          filesystem-mount
    Progress:           0.0
    ProgressValid:      false
    Rate:               0
    StartTime:          1492461777910727
    StartedByUID:       1000
22:42:57.932: /org/freedesktop/UDisks2/block_devices/sde1: org.freedesktop.UDisks2.Filesystem: Properties Changed
  MountPoints:          /run/media/mathieu/NIKON D5000
22:42:57.940: /org/freedesktop/UDisks2/jobs/39: org.freedesktop.UDisks2.Job::Completed (true, '')
22:42:57.940: Removed /org/freedesktop/UDisks2/jobs/39

du coup le noyau la détecte bien. Pb sur la taille encore une fois

comme je suis obstiné j'ai essayé de tout faire depuis garted
lancement de gparted avec message indiquant "la partition ne peut pas être en dehors du disque"
je démonte sde1 depuis gparted et je créé la table de partition type msdos
mais gparted ne me propose alors que 27,48 GO, comme d'hab...

#17 -1 »  [resolu] apache2 et reverse proxy » Le 25/03/2017, à 01:04

tuxrouge
Réponses : 7

Bonjour à tous

J'ai besoin qu'en se connectant à mon site (monsite.fr) le visiteur aille sur le port 8888
J'ai fouillé la doc et je suis tombé là dessus

J'ai créé monsite.conf dans /etc/apache2/sites-available/proxy-host (après avoir activé les différents modules de apache)

<VirtualHost *:80>
  ServerAdmin webmaster@localhost
  DocumentRoot /var/www/
  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined
  ProxyPreserveHost On
  # Servers to proxy the connection, or
  # List of application servers Usage
  ProxyPass / http://monsite.fr:8888/
  ProxyPassReverse / http://monsite.fr:8888/
  ServerName localhost
</VirtualHost>

je l'active, je modifie /etc/apache2/ports.conf en lui disant d'écouter le port 8888, je recharge apache et ... nada, rien "la connexion a échouée"

Qu'est-ce qui est faux dans mon fichier ?

#18 Re : -1 »  [resolu] apache2 et reverse proxy » Le 25/03/2017, à 01:38

tuxrouge
Réponses : 7

Salut Vobul

C'est un CMS que j'ai sur ce port. Je veux donc que les visiteurs qui arrivent sur ma page (port 80 si j'ai bien compris) aillent en fait sur le port 8888 (ou autre, je peux le changer)
comme je suis pas trop dégourdi avec tout ça j'ai suivi la doc qui me semblai la plus simple et j'ai choisi l'option apache parce qu'il est déjà installé sur ma machine.
Sinon si tu as une doc ultrasimple pour un neuneu pour nginx, je suis preneur aussi wink

#19 Re : -1 »  [resolu] apache2 et reverse proxy » Le 25/03/2017, à 09:22

tuxrouge
Réponses : 7
# service apache2 status
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: inactive (dead) since sam. 2017-03-25 00:58:33 CET; 8h ago
  Process: 30801 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 30182 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
  Process: 30784 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

mars 25 00:58:33 serveur apache2[30784]: Starting web server: apache2[Sat Mar 25 00:58:33.879669 2017] [proxy_html:notice] [pid 30798] AH01425: I18n support in mod_pr...ncorrectly.
mars 25 00:58:33 serveur apache2[30784]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8888
mars 25 00:58:33 serveur apache2[30784]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8888
mars 25 00:58:33 serveur apache2[30784]: no listening sockets available, shutting down
mars 25 00:58:33 serveur apache2[30784]: AH00015: Unable to open logs
mars 25 00:58:33 serveur apache2[30784]: Action 'start' failed.
mars 25 00:58:33 serveur apache2[30784]: The Apache error log may have more information.
mars 25 00:58:33 serveur apache2[30784]: .
mars 25 00:58:33 serveur apache2[30801]: Stopping web server: apache2.
mars 25 00:58:33 serveur systemd[1]: Started LSB: Apache2 web server.
Hint: Some lines were ellipsized, use -l to show in full.

#20 Re : -1 »  [resolu] apache2 et reverse proxy » Le 25/03/2017, à 10:13

tuxrouge
Réponses : 7

Hop, c'était effectivement ça, le listen
j'ai du mal comprendre la doc

merci

#21 -1 »  [resolu] GIT pour un nul » Le 23/03/2017, à 00:45

tuxrouge
Réponses : 2

Bonjour à vous

J'ai installé odoo en suivant la doc et git

$ git clone git clone https://github.com/odoo/odoo.git

mais maintenant, quelle est la commande pour que je puisse mettre à jours les fichiers modifiers sur le dépot ?

J'ai essayé un  git pull https://github.com/odoo/odoo.git mais ça ne donne rien
et je ne trouve pas dans les différentes documentations la commande qui va bien.

Vous avez une idée ?

#22 Re : -1 »  [resolu] GIT pour un nul » Le 25/03/2017, à 00:45

tuxrouge
Réponses : 2

merci, ça fonctionne. C'était tout simple

#23 -1 »  Probleme mise à jour programme » Le 17/03/2017, à 09:25

tuxrouge
Réponses : 1

Bonjour

J'ai odoo sur mon serveur
lors de la mise à jour j'obtiens une erreur:

Failed to perform requested operation on package.  Trying to recover:
Paramétrage de odoo (10.0.20170317) ...
chown: impossible d'accéder à « /var/lib/odoo »: Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet odoo (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 odoo

et c'est normal qu'il ne puisse pas accéder à /var/lib/odoo parce que celui-ci n'existe pas
odoo est installé dans /odoo

et voici les sorties de ls -a /var/lib/dpkg/ et ls -al /var/backups

# ls -a /var/lib/dpkg/
.   alternatives  cmethopt    diversions-old  lock   statoverride      status	   triggers
..  available	  diversions  info	      parts  statoverride-old  status-old  updates
# ls -al /var/backups
total 8356
drwxr-xr-x  2 root root      4096 mars  17 06:25 .
drwxr-xr-x 12 root root      4096 sept.  8  2016 ..
-rw-r--r--  1 root root     92160 mars   1 06:25 alternatives.tar.0
-rw-r--r--  1 root root      5879 févr. 25 06:25 alternatives.tar.1.gz
-rw-r--r--  1 root root      5796 janv. 28 06:25 alternatives.tar.2.gz
-rw-r--r--  1 root root      5798 déc.   4 06:25 alternatives.tar.3.gz
-rw-r--r--  1 root root      5789 nov.   7 06:25 alternatives.tar.4.gz
-rw-r--r--  1 root root      5777 sept.  8  2016 alternatives.tar.5.gz
-rw-r--r--  1 root root     35859 mars   1 11:43 apt.extended_states.0
-rw-r--r--  1 root root      3920 févr. 28 17:32 apt.extended_states.1.gz
-rw-r--r--  1 root root      3931 févr.  8 14:46 apt.extended_states.2.gz
-rw-r--r--  1 root root      3055 déc.   3 17:29 apt.extended_states.3.gz
-rw-r--r--  1 root root      2948 nov.   6 19:43 apt.extended_states.4.gz
-rw-r--r--  1 root root      2945 sept.  8  2016 apt.extended_states.5.gz
-rw-r--r--  1 root root   4310524 mars   1 11:43 aptitude.pkgstates.0
-rw-r--r--  1 root root    367073 févr. 28 17:32 aptitude.pkgstates.1.gz
-rw-r--r--  1 root root    367072 févr.  8 14:46 aptitude.pkgstates.2.gz
-rw-r--r--  1 root root    366826 janv.  8 19:02 aptitude.pkgstates.3.gz
-rw-r--r--  1 root root    366830 déc.   3 17:29 aptitude.pkgstates.4.gz
-rw-r--r--  1 root root    366703 sept.  8  2016 aptitude.pkgstates.5.gz
-rw-r--r--  1 root root       770 févr.  8 12:23 dpkg.diversions.0
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.1.gz
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.2.gz
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.3.gz
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.4.gz
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.5.gz
-rw-r--r--  1 root root       278 févr.  8 12:23 dpkg.diversions.6.gz
-rw-r--r--  1 root root       216 sept.  7  2016 dpkg.statoverride.0
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.1.gz
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.2.gz
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.3.gz
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.4.gz
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.5.gz
-rw-r--r--  1 root root       177 sept.  7  2016 dpkg.statoverride.6.gz
-rw-r--r--  1 root root    771762 mars   1 08:50 dpkg.status.0
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.1.gz
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.2.gz
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.3.gz
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.4.gz
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.5.gz
-rw-r--r--  1 root root    224519 mars   1 08:50 dpkg.status.6.gz
-rw-------  1 root root       885 févr.  8 12:28 group.bak
-rw-------  1 root shadow     746 févr.  8 12:28 gshadow.bak
-rw-------  1 root root      1814 févr.  8 12:28 passwd.bak
-rw-------  1 root shadow    1028 févr.  8 12:28 shadow.bak

j'ai vérifié j'ai plein d'espace libre sur le disque

df -h /
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/sda3          913G    4,6G  862G   1% /

une idée ?

#24 -1 »  problème d'adresse interne ? » Le 07/03/2017, à 14:55

tuxrouge
Réponses : 0

Bonjour

J'ai odoo installé sur une ubuntu server, tout fonctionne
J'ai mis en place Etherpad-lite pour bénéficier de fonctionnalités en suivant la documentation en ligne

quand je vais sur http://monsite.fr:9001 je peux créer mon pad, pas de pb
quand je configure odoo en indiquant l'adresse locale pour etherpad
http://127.0.0.1:9001 ou http://localhost:9001 ou encore http://0.0.0.0:9001
j'obtiens (évidemment adapté à l'adresse que j'ai indiqué dans la configuration)

La connexion a échoué

Firefox ne peut établir de connexion avec le serveur à l’adresse 127.0.0.1:9001.

   Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus tard ;

qu'est-ce que j'ai loupé ?