Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 09/02/2013, à 18:26

luigifab
Réponses : 345

Oui c'est possible, reste à savoir si cela va être facile (si grub peut utiliser directement un fichier VDI) ou si ça va être plus long (copie de la partition virtuelle sur une partition réelle).
Et j'ai pas souvenir que la question ai été posée ici.

#1 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 15/10/2013, à 09:56

luigifab
Réponses : 345

Re !

Alors une petite remarque, c'est pas la première fois que je le vois, mais pour le gestionnaire de démarrage NTLDR :
wget http://www.luigifab.info/ubuntu/virtualbox/boot_xp.img

Il n'y a pas d'autres versions, donc pas de seven, 7, 8, vista ou autres wink.
(d'ailleurs le répertoire est accessible en lecture si vous n'êtes pas convaincu)

#2 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 04/01/2014, à 18:15

luigifab
Réponses : 345

1) oui rien ne change

2) comme c'est le cas...

3) c'est ça, une installation = un environnement matériel, donc quand tu changes d'environnement matériel, XP va tenter de modifier son installation pour s'adapter au nouvel environnement, cependant, quand tu vas retourner sur l'ancien environnement, XP étant obsolète, il a tendance à perdre la mémoire, il va donc recommencer à s'adapter au nouvel environnement

4) euh... oui ça doit être sa

5) oui, plus ou moins

#3 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 04/01/2014, à 18:26

luigifab
Réponses : 345

Je peux pas vraiment dire mieux que :

Attention : À vos risques et périls
- Lorsque tu vas démarrer Windows à travers VirtualBox, l'environnement matériel va changer.
- De ce fait, Windows va réinstaller tout plein de pilotes, et rien ne l'empêchera de planter !

Mais si tu ne rencontres pas de problème, dans ces cas, la réponse sera oui.

#4 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 15/04/2014, à 22:03

luigifab
Réponses : 345

0) suffit de refaire la commande pour régénérer le fichier
1) oui, comme toujours avec windows big_smile
2) suffit de décocher la case réseau

#5 Re : -1 »  [HowTo] Démarrer un Windows installé physiquement dans VirtualBox » Le 29/08/2014, à 11:15

luigifab
Réponses : 345

ljdn,

1) en effet, tu peux voir éventuellement le message de Vaderf.
2) il faut mapper le disque D si tu veux y avoir accès (même procédure que pour le mapping du disque C).

smile

#6 Re : -1 »  Restaurer clone xp sous VirtualBox » Le 15/04/2014, à 22:00

luigifab
Réponses : 9

C'est le même principe, sauf qu'il faut que tu fasses une image au lieu d'utiliser une partition.
Un bon bricolage consisterai à faire un tar.gz de ta partition XP afin de décompresser ce contenu sur un disque dur virtuel... mais bon, dois y avoir plus simple (clonezilla?).

#8 Re : -1 »  Virtualisé Ubuntu installé physiquement » Le 21/10/2013, à 21:39

luigifab
Réponses : 11

Oui ça fonctionne, même si c'est Linux et Windows, Mac et Linux, ou Mac et Windows, ou Linux et Mac... c'est pareil, ça n'a pas d'importance.
En effet, le retour en mono-cœur n'est effectif que lors de la virtualisation.

Oui.

#9 -1 »  Crash partition btrfs » Le 23/09/2013, à 22:44

luigifab
Réponses : 2

Bonsoir

Je viens de rencontrer un petit soucis après avoir fait une sauvegarde d'une partition avec dd sur une autre.
La partition qui vient de faire.... paf : /dev/sda2, BTRFS, 250 Go

sudo mount /dev/sda2 /media/documents/ a écrit :

mount: wrong fs type, bad option, bad superblock on /dev/sda2,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

dmesg | tail a écrit :

[ 1063.423183] device label documents devid 1 transid 1237 /dev/sda2
[ 1063.423815] btrfs: disk space caching is enabled
[ 1063.424749] parent transid verify failed on 131072 wanted 214 found 1240
[ 1063.424755] btrfs: failed to read chunk root on sda2
[ 1063.465987] btrfs: open_ctree failed

Ce que j'ai fait juste avant de redémarrer : sudo dd if=/dev/sda1 of=/a/sda1.dd.
Sachant que /a était monté sur /dev/sda2.

---

Mon problème, est que je n'ai plus accès à ma partition.
J'ai essayé la commande sudo btrfs restore /dev/sda2 /destination qui me récupère mes données (enfin, qui fait une copie des données ailleurs), mais il faut avoir de l'espace disque quelque part, que je n'ai pas.

Est-ce qu'il y aurait une commande magique quelque part, genre btrfs repair ?

---

Voici exactement ce que j'ai fait :

- je suis sur mon système, je le met en hibernation
- je démarre le pc sur un live CD (gparted live cd)
- je monte la partition /dev/sda2
- je crée un fichier avec dd de sda1 sur sda2 (sudo btrfs restore /dev/sda2 /a/sda1.dd)
- je démonte la partition /dev/sda2
- je redémarre
- le pc redémarre, le système sort d'hibernation
- là je ne vérifie pas la partition
- je fais mes mises à jour
- je redémarre
- et là la partition ne se monte plus.

#10 Re : -1 »  Crash partition btrfs » Le 25/09/2013, à 19:13

luigifab
Réponses : 2

C'est bien ce qu'il me semblait, je sais pas pourquoi.
Bref, je recommencerai pas.

#11 Re : -1 »  sauvegarde virtualbox » Le 29/08/2013, à 09:16

luigifab
Réponses : 4

Ou alors, peut être moins pratique que les instantanés, tu fais un copier coller du disque dur virtuel (fichier .vdi).

#12 -1 »  Audit de code CSS (outil automatique ?) » Le 21/08/2013, à 20:30

luigifab
Réponses : 0

Bonjour/bonsoir

Je cherche actuellement s'il existe un outils qui serait capable, à partir d'un fichier CSS, de me dire :
- tu utilises les propriétés suivantes :

font, color, transition, font-size...

- tu utilises les propriétés spécifiques aux navigateurs suivantes :

-moz-hyphens, -ms-hyphens, -webkit-hyphens...

- soit 35 de CSS 2 et 17 de CSS 3
- sachant cela, ce code est compatible avec : Firefox 5+, Chrome 19+, Opera 15+, IE 17+, Safari 6+

Les seuls truc que je trouve, c'est des minifier ou des validateurs ou des trucs qui n'ont rien à voir.
Est-ce que ça existe ?

#14 Re : -1 »  [HowTo] Démarrer un Linux installé physiquement dans VirtualBox » Le 22/07/2013, à 10:02

luigifab
Réponses : 20

Tu peux toujours supprimer Grub2 sur ton système, installé Grub1, faire l'image, et réinstaller Grub2.
Mais vu ton erreur, je pense que tu t'ai trompé d'uuid.

#15 -1 »  Pont réseau avec isc-dhcp-relay » Le 28/04/2013, à 12:16

luigifab
Réponses : 1

Bonjour

J'ai un ordinateur avec deux interfaces réseaux.

Je souhaite faire un pont réseau afin de pouvoir faire ceci : connecter mon PC 2 à internet via mon PC 1.
(le but étant de transférer des données du PC 2 au PC 1 en Gigabit tout en accédant à internet)

MA BOX          MON PC 1           MON PC 2
       ------- eth1  eth0 -------- eth0

Le réseau est géré par network manager sur les deux PC.
Pour le pont réseau sur le PC 1 j'utilise isc-dhcp-relay.

Tout à l'air de fonctionner sauf que le PC 2 n'arrive pas à obtenir une adresse IP.
Sur le PC 1, j'obtiens l'erreur suivante :

Apr 28 13:00:34 localhost dhcrelay: Discarding packet received on eth0 interface that has no IPv4 address assigned.

Je ne comprends pas comment résoudre ce problème.
Est-ce que quelqu'un a une idée ?

#16 Re : -1 »  Pont réseau avec isc-dhcp-relay » Le 28/04/2013, à 12:24

luigifab
Réponses : 1

Dès fois que ce soit un problème de câble droit/croisé entre le PC 1 et le PC 2, j'ai branché entre les deux un switch le temps de pouvoir faire fonctionner mon pont.

MA BOX          MON PC 1          SWITCH         MON PC 2
    p1 ------- eth1  eth0 -------- p5 p4 -------- eth0

Sauf que ça ne fonctionne pas non plus.

#18 Re : -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 28/03/2013, à 14:52

luigifab
Réponses : 11
__fabrice a écrit :

Je teste déjà IE8 avec IE10 (qui simule IE8 en mode IE8), cela me semble bon.

Certes, mais IE 10 en mode IE 8 n'est pas égal à IE 8.

#19 Re : -1 »  [HowTo] Configuration réseau de VirtualBox » Le 02/02/2013, à 18:01

luigifab
Réponses : 16

@caldoche56 : sur windows désinstalle toutes les cartes réseau dans le gestionnaire de périphérique, sur virtualbox configure une carte réseau en NAT et relance la machine virtuel.

#20 -1 »  [OK] RubyOnRails image SVG via Ruby » Le 23/02/2013, à 19:48

luigifab
Réponses : 0

Bonsoir

Dans un projet, j'ai un fichier SVG qui passe par PHP pour définir quelques valeurs.
Dans mon autre projet (qui utilise Redmine), j'ai besoin de ce même fichier SVG.

L'appel de ce fichier se fait dans un fichier CSS : url("../images/dialog/error.svg.php?w=200&h=200&lang=fr").
Est-il possible de transformer mon fichier PHP (.php) en fichier RUBY (.rb?) ?

EDIT : Oui c'est possible et simple.
Avec lighttpd, il suffit d'ajouter dans la configuration : cgi.assign = ( ".rb" => "/usr/bin/ruby" )

#21 -1 »  Comment définir la taille du texte dans un fichier SVG ? » Le 18/02/2013, à 19:20

luigifab
Réponses : 2

Bonsoir

Comment définir la taille de la police d'un texte dans un fichier SVG pour que celle-ci soit dynamique ?

Je m'explique, j'ai un fichier SVG de 500px par 500px, avec un texte avec une taille de 350%, le rendu est parfait.
Cependant, si je modifie la taille du fichier SVG, par exemple 100px par 100px, la taille du texte fait n'importe quoi.

Du coup, je ne sais pas comment définir la taille de mon texte ?
Après, il est possible aussi que je n'ai rien compris...

<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg width="500px" height="500px" xmlns="http://www.w3.org/2000/svg" version="1.1">
	<text x="42%" y="47%" font-family="Verdana, sans-serif" font-size="350%" font-weight="bold" fill="black">ERREUR</text>
	<text x="42%" y="59%" font-family="Verdana, sans-serif" font-size="350%" font-weight="bold" fill="black">404</text>
	<line x1="15%" y1="37%" x2="16.75%" y2="39%" stroke="black" stroke-width="6%" stroke-linecap="round" />
	<circle cx="25%" cy="50%" r="15%" fill="black" />
	<line x1="18.5%" y1="43.5%" x2="31.5%" y2="56.5%" stroke="red" stroke-width="7%" stroke-linecap="round" />
	<line x1="31.5%" y1="43.5%" x2="18.5%" y2="56.5%" stroke="red" stroke-width="7%" stroke-linecap="round" />
</svg>

#22 Re : -1 »  Comment définir la taille du texte dans un fichier SVG ? » Le 19/02/2013, à 13:00

luigifab
Réponses : 2

Non je n'ai pas essayé de transformer le texte en chemin, et je suis pas sur que ce soit une bonne idée pour ce que je veux faire (le texte dépend de la langue).
Du coup, faute de mieux, et étant donnée que mon fichier SVG est le résultat de quelques lignes de PHP, je fais un petit calcul pour trouver la taille du texte en fonction de la taille de l'image.

#23 -1 »  Logos SVG Firefox/Thunderbid » Le 22/01/2013, à 23:26

luigifab
Réponses : 11

Bonsoir

Je cherche les logos des logiciels de Mozilla en SVG, sauf que je n'arrive pas à trouver mon bonheur via Google.
Je cherche les logos de :
- Firefox
- Thunderbird
- Firefox Nightly
- Thunderbird Daily

Actuellement je n'ai que des images PNG de 48x48 ou 128x128, mais je n'arrive pas à trouver les versions SVG toutes belles de ces 4 logos.
Quelqu'un sait t-il ou je pourrai trouver cela ?

#24 Re : -1 »  Logos SVG Firefox/Thunderbid » Le 27/01/2013, à 19:51

luigifab
Réponses : 11

@Kanor: http://www.mozilla.org/en-US/styleguide
Tiens je l'avais pas trouvé celui-là, j'aime bien smile.

@Hibou57: L’explication est peut‑être dans la protection du logo et de l’image de la marque ou de l’entreprise qui possède les droits sur le logo.
Admettons.

Mon but n'était pas de publier les logos, mais de les utiliser comme icônes sur mon système.
Le problème c'est que ce que je veux faire ne fonctionne pas (même avec une icône de grande taille, elle est toute pixelisée quand je fais joujou avec le alt+tab de compiz)...