Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  correcteur Druide Antidote » Le 03/05/2013, à 02:14

pierig
Réponses : 121

Unzip l'archive, puis lancer dans un terminal…

#1 -1 »  Postfix mettre message vers l'extérieur en standby » Le 24/04/2013, à 11:58

pierig
Réponses : 7

Bonjour,

J'ai une configuration avec un serveur distant qui héberge mon domaine et mon serveur email (postfix -dovecot). Il marche parfaitement.
J'ai en local un autre serveur email (postfix-dovecot) qui est synchronisé avec offlineimap avec le premier serveur.

Le serveur local ne devrait pas envoyer les emails vers l'extérieur.  Il devrait les garder pret pour l'envoi. Comme cela lors de la synchronisation, ils seront envoyés par le serveur distant. L'une des raison est que le serveur local n'a pas d'IP fixe (et encore moins de possibilité d'un beau champ MX bien propre). Je préfère donc qu'il n'envoi pas d'email. Je pourrais configurer le client email pour se servir du serveur distant pour envoyer les emails, mais ça oblige à avoir une connexion internet permanante (ce qui n'est pas le cas) ou au moins à avoir le client mail qui tourne quand on est connecter. Or je préfère n'avoir que le moins possible qui tourne (et un serveur postfix-dovecot) ça va pas loin par rapport à un client riche.

Donc je cherche à configurer postfix pour que tout ce qui est localhost soit distribué directement et pour le reste, il attend… sans envoyer d'erreur qu'il n'a pas fait l'envoi. C'est donc bien attendre, pas refuser l'envoi.

Avez vous une idée?

pour vous aider déjà, voici la config actuelle du serveur local.

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
delay_warning_time = 4h
home_mailbox = Maildir/
inet_interfaces = all
mailbox_size_limit = 0
mydestination = $myhostname,localhost
myhostname = nom.local
mynetworks = 127.0.0.0/8 192.168.1.0/24 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = $myhostname
recipient_delimiter = +
relayhost = [mon.nom.de.domaine]
smtp_generic_maps = hash:/etc/postfix/generic
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

Merci le votre aide

#2 Re : -1 »  Postfix mettre message vers l'extérieur en standby » Le 25/04/2013, à 04:48

pierig
Réponses : 7

Bonjour,

Merci pour ta réponse.

Pour le moment ma config envoi effectivement les emails directement. C'est ce que je souhaite éviter. Je voudrais que l'envois ne soit fait qu'après la synchronisation avec le serveur public.

Dans ton explication, pourquoi indique tu dns.du.serveur.public plutot que le serveur public? je ne comprends pas. Dans mon cas, il n'y aura pas de différence au final. C'est le même serveur avec la même IP.

Merci.

#3 Re : -1 »  Postfix mettre message vers l'extérieur en standby » Le 26/04/2013, à 02:51

pierig
Réponses : 7

Bonjour,

Il semble en effet qu'en enlevant les crochets, le relayhost marche correctement de manière transparente pour les destinataires.  Merci.
Reste ma question d'origine. Est-il possible de mettre en standby les emails sortant pour qu'ils ne soient envoyés que arpès synchronisation? C'est moins important avec un relayhost propre, mais ça m'aiderait qu'en même.

Merci.

#4 Re : -1 »  Postfix mettre message vers l'extérieur en standby » Le 26/04/2013, à 10:13

pierig
Réponses : 7

Merci je vais creuser ma lecture de la liste de diffusion de postfix…

#5 -1 »  RÈSOLU]Postfix, avoir un relayhost different suivant adresse de l'expé » Le 26/04/2013, à 05:44

pierig
Réponses : 2

Bonjour,

Certains ont peut-être vu un autre message lié à postfix et à offlineimap. Ça reste d'actualité, mais je cherche à avancer en parrallèle sur d'autres sujets.

J'utilise en parallèle plusieurs comptes avec des adresses (et des nom de domaines différents).
J'ai un serveur imap local (postfix) que me permet de tout gérer localement (réactivité, sauveguared…) bien que ce PC soit mobile.
Donc j'utilise un relayhost pour l'envoi des emails pour éviter d'avoir des refus pour cause d'envoi depuis une IP qui n'héberge pas de serveur mail propre.
Par contre, toujours pour avoir des envois d'emails les plus propres possible, il me semble logique d'utiliser le bon relayhost pour chaque compte.
J'ai des comptes comme moi@dom1.com et d'autres en moi@dom2.com.
Les emails envoyés par moi@dom1.com devrait passer par le relayhost dom1.com alors que
les emails envoyés par moi@dom2.com devrait passer par le relayhost dom12.com

Avez vous des pistes pour la configuration de postfix pour cela?
Ma config locale actuelle:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
delay_warning_time = 4h
home_mailbox = Maildir/
inet_interfaces = all
mailbox_size_limit = 0
mydestination = $myhostname,localhost
myhostname = nom.local
mynetworks = 127.0.0.0/8 192.168.1.0/24 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = $myhostname
recipient_delimiter = +
relayhost = mon.nom.de.domaine
smtp_generic_maps = hash:/etc/postfix/generic
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

Dans la partie smtp_generic_maps je change déjà la forme de mes adresses emails. Peut-être qlq chose dans ce gout là?

Merci

#6 Re : -1 »  RÈSOLU]Postfix, avoir un relayhost different suivant adresse de l'expé » Le 26/04/2013, à 08:49

pierig
Réponses : 2

Super!

J'avais commencé à regarder pour lancer plusieurs instances de postfix sur la même machine… Mais ça me parraisssait très lourd pour ce que je voulais.

Merci.

#7 Re : -1 »  Journée internationale contre les DRM - édition 2012 » Le 26/04/2013, à 03:07

pierig
Réponses : 4

Il faut en parler, surtout en ces temps de discussion sur l'intégration de DRM dans HTML 5.
April et
la pétition.

#8 Re : -1 »  Configurer dns pour serveur mail local » Le 19/04/2013, à 12:22

pierig
Réponses : 4

Adresse fixe et no-ip,  j'ai comme un doute. Ton adresse IP est vraiment fixe? que vient faire no-ip la dedans?

#9 Re : -1 »  Configurer dns pour serveur mail local » Le 22/04/2013, à 02:34

pierig
Réponses : 4

Tu n'as pas d'IP fixe, un nom de domaine fixe. C'est pas tout à fait pareil car dans le champs MX, c'est bien une IP qu'on va te demander.

#10 -1 »  Répondre à soi même dans Thunderbird » Le 18/04/2013, à 11:42

pierig
Réponses : 3

Bonjour,

J'utilise Thunderbird depuis de nombreuses années sans soucis…
J'utilise plusieurs compte simultanément ce qui est bien pratique, mais j'ai un soucis.
Quand je veux relancer quelqu'un, je réponds à l'email que j'avais mois même envoyé. Cependant, l'interface ouvre l'email pret pour l'écriture, mais je suis le destinataire principale, mon ancien destinataire est en CC et le compte qui envoi l'email n'est plus le même. Ni même le compte principale.

Je soupçonne un petit paramètre dans un coin pour définir le compartement de Thunderbird. Je souhaiterais bien sur que le message soit avec le même émetteur que le précédant, et les même destinataires.

Quelqu'un aurait une petite idée?

Merci bien!

#11 Re : -1 »  Répondre à soi même dans Thunderbird » Le 18/04/2013, à 12:05

pierig
Réponses : 3

Effectivement JBF, c'est une solution que je n'avais jamais utiliser. Ça n'intègre pas la signature pour montrer que c'est une deuxième partie, mais dans bien des cas c'est mieux ainsi.

Un forward ne conserve pas la liste des destinataires, donc je ne peux pas utiliser ta solution BrunoGey. Merci tout de même.

#12 -1 »  Synchronisation de deux serveurs imaps » Le 18/04/2013, à 10:54

pierig
Réponses : 0

Bonjour,

J'ai un serveur de mail IMAP sur un VPS chez OVH. (dovecot+postfix)
J'ai un PC principal à la maison sur lequel j'ai aussi un serveur de mail  (dovecot+postfix)

Je synchronise les serveurs IMAP grace à offlineimap. La synchro se passe bien.
Mon Problème est le suivant (dans la config de postfix en fait).

Mon serveur VPS est celui qui correspond à mon nom de domaine. Donc il gère les emails en moi@monnomdedomaine.
Si, depuis la maison j'envoie un email avec le serveur vps comme serveur SMTP, tout marche bien.
Par contre, comment faire pour utiliser le serveur de la maison? je ne peux pas configurer postfix pour lui indiquer qu'il est en charge de monnomdedomaine, et ensuite faire un relayhost vers monnomdedomaine…
Ce que je voudrais, c'est que les emails de la maison soient mis dans la "boite d'envoi" du serveur de la maison, lors de la synchronisation, le serveur VPS envoi les emails en attente dans la boite d'envoi. Donc il faut que mon serveur smtp local s'abstienne d'envoyer. Juste que tout soit près.
La raison de cette manipulation un peu bizarre est principalement lié à ma connexion internet locale (très mauvaise). Ainsi faire un envoi en imap d'un mail un peu gros pose souvent problème soit lors de l'envoi, soit lors de la copie dans le dossier "envoyé". Alors que si je fais ça sur le serveur imap local, c'est instantané, et l'envoi réel se fait derrière de manière transparente quand ça passe.

Je cherche donc votre aide pour:
Sur le principe, comment faire? comment configurer postfix pour qu'il recoive les emails a envoyer, mais pour qu'il attende pour les envoyer. Comment faire pour que le postfix du VPS trouve ces emails et les envois (je pense que c'est peut être assez automatique si les emails sont stockés au bon endroit avec le bon tag, mais vous allez peut être me contredire.

Merci de votre aide en tout cas.

#13 Re : -1 »  Clé USB Attaché 8GB non reconnue Ubuntu ou autre et apparaît lusb » Le 29/03/2012, à 11:29

pierig
Réponses : 4

Je remonte le sujet car j'ai le meme pb avec une clé neuve…
Pour info, elle est vue sur un poste windows, mais sur aucun des 3 linux que j'ai essayé

Pour essayer d'aider, en me disant qu'il pouvait y avoir un defaut de partition ou autre, je l'ai formaté sur windows, pas le changement.

Pour info, la petite led clignote de temps en temps.

mais rien

dans le log j'ai cette ligne qui apparait régulièrement et qui doit bien être la source du problème:

Mar 29 17:27:51 desktop kernel: [219638.968796] usb 1-5.1: reset high speed USB device number 28 using ehci_hcd

ume idée?

Merci bien

#14 Re : -1 »  Clé USB Attaché 8GB non reconnue Ubuntu ou autre et apparaît lusb » Le 29/03/2012, à 11:53

pierig
Réponses : 4

On se sent moins seul, smile
mais ça n'aide pas beaucoup sad

#15 -1 »  [Résolu]récupérer ip depuis un site » Le 11/12/2011, à 04:58

pierig
Réponses : 5

bonjour,

je cherche a récupérer mon adresse ip depuis un site http://www.monadresseip.fr/

pour cela j'utilise wget, je passe un grep pour n'avoir que la bonne ligne, il me reste a nettoyer la ligne, et la je sèche.

voici le code de la page reçue:

<table border=0 align=center>
<tr>
<td width=500>
<h1>Votre <strong>adresse IP</strong> est :</h1>

<code>158.38.68.228</code> - <a href='ping.php?ip=158.38.68.228'>ping 158.38.68.228</a>
<BR><BR>
<h1>Votre <strong>proxy</strong> est :</h1>
<code>228.68.38.58.broad.xw.sh.dynamic.163data.com.cn</code>
<br><br>

voici ma commande pour avoir la bonne ligne: (grace au mot ping)

wget http://monadresseip.fr/ -q -O - | grep "ping"

Mais il me manque la dernière partie pour n'avoir que ce qui est entre ip= et le ' suivant.

Quelqu'un pourrait il m'indiquer?

Mercis

#16 Re : -1 »  [Résolu]récupérer ip depuis un site » Le 11/12/2011, à 10:35

pierig
Réponses : 5

La solution 1 marche bien.

Je ne connaissaist pas curl. Il faut que je regarde.

Merci

#17 -1 »  wget et Navigateur » Le 11/12/2011, à 05:12

pierig
Réponses : 2

Bonjour,

Pour ma culture personnelle,

si je cherche la page par exemple http://www.mon-ip.com/  ça marche, alors qu'avec wegt j'ai une erreur 403

wget http://www.mon-ip.com/
--2011-12-11 11:11:11--  http://www.mon-ip.com/
Résolution de www.mon-ip.com (www.mon-ip.com)... 80.247.226.90
Connexion vers www.mon-ip.com (www.mon-ip.com)|80.247.226.90|:80...connecté.
requête HTTP transmise, en attente de la réponse...403 Forbidden
2011-12-11 11:11:12 ERREUR 403: Forbidden.

Une idée de la raison?

Merci

#18 Re : -1 »  wget et Navigateur » Le 11/12/2011, à 10:38

pierig
Réponses : 2

Merci pour l'info. Je n'avais pas pensé à ça.

#19 Re : -1 »  Ubuntu trop puissant pour mon Eeepc? » Le 02/12/2011, à 09:50

pierig
Réponses : 9

effectivement tu as un fil expliquant comment passer un paramètre au noyau?

Pour ma part je doit passer "acpi=force", mais je ne sais pas faire ça. Charger un module,OK. Mais passer un paramètre NOK sad

#20 -1 »  Economie d'energie sur EEEPC - Lubuntu » Le 29/11/2011, à 06:19

pierig
Réponses : 3

bonjour,

Sur un EEEPC904 recement passe sous Lubuntu, je n'arrive plus a gerer correctement la fequence du processeur, alors que j'y arrivais sous Ubuntu et autres derives de Debian.

Lors du boot j'ai bien un message d'erreur sur le power manager, mais je n,arrive pas a lire, donc j'ai fouille dans les logs: st voila ce que j'ai:

Nov 29 12:02:01 eeepc kernel: [   18.443173] ondemand governor failed, too long transition latency of HW, fallback to performance governor
...
Nov 29 12:03:07 eeepc kernel: [   84.708969] ondemand governor failed, too long transition latency of HW, fallback to performance governor

Comme ondemand semble encause, j'ai decouvert que

xxx@eeepc:/var/log$ sudo modprobe ondemand
FATAL: Module ondemand not found.

Nota p4-clocmod est bien charge.

Mais je ne sais pas comment faire "reapparaitre" le module ondemand.

Quelqu'un pourrait il me renseigner?  Merci

#21 Re : -1 »  Economie d'energie sur EEEPC - Lubuntu » Le 29/11/2011, à 09:57

pierig
Réponses : 3

C'est la méthode que j'utilisais jusqu'a maintenant (avant ma réinstal). et c'est ce que j'ai essayé de forcé avec les ligne modprode.

Mais mon problème demeure. si je fais ce passage de paramètres au boot, un sudo cpufreq-set -g ondemand ne génerera pas d'erreur, mais le pc reste en fait sur le governor performance… sad

Une autre idée peut etre?

Merci

#22 Re : -1 »  Economie d'energie sur EEEPC - Lubuntu » Le 02/12/2011, à 03:16

pierig
Réponses : 3

Bonjour,

Personne n'aurait d'idée pour moi? changer la fréquence à la main avec cpufreq-set ça marche, mais c'est vraiment pas userfriendy…

#23 Re : -1 »  utilisation lecteur numérique ou E reader » Le 18/11/2011, à 10:10

pierig
Réponses : 11

J'utilise un reader sony avec mon post sous Ubuntu sans problème via Calibre.

Ma liseuse n'a jamais connu le DRM. et s'en porte très bien.

#24 Re : -1 »  governor ondemand devient performance » Le 21/11/2011, à 10:56

pierig
Réponses : 1

Bonjour,

personne pour me proposer des pistes à étudier pour mon problème de ondemand non reconnu dans les faits alors qu'il ne renvoit pas d'erreur?

Merci