Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  [Tuto] - Ma personnalisation Xubuntu (et autres variantes) » Le 13/07/2014, à 22:21

metalux
Réponses : 1608

J'ai passé le J9 du tuto mais ça ne fonctionne pas, y-a-t-il une solution? xbacklight me retourne "No outputs have backlight property"

#1 Re : -1 »  [Tuto] - Ma personnalisation Xubuntu (et autres variantes) » Le 14/07/2014, à 11:58

metalux
Réponses : 1608

@moko138
Oui, j'avais bien fais ça.
@nam1962
Pas trop envie de flasher le bios rien que pour la luminosité mais ça répond à mon interrogation. Je ne savais pas d'où ça pouvait bien venir.
@letus
Je n'ai pas trouvé comment faire pour augmenter la luminosité par palier avec xcalib sinon ça fonctionne bien. Du coup je suis finalement passé par xrandr pour faire ce que je voulais à défaut d'un support natif de l'applet.
Je le met en partage ici si d'autres personnes sont confrontés au même bug
Pour un applet dans le tableau de bord: ajouter un lanceur, et mettre en commande sh -c "chemin vers le script" et en icône, taper "brightness" dans icônes d'états.

#!/bin/bash
RET=$(xrandr | awk 'BEGIN{} $2=="connected" {print $1}END{}')
INTENSITE=$(zenity --scale --value=60 --min-value=20 --text="INTENSITE" --title="LUMINOSITE")
LUMINOSITE=$(echo $INTENSITE/100 | bc -l)
xrandr --output $RET --brightness $LUMINOSITE

Pour un réglage en palier au raccourci clavier, associer les scripts suivants à une touche. Ne pas oublier de les rendre exécutable auparavant:
Pour augmenter la luminosité:

#!/bin/bash
[[ "$(pgrep -x $(basename $0))" != "$$" ]] && exit 1
RET=$(xrandr | awk 'BEGIN{} $2=="connected" {print $1}END{}')
current=$(xrandr --verbose | grep Brightness | awk '{print $2}')
LUMINOSITE=$(echo $current+0.05 | bc -l)
if [[ $(echo "$current >= 1.0" | bc) -eq 1 ]];then
	pgrep xfce4-notifyd && pkill xfce4-notifyd
	notify-send 'Brightness' 'Luminosité maximale'
else
	xrandr --output $RET --brightness $LUMINOSITE
	newcurrent=$(xrandr --verbose | grep Brightness | awk '{print $2}')
	intensite=$((echo $newcurrent*100 | bc) | cut -d . -f1)
	pgrep xfce4-notifyd && pkill xfce4-notifyd
	notify-send 'Brightness' "intensité de $intensite %"
fi
exit 0

Pour diminuer la luminosité:

#!/bin/bash
[[ "$(pgrep -x $(basename $0))" != "$$" ]] && exit 1
RET=$(xrandr | awk 'BEGIN{} $2=="connected" {print $1}END{}')
current=$(xrandr --verbose | grep Brightness | awk '{print $2}')
LUMINOSITE=$(echo $current-0.05 | bc)
if [[ $(echo "$current <= 0.3" |bc ) -eq 1 ]];then
	pgrep xfce4-notifyd && pkill xfce4-notifyd
	notify-send 'Brightness''Luminosité minimale'
else
	xrandr --output $RET --brightness $LUMINOSITE
	newcurrent=$(xrandr --verbose | grep Brightness | awk '{print $2}')
	intensite=$((echo $newcurrent*100 | bc) | cut -d . -f1)
	pgrep xfce4-notifyd && pkill xfce4-notifyd
	sleep 0.1
	notify-send 'Brightness' "intensité de $intensite %"
fi
exit 0
jflh0816 a écrit :

Et oui, c'est pour ça que je dis que je dois être sclérosé de la boite à neurones

Tu n'es pas le seul, cette inversion me perturbe également. Si tu mets l'applet à droite, les colonnes se mettent comme nous le souhaitons comme quoi c'est possible. D'ailleurs nous ne sommes pas les seuls, j'avais vu cette demande sur la wishlist de whisker et j'espérais qu'il y aurais eu une option pour ça avec l'intégation native de whisker pour Xubuntu 14.04 mais malheureusement ce n'est pas le cas.
EDIT: Ça y est, c'est possible avec le P.P.A.!

sudo add-apt-repository ppa:gottcode/gcppa
sudo apt-get update
sudo apt-get install xfce4-whiskermenu-plugin 

Ensuite tu supprimes l'applet de whisker actuel et tu le réinstalles. Puis clic droit sur l'applet, propriétés et cocher "Positionner les catégories à côté du bouton du tableau de bord"

#2 Re : -1 »  [Tuto] - Ma personnalisation Xubuntu (et autres variantes) » Le 16/07/2014, à 00:07

metalux
Réponses : 1608

@hackoeur
Voici un petit script "maison"  basé également sur youtube-dl. Il suffit de créer un lanceur dans le tableau de bord avec la commande sh -c "chemin vers le script" sans oublier de rendre le script exécutable.

#!/bin/bash
path=$(dirname $0|sed -e 's/ /\\ /g')
cd $path
choix=$(zenity --list --radiolist --width=300 --height=250 --title="Metalux extract video & Mp3"  --column="Choix :" --column="Vidéo" "" "Enregistrer une video" TRUE "Enregistrer le son" "" "Enregistrer le son et la video") && [[ -n $choix ]]

if [[ $choix == "Enregistrer une video" ]]; then
	param=""
elif [[ $choix == "Enregistrer le son" ]]; then
	param='--extract-audio --audio-format mp3 '
elif [[ $choix == "Enregistrer le son et la video" ]]; then
	param=' --extract-audio --audio-format mp3 -k '
else
	exit 0
fi

youtube-dl $param--output="%(title)s.%(ext)s" $(xclip -o)

if [[ $? -ne 0 ]]; then
	notify-send 'Erreur' "Sélectionne une vidéo valide"
	exit 1
fi  

mv *.mp3 ~/Musique
mv *.* ~/Vidéos

notify-send 'Extract video & Mp3' 'Fichier disponible'

exit 0

Pour l'utiliser, il suffit de surligner l'adresse de la video dans la barre d'adresse de son navigateur et de cliquer sur le lanceur. Une notification avertie lorsque c'est fini. Par contre, il ne faut faire qu'une vidéo à la fois et attendre le message avant de faire une autre.
Pour youtube-dl il faut utiliser la dernière version pour un maximum de compatibilité.
Les dépendances à installer:

sudo apt-get install youtube-dl xclip 

Si tu préfères le copier/coller traditionnel au surlignage, il suffit de remplacer xclip -o par xclip -selection clipboard -o et il y a la possibilité de changer les paramètres par ceux qui te conviennent en consultant le manuel de youtube-dl. Il y a des vidéos cryptées qui sont impossibles à récupérer avec youtube-dl, le message d'erreur s'affichera dans ce cas. Mais la 1ère chose à vérifier est d'avoir une version bien à jour de youtube-dl. Parfois le message d'erreur s'affiche si le surlignage a mal été fait même si la vidéo est valide.

#3 Re : -1 »  [Tuto] - Ma personnalisation Xubuntu (et autres variantes) » Le 17/07/2014, à 00:47

metalux
Réponses : 1608
enebre a écrit :

Merci metalux pour ce script, s'il te plait serait-il possible de rajouter au script une option pour le démarrage automatique de la lecture dans mplayer, je n'ai pas le savoir pour faire cette ajout, pourrais-tu m'écrire le sésame ?
Dans quel format yt-dl choisi la vidéo, est il possible d'imposer une préférence.

J'ai modifié rapidement le script pour que ce soit fonctionnel mais c'est pas très joli, l'important c'est que ça marche, n'est-ce pas? A la fin du téléchargement, une fenêtre te demandera si tu veux lire le fichier avec mplayer avant de le déplacer dans le dossier Video.
Met le script bien à part dans un dossier ou il n'y a pas de fichiers avec extensions sinon ça va te les déplacer dans le dossier vidéo.

#!/bin/bash
path=$(dirname $0|sed -e 's/ /\\ /g')
cd $path
download () { youtube-dl $param--output="%(title)s.%(ext)s" $(xclip -o)
}
lecture () { zenity --question --text "Voulez-vous lire la vidéo enregistrée maintenant?"
[[ $? -eq 0 ]] && mplayer *.* 
mv *.* ~/Vidéos
}
choix=$(zenity --list --radiolist --width=300 --height=250 --title="Metalux extract video & Mp3"  --column="Choix :" --column="Vidéo" "" "Enregistrer une video" TRUE "Enregistrer le son" "" "Enregistrer le son et la video") && [[ -n $choix ]]

if [[ $choix == "Enregistrer une video" ]]; then
	param="" && download && lecture
elif [[ $choix == "Enregistrer le son" ]]; then
	param='--extract-audio --audio-format mp3 ' && download && mv *.mp3 ~/Musique
elif [[ $choix == "Enregistrer le son et la video" ]]; then
	param=' --extract-audio --audio-format mp3 -k ' && download && mv *.mp3 ~/Musique && lecture
else
	exit 0
fi
if [[ $? -ne 0 ]]; then
	notify-send 'Erreur' "Sélectionne une vidéo valide \n Seul le surlignage fonctionne et pas le copier au clic droit ou ctrl+C"
	exit 1
fi  
notify-send 'Metalux Extract video & Mp3' 'Fichier disponible'

Pour imposer une préférence de format, oui ça doit être possible. Regarde dans les options de youtube-dl et modifie param dans le script.
@nam1962
Promis je ne pollue plus le topic avec des scripts sinon je vais faire fuire les débutants big_smile

#4 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 23/07/2014, à 23:39

metalux
Réponses : 47
hackoeur a écrit :

@metalux merci à toi pour ce script, mais comme dit, il faut un peu décortiquer les consignes d'installation, car je suis (un peu moins) débutante avec mister-terminal.
Si je comprends bien, en ce qui me concerne c'est bien celui-ci que tu m'as concocté :
metalux a écrit :

    @hackoeur
    Voici un petit script "maison"  basé également sur youtube-dl. Il suffit de créer un lanceur dans le tableau de bord avec la commande sh -c "chemin vers le script" sans oublier de rendre le script exécutable.

Déjà à ce point :
Comment rendre un script exécutable ?

Pour rendre le script exécutable, le plus simple est de faire un clic droit dessus le fichier, propriétés et de cocher la case correspondante, je te laisse chercher un peu wink.
ou sinon en terminal:

chmod u+x le_script

Le plus simple pour mettre le bon chemin du script, tu fais glisser le fichier dans le terminal après avoir écrit chmod u+x.
IMPORTANT: met le script dans un dossier bien à lui car les vidéos se téléchargent dedans puis sont déplacées dans le dossier vidéos (ou Musiques si tu as choisis Mp3).
Ensuite dans ton tableau de bord tu crées un lanceur avec la commande sh -c "chemin vers le script". Remplace bien sûr "chemin vers le script" par le vrai chemin.
Un conseil, si tu veux un maximum de vidéos reconnues par youtube-dl, utilise les sources officiels.
La dernière version en date:

sudo curl http://yt-dl.org/downloads/2014.07.23.2/youtube-dl -o /usr/bin/youtube-dl

Par la suite pour mettre à jour si tu as des vidéos non reconnues:

sudo youtube-dl -U

Pour le reste, reprend ce que j'ai dis sur le tuto de Nam1962.
Le gros avantage, ce n'est pas dépendant du navigateur utilisé, il suffit de surligner l'adresse de la vidéo puis un clic sur ton lanceur qui se trouve dans le tableau de bord.
Voici un screen, c'est tout simple:
1406151198.png
Pour le son c'est du Mp3, pour les vidéos, c'est la meilleure définition trouvée sur la page. Tu peux faire évoluer le script en changeant les options de youtube-dl (man youtube-dl dans un terminal pour avoir l'ensemble des options), changer le chemin de destination,etc...

#5 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 24/07/2014, à 22:37

metalux
Réponses : 47
hackoeur a écrit :

Kesako que j'ai fait de faux ?

Rien du tout!  La réponse à l'update est normale car tu as la version des dépôts et non celle via les sources. Et pour curl: command not found
c'est que curl n'est pas installé, je croyais que c'était le cas par défaut.
En plus j'avais oublié de te dire de rendre youtube-dl exécutable.

Voici la solution complète à faire dans l'ordre:

sudo apt-get install curl
sudo curl http://yt-dl.org/downloads/2014.07.23.2/youtube-dl -o /usr/bin/youtube-dl
sudo chmod a+x /usr/bin/youtube-dl
sudo youtube-dl -U

Je viens d'essayer avec une vidéo de dailymotion et pas de soucis. Cela peut venir de ta version de youtube-dl qui est obsolète tant que tu n'as pas mis à jour vers la dernière version. Si tu n'y arrives pas, met le lien vers la vidéo que je vois si elle est reconnue par youtube-dl. Pense également à mettre régulièrement à jour youtube-dl avec la dernière commande.
Si l'anglais est ta langue native, c'est un gros avantage car c'est plus galère à comprendre les options du manuel de chaque commande quand il n'y a pas de traduction qu'à faire le script en lui-même.
Pour le classement des vidéos, il y a la possibilité d'ajouter une option pour choisir le dossier de destination par exemple, il y a la possibilité de faire évoluer le script en fonction de tes besoins.
Pour le lanceur dans le tableau de bord, il n'y a pas plus simple, il suffit de faire ce que j'ai indiqué et de lui choisir une belle icône! Comme ça toujours à portée de souris que tu sois sur opera, firefox ou autre navigateur.

#6 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 24/07/2014, à 23:37

metalux
Réponses : 47

Tu ne peux pas t'imaginer comme ça me simplifie la vie étant papillonneuse de navigateurs (mais Jack Sparrow reste mon préféré), so, merci infiniment.

De rien. Et comme navigateur, aucun ne peux rivaliser avec Jack Sparrow wink

#7 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 24/07/2014, à 23:48

metalux
Réponses : 47

Tu as vu la synchro de nos posts? décidément....
N'hésite pas si tu as d'autres questions mais ne soit pas impatiente, je pars sous peu au pays des pizzas, et ce, sans Pc ni téléphone. big_smile
L'image ne s'affiche pas dans ta réponse précédente...bien que je n'en ai pas l'utilité.

#8 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 25/07/2014, à 00:21

metalux
Réponses : 47

Ah ok pour l'icône, je n'avais pas capté!
J'ai fais une erreur plus haut que j'ai rectifié:
remplace

sudo chmod a+x /usr/local/bin/youtube-dl

par

sudo chmod a+x /usr/bin/youtube-dl

et si il tu as une version de présente dans /usr/local/bin, supprime là de préférence.

sudo rm /usr/local/bin/youtube-dl

#9 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 25/07/2014, à 12:15

metalux
Réponses : 47

@hackoeur
Tu peux changer la couleur des polices et leur taille. J'utilise zenity qui est installé par défaut pour l'interface graphique. Pour le reste, c'est ton thème comme signalé par enebre.
http://doc.ubuntu-fr.org/zenity#exemples
@enebre
Peux-tu relancer en terminal avec la commande:

bash -x /home/marc/yt/metalux/yt-meta

et me donner le retour.
Utilises-tu bien la dernière version de youtube-dl à partir des sources?

#10 Re : -1 »  [Résolu]Convertisseur de clips dailymotion, YT, etc, en mp3 et mp4 » Le 26/07/2014, à 00:05

metalux
Réponses : 47

@enebre
Pas le temps de regarder maintenant, je suis sur le départ big_smile
En attendant essaye avec simplement la ligne de commande youtube-dl, si ça échoue ça vient de youtube-dl et non du script. Moi c'est ok, testé à l'instant sur Ubuntu 12.04 mais pas testé sur xubuntu 14.04 pour l'instant.
La ligne de commande à tester:

youtube-dl -f 43 standard --extract-audio --audio-format mp3 -k 'http://www.youtube.com/watch?v=mhJHfP3WOhA'

Pour le second, c'est le contenu de ton presse-papier qui n'est pas le bon:
youtube-dl -f 43 --extract-audio --audio-format mp3 -k '--output=%(title)s.%(ext)s' ─ '$' ▶ bash -x /home/marc/yt/metalux....... y'a rien qui te choque là? c'est pas vraiment une adresse vidéo wink
Pour la 3ème erreur, vérifie que ffmpeg ou avconv est installé. Fait une recherche là-dessus, je crois qu'il y a eu des changements de l'un à l'autre pour la 14.04. Je ne suis pas sûr mais je pense que ça vient de là. Ce qui est bizarre, c'est que ça a fonctionné avant, tu as fais des changements entre temps concernant ces paquets?
Si youtube-dl ne fonctionne pas sur la 1ère vidéo (sans utiliser le script), c'est sans doute que tu n'utilises pas correctement la dernière version. Désinstalle proprement et ré-installe(assure toi d'avoir curl d'installé):

sudo apt-get purge youtube-dl
sudo rm /usr/bin/youtube-dl
sudo rm /usr/local/bin/youtube-dl
sudo curl http://yt-dl.org/downloads/2014.07.23.2/youtube-dl -o /usr/bin/youtube-dl
sudo chmod a+x /usr/bin/youtube-dl
sudo youtube-dl -U

@hackoeur
Zenity est déjà installé, rien d'autre à faire. Je t'ai mis le lien vers la page de doc, ça explique comment mettre de la couleur avec les balises "span color" "span font-family", etc... Voici un exemple avec modcustom de frafa:
http://liveusb.info/ModCustom/Capture-ModCustom-1.png
Ca reste basique mais ça égaie un peu. Il faut modifier le code du script comme indiqué dans la doc.

Je repasse d'ici une quinzaine de jours.
Ciao!

#11 Re : -1 »  [Résolu] Paramétrer et fixer la taille des fenêtres Xfce → devilspie » Le 17/07/2014, à 11:22

metalux
Réponses : 23

Bonjour hackoeur,
Pour le css je n'en sais rien mais devilspie devrait te permettre de faire ce que tu souhaites.

#12 Re : -1 »  [Résolu] Paramétrer et fixer la taille des fenêtres Xfce → devilspie » Le 23/07/2014, à 20:04

metalux
Réponses : 23

Je n'utilise pas devilspie mais normalement c'est possible avec Xfce.
As-tu bien suivi la doc?

#13 Re : -1 »  Curseur qui sélectionne automatiquement ! » Le 23/07/2014, à 23:59

metalux
Réponses : 2

Bonsoir,
Tu n'aurais pas tout simplement activer le simple clic dans ton explorateur de fichiers? Dans ce cas il faut regarder dans les préférences de celui-ci à l'onglet comportement.

#14 Re : -1 »  Problème dualboot W8.1 et Ubuntu Sony Vaio EFI » Le 23/07/2014, à 23:52

metalux
Réponses : 3

Moi aussi je mets un certain temps pour repasser:
Essaye déjà de changer l'ordre de démarrage et redémarre.

sudo efibootmgr -o 0001,000F,0008,0009,000A,000B,000C,0007,000D,000E

Si ce n'est pas mieux, il faudra suivre l'autre topic. Je te guiderai éventuellement mais je vais m'absenter 2 semaines et je n'aurai pas de Pc sous la main. A moins que tu ne répondes avant vendredi.

#15 Re : -1 »  [Résolu] Enormément d'erreurs de vérification de signatures » Le 23/07/2014, à 14:19

metalux
Réponses : 10

Bonjour,
entre la commande suivante:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 43525C28E533491A 082CCEDF94558F5940976EAF437D05B5  3B4FE6ACC0B21F32 etc...

Remplace le etc... par toutes les autres clefs trouvées.
Sinon un outil qui simplifie drôlement la tâche pour ce genre d'erreurs est launchpad-getkeys. Tu trouveras tous ce qu'il te faut dans cette page de documentation

#16 Re : -1 »  [Résolu] Enormément d'erreurs de vérification de signatures » Le 23/07/2014, à 17:16

metalux
Réponses : 10

Etrange ce 'Resource limit' alors que tu n'as installé que 2 P.P.A. hmm
Vérifie quand même le contenu du dossier /etc/apt/trusted.gpg.d

ls /etc/apt/trusted.gpg.d 

A part ça, je ne vois pas ce qui cloche, généralement la 1ère commande ou launchpad-getkeys suffisent à rétablir la situation.

#17 Re : -1 »  [Résolu] Enormément d'erreurs de vérification de signatures » Le 23/07/2014, à 17:26

metalux
Réponses : 10
jplemoine a écrit :

Il y a peut-être trop de signature qui ne serait pas utilisées. Je ne sais pas comment fait-on, pour les voir...

Les signatures inutilisés sont stockées je crois dans le dossier que j'ai indiqué. A défaut, il suffit de vérifier par l'application graphique le nombre de clefs présentes.

#18 Re : -1 »  [Résolu] Enormément d'erreurs de vérification de signatures » Le 23/07/2014, à 19:53

metalux
Réponses : 10

Le problème semble bien être le nombre de clefs:
J'ai trouvé sur le forum anglais ceci:

As I said in the debian bug, 0.9.10 has a better handling of files while deleting keys, so you will be hit by it only with >= 40 sources. Personally I believe that if you have >= 40 sources, you have an addiction problem and should remove some…

Je ne suis pas un as de l'anglais mais ça ne me parait pas bien compliqué de comprendre que le problème apparaît avec 40 sources ou +. En fait, lorsqu'un dépôt est ajouté puis retiré, il supprime la clef mais laisse un fichier de taille 0 dans le dossier /etc/apt/trusted.gpg.d .
La solution consiste à supprimer ces clefs "vides".

 sudo find /etc/apt/trusted.gpg.d -name '*.gpg' -size 0 -delete

Les fichiers se terminant par ~ sont à supprimer également, il ne s'agit que de sauvegardes en général inutiles cf documentation
relance ensuite:

sudo apt-get update
sudo apt-get dist-upgrade

#19 -1 »  [Tuto] Jouer aux jeux basés sur unity3d comme Uberstrike » Le 22/07/2014, à 13:37

metalux
Réponses : 1

Bonjour,
Voici un résumé de ce qu'il faut faire pour jouer aux jeux basé sur unity3d tel que Uberstrike. J'ai effectué les tests avec Firefox.
Tout d'abord installer pipelight
Activez ensuite unity3d navigateur fermé:

sudo pipelight-plugin --enable unity3d 

Redémarrez Firefox et vérifiez que le plugin Unity Player est bien chargé (Outils/modules complémentaires/Plugins)
Si le plugin affiche "ERROR", fermez votre navigateur puis lancez la commande suivante:

sudo pipelight-plugin --update

Si ensuite vous avez toujours une erreur, entrez finalement cette commande:

sudo pipelight-plugin --create-mozilla-plugins

Le plugin devrait désormais se charger correctement.
Ensuite lorsque vous vous rendez sur Uberstrike, celui-ci vous dit que votre O.S. n'est pas supporté. Pour le tromper, nous allons utiliser User agent switcher
Créez un nouveau "User Agent". Mettez les renseignements suivants dans celui-ci:

Description: Windows 7
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0
App Code Name: Mozilla
App Name: Netscape
App Version: 5.0 (Windows)
Platform: Win32

Activez ensuite ce "User Agent" nouvellement crée lorsque vous allez sur Uberstrike, le jeu devrait maintenant fonctionner.
Je n'ai testé que sur Uberstrike mais beaucoup de jeux Unity3d sont supportés d'après le site de pipelight. Faites vos tests et n'hésitez pas à indiquer sur cette page les jeux compatibles et ceux qui ne fonctionnent pas.

#20 Re : -1 »  Ubuntu 13.10 refuse que je démarre sous windows 8 et/ou windows 7 » Le 19/07/2014, à 23:35

metalux
Réponses : 14

Bonsoir,
Essaye la commande suivante dans un terminal:

sudo os-prober

#21 Re : -1 »  Paramétrer le menu whisker » Le 20/07/2014, à 00:05

metalux
Réponses : 4

Cette fonction est désormais intégrée dans la dernière version de Whisker menu. Elle est disponible à partir du P.P.A. Gott Code

#22 Re : -1 »  condition dans un shell » Le 18/07/2014, à 21:21

metalux
Réponses : 5

Salut,
Il manque également un espace après le if

#23 Re : -1 »  Live Voyager » Le 13/07/2014, à 00:39

metalux
Réponses : 2493

Colle ça dans un fichier:

# Use Xft?
use_xft yes
xftfont Trebuchet MS:size=8
xftalpha 0.8
text_buffer_size 2048
background yes
# Update interval in seconds
update_interval 1
xftalpha 0.8
own_window_argb_visual yes
# This is the number of times Conky will update before quitting.
# Set to zero to run forever.
total_run_times 0

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_transparent yes
own_window_type normal
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# Minimum size of text area
minimum_size 180 0

# Draw shades?
draw_shades no

# Draw outlines?
draw_outline yes
default_outline_color white
# Draw borders around text 
draw_borders no

# Stippled borders?
stippled_borders 0

# border margins
border_margin 5

# border width
border_width 1

# Default colors and also border colors
# default_color white
# own_window_colour white

# Subtract file system buffers from used memory?
no_buffers yes

# set to yes if you want all text to be in uppercase
uppercase no

# number of cpu samples to average
# set to 1 to disable averaging
cpu_avg_samples 2

# number of net samples to average
# set to 1 to disable averaging
net_avg_samples 2

# Force UTF8? note that UTF8 support required XFT
override_utf8_locale yes

# Add spaces to keep things from moving about?  This only affects certain objects.
use_spacer none

alignment bl
gap_x 1100
gap_y 0
minimum_size 250 250
maximum_width 280

default_color 1271CF


TEXT
${color #00ffff}RadioTray: $color${if_running radiotray} $else ${color red}Not running $endif
${color #00ffff}Station: ${execi 15 qdbus net.sourceforge.radiotray /net/sourceforge/radiotray net.sourceforge.radiotray.getCurrentRadio}
${color #7D8C93}Artist & Song
${execi 15 qdbus net.sourceforge.radiotray /net/sourceforge/radiotray getCurrentMetaData| fold -s -w35}

Ensuite avec conky control option "Conky Gestion/Ajout" et tu sélectionnes ton fichier. Tu pourras alors le sélectionner dans les conkys perso de "conky listes"

PS: Si ce n'est pas fonctionnel, je regarderai plus tard mais je ne suis pas très doué en conky, à vrai dire je me contente de reprendre ce que les autres font mieux que moi. Ça fonctionne sur Unity ou je suis en ce moment. A toi d'adapter les couleurs, polices,etc...

#24 Re : -1 »  Live Voyager » Le 13/07/2014, à 10:09

metalux
Réponses : 2493

@Vincent Valentine
C'est les lignes ci-dessous qui déterminent le contour

# Draw outlines?
draw_outline yes
default_outline_color white

Si tu ne veux pas de contour, passe la valeur à no draw_outline no. Si tu veux modifier la couleur, change white par la couleur que tu souhaites.
@Jibel
Oui, c'est possible. Tu trouveras l'essentiel dans le dossier ~/.scripts. A vérifier que les actions personnalisées de thunar pointent bien vers tes nouveaux scripts. Après à toi de faire attention de ne pas tout casser. En tout cas pour conky control c'est OK.