Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Money 2005 avec Wine & Ubuntu 6.1 » Le 18/05/2008, à 11:27

tsndcb
Réponses : 211

Bon je vous fais part de mon "avancement".

j'ai fait un test avec la version d'essai de crossover et ma version de money 2005 fonctionne parfaitement, plus de debug et affichage OK.

Le seul hic pour le moment c'est que je ne peux pas utiliser mon fichier money, car money n'arrive pas à télécharger la mise à jour de microsoft...

Pour le moment c'est ce qui me bloque, il faut que je vois comment je peux régler cela.

La version de wine qui est utiliser est la 0.9.34

#1 Re : -1 »  Money 2005 avec Wine & Ubuntu 6.1 » Le 18/05/2008, à 15:55

tsndcb
Réponses : 211

Bon ça y mon money 2005 est pleinement fonctionnel.

En fait, il faut faire l'installation au début avec une bootle paramétrée en win98. Il y a quelques problèmes d'affichage, mais c'est pas très grave.

Une fois l'install finie, rester en win98 et relancer money, là cette fois-ci la mise à jour de money se fait correctement, mais il y a toujours quelques problèmes d'affichage.

Une fois que la mise à jour est finie, fermer money, paramétrer la bootle en win2OOO (en winxp, il y a des messages d'avertissement qui s'affiche) et là tout est good, pas de problème d'affichage, pas de message d'avertissement et tout fonctionne parfaitement wink

#2 Re : -1 »  Money 2005 avec Wine & Ubuntu 6.1 » Le 18/05/2008, à 20:34

tsndcb
Réponses : 211

Salut Garth,

Comme je l'ai mis plus haut, ceci n'était qu'un test (j'ai utilisé une version d'essai de crossover qui comporte une version 0.9.34 de wine).

Le bonne nouvelle, c'est que visiblement la version de money 2005 peut bien fonctionner sous HARDY avec wine.

La "mauvaise" nouvelle, du moins celle qui ne me satisfait pas, c'est que pour ce faire j'ai dû utiliser une version commerciale de wine.

Ce qui me faire dire que cela devrait pouvoir fonctionner avec la version "normale" de wine, c'est que money n'est pas supporté par crossover et que par conséquent, je n'ai utilisé aucun script money de crossover pour l'installer.

Maintenant reste à approfondir et à trouver le bon réglage avec la version normale de wine, mais déjà, maintenant, on c'est que c'est possible et je pense que cela aidera surement liquidalien wink

#3 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 29/05/2012, à 16:07

tsndcb
Réponses : 2641

@ArchangeGabriel

Pour OCCULTHUM, ayant le même portable mais avec un i7 à la place du i5, si cela peut aider à analyser, voici ce qu'il devrait de répondre :

lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0fd1] (rev ff) (prog-if ff)

Pour les erreurs, je pense qu'il doit parler de celle-ci

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)
[ERROR]Aborting because fallback start is disabled.

Si cela peut aider

#4 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 30/05/2012, à 18:35

tsndcb
Réponses : 2641

@ArchangeGabriel

Ayant un petit peu de temps à y consacrer (et en plus c'est pas tout les jours qu'on peu aider le développeur français à perfectionner son package) et ayant à peu près la même configuration que OCCULTHUM  (AW M14xR2 i7 Nvidia GT650M)

Je tourne d'habitude sous debian, mais pour faire avancer le chmilblic (si c'est possible), je viens de faire une fresh install d'ubuntu 12-04 et d'installer bumblebee.

voici ce que cela donne après reboot :

lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation Ivy Bridge Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0fd1] (rev ff) (prog-if ff)

glxspheres => OK

glxspheres
Polygons in scene: 62464
Visual ID of window: 0xa5
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile 
59.741523 frames/sec - 54.548790 Mpixels/sec
59.995943 frames/sec - 54.781096 Mpixels/sec
60.081003 frames/sec - 54.858763 Mpixels/sec
59.969422 frames/sec - 54.756880 Mpixels/sec
60.002668 frames/sec - 54.787236 Mpixels/sec

Par contre optirun glxspheres => KO

optirun glxspheres
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ERROR]Aborting because fallback start is disabled.

Voici quelques informations complémentaires :

optirun -vv glxinfo
[DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[DEBUG]Process /sbin/modinfo started, PID 2360.
[DEBUG]Hiding stderr for execution of /sbin/modinfo
[DEBUG]SIGCHILD received, but wait failed with No child processes
[DEBUG]Detected nvidia driver (module nvidia-current)
[DEBUG]Active configuration:
[DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[DEBUG] X display: :8
[DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-current:/usr/lib32/nvidia-current
[DEBUG] Socket path: /var/run/bumblebee.socket
[DEBUG] VGL Compression: proxy
[DEBUG]optirun version 3.0 starting...
[INFO]Response: No - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[DEBUG]Socket closed.
[ERROR]Aborting because fallback start is disabled.
[DEBUG]Killing all remaining processes.
cat /var/log/Xorg.8.log
[   151.498] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[   151.498] X Protocol Version 11, Revision 0
[   151.498] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
[   151.498] Current Operating System: Linux 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
[   151.498] Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-23-generic root=UUID=54377a5f-6d86-4025-a9f2-73c47df34796 ro quiet splash vt.handoff=7
[   151.498] Build Date: 05 April 2012  04:32:37AM
[   151.498] xorg-server 2:1.11.4-0ubuntu10 (For technical support please see http://www.ubuntu.com/support) 
[   151.498] Current version of pixman: 0.24.4
[   151.498]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   151.498] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   151.498] (==) Log file: "/var/log/Xorg.8.log", Time: Wed May 30 18:04:34 2012
[   151.498] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[   151.498] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   151.498] (==) ServerLayout "Layout0"
[   151.498] (==) No screen section available. Using defaults.
[   151.498] (**) |-->Screen "Default Screen Section" (0)
[   151.498] (**) |   |-->Monitor "<default monitor>"
[   151.498] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[   151.498] (**) |   |-->Device "Device1"
[   151.498] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   151.498] (**) Option "AutoAddDevices" "false"
[   151.498] (**) Not automatically adding devices
[   151.498] (==) Automatically enabling devices
[   151.498] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   151.498]     Entry deleted from font path.
[   151.498] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[   151.498] (++) ModulePath set to "/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules"
[   151.498] (==) |-->Input Device "<default pointer>"
[   151.498] (==) |-->Input Device "<default keyboard>"
[   151.498] (==) The core pointer device wasn't specified explicitly in the layout.
    Using the default mouse configuration.
[   151.498] (==) The core keyboard device wasn't specified explicitly in the layout.
    Using the default keyboard configuration.
[   151.498] (II) Loader magic: 0x7f504b3d6b00
[   151.498] (II) Module ABI versions:
[   151.498]     X.Org ANSI C Emulation: 0.4
[   151.498]     X.Org Video Driver: 11.0
[   151.498]     X.Org XInput driver : 16.0
[   151.498]     X.Org Server Extension : 6.0
[   151.499] (--) PCI:*(0:1:0:0) 10de:0fd1:1028:0552 rev 161, Mem @ 0xd0000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[   151.499] (II) Open ACPI successful (/var/run/acpid.socket)
[   151.499] (II) LoadModule: "extmod"
[   151.499] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   151.499] (II) Module extmod: vendor="X.Org Foundation"
[   151.499]     compiled for 1.11.3, module version = 1.0.0
[   151.499]     Module class: X.Org Server Extension
[   151.499]     ABI class: X.Org Server Extension, version 6.0
[   151.499] (II) Loading extension MIT-SCREEN-SAVER
[   151.499] (II) Loading extension XFree86-VidModeExtension
[   151.499] (II) Loading extension XFree86-DGA
[   151.499] (II) Loading extension DPMS
[   151.499] (II) Loading extension XVideo
[   151.499] (II) Loading extension XVideo-MotionCompensation
[   151.499] (II) Loading extension X-Resource
[   151.499] (II) LoadModule: "dbe"
[   151.500] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   151.500] (II) Module dbe: vendor="X.Org Foundation"
[   151.500]     compiled for 1.11.3, module version = 1.0.0
[   151.500]     Module class: X.Org Server Extension
[   151.500]     ABI class: X.Org Server Extension, version 6.0
[   151.500] (II) Loading extension DOUBLE-BUFFER
[   151.500] (II) LoadModule: "glx"
[   151.500] (II) Loading /usr/lib/nvidia-current/xorg/libglx.so
[   151.565] (II) Module glx: vendor="NVIDIA Corporation"
[   151.565]     compiled for 4.0.2, module version = 1.0.0
[   151.565]     Module class: X.Org Server Extension
[   151.565] (II) NVIDIA GLX Module  295.53  Fri May 11 23:49:08 PDT 2012
[   151.565] (II) Loading extension GLX
[   151.565] (II) LoadModule: "record"
[   151.565] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   151.566] (II) Module record: vendor="X.Org Foundation"
[   151.566]     compiled for 1.11.3, module version = 1.13.0
[   151.566]     Module class: X.Org Server Extension
[   151.566]     ABI class: X.Org Server Extension, version 6.0
[   151.566] (II) Loading extension RECORD
[   151.566] (II) LoadModule: "dri"
[   151.566] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   151.566] (II) Module dri: vendor="X.Org Foundation"
[   151.566]     compiled for 1.11.3, module version = 1.0.0
[   151.566]     ABI class: X.Org Server Extension, version 6.0
[   151.566] (II) Loading extension XFree86-DRI
[   151.566] (II) LoadModule: "dri2"
[   151.566] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   151.566] (II) Module dri2: vendor="X.Org Foundation"
[   151.566]     compiled for 1.11.3, module version = 1.2.0
[   151.566]     ABI class: X.Org Server Extension, version 6.0
[   151.566] (II) Loading extension DRI2
[   151.566] (II) LoadModule: "nvidia"
[   151.566] (II) Loading /usr/lib/nvidia-current/xorg/nvidia_drv.so
[   151.573] (II) Module nvidia: vendor="NVIDIA Corporation"
[   151.574]     compiled for 4.0.2, module version = 1.0.0
[   151.574]     Module class: X.Org Video Driver
[   151.576] (II) LoadModule: "mouse"
[   151.576] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[   151.577] (II) Module mouse: vendor="X.Org Foundation"
[   151.577]     compiled for 1.11.3, module version = 1.7.1
[   151.577]     Module class: X.Org XInput Driver
[   151.577]     ABI class: X.Org XInput driver, version 16.0
[   151.577] (II) LoadModule: "kbd"
[   151.577] (WW) Warning, couldn't open module kbd
[   151.577] (II) UnloadModule: "kbd"
[   151.577] (II) Unloading kbd
[   151.577] (EE) Failed to load module "kbd" (module does not exist, 0)
[   151.577] (II) NVIDIA dlloader X Driver  295.53  Fri May 11 23:29:56 PDT 2012
[   151.577] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   151.578] (--) using VT number 7

[   151.578] (II) Loading sub module "fb"
[   151.578] (II) LoadModule: "fb"
[   151.578] (II) Loading /usr/lib/xorg/modules/libfb.so
[   151.578] (II) Module fb: vendor="X.Org Foundation"
[   151.578]     compiled for 1.11.3, module version = 1.0.0
[   151.578]     ABI class: X.Org ANSI C Emulation, version 0.4
[   151.578] (II) Loading sub module "wfb"
[   151.578] (II) LoadModule: "wfb"
[   151.578] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   151.580] (II) Module wfb: vendor="X.Org Foundation"
[   151.580]     compiled for 1.11.3, module version = 1.0.0
[   151.580]     ABI class: X.Org ANSI C Emulation, version 0.4
[   151.580] (II) Loading sub module "ramdac"
[   151.580] (II) LoadModule: "ramdac"
[   151.580] (II) Module "ramdac" already built-in
[   151.581] (II) Loading /usr/lib/nvidia-current/xorg/nvidia_drv.so
[   151.581] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   151.581] (II) Loading /usr/lib/xorg/modules/libfb.so
[   151.582] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   151.582] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   151.582] (==) NVIDIA(0): RGB weight 888
[   151.582] (==) NVIDIA(0): Default visual is TrueColor
[   151.582] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   151.582] (**) NVIDIA(0): Option "NoLogo" "true"
[   151.582] (**) NVIDIA(0): Option "UseEDID" "false"
[   151.582] (**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
[   151.582] (**) NVIDIA(0): Enabling 2D acceleration
[   151.582] (**) NVIDIA(0): ConnectedMonitor string: "DFP"
[   151.582] (**) NVIDIA(0): Ignoring EDIDs
[   159.309] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[   159.309] (EE) NVIDIA(0):     check your system's kernel log for additional error
[   159.309] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
[   159.309] (EE) NVIDIA(0):     README for additional information.
[   159.309] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[   159.309] (II) UnloadModule: "nvidia"
[   159.309] (II) Unloading nvidia
[   159.309] (II) UnloadModule: "wfb"
[   159.309] (II) Unloading wfb
[   159.309] (II) UnloadModule: "fb"
[   159.309] (II) Unloading fb
[   159.309] (EE) Screen(s) found, but none have a usable configuration.
[   159.309] 
Fatal server error:
[   159.309] no screens found
[   159.309] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   159.309] Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[   159.309] 
[   159.309]  ddxSigGiveUp: Closing log
[   159.309] Server terminated with error (1). Closing log file.
lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd1 (rev ff)
07:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)
08:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
09:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
lspci -v -s 01:00.0
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd1 (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: nvidia

kernel d'origine :

uname -a
Linux 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Je n'ai pas de fichier /etc/X11/xorg.conf, j'espère avoir donné tout les renseignements nécessaire, si ce n'est pas le cas, ne pas hésiter à le demander.

[Edit] Une chose que j'ai également remarqué, le DisplayPort, ne semble pas supporté [/Edit]

#5 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 31/05/2012, à 07:28

tsndcb
Réponses : 2641
ArchangeGabriel a écrit :

@OCCULTHUM, tsndcb : Bien et ben il va me falloir /var/log/syslog de vos machines pour avancer. Je ne sais pas si vous pouvez le copier quelque part sur le web, sinon envoyez-le moi par mail (faites un MP, je vous répondrai et vous aurez mon email). tsndcb : Et sous Debian ça fonctionne ?

@ArchangeGabriel] : fichier envoyé

#6 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 03/06/2012, à 20:25

tsndcb
Réponses : 2641

@ArchangeGabriel : tout d'abord merci pour ton travail, j'ai essayé le changement demandé, mais maintenant j'ai le même symptôme que OCCULTHUM : message d'erreur + arrêt brutal (arrêt brutal que je n'avais pas avant, mais je ne pense pas que cela vienne de ce changement d'option), j'ai essayé de mettre complètement à  jour ubuntu, mais même problème, je vais refaire une install sous débian avec ton option pour voir si ça change et je te tiens au courant.

Et effectivement malheureusement je me doute que nous ne sommes pas tout seul dans ce cas là, optimus de m.... si encore NVIDIA faisait son travail et fournissait un support pour optimus sous linux ... Heureusement qu'il y a des développeur déterminé dans la communauté.

#7 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 04/06/2012, à 00:20

tsndcb
Réponses : 2641

@ArchangeGabriel, merci beaucoup pour cette bonne nouvelle (je dis bien bonne car cela devrait donc être résolu dés que des drivers pour la GT650M seront disponible).

De mon coté j'ai fini de réinstaller ma debian et comme je le pensais j'ai les mêmes problèmes avec optirun glxspheres, mais je préférais en être sûr.

Je suis désolé pour l'éventuel temps perdu qu'à provoqué notre problème que tu ne pouvais pas résoudre puisque cela provient très probablement des drivers nvidia manquant pour notre carte GT650M.

Encore merci.

[Edit] Effectivement seul les cartes suivantes dans notre série (6xxM) sont prise en charge : GT 635M, GT 630M, G610M [/Edit]

#8 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 08/06/2012, à 19:30

tsndcb
Réponses : 2641

@falcon72 : tu es dans le même cas que nous tous avec les nouvelles nvidia, il n'y a actuellement pas de drivers linux pour ces dernières, il faut attendre comme l'a indiqué ArchangeGabriel un peu plus haut :

ArchangeGabriel a écrit :

@tsndcb, OCCULTHUM, Ethylamide : bon en fait on a trouvé le problème, vos cartes ne sont pas supportées par la version actuelle du driver nvidia. Comme aucune carte de la génération Kepler d'ailleurs, à l'exception de la GTX680 sortie il y a déjà plusieurs mois.

Donc aucun drivers pour la série Kepler, dont ta carte fait parti.

#9 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 11/06/2012, à 13:05

tsndcb
Réponses : 2641

@ArchangeGabriel : petite question, dans la mesure où l'on ne peut pas utiliser nvidia-xconfig, comment peut-on utiliser nvidia-settings, dans la mesure où nvidia-xconfig est un pré-requis ?
Je te remercie d'avance pour ton retour.

[Edit] j'entrevois une très bonne nouvelle :
Version :295.59 Certified
Date de réalisation :2012.06.11
Système d’exploitation :Linux 64-bit

GeForce 600M series:
GTX 675M, GTX 670M, GTX 660M, GT 650M, GT 640M LE, GT 640M, GT 635M, GT 630M, GT 620M, G610M

Added support for the following GPUs:

    NVS 5400M
    NVS 310
    GeForce GT 620M
    GeForce GT 640M
    GeForce GT 640M LE
    GeForce GT 650M
    GeForce GTX 660M
    GeForce GTX 670M
    GeForce GTX 675M
    GeForce GTX 555
    GeForce GTX 560 SE
    GeForce GT 415
    GeForce GTX 460 v2

[/Edit]

#10 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 13/06/2012, à 23:30

tsndcb
Réponses : 2641
ArchangeGabriel a écrit :

@tsndcb : Lis les questions/réponses page 1. wink
.

Effectivement, merci pour l'info.

#11 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 19/06/2012, à 10:36

tsndcb
Réponses : 2641

@ArchangeGabriel, pour le moment je ne peux pas aider pour l'hdmi, n'étant pas touché par ce cas (le port HDMI étant relié à la carte Intel), seul le displayport est relié à la carte Nvidia.

Cependant pour le moment, même avec les derniers drivers j'ai toujours l'erreur :

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ERROR]Aborting because fallback start is disabled.

Donc à suivre ...

#12 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 21/06/2012, à 14:58

tsndcb
Réponses : 2641

Bonjour à tous,

Pour information de ce que j'ai pu lire sur différents forums US, les personnes qui ont réussi à faire fonctionner une GT 650M avec bumblebee étaient sous Ubuntu 12.04 avec un  kernel 3.4.3.

Pour ma part, je ne pourrais pas tester tout de suite cette solution étant repassé sous sid.

#13 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 25/06/2012, à 17:50

tsndcb
Réponses : 2641
tsndcb a écrit :

Bonjour à tous,

Pour information de ce que j'ai pu lire sur différents forums US, les personnes qui ont réussi à faire fonctionner une GT 650M avec bumblebee étaient sous Ubuntu 12.04 avec un  kernel 3.4.3.

Pour ma part, je ne pourrais pas tester tout de suite cette solution étant repassé sous sid.

Pour ma part, je viens de faire le test sous debian, sans rien modifier d'autre, le simple fait de passer à un noyau 3.4 a solutionné mon problème de lancement d'optirun.

Tout est OK de ce point de vu.

[Edit] il me reste encore le displayport à activer [/Edit]

#14 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 26/06/2012, à 22:06

tsndcb
Réponses : 2641

@ArchangeGabriel : visiblement la version du kernel a beaucoup d'importance, je pense que le comportement que j'ai eu sur sid doit être le même sur ubuntu.
Concernant le displayport, je pense que ce dernier est partiellement activé car je vois le "gros" X se déplacer quand je bouge la souris sur les deux autres écrans, donc il faut que je creuse ce point là.
Pour ma part, à mon avis les drivers 295.59 sont compatible avec la 650M vu que j'accède bien à optirun ainsi qu'à nividia-settings.

Donc à suivre.

Pour info, voici ce que j'obtiens :

OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
60.044033 frames/sec - 62.541865 Mpixels/sec
60.057783 frames/sec - 62.556186 Mpixels/sec
59.954130 frames/sec - 62.448222 Mpixels/sec
59.932513 frames/sec - 62.425705 Mpixels/sec


avec la carte nvidia :

OpenGL Renderer: GeForce GT 650M/PCIe/SSE2
136.495704 frames/sec - 142.173926 Mpixels/sec
151.041453 frames/sec - 157.324777 Mpixels/sec
154.877684 frames/sec - 161.320595 Mpixels/sec
154.286134 frames/sec - 160.704437 Mpixels/sec


Merci pour le travail effectué avec bumblebee

#15 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 27/06/2012, à 07:07

tsndcb
Réponses : 2641
Stef-Asus a écrit :

@ArchangeGabriel
EDIT
Lorsque je fait un sudo nvidia-settings
Le retour est:

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Je n'ai pas voulu faire le sudo nvidia-xconfig car ya 2 jour cela m'a planté complètement l'affichage

Merci.

En fait il faut utiliser : optirun nvidia-settings -c :8 et non pas juste nvidia-settings

#16 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 27/06/2012, à 11:25

tsndcb
Réponses : 2641

Bonjour à tous,

Pour info dans les dépots debian (sid), vient d'apparaître la version 302.17 pour les pilote nvidia, donc je pense que cela doit également être le cas pour ubuntu ou que cela ne va pas tarder.

Par contre je n'ai pas encore eu le temps de tester.

#17 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 27/06/2012, à 21:48

tsndcb
Réponses : 2641
tsndcb a écrit :

Bonjour à tous,

Pour info dans les dépots debian (sid), vient d'apparaître la version 302.17 pour les pilote nvidia, donc je pense que cela doit également être le cas pour ubuntu ou que cela ne va pas tarder.

Par contre je n'ai pas encore eu le temps de tester.

Bonsoir,

Les performances avec les nouveaux drivers semblent bien meilleures :

OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
59.985033 frames/sec - 62.480411 Mpixels/sec
59.949438 frames/sec - 62.443335 Mpixels/sec
59.993642 frames/sec - 62.489378 Mpixels/sec
59.982546 frames/sec - 62.477820 Mpixels/sec

OpenGL Renderer: GeForce GT 650M/PCIe/SSE2
205.915534 frames/sec - 214.481620 Mpixels/sec
208.445552 frames/sec - 217.116887 Mpixels/sec
208.884410 frames/sec - 217.574001 Mpixels/sec
220.280340 frames/sec - 229.444002 Mpixels/sec

#18 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 06/07/2012, à 21:05

tsndcb
Réponses : 2641
dragao13 a écrit :

Je ne sais pas si vous aviez vu mais apparemment ça bouge chez nvidia et le support optimus pour linux : http://www.phoronix.com/scan.php?page=n … px=MTEyOTQ

C'est plutôt bon signe, espérons que des développeurs comme ArchangeGabriel, vont avoir enfin un support digne de ce nom de la part de Nvidia.

A suivre ...

#19 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 11/07/2012, à 18:19

tsndcb
Réponses : 2641
Renaud104 a écrit :
[renaud@renaud-laptop ~]$ optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ERROR]Aborting because fallback start is disabled.

C'est un problème "classic", il faut installer : xserver-xorg-input-mouse

#20 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 11/07/2012, à 22:25

tsndcb
Réponses : 2641
Renaud104 a écrit :

@tsndcb : Le driver "extra/xf86-input-mouse 1.7.2-1 (xorg-drivers xorg) [installed]", ainsi qu'il se nomme sous arch est comme tu peux le voir installé. Dommage que ça n'ait pas résolu le problème.

Vraiment désolé, moi cela avait réglé ce problème sous debian.

#21 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 14/10/2012, à 11:51

tsndcb
Réponses : 2641

@ArchangeGabriel : peut-être ouvrir un autre post "uptodate" wink

#23 Re : -1 »  Wireless Touchpad de Logitech » Le 22/02/2012, à 19:57

tsndcb
Réponses : 3

Bonsoir papoteur,

Etant également intéressé par ce touchpad qui est moins encombrant qu'une bamboo, même si visiblement les fonctions multitouch sont plus limitées (pas de zoom ou rotation)..

Pourrais-tu s'il te plaît nous faire un peu petit retour avec maintenant un mois d'utilisation ?

Je t'en remercie d'avance.

#24 -1 »  WMP300N atheros 5416 possibilité Wifi N avec linux ? » Le 13/05/2008, à 07:47

tsndcb
Réponses : 0

Voilà, j'ai essayé avec Ndiswrapper et la dernière version de madwifi, avec  les deux méthodes la carte fonctionne très bien sous hardy.

Le seul hic, c'est que je n'arrive pas à dépasser la vitesse de 54 Mbits en détection et je reste donc en Wifi G alors que cette carte supporte le Wifi N.

Je souhaiterai donc savoir si des personnes ont réussi à faire fonctionner ce genre de carte en Wifi N.

Je vous remercie d'avance pour vos réponses wink


[Edit]Changement de titre[/Edit]