Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 00:02

Babdu89
Réponses : 41

Bonsoir.
Lorsque la machine démarre, dans le menu grub, essaye de lancer les Os installés un par un, en t'aidant des numéro de disques et partitions. (/dev/sd**)
indiqués dans chaque entrée du menu Grub.
Comme écrit plus haut. Dans le menu Grub les variantes de Ubuntu (Xubuntu, Lubuntu, Kubuntu ) portent le même nom ; Ubuntu.

Tu t'armes d'un papier un crayon, et tu notes le nom de quel Os est lancé par chaque entrée du menu Grub. Comme çà tu sauras à qui tu as affaire.

D'après le retour de la mise à jour de grub de l'Os qui démarre la machine, tu dois avoir ceci dans le manu Grub.
l'os qui démarre par défaut.
Sur le premier disque;
Ubuntu 14.04 (ou 14.10, noyau version 3.16.0-33) en /dev/sda1
Memory test
Memory test
Ubuntu 14.04.1 sur /dev/sda4
Sur le deuxième disque;
Ubuntu  12.04.5 sur /dev/sdb1

Pour l'organisation de tes disques, la taille des partitions tu es libre, après tout, tu es chez toi. Du moment que çà marche...
Si tu manques de place pour installer autre chose, tu reviens sur le forum, et quelqu'un, par exemple Qid...   wink Se fera un plaisir de t'aider à remettre de l'ordre dans tes disques, pour faire de la place.

alca94 a écrit;
Bonsoir
Moi je n'aurais qu'une question ,a quoi sert d'avoir 3 versions différentes d'Ubuntu sur son PC "de tous les jours"
Pour un "aidant" sur le Forum pourquoi pas (histoire d'avoir toute les possibilité de réglages) mais là ? une fois l'écran d'accueil passé les logiciels sont les mêmes

Oui, on voit du Ubuntu partout dans le menu grub.
Mais d'après  mamyzero, il y a au moins un Ubuntu, un Lubuntu et un Xubuntu installés. Les variantes affichent bien ; Ubuntu dans le menu Grub?.
Chacun à bien le droit de tester ces variantes?  non?...

Ah làlà!!!.
Si je branche mes 4 hdd usb , avec les 4 hdd internes de ma config, si je montres  tous les Os installés on va aussi me demander ce que j'en fais?...
Je teste, je fouine, j'installe, je compare, et je laisse en l'état, jusqu’à ma nouvelle "marote" . une autre installation de tests.
Je copie mes système sur mes hdd usb,  pour le trimbaler à jour, de machine en machines aussi.

L'informatique, c'est une "marmite" dans laquelle il ne faut ps tomber !!! . lol

@+.  Babdu89   . smile

#1 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 13:34

Babdu89
Réponses : 41

Bonjour.

mamyzero a écrit :

Voilou!
Je me suis trompée au #9, c'est pas Lubuntu en 1er
Donc :
* Ubuntu, avec Linux 3.13.0-45--generic > l'écran Ubuntu, (sans doute Unity) trop long, après 5 mn n'a toujours pas démarré
* pévious linux versions
* mémory test (memtest86+)
* mémory test (memtest86+, sérial console 115200)

Le suivant est Lubuntu
* Ubuntu--class ubuntu--class gnu linux--class gnu--class os, gnulinux-simple-75f0e2cf-c6fd-42d0-94fe-9ef83bc13bc1 (on /dev/dsa1)
* Ubuntu, avec linux 3.16.0-31 generic'--class ubuntu--class gnu linux--class gnu--class os  'gnulinux-3.16.0-31-generic-advanced-   75f0e2cf-c6fd-42 et une petite flèche

Maintenant, ce que contient prévious :
* Ubuntu, avec linux 3.13.0-44-generic : écran ubuntu (sûrement unity 14.04) mais ne démarre pas
* Ubuntu, avec linux 3.13.0-43-generic : écran ubuntu (sûrement unity 14.04) mais ne démarre pas
* Ubuntu, avec linux 3.13.0-41-generic : écran ubuntu (sûrement unity 14.04) mais ne démarre pas
* Ubuntu, avec linux 3.13.0-40-generic : écran ubuntu (sûrement unity 14.04) mais ne démarre pas
* Ubuntu, avec linux 3.13.0-39-generic : écran ubuntu (sûrement unity 14.04) mais ne démarre pas
* Ubuntu, avec linux 3.13.0-38-generic : rien écran noir, initramfs , curseur clignote, ctrl alt suppr ne déconnecte pas le pc, arrêt à l'arrache.
* Ubuntu, avec linux 3.13.0-24-generic : Démarre sous Ubuntu Unity 12.04
* Ubuntu, avec linux 3.2.0-79-generic-pae : Ubuntu Unity 12.04
* Ubuntu, avec linux 3.2.0-77-generic-pae : Ubuntu Unity 12.04
* Ubuntu, avec linux 3.2.0-76-generic-pae : Ubuntu Unity 12.04
* Ubuntu, avec linux 3.2.0-23-generic-pae : Ubuntu Unity 12.04

Il n'y a qu'un seul où la partition est notée.

Comment supprimer ces noyaux inutiles ?
Et, je fais quoi maintenant ? sous vos conseils assez détaillés car je ne veux pas faire encore du n'importe quoi sad

Ah!!!.  C'est un peu confus, et çà ne retourne que deux Os.

Bon on va procéder de la manière suivante.
Tu démarres la machine sur l'Os par défaut. Celui qui démarre depuis le menu Grub sans rien faire. Tu notes de quel Os il s'agit.

Lorsque tu es sur le bureau, dans un terminal, on va mettre Grub de cet Os à jour.

sudo update-grub

On va lister ce que contient le menu Grub

grep menuentry /boot/grub/grub.cfg

Tu donnes le retour terminal complet, c'est à dire avec les deux prompts début et fin. Sinon on considère le menu incomplet. 
Si c'est le cas il faut changer l'affichage du nombre de lignes dans le terminal.
On va dans les menus du terminal.
Édition>Préférence du profile , dans l'onglet "Défilement" on coche "illimité".
Ça devrait retourner toute les lignes comprises dans le menu Grub . Avec les deux prompts.

On va lister disque et partitions avec leurs UUID.

sudo blkid

Tu postes le retour terminal avec  blkid.

Avec tout çà on va pouvoir déterminer exactement ce qui est installé sur les partitions.

Tu redémarres et tu essayes les entrées. Chaque entrée du menu Grub, c'est deux lignes.
La première le démarrage en mode normal, c'est çà qui doit démarrer chaque Os.
la deuxième le démarrage en mode recovery (réparation) .

Tu notes de quel Os il s'agit.

Après on pourra voir ce qui ne démarre pas et faire du nettoyage de noyaux en trop.

@+. Babdu89   .

#2 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 14:15

Babdu89
Réponses : 41

Ah!! j'ai zappé çà.

Donc :
* Ubuntu, avec Linux 3.13.0-45--generic > l'écran Ubuntu, (sans doute Unity) trop long, après 5 mn n'a toujours pas démarré
* pévious linux versions

Donc si tu choisis de démarrer un autre Os, que le premier proposé, et qu'il marche. Tu peux faire une des  manips que j'indique post#6. Mise à jour de Grub seulement pour l'instant.
Au redémarrage ce n'est pas le menu Grub de cet Os qui va s'afficher.  Mais encore celui où le premier Os ne démarre pas. Tu ne redémarres pas.

Donc, Il faut qu'on réinstalle Grub sur l'Os que tu choisis de démarrer pour faire les manips.
Alors comme tu n'as que 3 Os installés çà va faciliter la suite.

Donc tu fais la mise à jour de Grub.

sudo update-grub

Tu postes le retour du terminal.

On va te dire pour la suite des manips pour réinstaller Grub .

J'anticipe les commandes.

Lister les Os installé dans la config

sudo os-prober

Mise à jour de Grub de l'Os qu'on utilise

sudo update-grub

Réinstallation de Grub sur le disque qui démarre la machine. (ce n'est pas forcément celui où est installé l'os qui démarre.)

sudo grub-install /dev/sd*

/sd* ...  le * sera remplacé par le disque ou est réinstallé Grub. On va savoir çà avec le retour de update-grub.


@+.  Babdu89  .

#3 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 18:55

Babdu89
Réponses : 41

Oui, kclean!.  Super!!!.
Un grand Bravo à Hoper.
Et on l'installe avec la logithèque.
Je l'installe sur tous mes Os susceptibles de rester sur mes disques. Comme çà lorsque j'en ai besoin, je peux le lancer.
Bien plus facile à utiliser que la méthode par Synaptic.

Alors, qu'est ce que çà donne le  sudo update-grub demandé au post#28?.

@+.   Babdu89   .

#4 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 22:45

Babdu89
Réponses : 41

Bonsoir.

Je répondrais pour Kclean un peu plus tard.

Je reviens vers  mamyzero.
On sait qu'il y a 3 Os installés sur sa machine. Voir les screen fait avec Gparted plus haut dans le sujet.
1 en /dev/sda1
1 en /dev/sda4
1 en /dev/sdb1 avec peut-être à confirmer un /home séparé en /dev/sdb3 .

On sait que l'Os en /dev/sda1 démarre, puisque c'est de cet Os qu'est faite la mise à jour de grub. (post#32).

@ mamyzero  stp, on peut avoir le retour des commandes suivantes ? Faites depuis l'Os (/dev/sda1) que tu as démarrer pour faire la maj de Grub?. Comme demandé post#26.

grep menuentry /boot/grub/grub.cfg

et

sudo blkid

Puis faire un démarrage de chaque Os, en disant ceux ou celui qui ne marche ou pas.

Première entrée du menu grub (deux lignes) Os en /dev/sda1
Deuxième entrée du menu grub (deux lignes) Os en /dev/sda4
Troisième entrée du menu grub (deux lignes) Os en /dev/sdb1

Édit.
Ah bon, bonne nuit à demain.

@+.   Babdu89 .

#5 Re : -1 »  Xubuntu installé, mais pas visible » Hier à 23:25

Babdu89
Réponses : 41

Kclean.

Bon, je n'aime pas trop polluer les sujets, mais çà intéressera aussi  mamyzero.

Kclean, on récupère le paquet .deb sur le sujet de Hoper.

http://forum.ubuntu-fr.org/viewtopic.php?id=242358&p=1

On peut aussi pour ceux qui le veulent récupérer le script , le lancer en commandes.

On installe le paquet .deb  Kclean, avec la logithèque, gdebi &&..
On le lance en graphique depuis les menus, ou en commande.

sudo kclean
sudo "kclean -g"

Avec certains environnements. J'en ai un chez moi qui ne marche qu'avec cette commande. (Merci Hoper).

Des fenêtres zenity s'ouvrent pour demander si on veut garder la dernière version du noyau .
Ce qu'il faut comprendre par là, c'est que l'on veut garder le dernier noyau avant celui qui est employé pour faire marcher l'Os qui lance Kclean.
Donc l'avant dernier noyau. On garde les deux noyaux au menu grub.

Une de ces fenêtres zenity montre les noyaux qui seront supprimés avec des coches validées devant chacun. On peut encore modifier le choix.

Je l'ai déjà utilisé pour me sortir d'affaire, avec un noyau dernière version qui ne marche pas et que je ne pouvais pas supprimer.
Il suffit de démarrer l'os sur le noyau version d'avant, ou celui qui marche.
Kclean indique que la machine n'est pas démarrée sur la dernière version du noyau, qu'une version supérieur existe et qu'il va arrêter sans rien changer.
Il indique aussi que si on veut faire la manip , on doit lancer Kclean en commandes en le forçant avec l'option  -f .
On est averti que tous les noyaux sauf celui utiliser vont être supprimés. Le travail est fait ensuite.

On peut faire la même chose avec synaptic, c'est plus compliqué.  Avec les commandes , il faut savoir lesquelles utiliser.

La commande  apt-get autoremove  ne va pas forcément supprimer tous les anciens noyaux, même si elle propose de le faire.
Il y a déjà eu une discutions  à ce sujet, tiramiseb à expliqué pourquoi. C'est assez costaud comme "truc" j'ai découvert en testant des fichiers que je ne connaissais pas...
Faudrait la retrouver, il me semble c'est un sujet avec dans le titre " ... autoremove lave plus blanc..." 
Participants dont je me rappelle. malbo, moi même, tiramiseb , les autres excusez moi.
tiramiseb mettait l'accent sur les noyaux installer automatiquement, et ceux installés manuellement. La commande autoremove ne pouvait nettoyer que ceux installés automatiquement, en faisant les maj système. Ceux installé "manuellement" en dehors des maj système, il n'y touche pas... Bon ,çà c'était aussi au début de l'emploi de autoremove, je ne sais pas si çà a évolué depuis, car j'utilise Kclean , qui fait parti des applications que je me dépêche d'installer sur chaque fraîche install .

Je suis entièrement d'accord avec ce qui est dit par youraty . Il y a des outils qu'il  ne vaut mieux pas utiliser pour faire ce nettoyage.

@+.  Babdu89  .

#6 Re : -1 »  Installer Ubuntu Mate 15.04 » Le 24/04/2015, à 09:18

Babdu89
Réponses : 46

Bonjour.
Le titre?
ubuntu 15.04

Le lien de téléchargement donné post#9 mène à télécharger  Ubuntu Mate 15.04 .

Svp, changer le titre.  Merci.

@+.   Babdu89  .

#7 Re : -1 »  Installer Ubuntu Mate 15.04 » Hier à 00:14

Babdu89
Réponses : 46

Bonjour.

Tamarou a écrit :

Cela m'a rappelé de vieux souvenirs. On dirait un mix entre gnome2 et unity, le tout repeint en vert.

Moi çà me fait plus penser à la 8.04 . Si je retrouve le fond d'écran et que je le change, je reviens vers mon Héron ...
Même nombre de colonnes; 3  dans les menus du tableau de bord. Et on n'est pas loin du même contenu.
Gnome panel 3 colonnes, alors que gnome2, à partir de la 10.10 c'était déjà 2 colonnes dans les menus, ce qui est devenu aujourd'hui Gnome-flash-back.

La 14.04 installé chez moi il y a peu, çà tourne fort bien. Faut que je retrouve le fond d'écran du Héron...

@+.  Babdu89  .

#8 Re : -1 »  Ubuntu version 15.04 » Hier à 00:23

Babdu89
Réponses : 6

Bonsoir.
Rappel aussi ; sur Ubuntu.fr.org, sont proposées les versions francisées des iso (c'est un gros travail que de faire ces iso) et un lien vers les versions officiels (internationales) .

@+.  Babdu89   .

#9 Re : -1 »  [Tuto] Réinstallation de Ubuntu 14.04.2 par la "méthode 1" » Hier à 14:26

Babdu89
Réponses : 12

Bonjour.
@ malbo.

......Un vrai repoussoir.

Oui, mais pour réinstaller la même version on est bien obligé d'y passer si on veut conserver nos paramètres et applications installées.

Pour la mise à niveau, vaut mieux faire la manip normalement, on conserve nos applications et paramètres, ou tout réinstaller avec la nouvelle version.

@+.   Babdu89   .

#10 Re : -1 »  MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2] » Le 20/04/2015, à 09:16

Babdu89
Réponses : 1084

Bonjour.

Me disant que je ne pouvais pas installer windows 7 32 bits sur une partition GPT.

Il y a de fortes chances que la machine démarre en mode UEFI. Si tu as installé Ubuntu en UEFI. On voit une partitionFAT32 /boot/efi
Si c'est la cas.
Windows7 en  32 bit ne pourra pas s'installer en mode UEFI. Il faut une version 64 bit UEFI.( si çà existe)

Rappel;  Soit on installer tous les Os en UEFI, soit en non UEFI (Bios_Legacy).
Les installations en "panachant" les deux modes est possible. Mais çà pose des soucis au démarrage.
Il faut revoir le paramétrage du démarrage de la machine, pour démarrer dans l'un ou l'autre mode, suivant l'Os que l'on veut lancer.

Si tu veux vraiment Windows7 . Qu'il n'y a pas de version 64 bit UEFI.
Il faut démarrer la machine en mode Bios_Legacy.
Supprimer Ubuntu 64 bit UEFI. Supprimer la partition /boot/efi (/dev/sda1). Installer Windows7 en premier ,en mode Bios_Legacy. Ensuite réinstaller Ubuntu 64 bit en mode Bios_Legacy.
On peut le faire sur le hdd partitionné en GPT . Ou refaire une table de partition de type MSDOS.
Si le hdd d'installation fait plus de 2,2 To. Il doit avoir une table de partitions GPT.

@+.   Babdu89  .

#11 Re : -1 »  rendre des logiciels windows compatible avec xububntu » Le 24/04/2015, à 23:14

Babdu89
Réponses : 11

Bonsoir.
Continuons dans la bonne humeur.
[hs]
C'est bizarre, mais je n'ai jamais vu quelqu'un poser la question dans l'autre sens.  yikes
Rendre des logiciels Linux compatibles avec Windows?...   tongue
Bon, on me dira de fréquenter les fora Windows, j'en verrait peut-être poser la question...
[/hs].

@.  Babdu89   .  smile

#12 Re : -1 »  Aide à l'installation (windows 8 UEFI) » Le 24/04/2015, à 17:47

Babdu89
Réponses : 8

Bonjour.
@ malbo.

malbo a écrit;
1) est-ce que c'est avec ce LiveCD Boot-Repair-Disk que tu as fait l'installation de Ubuntu ?

Dans le rapport boot info le noyau de Ubuntu est en v 3.16.0-30 .
Je fiche mon billet que BRD est encor en 3.13.0-xx ...Non? ;
On voit aussi;  Boot-Repair-Disk 64bit 29nov2014, ...  tongue

Pour le reste ... De L'UEFI, je me tais et je continue d'apprendre. wink

@+.   Babdu89  .

#13 Re : -1 »  Ouverture de session impossible [résolu] » Le 19/04/2015, à 09:03

Babdu89
Réponses : 8

Bonjour.

Suite à une vague de mise à jour sous 14.04, je reste bloqué sur l'écran d'accueil qui revient en boucle. Le mot de passe est correct.
La session invité ne se lance pas davantage (il n'y a pas d'autre profil créé)

Il n'y a pas de messages d'erreur au sujet du mot de passe?
Il n'y aurait pas changement de langue du clavier au démarrage de la session?.

@+.   Babdu89  .

#14 Re : -1 »  Ouverture de session impossible [résolu] » Le 24/04/2015, à 17:21

Babdu89
Réponses : 8

Bonjour.
Post#1 on peut lire.

Suite à une vague de mise à jour sous 14.04, je reste bloqué sur l'écran d'accueil qui revient en boucle. Le mot de passe est correct.

On peut en savoir plus sur cette  vague de mise à jour sous 14.04, ??.
Çà ne s'est pas bien passé?.
Vu la belle collection de versions de noyaux, il n'y en a pas un ancien qui démarre en recovery?.

Je ne parle pas de nettoyage dans les noyaux, ( du 2.6.32-25 au 3.0.13-49)  le rapport boot info indique qu'il y a encore de la place dans la partition système /sda7, occupation à 46%.

@+.    Babdu89  .

#15 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 19/04/2015, à 17:10

Babdu89
Réponses : 18

Ok pour la 10.10.  wink

Mais comme tu indiques que la machine démarre en non UEFI, je pense qu'il faut lancer les sessions live en non UEFI aussi.

@+.  Babdu89  .

#16 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 19/04/2015, à 17:25

Babdu89
Réponses : 18

Re...

Post#1 on lit;

J'ai acheté un nouveau portable (PClinuxFrance  pclfW510TU) et je veux installer Ubuntu 14.04.2 LTS Trusty à partir d'une image iso que j'ai téléchargé sur un disque dur externe.

Lorsque tu vas réussir à démarrer ta session live.. Tu vas certainement être confronté à ce souci.

https://doc.ubuntu-fr.org/tutoriel/grub … so_desktop

C'est ce qui m'arrive chaque foi lorsque je lance des iso depuis Grub, et que je cherche à les installer...

J'utilise aussi cette méthode; le script .bsh . Je n'ai pas encore testé l'autre écriture du script.

http://forum.ubuntu-fr.org/viewtopic.php?id=1236981

Mais çà ne marche pas pour tout type d'iso. Ubuntu et ses variantes, çà va bien.

Question, pourquoi ne pas utiliser de média live, DVD ou usb ?
Tu testes, ou c'est par obligation?.

@+.   Babdu89  .

#17 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 19/04/2015, à 21:34

Babdu89
Réponses : 18

Bonsoir.

Point 3 : en session live j'ai eu la curiosité de regarder comment les partions étaient montées : une seule partition interne montée (cela me paraît normal) montée sur /isofile (ou /isolive je ne sais plus trop), mais surprise ce n'est pas ma partition de boot, mais l'autre où il y a aussi l'image iso à la racine. Alors j'enlève l'image iso de ma partition de boot et je réessaye : message qui dit qu'il ne trouve pas l'iso ! Tout se passe comme si il commençait avec l'iso de la partition de boot, mais que plus tard les disques ayant changé de nom il montait l'autre partition (en effet dans Gparted le disque SSD qui contient la partition de boot est référencé sdb, l'autre disque interne (qui contient le /home) s'appelle sda, et le disque externe sdc. Et lorsque l'on démarre avec Grub il ne connaît qu'un disque hd0, celui qui contient le chargeur Grub dans son MBR, et sur lequel il trouve l'iso !

Çà ne serait pas sur isodevice ? ce dont je parle dans mon post.
Si c'est le cas il faut la démonter en commande, avant de lancer l'installation ;

sudo umount -lfd /isodevice

Pour la recherche de la partition qui contient l'iso à lancer en session live.
Au lieu de passer par (hd*,*) ,il me semble que l'on peut utiliser la recherche en utilisant l'UUID de la partition. Grub sait faire.
Mais je ne sais comment rédiger la commande.

@+.   Babdu89   .

#18 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 19/04/2015, à 22:41

Babdu89
Réponses : 18

Alors la recherche de la partition de stockage avec son UUID.
Je viens de tester ceci chez moi.
Branchement d'un hdd usb.
Une partition ext4 vide.
J'y place une copie de l'iso ubuntu-14.04.2-desktop-amd64.iso  dedans.
Un

sudo blkid

Me liste hdd et partitions.
La partition du hdd usb de stockage est  /dev/sde9
Son UUID  bbdbd261-4eb0-423d-890d-1c24dc1d9343

Bon comme je bidouille sans trop être sur du résulat, mais je sais que dans le fichier grub.cfg les partitions sont recherchées par leur UUID.
Dans le  fichier grub.cfg de l'Os qui lance ma machine pour le moment, je teste ceci.
Dans la rubrique
### BEGIN /etc/grub.d/40_custom ###
### END /etc/grub.d/40_custom ###

Je copie ce que tu as mis dans ton fichier grub.cfg dans cette même rubrique.
En adaptant pour que la partition soit recherchée avec son UUID.
C'est ce qui est écrit dans le fichier grub.cf

Çà donne çà.

#Ce qui sert à modifier l'entrée; iso ubuntu-14.04.2-desktop-amd64.iso stockée sur hdd usb en /dev/sde9 (hd4,msdos9) (hd4,9)  UUID bbdbd261-4eb0-423d-890d-1c24dc1d9343
menuentry "Iso Live ubuntu-14.04.2-desktop-amd64.iso test encours" {
	insmod loopback
	insmod iso9660
	set isofile="/ubuntu-14.04.2-desktop-amd64.iso"
	#recherche de la partition dans laquelle se trouve le fichier ISO et montage de celle ci dans "/"
	#search -sf $isofile
	#Montage du fichier ISO dans (loop)/
        set root='(hd4,msdos9)'
	search --no-floppy --fs-uuid --set=root bbdbd261-4eb0-423d-890d-1c24dc1d9343
	loopback loop (hd4,9)/$isofile
	echo	'Chargement du noyau Linux ...'
	linux (loop)/casper/vmlinuz.efi locale=fr_FR bootkbd=fr console-setup/layoutcode=fr iso-scan/filename=$isofile boot=casper file=/cdrom/preseed/ubuntu.seed noprompt quiet splash --
	echo	'Chargement du disque mémoire initial ...'
	initrd (loop)/casper/initrd.lz
}

Les modifs

        set root='(hd4,msdos9)'
	search --no-floppy --fs-uuid --set=root bbdbd261-4eb0-423d-890d-1c24dc1d9343
	loopback loop (hd4,9)/$isofile

Je ne sais pas si c'est "propre" ? ...

Je ferme tout, je relance la machine, j'ai ma nouvelle entrée dans le menu Grub.
Je lance la session live. Il faut attendre que le système retrouve ses petits... Elle démarre, je te répond depuis cette session live.

Donc j'ai réussi à lancer l'iso stockée sur mon hdd usb.

On va voir pour le montage en /isodevice...
C'est la première partition du hdd usb qui y est montée. J'aurais pensé que ce serait celle qui contient l'iso, mais non.
La partition qui contient l'iso lancée en session live, est montée dans /media/ubuntu

À l'occasion je testerais une installation pour voir.
Edit.
Après avoir démonter /isodevice. Installation faite sur un de mes hdd interne.

Si çà peut aider.

En tout cas, moi, çà va m'aider à tester le lancement de certaines iso qui ne se lancent pas avec le script de Arbiel. Dès fois, on ne sait jamais.

@+.  Babdu89 .

#19 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 20/04/2015, à 11:51

Babdu89
Réponses : 18

Bonjour.
Étonnant qu'il ne trouve pas la partition où est stockée l'iso sur le hdd usb, en passant par l'UUID de cette partition, comme je l'ai fait chez moi.
Normalement il devrait la trouver. Sauf si le Bios ne voit pas le hdd usb lorsqu'il est branché...

Dans l'entrée que tu indiques ci-dessus, si l'iso est stockée dans la racine de ton Ubuntu. Ce n'est pas celle-ci qu'il lancerait par hasard?
Et pas celle contenue dans le hdd usb.

@+.   Babdu89  .

#20 Re : -1 »  [Résolu] Installation à partir d'une image iso sur disque dur externe » Le 22/04/2015, à 16:37

Babdu89
Réponses : 18

Bonjour.

Hdd usb débrancher, que donne;

lsusb

Tu branches le hdd usb, tu attends un peu, et encore;

lsusb

On va bien voir si çà confirme qu'il est vu, ou pas dans le système.

@+.   Babdu89  .

#21 Re : -1 »  [Résolu] Personnalisation de menu.lst » Le 21/04/2015, à 00:46

Babdu89
Réponses : 21

Bonsoir.

Tu aurais un lien ou un tutoriel pour m'expliquer comment écrire les "menuentry" dans grub.cfg et comment le rendre le choix de la résolution automatique ?

Alors, avec le fichier  grub.cfg, on passe de Grub Legacy, qui utilise le menu.list ,à Grub2 (PC) qui lui utilise le fichier  grub.cfg

Post#9 tu dis;

Si non, aurait-il un logiciel capable de créer les fichiers pour faire une USB Multiboot avec Linux/Windows/Ultimate Boot CD ?

C'est pour çà que je t'ai renvoyé au MultiSystem. Il le fait bien.
Mais bon si çà ne te plaît pas...

Utiliser Grub.cfg pour lancer des iso , Ok. Mais tu ne lanceras que des iso linux.  Un Windows installé (pas en live pour installer).
Pas Windows depuis l'usb pour installation, UBCD, je ne sais pas comment il est lancé.

@+.  Babdu89  .

#22 Re : -1 »  [Résolu] Personnalisation de menu.lst » Le 21/04/2015, à 13:56

Babdu89
Réponses : 21

Bonjour.
Oui, j'ai mal spécifié.
Oui grub2 sait lancé un Windows installé en dual boot sur un hdd... Un Windows installé.
Os-prober trouve les systèmes d'exploitations installés sur la config, et les porte au menu Grub en les incluant dans le fichier grub.cfg de l'Os Linux qui lance la machine. Là on parle bien de systèmes installés.

Toi tu cherches à faire une clé live avec Grub2 qui lancerait les iso Linux, et Windows, et autres. Depuis le menu grub de la clé. (Ce que fait le MultiSystem)
Sur une clé live, les systèmes ne sont sont pas installé, comme avec une installation sur hdd. Les iso sont décompressées et lancées avec syslinux. (ou grub2 avec le MultiSystem).  Çà ne fonctionne pas pareil que des systèmes installés sur hdd, qui eux  sont lancé avec Grub d'un Linux installé...

Il faut bien saisir la différence entre système live et système installé.
Depuis un système live, tu peux installer le système sur un disque dur.
Depuis un système installé, tu ne peux pas le faire. Tu ne peux pas utiliser ton Windows installé, pour l'installé sur un autre hdd. Pour Linux c'est pareil.

Bien que l'on puisse utiliser Grub dans les deux cas, çà ne fonctionne pas de la même façon.
C'est pour cela que c'est assez "coton" d'utiliser Grub avec un système live, d'autant plus multi iso.
Ce que fait très bien le MultiSystem. Il faut l'utiliser, lire sa doc, voir et comprendre comment il fonctionne, et demander à son auteur  frafa via le forum, des explications plus techniques, que ce que l'on pourra te donner ici ...

Je l'utilise sur Lés usb MultiSystem et sur un hdd usb dont la première partition est au format FAT32, où j'ai installé un MultiSystem.
Sur ce même hdd usb, d'autre installation d'Os Linux y sont, et j'ai modifié le menu Grub du MultiSystem (grub.cfg), pour avoir accès au menu Grub d'un des Os Linux, qui me permet de "chaîner"  le démarrage vers tous les Linux installés sur ce hdd, depuis le MultiSystem. Sur cet Os Linux, j'ai installé le logiciel du MultiSystem. Ce qui me permet d'ajouter/retirer des iso de la partition FAT 32 du disque usb MultiSystem. Ou de faire des clé usb MultiSystem
Donc sur ce hdd il y a.
Un système en live Multi iso (le MultiSystem)
Des Os Linux, que je peux démarrer en chaînant à partir du menu Grub du MultiSystem. Puisque ce hdd démarre par défaut en session live MultiSystem.

Tu dois te demander si j'ai des "actions" dans le MultiSystem? ...
Non , c'est simplement un outil merveilleux, lorsque l'on a compris comment il fonctionne et les possibilités qu'il offre, qu'a créé son auteur frafa. Merci à lui. 

Pour faire ce que tu veux faire, je ne connais pas d'autre solution. Soit à réinventer la roue.

@+.   Babdu89  .

#23 Re : -1 »  [Résolu] Personnalisation de menu.lst » Le 22/04/2015, à 17:16

Babdu89
Réponses : 21

Bonjour.

PS: Venant d'arriver sur Linux, aurais tu des conseils à me donner ? Des endroits où je pourrais en apprendre sur Linux ? Merci à toi!

Serais-tu comment (avec quelle commande) passer Grub4dos en français et avoir le clavier en AZERTY ainsi qu'avoir les accents, si possible ?

Tu lis la doc de Ubuntu-fr.org . C'est déjà une mine de renseignements. Dans ce que tu liras, il y aura des liens qui revoient à des docs qui apportent plus de précisions sur ce que tu lis. Mais pour les néophytes que nous sommes, çà devient vite coriace.
Tu fouilles dans le Forum, à la recherche de sujets qui traitent de ce qui t’intéresse. Google (ou un autre moteur de recherche) aussi apporte des réponses à nos questions, (pas toujours, mais il faut essayer).

Mettre grub4Dos en français je ne sais pas si c'est possible, je ne pense pas.

Google (ou un autre moteur de recherche) aussi apporte des réponses à nos questions, (pas toujours, mais il faut essayer). J'ai tenté sans succès.

La langue employée en informatique (programmation, développement, ligne de commandes &&&) c'est l'Anglais. Ce qui bloque bien des personnes qui ne pratiquent pas ou très peu. C'est mon cas...

Le clavier en azerty, je n'ai jamais pensé à regardé comme il est lorsque je lance mes clés de tests avec grub4Dos . Je pense qu'il est en anglais.
Je n'utilise pas de corrections dans les menus, puisque je les écris et modifie depuis une session Linux installée avec clavier en azerty.
Je navigue dans les menus de grub4Dos avec les flèches haut, bas et "Entrée" ... Je pense que peu importe la langue du clavier pour cette utilisation .

Par contre pour des modif dans les menus grub2, pour,  par exemple passer des options de démarrage au noyau. Il faut corriger en éditant et ajoutant des mots, et là le clavier anglais me pose des soucis. Mais bon je "bidouille" et je trouve...

Pour les accents rien de mieux à proposer que ce qui est au post#2 ...

Ah au fait !!! . Je ne pense pas que grub4Dos soit capable de lancer des sessions live d'Os 64 bit en UEFI. Je ne pense pas qu'il le prenne en charge.
Et c'est pourtant l'avenir de nos machines. Le Bios est appeler laisser sa place à l'UEFI.
Les Os à être de plus en plus installés en mode UEFI.

@+.  Babdu89  .

#24 Re : -1 »  [Résolu] Personnalisation de menu.lst » Le 22/04/2015, à 18:25

Babdu89
Réponses : 21

Oui, c'est bien dommage. Mais je pense que les développeurs et la communauté sortiront un prochain Grub qui soit capable d'amorcer des sessions live en 64bits en UEFI smile

Il y a déjà un Grub-efi . C'est une version de grub2 qui prend en charge l'UEFI. C'est ce qui permet de faire les sessions live et  installations en UEFI actuellement.
Mais je ne crois pas que Grub4Dos saura faire çà .

@+.   Babdu89  . smile