Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 14

#0 -1 »  Création d'un démon (Keylogger avec Xinput) » Le 21/11/2014, à 12:17

Siedblack
Réponses : 4

Bonjour,
dans le cadre de mes cours de système d'exploitation, il m'a été demandé de créer un keylogger. J'aimerais que celui-ci se lance dès que l'ordinateur est allumé, donc de créer un démon. Je dois avouer que c'est la première fois que j'en crée un, et il ne semble pas opérationnel... Voici son code :

	

    #!/bin/bash
     
    source /etc/sysconfig/rc
    source $rc_functions
    case "$1" in
            start)
     
                    >/home/user0/mesLogs/8
                    >/home/user0/mesLogs/9
     
                    chmod 777 /home/user0/mesLogs/8
                    chmod 777 /home/user0/mesLogs/9
     
                    xinput test 8  >/home/user0/mesLogs/8&
                    xinput test 9  >/home/user0/mesLogs/9&
                    loadproc /usr/sbin/lescript
                    ;;
            stop)
                    echo "Stopping lescript..."
                    killproc /usr/sbin/lescript
                    ;;
            reload)
                    echo "Reloading lescript..."
                    killall -HUP lescript
                    ;;
            restart)
                    $0 stop
                    sleep 1
                    $0 start
                    ;;
            status)
                    statusproc /usr/sbin/lescript
                    ;;
            *)
                    echo "Usage: $0 {start|stop|reload|restart|status}"
                    exit 1
                    ;;
    esac

(Je me suis fortement inspiré d'un tuto, je mettrai le lien plus tard car je suis sur un vieux pc et le cherche me prendrait 15 minutes).
Ce que je cherche à faire : lancer xinput sur les périphériques 8 et 9 (il s'agit de la souris et du clavier), et enregistrer les données dans le fichier 8 et 9.
Ce qu'il se passe : les fichiers 8 et 9 sont créés, c'est tout... Pourtant, si je lance ces commandes dans un terminal tout roule. Pouriez-vous m'aider ?
Merci !

#1 Re : -1 »  Création d'un démon (Keylogger avec Xinput) » Le 25/11/2014, à 10:13

Siedblack
Réponses : 4

Bonjour,
après de multiples essais je n'ai toujours pas trouvé la solution .. hmm
Quelqu'un pourrait m'aiguiller ?
merci ^^'

#2 Re : -1 »  Création d'un démon (Keylogger avec Xinput) » Le 25/11/2014, à 11:23

Siedblack
Réponses : 4

Merci pour cette réponse smile
Malheureusement, ça crée bien le fichier mais ça ne veut pas le remplir ( alors que si j'execute la commande "à la main", le fichier se rempli ..) Je ne comprends pas trop pourquoi ;s

#3 -1 »  Distribution pour montrer que le PC tourne en BIOS ou en UEFI » Le 30/09/2014, à 16:06

Siedblack
Réponses : 9

Bonjour,
pour les cours nous avons des projets à faire, et j'ai décidé de choisir comme sujet "EFI" . Etant donné que le prof ne connait pas dutout, le sujet est doublement interessant, sauf que du coup je ne sais pas à qui poser mes questions avant de faire des manipulations ( la dernière fois j'ai supprimé la partition system UEFI justement... T.T heureusement celle-ci a été recrée lors de la réinstallation d'ubuntu ( corrigez moi si je me trompe, en tout cas avant d'avoir installé ubuntu UEFI ne fonctionnait plus ! ).
Comme matériel je duspose d'un HP possédant le mode EFI et Legacy.
Ce que j'aimerais faire : prouver que lorsque je démarre en mode Legacy je boot bien avec le Bios, et vice-versa .
Le problème : le prof a écrit un kernel qu'on a utilisé l'an dernier, selon-lui le faire booter sur le PC HP prouverait que le mode Bios fonctionne. J'ai donc mis ce fameux Kernel qui fonctionne sur les autres pc (plus anciens et ne disposants pas de UEFI), mais qui ne semble pas fonctionner sur le fameux HP que je met en mode legacy   T.T  . Bref je ne sais pas trop où donner de la tête pour résoudre ceci ...

Pour être certain de ne pas faire fausse piste :
Lorsque je démarre le PC, celui-ci lance un firmware qui choisit s'il boot via le BIOS ou via l'UEFI, est-ce correct ?
2124994cf28c0779694fbaaa1b46c56b426d04medium.jpg

Sinon, j'aurais encore un ou deux sujets à présenter cette année et je n'ai pas trop d'idée, si quelqu'un a une idée de sujet sympa et interessant (et se rapportant au monde de Linux, bien que ca ne soit pas obligatoire) merci de bien vouloir m'en parler en MP big_smile

Merci d'avance smile

#4 Re : -1 »  Distribution pour montrer que le PC tourne en BIOS ou en UEFI » Le 02/10/2014, à 21:40

Siedblack
Réponses : 9

Bonjour ,
merci pour vos réponses smile
finalement j'ai montré que j'étais en bios en installant un linux non compatible EFI smile
Par contre, et pour des raisons que nous ignorons en mode bios il nous est impossible d'utiliser un USB en mode BOOT, ça ne semble fonctionner qu'en EFI O.o

#5 -1 »  Netbeans 7.0.1 bug "done loading modules" » Le 13/11/2013, à 20:10

Siedblack
Réponses : 0

Bonjour,
je vous contacte car j'ai un petit souci avec Netbeans...
Je l'ai installé tout à l'heure, et il n'a jamais voulu se lancer. Il reste coincé au chargement à "done loading modules".
j'ai croisé quelques internautes (sur google) ayants eu le même problème que moi, mais je n'ai jamais trouvé de réponse adéquate (d'où ce post).
Pourriez-vous m'aider ?
Merci smile

#6 -1 »  Installer KDBG : BUG GDB ( READING ...) [RÉSOLU] » Le 07/02/2013, à 13:01

Siedblack
Réponses : 3

Bonjour,
pour l'école j'ai ABSOLUMENT besoin de KDBG,seulement celui-ci ne veut pas fonctionner correctement...Visibilement il s'agirait d'un bug de la part de KDBG ou du déboguer qu'il utilise: GDB.
Pour utiliser KDBG j'utilise le tutoriel fournit par l'école,qui fonctionne sur les pc de l'école,et qui est sensé fonctionner sur mon pc (ça fonctionne sur les pc des autres):
nasm MonProg.asm -o MonProg.o -f elf -g -F dwarf
ld MonProg.o -o MonProg -m elf_i386 -e main
./MonProg
kdbg MonProg
C'est lorsque je fais "kdbg MonProg" que ça ne fonctionne plus,ça affiche comme sur le screenshot (GDB:Reading symbols from.......done). J'ai cherché un peu partout sur internet et je n'ai pas trouvé de solution ... Pourriez vous m'aider? Voici les screen:
http://www.servimg.com/image_preview.php?i=1&u=18100473
http://www.servimg.com/image_preview.php?i=2&u=18100473
Ce qui m'inquiete c'est que GDB ne m'indique pas d'erreur lorsque je le fais tourner tout seul,mais c'est au moment où j'utilise KDBG qu'il y a une erreur ... Je ne sais pas si ça peut aider,mais j'utilise Ubuntu 12.10 64bits. En essayant avec Nemive(une alternative à KDBG) je n'ai pas de problème,seulement il n'affiche les valeurs des registres qu'en hexadecimal ,et ça j'en ai vraiment besoin.
Le code source de "mon programme" est le suiviant :

global main

section .text
main:
    mov al, 10011101b               
    not al             

    mov al, 11100101b
    mov ah, 00101010b
    and al, ah          

    mov al, 11100101b
    mov ah, 00001010b
    and al, ah         

    mov al, 01100101b
    mov ah, 01010101b
    or  al, ah          

    mov al, 11100101b
    mov ah, 01010101b
    or  al, ah         

    mov dx, 1100010011100101b
    mov si, 0011000001100010b
    xor dx, si         
                      

    mov al, 11100101b
    mov ah, 11100101b
    xor al, ah         

    
    mov eax, 1
    mov ebx, 0
    int 0x80 

Normalement il est bon,car il est fournit par les profs,et je n'y ai pas touché smile

Merci beaucoup de bien vouloir m'aider !
ps: je possède KDBG en version 2.5.1 ,c'est la version dispo dans les dépots,je sais qu'il existe une version 2.5.2 mais je n'arrive pas à l'installer. Pourtant je fais toutes les commandes nécessaires...

#7 Re : -1 »  Installer KDBG : BUG GDB ( READING ...) [RÉSOLU] » Le 08/02/2013, à 12:27

Siedblack
Réponses : 3

SUPER GENIAL CA FONCTIONNE !!!!! Merci beaucoup big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile big_smile

#8 -1 »  Lecture de contenu impossible ( vidéos,jeux...) » Le 12/01/2011, à 15:22

Siedblack
Réponses : 3

Bonjour à vous !
Après avoir installé Flash Player j'ai eu accès aux vidéos de youtube.
Seulement,j'ai remarqué que je n'avais pas accès aux autres type de contenu flash ( tel que les jeux flash,ou encore les vidéos de dailymotion).
Pouvez-vous m'expliquer ce que je dois faire pour avoir accès à ce contenu? Merci d'avance

#9 Re : -1 »  Lecture de contenu impossible ( vidéos,jeux...) » Le 13/01/2011, à 17:57

Siedblack
Réponses : 3

Bonsoir,
je viens de tester,et ça ne fonctionne toujours pas :s

#10 -1 »  Droits et accès manquants ! » Le 08/01/2011, à 22:12

Siedblack
Réponses : 3

Bonjour à vous,
j'aimerais me crée un serveur teeworlds,mais c'est impossible,car lorsque je transfère le fichier .CFG ,mon ordinateur m'anonce qu'il m'est intérdit de le transfrerer ! Dans les droits,je vois que root peut le faire ... j'ai fais quelque recherche,mais j'avoue que je n'arrive pas à avoir les droits ...MErci de bien vouloir m'aider !

#11 Re : -1 »  Droits et accès manquants ! » Le 09/01/2011, à 11:56

Siedblack
Réponses : 3

Merci de votre réponse smile
J'ai écris votre commande,et maintenant dans mon konsole j'ai une sorte d'onglet <nom d'utilisateur>gksu   .
Ensuite,j'ai essayé de mettre mon fichier dans le dossier teeworlds,et je ne peux toujours pas (accès refusé à...)
Pouvez vous m'expliquer ? :s

#12 -1 »  Plasmoïde de son + Problème internet » Le 26/09/2010, à 16:02

Siedblack
Réponses : 4

Bonjour à vous smile
Etant nouveau sous Kubuntu ( de moins de 2 heures),j'ai déjà fait la boulette de supprimer le tableau de bord de base,... J'en ai donc "renconstituer" un,mais il me manque le plasmoïde qui me permettait de rêgler le son ( Avec lui,le son sur internet fonctionnait !) . Pouvez vous m'indiquer où je pourrais le trouver?
Aussi,j'aimerais utiliser les boutons latéraux de ma souris ( gauche et droite) pour afficher la page d'avant,et d'après ( comme sous windows), je ne trouve pas où la configurer,.. pouvez vous m'aider ? sad merci ! smile

#13 Re : -1 »  Plasmoïde de son + Problème internet » Le 26/09/2010, à 18:27

Siedblack
Réponses : 4

J'ai une simple intllimouse Optical 1.1A USB de MIcrosoft sad
Et merci beaucoup,le problème est résolu grâce à Kmix !:)
Seulement,j'ai remarqué que le son va moin fort que sous windows,j'ai vu qu'il y avait peut être moyen de rêgler ça via des commandes à éxecuter,mais je ne m'en sors pas,.. sad