Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  [Boot-Repair] Réparer le démarrage du PC (GRUB, MBR) en 1 clic ! » Le 22/02/2012, à 19:52

utinoris
Réponses : 1282

Bonjour à tous.

J'ai un petit problème et je n'arrive pas à m'en sortir tout seul. C'est un peu devenu incompréhensible.
Alors tout d'abord j'avais plein de système tout marchait bien.

J'ai fait le ménage dans mes partitions, et j'ai réinstaller grub.
Résultat : Ma partition ubuntu préféré n'est plus dans le menu du Grub.
Je ne peux donc pas la démarré.

J'ai essayé tout les boots possible, avec un dossier séparé, avec  un installe de grub, une purge etc...

J'ai donc refait une partition avec ubuntu avec l'installe du boot dans la partition.
Celui est donc mon menu grub actuel il me propose mon windows et ce ubuntu. Mais celui que je veux récupérer est toujours absent.

Néanmoins os-prober détecte bien un ubuntu sur sda6 (la part concernée)
et un update-grub trouve aussi ce ubuntu mais toujours pas de possibilité de boot.

Grosso modo chez moi c'est
sda1 windows (un loader de 7 ou je sais pas trop) (le boot flag se trouve ici)
sda2 windows 7 (le vrai)
sda3 Recovery Windows
sda5 swap
sda6 Mon ubuntu à récupérer
sda7 des données
sda8 une ancienne partition ou je voulais mettre mon boot
sda9 le nouveau ubuntu qui devrait contenir le boot/ et grub


Bref, je pense que le "système" ubuntu est encore la puisqu'il est détecté mais j'ai pu faire n'importe quoi avec boot-repair ou un bug ou un erreur.

Fin bref si quelqu'un peut m'aider. Je ne vois aucune solution à mon problème en parcourant divers forum. merci d'avance.

#2 Re : -1 »  [nVidia Optimus] État des lieux » Le 05/09/2011, à 17:17

utinoris
Réponses : 201

Bonjour,

Alors, tout d'abord, la commande n'est plus optirunXX mais optirun tout cours.

De plus, tu verras toujours dans ton lspci la carte Nvidia, c'est normal, même sans bumblebee.
Essaie d'aller lire ceci ici
Il y a l'ensemble des procédures à suivre pour correctement installer bumblebee project.

a+


NB : depuis dimanche 4/09, la version 2.3.2 est sur le github

#3 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 25/08/2011, à 19:26

utinoris
Réponses : 2641

Edit :  Ouai j'ai vu et ca MARCHE


Ok c'est bon avec la 2.3.1 et la manip manuelle  DFP->CRT dans xorg.conf.nvidia

Lancement avec glxspheres Ok
Carte apriori bien pris en charge.

Bravo à l'équipe de devs, anciens et nouveaux.

Dispo pour lancer des tests sur distrib spéciales etc... si il le faut.


Pour info, le PC est un modèle Toshiba A660   ( A660-1F5) , mais beaucoup doivent lui ressembler en terme de config et embarquant la GT330M.

Vivement un module de désactivation de la carte qui va bien.

#4 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 28/09/2011, à 16:54

utinoris
Réponses : 2641

Salut Archange.

je voudrais essayer d'optimiser ubuntu en terme de consommation electrique.

Donc du coup essayer les scripts de cardon et cardoff.
Néanmoins je sais pas trop lesquelles choisir j'ai un toshiba A660.
Il n'est pas dans la liste du wiki.

Est ce que je peux te mailer les résultats d'acpidump que vous souhaitez, est ce que je peux me renseigner ailleurs etc...

Tout conseils sont bon à prendre, en fait je souhaiterais couper la carte nvidia tout le temps, quitte à l'activer " a la main" au besoin. donc a priori la couper complètement au démarrage de linux. Si tu as une autre solution, je suis aussi preneur.


Lucas

#5 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 04/10/2011, à 13:35

utinoris
Réponses : 2641

@Archange :
J'ai envoyé l'archive à hybridgraphic.

A savoir lors de la première application du power management : Les ventilos se sont mis à tourner à fond immédiatemment après le restart du daemon.
J'ai donc désactiver le power management.
Restart le daemon.
Réactiver le power management.
Restart le daemon.
Le ventilo s'est calmé tout de suite.
En quelques minutes :
Baisse de la température ( environ 15°c sur les processeurs et 5°c au niveau du disque)
Baisse de la consommation entre 7/10 Watts

La consommation de la machine est passé à ~13W et donc une autonomie >3h30 sur un 16".

Autant dire que ca marche nikel!

Un petit bémol, le retour de veille sur batterie est toujours un peu long avec ubuntu (1 min voir plus avant qu'il affiche l'invite de mot de passe, je ne sais pas ce qui provoque cela)
Et lors du retour au bureau tout à rechauffer, j'ai restart le daemon et tout est re-rentré dans l'ordre.

Nice Work Archange et tout les autres.

Est ce que tu veux que j'édite le wiki pour rajouter ma machine et les appels acpi. ?

Uti


Edit :  Je me suis plongé un peu plus sur la mise en veille. Alors en fait, le problème survient uniquement suite à une mise en veille automatique du système (inactivité)
Aucun problème lorsque la mise en veille à été faite manuellement. J'en déduis que c'est donc lier au démarrage un peu long dans ce cas précis. Je vais creuser du coté des drivers Nvidia et X. J'ai entendu des problèmes similaires

#6 Re : -1 »  [RESOLU] Wifi lent ou pas de wifi du tout Realtek RTL8188CE » Le 03/08/2012, à 17:28

utinoris
Réponses : 14

Salut ZeMSt4

Alors en fait le pilote des noyaux 3.x linux galère un peu avec cette carte. Mais heureusement Realtek semble faire le job.

1) télécharge le pilote
Va sur le site de realtek.com, http://www.realtek.com.tw/downloads/
Fait une recherche pour le RTL8188CE.
Dans la catégorie Unix prend le pilote qui correspond à ta version de noyaux >3.X a priori.
Choisit un serveur et tu download le .tar

C'est normal que ce soit le 8192 c'est le même chipset.

2) "dezipper" et aller dans le dossier
Il faut détarer le fichier soit dans nautilus en cliquant extract here
soit
$ tar -xvf  /Downloads/Rtl92_machin.tar

Rends toi dans le dossier
$ cd /Downloads/rtl_92...

3) Installe le nouveau pilote et redémarre (cf Readme)
$ sudo su 
$ make
$ make install
$ reboot


Tiens moi au courant normalement ca devrait régler les problèmes d'instabilité.


Uti

#7 Re : -1 »  problème de démarrage ubuntu10.04 terminal intitulé(initramfs)[RESOLU] » Le 03/08/2012, à 18:32

utinoris
Réponses : 31

Ah priori aucun problème de disque dur ici,

le mien est toujours la alors que je l'utilise intensivement.
Et toujours scanné sain.

Uti

#8 -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 22/02/2012, à 20:22

utinoris
Réponses : 27

Bonjour, donc je fork mon problème ici.

Ancien message :

Bonjour à tous.

J'ai un petit problème et je n'arrive pas à m'en sortir tout seul. C'est un peu devenu incompréhensible.
Alors tout d'abord j'avais plein de système tout marchait bien.

J'ai fait le ménage dans mes partitions, et j'ai réinstaller grub.
Résultat : Ma partition ubuntu préféré n'est plus dans le menu du Grub.
Je ne peux donc pas la démarré.

J'ai essayé tout les boots possible, avec un dossier séparé, avec  un installe de grub, une purge etc...

J'ai donc refait une partition avec ubuntu avec l'installe du boot dans la partition.
Celui est donc mon menu grub actuel il me propose mon windows et ce ubuntu. Mais celui que je veux récupérer est toujours absent.

Néanmoins os-prober détecte bien un ubuntu sur sda6 (la part concernée)
et un update-grub trouve aussi ce ubuntu mais toujours pas de possibilité de boot.

Grosso modo chez moi c'est
sda1 windows (un loader de 7 ou je sais pas trop) (le boot flag se trouve ici)
sda2 windows 7 (le vrai)
sda3 Recovery Windows
sda5 swap
sda6 Mon ubuntu à récupérer
sda7 des données
sda8 une ancienne partition ou je voulais mettre mon boot
sda9 le nouveau ubuntu qui devrait contenir le boot/ et grub

Bref, je pense que le "système" ubuntu est encore la puisqu'il est détecté mais j'ai pu faire n'importe quoi avec boot-repair ou un bug ou un erreur.

Fin bref si quelqu'un peut m'aider. Je ne vois aucune solution à mon problème en parcourant divers forum. merci d'avance.



Pour compléter ma demande
Voici mes info Boot : http://paste.ubuntu.com/853022/

Merci d'avance.

#9 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 22/02/2012, à 21:49

utinoris
Réponses : 27

Alors

pour le MBR -> Ouai pas de pb. (Mais j'avais compris que le grub mbr lancait ensuite un autre grub (grub2?) dans le dossier /boot/
De toute facon j'ai bien mon menu, je l'ai installé et supprimé plusieurs fois. Effectivement, je ne pense pas que le problème viennent de la.


Le contenu de /etc/default/grub de la partition 9 :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Question : Est-il important sur les autre partitions? Ce fichier permet de configurer le menu.lst il me semble justement.

Il est lancé par grub?
ou bien
Est-il utilisé typiquement dans un "update-grub" pour placer la config de grub dans le dossier Boot/ ?
(En fait je voudrais avoir une partition boot/ qui lance mon ubuntu mon archlinux, mon windows mon backtrack en fonction de mes utilités. et que je puisse virer les autres partitions à souhait sans réinstaller grub à chaque fois)


Pour l'utilisation que j'ai faite de boot-repair:
J'ai surtout utilisé l'option ré-installer grub. Car l'option OS par défault n'était pas disponible.
J'ai essayer en séparant le boot, puis sans etc...
La finalement J'ai un boot ubuntu neuf sans avoir ré-utiliser boot-repair.

Tiens en attendant je vais tenté un repair par défault. Si c'est mal, je pourrais ré-installer ubuntu. Pas de souci.

@YannUbuntu :
Je pense que tu devrais repasser par la.
Bravo, super boulot.
Si je peux me permettre, j'ai l'impression que Boot-repair essait de bidouiller ma partition caché de recovery windows (avec le flag hidden), il demande notamment de faire de la place sur la partition car elle est occupé à plus de 95%. (Trés dangereux pour un néophyte) Et finalement ne pourrait elle par remplir cette partition de log. Il faudrait mieux essayer de détecter le flag et ne pas trop y touché je pense à celle-ci.
Edit : d'ailleurs je confirme la présence du /clean/ Il fait déja 4MB chez moi.

#10 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 22/02/2012, à 21:59

utinoris
Réponses : 27

Fait notable, important, je ne sais pas.

Lors du lancement de boot-repair j'ai toujours un pop-up me disant que le boot est en EFI mais qu'il n'y a pas de partition EFI. Donc...

Je sais pas pourquoi c'est ce mode mais je n'ai pas touché au bios a priori.


Edit :
J'ai donc fait le repair standard avec B-R mais pas d'effet.

(Pendant la réinstallation de grub, dans mon terminal) à l'étape ou il trouve mes systèmes
J'ai bien les "2" windows, les images de cette distribution ET mon ancien ubuntu qui est marqué comme found.

Puis toujours absent du menu grub

#11 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 22/02/2012, à 22:44

utinoris
Réponses : 27

Alors le fichier ne contient plus ca mais maintenant (Il y a eu un repair par défaut entre temps)

/etc/fstab sur sda6 (la partition qui ne marche plus).

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda9 during installation
UUID=5abb9eb3-501d-446b-bbe5-6c1f5c03df30 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=28834ecc-9230-43e1-a55c-f27cb5a45984 none            swap    sw              0       0

@Abriel -> Non pas du tout aucune modifications barbare à la main. Par contre j'ai fais des modifs de partitions avec gparted. (et il notamment eu un ré-numérotation des sdaX après la suppression d'une partition)

Que faire? J'essaie de regarder si j'arrive à quelque chose avec les UUID
Merci

#12 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 22/02/2012, à 23:35

utinoris
Réponses : 27

dsl je suis sur un qwerty

Yann-> http://paste.ubuntu.com/853262/ Voila jai enleve une partition et fait une reparation

De plus jai essaye de suivre la procedure de ton lien mais je n ai pas l option BS.
Je peux supprimer le dossier boot si il faut.

#13 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 01:03

utinoris
Réponses : 27

Yann -> Alors j ai fait le repair demande
Voici l url
http://paste.ubuntu.com/853360/


Abriel -> Je suis d accord pour les degats.

En fait avant j avais un grub sur ma partition archlinux. Je pense que j utilisais celui la sans le savoir.

#14 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 01:12

utinoris
Réponses : 27

Abriel ->

Je n'ai pas vraiment compris tu m'as perdu la.

Normalement, le MBR va lancer la partition voulu grace au logiciel grub.
Il y a un seul MBR par disque. et donc besoin d'un seul "grub" et nécessaire un seul (on peut pas en même un deuxième donc ? corrige moi si je me trompe)

Ensuite le dossier /boot
Tu dois en avoir un et un seul?
Ou bien un dans chaque partition (hormis windows pour chainloader)

Dans l'idée, je souhaiterais avoir un dossier boot séparé pour la totalité des distributions que j'utilise.
Et j'installe souvent des distribs et donc éviter de me prendre la tête avec grub tout les 6 mois.

#15 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 01:14

utinoris
Réponses : 27

Les noyaux sont contenu dans /boot ??
J'ai des vmlinux à la racine de sda6 ils sont pas la plutot?

#16 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 01:37

utinoris
Réponses : 27

Ce que j'ai dans quel sens?

Dans cette config la je souhaite juste redémarrer ce linux.
Mais bon si j'ai bien compris c'est pas gagné.

En fait j'ai pas vraiment compris ce que tu voulais me faire retrouver le initrd ok
Mais le noyau
Avant j'avais soit un 10.04  soit un 10.10
J'avais gardé le noyau 2.8. je crois. Mais bon ils sont relativement identiques.

#18 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 03:27

utinoris
Réponses : 27

@ Abriel
Alors j'ai édité le fichier /etc/grub.d/40_Custom et non init.d d'ailleurs (j'ai un peu galéré).
D'ailleurs ce fichier n'as qu'une ligne non commenté initialement mais je suppose que c'est normal.

Après j'ai reboot. Donc forcément ca marchait pas.
J'ai re édite le fichier puis fait le update, et la aucune modif.
Marche toujours pas (pas de lien Ubuntu préféré du tout)

Ensuite j'ai supprimé le dossier grub dans /boot/ pour voir dans sda8. Au grand maux les grands moyens.

A priori pas d'effet. Je commence à douter.


@Yann
Je teste ca et je t'envoi un MP sur le forum.

Est ce que j'ai un moyen de savoir si ma version est bien à jour avec le fix?? genre num ou autre
Je testerais dans 24h sinon.
D'ailleurs, hésite pas mettre un bouton Update si tu supprime la maj directe. (J'ai vu ca je sais plus ou)


Sinon comment pourrais-je réinstaller qu'un noyau
Grosso-modo Est ce que je peux retrouver un environnement comme avant ou pas.
J'ai pas mal de config bizarre et c'est surtout ca qui m'emmerde.

Sinon ouai je vais formater complétement la partition Etendu et réduire un peu la logique windows.
Et réinstaller un ubuntu tout neuf. Mais bon le dash, unity, tout ca.

#19 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 23/02/2012, à 19:15

utinoris
Réponses : 27

C'est normal que le paquet boot-sav-3.17-0ppa13 n'y soit plus dans la liste??
C'est le 14 maintenant en attente. Le 13 est implicitement validé?

#20 Re : -1 »  Noyau ubuntu disparu du grub suite à réinstall » Le 27/02/2012, à 02:18

utinoris
Réponses : 27

@ Yann
Je te confirme que j'ai plus la demande de reduction de place sur la partition "hidden" et que apparemment ca ne creer par de /clean/

@Arbiel
Je te remercie. Je vais essayer cette solution en bidouillant un peu.

#21 Re : -1 »  [Résolu] Dual screen sur un seul écran » Le 25/08/2011, à 20:12

utinoris
Réponses : 16

Je crois avoir compris ce que tu souhaites faire, c'est une solution que j'aime bien pour coder.

Je sais pas vraiment comment tu peux spliter le truc je le vois vraiment mal.
Tu peux déja bidouiller la config de gnome et de certain logiciels et ton terminal.
Par exemple moi à chaque ouverture de fenetre (sauf pour firefox), la fenêtre s'ouvre tantot à droite, puis à gauche pour la suivante, etc... en prenant exactement ma moitié de la place dispo et toute la hauteur de ton écran.

Après la je fais un passage sur gnome3, j'ai pas fait ça mais bon ca doit être bidouillable

#22 Re : -1 »  [Résolu] Dual screen sur un seul écran » Le 26/08/2011, à 02:47

utinoris
Réponses : 16

Ouai tout a fait.

Mais du coup dans ce cas la, si ça t'interresse, je te conseil d'installer archlinux sur une partition différente et d'installer sur celui-ci le gestionnaire de fenetre de ton choix.

Ca m'as permis par exemple pour ma part de tester gnome 3

#23 Re : -1 »  [Résolu] Dual screen sur un seul écran » Le 26/08/2011, à 17:41

utinoris
Réponses : 16

Je suis pas trop au courant pour Unity, mais j'aime pas trop l'interface, je la trouve moins rapide pour bosser.

Du coup en fait, la plupart du temps je boote en Ubuntu Classique pour ma part

#24 Re : -1 »  Nouvelle carte graphique, ATI ou Nvidia pour ne pas être embêté ? » Le 25/08/2011, à 19:53

utinoris
Réponses : 13

Salut à tous.

alors j'ai un laptop avec une carte nvidia datant d'une année environ je pense. A savoir la GT330M.

Tout d'abord, que le dual screen est parfaitement prise en charge, j'utilise souvent mon laptop avec un rétro ou un LCD.
J'utilise une config un peu spécial mais même avec le driver de base tout marche très bien, sans effets 3D, pour cela il faut une prise en charge complète de la carte nvidia -> le pilote proprio ou le libre pour toutes les cartes ou pour les optimus (moins gourmandes pour les plateformes mobiles) utilisé blumblebee

Pour info, sur beaucoup de nouvelle carte nvidia récente, la carte embarque la technologie optimus, surtout les cartes laptop GTXXXM
C'est vérifiable trés rapidement sur le site d'nvidia si vous avez le modèle.

Si tu veux c'est la séparation entre un petit calculateur et un vrai chipset dédié qui démarre si il faut (jeux, etc..)
Ca marche super sur windows, on gagne en chaleur à basse utilisation et en batterie.
A savoir mac a dévellopé sa propre prise en charge pour les cartes gt330m qu'il a embarqué sur certain macbookpro ( 1an )
Eux aussi annonce un gain de minutes précieuse.

A fortiori les trés récentes cartes ATI embarquent une technologie identique ressemblant à Optimus.

Le problème des linux, c'est le serveur X, il n'as pas du tout été concu (il y a trés longtemps, au fin fond d'une galaxie lointaine) pour changer à la volé de calculateur graphique. Donc, tant qu'il n'y aura pas de refonte complète la prise en charge native est exclu.


NEANMOINS, le travail autour de la prise en charge d'optimus sur les ubuntus notamment a pris une envolée incroyable.

Il est désormais possible de lancer un programme sur le calculateur nvidia.
Il devrait être possible, je l'espère le plus vite possible de couper la carte nvidia proprement pour l'arrèter complétement.

Par exemple je peux lancer Minecraft, Unreal Tournament etc  sur ma carte nvidia et rester sur le chipset pour tout le reste.

Il manque donc pour l'instant la possibilité de couper la carte au démarrage
Ou une prise en charge complète dés le départ du serveur X à moyen terme -> pourrait intéresser tout les fans d'effets 3D.

Apriori, moi aujourd'hui, sachant ce que je sais sur cette techno je reprendrais de l'optimus aujourd'hui. Mais je te rassure je ne disais pas la même chose il y a 8 mois! !

De plus, chez ATI cette techno émmerge, donc c'est a priori une techno trés intéressante, et elle commence à être gérer un petit peu pour les nvidia, pour les ATIs, on a pas vraiment de date.


Voila mon avis sur la question

Au fait le nom du soft qui permet de lancer la carte c'est bumblebee, allez faire un tour la bas : ici