Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 31/03/2015, à 17:07

philoup44
Réponses : 15

Suite à une installation manuelle en dual boot (Windows7/Linux 12.04), je ne peux plus lancer Windows
Le PC est un Asus K52F
Au démarrage, j'ai bien le choix, mais Windows ne se lance pas quand je le choisis
Normallement, j'ai bien indiqué la partition de Windows pour l'instal de GRUB
mais je voudrais etre certain que c'est le cas
Quelle commande me permettrait de savoir ou est placé GRUB (sur quelle partion) ??

NB
Avant l'installation de Linux, Windows faisait déja des siennes
Par exemple, la suppression de certains fichiers sur D: on eu pour effet de Vider le Bureau ... (il y avait peut etre des liens mais quand meme ...) ??
La raison pour laquelle on m'a demandé un dualboot avec Linux

#2 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 31/03/2015, à 22:00

philoup44
Réponses : 15
The default repair of the Boot-Repair utility would reinstall the grub2 of sda6 into the MBR of sda.

Si je comprends bien bootinfo, GRUB2 serait sur sd6 ??

Si c'est le cas, je pense savoir ce qui c'est passé
lors du choix de la taille de /, j'ai changé d'avis et choisi une autre taille à allouer
et l'option d'installer le grub sur sda c'est ré_initialisé pour remettre son choix par defaut

De l'autre coté, je ne comprends pas, si je dis pas de bétise,
Lors de l'installation, Linux installe un "grub partiel" dans le MBR qui pointe ensuite sur le bootloader de linux ( GRUB2 )
                                           lequel propose à son tour de lancer LINUX ou Windows
                                           l'installateur de Linux met un pointeur qui indique au bios ou se trouve le bootloader à lancer
                                          ( ici en l'occurence GRUB2 dans la partition sda6 qui est elle-meme dans la partition étendue sda2 )

Linux se lance bien, pas Windows , serait ce le bootloader de windows qui à un souci ??

#3 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 31/03/2015, à 22:38

philoup44
Réponses : 15

J'ai lu ces 3 liens
Doc.ubuntu-fr.org/grub-pc

Doc.ubuntu-fr.org - Comment restaurer grub

Doc.ubuntu-fr.org - boot-repair

Je suis "peut-etre" bon pour

1) Installer Boot-Repair depuis une session live (DVD ou liveUSB) de Ubuntu
2) puis lancer Boot-Repair

ici, vous me conseillez quelle option ??

Réparation recommandée
ou
Optins avancées ---> réinstaller grub
                                  placer grub dans ---> sda

#4 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 11:32

philoup44
Réponses : 15

Salut malbo

Dans le #1, je me suis mal exprimé, je voulais dire ---> installation du chargeur d'amorçage sur dev/sda

Pour le
2) Réparer le secteur de Boot de sda1 :
Pour créer un CD de réparation Win7, je peux le faire comme indiqué dans ton lien sur un autre ordi équipé de Win7 et qui soit compatible avec n'importe quel PC ??

#5 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 12:21

philoup44
Réponses : 15

Grand merci malbo !!

J'ai suivi le tuto de YannUbuntu

L'étape
5) puis [Proceed]
n'était pas présente mais la suite oui

Sur ce, j'ai refait un

sudo grub-install /dev/sda 

re-démarrage, puis j'ai lancé Win7 qui m'a proposé une réparation, je lui est dis OK
et j'ai finalement retrouvé le Win7 malade,( il ne retrouve pas son bureau , et à "perdu" des docs etc ...c'était le cas avant l'install de Linux )


Sinon, comment Vérifier sur quelle partition Grub est installé ?? (sans passer par bootinfo)

#6 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 12:43

philoup44
Réponses : 15

La commande que tu me propose

sudo debconf-show grub-pc

C'est celle qui permet de connaitre l'emplacement du GRUB ??

Si oui, ce qui m'intérresse c'est à quel endroit regarder pour trouver la bonne info
je dis ça , vu que tu précise "Je ferai le tri" ce qui me laisse à penser qu'il y aura pas mal de lignes d'infos qui s'afficheront ...

Mais , suite à la procédure suivie du #8, j'ai maintenant accès à Windows
Je ne sais pas si cela est utile que tu passes du temps à faire du tri ....

Mais comme tu dis

Tu me laisse à penser que la résolution est temporaire

#7 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 12:57

philoup44
Réponses : 15
sudo debconf-show grub-pc
[sudo] password for domi: 
  grub-pc/kopt_extracted: false
  grub2/kfreebsd_cmdline:
  grub2/device_map_regenerated:
* grub-pc/install_devices: /dev/disk/by-id/ata-ST9320325AS_6VD7ND0A-part1
  grub-pc/postrm_purge_boot_grub: false
  grub-pc/install_devices_failed_upgrade: true
  grub-pc/disk_description:
* grub2/linux_cmdline:
  grub-pc/install_devices_empty: false
  grub2/kfreebsd_cmdline_default: quiet
  grub-pc/partition_description:
  grub-pc/install_devices_failed: false
  grub-pc/install_devices_disks_changed:
* grub2/linux_cmdline_default: quiet splash
  grub-pc/chainload_from_menu.lst: true
  grub-pc/hidden_timeout: false
  grub-pc/mixed_legacy_and_grub2: true
  grub-pc/timeout: 10

La ligne qui t'intéresse

* grub-pc/install_devices: /dev/disk/by-id/ata-ST9320325AS_6VD7ND0A-part1

La commande "sudo debconf-show grub-pc" indique comme résultat part1
Donc, l'emplacement du chargeur d'amorçage enregistré est dans le secteur de boot de la partition sda1 ??
ici, j'essaie de comprendre selon les infos que tu donnes ci dessous
[Tuto] màj à faire après install de grub dans un autre disque dur

#8 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 15:12

philoup44
Réponses : 15

J'ai du "adapter" un peu ...

sudo dpkg-reconfigure grub-pc
[sudo] password for domi: 

de l'étape 1) à l'étape 3), je ne fais que valider par la touche Entrée après avoir déplacer le curseur sur OK (avec la flèche bas )
TAB semblait sans effet

en 4) apparait 2 options

/dev/sda (320072 Mo ; ST9320325s )
 - /dev/sda6 (49999 Mo ; / )

aucune étoile sur aucune option ??

je vais sur /dev/sda
j'appuye sur la touche TAB pour que <OK> soit sélectionné puis valide par la touche Entrée
puis s'affiche un rapport

Installation finished. No error reported.
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-79-generic
Found initrd image: /boot/initrd.img-3.2.0-79-generic
Found linux image: /boot/vmlinuz-3.2.0-29-generic
Found initrd image: /boot/initrd.img-3.2.0-29-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done

j'entre ensuite la commande

sudo debconf-show grub-pc
sudo debconf-show grub-pc
  grub-pc/kopt_extracted: false
  grub2/kfreebsd_cmdline:
  grub2/device_map_regenerated:
* grub-pc/install_devices: /dev/disk/by-id/ata-ST9320325AS_6VD7ND0A
  grub-pc/postrm_purge_boot_grub: false
  grub-pc/install_devices_failed_upgrade: true
  grub-pc/disk_description:
* grub2/linux_cmdline:
  grub-pc/install_devices_empty: false
  grub2/kfreebsd_cmdline_default: quiet
  grub-pc/partition_description:
  grub-pc/install_devices_failed: false
  grub-pc/install_devices_disks_changed:
* grub2/linux_cmdline_default: quiet splash
  grub-pc/chainload_from_menu.lst: true
  grub-pc/hidden_timeout: false
  grub-pc/mixed_legacy_and_grub2: true
  grub-pc/timeout: 10
* grub-pc/install_devices: /dev/disk/by-id/ata-ST9320325AS_6VD7ND0A

#9 Re : -1 »  [Résolu] Vérifier que Grub est bien sur la bonne partition » Le 01/04/2015, à 15:26

philoup44
Réponses : 15

Je comptais le faire !!
Mais seulement après ta confirmation ....

Merci pour tout, et passe une bonne journée !!

#10 Re : -1 »  ubuntu ce lance pas au démarrage » Le 23/02/2015, à 00:03

philoup44
Réponses : 16
abricot91 a écrit :

j'ai recu la clé usb "prête a l'emploi"

Je ne connais pas cette clé
Mais il y a quelle version Ubuntu dedans ??

Est ce que le bios est configuré pour démarré d'abord de la clé USB ??

Dans les liens ci-dessous
Doc.ubuntu-fr - uefi
zebulon.fr - desactiver-le-demarrage-rapide-de-windows-8
Tu verras, il n'y a pas que le secure boot à désactiver ...
il y a aussi le démarrage rapide ("Fast Startup" à mettre sur Off)

Le démarrage rapide permet d'enregistrer l'état de votre système lors de l'arrêt de l'ordinateur et permettre ainsi un redémarrage beaucoup plus rapide. Mais si cela permet d'accélérer Windows, le revers de la médaille est que l'appui sur la touche F12 lors du boot ne sera pas effectif. Il est ainsi impossible de modifier les choix du boot afin de démarrer sur une clé USB ou encore sur un CD-ROM par exemple.

En fait, Windows hiberne

Sur la Doc, Je relève ceci

Doc Ubuntu a écrit :

Versions d'Ubuntu démarrables en mode EFI

    Seule la version internationale d'Ubuntu 64bits, et ses variantes 64 bits (Kubuntu, Xubuntu, Lubuntu) permettent de démarrer en mode EFI.
    Ubuntu Edition Francophone 64bits ne peut pas démarrer en mode EFI (bug), mais une fois installée, elle peut être convertie en mode UEFI.

Ce qui pourrait peut etre expliquer aussi certaines choses ... (j'ignore ce qu'il y a sur ta clé)

#11 Re : -1 »  ubuntu ce lance pas au démarrage » Le 26/02/2015, à 14:18

philoup44
Réponses : 16

Sur ton lien, je vois ---> Clé USB 14.10 Ubuntu-fr
Peut etre la version françisée ... ??

(suit les instructions du lien donné par Bougron) ---> [TUTO] LiveUSB Ubuntu 14.04.2 64 bits créée avec LiLi depuis Windows

Sur une clé de 2 Go, tu vas créer une clé usb bootable d'une  iso Ubuntu
installe la dernière version LTS ( la 12.04.2 )

Doc.ubuntu-fr - Création d'une live usb

Liens pour télécharger Ubuntu 14.04.2 au choix :
Avec un client Torrent
releases.ubuntu.com/14.04.2/ubuntu-14.0 … so.torrent
sinon
http://releases.ubuntu.com/trusty/
prendre ici, --->  64-bit PC (AMD64) desktop image
ou
releases.ubuntu.com/releases/trusty/ubu … -amd64.iso

Une fois fait, teste la clé
Si tu peux booter dessus, choisi " Essayer sans installer " (avec les flèches du clavier)
vérifie ,si tout fonctionne (wifi, ethernet, affichage, souris, clavier, reconnaissance d'un périphérique (clé etc..), imprimante etc ....

Après voir si tu veux installer à coté de Windows ou pas ...

Infos sur les versions LTS
Doc Ubuntu - Versions maintenues à long terme (LTS)

---------------------------------------------------
Edit
N'installes pas Linux
Voir d'abord si Windows est installé en mode EFI avec partitionnement GPT
On te demanderas peut etre de faire un boot info ...
Voir également, s'il faut toujours privilégier l'installation manuelle ou pas ..

n'hésite pas à poser des questions ... !!

#12 Re : -1 »  ubuntu ce lance pas au démarrage » Le 26/02/2015, à 22:25

philoup44
Réponses : 16
Bougron a écrit :

Peut-être que sur leur site il y a le mode d'emploi, mais il va falloir mettre la main dessus.

Je l'ai cherché sans résultat ...
http://www.enventelibre.org/clef/cl%C3% … -ubuntu-fr

Clé USB 14.10 Ubuntu-fr
Une clé performante (USB 3.0) compacte, sans capuchon embarquant un live 14.10 d'ubuntu (64 bits), compatible UEFI.
Cette clé est fournie prête à l'emploi, pour effectuer tout type d'installation d'ubuntu 14.10.
Vous pouvez également choisir de la formater afin de profiter pleinement de ses 16GB de stockage.

D'un coté, on voit ,"Ubuntu-fr" de l'autre " compatible UEFI "
C'est Ubuntu Edition Francophone ou pas ??

Si la clé peut "booter" sur un PC en mode classique (hérité/legacy), c'est que c'est probablement un Ubuntu Edition Francophone qui est installé ...
Mais dans ce cas, l'info compatible UEFI, est fausse ...

#14 Re : -1 »  Digikam prend toutes les reçources de mon ordi » Le 26/02/2015, à 23:43

philoup44
Réponses : 1

Salut

Tu es sous Xubuntu ---> Un bureau léger et fonctionnel basé sur l'environnement xFCE.
Je ne connais pas Digikam, mais
Doc.ubuntu-fr - photo
Doc.ubuntu-fr - digikam
je vois que Digikam, a été conçu à la base pour Kubuntu, donc bureau, environnement  KDE
As tu suivi toutes les recommandations pour son installation ??

#15 Re : -1 »  erreur d'interpretation du fichie rimage jpeg -improper call to jpeg » Le 26/02/2015, à 23:23

philoup44
Réponses : 1

Salut

Toutes tes photos, sont des JPG ??

improper call to jpeg ---> peut etre que le format, n'est pas le bon ??

Prends une photo qui cause problème, et supprime sont extension (avec le point) ---> tu renommes en fait sans extension ...
Ex : Toto.jpg ---> Toto
Puis fait un clic droit sur l'image > propriété > et regardes quelle extension est proposée ...

#16 Re : -1 »  installation ubuntu : gros problème » Le 23/02/2015, à 23:45

philoup44
Réponses : 5

Salut arcturus-99

Tu en es ou ??
Tu as voulu installer quelle version de Linux à coté de quelle version de Windows ??
Ton PC, c'est quel modèle ??

Ce que l'on peut voir en bas de ton image

/usr/ubiquity/ubiquity/frontend/gtk_components/nmwidgets.py:131: Warning: source ID 317139 was not found when attempting to remove it
Glib.source_remove(self.rows_changed_ID)

#17 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 22/02/2015, à 19:03

philoup44
Réponses : 22

Donc, dans ce cas, pourquoi ne pas faire juste une installation classique de Ubuntu ??
qui écraseras tout ce qu'il y a sur ton PC (y compris d'éventuels "virus")
- Faire au préalable une Sauvegarde de tes données perso
- Pour une installation manuelle penser à créer une partition EFI (si bios EFI + partitionnement GPT)

Doc.ubuntu-fr.org/uefi

#18 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 01:03

philoup44
Réponses : 22

Ne tiens pas compte de ce que je place ici
c'est des penses betes concernant les messages d'erreurs que tu m'as affiché au dessus
Si une pointure passe derrière moi, ça lui causera

Could not open "\EFI\BOOT\fallback.efi"

EFI Fallback error when booting from USB on Macintosh
Solution trouvée

Copy grubx64.efi and past it as fallback.efi

Secure boot:

copy /EFI/ubuntu/shimx64.efi to /EFI/BOOT/fallback.efi
copy /EFI/ubuntu/grubx64.efi to /EFI/BOOT/grubx64.efi

Nonsecure boot:
copy /EFI/ubuntu/grubx64.efi to /EFI/BOOT/fallback.efi

Concernant fallback.efi
http://blog.uncooperative.org/blog/2014 … partition/
Sur certains  OS ,le problème de démarrage par défaut se fait par un "shim" utilitaire fournit nommé fallback.efi.

uloc magicis broken at 0 x 5A79EA80 aborted

ici, je ne sais pas si il fait référence au number magic ( normalement contenu dans le MBR (protecteur ou pas) )

#19 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 01:06

philoup44
Réponses : 22

Question bete (peut etre pas), tu as toujours acces à ton lubuntu ??
Dans le bios, le secure boot est désactivé ??
Ta clé, est une clé bootable avec Linux dessus, si oui, quel version de Linux ??

#20 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 01:38

philoup44
Réponses : 22

désactive sécure boot pour voir
Pour EFI regardes le lien ci-dessous
https://doc.ubuntu-fr.org/uefi

#21 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 02:01

philoup44
Réponses : 22

Sur le lien que je t'ai donné
regardes les sections 2.4, 2.5, 2.6

#22 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 02:17

philoup44
Réponses : 22

oups, j'ai rectifié .. tongue
désactive tout ce qui est indiqué sur le lien (section 1.3 et 1.4)

Sinon, penser aussi
soit la clé est HS ou soit, l'installation de linux sur la clé c'est mal passée
alors refaire une live usb

#23 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 02:40

philoup44
Réponses : 22

3clés sont morte en même temps?

3 clés, ça fait beaucoup ....

Sous Lubuntu, tu as un créateur de disque de démarrage (USB Creator) ??
https://doc.ubuntu-fr.org/usb-creator
Il faut éviter de positionner l'image iso de Linux à installer dans le dossier "Téléchargement"
Tu peux mettre une copie sur ton bureau, pour indiquer l'emplacement de l'iso,
tu clic sur "autre" et tu lui montre ton bureau
il verra l'iso, ça fonctionne, je l'ai fait plusieurs fois ...

Essaie de passer par lui pour voir (c'est t-on jamais)

J'va rejoindre morphée
croise les doigts  ...

#24 Re : -1 »  Migration Lubuntu ---> ubuntu » Le 23/02/2015, à 22:15

philoup44
Réponses : 22

tongue
Par curiosité
Tu veux dire que tu avais mis des permissions spécifiques ??

Si tu as pu faire l'installation, pense à mettre résolu