Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  /* Topic des codeurs [8] */ » Le 25/03/2013, à 00:54

naingenieu
Réponses : 2221

Je me suis remis au C++ et franchement j'adore... ça reste un peu compliqué à bien comprendre mais j'étais vraiment pas allé assez loin les templates etc :bave:

d'ailleurs si quelqu'un a des bons tutos sur le c++ ( en dehors des classiques developpez et sdz ) je suis preneur big_smile ( l'anglais me dérange pas trop au cas où même si pur des notiions compliqués le français est appréciable )

#1 -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 20/01/2014, à 18:34

naingenieu
Réponses : 24

Bonjour tout le monde,

Je poste sur ce forum en désespoir de cause sad
J'ai récemment eu un nouveau PC ( MSI GT70 2OC-430XFR ) doté d'un i7 et d'une nvidia gtx 770m et initialement pourvu de FreeDOS

J'ai installé Windows 8 dessus ( j'ai toujours vu qu'il était conseillé d'installer Windows avant Linux et je voulais faire un dual boot )

J'ai essayé toutes les combinaisons possibles entre :

[*]Ubuntu 12.04 LTS et Ubuntu 14.04 testing ( un rapport de bug suggérait de l'essayer ) [/*]
[*]Boot en mode UEFI, UEFI avec support CSM, LEGACY[/*]
[*]FastBoot On et Off[/*]
[*]Lancement avec les arguments de base, avec les arguments supplémentaires acpi=off et/ou nomodeset[/*]

Et rien ne marche sad

Quand je suis UEFI, je choisit mon entrée dans GRUB et il ne se passe rien, j'arrive sur un écran noir ( rétroéclairé ) et je peux attendre très longtemps sans changement ), la clé USB ne montre d'ailleurs de l'activité que pendant les premières secondes après la sélection

Quand je suis en LEGACY, j'arrive à un menu Unetbootin qui propose les choix Default, Installation, Memory Check, Essayer Ubuntu et quoi que je fasse, l'acran clignote une fois au boute de quelques secondes et ensuite plus rien ne se passe

Je précise que les ISO ont été téléchargées sur le site officiel, j'ai fait les checksums de rigueur et j'ai utilisé une clé USB formatée en FAT32 et Unetbootin

Je ne sais pas quoi faire ...

Je pense avoir fournit toutes les informations nécessaires, j'ai cherché sur plusieurs forums etc et rien, venez moi en aide s'il vous plaît smile

#2 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 20/01/2014, à 18:59

naingenieu
Réponses : 24

Windows 8, j'avais que ça sous la main du coup.

#3 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 20/01/2014, à 19:04

naingenieu
Réponses : 24

Ok je vais faire tout ça et je te tiens au courant merci beaucoup smile

BTW, j'ai pas précisé mais j'ai bien enlevé le SecureBoot smile

#4 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 20/01/2014, à 19:18

naingenieu
Réponses : 24

Je suis au regret de t'annoncer que ça n'a pas marché

J'ai laissé l'UEFI, gardé / enlevé le FastBoot, essayé avec les options de base / avec nomodeset et/ou acpi=off et j'ai le même comportement qu'à chaques fois ....

#5 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 20/01/2014, à 22:51

naingenieu
Réponses : 24

@malbo oui excuse moi je me suis complètement embrouillé dans mon écriture
Je vais regrder le thread mais j'arrive même pas à installer en legacy sad

@alca94 ce n'est pas ça, l'écran est bien visible smile

#6 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 00:54

naingenieu
Réponses : 24

Bon je reviens avec des nouvelles smile

J'ai pu installer Ubuntu 13.10 en legacy ( j'ai quand même du passer l'argument nomodeset )

Seulement ensuite j'ai utiliser boot-repair afin de le passer en boot UEFI ( aller dans le bios à chaque fois pour switcher d'OS c'est lourd tongue ) et là ça déconne complètement,
au démarrage en EFI j'ai grub qui s'ouvre mais en tout petit ( centré ) et j'ai que 3 entrées, à savoir Windows, Windows et Shim UEFI key Management ....

#7 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 10:04

naingenieu
Réponses : 24

Voici le boot-info : http://paste.ubuntu.com/6790349/

Merci de prendre le temps de m'aider big_smile

#8 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 12:30

naingenieu
Réponses : 24

Comment je fais pour réparer ça? Parce que le truc c'est que ce fichier a été généré par boot-repair qui était censé gérer la transition LEGACY - UEFI hmm

#9 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 12:45

naingenieu
Réponses : 24

Donc pour toi je n'ai pas d'autres choix que de réinstaller Windows? Je t'avouerais que ça m'arrange pas trop, j'ai pas mal de truc installés dessus déjà j'aimerais bien l'épargner si possible hmm

Parce que dans la doc sur l'uefi il parait possible de changer la méthode de boot d'ubuntu...

#10 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 12:47

naingenieu
Réponses : 24

Bon j'ai du faire une mauvaise manip avec boot repair, je viens de le relancer et j'ai ce boot-info à la sortie,
je comprends pas tout mais ça m'a l'air bien plus plaisant big_smile

#11 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 13:05

naingenieu
Réponses : 24

Me revoilà, sous Windows .... sad

Alors au boot en UEFI j'arrive bien sur GRUB ( violet et en grand c'est un bon début )
Par contre je n'arrive pas à booter sous Ubuntu...

Quand je choisit l'option par défaut je reste bloqué sur l'écran violet ( le disque ne signal aucune activité )  et quand je vais dans les options avancées, quelque soit l'entrée, j'ai deux lignes qui s'affichent :

loading linux kernel xxxxxxxxxxxxx
loading initial ramdisk

Puis plus rien.
J'ai essayé de mettre les options nomodeset et/ou acpi=off et rien ne change :'( :'(

D'après grub.cfg, je dois en conclure que c'est l'étape

initrd	/boot/initrd.img-3.11.0-15-generic

qui bloque non? vu que le texte avant s'affiche correctement ?

#12 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 13:54

naingenieu
Réponses : 24

Ah ... bon ben merci de ton aide avec un peu de chance quelqu'un va passer par là avec la solution miracle big_smile

En attendant, tu pourrais me dire où signaler les bugs qu'au moins je fasse remonter ça s'il te plaît?

#13 Re : -1 »  Ubuntu, EFI, nvidia, MSI et installation impossible » Le 21/01/2014, à 20:55

naingenieu
Réponses : 24

C'est noté malbo hmm pas de bug report de ma part alors...

Sinon on m'a parlé d'un outil appelé EasyBCD, ça dit quelque chose à quelqu'un?

#15 -1 »  [C++] Problème avecQt, strings et char » Le 25/06/2013, à 23:16

naingenieu
Réponses : 0

Bonsoir tout le monde smile

J'ai un petit soucis avec un programme que je suis en train d'écrire  une partie consiste en l'encodage de fichiers. Pour cela je me suis basé sur un code source trouvé en ligne, qui fait appel à cette fonction :

fencrypt("aencoder", "fichierencodé", (unsigned const char*)"un mot de passe _123_");

qui fonctionne très bien ...

Seulement, je travaille avec un GUI ( j'ai choisit Qt pour cela ) où l'utilisateur rentre notamment son mot de passe et là rien ne va plus. Le processus de chiffrement / déchiffrement ne fonctionne que si le mot de passe de la personne n'est composé que de lettres. Pour info, j'utilise ce code pour récupérer le mot de passe :

std::string passphrase = (_tab_crypt_passphrase -> text()).toStdString()
fencrypt((char*)fileName.c_str(), (char*)fileNameEnc.c_str(), (const unsigned char *)passphrase.c_str());

quelqu'un aurait une piste?

Merci d'avance smile

#16 -1 »  Des actuaires parmis vous? » Le 26/03/2013, à 20:39

naingenieu
Réponses : 0

Yop tout le monde smile

Je prépare une école d'actuaire et je m'intéresse pas mal à l'informatique aussi.
j'aurais aimé savoir les logiciels fréquemment utilisés, si c'était possible de pratiquer sous Linux etc... Je fasi pas mal de python, du C++ etc ils sont utilisables?

Merci de vos réponses big_smile

Bonne soirée !

#17 Re : -1 »  Topic des Couche-Tard (cinquante-sept) » Le 15/03/2013, à 03:06

naingenieu
Réponses : 11046

joli plop big_smile

sur ce bonne nuit, plopez bien

#18 Re : -1 »  Topic des Couche-Tard (cinquante-sept) » Le 16/03/2013, à 22:54

naingenieu
Réponses : 11046

@S.O.D. Où est-ce qu'on signe?

#19 Re : -1 »  Topic des Couche-Tard (cinquante-sept) » Le 18/03/2013, à 01:16

naingenieu
Réponses : 11046

bonne nuit !
Demain c'est la rentré sad

#20 Re : -1 »  Geek et sexisme ordinaire… » Le 17/03/2013, à 17:12

naingenieu
Réponses : 53

Je suis en train de lire l'article et c'est intéressant mais j'aimerais apporter mon point de vue :
Il y a à mon avis deux causes principales de sexisme dans cette communauté.
Tout d'abord ça vient peut être de "l'origine des geeks" c'était un mouvement plutôt masculin, et très mal vu, les membres étaient souvent regroupés en petite commu mais mis à l'écart du reste or il y à en ce moment une mode du geek, c'est indéniable ( j''ai emprunté un magazine de ma petite soeur, un truc de mode où il y avait un "coin des geeks, où il parlaient de séries lol ) et donc ça amène beaucoup de personnes qui se revendiquent d'une mouvance qu'ils ne comprennent et connaissent pas ce qui entraîne une forte répulsion : les tru3s contre les n00bs, la chasse au casu etc donc ce n'est pas nécessairement du sexisme mais le refus de devenir des objets de mode ( et c'est d'autant plus marqué contre les filles parceque leur nombre étaient très réduit au départ alors que maintenant on entend partout des pseudos-hipsters dire "olalala je suis trop une geek j'ai regardé une heure de séries hier soir xP" )

Le deuxième problème vient surtout de la jeune génération de "geeks" qui sont plus des gamers qu'autre chose. Là les éditeurs ont tout fait pour rameuter de jeunes garçons qui sont souvent abreuvés de pornographie à côté etc et donc leur attitude n'est que le reflet de ce rapport faussé aux femmes. Quand à l'industrie du JV qui pense surtout à l'argent, elle ne fait que suivre les désirs de ce publique pour vendre ( ça couterait cher et on risquerait de faire un flop en voulant changer les mentalités ...)

Pour le sujet du sexisme dans les JV vous puvez aussi regarder http://www.youtube.com/watch?v=X6p5AZp7r_Q

#21 Re : -1 »  Geek et sexisme ordinaire… » Le 18/03/2013, à 01:17

naingenieu
Réponses : 53

@Traductator je ne dis pas qu'elle l'est, mais qu'elle l'a été, comme toute communauté en fait, maintenant elle est au contraire victime d'un effet de mode

#22 Re : -1 »  Flash sous Linux va devenir une exclusivité Google Chrome » Le 17/03/2013, à 14:30

naingenieu
Réponses : 92
Neros a écrit :

e côté pourri ce serait le H264,

Tu pourrais m'expliquer pourquoi? Je connais que sa "bonne face" qui est une capacité de compression impressionnante

#23 Re : -1 »  Flash sous Linux va devenir une exclusivité Google Chrome » Le 17/03/2013, à 16:19

naingenieu
Réponses : 92
[15:12 1.64]
[pierre@PC-ubu 14] ~ $ x264 --version
x264 0.129.2 bc13772
(libswscale 2.1.103)
(libavformat 54.59.107)
built on Jan 13 2013, gcc: 4.6.1
configuration: --bit-depth=8 --chroma-format=all
x264 license: GPL version 2 or later

pourtant je l'ai compilé moi même et il est sous GPL...

#24 Re : -1 »  Flash sous Linux va devenir une exclusivité Google Chrome » Le 17/03/2013, à 16:38

naingenieu
Réponses : 92

ah en effet j'avais pas vu la nuance ...