Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  [Résolu] L'installation de Ub. 14.04 ne détecte pas W7 déja installé! » Le 27/02/2015, à 07:21

ikewdu
Réponses : 14

Salut,

http://forum.ubuntu-fr.org/viewtopic.ph … #p17964441

Ce lien m'intéresse au plus haut point,  car il va m'éviter d'expliquer inlassablement la même chose sur un autre site.

Pour Christian, une simple remarque : la manipulation "zap" avec gdisk n'est pas tout à fait sans risque. J'ai déjà eu la surprise de me retrouver avec un disque dur à blanc juste après. Si gdisk identifie le disque comme un disque gpt, on peut aussi tenter l'option g comme je l'ai fait ici : http://forum.ubuntu-fr.org/viewtopic.php?id=1767581 . Mais là non plus, ce n'est pas sans risque.

#1 Re : -1 »  Problème dual-boot Ubuntu 14.04/Windows 8.1 » Le 28/02/2015, à 19:07

ikewdu
Réponses : 12

Salut,

A mon avis, le plus sage serait de réparer le démarrage de windows avec le DVD W8 ou avec dart  (W8 64 bits):

http://forum.pcastuces.com/images_de_re … f7s963.htm

Tu fais en sorte de booter dessus en uefi et on verra comment faire avec l'invite de commandes.

#2 Re : -1 »  Problème dual-boot Ubuntu 14.04/Windows 8.1 » Le 01/03/2015, à 09:07

ikewdu
Réponses : 12

Re,

Double clique sur l'iso pour graver Dart en décompressant. On pourra vérifier facilement si tu bootes sur le cd en uefi, et on avisera si ce n'est pas le cas.

La manip que je me propose de faire réinstallera les fichiers nécessaires à Windows pour démarrer. Ubuntu ne sera pas supprimé.

#3 Re : -1 »  (ABANDON de la question) Cohabitation Ubuntu 14.04 / W8 » Le 21/02/2015, à 11:55

ikewdu
Réponses : 10

Salut,

Dans ton rapport boot-repair, on voit ceci :

6      11.2GB  12.2GB  977MB   linux-swap(v1)
5      989GB   1000GB  11.5GB  ntfs            Basic data partition  hidden, diag

Une énorme partie de ton disque dur est inutilisée. Visiblement, c'est l'emplacement (en partie) de ton ex-windows 8. Le recovery étant toujours présent, tu peux tenter une récupération via dart :

http://forum.pcastuces.com/images_de_re … f7s963.htm

#4 Re : -1 »  (ABANDON de la question) Cohabitation Ubuntu 14.04 / W8 » Le 21/02/2015, à 18:11

ikewdu
Réponses : 10

Je viens de vérifier avec le lien suivant (qui est le bon fichier)... aucun problème pour télécharger.

http://odsxxr.1fichier.com/

#5 Re : -1 »  [résolu] Asus X200CA et Bios ... » Le 22/02/2015, à 08:15

ikewdu
Réponses : 5

Salut,

Perso, je ne vois pas d'Ubuntu installé sur ce disque et boot-repair non plus:

/dev/sdb2      ext4       455G   71M  431G   1% /mnt/boot-sav/sdb2
No OS or WinEFI system

71 Mb pour tout un linux... Ton live-cd est lancé correctement, en uefi. Refais l'installation de A à Z.

#6 Re : -1 »  Accès à Ubuntu en 2 démarrages de l'ordi .... » Le 14/02/2015, à 09:38

ikewdu
Réponses : 8

Salut,

L'installation semble globalement correcte, bien que là, on voie que tu as un problème avec tes partitions de swap (pourquoi 2) ?

/dev/sda8   1,180,743,680 1,200,275,455    19,531,776 Swap partition (Linux)
/dev/sda9   1,164,130,304 1,180,743,679    16,613,376 Swap partition (Linux)

Failed to mount '/dev/sda8': Argument invalide
The device '/dev/sda8' doesn't seem to have a valid NTFS.
Failed to mount '/dev/sda9': Argument invalide
The device '/dev/sda9' doesn't seem to have a valid NTFS.

Les deux partitions n'ont pas d'UUID identifié :

"blkid" output: ________________________________________________________________
Device           UUID                                   TYPE       LABEL
/dev/sda7        b92e5c74-b51c-4453-9004-eb27b2052530   ext4       
/dev/sda8                                                          
/dev/sda9  

                                                       

Par ailleurs, Ubuntu cherche à monter un swap qu'il ne trouve pas.

=============================== sda7/etc/fstab: ================================
# swap was on /dev/sda9 during installation
#UUID=91cc9726-f3af-431b-a3cb-922640f5cd90 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Règle déjà ce problème de swap en suivant ce qui est dit ici : https://doc.ubuntu-fr.org/swap

Mais il se peut que le problème de démarrage une fois sur deux ne viennent pas de là, mais de Windows. Si le mode hibernation est activé sous W8, il se peut que ça ait des conséquences sur le dual-boot. Depuis W8, tente de taper en admin la commande suivante :

powercfg -h off

Ca permettra déjà d'écarter cette piste.

#7 Re : -1 »  boot du w7 s'est evanoui en passsant par le bios je boot sur unbuntu14 » Le 03/02/2015, à 13:57

ikewdu
Réponses : 10

Salut,

bougron a écrit :

Utiliser  le CD de réparation de windows et faire la commande FIXMBR  en mode administrateur

Attention, ça c'est la commande avec XP. Là, c'est W7 (ou vista). Donc :

bootrec /fixmbr
bootrec /fixboot

Et il vaut mieux débrancher ce qui est inutile durant l'opération....

#8 Re : -1 »  boot du w7 s'est evanoui en passsant par le bios je boot sur unbuntu14 » Le 05/02/2015, à 20:08

ikewdu
Réponses : 10

Re

Pour info :

source>bootrec /FixMbr
source>bootrec /FixBoot

est égal à

source>bootsect /nt60 c:   

qui est égal à

bootsect /nt60 SYS /Mbr

Bref, tu as fait 3 fois la même chose.

#9 Re : -1 »  Je ne peux plus démarrer windows7 » Le 07/02/2015, à 19:06

ikewdu
Réponses : 10

Salut,

Tu as fait une installation bancale.... Tous tes OS sont sur sdb et tu as un grub installé dans le mbr de sda. Ensuite, tu as également un grub dans le secteur de boot de sdb2 (d'où le démarrage possible avec easybcd). Bref, comme tu l'as dit, il faut faire quelques réparations :

1. Remettre un mbr Windows sur sda et rendre ce disque inactif.
2. Réparer le démarrage de Windows sur sdb.
3. Réinstaller grub proprement dans le mbr de sdb.

Tu pourrais essayer la réparation recommandée de boot-repair qui semble potable, sait-on jamais (refais ensuite un boot-infos).

Sinon, il te faut une console de réparation de W7, ce qu'on trouve ici :

http://www.pcastuces.com/pratique/windo … /page1.htm

#10 Re : -1 »  Howto_Comment identifier si les partitions sont GPT ou MBR » Le 08/02/2015, à 08:13

ikewdu
Réponses : 25

Salut,

J'ai fait ici une série de tests de basculements de gpt vers mbr et inversement... avec des dual-boot W10 /ubuntu. On peut faire pas mal de choses, en fait. Gdisk est assez magique pour faire les conversions.

http://forum.ubuntu-fr.org/viewtopic.php?id=1767581

Quant à la clé usb, elle devrait pouvoir booter même en gpt si on crée une entrée de boot dans le bios en pointant vers grubx64.efi. Mais je n'ai pas testé.

#11 Re : -1 »  Howto_Comment identifier si les partitions sont GPT ou MBR » Le 08/02/2015, à 08:43

ikewdu
Réponses : 25

Je disais ça pour un live... Si la partition est fat32, en allant chercher dans le bios le fichier /efi/boot/grubx64.efi , je pense (il faudrait vérifier) que ça devrait se lancer.

Avec un Linux installé sur clé usb, ça devrait d'ailleurs aussi fonctionner.

#12 Re : -1 »  Howto_Comment identifier si les partitions sont GPT ou MBR » Le 08/02/2015, à 08:50

ikewdu
Réponses : 25

Si j'ai le temps, je ferai un essai... formatage en fat32 d'une clé usb en gpt, activation de la partition, et simple copie du contenu de l'iso sans aucun outil du type Lili ou unetbootin... par curiosité.

#13 Re : -1 »  Pas de menu grub lors d'un redémarrage après installation et m.à.j. » Le 02/02/2015, à 07:09

ikewdu
Réponses : 7

Salut,

Démarre sur ton live-cd linux et propose-nous un rapport boot-info.

https://doc.ubuntu-fr.org/boot-repair

(ne fais pas la réparation automatique tant qu'un avis ne t'a pas été donné). Et pour info, un mac s'appuie sur une base Unix, comme Linux. Les deux systèmes ne sont pas si éloignés que cela.

#14 Re : -1 »  Problème de cohabitation windows 7 pro / ubuntu 14.10 » Le 04/02/2015, à 06:36

ikewdu
Réponses : 6

Salut,

Comme xabilon, je pense que ton BSOD est un problème spécifiquement dû à Windows. Fais toujours un rapport boot-info histoire qu'on voie si tout est normal du côté Linux :

https://doc.ubuntu-fr.org/tutoriel/boot-info

Et si tout est correct, il faudra regarder avec le cd de réparation de Windows ce qui peut clocher. Le BSOD étant révélateur de pas mal de choses, il faudra faire quelques tests pour voir si on trouve l'origine du mal.

#15 Re : -1 »  Réinstallation de grub2 après l'installation de windows avec dual boot » Le 02/02/2015, à 07:05

ikewdu
Réponses : 1

Salut,

La première chose à faire, ce serait de démarrer sur le live-cd et à partir de boot-repair, de nous proposer un rapport boot-info. On y verra plus clair.

#16 Re : -1 »  depuis l'installation d'ubuntu en dual boot windows suite » Le 31/01/2015, à 23:01

ikewdu
Réponses : 75

Non, c'était une faute de frappe de ma part....

Quant au message d'erreur, il y a visiblement un problème de boot sur une partition... Il faudrait que j'aie toute la ligne.
Propose un boot-info pour que je voie ce qui a pu clocher.
Essaie aussi de démarrer sur windows boot manager depuis le bios, pour voir si W8 se lance toujours.

#17 Re : -1 »  depuis l'installation d'ubuntu en dual boot windows suite » Le 01/02/2015, à 08:07

ikewdu
Réponses : 75

Re,

Peux-tu poster un rapport boot-info ?

https://doc.ubuntu-fr.org/boot-repair

Tu fais juste le rapport, et non la réparation.

Edit. Malbo a résolu ce problème ici  (un simple souci avec le secure-boot qu'il faut désactiver):
http://forum.ubuntu-fr.org/viewtopic.php?pid=16013711

#18 Re : -1 »  depuis l'installation d'ubuntu en dual boot windows suite » Le 01/02/2015, à 11:33

ikewdu
Réponses : 75

A vue de nez, l'installation me semble correcte. Au pire, si la désactivation de secure-boot ne change rien, on tentera d'ajouter une entrée manuelle "simplifiée" dans 40_custom... on verra si ça passe mieux.

#19 Re : -1 »  depuis l'installation d'ubuntu en dual boot windows suite » Le 01/02/2015, à 11:59

ikewdu
Réponses : 75

Salut,

Bougron a écrit :

Bonjour à vous deux.
Pourquoi ne pas tenter d'abord cette piste avant de modifier 40_custom ?
"Si votre BIOS ne permet pas de changer l'ordre de démarrage, changez l'entrée de démarrage par défaut de l'amorceur Windows.
Par exemple, vous pouvez démarrer Windows, puis saisir la commande suivante dans une invite de commande en mode administrateur :
bcdedit /set {bootmgr} path \EFI\...\grub*.efi"

que je traduis par  bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
ou bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi
PS. J'ignore s'il est possible de mettre un * dans cette commande,

Attendons la désactivation du boot-secure... Et perso je me refuse définitivement à proposer ces bidouillages de noms de fichiers. C'est du foireux absolu et du plantage en perspective, à court ou moyen terme. C'est d'autant plus inutile que grub est correctement trouvé au boot. C'est l'entrée Windows dans le menu grub qui merdouille.

#20 Re : -1 »  depuis l'installation d'ubuntu en dual boot windows suite » Le 01/02/2015, à 16:48

ikewdu
Réponses : 75

Ajoute [résolu] dans le titre. A +

#22 Re : -1 »  Probléme de démarage » Le 01/02/2015, à 11:35

ikewdu
Réponses : 5

Salut,

Beurk ! beurk ! beurk ! Installation faite avec wubi, pas compatible avec W8 en uefi :

Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe 
                       /wubildr /wubildr.mbr

Le mieux serait déjà de virer toutes les traces de wubi, puis de refaire un boot-info depuis le live-cd lancé en uefi... car là, c'est trop "sac de noeuds" pour mes faibles moyens.

#23 Re : -1 »  Probléme de démarage » Le 01/02/2015, à 11:53

ikewdu
Réponses : 5

Pourtant, il en reste des traces... Quoi qu'il en soit, ton installation risque de ne pas pouvoir être beaucoup améliorée... sur certaines marques (HP notammement, et PB est une sous-marque d'HP), on doit passer par F9 pour  démarrer. Vois les nombreux sujets à ce propos.

#24 Re : -1 »  Probléme de démarage » Le 01/02/2015, à 12:06

ikewdu
Réponses : 5

Tu peux déjà vérifier que le programme est bien désinstallé dans "tous les programmes" de W8. Puis, tu cherches sur sda4 et sda6 (depuis W8) les dossiers correspondants à wubi : /wubildr /wubildr.mbr (puisqu'ils sont détectés par le boot secure) . Tu les vires.

Enfin (tu pourrais même commencer par là), tu vérifies que les entrées wubi ont disparu de bcd. Tu lances l'invite de commandes de W8 en admin, tu tapes

bcdedit /v

Si wubi apparaît dans la liste, tu supprimes l'entrée par bcdedit /delete {id-de-wubi}

Théoriquement, tu en auras fini avec lui.