Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  PB installation mysql phpmyadmin » Aujourd'hui à 19:51

bruno
Réponses : 5

Bonsoir,

Lorsque tu installes le paquet mysql-server il doit te demander de définir le mot de passe de l'utilisateur 'root' de mysql. Il est indispensable de définir un mot de passe (fort) à cette étape.

Si tu installes ensuite phpmyadmin il va te demander :

- le mot de passe de l'utilisateur root de mysql afin de pouvoir créer un utilisateur 'phpmyadmin' et une base de donnée du même nom ;
- un mot de passe pour l'utilisateur 'phpmyadmin', mieux vaut éviter de donner le même que pour 'root'

Quand tu voudras te connecter à l'interface web de phpmyadmin tu pourra utiliser 'root' et son mot de passe si tu veux avoir un accès complet à tout le SGBD, ou au choix le nom d'un utilisateur qui a un accès restreint (généralement à une seule base de donnée).


Ceci dit phpmyadmin n'est pas vraiment fait pour « configurer MySQL », c'est juste utile pour gérer des bases de données (petites) à distance lorsque l'on a pas d'autre accès au serveur. Sinon on utilise directement mysql / mysqladmin en ligne de commande ou une interface graphique comme MySQL Workbench.

#1 Re : -1 »  PB installation mysql phpmyadmin » Aujourd'hui à 23:03

bruno
Réponses : 5

mysql-server est un paquet vide qui a pour dépendance la dernière version de mysql (mysql-server-5.5). Lire les descriptions des paquets c'est utile…

Vu le retour de ta commande le paquet mysql-server-5.5 est déjà installé. Si tu as oublié le mot de passe de l'utilisateur 'root', tu peux le redéfinir simplement avec :

sudo dpkg-reconfigure mysql-server-5.5

#2 Re : -1 »  Sécuriser Apache, mysql, serveur ftp » Aujourd'hui à 12:43

bruno
Réponses : 16

Bonjour,

Franchement le premier lien… hum…
La sécurité d'un serveur cela ne se gère pas avec des tutos qui ne sont souvent que des recettes correspondant à un cas d'usage bien particulier. C'est un travail permanent…
Pour commencer il faut faire ton installation uniquement à partir des dépôts officiels (et surtout pas des ppa ou pis dotdeb comme dans le lien en #2), ensuite il faut maintenir ta distribution à jour et notamment faire les mises à jour de sécurité dès qu'elles sont publiées.

Pour le reste cela dépend de l'usage que tu va faire de ton serveur (services installés, utilisateurs, etc.). Il faut surtout bien garder à l'esprit que sur un serveur web le maillon le plus faible est constitué par les sites hébergés (failles de sécurité dans les CMS, injection de code, etc.).

Pour le FTP ce n'est absolument pas indispensable. Une solution SFTP avec openssh-server sera bien plus sécurisée.

#3 Re : -1 »  Remplacement HDD défectueux sur Serveur Raid 1 [Resolu] » Le 31/03/2015, à 09:50

bruno
Réponses : 39

Re,

hum… dans la mesure où le disque fautif est identifié par sdd et où le disque sain est identifié par sdc, je ne toucherai pas à sdc !

A priori les 3 RAID ont été construit sur des disques entiers, non partitionnés. Il ne faut donc pas que sdd contienne de partition. Là il contient une partition de type EFI ce qui est de toute façon une erreur.
Il faudrait au contraire supprimer la partition de sdd avec un outil prenant en charge GPT : gdisk; cgdisk, parted ou autre, et recréer une table de partition MBR (MS-DOS).

#4 Re : -1 »  Remplacement HDD défectueux sur Serveur Raid 1 [Resolu] » Le 03/04/2015, à 11:21

bruno
Réponses : 39

Tu n'as pas besoin de tout refaire… D'après les infos que tu as donné le RAID qui pose problème est constitué de deux disques

sdc : disque non partitionné sain
sdd : disque avec une table de partition GPT et une partition de type ee (EFI) (qui était marqué fautif)

Il faut donc supprimer la partition de sdd (avec gdisk ou cgdisk) de façon à ce que un fdisk /dev/sdd te donne le même résultat que fdisk /dev/sdc. Ensuite réintégrer sdd au RAID avec les commandes habituelles.

#5 Re : -1 »  Remplacement HDD défectueux sur Serveur Raid 1 [Resolu] » Le 03/04/2015, à 17:50

bruno
Réponses : 39

Si tu préfères l'interface graphique, utilise gparted.

#6 Re : -1 »  probleme avec apt-get install » Le 17/04/2015, à 15:36

bruno
Réponses : 23

Bonjour,

Visiblement ton disque est partitionné en LVM. Il aurait été plus judicieux de commencer par regarder si tu ne pouvais pas augmenter la taille du volume réservé à /usr (/dev/mapper/vgroot-usr)…

#7 Re : -1 »  [RESOLU] mail() de PHP ne fonctionne pas avec Apache (Exim en MTA/MDA) » Le 22/04/2015, à 08:50

bruno
Réponses : 2

Bonjour,

Que disent les logs, ceux d'Apache et d'exim au moment où tu essaies d'envoyer un courriel via la fonction mail() de PHP ?

#8 Re : -1 »  [Résolu] cron-apt : avoir les notifications du nbre de paquets à inst » Le 17/04/2015, à 15:46

bruno
Réponses : 8

Bonjour,

Cette ligne :

APTCOMMAND=/usr/bin/apt

C'est toi qui l'a ajouté ? Qu'est-elle censée faire ?

#9 Re : -1 »  [Résolu] cron-apt : avoir les notifications du nbre de paquets à inst » Le 18/04/2015, à 08:10

bruno
Réponses : 8

+1
L'erreur, clairement indiquée en #1, vient du fait que la commande apt ne prend pas en charge les options de la commande apt-get .
Tu as la doc dans /usr/share/doc/cron-apt/README. À lire…

#10 Re : -1 »  Script restart » Le 09/04/2015, à 17:53

bruno
Réponses : 5

Bonjour,

sudo reboot

mais c'est un peu violent… Mieux vaut tuer le processus qui a planté (cf. man kill) et le relancer.

#11 Re : -1 »  [RESOLU] utilisation sftp en curl » Le 16/04/2015, à 14:53

bruno
Réponses : 5

Bonjour,

Il me semble que libcurl pour Ubuntu est compilée sans la prise en charge du protocole SFTP. Tu peux le voir en faisant :

curl -V

Il te faut donc soit compiler ta propre version de libcurl, soit utiliser une autre solution pour faire du transfert SFTP avec PHP :

http://php.net/manual/fr/function.ssh2-sftp.php
http://phpseclib.sourceforge.net/

#12 Re : -1 »  [RESOLU] utilisation sftp en curl » Le 16/04/2015, à 17:09

bruno
Réponses : 5

Tu peux avoir la bibliothèque libcurl, qui est une dépendance de php5-curl, sans nécessairement avoir installé l’exécutable en ligne de commande (curl).

Je reconnais que l'usage des fonctions ssh2 de PHP n'est pas très simple (installer le paquet php5-ssh2) et je ne garantis pas le fonctionnement avec le serveur qui est en face…
Pour le deuxième lien il y a aussi un paquet Ubuntu : php-seclib

#13 Re : -1 »  INFECTION VIRUS yxo.warmportrait » Le 05/04/2015, à 16:02

bruno
Réponses : 78

Bonjour,

A priori ce logiciel malveillant ne peut s'installer que sous Windows… Je vois donc mal comment tu pourrais être infecté. À moins que tu ne partages le dossier de chromium entre Ubuntu et Windows. Dans cas il serait possible que tu en observes uniquement les symptômes : redirections vers des sites malveillants, popups publicitaires, sous Ubuntu.

#14 Re : -1 »  INFECTION VIRUS yxo.warmportrait » Le 05/04/2015, à 16:17

bruno
Réponses : 78

Alors comment sais-tu qu'il s'agit précisément de ce logiciel malveillant : Yxo WarmPortrait ?

Si c'est avéré cela vient forcément d'une extension, et les « dégâts » (symptômes décrits en #13) sont très probablement uniquement limités à Chromium.

#15 Re : -1 »  Meilleure solution pour migrer une Ubuntu server 8.04 ? » Le 15/04/2015, à 13:53

bruno
Réponses : 13

Je ne peux que confirmer l'avis de tiramiseb. Faire les mises à niveau à coups de « do-release-upgrade » (ou un changement des sources) c'est long, parfois même très long, et cela laisse plein de « traces » : paquet obsolètes qui ne sont plus dans les dépôts, paquets non désinstallés complètement à purger, etc. Sans compter les nombreuses questions posées par debconf pendant l'installation des nouveaux paquets (faut-il garde l'ancien fichier de configuration ? faut-il redémarrer le service truc ?) qui vont obliger à rester devant la machine…

D'autre part, je suis prêt à parier que la moitié des services installés ne fonctionnera plus correctement une fois la mise à niveau vers 14.04 LTS accomplie. Il faudra donc les reconfigurer. Globalement je pense que cette méthode sera beaucoup plus longue qu'un réinstallation complète.

#16 Re : -1 »  Pb avec version PHP et moodle ? » Le 14/04/2015, à 09:05

bruno
Réponses : 3

Bonjour,

Les logs ! Que disent les logs ? Si l'affichage des erreurs PHP dans le navigateur n'est pas activée il faut regarder dans les logs d'Apache.

#17 Re : -1 »  Pb avec version PHP et moodle ? » Le 14/04/2015, à 17:42

bruno
Réponses : 3

Un peu de lecture :

http://php.net/manual/fr/errorfunc.conf … lay-errors

qui doit être sur "on" pour du développement et sur "off" en production.

et accessoirement
http://php.net/manual/fr/errorfunc.conf … -reporting

Quant aux logs il suffit de les examiner au moment où tu charges la page qui pose problème avec une commande du style :

tail -f /chemin/vers/log/du/site/error.log

#18 Re : -1 »  .htaccess ignoré avec virtualHost » Le 09/04/2015, à 17:47

bruno
Réponses : 18

Bonjour,

Lire la doc Apache…
Comme indiqué dans le message d'erreur, on ne met pas de directive <Directory> dans un fichier htaccess (cela semble assez évident puisque l'on est déjà dans le contexte d'un répertoire).

#19 Re : -1 »  Equivalence Kstat sur Linux - Intégration script ? [RESOLU] » Le 09/04/2015, à 18:06

bruno
Réponses : 9

Bonjour,
Tu peux te servir des commandes ip plutôt que ifconfig qui est obsolète (et ne donne pas toutes les infos…)

ip addr

Ensuite ethtool (alternative à mii-tool) peut te donner les informations que tu cherches mais il faut l’appeler sur chaque interface :

ethtool eth0

On peut également retrouver des infos dans les journaux système (dmesg, syslog).

#20 Re : -1 »  Equivalence Kstat sur Linux - Intégration script ? [RESOLU] » Le 10/04/2015, à 10:41

bruno
Réponses : 9

Pour les différences je t'invite a essayer les deux commandes et à regarder la page de man ip.

ethtool indique bien si une interface est active, exemple :

$ sudo ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 2
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000001 (1)
                               drv
        Link detected: yes

Si tu veux l'utiliser sur toutes les interfaces (physiques et virtuelles), tu peux sans doute faire un petit script qui fait une boucle sur les noms d'interfaces présents sous /sys/class/net

#21 Re : -1 »  [RESOLU] Serveur Ubuntu 14.04 injoignable » Le 09/04/2015, à 17:43

bruno
Réponses : 2

Bonjour,

Commence par désactiver le pare-feu (inuutile de toute façon…) :

sudo ufw disable

Vérifie également tes redirections de ports sur ta freebox.

#23 Re : -1 »  Calibre DRM PyCrypto » Le 28/03/2015, à 11:32

bruno
Réponses : 2

Bonjour,

C'est le paquet python-crypto…

#24 Re : -1 »  Probleme sql distant depuis un serveu dedie ovh » Le 28/03/2015, à 11:48

bruno
Réponses : 3

10.0.x.y ce n'est pas une IP publique… Il faut aussi vérifier sur ton sql privé que ton utilisateur est bien autorisé à se connecter depuis ton serveur dédié (nomutilisateuir@hôte)

P.S. : sinon il y a une raison particulière pour utiliser mysql_pconnect  (obsolète avec PHP 5.5) plutôt que mysqli_connect ou PDO ?