Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2] » Le 27/08/2013, à 07:39

roger64
Réponses : 612

Bonjour

Cela faisait longtemps.  smile Alors que j'avais bien réussi à charger puis installer l'iso précédente, cette-fois ci avec la version 201308 de SolydX (64bits), je me suis planté deux fois, une fois sur des histoires d'ELF magic et j'ai reformaté la clé, la deuxième fois, j'ai été plus loin, l'iso s'est installée mais au lancement de Multisystem, il cherche le kernel et demande de taper n'importe quelle clé pour retourner au menu.

Peut-être cette iso n'est-elle pas encore intégrée dans Multisystem ou ont-ils changé quelque chose par rapport à la précédente?

#3 Re : -1 »  MultiSystem, Créez votre LiveUSB MultiBoot simplement! [2] » Le 16/10/2013, à 15:45

roger64
Réponses : 612

Bonjour

Je viens de m'apercevoir que la dernière version de Parted Magic, tout en restant avec la licence GPL, est devenue payante au téléchargement (environ 5 dollars). Cela va t-il poser un problème de soutien pour Multisystem? Si c'est le cas que convient-il de faire?
- cesser de l'utiliser parce qu'elle n'est plus supportée (et donc - pour moi au moins - inutilisable)
- te faire passer une copie pour que tu en assures le soutien même si c'est sans l'autorisation de l'auteur?
- autre solution, par exemple écrire à l'auteur pour obtenir les paramètres techniques (???) de l'iso

#4 Re : -1 »  Live Voyager » Le 06/10/2013, à 07:31

roger64
Réponses : 2476

hors sujet

Raah, trop tard pour moi.

J'ai acheté vendredi dernier une Deskjet 2510 (HP) pour remplacer une Deskjet 2100 qui avait effectivement des problèmes de cartouche (durs à détecter, il a fallu que je passe sur W7 pour avoir l'info). Certes la cartouche n'était pas de chez HP mais elle était pratiquement neuve (quelques pages à peine). Je n'ai pas osé acheter Canon car j'ignorais qu'il supportait aussi bien Linux. La prochaine fois... smile

/hors sujet

Bonne continuation à Voyager. À tout hasard pour me faire pardonner, quelques infos qui pourraient potentiellement vous intéresser.

J'utilise aussi Xfce en distribution d'appoint (SolydX et des dépôts dérivés de Debian) installable avec le menu Whisker et le Xfce-theme-manager. L'une des fonctions qui me manquaient depuis Gnome était les nautilus-scripts. Je trouve que les Thunar actions ne sont pas très conviviales - j'ai sûrement tort - et j'ai bien une douzaine de petits scripts que j'utilise régulièrement. Installer Nautilus (que Gnome persiste à châtrer) entraîne aussi l'installation d'une horde de dépendances (70 megs environ) inutiles. J'ai trouvé une solution de rechange: j'ai installé Nemo (10 megs tout compris) qui a gardé toutes les fonctionalités d'origine de Nautilus et je puis désormais sans problèmes continuer à utiliser mes scripts avec un clic droit.

#5 Re : -1 »  Live Voyager » Le 06/10/2013, à 08:03

roger64
Réponses : 2476
PPdM a écrit :

Les cartouches adaptables sont de la fumisterie, cela reviens bien plus cher a la page que celle d'origine car elles moins de pages et il faut souvent renforcé la densité pour avoir les mêmes couleur et sur les Canon et les Epson ça bouche les têtes d’impressions.

D'accord avec toi. On l'apprend avec l'expérience... En fait, j'ai utilisé avec succès pendant quelques années une imprimante laser avec des toners que je réutilisais. Puis j'ai été contraint de changer d'imprimante (plus compatible) et effectivement je viens d'apprendre que ce n'est pas pareil avec les cartouches...

#6 Re : -1 »  Richard Stallman déconseille Ubuntu à cause de son spyware » Le 14/08/2013, à 17:53

roger64
Réponses : 1035

Bonjour

La première ligne semble un peu lourde: "Permettez-moi de vous remercier.../..." ou mieux, "Je tiens à vous remercier.../..."

Il me semble que l'auteur doit quand même se rappeler s'il lui a, ou non, déjà écrit... smile

#7 Re : -1 »  Richard Stallman déconseille Ubuntu à cause de son spyware » Le 14/08/2013, à 19:19

roger64
Réponses : 1035

Bonjour

Les "salutations les plus respectueuses" tout en faisant double emploi avec "Cordialement" ne sont pas au même niveau stylistique que l'adverbe. La première expression est beaucoup plus formelle. Il y a un choix à faire. ;-)

#8 Re : -1 »  Echecs: Scid et ses fans » Le 30/08/2013, à 17:23

roger64
Réponses : 597

Bonjour

Stockfish 4 a été publié il y a quelques jours. La mauvaise nouvelle est qu'il n'y a plus de version Linux mais une version Android qui ne fonctionne pas sur nos systèmes. J'ai cependant réussi à le compiler facilement en suivant les indications car la version Android est accompagnée du code source placé dans un dossier nommé src.

- Ouvrez un terminal dans le dossier src.

make help

Ceci devrait vous indiquer comment poursuivre. Pour moi, j'ai utilisé:

make build ARCH=x86-64

Puis au retour du prompt,

sudo make install

Il m'a informé que l'exécutable avait été installé sur /usr/local/bin/stockfish

En ouvrant Scid (version 4.10), j'ai créé un nouveau moteur avec ces informations. Dans les paramètres de réglage, j'ai indiqué deux "threads" au lieu d'une puisque mon ordinateur a un double cœur.

Cela fonctionne. smile

Maintenant si quelqu'un a des conseils à donner pour améliorer ceci, il est le bienvenu.

#10 Re : -1 »  Echecs: Scid et ses fans » Le 22/11/2013, à 06:20

roger64
Réponses : 597

L'open source à la fête!!

1385093624.png

Brillante qualification de Stockfish pour la super finale du nTCEC season2. Il y affrontera son plus proche rival Komodo. Les précédents champions ont disparu: Rybka ne s'est même pas qualifié dans les six premiers et Houdini s'est fait proprement étriller par Stockfish au cours de la dernière étape (voir copie d'écran).

Cela faisait longtemps qu'un moteur open source n'avait pas été à pareille fête dans un championnat si relevé. Ses supporters espèrent qu'il ne se ressentira pas trop des efforts consentis et qu'il sera en mesure de gagner la finale. tongue

#11 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 01/12/2013, à 12:17

roger64
Réponses : 250

Bonjour

J'ai vu qu'avec la 4.1 on pouvait désormais lire des polices Open-Type (et leurs ligatures) et incorporer une police dans un document.

La première nouveauté constitue un plus indéniable qui était souhaité depuis longtemps. Je suis plus réservé quant à l'utilité pratique de la seconde.

J'ai fait un essai avec un texte de deux lignes: cela fonctionne mais le document a désormais une taille de 3.2Mo... En fait, il me semble que LibreOffice s'est arrêté à mi-chemin. Il faudrait que l'on puisse incorporer, non la police complète avec ses quatre ou six fontes, mais simplement un sous-ensemble de cette police, contenant uniquement les glyphes contenus dans le document. Cette remarque reste valable même si l'on publie un gros texte (livre).

Il existe des sites en ligne qui le font mais ce n'est pas très pratique à utiliser. Calibre permet de le faire en ligne de commande sur un EPUB. Je ne sais pas s'il cette technique pourrait s'appliquer à un fichier odt. En attendant cela, je crains que l'utilisation de cette nouveauté ne reste limitée qu'à des cas où il est absolument indispensable d'incorporer la police (langues rares et autres cas particuliers de ce genre) alors qu'elle pourrait devenir d'usage courant et nous permettre enfin de sortir de l'usage des polices Microsoft dont nous sommes devenus, bon gré mal gré, dépendants.

#12 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 01/12/2013, à 14:47

roger64
Réponses : 250

Bonjour

Il n'y a rien d'anormal. Il s'agissait de la police Linux Libertine version 5.3 otf qui fait effectivement un peu plus de trois mégas installée sur mon ordinateur (avec les fontes normal, italiques, gras et gras-italiques). Je l'utilise régulièrement en l'incorporant dans mes EPUB mais en tant que sous-ensemble. Elle ne fait plus alors que 400k (avec les fontes normal et italique) ce qui est déjà conséquent mais pas énorme. Il devrait d'ailleurs être possible d'obtenir un sous-ensemble d'une taille encore plus réduite mais il faudrait d'autres outils de création que calibre, du genre InDesign ou autres que je ne connais pas.

Vous pouvez faite l'essai en installant la police en question. La version otf (OpenType) est excellente.

http://sourceforge.net/projects/linuxli … ine/5.3.0/

Il est souhaitable effectivement de ne réaliser un sous-ensemble que pour un texte considéré comme fini, et destiné à la publication. Mais, pour sur un texte courant de type "occidental", on peut sans problème effectuer les corrections orthographiques, etc... Du moins avec la pratique que j'en ai (rassurez-vous, les sous-ensembles créés par calibre sont taillés large!).

#13 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 03/12/2013, à 06:23

roger64
Réponses : 250
Smon a écrit :

C'est la fin des ennuis ! smile

Bonjour

Hélas, non...  smile C'est peut-être le début de la fin des ennuis (ou si vous préférez un pas dans la bonne direction) mais vous ne pourrez utiliser en pratique de "vraie" police (c'est à dire complète) pour les raisons de taille que j'ai données plus haut tant que vous n'aurez pas la possibilité d'incorporer un sous-ensemble.

Ce qui est offert actuellement ne me paraît utilisable que pour des cas particuliers (langues rares, police exotique etc.) mais expliquez-moi comment vous pensez généraliser par exemple l'usage de Linux Libertine dans votre entreprise s'il faut ajouter à chaque document, quelle que soit sa taille, 2 ou 3 Mo supplémentaires? Cela me paraît irréaliste.

Avant que cette "révolution" des polices ne puisse avoir lieu, il sera nécessaire de mettre à disposition des utilisateurs un outil compatible avec LibreOffice capable de générer et d'incorporer un  sous-ensemble de taille raisonnable. Ce n'est pas de la science-fiction: des outils open-source comme calibre disposent de telles fonctions (pour le format EPUB) même s'ils sont à mon avis encore très perfectibles.

#14 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 03/12/2013, à 15:45

roger64
Réponses : 250
JBF a écrit :

bonjour,

Si tu veux généraliser l'usage d'une police précise dans ton entreprise, le plus simple est quand même de la faire déployer sur tous les postes de travail par ton service informatique.

Je n'ai pris qu'un exemple. Pour assurer le respect de la charte graphique de l'entreprise dans ce domaine, il faudra quand même incorporer cette police spécifique dans tous les documents au format odt qui sortiront de l'entreprise même si la police en question est déjà déployée sur tous les postes de travail. Si le format export n'est pas le format odt, le problème est bien sûr différent.

JBF a écrit :

Il me semble que l'intérêt de pouvoir embarquer une police dans un document concerne effectivement seulement les polices exotiques et/ou propriétaires dont on peut supposer que le destinataire du document aura quelques difficultés à se les procurer. Dans les autres cas, il n'est pas compliqué d'installer les polices manquantes. Dans la mesure où on a pris conscience qu'elles manquent ...

On est bien d'accord à ce sujet. C'est pourquoi je dis que ce n'est qu'un premier pas et pas très pratique à ce jour en raison de la taille excessive des polices embarquées. Par ailleurs, à l'exception des polices open-source (ou sous licence libre), on ne peut pas incorporer n'importe quelle police dans un document sans accord de licence, mais là aussi c'est un autre problème...

#15 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 03/12/2013, à 17:23

roger64
Réponses : 250

Bonjour

Il y a beaucoup de polices de ce genre sous licence libre (par exemple les google web fonts  http://www.google.com/fonts). Ces web-fonts sont soit des sous-ensembles de polices complètes soit n'offrent qu'une partie (une fraction dans certains cas) des glyphes d'une police complète. Tout utilisateur peut se créer "sa" web-font en fonction de ses besoins propres - ou plutôt de ceux de son document. J'avais utilisé pour de nombreux livres un sous-ensemble de Linux Libertine avec des web-fonts de 60k chacune (regular, italic, smallcaps). Leur registre d'emploi était  limité à quelques langues occidentales. On peut  par exemple créer des web-fonts sur mesure avec cet outil:
http://www.fontsquirrel.com/tools/webfont-generator

Il faudrait ensuite que l'utilisateur de LibreOffice installe ces web-fonts comme s'il s'agissait de police système pour qu'il puisse les incorporer dans ses documents. Mais j'avoue avoir un peu de peine à renoncer à toutes les possiblités qu'offre une police complète. et cela est d'autant plus vrai dans un cadre professionnel. Si l'on doit publier un document comportant par exemple des mots grecs, il faudrait créer une nouvelle version de ses web-fonts (regular, italic...), les installer pour ensuite les incorporer... Pas très pratique.

Calibre se contente de tailler à grands coups de hache. Le résultat - moyen en termes de réduction de taille - n'est pas ciselé mais on obtient en deux ou trois secondes une police réduite parfaitement utilisable pour le document demandé. On en revient finalement à la possibilité - manquante aujour'dhui avec LibreOffice mais ô combien souhaitée -  de créer pour ses documents un sous-ensemble adapté à partir d'une police complète.

#16 Re : -1 »  Vos avis sur LibreOffice 4.0 (vos tests, suggestions et critiques) ! » Le 08/12/2013, à 02:35

roger64
Réponses : 250

Bonjour

Il suffit de faire une recherche avec les mots "font subset tool" pour trouver de nombreux autres projets de ce genre. Voici à titre d'information un lien vers la bibliothèque opensource d'un projet intialement développé par Google qui permet de créer des sous-ensembles. Il ne s'agit pas de l'outil en tant que tel mais de la bibliothèque permettant de développer - eventuellement - un tel outil.
http://code.google.com/p/sfntly/

Bien entendu, les PDF disposent en interne d'outils de ce genre (quoique moins agressifs me semble t-il, plutôt à la façon de Calibre) depuis très longtemps mais le code reste la propriété d'Adobe.

#17 Re : -1 »  Cinnamon!! » Le 01/09/2013, à 08:31

roger64
Réponses : 438

Bonjour

Vers Cinnamon 2.0

Depuis la sortie de Cinnamon 1.8 au début mai, on attendait la suite. Selon des informations données récemment par Clément Lebebvre sur son blog, la version 2.0 de Cinnamon devrait sortir à temps pour Linux Mint 16 ("Petra") cet automne. Cinnamon devrait alors devenir un environnement de bureau à part entière et gagner son indépendance par rapport à Gnome. Il aura ainsi son centre de contrôle propre, de nouveaux modules de configuration et applets de gestion (user management applets), etc.

UP7 de LMDE

Ces derniers temps, LMDE n'avait pu suivre les mises à jour de Debian testing - qui est maintenant devenu Jessie - à cause de problèmes de compatibilité de Cinnamon 1.8 avec la version 1.36 de gjs (gnome javascript). Ceci a significativement retardé la sortie de l'UP7 sur LMDE. Il semblerait qu'en attendant la solution définitive qu'apportera la sortie de Cinnamon 2.0, une solution d'attente ait été trouvée puisque Clément Lebebvre a annoncé la sortie cette semaine de l'UP7, impatiemment attendue par nombre d'utilisateurs. Il faudra toutefois encore attendre l'UP8 qui suivra Petra pour disposer de nouvelles isos LMDE et d'une solution définitive.

Sous réserve d'inventaire, il semble donc que Cinnamon parviendra bientôt à retrouver son souffle et  cessera d'être à la merci de la moindre mise à jour d'un composant de Gnome.

SolydX

En attendant l'Arlésienne qu'était devenue l'UP7 sur LMDE, j'ai fait un petit test de SolydX, basé sur la version Xfce de Debian testing. SolydX est né après que Linux Mint ait renoncé aux versions Xfce et KDE de Debian testing. La philosophie et les outils de mise à jour en sont étroitement inspirés. On est au goût du jour (kernel 3.9.1) et l'installation se fait sans le moindre problème. À conseiller pour ceux qui veulent tester Xfce dans une version style rolling-release (sans mise à jour semestrielle de nouvelle version mais avec des packs de mise à jour mensuels).

mini_725654SolydX.png

#18 Re : -1 »  Cinnamon!! » Le 24/09/2013, à 09:08

roger64
Réponses : 438

Bonjour

Quelques informations complémentaires sur l'UP 7

L'UP7 (LMDE) a été validée il y a a quelques jours  et est maintenant en place dans tous les dépôts Latest. C'est une mise à jour massive (la précédente remontait quand même à décembre 2012) comprenant de 1200 à 1500 paquets suivant votre installation. En dépit de cela, elle n'est pas accompagnée d'une ISO. Clément Lefebvre en a donné la raison sur son blog à la fin août: Cinnamon est actuellement incompatible avec Gnome Shell. C'est soit l'un, soit l'autre. Il faudra attendre la sortie de Cinnamon 2.0 pour retrouver une version compatible avec Gnome Shell et pour obtenir la nouvelle ISO LMDE. Ceci pourrait arriver en fin d'année, voire en janvier 2014.

Les utilisateurs de Mate, qui ont reçu à la fin août une grosse mise à jour (de 1.4 vers 1.6), devraient également recevoir une nouvelle mise à jour (de 1.6 vers 1.8) à l'occasion de la sortie de cette future ISO.

Cinnamon 2.0 devrait arriver d'abord dans Petra (Linux Mint 16) quelques semaines après Ubuntu 13/10 sur lequel il est en grande partie basé. Le volume restreint de l'équipe de Mint ne lui permet pas de développer simultanément plusieurs versions de sa distribution. D'ici la fin de l'année on verra donc se reproduire le cycle précédent avec les sorties successives de  Petra Cinnamon, Petra Xfce, Petra KDE suivies enfin de LMDE Cinnamon (UP 8).

#19 Re : -1 »  La fondation Apache publie OpenOffice 4.0 » Le 28/07/2013, à 20:25

roger64
Réponses : 16

Bonjour

J'ai les deux suites installées sur mon ordinateur (AOO4 et Libo4.1) qui coexistent pacifiquement (installées à partir de leurs dépôts officiels). LibreOffice a indiqué avoir copié la barre latérale d'AOO mais je ne l'ai pas vu sur la 4.1.

Si vous utilisez AOO4, il se peut que vous ayez des problèmes d'extension car des A.P.I. ont été changées. Ainsi les icônes des extensions ne s'affichent plus comme avant dans la barre des menus, mais on peut parfois encore les lancer à partir de leur macro ou d'un menu déroulant (AltSearch).

#20 Re : -1 »  La fondation Apache publie OpenOffice 4.0 » Le 31/08/2013, à 16:38

roger64
Réponses : 16
malibu a écrit :

salut à tous
j'avais testé apache open office sur windows qui a de suite remplacé libre office (pour des petits détails)
Si j'ai bien compris, pas de dépôts pour ubuntu.
Donc vous l'avez installé à partir du site ( pas de maj auto) ou via un ppa ?

J'utilise AOO v4 après installation directe des debs telechargés depuis le site d'OpenOffice (LMDE 64 bits). Cela fonctionne parfaitement bien. Si vous avez déjà installé OpenOffice avec votre distribution et que vous vouliez faire l'essai en telechargement direct, il me semble qu'il vaudrait mieux désinstaller l'ancienne version et purger le profil.

#21 Re : -1 »  La fondation Apache publie OpenOffice 4.0 » Le 01/09/2013, à 04:50

roger64
Réponses : 16

Bonjour

OpenOffice et LibreOffice peuvent cohabiter sans problèmes. Par contre, il faut éviter d'installer deux versions de la même suite (#deux openOffice, #deux LibreOffice).  smile

#22 Re : -1 »  La fondation Apache publie OpenOffice 4.0 » Le 01/09/2013, à 15:38

roger64
Réponses : 16

Bonjour

Effectivement,  Unity a l'air de compliquer les choses mais il doit bien être possible de créer un lanceur et de le poser quelque part. Ce n'est pas un problème de cohabitation, c'est un problème lié à Unity. Voici à titre d'exemple ce que j'ai avec le menu Cinnamon (LMDE - 64bits), et la cohabitation entre les deux suites est tout à fait pacifique. Il s'agit de deux install faites directement à partir des binaires des deux éditeurs.

mini_245299cohabitation.jpg

Ainsi pour les traitements de texte, les lanceurs mis en place utilisent respectivement:
libreoffice4.1 --writer %U et openoffice4 -writer %U

#23 -1 »  Adaptation d'un script existant vers un fichier ODF (content.xml) » Le 30/08/2013, à 11:23

roger64
Réponses : 0

Bonjour

Il y a quelques mois, j'ai pu mettre au point grâce à l'aide déterminante de Nesthib et Pingouinux un script bash qui permet d'accélérer la correction orthographique des fichiers odt. Cela passe par une transformation préalable - quasiment instantanée - du fichier odt à un format  texte. Le script fonctionne très bien et je l'utilise régulièrement. Tel quel, ce script m'épargne le très processionnel correcteur orthographique d'AOO ou Libo. Le seul inconvénient est que pour corriger les fautes détectées, il y a de fréquentes itérations  (par drag and drop) du fichier texte au fichier odt.

J'ai cependant lu au paragraphe nommé: "The power of script-based ODF processing" qu'il pourait être possible de créer un script travaillant directement sur le fichier xml de l'odt. À l'exploitation des résultats, on n'aurait alors qu'à travailler sur le fichier odt, ce qui faciliterait évidemment  les corrections.

L'auteur: a écrit :

This is possible because an ODF file is just a ZIP archive, with pictures and macros in their own folders and the actual text written, in XML format, inside a file called content.xml. Therefore, in order to create a new, 100% compliant ODF file with different data, tables or images, you only have to open the archive, process the text inside content.xml or put new pictures in their folder if necessary and zip everything again.

Ma question est la suivante: est-il possible de faire ce que fait ce script cité plus haut en le faisant travailler sur le fichier content.xml d'un fichier odt?

#24 -1 »  Ubuntu Edge Phone pour pouvoir utiliser enfin Microsoft Office (cloud) » Le 24/07/2013, à 16:14

roger64
Réponses : 3

Bonjour

Vous m'excuserez de ne pas faire de commentaire, cependant l'intitulé de la nouvelle n'a pas manqué d'attirer mon attention.
Voici l'article -en anglais -, vous verrez que je n'invente rien... 
- ... (insérez ici une réaction vigoureuse)
- Hein? Ah! D'accord, c'est normal, il y a longtemps que ça aurait du être fait. smile

A propos d'Edge, réponse le 21 août pour savoir si, oui ou non, il verra le jour (en fonction du succès ou de l'échec de la campagne de lever de fonds).