Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 24

#0 Re : -1 »  Logiciel de CAO 2D/3D (Conception Mecanique) » Le 27/04/2006, à 14:29

tbonacco
Réponses : 351

Afin d'éviter de compiler OpenCascade, une alternative serait d'utiliser la plateforme SALOME (http://www.salome-platform.org), en cours de développement, dont le composant géométrique est développé à partir de la technologie OpenCascade.

#1 Re : -1 »  Pb à l'installation de matlab » Le 03/03/2006, à 10:07

tbonacco
Réponses : 17

Bonjour,

j'imagine que pour ton TP c'est bien le langage mathlab qu'il ta faut, mais pour info tu peux fa

#2 Re : -1 »  Pb à l'installation de matlab » Le 03/03/2006, à 10:12

tbonacco
Réponses : 17

Bonjour,

pour info :

j'imagine que pour ton TP c'est bien le langage mathlab qu'il ta faut. Par la suite tu peux faire la même chose aussi simplement avec PYTHON. Et tu peux même faire plus de choses. PYTHON c'est libre, c'est gratuit, c'est simple, c'est portable, ça s'interface, c'est largement utilisé dans le calcul scientifique, et ça marche !

Bon courage.

#3 Re : -1 »  Insertion de code HTML dans latex » Le 10/04/2007, à 15:33

tbonacco
Réponses : 6
Malv0iD a écrit :

simple et efficace, merci big_smile

\lstset{numbers=left, tabsize=2, frame=single, breaklines=true, basicstyle=\ttfamily,
   numberstyle=\tiny\ttfamily, framexleftmargin=13mm, backgroundcolor=\color{grey}, xleftmargin=12mm}

\begin{lstlisting}
<html><body>
blabla
</body></html>
\end{lstlisting}

et aussi

\lstinputlisting{monFichier.html}

Et voilà ! C'est aussi simple et efficace !

Sinon, est-ce que quel'un connait les option pour enlever la numérotation ?

Merci.

#4 Re : -1 »  Insertion de code HTML dans latex » Le 10/04/2007, à 16:06

tbonacco
Réponses : 6

Ok j'ai trouvé pour la numérotation, il suffit d'ajouter la ligne suivante avant la morceau de code que l'on ne veut plus numéroter:

\lstset{numers=none}

D'accord, c'est évident. Mais encore fallait -t- il savoir que cela fonctionne.

Pour pikachu, j'ai pas encore essayé ta solution.

J'ai cependant encore un petit souci, c'est lorsque je veux découper mon code comme ça :

mon programme machin il est vachement bien, le spremière 30 lignes c'est comme ça :
\lstset{numbers=left}
\begin{lstlisting}
 if machin :
    alos chose
 chose++
 remove bidule
\end{lstlisting}

Et enfin on voit que les lignes suivantes sont comme ça :

\begin[firstnumber=last]{lstlisting}
 if machin :
    alos chose
 chose++
 remove bidule
\end{lstlisting}

Dans ce cas la numérotation de la deuxième portion de code doit suivre celle de la première. Il se trouve que le premier numéro de la seconde portion et le même que le dernier numéro de la première portion de code. Or j'aimerais que ce soit le même +1.

N'y a -t- il pas un moyen de faire un firstnumer=last+1 ?

Merci.

#5 Re : -1 »  Probleme avec les images gif » Le 30/03/2007, à 20:36

tbonacco
Réponses : 4

Salut,

j'ai le même problème que toi, tu as trouvé une solution ?

En fait, j'ai des gif animé sur firefox, et lorsque je les enregistre sur mon bureau et que je les redépose sur internet, il ne le sont plus... alors je sèche vraiment pour le coup.
C'est la même chose pour mes gif créé avec gimp...

#6 Re : -1 »  Configuration double-écran sur portable » Le 07/02/2006, à 15:10

tbonacco
Réponses : 10

J'ai le même problème pour l'affichage sur un vidéo projecteur.
Moi je voudrais uniquement modifier la fréquence (l'affichage fonctionne)

#7 Re : -1 »  Configuration double-écran sur portable » Le 15/02/2006, à 12:18

tbonacco
Réponses : 10

j'ai pu résoudre le problème en installant l'acceleration 3D ATI.

L'affichage sur double écran fonctionne, l'acceleration 3D aussi. Il y a un seul hic : lorsque je tente de visualiser une vidéo (VLC ou Totem) mon serveur X s'écroule et je dois le relancer à la main.

Je n'ai pu que constater le bug et je n'ai pas encore chercher d'où cela peut-il venir.

Si quelqu'un à une idée je suis preneur.

Je n'ai pas le temps mais je pense repasser bientôt pour déposer mon xorg.conf auquel je n'ai pas encore jeter de coup d'oeil non plus.

#8 Re : -1 »  Gaphor 0.7.1 » Le 13/06/2006, à 17:18

tbonacco
Réponses : 6

A priori il y a un bug avec Dapper qui provient de diacanvas. Pour l'occasion une version peut-être installée à l'ancienne, téléchargeable sur sourceforge (diacanvas2.0  ->  2.0.14.4).

C'est bien dommage Gaphor est pratique pour les diagrammes UML de sources PYTHON.

#9 Re : -1 »  Stellarium : une autre façon de voir l'astronomie ! » Le 08/08/2006, à 13:06

tbonacco
Réponses : 71

Bonjour,

j'ai le même problème de caractère avec Stellarium. Vous avez toujours pas trouvé de solution ?

Merci,

#10 Re : -1 »  Stellarium : une autre façon de voir l'astronomie ! » Le 08/08/2006, à 13:51

tbonacco
Réponses : 71

ReBonjour,

J'utilise une session gnome XGL/Compiz, si je n'utilise plus xgl stellarium reprend ses caractères. Affaire à suivre...

#11 Re : -1 »  xorg & sortie vga » Le 08/02/2006, à 00:00

tbonacco
Réponses : 5

Sur ma machine, SONY VAIO carte ATI X600, j'ai pu le résoudre en installant l'acceleration 3D ATI.

#12 -1 »  Plantage de gaphor sous Dapper [résolu] » Le 04/08/2006, à 15:28

tbonacco
Réponses : 1

Bonjour,
Depuis la migration vers Dapper, gaphor (editeur UML PYTHON) ne fonctionne plus. Le bug est bien connu. J'ai trouvé une alternative qui vaut ce qu'elle vaut, mais elle a le mérite de fontionner.
Lors de l'exécution de gaphor vous avez un message d'erreur qui finit comme ça

...
...
...Traceback (most recent call last):
  File "/usr/bin/gaphor", line 10, in ?
    gaphor.main(model)
  File "/usr/lib/python2.4/site-packages/gaphor/__init__.py", line 48, in main
    import diagram
  File "/usr/lib/python2.4/site-packages/gaphor/diagram/__init__.py", line 56, in ?
    from classifier import ClassifierItem
  File "/usr/lib/python2.4/site-packages/gaphor/diagram/classifier.py", line 18, in ?
    from nameditem import NamedItem
  File "/usr/lib/python2.4/site-packages/gaphor/diagram/nameditem.py", line 9, in ?
    from elementitem import ElementItem
  File "/usr/lib/python2.4/site-packages/gaphor/diagram/elementitem.py", line 74, in ?
    initialize_item(ElementItem)
  File "/usr/lib/python2.4/site-packages/gaphor/diagram/__init__.py", line 39, in initialize_item
    if (diacanvas.CanvasItem in bases) or \
AttributeError: 'module' object has no attribute 'CanvasGroup'

Si l'on fait un tour dans le fichier

/usr/lib/python2.4/site-packages/gaphor/diagram/__init__.py

, on peut supprimer la condition du if qui fait planter :

(diacanvas.CanvasGroup in bases) or \

En attendant quelque chose de mieux ça fonctionne

#13 Re : -1 »  [resolu]Installation de UTF-8 pour LaTeX » Le 16/02/2006, à 00:33

tbonacco
Réponses : 14

Juste une remarque, il est possible de connaitre l'encodage du fichier avec la commande "file", et de changer l'encodage d'un fichier (cela évite d'ajouter des "/usepackage" et d'installer des paquets) avec la commande "iconv" (cf le man très très clair en l'occurence)

#14 Re : -1 »  xgl et sortie télé --> écran noir avec le curseur » Le 05/07/2006, à 11:16

tbonacco
Réponses : 3

J'ai le même proble pour un videoprojecteur

#15 -1 »  probleme de lancement IDLE sous DAPPER[resolu] » Le 16/06/2006, à 15:40

tbonacco
Réponses : 5

Bonjour,

j'ai effectué la mise à jour de breezy vers dapper depuis peu. Je développe des applis en PYTHON. J'ai eu un premier problème avec GAPHOR ( editeur de diagramme UML ) qui ne fonctionne pas sous DAPPER (a priori à cause de diacanvas) et aujourd'hui idle ne se lance pas non plus (. A priori ces bugs sont fixés [url=https://launchpad.net/distros/ubuntu/+source/python-defaults/+bug/24841]ici[url]et [url=https://launchpad.net/bugs/30344]là[url]).

tbonacco@lamachine:~$ idle
Traceback (most recent call last):
  File "/usr/bin/idle", line 5, in ?
    main()
  File "/usr/lib/python2.4/idlelib/PyShell.py", line 1350, in main
    root = Tk(className="Idle")
  File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 1569, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: this isn't a Tk applicationunknown color name "Black"

En fait c'est même carrément Tkinter qui ne fonctionne plus. Quelqu'un a-t-il une solution, meme temporaire à proposer ?

Merci d'avance.

#16 Re : -1 »  probleme de lancement IDLE sous DAPPER[resolu] » Le 22/06/2006, à 12:48

tbonacco
Réponses : 5

Comment faire pour lever Xgl ? Cela ne pose-t- il,pas de problème pour l'accélération graphique ?

#17 Re : -1 »  probleme de lancement IDLE sous DAPPER[resolu] » Le 22/06/2006, à 14:36

tbonacco
Réponses : 5

Ok j'ai trouvé la solution, ce n'est pas Xgl...
dans /etcX11/xorg.conf

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath     "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

La variable RgbPath pointe sur le fichier rgb.txt. Il se trouve que se fichier n'existait pas, mais il était dans /etc/X11/rgb.txt.
JIl suffit de faire un lien symbolique

sudo ln -s /etc/X11/rgb.txt /usr/X11R6/lib/X11/rgb.txt

Et relancer le serveur X

#18 Re : -1 »  probleme de lancement IDLE sous DAPPER[resolu] » Le 22/06/2006, à 17:36

tbonacco
Réponses : 5

J'ai essayé

sudo ln -s /etc/X11/rgb.txt /usr/share/X11/

mais comme RgbPath pointe sur "/usr/X11R6/lib/X11/rgb" cela ne fonctionnait pas dans mon cas.

Pour info je viens d'installer xgl et compiz, je n'ai pas d'erreur. C'était bien un problème de rgb.txt

Merci de ton aide.

#19 Re : -1 »  kile et html » Le 16/02/2006, à 18:46

tbonacco
Réponses : 7

Bonjour,
aurais tu un dépot de latex2html pour ubuntu ?

#20 Re : -1 »  kile et html » Le 21/02/2006, à 11:38

tbonacco
Réponses : 7

Bonjour,

J'ai décommenté mes lignes de dépots "multiverse" mais sans succès. Finallement j'ai téléchargé les sources de latex2htlm sur http://www.latex2html.org/ et je les ai installées en local sur un compte.
Ca fonctionne mais si j'avais le bon dépot ce serait plus propre.
Sinon cet outil (latex2html) est vraiment super ! De belle pages bien pro à porté de click sous kile.

#21 Re : -1 »  kile et html » Le 22/02/2006, à 00:50

tbonacco
Réponses : 7

Autant pour moi, je viens de m'apercevoir que les seuls dépots multiverse que j'avais dans mon sources.list étaient les security.
Merci

#22 Re : -1 »  Probleme de polices et d'accents ... » Le 15/02/2006, à 18:41

tbonacco
Réponses : 4

Même problème... pour le LATEX c'est embétant...

#23 Re : -1 »  Sortie TV sur carte ATI (Breezy + drivers ATI 8.19) » Le 07/02/2006, à 23:57

tbonacco
Réponses : 3

J'avais le même problème qui a été résolu instantannément dès lors que j'ai suivi l'installation de l'acceleration 3D ATI.