Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 -1 »  Installer un serveur Astrometry.net en local » Le 16/07/2017, à 11:09

Saturnin51
Réponses : 2

Bonjour à tous,

astronome amateur, j'ai besoin d'utiliser les fonctions de réduction astrométrique d'Astrometry.net. On peut le faire en soumettant sa photo au serveur en ligne. Mais c'est long et parfois ça plante. J'ai mis plus de 5h pour traiter 336 photos en plusieurs sessions.

Disposer d'un serveur local serait la solution. Dans la documentation en ligne on trouve ceci :

Running on a local machine (your laptop, say)

Prerequisites:

    django
    python-openid
    django-openid-auth
    South
    PIL
    sqlite3
    simplejson

Once you’ve got the code checked out, you need to symlink one of the settings_*.py files to settings.py:

ln -s settings_test.py settings.py

for local testing, settings_test.py is the best bet, since it uses a local sqlite3 database rather than a real external database.

Initialize the database:

python manage.py syncdb
python manage.py migrate

Then you can run the Django web server by running:

python manage.py runserver

And then go to: http://localhost:8000

Pour moi c'est un peu ésotérique. Je n'ai pas de compétences en programmation ou développement. J'ai quand même réussi à installer les pré requis excepté Django-openid-auth, qui semble gérer les accès au serveur.

Une âme charitable pourrait t-elle m'apporter ses lumières ? Je vais avoir plusieurs centaines d'images à résoudre en un lieu ou il n'y aura pas de liaison internet (à partir du 29 Juillet) !

Merci d'avance.

#1 Re : -1 »  Installer un serveur Astrometry.net en local » Hier à 20:52

Saturnin51
Réponses : 2

Désolé ne ne pas avoir répondu mais j'étais parti quelques jours dans la Creuse ! Comme l'installation local serveur est un peu trop velu pour moi, je vais me rabattre sur un script, qui traite la série d'images, que m'a envoyé un collègue du forum Webastro. Merci pour ton aide.

#2 -1 »  [RES] Smartphone non reconnu » Le 03/07/2017, à 11:54

Saturnin51
Réponses : 4

Bonjour,

j'ai un smartphone Acer Liquid Z630S, lorsque je le connecte en USB à mon portable Ubuntu-Mate 16.04LTS, il n'est pas reconnu. Le smartphone demande bien si on autorise bien la connexion USB au PC et c'est tout.

Que faire ? Pas de soucis avec WIn10 !!

#3 Re : -1 »  [RES] Smartphone non reconnu » Le 04/07/2017, à 20:13

Saturnin51
Réponses : 4

Voilà. En ouvrant la notification sur le smartphone de la recharge par USB, je peux choisir le mode MTP ou PTP. Mais ça ne change rien.

robert@robert-PORTEGE-R930:~$ lsusb
Bus 002 Device 003: ID 08ff:168b AuthenTec, Inc. 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 8087:07da Intel Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 0502:384b Acer, Inc. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

#4 Re : -1 »  [RES] Smartphone non reconnu » Le 07/07/2017, à 13:21

Saturnin51
Réponses : 4

Rien de notable dans la doc. on branche, on vérifie qu'on est en MTP et ça fonctionne (sous Windows évidemment). Avec mon fils, on a trouvé une solution en installatn gMTP et QLix qui sont 2 solutions pour les smartphone Android.

Avec gMTP ça fonctionne, à condition d'être patient au moment de la connexion et d l'affichage de la mémoire interne ou de la SD card.

Qlix plante au moment de la connexion.

Je considère mon problème comme résolu. Merci de ton aide

#5 -1 »  Problème graphique au lancement de Stellarium360 » Le 26/06/2017, à 11:30

Saturnin51
Réponses : 7

Bonjour,

je cherche à faire fonctionner Stellarium360 (un logiciel pour planétarium issu de Stellarium http://www.lss-planetariums.info/index. … larium360) sur un Raspberry PI 3 et une Tinker Board Asus. Ubuntu-Mate est le système d'exploitation dans les deux cas. Au lancement du logiciel dans un terminal j'ai un message d'erreur, dont je ne connais pas la signification profonde.

sh: 1: kill: No such process

(EE): SDL Could not create window: Couldn't find matching GLX visual Retrying with stencil size 0
(EE): SDL could not create window even with stencil 0: Couldn't find matching GLX visual

En cherchant sur le web et empiriquement, j'ai trouvé qu'en exécutant au préalable "export SDL_VIDEO_X11_VISUALID=0 le problème semblait résolu. Est-ce un problème de puissance de carte graphique (celle de la Tinker Board est plus récente que celle du Raspberry) ?
J'aimerais avoir des explications sur tout ceci et savoir si pour mon association je pourrais utiliser un Raspberry ou une Tinker Board pour exploiter Stellarium360 avec notre dôme gonflable.

Votre aide est la bienvenue. Merci d'avance.

#6 Re : -1 »  Problème graphique au lancement de Stellarium360 » Le 27/06/2017, à 10:24

Saturnin51
Réponses : 7

Je ne pense pas que ce soit un problème de source ARM. Ce soft tourne sous Linux, point. Je l'ai compilé à partir des sources.

Qu'est-ce qu'un chaînage ARM SVP ?

Sinon avec le paramètre export, le soft se lance et tourne. En 800*600 c'est acceptable alors qu'en 1024*768 c'est saccadé.

Je voudrais comprendre juste le problème et d'où il vient. Merci pour ton aide.

#7 Re : -1 »  Problème graphique au lancement de Stellarium360 » Le 28/06/2017, à 06:13

Saturnin51
Réponses : 7

La compilation s'est faite sur le RPI3 et sur la Tinker Board. Le soft fonctionne avec cet export SDL_.....

#8 Re : -1 »  Problème graphique au lancement de Stellarium360 » Le 29/06/2017, à 14:19

Saturnin51
Réponses : 7

Je crains que ce ne soit largement au delà de mes capacités ! Merci pour les infos.

#9 -1 »  [RES] Positionnement des fenêtres » Le 28/06/2017, à 14:39

Saturnin51
Réponses : 3

Bonjour,

j'ai une fenêtre d'un HDD USB externe qui s'ouvre systématiquement lors d'une nouvelle session. Comment empêcher son ouverture ou bien y-a-t-il moyen de la repositionner au milieu de l'écran. En effet elle s'ouvre avec sa barre cachée sous la barre de menu de Mate. Je sais la repositionner mais  j'aimerais une solution définitive. Merci d'avance.

#10 Re : -1 »  [RES] Positionnement des fenêtres » Le 28/06/2017, à 17:19

Saturnin51
Réponses : 3

Merci à tous les deux. La solution de erresse me convient.

#11 -1 »  [RES] Problème avec le dernier update » Le 20/06/2017, à 11:07

Saturnin51
Réponses : 2

Bonjour,

lors du dernier update, après mise à jour du système par le gestionnaire de MAJ, j'ai l'erreur suivante à la fin de l'update (qui concerne principalement Kstars-bleeding sur le ppa:mutlaqja/ppa).

Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libgphoto2-port12_2.5.9-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et je me retrouve avec des paquets cassés:
- libgphoto2-6:i386
- libsane:i386
- wine 1.6-i386:i386

Que se passe-t-il SVP ?

#12 Re : -1 »  [RES] Problème avec le dernier update » Le 20/06/2017, à 11:18

Saturnin51
Réponses : 2

Voilà:

robert@M11AD:~$ sudo apt full-upgrade
[sudo] Mot de passe de robert : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libgphoto2-6:i386 : Dépend: libgphoto2-port12:i386 (>= 2.5.9) mais il n'est pas installé
 libsane:i386 : Dépend: libgphoto2-port12:i386 (>= 2.5.9) mais il n'est pas installé
 wine1.6-i386:i386 : Dépend: libgphoto2-port12:i386 (>= 2.5.9) mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f

J'ai vérifié avec Synaptic. Il n'y a pas de libgphoto-port12:i386 mais seulement un libgphoto2-port12 installé.

J'ai continué mes explorations. Il y a une incompatibilité à propos de libgphoto2-port12 avec Wine. Si je n'installe pas Wine, le reste va bien !! Insatisfaisant quand même, car j'utilise Wine normalement.

#13 -1 »  Barre de menu sur deuxième écran » Le 24/05/2017, à 14:21

Saturnin51
Réponses : 2

Bonjour,

après une recherche infructueuse je pose la question. Y-a-t-il moyen de disposer des barres de menu et de taches sur le deuxième écran de ma config, en mode affichage étendue comme sur l'écran principal ?

#14 Re : -1 »  Barre de menu sur deuxième écran » Le 26/05/2017, à 11:17

Saturnin51
Réponses : 2

J'utilise Ubuntu-Mate et il n'y a pas d'option en ce sens. Merci.

#15 -1 »  [RES] Relier 2 PC par câble Ethernet » Le 24/04/2017, à 21:24

Saturnin51
Réponses : 4

Bonjour,

j'ai fait des recherches sur le sujet sans avoir vraiment trouver de solution.

J'ai un Raspberry PI3 et un portable, tous les deux sous Ubutun-Mate 16.04.1LST.
Sur le RPI3 est lancé un serveur de périphériques USB.
Sur le portable je dois y accéder à l'aide d'une page internet par l'adresse IP du RPI3 et un numéro de port spécifique.
J'ai besoin d'un débit assez élevé pour transférer des images prises par APN du RPI3 sur le portable.

Comment puis-je établir le lien nécessaire avec un câble Ethernet ?

J'ai essayé de le faire comme suit, mais sans résultat:
- Avec un câble droit ou un câble croisé
- en IPv4, lien local uniquement sur les deux machines

Par un ping sur l'adresse des machines, j'ai bien la communication entre les deux machines.
La connexion au serveur de périphériques ne s'établit pas. Pourquoi ?

#16 Re : -1 »  [RES] Relier 2 PC par câble Ethernet » Le 24/04/2017, à 23:37

Saturnin51
Réponses : 4

Quelques précisions supplémentaires SVP ! Je ne suis pas familiarisé avec SSH.

#17 Re : -1 »  [RES] Relier 2 PC par câble Ethernet » Le 10/05/2017, à 10:35

Saturnin51
Réponses : 4

Merci. Problème résolu.

#18 -1 »  [RES] Erreur lors d'un update » Le 09/05/2017, à 02:08

Saturnin51
Réponses : 6

Bonjour,

lors d'un update sur mon portable, ça se termine pas de nombreuses lignes d'erreurs, que je ne sais pas résoudre.

 Lecture des listes de paquets... Fait
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
E: The repository 'http://download.tuxfamily.org/ekdforum/ekd xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fr_FR) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fr) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:45 and /etc/apt/sources.list.d/xenial-partner.list:4

Merci de m'éclairer sur ce qu'il y a lieu de faire.


Modération : merci à l'avenir d'utiliser les balises code (explications ici).

#19 Re : -1 »  [RES] Erreur lors d'un update » Le 09/05/2017, à 15:01

Saturnin51
Réponses : 6

Voilà: May  9 2017, bisnext report id 718a7 also available at https://paste.debian.net/931584/

#20 Re : -1 »  [RES] Erreur lors d'un update » Le 09/05/2017, à 19:31

Saturnin51
Réponses : 6
cat /etc/apt/sources.list.d/xenial-partner.list
# channel for the xenial (16.04) partner channel
# 
#:description:This channel contains the partner software for xenial
deb http://archive.canonical.com/ubuntu xenial partner

J"ai supprimé la ligne EKD.

#21 Re : -1 »  [RES] Erreur lors d'un update » Le 10/05/2017, à 10:34

Saturnin51
Réponses : 6

C'est réparé. Merci de votre aide. A+.

#22 -1 »  [RES] Désactivation de la caméra du portable » Le 01/05/2017, à 13:54

Saturnin51
Réponses : 2

Bonjour,

sur mon Toshiba Portege R930, j'ai une webcam intégré. J'ai besoin de la désactiver. Comment puis-je le faire SVP ?

Ubuntu-Mate 16.04.2LST

#24 -1 »  [RES] Ré installation Ubuntu-Mate 16.04.1LST » Le 14/04/2017, à 09:39

Saturnin51
Réponses : 0

Bonjour,

j'ai ré installé mon système Ubuntu-mate en conservant mon répertoire /home. Je me retrouve sans carte son, alors qu'elle était fonctionnelle précédemment. Embêtant pour un musicien comme moi !

Je précise que c'est une installation non EFI. D'autres précisions vous sont-elles nécessaires ?

Après un update/upgrade tout est rentré dans l'ordre.