Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 12

#0 Re : -1 »  [IMPORTANT] Vieilles cartes ATI et pilote proprio » Le 18/12/2009, à 12:16

Fiabulu
Réponses : 441

Les nouveaux pilotes Catalyst 9.12 pour Linux sont sortis mais cela ne règle pas le problème...

- les catalyst 9.12 ne sont pas faits pour fonctionner avec les vieilles cartes X1xxx (entres autres).
- Ubuntu 9.10 (et 9.04) ne supportent plus les drivers catalyst antérieurs (9.3 par exemple)

Question:
Les tristes propriétaires de cartes graphiques un peu obsolètes peuvent-ils espérer un résolution de ce problème pour la prochaine LTS d'Ubuntu?

Les solutions ne sont pas nombreuses (enfin de mon point de vue smile ): soit ATI réintègre dans ses futurs pilotes la capacité à gérer les anciennes cartes soit les développeurs d'Ubuntu font en sorte qu'il soit possible d'utiliser des drivers ati un peu vieillots...

#1 -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 19/11/2009, à 15:07

Fiabulu
Réponses : 14

Bonjour,

Je suis un tout jeune utilisateur d'Ubuntu et j'ai quelques problèmes.

J'ai choisi d'installer la version 9.10 ( tout en gardant Windows XP) et l'installation s'est plutôt bien passée.

Le problème est le suivant: la définition de mon écran n'est pas adaptée au lieu de 1440*900 il me propose 1024*768 et c'est pas tip top. (ma carte graphique est une ATI mobility radeon X1800)

J'ai déjà cherché une réponse sur le forum et j'en ai déduit que le problème venait des pilotes.
Lorsque j'édite mon fichier xorg.conf, le driver utilisé est "vesa". Apparemment c'est le pilote de base, ce qui expliquerait pourquoi je ne peut choisir la bonne résolution.

J'ai donc suivi diverses méthodes de ce site pour prendre de "meilleurs" pilotes. J'ai donc tenté les choses suivantes:

installer les pilotes propriétaires (catalyst). Cependant, il semblerait qu'il y ait des problèmes avec la version 9.10 d'ubuntu. L'application de patch est nécessaire ce que je n'ai pas su trop faire.

après réflexion que la 3D ne m'est pas utile, des pilotes moins "performant" me combleront totalement, j'ai donc regarder vers les pilotes libres radeon et radeonhd.

j'ai donc télécharger les paquets radeon et radeon hd vie le gestionnaire de paquets et j'ai modifié mon fichier xorg.conf en conséquence.

cependant dans les deux cas; lorsque je lance ubuntu, j'obtiens un écran noir.

ma question est la suivante: pourquoi ai-je un écran noir lorsque je veux utiliser les pilotes libre radeon ou radeonhd

merci d'avance

#2 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 19/11/2009, à 15:21

Fiabulu
Réponses : 14

merci de me répondre aussi rapidement. Lorsque je tape la première ligne de commande du post ci dessus dans un terminal j'obtiens le message suivant:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet –purge

j'ai essyé d'installer un paquet contenant purge mais cela ne fonctionne pas. Quel paquet dois-je installer?

#3 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 19/11/2009, à 17:22

Fiabulu
Réponses : 14

Le problème n'est toujours pas résolu.

Je me connecte en mode root (au lancement je choisis recovery mode et ensuite je sélectionne root dans le menu)

je tape:
apt-get remove -purge fglrx*

j'obtiens comme message:
E:command line option 'p' [from -purge] is not know

une idée?

merci d'avance

#4 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 19/11/2009, à 21:32

Fiabulu
Réponses : 14

Bon, cela ne fonctionne toujours pas!

j'ai effectué la manip suiavnte:

dans un terminal:
sudo apt-get remove -–purge fglrx*
sudo apt-get remove -–purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati

(je fais cela, car je n'arrive pas a me connecter au net en mode recovery)
puis en mode recovery:
X -configure
cp /root/xorg.conf.new /etc/X11/xorg.conf

et je reboot.

le résultat est que j'arrive à l'écran ou normalement j'entre mon mot de passe. Et la il n'y a que l'image de fond, le petit rectangle ou est le nom d'utilisateur et ou je dois entrer mon mot de passe est un rectangle noir. Lorsque j'entre mon mote de passe " a l'aveuglette", cela fonctionne mais ensuite seule l'image de fond reste et cela rest comme cela, je ne peut plus rien faire..

j'avoue que c'est pas drole.. si c'est déja arrivé a qulqu'un..

#5 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 20/11/2009, à 12:03

Fiabulu
Réponses : 14

Ok merci je vais essayer tout ça!

#6 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 02/12/2009, à 15:12

Fiabulu
Réponses : 14

Bon, après un ptit moment ou j'ai rien pu testé, je suis revenu à la charge ce matin et les résultats ne sont pas au rdv!

j'ai essayé plein de trucs, mettre le résolution de mon écran dans le xorg, ce que je ne comprend pas c'est que quand je mets vesa en pilote, cela fonctionne. Des que je mets radeon ou radeonhd: écran noir

si quelqu'un a des pistes... je suis preneur

sous windows (je suis en dual boot) j'ai deux cartes graphiques qui sont présentes. cela ne pourrait-il pas venir de la?

merci d'avance

#7 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 12/12/2009, à 18:52

Fiabulu
Réponses : 14

Bon après une semaine ou j'ai laissé mon pc de coté, je suis revenu à la charge cet aprem pour utiliser les pilotes radeonhd: pas réussi.

Je récapitule: je possède une ATI mobility X1800 qui est normalement compatible avec les pilotes radeonhd.
j'ai essayé un nombre impressionnant de manipulations... en désespoir de cause j'ai même essayé de passé à la toute nouvelle beta 10.4, sans succés, j'ai remis la 9.10 en essayant d'utiliser les dernières versions des pilotes radeonhd (en utilisant GIT): sans succès. La je suis à nouveau sans idées et un peu démotivé et je me tourne vers vous:
-une personne a-t-elle une ati x1800 sous ubuntu 9.10?
-y a t-il un spécialiste des radeonhd?


je rappelle le probleme: lorsque j'utilise les radeonhd, lors du démarrage, j'arrive à l'écran ou il faut rentrer son nom d'utilisateur et la la barre en bas et la "fenetre" ou il faut entrer les infos sont des rectangles noirs.

cependant, lorsque je clique " à l'aveugle" je peux par exemple entrer mon mot de passe!

#9 Re : -1 »  Problème écran noir ubuntun 9.10 ati X1800 » Le 17/12/2009, à 12:51

Fiabulu
Réponses : 14

Bon je n'ai pas résolu le problème je l'ai évité...

En fait je pense qu'il y a un problème particulier avec ma configuration (fujitsu amilo XI 1546, ati mobility radeon X1800).
En effet, après avoir essayé et essayé, bidouiller, réinstaller complètement Karmic, j'ai décidé de passer à une autre version d'ubuntu (la 8.10)
cependant, gros problème pendant l'install: écran noir, impossible de faire quoi que ce soit (même en modifiant les options avec F4 et F6)
donc j'ai abandonné, télécharger la 8.04 (installation nickelle) pour upgrader vers la 8.10.

Et je confirme: la 8.10 fonctionne bien, je suis un néo-linuxien heureux smile

(mais vivement la prochaine LTS quand même qui j'espère focntionnera....

#10 -1 »  Modification du nom d'utilisateur après update grub » Le 12/12/2009, à 15:46

Fiabulu
Réponses : 2

Bonjour

depuis plusieurs jours je me bat avec mon xorg pour réussir à fonctionner avec les pilotes libres radeonhd. Une manip que j'ai pu lire sur un forum était de rajouter une option dans le menu.lst. Cependant comme j'ai ubuntu 9.10, j'ai le grub 2 et je n'ai pas le menu.lst. Il faut donc modifier le grub, ce que j'ai fait. Cela ne m'a d'une part pas résolu mon problème, mais cela m'en a apporté un autre: mon nom d'utilisateur a été modifié!

Très étrange, c'est mon nom d'utilisateur windows qui a été pris. le mot de passe n'a pas été changé.

Tout d'abord est ce que quelqu'un aurait une explication logique et surtout une solution simple pour revenir à mon ancien nom d'utilisateur?

merci

#11 Re : -1 »  Modification du nom d'utilisateur après update grub » Le 12/12/2009, à 18:34

Fiabulu
Réponses : 2

bon en fait j'en ai eu marre j'ai tout réinstaller 9.10. Aucune solution ne fonctionnait.

merci pour votre aide.

maintenant je me reconcentre sur mon principal problème: l'utilisation des drivers radeonhd sad