Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Nouveau site sur les logiciels libres "mature" » Le 06/05/2012, à 02:48

danydube
Réponses : 4

Salut à tous,

Je viens de lancer un nouveau site web dédié sur les logciels libres "mature" pour Linux Ubuntu.

Le site s'adresse aussi bien aux particuliers qu'aux entreprises.

Pour l'instant, une vingtaine de programmes y est présenté mais j'y ajoute un ou deux programme par semaine.
Vous y trouverez plusieurs informations pratiques comme une section didacticiels, une section commandes terminal et une section licences.

Seuls les programmes dits "matures" y sont présentés.

Je vous invite à y jeter un coup d'oeil.

http://www.librogiciel-linux.net

#1 -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 19/04/2009, à 23:03

danydube
Réponses : 7

J'ai réalisé des vidéos sous Linux Ubuntu (et pour Ubuntu) pour montrer comment utiliser tel ou tel logiciel.
Je me suis dit que la meilleure façon d'apprendre pour un débutant est de voir en vidéo.
J'ai réalisé tout ça avec le logiciel recordmydesktop.

Toutes les vidéos sont sur youtube et en haute définitions (HD).
Une loupe est activé dans chacune de mes vidéos afin de mieux voir le curseur de ma souris vous évitant ainsi d'agrandir l'image de la vidéo. Néammoins, il est préférable bien sûr de regarder mes vidéos en HD pour une meilleure lisibilité.

D'autres vidéos s'ajouteront dans ma liste. Jusqu'ici, j'en ai cinq.

http://www.youtube.com/view_play_list?p=23D13D27D76ED4FE


P.S.: Certains vidéos m'ont pris beaucoup de reprises afin d'en arriver au résultat souhaité. J'ai dû recommencer plusieurs fois (jusqu'à 10 fois) pour de multiples raisons: oublier de dire ceci ou cela, oublier de cliquer à tel endroit, durée trop longue, trop technique dans mes termes, oublier de cacher certains éléments "personnels" dans ma vidéo, etc.

#2 Re : -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 19/04/2009, à 23:39

danydube
Réponses : 7

Salut Spirzouf,

Merçi pour tes commentaires.

- à moins que je ne me trompe, les codes sources ne sont pas intéressants pour un débutant ?

Oui en règle général, les dépôts sources ne sont pas vraiment essentiel pour un débutant. Mais je me suis dit que le fait d'activer ces dépôts, cela pourrait servir à plus tard. Le fait de les cocher n'impliquent pas de risques au système. Dans une prochaine vidéo, je vais montrer les options avancées de Synaptic.

faut il vraiment conseiller les dépôt backports, qui je croient comportent des versions logicielles instables

La plupart des logiciels que j'ai pû tester jusqu'ici, présente une très bonne stabilité. Mais oui, officiellement parlant, tu as raison. Ces logiciels sont classés comme instable.

je ne me souviens plus si medibuntu est "cochable" où s'il faut l'ajouter manuellement dans synaptic. S'il n'est pas cochable, ce serait bien de montrer comment l'ajouter manuellement, car pour le coup, ce dépôt me parait vraiment indispensable.

Dans une prochaine vidéo, je vais montrer comment ajouter des dépôts manuellement. Malheureusement, je n'ai pas pû la montrer dans cette vidéo car je ne devais pas dépasser les 10 minutes qu'exige youtube pour une vidéo. Et je me devais ne dire que le principal ou l'essentiel si on veut.

#3 Re : -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 20/04/2009, à 14:59

danydube
Réponses : 7

À silv_elo,

"...Après, ça reste une idée..."

Une très bonne idée quand même. En effet, quand j'aurai plus de vidéos, je vais créer un dvd de salon soit avec le logiciel Devede ou ManDvd (pour la création de menus, il est meilleur que Devede). Ensuite, faudrait que je trouve un moyen de diffuser ce dvd sur le net. Je suis en train de regarder une procédure de serveur torrent. Ça avance bien jusqu'ici.

D'ici là, j'envoie mes vidéos sur youtube. La qualité des vidéos sur youtube est quand même très bonne sans exagérer. En mode HD c'est excellent surtout si on appuie sur le bouton HD d'abord puis en mode plein écran. Et puis, tu peux télécharger les vidéos au format FLV (format flash) avec l'extension DownloadHelper sous Firefox https://addons.mozilla.org/fr/firefox/addon/3006

#4 -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 19/04/2009, à 23:18

danydube
Réponses : 5

J'ai réalisé des vidéos sous Linux Ubuntu (et pour Ubuntu) pour montrer comment utiliser tel ou tel logiciel.
Je me suis dit que la meilleure façon d'apprendre pour un débutant est de voir en vidéo.
J'ai réalisé tout ça avec le logiciel recordmydesktop.

Toutes les vidéos sont sur youtube et en haute définitions (HD).
Une loupe est activé dans chacune de mes vidéos afin de mieux voir le curseur de ma souris vous évitant ainsi d'agrandir l'image de la vidéo. Néammoins, il est préférable bien sûr de regarder mes vidéos en HD pour une meilleure lisibilité.

D'autres vidéos s'ajouteront dans ma liste. Jusqu'ici, j'en ai cinq.

http://www.youtube.com/view_play_list?p=23D13D27D76ED4FE


P.S.: Certains vidéos m'ont pris beaucoup de reprises afin d'en arriver au résultat souhaité. J'ai dû recommencer plusieurs fois (jusqu'à 10 fois) pour de multiples raisons: oublier de dire ceci ou cela, oublier de cliquer à tel endroit, durée trop longue, trop technique dans mes termes, oublier de cacher certains éléments "personnels" dans ma vidéo, etc.

#5 Re : -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 19/04/2009, à 23:46

danydube
Réponses : 5

À Grant_Grunt,

Oui en effet, j'essaie d'envisager une solution pour partager mes vidéos mais comme ils sont lourd (ils sont en HD n'oublions pas), ma bande passante pour mon upload est malheureusement très limité (10 gigs par mois). Néammoins, je vais essayer de les stocker sur un serveur et voir ce que ça donne comme partage.

En cas d'urgence, si tu as un serveur chez toi, tu pourrais me donner les coordonnées afin que j'upload les fichiers en question.

#6 Re : -1 »  Vidéos didactiques sur Ubuntu en français ! » Le 19/04/2009, à 23:51

danydube
Réponses : 5

À Wido,

-comment installer une application (deux options synaptics ou ajouter/supprimer de programme) (niveau débutant), installation d'un .run , .deb via le web (niveau intermédiaire),
-comment extraire un cd audio (sound juicer) en ogg
-comment utiliser OOO (deux,trois exemples de présentation)
-comment communiquer avec des logiciels de messagerie (pidgin,amsn,...)

Merçi pour tes suggestions Wido. Très bonnes idées. J'en ai pris note. Ce serait en effet interessant de faire des vidéos sur OpenOffice, SoundJuice, installation des applications des deux méthodes et Pidgin.

#7 -1 »  Site de trucs et astuces pour Ubuntu » Le 17/01/2009, à 22:57

danydube
Réponses : 6

Salut à tous les Ubuntutistes !

Je trouve ces forums vraiment très pratiques et cela fait très longtemps que j'y viens y jeter un coup d'oeil. Une vrai mine d'informations utiles pour tout utilisateur Ubuntu.

Cela m'a donné l'idée de parler ici de mon site web que j'ai créé en 2007. En fait, ce site web est un blogue entièrement consacré sur Linux Ubuntu. J'y présente des articles sur différents logiciels Libres (avec captures d'écrans) mais aussi des trucs et astuces de toutes sortes. En moyenne, un article par semaine, quelque fois plus. De plus, une section de liens utiles sur la documentation et autres sites web y sont également présentés.

J'en profite pour parler de mon site ici, histoire d'augmenter mon traffic web. Jusqu'ici, plus de 120 personnes par jour visites mon blogue.

Je vous y invite à venir visiter mon blogue à l'adresse suivante :

http://astuces-ubuntu.blogspot.com/

N'hésitez pas à me laisser des commentaires au besoin.

Bienvenue à tous et à toutes !

#9 -1 »  Problème avec le flash dans Firefox avec le LiveCd Final de Gutsy » Le 19/10/2007, à 03:39

danydube
Réponses : 4

J'ai téléchargé et tester la Gutsy LiveCD version final, donc le 18 octobre. Excellente version et tout ce que j'ai pu tester fonctionnait très bien: son, video, synaptic, console, accès au disque dur, internet, etc.

Mais voilà. Avec firefox (2.0.0.6), sur le site de YouTube, Firefox me demande de choisir entre deux plugins flash: Adobe Flash player et Gnash. Je choisis donc le premier car étant plus connu. Il télécharge le plugin via apt-get avec succès mais lors de l'install, il se produit une erreur fatal mais vraiment fatal. La fenêtre d'erreur dit qu'il y a erreur de script (qu'il n'affiche pas d'ailleurs). Firefox fonctionne toujours mais sans flash. De plus, apt-get (en console) de même synaptic sont devenus inutilisables. Bloqués. Dans les deux cas, ils proposent de faire dpkg --configure -a. Je ne peux donc ni installer ou désinstaller quoi que ce soit (en console ou avec synaptic).

Même après avoir taper dpkg --configure -a, rien à faire non plus.

J'ai vérifié sur launchpad Ubuntu mais je n'ai rien vu sur ce bogue là. À moins que ce problème n'existe que sur la version desktop et non sur l'alternate. Je n'ai pas encore installé Gutsy sur mon système car je préfère attendre encore un peu (un mois ou deux). Présentement, j'utilise la 7.04.

Alors, je me demandais si quelqu'un avais eu ce genre de problème avec les plugins flash dans Firefox sur la version LiveCD de la 7.10. Si oui, alors je pourrais en faire un rapport de bogue sur Launchpad.

Il faut que je dise au final qu'avant le crash de apt-get (dû au plugin flash je crois), j'ai pu auparavant avec succès télécharger et installer plusieurs paquets via Synaptic.

#10 Re : -1 »  Problème avec le flash dans Firefox avec le LiveCd Final de Gutsy » Le 19/10/2007, à 12:26

danydube
Réponses : 4

Ok très bien merçi pour vos réponses.

Oui c'est vrai smo. Il vaut mieux l'installer manuellement en téléchargeant le fichier .tar.gz de flash du site Macromédia.

#11 -1 »  Marque-page automatique avec Evince et Gedit » Le 14/10/2007, à 15:15

danydube
Réponses : 1

Ce n'est pas une astuce mais plutôt une observation.

Ouvrez un fichier PDF quelconque avec Evince (celui par défaut dans Gnome). Allez à la page 5 de votre document (mais ce peut être n'importe quel page). Fermer Evince. Puis cliquer sur le même fichier PDF ouvert précédemment. La dernière page vue dans le document s'affichera big_smile
Très pratique quand on lis un roman de plusieurs centaines de pages sans être obligé de noté la dernière page lue. Evince note en mémoire chaque dernière page affichée et ce, pour chaque fichier PDF qui a été ouvert.

Le même principe se fait aussi dans Gedit (l'éditeur de texte par défaut dans Gnome) mais se fait avec le curseur. Il faut en fait positionner votre curseur sur une page voulu. Fermer Gedit.
La prochaine fois que vous aller ouvrir votre document texte, cette même page marqué de votre curseur s'affichera.

Remarquer que cela fonctionne même après un redémarrage de votre ordi.


Personnellement, je ne sais pas à quel fonctionnalité Evince (ou Gedit) fait appel pour retenir une page automatiquement. Où retient-il ces "mémoires-pages" ? Est-ce une fonction spéciale de Gnome ? La question reste posé...Mais c'est juste par curiosité, hein...

Mais il y a peut-être d'autres applications qui font de même ou qui font appel à une fonction de "mémoire-page".

J'utilise Ubuntu 7.04...bientôt 7.10

Juste comme ça en passant, je n'ai pas trouvé d'équivalent semblable dans Windows roll

#12 -1 »  [résolu] Petit problème avec Zabbix.... » Le 02/05/2007, à 23:52

danydube
Réponses : 7

Salut à tous !

J'ai décidé de testé le serveur Zabbix (sous Edgy), un moniteur de PC pour surveiiler un parc informatique.

Zabbix utilise MySql. Après avoir installé MySql et créer un utilisateur root et son mot de passe, tout est OK.

J'ai suivi la procédure sur le site ubunt-fr (http://doc.ubuntu-fr.org/zabbix) mais quand je veux afficher la page de Zabbix (http://localhost/zabbix/), j'obtien le message d'erreur suivant de la part de MySql :

Fatal error: Call to undefined function mysql_pconnect() in /usr/share/zabbix/include/db.inc.php on line 32

J'y ais mis tout les droits au fichier ci-haut mais rien n'y fait. J'ai sûrement oublié quelque chose mais quoi ? C'est peut-être bête de ma part....

#13 Re : -1 »  [résolu] Petit problème avec Zabbix.... » Le 04/05/2007, à 12:43

danydube
Réponses : 7

A Brice Favre.

Oui j'ai bien php5-mysql et aussi php4-mysql d'installés. La librairie Mysql.so est chargé...enfin je crois...voici une partie du fichier php.ini de php5-mysql :

;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
;
; If you wish to have an extension loaded automatically, use the following
; syntax:
;
;   extension=modulename.extension
;
; For example, on Windows:
;
;   extension=msql.dll
;
; ... or under UNIX:
;
;   extension=msql.so
;
; Note that it should be the name of the module only; no directory information
; needs to go here.  Specify the location of the extension with the
; extension_dir directive above.


; Example lines:

extension=mysql.so
extension=gd.so

;;;;;;;;;;;;;;;;;;;

J'ai regardé la ligne 32 de la ligne d'erreur affiché ci-haut et et cela donne:

$DB=mysql_pconnect($DB_SERVER,$DB_USER,$DB_PASSWORD);

Il semble que ce soit au niveau de la connection de Mysql que vient l'erreur (de la part de Zabbix).

En tant qu'utilisateur, j'ai déclaré root dans mysql. Dans une console, je peux me connecter sans problème dans Mysql (mysql -u root -p).

Et je peux voir la base de données Zabbix qui a été créé manuellement auparavant.

Je vais continuer mes recherches...

#14 Re : -1 »  [résolu] Petit problème avec Zabbix.... » Le 05/05/2007, à 02:38

danydube
Réponses : 7

J'ai bien réinstallé le paquet zabbix-server-mysql (avec les mêmes mots de passe de configuration) mais toujours la même erreur de ligne de code tel que mentionnée ci-haut.

#15 Re : -1 »  [résolu] Petit problème avec Zabbix.... » Le 06/05/2007, à 23:42

danydube
Réponses : 7

Bon. Alors là...je ne comprend plus rien. Après avoir redémarré mon ordi sous Ubuntu, j'ai ré-ouvert la page locale http://localhost/zabbix/ et tout était presque en ordre...mise à part le mot de passe qu'il fallait inscrire dans le fichier /etc/zabbix/dbconfig.php

Et la page d'accueil de Zabbix est apparu. Cependant, il me faudra lire la documentation zabbix pour savoir comment afficher les graphiques de l'ordi et des odinateurs locaux. En somme, zabbix est moins intuitif que je ne le croyais. D'autant plus que ce dernier à surtout été développé pour Windows d'abord. Pour la version Linux, zabbix est un mélange de binaires et de fichiers php.

Mais en somme, zabbix me semble très intéressant pour gérer un parc informatique.

#16 Re : -1 »  [Resolu]fichiers flv en avi ou autre » Le 23/03/2007, à 03:27

danydube
Réponses : 7

Voici pour ta commande :

ffmpeg -i fichiervideo.flv -vcodec rawvideo -s 320x240 -acodec pcm_s16le -ac 2 -b 64 -f avi fichiervideo.avi

Pour ma part, je fais beaucoup de conversion .flv en .avi comme suit:

ffmpeg -i /media/hda6/Win_vs_Linux.flv -f avi -target ntsc-dvd -b 500 WinvsLinux.avi

Cela donne d'excellent résultat. Le fichier en sortie n'est pas exagérément trop lourd: dans mon exemple ci-haut, mon fichier source pèse 16 megs et le résultat en sortie ne fait que 32 megs !! Le double, quoi. De plus, avec cette commande, cela me facilite la conversion pour mettre la video en format DVD de salon.

-b 500 veut dire bitrate ou qualité d'encodage en bit par seconde. Commence par faire des tests avec une bitrate de 200 puis monte le chiffre si la qualité de ton fichier ainsi créé ne te satisfait pas. Dans ton cas, tu peux remplacer -target ntsc-dvd par -target pal-ntsc (25 images seconde) pour la France. Moi je réside au Québec (NTSC donc 29.97 images seconde).

Voilà. J'espère que cela t'aidera.

#17 -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 00:24

danydube
Réponses : 8

Salut à tous !

J'utilise Ubuntu Dapper 6.06.1 et j'avais OpenOffice 2.0.2 en français d'installé. J'ai voulu installer OpenOffice 2.0.3 mais sur le site officiel, OpenOffice pour Linux est disponible seulement en format RPM.
J'ai suivi la procédure sur le site Ubuntu.fr pour la conversion des RPM en DEB avec Alien (alien -d *.rpm). Tout s'est bien passé. Mais incapable d'exécuter OpenOffice 2.0.3 qui est installé dans le répertoire /opt.

Bon. Alors, j'ai essayé de désinstallé OpenOffice 2.0.3 mais sans succès (que ce soit avec Synaptic ou en ligne de commande). Ensuite, j'ai re-téléchargé OpenOffice 2.0.2 avec Synaptic. Mais impossible d'installer OpenOffice 2.0.2.

En ligne de commande de commande j'ai fait apt-get install ubuntu-desktop . Ubuntu-desktop est dépendant de OpenOffice 2.0.2. Voici l'erreur affiché :

Après dépaquetage, 146Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://security.ubuntu.com dapper-security/main openoffice.org-common 2.0.2-2ubuntu12.1 [26,4MB]
Réception de : 2 http://fr.archive.ubuntu.com dapper-updates/main ubuntu-desktop 0.120 [13,9kB]
Réception de : 3 http://security.ubuntu.com dapper-security/main openoffice.org-core 2.0.2-2ubuntu12.1 [29,7MB]
Réception de : 4 http://security.ubuntu.com dapper-security/main openoffice.org-java-common 2.0.2-2ubuntu12.1 [2405kB]
Réception de : 5 http://security.ubuntu.com dapper-security/main openoffice.org 2.0.2-2ubuntu12.1 [1956B]
Réception de : 6 http://security.ubuntu.com dapper-security/main openoffice.org-evolution 2.0.2-2ubuntu12.1 [80,7kB]
Réception de : 7 http://security.ubuntu.com dapper-security/main openoffice.org-gtk 2.0.2-2ubuntu12.1 [204kB]
Réception de : 8 http://security.ubuntu.com dapper-security/main openoffice.org-gnome 2.0.2-2ubuntu12.1 [59,6kB]
58,9Mo réceptionnés en 3m48s (258ko/s)
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-common_2.0.2-2ubuntu12.1_all.deb (--unpack) :
échec dans « buffer_read(fd) » : liste des fichiers du paquet « openoffice.org-core04u »: Erreur d'entrée/sortie
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/openoffice.org-common_2.0.2-2ubuntu12.1_all.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

J'ai essayé d'effacer openoffice.org-core04u mais voici l'erreur affiché:

# apt-get remove openoffice.org-core04u_2.0.3-8_i386.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Impossible de trouver le paquet openoffice.org-core04u_2.0.3-8_i386.deb

Décidément, les paquets RPM transformés en DEB ont été mal transformés.

J'ai fait aussi :

apt-get -f install ubuntu-desktop Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  openoffice.org openoffice.org-common openoffice.org-core openoffice.org-evolution openoffice.org-gnome openoffice.org-gtk
  openoffice.org-java-common
Paquets suggérés :
  openoffice.org-help menu oooqs-kde unixodbc prelink openoffice.org-hyphenation openoffice.org-thesaurus xlibmesa-gl
  libgl1 openoffice.org-officebean openclipart-openoffice.org pstoedit openoffice.org-filter-so52
Les NOUVEAUX paquets suivants seront installés :
  openoffice.org openoffice.org-common openoffice.org-core openoffice.org-evolution openoffice.org-gnome openoffice.org-gtk
  openoffice.org-java-common ubuntu-desktop
0 mis à jour, 8 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/58,9Mo dans les archives.
Après dépaquetage, 146Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/openoffice.org-common_2.0.2-2ubuntu12.1_all.deb (--unpack) :
échec dans « buffer_read(fd) » : liste des fichiers du paquet « openoffice.org-core04u »: Erreur d'entrée/sortie
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/openoffice.org-common_2.0.2-2ubuntu12.1_all.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Incapable aussi de désinstaller openoffice.org-common_2.0.2-2ubuntu12.1_all.deb.

Mais le pire, c'est que je suis incapable d'installer quoi que ce soit. Par exemple, quand je veux installer abiword, je fais ceci apt-get install abiword mais j'obtiens la même erreur que ci-haut :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  abiword-common libenchant1c2a
Paquets suggérés :
  abiword-plugins abiword-plugins-gnome
Paquets recommandés :
  abiword-help
Les NOUVEAUX paquets suivants seront installés :
  abiword abiword-common libenchant1c2a
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4392ko dans les archives.
Après dépaquetage, 14,8Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://fr.archive.ubuntu.com dapper/main libenchant1c2a 1.2.3-0ubuntu2 [148kB]
Réception de : 2 http://fr.archive.ubuntu.com dapper/main abiword-common 2.4.4-0ubuntu5 [1734kB]
Réception de : 3 http://fr.archive.ubuntu.com dapper/main abiword 2.4.4-0ubuntu5 [2510kB]
4392ko réceptionnés en 15s (276ko/s)
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/libenchant1c2a_1.2.3-0ubuntu2_i386.deb (--unpack) :
échec dans « buffer_read(fd) » : liste des fichiers du paquet « openoffice.org-core04u »: Erreur d'entrée/sortie
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libenchant1c2a_1.2.3-0ubuntu2_i386.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

On remarquera dans tout les cas une erreur dans le buffer read.

SVP aidez-moi. Je travaille en tant que formateur de logiciels libres (j'enseigne OpenOffice)...

La prochaine fois, j'attendrais qu'une version DEB stable soit disponible pour la prochaine version d'OpenOffice.:rolleyes:

#18 Re : -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 00:38

danydube
Réponses : 8

Merçi gilir. Cependant, voici ce que cela me donne :

sudo apt-get remove openoffice.org-core04u
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  openoffice.org-core04u
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 68,7Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?
(Lecture de la base de données... dpkg : erreur de traitement de openoffice.org-core04u (--remove) :
échec dans « buffer_read(fd) » : liste des fichiers du paquet « openoffice.org-core04u »: Erreur d'entrée/sortie
Des erreurs ont été rencontrées pendant l'exécution :
openoffice.org-core04u
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Comme tu peux voir...même erreur que d'habitude.

De mon côté je cherche sur le net une solution à mon problème.

J'espère de ne pas ré-installer Ubuntu pour réparer apt-get sad

#19 Re : -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 00:49

danydube
Réponses : 8

J'ai fait apt-get clean et apt-get autoclean. C'est ok pour ça. Je re-télécharge OpenOffice mais encore impossible d'installer quoi que ce soit avec apt-get. Même erreur que ci-haut. Remarquer que dans mon problème, ce n'est pas des paquets cassés mais un problème de buffer read. Sais pas ce que ça veut dire sad

#20 Re : -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 01:31

danydube
Réponses : 8

J'ai tenté un fsck. Effectivement, j'avais des problèmes de copy entre le backup et la partition original pour presque chacune des partitions. Mais j'avoue ne rien y comprendre à cela. Malheureusement, cela n'a rien réglé. Pas plus en ce qui concerne mon apt-get install après un redémarrage. J'ai soumis ma question  sur le forum PCAstuces et j'espère obtenir une réponse pour mon problème...autrement...autrement....je devrais ré-installer Ubuntu...snif sad

Je vais attendre jusqu'à demain.

Merçi quand même gilir.

#21 Re : -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 02:34

danydube
Réponses : 8

Enfin ! Problème réglé !

J'ai trouvé ça quelque part dans un site. Il fallait enlever tout les mots contenant OpenOffice dans le répertoire /var/lib/dpkg/info/. Ensuite, j'ai ouvert synaptic. J'ai rechargé la liste. Puis, j'ai sélectionné tout ce qui était de openoffice 2.0.3 et je l'ai ais tous supprimés avec succès.

Et finalement, j'ai coché les paquets OpenOffice 2.0.2 afin de les installés..je me suis croisés les doigts...et...boum ! Mon écran à pété. Non, voyons. lol

Tout les paquets OpenOffice se sont installés avec succès. J'ai même tester l'ouverture d'OO avec succès.

Comme quoi l'obstination de régler mon problème a porté fruit.

Je savais bien qu'on pouvait régler ça sans avoir à réinstaller Linux.

#22 Re : -1 »  [Résolu] - Impossible d'installer quoi que ce soit avec apt-get... » Le 26/09/2006, à 15:56

danydube
Réponses : 8

gilir a dit:

Et évites alien sur des paquets aussi important la prochaine fois

Ça tu peux en être sûr wink

P.S.: C'est con hein, mais je ne sais pas comment mettre RESOLU dans un titre une fois posté.
Comment fait-on pour ré-éditer son titre ? Pas de problème pour éditer un message envoyé mais un titre..sais pas.

#23 -1 »  Effacer tout les fichiers dans le répertoire courant sauf celui-ci. » Le 11/09/2006, à 02:10

danydube
Réponses : 2

Voici une astuce très pratique pour effacer tout un groupe de fichiers dans le répertoire courant sauf tel fichier. A faire dans un terminal :

D'abord, se placer dans le répertoire où l'on veut effacer tout les fichiers :

cd monrepertoire

Ensuite, faire la syntaxe suivante pour ne garder que le fichier souhaité:

find ./* ! -name "nom du fichier" -exec rm {} \;

Voici un exemple :

find ./* ! -name "Blade2.jpg" -exec rm {} \;

Efface tout les fichiers sauf Blade2.jpg
Le ! signifie = différent de

Pour effacer tout les fichiers dans le répertoire courant sauf celui-ci ET celui-là.

find ./* \( ! -name 'CleUSB.jpg' -a ! -name 'Camion.jpg' \) -exec rm {} \;

Efface tout les fichiers sauf CleUSB.jpg ET (avec l'otion -a) Camion.jpg.

-a = AND (ET)
-o = OR  (OU)

#24 -1 »  Retard de son avec plusieurs jeux. » Le 10/09/2006, à 21:35

danydube
Réponses : 0

Ce n'est pas un problème majeur.

Avec Ubuntu 6.06.1, j'ai remarqué que, dans mon cas, plusieurs jeux d'actions sous Gnome ou KDE ont des problèmes de retard de son (peut-être 100 ou 200 ms) par rapport à l'image dans le jeu (que ce soit des jeux en 2D ou en 3D). J'utilise le serveur de son ALSA. Je ne sais pas comment ajuster la synchronisation audio. Et pourquoi ce retard avec les jeux et pas avec des fichiers audio MP3 ou WAV ? Étrange, non ? Souvent, ce retard me nuit parfois (pour le gameplay) dans certains jeu comme Lbreakout2, Cube, Frozen-bubble, Fish-Fillet, et plusieurs autres encore.

J'aimerais savoir comment ajuster ce retard. Noter que ce retard de son se fait aussi avec le serveur OSS/ESD.

À noter que je n'avais pas ce petit problème dans les précédentes versions Ubuntu. Ma carte de son par défaut, utilisé par ma Ubuntu, est une AC97. J'ai aussi une sound blaser PCI 128 mais je ne sais pas comment l'utiliser par défaut dans Ubuntu Dapper. J'ai regardé sur le site Ubuntu.fr mais je n'ai rien trouvé pour régler mon problème.

Cela dit, ça ne m'empêche pas de profiter pleinement des jeux sous Ubuntu mais ce retard de son devient souvent gênant...

Pour finir, je signalerais un autre problème de son mais beaucoup plus rare : le son manquant quand j'ouvre plusieurs jeux ...Souvent, je dois redémarrer Linux au complet pour rétablir le son dans les jeux. Oui, je sais...c'est une très mauvaise habitude de redémarrer Linux smile