Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 25

#0 Re : -1 »  Reseau provisoire » Le 31/08/2013, à 21:53

NicoZic56
Réponses : 9

Hello.
Oui, il y a une astuce...
Il faut passer par un script suid.
Modifier ton script en :

#!/bin/ksh
service network-manager start
sleep 600
service network-manager stop

Ensuite, le script doit appartenir à root, mais il faut positionner le bit suid (qui permet de s'attribuer les droits du propriétaire du fichier).

sudo chmod 750 monscript
sudo chmod +s monscript

Voilà ce qui devrait faire l'affaire.

Attention, cela crée une faille de sécurité.
Suis avec attention les instructions de cette page.

#1 Re : -1 »  Reseau provisoire » Le 01/09/2013, à 22:40

NicoZic56
Réponses : 9

Tout d'abord, il y a une erreur dans le script, la première ligne est à supprimer
Ensuite, comme je l'indiquais, mettre le bit SUID sur un script présente trop de failles de sécurité. Cela a été désactivé.
Et puis ksh n'est plus nécessaire (je viens de me rendre compte qu'il n'est pas installé par défaut sous Ubuntu).
En relisant ta demande, je vois que tu acceptes de saisir ton mot de passe admin, il y a donc uns solution simple.

On va créer le script dans /root
(sudo gedit /root/a.sh).

#!/bin/sh
service network-manager start
sleep 600
service network-manager stop

(edit... j'avais oublié)

sudo chmod 700 /root/a.sh

Le script a mettre sur le bureau

#!/bin/sh
gksudo /root/a.sh

Lui mettre les droits d'exécution.
Si tu double-cliques dessus, il devrait te demander les droits d'admin et lancer le script.
(J'ai testé sous XFCE et ça marche avec un script similaire).

#2 Re : -1 »  Reseau provisoire » Le 02/09/2013, à 21:29

NicoZic56
Réponses : 9

Y pas de quoi. Merci pour ton retour.
N'oublie pas de marquer le problème comme résolu en ajoutant [Résolu] au titre.

#3 Re : -1 »  Reseau provisoire » Le 07/09/2013, à 09:59

NicoZic56
Réponses : 9

La commande stop est faite pour ça !
Que cela soit pour ta machine ou pour l'infrastructure la commande est correcte.

#4 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 26/08/2013, à 21:15

NicoZic56
Réponses : 29

Hello.

Tu as une anomalie dans ton statut

iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Essaye-ça :

sudo iwconfig wlan0 txpower auto

Ça devrait résoudre le problème.

#5 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 27/08/2013, à 21:04

NicoZic56
Réponses : 29

Les changements de configuration ont largement empiré le problème : le driver n'est plus chargé.
Il faudrait revenir à la configuration initiale.

#6 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 30/08/2013, à 14:50

NicoZic56
Réponses : 29

Me revoila !
J'ai beaucoup cherché, mais je n'ai pas trouvé de cas similaire, y compris sur les forums anglais.
Je te propose d'essayer encore quelques manips, et si on n'y arrive pas, de tester avec une version de noyau plus anciennes.
Je pense que le problème tourne bien autours de l'activation hardware, et qu'il faudrait essayer de bidouiller autour de ça.
1) Dans le BIOS
Essaye de regarder s'il y a quelque chose qui permette de configurer la touche F12 (soit pour la désactiver, soit pour changer la valeur d'activation par défaut)
Il faut que tu observes les changements éventuels par

rfkill list

qui ne doit pas remonter "Hard blocked"
2) Manœuvrer cette touche et voir (toujours par la commande rfkill) si cela change quelquechose.
3) Essayer de voir si une commande privée du driver permettrait d'activer la wifi (je n'y crois pas trop, mais bon...)
Chez moi cela donne :

nicolas@picogiga:~$ sudo iwpriv wlan0
wlan0     no private ioctls.

Ce qui signifie que je n'ai pas de commandes privées pour le driver. Qu'en est-il chez toi ?
4) Essayer une version backport du noyau
Si tu tapes :

apt-cache search linux|grep image|grep backport

Tu devrais voir apparaître une liste des modules backportés pour la wifi (c'est le cas en 12.04)
Il faudra que tu choisisses une version (ne prends pas le pae, tu es en 64bits), et que tu l'installes par une ligne de commande du genre (à compléter par le résultat de la commande précédente)

sudo apt-get install linux-backports-modules-cw-?.?-raring-generic 

#7 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 30/08/2013, à 17:07

NicoZic56
Réponses : 29

Non, inbox : la commande que tu proposes permet d'enlever le blocage logiciel(soft), pas le blocage matériel(hard).Or, il s'agit d'un blocage matériel ici (Hard blocked: yes)

#8 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 30/08/2013, à 17:27

NicoZic56
Réponses : 29

Le résultat de rfkill dépendrait donc des cartes ?
Chez moi, j'ai :

root@picogiga:~# rfkill list
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
18: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
root@picogiga:~# rfkill block wifi
root@picogiga:~# rfkill list
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
18: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
root@picogiga:~# rfkill unblock wifi

De même, pour le mode avion ? Il est également parfois résolvable par iwconfig wlan0 txpower on(ici)... mais dans ce cas iwconfig le signale...
Bon, en tout cas pour revenir au problème initial de simbad83, tu peux essayer la commande...

#9 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 31/08/2013, à 21:18

NicoZic56
Réponses : 29

Je crois que c'est bon signe... pour une carte ralink, apparemment, ce n'est wlan0, mais ra0.
Pour mon information, peux-tu confirmer que c'est la commande rfkill qui a créé l'interface ?
D'après ce que j'ai vu ailleurs, cela devrait maintenant marcher... Est-ce la cas ?
Ensuite, il faudrait reposter toutes les commandes du début  (que tu as déja postées), ou du moins toutes celles qui ont changées.

#10 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 01/09/2013, à 22:44

NicoZic56
Réponses : 29

Rapporte toi à mon post #10 point 4), pour installer les modules backport.

#11 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 02/09/2013, à 11:04

NicoZic56
Réponses : 29

sad
Pour le moment, je suis au boulot (pas trop de temps pour regarder ça en détail).
Je rebondis sur

sinbad83 a écrit :

Ce blocage est spécifique de 13.04. Il faudrait pouvoir installer un autre pilote... Mais je n'ai pas su installer le rt5592sta_fix_64bit_3.8.patch.

Je n'ai pas trouvé ni le patch, ni ce qu'il est censé corriger. Ou l'as-tu trouvé ?
Cela m'inspire 2 remarques :
1) peut-être que le driver 64bits est bugué. Est-ce que cela t'irais d'essayer un noyau pae ?
2) j'ai déjà compilé des drivers pour linux. Si on est sûrs que cela va corriger le problème, donne-moi ton état d'avancement, je pense que je pourrais te dépanner...

#12 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 02/09/2013, à 21:26

NicoZic56
Réponses : 29

A première vue, ça a l'air sur le point de marcher...
Qu'est-ce que donne sudo iwlist ra0 scanning ?

#13 Re : -1 »  Plus de Wifi en passant en 13.04 (Chipset RT5390) » Le 03/09/2013, à 21:21

NicoZic56
Réponses : 29

Arg... sad
Est-ce que la commande rfkill list indique toujours un blocage hardware ?
Si c'est le cas, c'est que malheureusement on n'aurait pas beaucoup avancé.
Est-ce que tu as essayé les autres pistes que je t'ai déjà indiquées (noyau 32 bits pae, bios, sudo iwpriv ra0) ?

#14 Re : -1 »  Equivalent de XCOPY sous Linux... » Le 03/09/2013, à 21:32

NicoZic56
Réponses : 3

Hello,
Une solution (qui en vaut une autre), utiliser tar (création d'archive).

Créer l'archive:

tar cvzf /tmp/tmp.tgz $(find . -name '*.pdf')

L'extraire à l'endroit souhaité (se déplacer préalablement dans le répertoire avec cd).

tar xvzf /tmp/tmp.tgz 

L'inconvénient : on passe par un fichier temporaire pas très utile.

#15 Re : -1 »  Deconnexions wifi intempestives » Le 30/08/2013, à 22:39

NicoZic56
Réponses : 3

Bonjour !
Je pense qu'il faut modifier la configuration wifi de ta box.
Je pense qu'elle apparaît dans le scan en premier, et que tu ne diffuses pas le SSID (c'est pour cela qu'elle n'apparaît pas ESSID:"<hidden>")
Il faudrait te connecter sur l'interface d'administration de ta box.
Change le numéro de canal.
Tous les points d'accès a proximité émettent sur le canal 11.
Change donc le canal pour 1, cela devrait beaucoup mieux marcher.
Tu peux aussi cocher diffuser le SSID (ou nom de réseau) cela pourrait simplifier le diagnostic ultérieur.

#16 Re : -1 »  Deconnexions wifi intempestives » Le 31/08/2013, à 21:07

NicoZic56
Réponses : 3

C'est assez compatible avec le problème de canal réseau que je t'ai soumis. Certaines box ont un choix de canal automatique, mais selon mon expérience, cela ne marche pas toujours très bien. Il a suffit que l'une d'entre elle reboote pour que le problème disparaissent.
Si tu relances une commande sudo iwlist wlan0 scanning tu devrais voir les autres canaux. Si le problème se reproduit, la recommandation de changer le numéro de canal reste valide.

#17 Re : -1 »  Problème Wifi avec Xubuntu 13.04 Sur Toshiba Satellite L30-109 » Le 30/08/2013, à 15:00

NicoZic56
Réponses : 1

Bonjour,
Il aurait été préférable de poster dans le forum spécialisé de la wifi, qui ce troue ici.
Merci de poster les informations demandées dans l'en-tête du forum.

#18 Re : -1 »  Problème de carte Wifi Zbox HD-ID12 » Le 21/08/2013, à 13:35

NicoZic56
Réponses : 4

Bonjour,
Tu aurais du poster dans le forum spécialisé de la Wifi (http://forum.ubuntu-fr.org/viewforum.php?id=82) qui fourni une procédure pour les commandes à poster (http://forum.ubuntu-fr.org/viewtopic.php?id=1089311).

Il peut effectivement s'agir d'un problème hardware
Ou bien (et cela serait mon option préférée): c'est que le PC est situé à un endroit où il n'y a pas de couverture wifi (ou parasitée par quelque chose). 

Le retour des commandes permettrait d'y voir plus clair.

#19 Re : -1 »  Problème de carte Wifi Zbox HD-ID12 » Le 21/08/2013, à 21:15

NicoZic56
Réponses : 4

Hello,
C'est un peu bizarre que la carte soit énumérée en wlan1, normalement cela devrait être wlan0.
Est-ce qu'il en est pareil pour les autres machines ?
Ensuite, ce n'est très bon signe que la carte ne renvoie rien... Les paramètres me semblent corrects.
Il faudrait un peu insister sur la commande

sudo iwlist scan 

Si elle ne renvoie rien, je pense qu'il y a effectivement un problème hardware...

#20 Re : -1 »  Bonjour, impossible d'activer Ralink corp. Device [1814:3290] malgré s » Le 21/08/2013, à 13:42

NicoZic56
Réponses : 1

Hello !

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Normalement, cela signifie  que tu as un interrupteur matériel wifi qui désactive la wifi.
Sur les PC portables, on a parfois tendance à appuyer dessus sans s'en rendre compte.

#21 Re : -1 »  [Résolu] Script plus lent à cause du pipe ??? » Le 21/08/2013, à 09:14

NicoZic56
Réponses : 9

Heu.. il faut juste que tu rajoutes l'appel vers zeity dans la ligne. L'aurais-tu oublié dans le copier-coller ?

mencoder "/home/$USER/video.vob" -nosound -ovc frameno -sid 9 -vobsubout "/home/$USER/soustitrage" -vobsuboutindex 0 -o /dev/null | awk  -vRS='\r' -F [%\(] '/%)/ {printf "\n%d\n",$2 ; printf "\n#%d %\n",$2 ;fflush();}' | awk '!x[$0]++' | zenity --progress --auto-close

#22 Re : -1 »  [Résolu] Script plus lent à cause du pipe ??? » Le 21/08/2013, à 09:40

NicoZic56
Réponses : 9

Qu'est-ce qui ne marche pas ?
J'ai fait un test chez moi, e le problème que j'ai c'est que zenity s'affiche un peu tardivement, sinon c'est OK.

#23 Re : -1 »  [Résolu] Script plus lent à cause du pipe ??? » Le 21/08/2013, à 10:26

NicoZic56
Réponses : 9

J'ai refait des tests, et c'est un problème avec la commande awk qui supprime les lignes en doublons.
Il ne flush pas sa sortie à chaque nouvelle ligne.
Il faudrait configurer la commande de suppression des lignes pour qu'elle flush. Je ne sais pas comment faire ça. (La commande awk précédente le fait, grâce au flush dans le code passé en paramètre).

Je sais m'en sortir avec python
Tu crées un fichier "remove_dup.py" dans un répertoire contenu dans ton PATH, contenant :

#!/usr/bin/python
import sys
l1=""
while 1:
	l2 = sys.stdin.readline()
	if not l2: break
	if l2 != l1:
		sys.stdout.write(l2)
		sys.stdout.flush()
	l1=l2

Et tu remplaces awk '!x[$0]++' par remove_dup.py dans la ligne de commande.

#24 Re : -1 »  wifi bloqué par harware » Le 20/08/2013, à 22:52

NicoZic56
Réponses : 28

Bon, voila le tuto pour compiler le module
Copier-coller le code suivant dans un éditeur, et sauvegarder le tout dans /tmp/nico.patch

diff -rupN acerhk/acerhk.c acerhk/acerhk.c
--- acerhk/acerhk.c	2009-07-02 23:48:23.000000000 +0200
+++ acerhk/acerhk.c	2013-08-19 22:43:21.556956104 +0200
@@ -37,6 +37,8 @@
 
 #ifndef AUTOCONF_INCLUDED
 #include <linux/config.h>
+#else
+#include <generated/autoconf.h>
 #endif
 
 /* This driver is heavily dependent on the architecture, don't let
@@ -2827,7 +2829,7 @@ static void acerhk_proc_cleanup(void)
 
 /* {{{ file operations */
 
-static int acerhk_ioctl( struct inode *inode, struct file *file,
+static long acerhk_ioctl( /*struct inode *inode,*/ struct file *file,
                          unsigned int cmd, unsigned long arg )
 {
   int retval;
@@ -2938,7 +2940,7 @@ static int acerhk_resume(struct platform
 
 static struct file_operations acerhk_fops = {
   owner:        THIS_MODULE,
-  ioctl:        acerhk_ioctl,
+  unlocked_ioctl:        acerhk_ioctl,
   open:         acerhk_open,
 #ifdef ACERDEBUG
   write:        acerhk_write,
diff -rupN acerhk/Makefile acerhk/Makefile
--- acerhk/Makefile	2009-07-02 23:48:23.000000000 +0200
+++ acerhk/Makefile	2013-08-20 21:55:09.912536657 +0200
@@ -1,11 +1,17 @@
 # change KERNELSRC to the location of your kernel build tree only if
 # autodetection does not work
 #KERNELSRC=/usr/src/linux
-KERNELSRC?=/lib/modules/`uname -r`/build
+#KERNELSRC=/lib/modules/`uname -r`/build
+
+KERNELSRC=/usr/src/linux-headers-`uname -r`/
+
 # Starting with 2.6.18, the kernel version is in utsrelease.h instead of version.h, accomodate both cases
-KERNELVERSION=$(shell awk -F\" '/REL/ {print $$2}' $(shell grep -s -l REL $(KERNELSRC)/include/linux/version.h $(KERNELSRC)/include/linux/utsrelease.h))
+KERNELVERSION=$(shell uname -r | sed 's/-.*//' )
 KERNELMAJOR=$(shell echo $(KERNELVERSION)|head -c3)
 
+#KERNELVERSION=3.2.0
+#KERNELMAJOR=3.2
+
 # next line is for kernel 2.6, if you integrate the driver in the kernel tree
 # /usr/src/linux/drivers/acerhk - or something similar
 # don't forget to add the following line to the parent dir's Makefile:
@@ -14,9 +20,12 @@ KERNELMAJOR=$(shell echo $(KERNELVERSION
 CONFIG_ACERHK?=m
 obj-$(CONFIG_ACERHK) += acerhk.o
 
-EXTRA_CFLAGS+=-c -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe
+CFLAGS+=-c -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe
 INCLUDE=-I$(KERNELSRC)/include
 
+CFLAGS+=-D  AUTOCONF_INCLUDED 
+INCLUDE+=-I$(KERNELSRC)/arch/x86/include
+
 ifeq ($(KERNELMAJOR), 2.6)
 TARGET := acerhk.ko
 else
@@ -33,6 +42,7 @@ help:
 	@echo -e install\\t- copies module binary to /lib/modules/$(KERNELVERSION)/extra/
 	@echo -e clean\\t- removes all binaries and temporary files
 
+
 # this target is only for me, don't use it yourself (Olaf)
 export:
 	sh export.sh

A partir du home dir

wget http://ftp.fr.debian.org/debian/pool/main/a/acerhk/acerhk-source_0.5.35-8_all.deb
sudo dpkg -i acerhk-source_0.5.35-8_all

Et puis la compil:

sudo -i
cd /usr/src
tar xjf acerhk.tar.bz2
cd modules
patch -p0 < /tmp/nico.patch
cd acerhk
make
make install
modprobe acerhk
echo 1 > /proc/driver/acerhk/wirelessled
exit

smile   smile   smile   Enjoy !