Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  [Résolu] Gestion ram après utilisation prolongée ?? Memoire saturée » Le 13/04/2005, à 17:50

PLOP
Réponses : 4

Bon alors mon problème c'est que je comprend pas pourquoi ma Hoary bouffe tant que sa en ram..

Je suis sur un portable, j'ai 1Go de ram..bon deja 900 de reconnus mais je dois pas avoir HIGHMEM dans le noyau .. bref

Toujours est il qu'avec très peu de chose :

Gdesklets, xorg, xmms, un terminal et deux firefox.. me voila deja rendu au bout de ma ram !

voici le résultat de top :

Mem:    906656k total,   881900k used,    24756k free,   102672k buffers
Swap:        0k total,        0k used,        0k free,   457220k cached

8169 root      15   0 70732  53m  10m S  2.0  6.0  11:34.92 Xorg
9897 plop      15   0  1996  604  480 R  2.0  0.1   0:32.50 esd
7443 plop      15   0 55016  11m 7904 S  2.0  1.3   1:23.68 xmms
12636 plop      15   0 39284  14m 9108 S  2.0  1.6   0:14.96 gnome-terminal
14610 plop      16   0  2076  952  736 R  2.0  0.1   0:00.01 top
    1 root      16   0  1552  508  444 S  0.0  0.1   0:00.46 init
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
    3 root       5 -10     0    0    0 S  0.0  0.0   0:00.10 events/0
    4 root       8 -10     0    0    0 S  0.0  0.0   0:00.01 khelper
   22 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 kacpid
  115 root       5 -10     0    0    0 S  0.0  0.0   0:00.20 kblockd/0
  150 root      15   0     0    0    0 S  0.0  0.0   0:00.00 pdflush
  151 root      15   0     0    0    0 S  0.0  0.0   0:00.12 pdflush
  153 root       6 -10     0    0    0 S  0.0  0.0   0:00.00 aio/0
  152 root      15   0     0    0    0 S  0.0  0.0   0:00.05 kswapd0
  740 root      25   0     0    0    0 S  0.0  0.0   0:00.00 kseriod
1110 root      15   0     0    0    0 S  0.0  0.0   0:00.46 kjournald
1136 root       8 -10  1532  360  288 S  0.0  0.0   0:00.02 udevd
2957 root      15   0     0    0    0 S  0.0  0.0   0:00.00 khpsbpkt
4563 root      19   0     0    0    0 S  0.0  0.0   0:00.00 shpchpd_event
4752 root      15   0     0    0    0 S  0.0  0.0   0:00.53 khubd
6798 root      15   0     0    0    0 S  0.0  0.0   0:00.00 knodemgrd_0

Ceci intervient après une utilisation prolongée car au demarrage j'ai beaucoup moins genre en dessous de 500..(après vérification 283 Mo après reboot)

Quelqu'un a deja eu le problème ? D'ou cela peut il venir ? (sachant qu'il n'y pas grand chose d'autre sur la machine, ormis un apache et mysql qui ne servent pour le moment pas...)

merci d'avance !

#1 Re : -1 »  [Résolu] Gestion ram après utilisation prolongée ?? Memoire saturée » Le 13/04/2005, à 22:24

PLOP
Réponses : 4

Ok merci pour ta réponse smile

et pis ben désolé pour la question récurrente..

#2 -1 »  Fluxspace ? personnaliser chaque workspace différemment » Le 10/01/2007, à 14:34

PLOP
Réponses : 1

Bonjour,

Voila tout est dans le titre, j'aimerai personnaliser mes workspace :

- avoir des icones différentes (avec idesk),
- pourquoi pas un fond d'écran différent également..

Je suis tomber par hasard sur fluxspace, malheureusement, j'ai un bug fatal à la compil et celui-ci semble mort depuis fin 2004, aucune réponses sur le forum, ni sur le support....

Donc si quelqu'un connait une solution alternative, ou possède un fluxspace fonctionnel, et bien je suis preneur !

merci d'avance.

si cela intéresse quelqu'un voici l'erreur lors de la compilation :

 g++ -DHAVE_CONFIG_H -I. -I. -I../.. -Wall -g -O2 -MT Menu.lo -MD -MP -MF .deps/Menu.Tpo -c Menu.cc  -fPIC -DPIC -o .libs/Menu.o
Menu.cc: In member function 'void FbTk::Menu::update(int)':
Menu.cc:496: error: no matching function for call to 'FbTk::FbPixmap::FbPixmap(FbTk::FbPixmap)'
make[2]: *** [Menu.lo] Erreur 1

#3 Re : -1 »  Comment obtenir un log des commandes ? » Le 26/04/2007, à 14:45

PLOP
Réponses : 9

Salut,

J'ai lutté pour trouver une réponse au sujet de l'heure dans l'historique bash, et finalement j'ai trouvé une variable implémenté depuis bash 3.0 :

HISTTIMEFORMAT=%Y−%m−%d_%H:%M:%S

L'interpretation interne marche comme strftime apparemment...
pour tester suffit de faire :

export HISTTIMEFORMAT=%Y−%m−%d_%H:%M:%S
history

pour adopter : ajouter la variable dans le .bashrc

Hopper: Les seules choses qui sont logués sont les commandes (tu les a trouvées donc, fichier .bach_history), les conexions avec date et heure (commande last) et puis bein.. c'est a peu près tout.

apparemment si, bash enregistrait la date et l'heure d'execution de chaque commande de l'historique...sufffisait de lui dire gentillement d'afficher l'heure et la date et cela marche meme pour les commandes plus anciennes que celle faites après l'export....

#4 Re : -1 »  Comment obtenir un log des commandes ? » Le 26/04/2007, à 15:45

PLOP
Réponses : 9

Autant pour moi j'etais tellement happy d'avoir trouvé le tip :

il ajoute la date courante aux commandes plus ancienne que l'export et sinon la bonne date/heure aux futures commandes...

et cela fonctionne sous debian etch, il faut avoir bash 3 et ptet que t'est sous sarge encore

#5 -1 »  devlabel ? comment donner un autre nom aux peripheriques (/dev/nom) » Le 10/10/2006, à 20:45

PLOP
Réponses : 2

Boujour smile

Voila je cherche un moyen d'associer un  nom de peripherique par rapport à un uuid (id unique d'un periph).

la cause :

un disque dur externe en firewire change de nom soit sda soit sdf ...et c'est chiant car dans fstab seul le sda est référencé...

Alors voila la solution serai d'ajouter sdf au fstab mais j'aimerai bien savoir si il existe une autre methode...et comme j'ai vu que sous redhat il y avait devlabel, je cherche un equivalent ubuntu smile

Merci d'avance pour toute réponse !

#6 Re : -1 »  son de qualité médiocre » Le 13/04/2005, à 16:57

PLOP
Réponses : 19

+1 shinji smile

en effet mon volume PCM etait au max dans alsamixer ..

j'ai réduit et depuis aucun problème !

#7 -1 »  Audigy 2 notebook compatible ? » Le 13/04/2005, à 16:58

PLOP
Réponses : 1

Salut,

Je suis en train de me tater pour acheter ce petit bijoux tongue

donc je voulais savoir si des gens ont deja testé et si tout fonctionnait bien..

Merci

#8 -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 02/06/2006, à 00:05

PLOP
Réponses : 20

Bonjour,

J'ai donc mis a jour en dapper et dès lors la configuration wifi n'a pas fonctionnée, j'ai donc mis les main dans le camboui :

- J'ai, telechargé les ieee80211 et ipw2200 ainsi que le firmware pour les bonnes versions, decompressé, make & make install
- J'ai placé le firmware dans /lib/firmware/ et meme dans /lib/firmware/`uname -r`/

Et toujours le même probleme au dmesg :

[4294686.503000] ieee80211_crypt: registered algorithm 'NULL'
[4294686.695000] ieee80211: 802.11 data/management/control stack, 1.1.13
[4294686.695000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
[4294686.980000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.2dmprq
[4294686.980000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[4294686.980000] ACPI: PCI Interrupt 0000:02:02.0[A] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
[4294686.980000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[4294696.980000] ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
[b][4294696.980000] ipw2200: Unable to load firmware: -2[/b]
[4294696.980000] ipw2200: failed to register network device
[4294696.980000] ACPI: PCI interrupt for device 0000:02:02.0 disabled
[4294696.980000] ipw2200: probe of 0000:02:02.0 failed with error -5

Après quelques recherches, j'ai appris que dapper utilisait maintenant HAL et udev et plus les hotplug scripts...

Ma question est donc la suivante :

Quelle est la procédure avec ce HAL ?

Est ce que cela ne peux pas fonctionner parce que les developpeurs du drivers n'ont pas pris en compte l'utilisation de hal, (dans la doc c'est toujours noté hotplug, et même dans les instructions à la fin du make install de ipw2200)...

Merci pour toute réponse smile

#9 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 02/06/2006, à 10:32

PLOP
Réponses : 20

Merci de ta réponse, mais je ne pense pas que se soit le même problème...

Je n'utilise pas ndiswrapper mais les drivers du projet ipw2200, et je n'ai pas ndiswrapper d'installé pour autre chose non plus.

le lsmod d'ailleurs confirme que je n'ai pas de module sous le nom de ndiswrapper.

Pour mon problème, je pensais à un conflit entre le module ipw2200 par defaut et celui que je compile mais avec celui par defaut j'avais la même erreur au dmesg (a une version du firmware près)...

Il y a peut être une commande a faire ou un fichier de conf a modifier pour hal ?

#10 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 04/06/2006, à 12:09

PLOP
Réponses : 20

Je vais essayer de reformuler la question peut être que ce n'etait pas clair...

Il ya t'il une démarche particulière pour que udev ou hal (je ne sais pas) arrive a charger un firmware ?

A priori j'ai mis le firmware de la carte dans /lib/firmware comme vu sur beaucoup de tutos...Mais cette simple étape qui n'arrange rien à la situation me fait dire qu'il y une autre étape que j'ai du zapper...

laquelle ?

ou alors il y a un problème inhérent au drivers ipw2200 non encore adapté pour udev/hal ?

Un million de merci offert à celui qui répondra smile

#11 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 04/06/2006, à 14:33

PLOP
Réponses : 20

Tiens marrant c'est aussi un xb7 le miens, par contre j'ai toujours utilisé les drivers ipw2200 et pas ceux d'ubuntu, par habitude..et cela a toujours fonctionné.

..jusqu'a dapper smile

J'essayerai cela janno59 quand je serai sur le portable. smile

Jme dis que peut être il serait bien de faire la full install dapper, parce que c'est ptet pas très propre d'avoir toujours fait des dist-upgrade depuis la warty.

Merci à vous deux!

#12 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 04/06/2006, à 22:35

PLOP
Réponses : 20
janno59 a écrit :

essais , pour voir

sudo rmmod ipw2200
sudo modprobe ipw2200

j'utilise le ipw2200 de la dapper et ça marche pas mal.
Bon courage.

Cela me fait toujours la même chose au dmesg lors du modprobe hmm
Mais merci quand même ! smile

Je trouve bizarre d'être le seul avec ce problème, tout le monde utilise le drivers des dépôts ?

J'aimerai bien savoir si quelqu'un est sous dapper avec le drivers non-ubuntu..

#13 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 04/06/2006, à 23:21

PLOP
Réponses : 20

En fait j'ai jamais utilisé ces drivers intégrés pour être à jour et puis parce que au début il n'y en avait pas dans la warty smile

Du coup par tradition et pour garder une version à jour du drivers, j'utilise ceux du projet sourceforge...

Mais ce sont les mêmes que ceux d'ubuntu si je ne m'abuse ?

Bref lorsque on install les drivers on supprime toute trace des anciens (donc de ceux installés par ubuntu) et donc je n'ai pas moyen de faire machine arrière, a moins de reinstaller hmm

Apparemment les drivers du projet sourceforge fonctionneraient avec udev selon leur site..donc yapa de raison.. d'autre part je note que je n'arrive pas a changer le timeout du chargement firmware :

echo 100 > /sys/class/firmware/timeout

Préconisé sur leur site pour un problème similaire au mien...Mon pc refuse en root d'ecrire car le fichier est changé entre temps..

(j'ai un peu l'impression de patauger et d'inspirer personne, désolé donc de polluer le forum de trucs ininteressants smile

#14 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 06/06/2006, à 10:15

PLOP
Réponses : 20

Se serait un problème de noyau ?

Bon en tout cas je crois que je vais me taper une reinstall cd histoire de rendre tout propre smile

Merci à vous pour vos réponses !

#15 Re : -1 »  ipw2200 avec dapper | chargement du firmware pose problème » Le 08/06/2006, à 22:14

PLOP
Réponses : 20

Raa j'y ai cru à ta solution smile

Mais rien a faire smile comme c'est le chargement du firmware qui ne marche pas, le drivers ipw2200 n'est pas lancé du tout donc encore moins son interface... hmm

donc après essai : nope hmm

Merci quand meme!

#16 Re : -1 »  Un endroit pour les laptopiens ? » Le 21/04/2005, à 14:54

PLOP
Réponses : 73

nan mais c'est pas pour compliquer les choses au contraire...

Moi qui suit sur un laptop je dois consulter ts les forums alors qu'un seul pourrais suffir !

je m'explique :

Si chacun fait un rapport de ce qui marche et ce qui marche pas selon les marques et en apportant des solutions par marques..sa ferait avancer les choses !

Pour exemple : j'ai un CL56

et bien ya une manipulation spéciale a faire pour avoir le wifi car un bouton d'activation du wifi est présent sur le portable mais pas pris en charge nativement par ubuntu.. il faut donc passer par acerhk.. mais sa faut le savoir surtout si on débute !

et ce n'est qu'un exemple...

De plus cela permettrait à tous de se porter plutot sur tel ou tel modèle sachant si c'est compliqué ou non d'avoir son portable 100% fonctionnel sous ubuntu...

#17 -1 »  [Résolu] Crash de X depuis update en breezy » Le 29/09/2005, à 18:31

PLOP
Réponses : 1

Coucou

Mon problème est le suivant :

Je viens juste de passer en breezy et lors du demarrage post-install impossible de lancer X..

Je regarde les logs et je trouve que il ne trouve pas la police "fixed" qui est la police par defaut pour x d'ou la fatal error...
Aparemment il ne trouverait également rien dans /usr/X11R6/lib/X11/fonts/Speedo (ce qui explique peut être le manque de fixed ?)

enfin bon je ne vois nullement d'ou sa vient puisque fixed devrait être dans le xserver-common non ?

Merci pour toute aide !

#18 Re : -1 »  [Résolu] Crash de X depuis update en breezy » Le 29/09/2005, à 19:07

PLOP
Réponses : 1

Bon en fait en regardant sur un fichier de conf de xorg ne m'appartenant pas j'ai vu que j'avais pas FontPath "unix/:7100"

donc que résolument avant je passais pas par xfs.... allez savoir pourquoi...

Donc modif de xorg.conf et apt-get install xfs et puis x demarre gentillement !

#19 Re : -1 »  [Résolu] Bug graphique Hoary - Xorg sur Ati mobility 9700 » Le 17/05/2005, à 18:13

PLOP
Réponses : 15

Bien sur, alors faut d'abord que tu ailles chopper radeontool qui va te permettre d'eteindre ton ecran... par contre il faut une carte radeon je pense...

Ensuite il suffit de modifier le script lid.sh, voici le mien : (pris sur un site, modifie le a ta guise car tu n'utilise peut etre pas hdparm et speedfreq...)

#!/bin/sh

# Author : Greg FABRE (zeemax@iero.org)
# Date : Mai 2004

# Quand on ferme l'écran :
#	- on eteind le lcd
#   Si on est sur le secteur (sinon, on est deja en powersave et tout)
#	- on baisse le spindown
#	- on passe en powersave
#
# Quand on allume l'écran :
#	- on allume le lcd
#   Si on est sur le secteur (sinon, on est deja en powersave et tout)
#	- on reaugmente le spindown
#	- on passe en performance

# spindown time pour le dur
# 10 minutes ou 5 minutes

ACAD_HD=120
BATT_HD=60

lid_status=`awk '/^state:/ { print $2 }' /proc/acpi/button/lid/LID0/state`
batt_status=`awk '/^charging state:/ { print $3 }' /proc/acpi/battery/BAT1/state`
acad_status=`awk '/^state: / { print $2 }' /proc/acpi/ac_adapter/ACAD/state`

case $lid_status in
        "closed")
		logger "Fermeture de l'écran"
                /usr/bin/radeontool light off
		case $acad_status in
			"on-line")
		        logger "Setting HD spindown to $BATT_HD"
	                /sbin/hdparm -S $BATT_HD /dev/hda > /dev/null 2>&1
		        logger "Setting speedfreq to powersave"
	                /usr/bin/speedfreq -p powersave
		;;
		esac
                exit 0
        ;;
        "open")
		logger "Ouverture de l'écran"
                /usr/bin/radeontool light on
		case $acad_status in
			"on-line")
		        logger "Setting HD spindown to $ACAD_HD"
	                /sbin/hdparm -S $ACAD_HD /dev/hda > /dev/null 2>&1
		        logger "Setting speedfreq to performance"
	                /usr/bin/speedfreq -p performance
		;;
		esac
                exit 0
        ;;
esac

ce script est situé dans /etc/acpi/ normalement

Voila n'hesite pas a me demander si tu n'y arrive pas, je sais pas si cette solution est très efficace niveau batterie mais en tout cas cela supprime le bug !

#20 Re : -1 »  [Résolu] Bug graphique Hoary - Xorg sur Ati mobility 9700 » Le 01/06/2005, à 16:36

PLOP
Réponses : 15

Coucou !

alors pour répondre à tes questions,

oui ce script n'affecte aucunement les autres configs, c'est juste exécuté lors de l'ouverture/fermeture de l'ecran.

Voici mon xorg.conf :

(mais euh c'est pour quoi d'abord ? wink )

Tation c'est long

# **********************************************************************
# Refer to the XF86Config(4/5) man page for details about the format of
# this file.
# **********************************************************************

# **********************************************************************
# DRI Section
# **********************************************************************
Section "dri"
# Access to OpenGL ICD is allowed for all users:
    Mode 0666
# Access to OpenGL ICD is restricted to a specific user group:
#    Group 100    # users
#    Mode 0660
EndSection

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"   # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"
    EndSubSection

# This loads the Type1 and FreeType font modules
    Load        "type1"
    Load        "freetype"

# This loads the GLX module
    Load        "glx"   # libglx.a
    Load        "dri"   # libdri.a

EndSection


# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath     "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).
#

#    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"

# The module search path.  The default path is shown here.

#    ModulePath "/usr/X11R6/lib/modules"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to cause a core dump at the spot where a signal is
# received.  This may leave the console in an unusable state, but may
# provide a better stack trace in the core dump to aid in debugging

#    Option "NoTrapSignals"

# Uncomment this to disable the <Crtl><Alt><BS> server abort sequence
# This allows clients to receive this key event.

#    Option "DontZap"

# Uncomment this to disable the <Crtl><Alt><KP_+>/<KP_-> mode switching
# sequences.  This allows clients to receive these key events.

#    Option "Dont Zoom"

# Uncomment this to disable tuning with the xvidtune client. With
# it the client can still run and fetch card and monitor attributes,
# but it will not be allowed to change them. If it tries it will
# receive a protocol error.

#    Option "DisableVidModeExtension"

# Uncomment this to enable the use of a non-local xvidtune client.

#    Option "AllowNonLocalXvidtune"

# Uncomment this to disable dynamically modifying the input device
# (mouse and keyboard) settings.

#    Option "DisableModInDev"

# Uncomment this to enable the use of a non-local client to
# change the keyboard or mouse settings (currently only xset).

#    Option "AllowNonLocalModInDev"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"
# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option "Protocol"   "Xqueue"

    Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#    Option "Xleds"      "1 2 3"

#    Option "LeftAlt"    "Meta"
#    Option "RightAlt"   "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"   "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"   "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"  "de"
# or:
#    Option "XkbLayout"  "de"
#    Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for XFree86
#    Option "XkbRules"   "xfree86"
#    Option "XkbModel"   "pc101"
#    Option "XkbLayout"  "us"
#    Option "XkbVariant" ""
#    Option "XkbOptions" ""

#    Option "XkbDisable"

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "fr"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver "mouse"
    Option "Protocol"   "ImPS/2"
    Option "ZAxisMapping"   "4 5"
    Option "Device"     "/dev/psaux"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"   "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"   "9600"
#    Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection


# **********************************************************************
# Other input device sections
# this is optional and is required only if you
# are using extended input devices.  This is for example only.  Refer
# to the XF86Config man page for a description of the options.
# **********************************************************************
#
# Section "InputDevice"
#    Identifier  "Mouse2"
#    Driver      "mouse"
#    Option      "Protocol"      "MouseMan"
#    Option      "Device"        "/dev/mouse2"
# EndSection
#
# Section "InputDevice"
#    Identifier "spaceball"
#    Driver     "magellan"
#    Option     "Device"         "/dev/cua0"
# EndSection
#
# Section "InputDevice"
#    Identifier "spaceball2"
#    Driver     "spaceorb"
#    Option     "Device"         "/dev/cua0"
# EndSection
#
# Section "InputDevice"
#    Identifier "touchscreen0"
#    Driver     "microtouch"
#    Option     "Device"         "/dev/ttyS0"
#    Option     "MinX"           "1412"
#    Option     "MaxX"           "15184"
#    Option     "MinY"           "15372"
#    Option     "MaxY"           "1230"
#    Option     "ScreenNumber"   "0"
#    Option     "ReportingMode"  "Scaled"
#    Option     "ButtonNumber"   "1"
#    Option     "SendCoreEvents"
# EndSection
#
# Section "InputDevice"
#    Identifier "touchscreen1"
#    Driver     "elo2300"
#    Option     "Device"         "/dev/ttyS0"
#    Option     "MinX"           "231"
#    Option     "MaxX"           "3868"
#    Option     "MinY"           "3858"
#    Option     "MaxY"           "272"
#    Option     "ScreenNumber"   "0"
#    Option     "ReportingMode"  "Scaled"
#    Option     "ButtonThreshold"    "17"
#    Option     "ButtonNumber"   "1"
#    Option     "SendCoreEvents"
# EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
    Identifier  "Monitor0"
    HorizSync   31.5 - 91.1
    VertRefresh 60 - 85
    Option "DPMS"

# === mode lines based on GTF ===
# VGA @ 100Hz
# Modeline "640x480@100" 43.163 640 680 744 848 480 481 484 509 +hsync +vsync
# SVGA @ 100Hz
# Modeline "800x600@100" 68.179 800 848 936 1072 600 601 604 636 +hsync +vsync
# XVGA @ 100Hz
# Modeline "1024x768@100" 113.309 1024 1096 1208 1392 768 769 772 814 +hsync +vsync
# 1152x864 @ 60Hz
# Modeline "1152x864@60" 81.642 1152 1216 1336 1520 864 865 868 895 +hsync +vsync
# 1152x864 @ 85Hz
# Modeline "1152x864@85" 119.651 1152 1224 1352 1552 864 865 868 907 +hsync +vsync
# 1152x864 @ 100Hz
# Modeline "1152x864@100" 143.472 1152 1232 1360 1568 864 865 868 915 +hsync +vsync
# 1280x960 @ 75Hz
# Modeline "1280x960@75" 129.859 1280 1368 1504 1728 960 961 964 1002 +hsync +vsync
# 1280x960 @ 100Hz
# Modeline "1280x960@100" 178.992 1280 1376 1520 1760 960 961 964 1017  +hsync +vsync
# SXGA @ 100Hz
# Modeline "1280x1024@100" 190.960 1280 1376 1520 1760 1024 1025 1028 1085 +hsync +vsync
# SPEA GDM-1950 (60Hz,64kHz,110MHz,-,-): 1280x1024 @ V-freq: 60.00 Hz, H-freq: 63.73 KHz
# Modeline "GDM-1950"  109.62  1280 1336 1472 1720  1024 1024 1026 1062 -hsync -vsync
# 1600x1000 @ 60Hz
# Modeline "1600x1000" 133.142 1600 1704 1872 2144 1000 1001 1004 1035 +hsync +vsync
# 1600x1000 @ 75Hz
# Modeline "1600x1000" 169.128 1600 1704 1880 2160 1000 1001 1004 1044 +hsync +vsync
# 1600x1000 @ 85Hz
# Modeline "1600x1000" 194.202 1600 1712 1888 2176 1000 1001 1004 1050 +hsync +vsync
# 1600x1000 @ 100Hz
# Modeline "1600x1000" 232.133 1600 1720 1896 2192 1000 1001 1004 1059 +hsync +vsync
# 1600x1024 @ 60Hz
# Modeline "1600x1024" 136.385 1600 1704 1872 2144 1024 1027 1030 1060 +hsync +vsync
# 1600x1024 @ 75Hz
# Modeline "1600x1024" 174.416 1600 1712 1888 2176 1024 1025 1028 1069 +hsync +vsync
# 1600x1024 @ 76Hz
# Modeline "1600x1024" 170.450 1600 1632 1792 2096 1024 1027 1030 1070 +hsync +vsync
# 1600x1024 @ 85Hz
# Modeline "1600x1024" 198.832 1600 1712 1888 2176 1024 1027 1030 1075 +hsync +vsync
# 1920x1080 @ 60Hz
# Modeline "1920x1080" 172.798 1920 2040 2248 2576 1080 1081 1084 1118 -hsync -vsync
# 1920x1080 @ 75Hz
# Modeline "1920x1080" 211.436 1920 2056 2264 2608 1080 1081 1084 1126 +hsync +vsync
# 1920x1200 @ 60Hz
# Modeline "1920x1200" 193.156 1920 2048 2256 2592 1200 1201 1203 1242 +hsync +vsync
# 1920x1200 @ 75Hz
# Modeline "1920x1200" 246.590 1920 2064 2272 2624 1200 1201 1203 1253 +hsync +vsync
# 2048x1536 @ 60
# Modeline "2048x1536" 266.952 2048 2200 2424 2800 1536 1537 1540 1589 +hsync +vsync
# 2048x1536 @ 60
# Modeline "2048x1536" 266.952 2048 2200 2424 2800 1536 1537 1540 1589 +hsync +vsync
# 1400x1050 @ 60Hz M9 Laptop mode
# ModeLine "1400x1050" 122.000 1400 1488 1640 1880 1050 1052 1064 1082 +hsync +vsync
# 1920x2400 @ 25Hz for IBM T221, VS VP2290 and compatible display devices
# Modeline "1920x2400@25" 124.620 1920 1928 1980 2048 2400 2401 2403 2434 +hsync +vsync
# 1920x2400 @ 30Hz for IBM T221, VS VP2290 and compatible display devices
# Modeline "1920x2400@30" 149.250 1920 1928 1982 2044 2400 2402 2404 2434 +hsync +vsync

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"

# The chipset line is optional in most cases.  It can be used to override
# the driver's chipset detection, and should not normally be specified.

#    Chipset     "generic"

# The Driver line must be present.  When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module.  Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

    Driver      "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for.  When this line isn't present, a device
# section can only match up with the primary video device.  For PCI
# devices a line like the following could be used.  This line should not
# normally be included unless there is more than one video device
# installed.

#    BusID       "PCI:0:10:0"

#    VideoRam    256

#    Clocks      25.2 28.3

EndSection

# === ATI device section ===

Section "Device"
    Identifier                          "ATI Graphics Adapter"
    Driver                              "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor  ===
    #Option                              "NoDDC"
# === disable/enable XAA/DRI ===
    Option "no_accel"                   "no"
    Option "no_dri"                     "no"
# === misc DRI settings ===
    Option "mtrr"                       "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
    Option "DesktopSetup"               "0x00000100"
    Option "MonitorLayout"              "AUTO, NONE"
    Option "IgnoreEDID"                 "off"
    Option "HSync2"                     "unspecified"
    Option "VRefresh2"                  "unspecified"
    Option "ScreenOverlap"              "0"
# === TV-out Management ===
    Option "NoTV"                       "yes"
    Option "TVStandard"                 "NTSC-M"
    Option "TVHSizeAdj"                 "0"
    Option "TVVSizeAdj"                 "0"
    Option "TVHPosAdj"                  "0"
    Option "TVVPosAdj"                  "0"
    Option "TVHStartAdj"                "0"
    Option "TVColorAdj"                 "0"
    Option "GammaCorrectionI"           "0x00000000"
    Option "GammaCorrectionII"          "0x00000000"
# === OpenGL specific profiles/settings ===
    Option "Capabilities"               "0x00000000"
# === Video Overlay for the Xv extension ===
    Option "VideoOverlay"               "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
#       will be disabled automatically
    Option "OpenGLOverlay"              "off"
# === Center Mode (Laptops only) ===
    Option "CenterMode"                 "off"
# === Pseudo Color Visuals (8-bit visuals) ===
    Option "PseudoColorVisuals"         "off"
# === QBS Management ===
    Option "Stereo"                     "off"
    Option "StereoSyncEnable"           "1"
# === FSAA Management ===
    Option "FSAAEnable"                 "no"
    Option "FSAAScale"                  "1"
    Option "FSAADisableGamma"           "no"
    Option "FSAACustomizeMSPos"         "no"
    Option "FSAAMSPosX0"                "0.000000"
    Option "FSAAMSPosY0"                "0.000000"
    Option "FSAAMSPosX1"                "0.000000"
    Option "FSAAMSPosY1"                "0.000000"
    Option "FSAAMSPosX2"                "0.000000"
    Option "FSAAMSPosY2"                "0.000000"
    Option "FSAAMSPosX3"                "0.000000"
    Option "FSAAMSPosY3"                "0.000000"
    Option "FSAAMSPosX4"                "0.000000"
    Option "FSAAMSPosY4"                "0.000000"
    Option "FSAAMSPosX5"                "0.000000"
    Option "FSAAMSPosY5"                "0.000000"
# === Misc Options ===
    Option "UseFastTLS"                 "0"
    Option "BlockSignalsOnLock"         "on"
    Option "UseInternalAGPGART"         "no"
    Option "ForceGenericCPU"            "no"
    BusID "PCI:1:0:0"    # vendor=1002, device=4e50
    Screen 0
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen0"
    Device      "ATI Graphics Adapter"
    Monitor     "Monitor0"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
#        Virtual     1280 1024
    EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# Any number of ServerLayout sections may be present.  Each describes
# the way multiple screens are organised.  A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option.  In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present
    Identifier  "Server Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens.  The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.

    Screen "Screen0"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used.  Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

### EOF ###

Voilou, n'hesite pas à poser des questions !

#21 -1 »  [résolu] Wifi ne fonctionne plus après un dist-upgrade » Le 30/05/2005, à 22:09

PLOP
Réponses : 2

Salut à tous,

tout fonctionnait a merveille sur ma hoary jusqu'a il y a un ou deux jours, je fais un dist-upgrade comme cela m'arrive régulierement..

bon nouveau kernel 10-5.. très bien...et d'autres choses dont je ne me souviens plus...

toujours est t'il qu'après un reboot plus de Wifi  !!!!

Donc je regarde un peu les logs et aparemment ipw2200 pose problème a présent...

(j'ai une intel  2200)

j'ai beau installer la derniere version de ipw2200 j'ai toujours cette erreur :

sudo modprobe ipw2200
FATAL: Error inserting ipw2200 (/lib/modules/2.6.10-5-386/drivers/net/wireless/ipw2200.ko): Unknown symbol in module, or unknown parameter (see dmesg)

après un dmesg :

ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
ipw2200: Unknown symbol ieee80211_wx_set_encode
ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
ipw2200: Unknown symbol ieee80211_wx_get_encode
ipw2200: disagrees about version of symbol ieee80211_crypt_delayed_deinit
ipw2200: Unknown symbol ieee80211_crypt_delayed_deinit
ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol ieee80211_freq_to_channel
ipw2200: disagrees about version of symbol ieee80211_rx
ipw2200: Unknown symbol ieee80211_rx
ipw2200: disagrees about version of symbol ieee80211_rx_mgt
ipw2200: Unknown symbol ieee80211_rx_mgt
ipw2200: Unknown symbol ieee80211_get_geo
ipw2200: Unknown symbol ieee80211_is_valid_channel

Alors bon.. est ce le programme ?? est-ce une erreur de ma part..

Merci d'avance si vous avez une réponse !

#22 Re : -1 »  [résolu] Wifi ne fonctionne plus après un dist-upgrade » Le 31/05/2005, à 01:15

PLOP
Réponses : 2

merci pour la réponse.meme sèche wink

mais en fait j'ai résolu mon problème , après eradication de tout module existants j'ai effectué une reinstall de la 1.0.4 et après un reboot cela fonctionnait..

a pluche

#23 Re : -1 »  Economie d'énergie : pas moyen d'éteindre l'écran » Le 21/04/2005, à 15:01

PLOP
Réponses : 5

Si tu as une radeon, il existe radeontool pour eteindre..

#24 Re : -1 »  Documentation wiki ? » Le 13/04/2005, à 17:30

PLOP
Réponses : 4

ah cool !

oui en effet sa doit manquer de publicité ! tongue

j'ai vu le lien nul part ! ptet que l'ajouter au menu du site serait pas mal