Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 13

#0 -1 »  problème avec les caractères accentués en console » Le 24/05/2013, à 19:05

lanusquet
Réponses : 21

Bonjour à tous et merci de votre aide.

J'ai installé Ubuntu sur mon nouveau PC, à côté de Windows 8. Or sur les consoles (toutes, de 1 à 6), les caractère accentués s'affichent incorrectement (m accent aigu pour é, par exemple), que ce soit dans les noms de fichiers ou dans les pages du man lorsqu'elles sont en français, par exemple.
J'ai surfé sur le net en vain. J'ai essayé des tutos sur les locales, toujours sans résultat. Est-ce l'installation UEFI qui pose pb ?

Cordialement, jml (qui s'initie ***lentement**** à la console).

#1 Re : -1 »  problème avec les caractères accentués en console » Le 24/05/2013, à 23:22

lanusquet
Réponses : 21

Merci d'avoir pris le temps de me répondre.
Voici les renseignements demandés. Cordialement, jml.

locale
LANG="fr_FR.UTF-8"
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LD_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


echo $LANG
fr_FR.UTF-8

#2 Re : -1 »  problème avec les caractères accentués en console » Le 25/05/2013, à 11:09

lanusquet
Réponses : 21

Bonjour et encore merci.
Réponse bizarre à la première instruction (sudo apt-get install locales-all) :
*******
Aucune version du paquet locales-all n'est disponible, mais il existe dans la base de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète ou qu'il n'est disponibel que sur une autre source.
E: le paquet locales-all n'a pas de version susceptible d'être installé.
*******
Tout cela farci de caractères les plus fantaisistes !!!

#3 Re : -1 »  problème avec les caractères accentués en console » Le 25/05/2013, à 12:59

lanusquet
Réponses : 21

yeah !!!!!

La dernière réponse est :
impossible de trouver le paquet language-gnome-pack-fr
impossible de trouver le paquet language-gnome-pack-fr-base

MAIS LE PROBLEME EST RESOLU ! Les accents s'affichent désormais correctement.
Merci d'avoir bien voulu passer du temps là-dessus. Bien cordialement, jml.

#4 Re : -1 »  problème avec les caractères accentués en console » Le 25/05/2013, à 19:13

lanusquet
Réponses : 21

Oups !
Le problème n'est pas vraiment résolu !
En fait, au redémarrage, on en revient aux mêmes incohérences d'affichage...
Faut-il que j'ouvre un autre fil de discussion ou bien poursuivons-nous dans le même ?

Cordialement, jml.

#5 Re : -1 »  problème avec les caractères accentués en console » Le 25/05/2013, à 21:54

lanusquet
Réponses : 21

Les deux commandes, locale et echo $LANG retournent les mêmes infos que précédemment.

#6 Re : -1 »  problème avec les caractères accentués en console » Le 26/05/2013, à 16:31

lanusquet
Réponses : 21

Merci encore !

sudo dpkg-reconfigure locales

Genarating locales...
en_AG.UTF8... up-to-date
en_AU.UTF8... up-to-date
en_BW.UTF8... up-to-date
en_CA.UTF8... up-to-date
en_DK.UTF8... up-to-date
en_GB.UTF8... up-to-date
en_HK.UTF8... up-to-date
en_IE.UTF8... up-to-date
en_IN.UTF8... up-to-date
en_NG.UTF8... up-to-date
en_NZ.UTF8... up-to-date
en_PH.UTF8... up-to-date
en_SG.UTF8... up-to-date
en_US.UTF8... up-to-date
en_ZA.UTF8... up-to-date
en_ZM.UTF8... up-to-date
en_ZW.UTF8... up-to-date
fr_BE.UTF8... up-to-date
fr_CA.UTF8... up-to-date
fr_CH.UTF8... up-to-date
fr_FR.UTF8... up-to-date
fr_LU.UTF8... up-to-date
Generation complete.

sudo dpkg-reconfigure keyboard-configuration
(après les deux-points, mes choix parmi les propositions)
Modèle de clavier : Dell (Mon ordi est un Dell, je choisis 'Dell' sans option, parce que je ne sais trop quoi prendre dans la centaine d'options proposées).
Pays d'origine du clavier : Français
Disposition du clavier : Français
Touche destinée à se substituer à AltGr : touche alt de droite (AltGr)
Touche compose : pas de touche compose
Faut-il utiliser Control+Alt+Ret.Arr. pour arrêter le serveur graphique ? : Oui
update-initramfs: deferring update (trigger activated)
Traitement des actions différées ("triggers") pour "initramfs-tools"...
update-initramfs: Generating /boot/initrd.img-3.8.0-21-generic
(A PARTIR DE différées COMPRIS, LES ACCENTS SONT REVENUS NORMALEMENT, mais ils ont disparu de nouveau au reboot)

sudo apt-get install language-pack-fr language-pack-fr-base language-gnome-pack-fr language-gnome-pack-fr-base
lecture des listes de paquets... Fait
E: impossible de trouver le paquet language-gnome-pack-fr
E: impossible de trouver le paquet language-gnome-pack-fr-base

#7 Re : -1 »  problème avec les caractères accentués en console » Le 26/05/2013, à 22:19

lanusquet
Réponses : 21

Voilà, en effet ! Tout cela se configure correctement grâce aux manips que tu as proposées, mais seulement pour la session en cours.
Le plus étrange, c'est que, sur mon précédent portable, un Acer sous Vista, le double boot n'a jamais posé ce type de pb.

#8 Re : -1 »  problème avec les caractères accentués en console » Le 27/05/2013, à 11:26

lanusquet
Réponses : 21

La cause est-elle un mauvais choix du clavier dans la liste proposée par sudo dpkg-reconfigure keyboard-configuration ?
Pourquoi, selon toi, les changements sont pris en compte immédiatement mais non enregistrés par le système et disparaissent au boot suivant ?
Enfin, dans quel fichier est rangée la configuration du clavier, qu'on pourrait modifier directement ?

De mon côté, je prends contact avec Dell pour leur demander quel clavier choisir dans la liste.

Cordialement, jml.

#9 Re : -1 »  problème avec les caractères accentués en console » Le 27/05/2013, à 15:14

lanusquet
Réponses : 21

Ben non, je suis en session d'utilisateur principal.
De toutes façons, je passe par la commande sudo chaque fois.

#10 Re : -1 »  problème avec les caractères accentués en console » Le 28/05/2013, à 09:21

lanusquet
Réponses : 21

Très intéressant !!!
1) En effet, le pb ne concerne que les consoles tty[1-6] ; le terminal, lui, reste convenablement accentué.
2) Pour ce qui concerne sudo dpkg-reconfigure console-data : j'ai 4 choix. Un recommandé pour les claviers USB (mais mon PC est un portable), un qui conserve le réglage de /etc/console, maintenu avec la commande install-keymap (8), un qui conserve le réglage du noyau (ne charge aucun codage du clavier au démarrage), enfin un qui propose de choisir un codage clavier dans la liste complète.
Aucune des possibilités ni sous-possibilités ne règle le pb.
3) Pour ce qui concerne sudo dpkg-reconfigure console-setup : on retombe sur les mêmes réponses que précédemment
update-initramfs: deferring update (trigger activated)
Traitement des actions différées ("triggers") pour "initramfs-tools"...
update-initramfs: Generating /boot/initrd.img-3.8.0-21-generic
Et le pb est réglé... jusqu'au prochain reboot.

Merci d'avoir pris le temps et la peine de répondre à mes questions.

Question subsidiaire : comment recopie-t-on ici des pages de la console comme tu viens de le faire ? Ça m'éviterait des recopies plus que laborieuses !

#11 -1 »  mot de passe su à l'installation » Le 13/11/2012, à 14:14

lanusquet
Réponses : 4

Bonjour et merci à ceux qui prennent ce temps d'aide.

Je viens d'installer Ubuntu sur mon PC. C'est la première fois que j'essaie Ubuntu (je viens de Mandriva). A l'installation, le logiciel m'a demandé de configurer mon compte (nom, mot de passe, etc.) Mais rien sur l'administrateur. Du coup, sur la console, lorsque j'essaie de me placer en su -, un mot de passe m'est demandé... Mais quel est-il ?? Ni le mien (bien entendu (1)), ni une entrée vide ne sont acceptés.

Cordialement, jml.

#12 Re : -1 »  mot de passe su à l'installation » Le 13/11/2012, à 14:49

lanusquet
Réponses : 4

Merci de cette réponse et de sa rapidité.
Cordialement, jml.