Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  [Mailpictures] Envoyer des photos/fichiers par Email avec Nautilus » Le 02/09/2007, à 10:47

Paul Atreides
Réponses : 343

big_smile

Merci beaucoup pour cette petite perle que je viens juste de découvrir à mon retour de vacances (du coup, j'ai laissé les autres essuyer les plâtres et attaque directement à la version 0.7... c'est pas pour autant que je ne ferai pas remonter les bugs éventuels, mais pour l'instant tout baigne).

Encore bravo !

#1 Re : -1 »  [Resolu] Thunderbird already running... et pourtant non !? » Le 06/06/2007, à 16:01

Paul Atreides
Réponses : 15

smile
Quant à moi, les méthodes précédentes n'ont pas fonctionné.
Comme j'avais dans l'idée que c'était sûrement Thunderbird qui avait dû se faire des noeuds dans la tête avec la gestion de ses profils, j'ai juste lancé à nouveau thunderbird dans un terminal avec l'option "gestion des profils" :

/usr/bin/thunderbird -P

Là, il n'y avait que le profil par défaut. Je l'ai laissé mais ai créé un second profil en lui indiquant le chemin du répertoire temporaire de Thunderbird (du style : /home/--utilisateur--/.thunderbird/xxxxxxxx.default).

Et miracle, là, ça remarche illico !

En espérant que cette astuce permettra de tirer d'affaires d'autres Ubunteros !

#2 Re : -1 »  [astuce] Créer un panoramique » Le 30/12/2007, à 08:56

Paul Atreides
Réponses : 16

Bonjour,

Je vous signale l'existence depuis quelques temps d'une version Ubuntu de Autopano Pro, un logiciel très performant développé par une équipe française dynamique et qui crée de façon automatique des panoramas de toute beauté avec possibilité d'influer manuellement sur les réglages si on le souhaite.

Il est possible de télécharger le fichier .deb de la version démo ici : http://www.autopano.fr/
De très nombreuses explications figurent sur le site (notamment vidéo) et il existe un forum d'utilisateurs très utile pour débuter...

Bon panoramas 2008 à  tous !

#3 Re : -1 »  Electricsheep : un screensaver génial ! » Le 03/02/2008, à 20:13

Paul Atreides
Réponses : 43
joachim109 a écrit :

Est-ce que quelqu'un sait comment faire en sorte d'activer le clavier pendant l'économiseur d'écran sous gutsy ?
parce que sous windows ça marche et cela permet entre autres de voter pour les meilleurs 'sheeps' (ou pour éliminer ceux qui ne plaisent pas...)

J'ai jamais trouvé et ça me désole car c'est bien pratique comme fonction pour améliorer les sheeps... hmm

#4 Re : -1 »  Electricsheep : un screensaver génial ! » Le 09/11/2008, à 22:17

Paul Atreides
Réponses : 43

Salut,
Pour le svn, il faut être sûr de ce qu'on fait et avoir déjà compilé auparavant.
Si c'est le cas, il suffit de charger les fichiers en tapant :

svn co https://electricsheep.svn.sourceforge.net/svnroot/electricsheep electricsheep

dans un terminal.
Puis de se rendre dans le répertoire qui contient le client :

cd electricsheep/trunk/client

et de taper les commandes habituelles pour la compilation :

./configure
make
sudo make install

Note : pour réussir la compilation, il faut les dépendances suivantes :
curl
expat
et leurs librairies (y compris comme d'hab pour compiler, les librairies -dev...
Voili voilou.

#5 -1 »  [Résolu ?] Gutsy ne démarre qu'avec "acpi=off" (MSI M670 sempron) » Le 02/11/2007, à 13:29

Paul Atreides
Réponses : 17

Bonjour à tous,

Je suis l'heureux propriétaire d'un portable MSI M670 (sempron 1.8MHz) qui marchait à merveille sous Feisy Fawn (7.04). Malheureusement, depuis mon passage sous Gustsy (7.10) il ne veut plus démarrer sans l'ajout de l'option acpi=off au boot.

Cela me permet de vous écrire depuis Gutsy, certes, mais pose différents problèmes, surtout pour un portable. En effet, le premier d'entre eux est qu'il n'y a plus de gestion d'énergie (puisque c'est l'ACPI qui s'en occupait) ! en plus, il ne s'arrête plus tout seul et je dois appuyer sur le bouton à la fin de la séquence d'arrêt. S'il n'y avait que ça, ce ne serait rien, mais l'absence de gestion d'énergie est très handicapante sur un portable...

J'ai pas mal bourlingué sur le net, google, mais surtout les différents forums Ubuntu (français et anglais) sans vraiment trouvé de solution à mon problème.
J'ai testé tout un tas d'options de boot (noapic, nolapic, pci=noacpi, acpi=force, irqpoll, pci=nomsi etc.) sans succès.

J'ai même mis à jour mon bios avec le firmware fourni par MSI, sans que cela n'améliore le problème.

Comme cela fonctionnait sans problème sous Feisty Fawn, c'est vraiment une régression plutôt qu'une évolution, je trouve.

Est-ce que l'un des gourous linuxiens présents sur le site pourrait m'orienter vers une piste qui me sortirait de cette situation ?

Merci d'avance !!!

#6 Re : -1 »  [Résolu ?] Gutsy ne démarre qu'avec "acpi=off" (MSI M670 sempron) » Le 02/11/2007, à 16:13

Paul Atreides
Réponses : 17

big_smile

Grand bravo à toi Tong !!!
Un seul message sur le forum, une seule réponse et c'est la bonne !
Surtout que je désespérais franchement d'y arriver un jour... En fait, la solution ne passait pas du tout par l'inhibition de l'ACPI (qui est très gênante) ; du coup, j'ai bien la gestion des batteries sur Gutsy... Exactement ce que je désirais.

Je précise qu'il s'agit du boot sur disque dur une fois l'installation effectuée, donc d'une solution tout à fait définitive et que ne joue pas que pour le live CD d'installation.

Je pense qu'il faudrait d'élever au grade de "grand gourou d'Ubuntu" ! wink

De plus, c'est une bonne nouvelle pour toi, car tu sais que sur une config équivalente à la tienne cela fonctionne et tu vas pouvoir passer le cap vers Gutsy !!!

Merci encore...

#7 Re : -1 »  [Résolu ?] Gutsy ne démarre qu'avec "acpi=off" (MSI M670 sempron) » Le 02/11/2007, à 19:45

Paul Atreides
Réponses : 17

hmm

Juste un petit souci tout de même. Il semble que la mise en veille et l'hibernation ne fonctionnent pas avec ce réglage. Dans les deux cas, l'écran devient noir avec apparition furtive de la fenêtre de saisie de mot de passe (celui censé réapparaître à la fin de la mise en veille ou hibernation) puis dans le 1er cas, l'ordi s'arrête, dans le second non. Mais dans les deux cas, impossible de redémarrer normalement, l'écran reste désespérément noir...

Je vais continuer à faire quelques tests pour voir si - par exemple - les trois paramètres sont indispensables. Peut-être qu'en enlevant noapic, cela fonctionnerait tout de même ? à voir...

#8 Re : -1 »  [Résolu ?] Gutsy ne démarre qu'avec "acpi=off" (MSI M670 sempron) » Le 06/11/2007, à 19:57

Paul Atreides
Réponses : 17

Y a pas de problème. Tu as déjà permis que je boote avec l'ACPI ce qui sur un portable est esssentiel. Maintenant les fonctionnalités sleep / hibernate sont moins importantes à mon sens que la gestion d'énergie.

Merci encore.

#9 Re : -1 »  [Résolu ?] Gutsy ne démarre qu'avec "acpi=off" (MSI M670 sempron) » Le 25/11/2007, à 20:00

Paul Atreides
Réponses : 17

Bon, finalement, en désespoir de cause, j'ai fini par revenir à Feisty Fawn qui gérait très bien tout ça sur le MSI. J'attendrai la prochaine version en espérant que des progrès auront été fait dans ce domaine ! hmm

#10 -1 »  [HOW-TO] Veille et Hibernation enfin fonctionnelles... (Hardy) » Le 12/05/2008, à 12:12

Paul Atreides
Réponses : 14

Bonjour,

Ayant beaucoup galéré pour faire fonctionner la mise en veille et l'hibernation sur mon laptop Toshiba P200-1FY, je mets en ligne la méthode simple qui permet d'y arriver et qui fonctionne parfaitement sous Ubuntu Hardy 8.04.

Cette méthode a été testé sur cet appareil (voir caractéristiques sur le site de Toshiba en bref Core2Duo T7250 2GHz, réseau Intel® Wireless WiFi™ Link 4965AGN et Express chipset Intel® PM965, ATI Mobility™ Radeon® HD2600) mais devrait être supportée par d'autres types de portables... à voir...

1. Vérifier que tous les paquets indispensables sont présents sur l'ordinateur :

sudo apt-get install acpi acpid acpi-support laptop-mode-tools powermanagement-interface pm-utils

2. Modifier le fichier /etc/default/acpi-support de cette façon :

sudo gedit /etc/default/acpi-support

pour qu'il corresponde à ça :

# Change the following to "standby" to use ACPI S1 sleep, rather than S3.
# This will save less power, but may work on more machines
ACPI_SLEEP_MODE=mem

# Add modules to this list to have them removed before suspend and reloaded
# on resume. An example would be MODULES="em8300 yenta_socket"
#
# Note that network cards and USB controllers will automatically be unloaded 
# unless they're listed in MODULES_WHITELIST
MODULES=""

# Add modules to this list to leave them in the kernel over suspend/resume
MODULES_WHITELIST=""

# Should we save and restore state using the VESA BIOS Extensions?
SAVE_VBE_STATE=false

# The file that we use to save the vbestate
VBESTATE=/var/lib/acpi-support/vbestate

# Should we attempt to warm-boot the video hardware on resume?
POST_VIDEO=false

# Save and restore video state?
# SAVE_VIDEO_PCI_STATE=true

# Should we switch the screen off with DPMS on suspend?
USE_DPMS=true

# Use Radeontool to switch the screen off? Seems to be needed on some machines
# RADEON_LIGHT=true

# Uncomment the next line to switch away from X and back again after resume.
# This is needed for some hardware, but should be unnecessary on most.
# DOUBLE_CONSOLE_SWITCH=true

# Set the following to "platform" if you want to use ACPI to shut down
# your machine on hibernation
#HIBERNATE_MODE=shutdown
HIBERNATE_MODE=platform

LOCK_SCREEN=true

# Uncomment this line to have DMA disabled before suspend and reenabled
# afterwards
# DISABLE_DMA=true

# Uncomment this line to attempt to reset the drive on resume. This seems
# to be needed for some Sonys
# RESET_DRIVE=true

# Add services to this list to stop them before suspend and restart them in 
# the resume process.
STOP_SERVICES=""

# Restart Infra Red services on resume - off by default as it crashes some
# machines
RESTART_IRDA=false

# Switch to laptop-mode on battery power - off by default as it causes odd
# hangs on some machines
ENABLE_LAPTOP_MODE=true

# Spindown time on battery
SPINDOWN_TIME=12

3. Tester si le mode mise en veille fonctionne à blanc :

sudo pm-suspend

4. Tester si le mode hibernation fonctionne à blanc :

sudo pm-hibernate

5. Si tout fonctionne (ce qui devrait être le cas), sauvegarder deux fichiers système que nous allons modifier :

sudo cp /usr/lib/hal/scripts/hal-system-power-suspend /usr/lib/hal/scripts/hal-system-power-suspend.original
sudo cp /usr/lib/hal/scripts/hal-system-power-hibernate /usr/lib/hal/scripts/hal-system-power-hibernate.original

6. Modification des fichiers en question :

pour la mise en veille,

sudo gedit /usr/lib/hal/scripts/hal-system-power-suspend

Vider son contenu et y mettre à la place :

#!/bin/sh

/usr/sbin/pm-suspend

puis pour l'hibernation,

sudo gedit /usr/lib/hal/scripts/hal-system-power-hibernate

Vider son contenu et y mettre à la place :

#!/bin/sh

/usr/sbin/pm-hibernate

7. Sauvegarder vos nouveaux fichiers (en cas de mise à jour de Hal) :

sudo cp /usr/lib/hal/scripts/hal-system-power-hibernate /usr/lib/hal/scripts/hal-system-power-hibernate.fonctionnel
sudo cp /usr/lib/hal/scripts/hal-system-power-suspend /usr/lib/hal/scripts/hal-system-power-hibernate.suspend.fonctionnel

en cas de mise à jour de Hal qui modifierait ces fichiers et mettrait à néant tous nos efforts, pas de panique, il suffirait de refaire :

sudo cp /usr/lib/hal/scripts/hal-system-power-hibernate.fonctionnel /usr/lib/hal/scripts/hal-system-power-hibernate
sudo cp /usr/lib/hal/scripts/hal-system-power-suspend.fonctionnel /usr/lib/hal/scripts/hal-system-power-suspend


Normalement tout devrait fonctionner parfaitement ainsi.

Pour terminer, au retour de veille ou d'hibernation, le réseau devrait refonctionner impeccable pour peu que l'on utilise l'excellent wicd à la place de network manager qui n'est franchement pas à la hauteur (voir la doc de wicd pour l'installation facile de ce gestionnaire de connexion en remplacement de network manager).

Le seul bug à signaler est le fait qu'au retour de veille, il n'y a plus de son.
J'avais trouvé un workaround (comme disent nos amis britanniques) qui rétablissait le son en une seule commande à taper dans un terminal dès le retour de veille :[/b]

sudo alsa force-reload

Et le son était rétabli...

Restait à l'intégrer et à l'automatiser au retour de veille ou d'hibernation.

C'est chose faite big_smile et voici la manip' :

8. Modification permettant d'avoir le son au retour de veille :

sudo gedit /usr/lib/pm-utils/sleep.d/50modules

Dans la partie :

unload_network()
{
	for x in /sys/class/net/*; do
	if [ -e $x/device/driver ]; then
		NETMODULES="$NETMODULES $(basename $(readlink $x/device/driver) | tr [:upper:\] [:lower:])"
	fi
	done
	for x in $NETMODULES; do
		modunload $x;
	done
	if [ -d /sys/module/ndiswrapper ]; then
	        modunload ndiswrapper;
	fi
}

case "$1" in
	hibernate|suspend)
		suspend_modules
		unload_network
		;;
	thaw|resume)
		resume_modules
                invoke-rc.d networking restart
		;;
	*)
		;;
esac

il suffit de rajouter après la ligne invoke-rc.d networking restart le fameux workaround évoqué précédemment :

alsa force-reload

pour que la partie en question ressemble à ça :

unload_network()
{
	for x in /sys/class/net/*; do
	if [ -e $x/device/driver ]; then
		NETMODULES="$NETMODULES $(basename $(readlink $x/device/driver) | tr [:upper:\] [:lower:])"
	fi
	done
	for x in $NETMODULES; do
		modunload $x;
	done
	if [ -d /sys/module/ndiswrapper ]; then
	        modunload ndiswrapper;
	fi
}

case "$1" in
	hibernate|suspend)
		suspend_modules
		unload_network
		;;
	thaw|resume)
		resume_modules
                invoke-rc.d networking restart
		alsa force-reload
		;;
	*)
		;;
esac

Et ça marche !! big_smile (merci à Akred et roger64 de m'avoir incité à me replonger sur le problème et de m'avoir ainsi soufflé la réponse)...

N'hésitez pas à faire vivre ce post ! smile

#11 Re : -1 »  [HOW-TO] Veille et Hibernation enfin fonctionnelles... (Hardy) » Le 03/06/2008, à 09:50

Paul Atreides
Réponses : 14

@Akred :

Bonjour,
En fait, cela ne fonctionnait pas du tout, tout simplement. Là, ça marche parfaitement, avec le petit bémol de la manipulation d'alsa lors du retour mais j'ai mis un lanceur pour ça sur mon bureau et c'est l'histoire d'un clic... donc pour moi, je considère que c'est réglé, sauf à parfaire le truc en automatisant la remise à zéro d'alsa lors du retour, mais je ne sais pas comment m'y prendre...

@roger64 :

Bonjour,
Le programme pm-suspend se trouve dans le paquet pm-utils. Normalement, il est chargé automatiquement sous Hardy mais sinon, il suffit de taper

sudo apt-get install pm-utils

pour l'installer.
Une fois installé, il suffit de taper les commandes "à blanc" pour se rendre compte s'il y a un  problème ou non. Si ça marche correctement, il suffit de suivre le reste du tuto pour automatiser tout ça.
Voili, voilou...

P.S. : si ça marche pas "à blanc", tout n'est pas perdu car le programme pm-suspend admet pas mal d'options qu'il faut essayer les unes après les autres pour trouver le bon choix (voir man pm-suspend).

#12 Re : -1 »  [HOW-TO] Veille et Hibernation enfin fonctionnelles... (Hardy) » Le 03/06/2008, à 10:04

Paul Atreides
Réponses : 14

big_smile

Merci à Akred et à roger64 !!!

Grâce à vous, je me suis repenché sur le problème de son ayant disparu au retour de veille ou d'hibernation. Vos remarques m'ont aiguillé vers la solution qui fonctionne à merveille. Je l'ajoute dans le post initial pour qu'il soit complet...

Ah, Linux... c'est merveilleux : big_smile wink

#13 Re : -1 »  [HOW-TO] Veille et Hibernation enfin fonctionnelles... (Hardy) » Le 03/06/2008, à 19:15

Paul Atreides
Réponses : 14

C'est pas que j'utilise pas pulseaudio, mais il se trouve qu'en faisant cela, ça marche, alors je cherche pas plus loin...
Quant aux forces de l'ombre qui conspirent, c'est la règle... suffit de voir le nom du démon en question : HAL (soit IBM en décalant les lettres sur la droite... merci à Arthur C. Clarke et Stanley Kubrick wink )

#14 Re : -1 »  [HOW-TO] Veille et Hibernation enfin fonctionnelles... (Hardy) » Le 20/09/2008, à 10:25

Paul Atreides
Réponses : 14

Merci à tous... content de voir que ces quelques conseils ont pu dépanner certains ! smile

#15 Re : -1 »  VirtualBox : une alternative libre à VMWare ? » Le 06/06/2007, à 19:04

Paul Atreides
Réponses : 612

smile
La dernière version de VirtualBox vient de sortir. Il s'agit de la version 1.4
Innotek a eu l'agréable idée de faire un dépôt pour feisty !!!
ça gère notamment le presse-papier de l'hôte vers l'invité et vice-versa.
On peut utiliser une image Vmware...
J'ai remarqué également une simplification de la gestion des dossiers partagés.

et surtout pour tous ceux qui l'attendait, une version 64 bits !!

Enfin, à découvrir de toute urgence !

le lien :

http://blog.racoon97.net/index.php?2007 … virtualbox

#16 Re : -1 »  skype : static ou dynamic ? (resolu ) » Le 25/11/2008, à 12:53

Paul Atreides
Réponses : 5

A partir de synaptic, Skype static est celui qui a le plus de chance de s'installer surtout pour un débutant.

C'est dommage que la doc ne fasse pas mention de cela car j'ai un ami qui a galéré et que j'ai dû aider par tel en lui disant de charger skype static à partir du dépôt Medibuntu dans synaptic...

(déjà que je ne suis pas pour l'utilisation de Medibuntu pour un débutant sous Ubuntu au risque de le faire fuir...).

#17 Re : -1 »  Serveur Impression Dlink DP-301P+ » Le 30/12/2007, à 09:05

Paul Atreides
Réponses : 14

Pour info sur un autre serveur d'impression DLink (le DPR 1260) sous 7.10, la ligne qui permet de piloter ma Samsung ML-2250 est la suivante : lpd://192.168.0.10/ML-2250
Si cela peut aider... car j'ai moi-même pas mal tatonné avant de trouver comment le faire fonctionner mais maintenant ça marche nickel.

#18 Re : -1 »  Ubuntu sur HP Pavilion DV9649 ? » Le 08/12/2007, à 10:45

Paul Atreides
Réponses : 6

Je suis également très intéressé par ce modèle pour passer au laptop... mais je me pose les mêmes questions ! alors, si quelqu'un a des lumières, comme zehorus, je suis preneur de tout retour d'expériences !!!
Merci et longue vie à  Ubuntu-fr !

#19 Re : -1 »  EasyTunes - un logiciel pour écouter les radios sur la freebox. » Le 02/06/2007, à 13:42

Paul Atreides
Réponses : 56

J'ai peur que ce soit un problème de dépendances. Mais comme ça marchait avant, je ne vois pas. Sinon, ce serait bien d'ajouter dans le premier message la ligne de commande pour installer d'un coup toutes les dépendances nécessaires au fonctionnement du logiciel, non ?

#20 Re : -1 »  EasyTunes - un logiciel pour écouter les radios sur la freebox. » Le 02/06/2007, à 22:51

Paul Atreides
Réponses : 56

smile
Un nouveau sudo make install dans le répertoire d'EasyTunes a réglé le problème...
Je peux de nouveau profiter de ce super logiciel, merci encore Marc !

#21 Re : -1 »  EasyTunes - un logiciel pour écouter les radios sur la freebox. » Le 01/07/2007, à 11:13

Paul Atreides
Réponses : 56

smile Je l'utilise quotidiennement et en suis très satisfait ! La mise à jour m'a été signalée automatiquement mais nécessite l'appui sur le bouton U pour se dérouler, ce qui se passe sans aucun problème.
Merci encore Marc pour ce merveilleux programme ! big_smile

#22 Re : -1 »  EasyTunes - un logiciel pour écouter les radios sur la freebox. » Le 14/07/2007, à 20:01

Paul Atreides
Réponses : 56

Merci encore Marc ! toujours sur la brèche je vois, même le jour de la fête nat' !!!

#23 Re : -1 »  Lightzone 2 pour Linux officiellement dispo » Le 13/10/2007, à 09:53

Paul Atreides
Réponses : 56

Eh ben, ça tombe bien puisque l'archive de Lightzone est directement utilisable. La seule chose à faire est de la décompresser dans un répertoire de ton choix (ex. /opt/LightZone) et de lancer l'exécutable intitulé... LightZone soit dans un terminal :
sh /opt/LightZone/LightZone
soit en créant un lanceur sur ce modèle... voilà. Les icônes pour le lanceur sont dans le répertoire en question. Amuse-toi bien !

PS Quel dommage que LightCrafts ait décidé de cesser le développement de ce logiciel sous Linux. Pour ceux qui seraient intéressé, LightZone 3 pour windows fonctionne parfaitement en environnement virtualisé sous VirtualBox et avec la dernière fonctionnalité "seamless mode" de VirtualBox, bien malin qui pourrait savoir que le logiciel tourne sous windows puisque l'ensemble de l'environnement Ubuntu reste parfaitement disponible !!!

#24 Re : -1 »  [Résolu] -> message d'erreur sur synaptic: paquet debconf à revoir ? » Le 06/10/2007, à 11:24

Paul Atreides
Réponses : 3
sudo dpkg-reconfigure debconf

ça marche impeccable ! Merci big_smile