Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 10:51

bruno
Réponses : 12

Bonjour,

Tu n'aurais pas installé le paquet biosdevname par hasard ? Et si oui, pourquoi ?

#1 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 13:18

bruno
Réponses : 12

Sûr ? Quel est le retour de :

sudo aptitude show biosdevname

et de

ls -l /etc/udev/rules.d 

Parce qu'avoir ce nom pour une interface réseau c'est typique de l'utilisation de ce paquet…

#2 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 13:41

bruno
Réponses : 12

Donc maintenant, après redémarrage du système tu devrais retrouver eth* pour tes noms d'interfaces réseau.
Quant au paquet biodevname, c'est curieux car il ne s'installe pas tout seul, jamais.

#3 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 14:44

bruno
Réponses : 12

Bizarre, c'est quoi comme machine ?
En principe, sauf indication contraire dans une règle udev (ou BIOS bizarre), les interfaces réseau Ethernet sont nommées eth*
Il faudrait examiner les logs de démarrage (dmesg) et voir la sortie de ip addr (ou ifconfig).

En cherchant « p4p1 » sur le web, il y a des solutions qui concernent Fedora mais qui peuvent peut être s'appliquer à ton cas.
http://www.howtoforge.com/forums/showth … iosdevname

#4 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 16:06

bruno
Réponses : 12

Termine l'installation et essaie de suivre la méthode qui est proposée sur le forum que j'ai mis en lien.

#5 Re : -1 »  Interface réseau eth0 en p4p1 » Le 12/09/2014, à 17:19

bruno
Réponses : 12

C'est quand même étrange que ce paquet s'installe tout seul…
Après ce n'est sans doute pas gênant que ton interface graphique s'appelle p4p1 plutôt que eth0

Il faudrait quand même voir lr résultat de :

ifconfig

#6 Re : -1 »  Règles iptables trop imperméable » Le 12/09/2014, à 11:15

bruno
Réponses : 37

@Pator75 : c'est parce que (apparemment) tu ne comprends pas le fonctionnement d'iptables. Les règles sont appliqués les unes après les autres, dans l'ordre, de la première à la dernière.
Donc on commence par tout bloquer (DROP sur tout ce qui entre) et on autorise ensuite un service, une ip, un bvloc d'ip, etc.

EDIT: je me rend compte que ce que j'ai écrit n'est pas clair : les règles sont appliquées dans l'ordre où elles ont été placées, la dernière règle prenant toujours le pas sur la précédente.

#7 Re : -1 »  Règles iptables trop imperméable » Le 12/09/2014, à 11:24

bruno
Réponses : 37

C'est un principe de base en matière de sécurité, et cela n'a rien de spécifique à iptables : on commence par tout interdire et on autorise ensuite au coup par coup, jamais l'inverse.

#8 Re : -1 »  Règles iptables trop imperméable » Le 12/09/2014, à 13:21

bruno
Réponses : 37

@Pator75: où ça ailleurs que chez iptables ? Parce que des pare-feux qui fonctionnent à l'inverse de la logique la plus élémentaire je n'en ai jamais vu, ni sous Linux, ni sous BSD, ni ailleurs.

#9 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 10:36

bruno
Réponses : 23

Bonjour,

Deux choses à essayer.
Une fois connecté en SSH sur le serveur, essaie de lancer ton script en ligne de commande :

/usr/bin/php /exemple/exemple/exemple/exemple/monscript.php

Si cela ne marche pas il faut effectivement utiliser wget dans ta tâche cron mais ainsi :

0 1 * * 6 /usr/bin/wget -q http://monsite.com/monscript.php

#10 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 11:05

bruno
Réponses : 23

Attention ton hébergeur te fournit du PHP en version 4.4.9 dans la version en ligne de commande ! Or la gestion des exceptions n'est apparue que dans PHP 5…
Il semble bien portant que le module PHP pour le serveur web soit en version 5 (puisque cela marche).


C'est assez curieux comme configuration… Donne-nous le retour de :

/usr/bin/php5 -v

Si cela renvoie PHP 5*****, alors tu pourras mettre dans ton cron :

0 1 * * 6 /usr/bin/php5 /exemple/exemple/exemple/exemple/monscript.php

#11 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 11:22

bruno
Réponses : 23

Oui tu as bien compris.

La première solution  avec php5 est préférable car le script est exécuté directement sur le serveur par l'interpréteur PHP.

La seconde solution passe par wget qui va interroger le serveur (avec une résolution de nom au passage) et lui demander d'exécuter le script php. Cette solution mobilise donc plus de ressources et de temps.

#12 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 11:46

bruno
Réponses : 23

C'est une pratique assez courante chez les hébergeurs de proposer plusieurs versions de php. Cela doit être documenté chez ton hébergeur (notamment comment utiliser tel ou telle version).

Pour comprendre l'histoire de la version 5.2, il faudrait regarder ce que sont réellement ces fichiers (des exécutables, des liens symboliques,…) :

ls -l /usr/bin/php*

#13 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 12:17

bruno
Réponses : 23

Bon c'est clair les exécutables sont dans /usr/lib/cgi-bin/ et il y a des liens symboliques (tu as coupé tes lignes) :

lrwxrwxrwx 1 root root       19 Nov 19  2013 /usr/bin/php -> ../lib/cgi-bin/php4
lrwxrwxrwx 1 root root       19 Nov 19  2013 /usr/bin/php4 -> ../lib/cgi-bin/php4
lrwxrwxrwx 1 root root       19 Nov 21  2013 /usr/bin/php5 -> ../lib/cgi-bin/php5
lrwxrwxrwx 1 root root       21 Dec 10  2013 /usr/bin/php5.4 -> ../lib/cgi-bin/php5.4
lrwxrwxrwx 1 root root       21 Dec 10  2013 /usr/bin/php5.5 -> ../lib/cgi-bin/php5.5
lrwxrwxrwx 1 root root       21 Dec 10  2013 /usr/bin/php6 -> ../lib/cgi-bin/php5.4

Pour résumer, en ligne de commande :

php -> PHP version 4.4.9
php5 -> PHP version 5.2.17
php5.4 -> PHP version 5.4
php5.5 -> PHP version 5.5

php6 -> PHP version 5.4 (c'est idiot de toute façon PHP 6 ne sortira jamais wink)

#15 Re : -1 »  [Resolu] Probleme execution de script php avec cron » Hier à 14:14

bruno
Réponses : 23

Dans la mesure où tous ces fichiers appartiennent à root je doute fort que tu puisses le faire. Ce n'est pas un serveur dédié, ni un serveur virtuel, mais un hébergement mutualisé (enfin je suppose) tu n'as donc pas de droits 'root', ni de possibilité d'utiliser sudo.

#16 Re : -1 »  Problème avec gnupg et kgpg » Le 11/09/2014, à 17:54

bruno
Réponses : 10

Tu as modifié le fichier .gnupg/gpg.conf ? Vérifie qu'il y a bien une ligne 'use-agent'.
Et quel est le contenu du fichier .gnupg/gpg-agent.conf ?

#17 Re : -1 »  Problème avec gnupg et kgpg » Le 12/09/2014, à 09:39

bruno
Réponses : 10

Cela ne répond pas à mes questions…
Ce n'est pas normal que tu n'aies pas de fichier gpg-agent.conf. Le paquet gnupg-agent est-il bien installé ? Idéalement ces paquets doivent être installés : gnupg2 gnupg-agent kgpg pinentry-qt4

S'il en manque installe-les, puis supprime le fichier ~/.kde/share/config/kgpgrc et relance ta session KDE.

#18 Re : -1 »  Problème avec gnupg et kgpg » Le 12/09/2014, à 11:09

bruno
Réponses : 10

Avec plaisir, pense à modifier ton premier message pour mettre [Résolu] devant le titre.

#19 Re : -1 »  Problème avec gnupg et kgpg » Le 13/09/2014, à 09:28

bruno
Réponses : 10

Je suppose que c'est également dû à des bidouillages avec la commande sudo (Attention de ne pas lancer d'application en mode graphique avec cette commande).

Donc être sûr de te réapproprier tous les fichiers de ton dossier personnel :

sudo chown -R denis:denis /home/denis/

Puis relancer ta session KDE.

#20 Re : -1 »  [Résolu] Utilisateur SFTP bloqué dans son répertoire » Le 13/09/2014, à 10:51

bruno
Réponses : 21

Soit root est membre du groupe sftpusers, soit il y a encore une erreur dans ton fichier de configuration. L'erreur que tu signales concernant la directive Match n'est pas normale…

#21 Re : -1 »  Rsync ne veut rien savoir avec un port différent de 22 » Le 13/09/2014, à 12:18

bruno
Réponses : 8

Il manque une espace :

-e 'sssh -p 2224'

#22 Re : -1 »  Rsync ne veut rien savoir avec un port différent de 22 » Le 13/09/2014, à 15:39

bruno
Réponses : 8
rsync -av --del --progress -e 'ssh -p 2224' root@195.168.48.1:/var/log/ /home/jyl/backup-logs-server1/

Y-a-t-il des messages d'erreur ?

#23 Re : -1 »  [Astuce] Trucs typographiques – pour français et langues latines » Le 12/09/2014, à 11:43

bruno
Réponses : 47

C'est vraiment bizarre tous ces problèmes de clavier…
Pour reconfigurer le clavier au niveau du système :

sudo dpkg-reconfigure keyboard-configuration

et répondre au questions. Choisir français (variante) qui est a meilleure disposition pour un clavier azerty en français. Redémarrer le système.