Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 4

#0 -1 »  Lire ECW avev QGIS v1.7(dev) » Le 27/03/2011, à 18:32

Cyde
Réponses : 40

Bonjour,

Je viens d'installer QGIS 1.7 sur mon PC sous UBUNTU 10.10 et je ne parviens pas à lire les fichiers compressés au format ECW.
J'ai essayé le tutoriel sur ce site et d'autres recettes sur les forums de géomatique, mais sans aucun succès.
J'ai essayé :
http://doc.ubuntu-fr.org/qgis
http://answerpot.com/showthread.php?303 … +on+Ubuntu
http://geomatips.blogspot.com/2009/12/d … buntu.html

J'ai bien effectué les opérations jusqu'au bout et obtenu la validation de la prise en charge du format ECW par GDAL :

Contrôler l'installation :
taper dans un terminal

    gdalinfo --formats | grep ECW

Deux formats supplémentaires devraient apparaître :

    ECW (rw): ERMapper Compressed Wavelets
    JP2ECW (rw+): ERMapper JPEG2000

J'aurais bien essayé de recompiler le SDK comme indiqué, mais apparemment la source n'est plus disponible. J'ai sûrement loupé un truc tout bête.

Si ça peut aider, sur mon disque :
gdal-ecw-build se trouve sur /usr/bin/
libecwj2.a se trouve sur /usr/lib/
gdal_ECW_JP2ECW.so se trouve sur /usr/lib/gdal17plugins/

Je poste très rarement, car habituellement je trouve les réponses sur le site, mais là ça coince.
Merci encore pour toutes les infos de ce site et tous les tutoriels pour les nuls comme moi.

#1 Re : -1 »  Lire ECW avev QGIS v1.7(dev) » Le 21/06/2011, à 21:34

Cyde
Réponses : 40

Bonjour kikislater,

kikislater a écrit :

Salut Cyde,
Peux tu redonner tes manips ? C'est assez simple à faire !

Depuis mon message initial je suis passé sous ubuntu 11.04.
Je viens de voir que libgdal-ecw-src était disponible dans la logithèque ubuntu, je l'ai donc installé, mais sans résultat.
Voilà ce que j'obtiens sur le terminal:

~$ gdalinfo --formats | grep -i ecw
  ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
  JP2ECW (rw+): ERDAS JPEG2000 (SDK 3.x)

J'ai désinstallé grass puis qgis1.7 puis réinstallé grass, puis qgis 1.7. Toujours pas possible d'ouvrir un ecw.
Grass est installé, mais j'ai essayé d'installer le plugin-qgis-grass, et j'obtiens "impossible de résoudre les dépendances du paquet"
Détails:

Les paquets suivants ont des dépendances non-satisfaites :

qgis-plugin-grass: Depends: qgis (= 1.8.0+git20110620+a21e1db~natty1) mais la version 1.8.0+git20110620+a21e1db~natty1 va être installée
                   Depends: qgis-plugin-grass-common (= 1.8.0+git20110620+a21e1db~natty1) mais la version 1.8.0+git20110620+a21e1db~natty1 va être installée
                   Depends: libc6 (>= 2.7) mais la version 2.13-0ubuntu13 va être installée
                   Depends: libgcc1 (>= 1:4.1.1) mais la version 1:4.5.2-8ubuntu4 va être installée
                   Depends: libgeos-c1 (>= 3.2.0) mais la version 3.2.2-2~natty1 va être installée
                   Depends: libqt4-network (>= 4:4.5.3) mais la version 4:4.7.2-0ubuntu6.1 va être installée
                   Depends: libqt4-svg (>= 4:4.5.3) mais la version 4:4.7.2-0ubuntu6.1 va être installée
                   Depends: libqt4-xml (>= 4:4.5.3) mais la version 4:4.7.2-0ubuntu6.1 va être installée
                   Depends: libqtcore4 (>= 4:4.7.0~beta1) mais la version 4:4.7.2-0ubuntu6.1 va être installée
                   Depends: libqtgui4 (>= 4:4.5.3) mais la version 4:4.7.2-0ubuntu6.1 va être installée
                   Depends: libstdc++6 (>= 4.1.1) mais la version 4.5.2-8ubuntu4 va être installée
                   Depends: grass640+42329 mais c'est un paquet virtuel

Je n'y comprends pas grand chose, mais j'espère que ça peut aider au diagnostic.
Merci pour le coup de main.

#2 Re : -1 »  Lire ECW avev QGIS v1.7(dev) » Le 21/06/2011, à 22:38

Cyde
Réponses : 40
kikislater a écrit :

Donne moi ça stp pour vérifier :

gdalinfo --version

Résultat:

$ gdalinfo --version
GDAL 1.8.0, released 2011/01/12

kikislater a écrit :

et ça :

gdalinfo monfichier.ecw

Bien sûr tu remplaces monfichier.ecw par un vrai ecw présent sur ton disque dur ou média amovible ...

Résultat:

$ gdalinfo monfichier.ecw
Driver: ECW/ERDAS Compressed Wavelets (SDK 3.x)
Files: monfichier.ecw
Size is 10000, 10000
Coordinate System is:
PROJCS["LMFRAN93",
    GEOGCS["FRANCE 1993",
        DATUM["RGF93",
            SPHEROID["GRS80",6378137,298.257222101]],
        PRIMEM["Greenwich",0],
        UNIT["degree",0.0174532925199433]],
    PROJECTION["Lambert_Conformal_Conic_2SP"],
    PARAMETER["standard_parallel_1",44],
    PARAMETER["standard_parallel_2",48.99999999999876],
    PARAMETER["latitude_of_origin",46.49999999999998],
    PARAMETER["central_meridian",3.000000000009746],
    PARAMETER["false_easting",700000],
    PARAMETER["false_northing",6600000],
    UNIT["Meter",1]]
Origin = (880000.000000000000000,6945000.000000000000000)
Pixel Size = (0.500000000000000,-0.500000000000000)
Corner Coordinates:
Upper Left  (  880000.000, 6945000.000) (  5d29'17.14"E, 49d34'43.36"N)
Lower Left  (  880000.000, 6940000.000) (  5d29' 9.31"E, 49d32' 1.68"N)
Upper Right (  885000.000, 6945000.000) (  5d33'25.78"E, 49d34'38.20"N)
Lower Right (  885000.000, 6940000.000) (  5d33'17.73"E, 49d31'56.52"N)
Center      (  882500.000, 6942500.000) (  5d31'17.49"E, 49d33'19.96"N)
Band 1 Block=10000x1 Type=Byte, ColorInterp=Red
  Overviews: 5000x5000, 2500x2500, 1250x1250, 625x625, 312x312, 156x156
Band 2 Block=10000x1 Type=Byte, ColorInterp=Green
  Overviews: 5000x5000, 2500x2500, 1250x1250, 625x625, 312x312, 156x156
Band 3 Block=10000x1 Type=Byte, ColorInterp=Blue
  Overviews: 5000x5000, 2500x2500, 1250x1250, 625x625, 312x312, 156x156

kikislater a écrit :

Tu as un problème de dépendance donc surement de dépôt .... Pour cela donne moi le résultat de ces commandes là :

apt-cache policy qgis

Résultat:

$ apt-cache policy qgis
qgis:
  Installé : 1.8.0+git20110620+a21e1db~natty1
  Candidat : 1.8.0+git20110620+a21e1db~natty1
Table de version :
*** 1.8.0+git20110620+a21e1db~natty1 0
        500 http://qgis.org/debian-nightly/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     1.7.0~natty1 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ natty/main i386 Packages
     1.4.0+12730-5ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        500 http://mirror.ovh.net/ubuntu/ natty/universe i386 Packages

kikislater a écrit :

apt-cache policy gdal

Résultat:

$ apt-cache policy gdal
N: Impossible de trouver le paquet gdal

Apparemment, c'est ici que ça coince?

#3 Re : -1 »  Lire ECW avev QGIS v1.7(dev) » Le 22/06/2011, à 20:08

Cyde
Réponses : 40

Bonsoir kikislater,

kikislater a écrit :

Tu devrais avoir la 1.7 avec le support ecw

Ça marche!!!!!!

Tout ça à cause d'un dépôt dév de trop!

Merci beaucoup à toi, ça m'aurais ennuyé de devoir revenir à la version 1.6 et de perdre la reprojection à la volée des rasters.

big_smile