Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 13

#0 -1 »  Se servir de SSH pour connecter une session graphique? » Le 17/08/2007, à 02:25

[110]
Réponses : 8

Bonjour à tous,

Je suis confronté à un problème avec un serveur se trouvant à une centaine de kilomètres de chez moi, et qu'il me serait utile de pouvoir réutiliser d'urgence.

En gros, il faudrait que je puisse me connecter grâce à VNC à la machine, ce qui visiblement est impossible tant que je ne suis pas loggué sur l'ordinateur via une session graphique.

Actuellement, je peux par contre me logguer sous SSH, mais, le but étant de démarrer une VMWare, je ne suis pas très avancé...

Existe-t-il donc un moyen de créer la connexion graphique grâce à SSH, càd, si je m'exprime mal, de faire comme si je me loguais depuis le clavier de l'ordinateur concerné? Il n'y a aucun risque à ce que je puisse le connecter et le laisser ainsi, vu que l'ordinateur est dans une pièce fermée.

En espérant avoir été suffisamment compréhensible, je vous remercie d'avance pour votre aide smile

110

#1 Re : -1 »  Se servir de SSH pour connecter une session graphique? » Le 17/08/2007, à 12:09

[110]
Réponses : 8

Merci pour vos réponses, mais en fait elles ne correspondent pas vraiment à ce que je voulais faire... Je me suis mal expliqué avec mon VMware....

(lefred21, la commande export display ne renvoie aucun résultat... est-ce normal?)

En fait je ne veux pas lancer d'application graphiques via SSH car ca ne m'avancera à rien...
Voici en gros l'architecture de la machine concernée : une distribution ubuntu est installée, et est sur l'ip xx.xx.xx.32, et le "serveur web" en lui-même tourne en démarrant VMWare (le serveur est sous un windows virtuel en gros), et ce VMWare communique au net grâce à une autre ip (xx.xx.xx.40). Ca ne m'avance donc à rien de réussir à démarrer VMWare en mode SSH graphique, car sitot que je coupe la connection SSH, ben le serveur web s'éteint...

Ce que je veux donc, c'est connecter le serveur distant à la session administrateur, comme si j'étais assis en face de lui : je veux que le bureau gnome s'ouvre, qu'il lance par conséquent le gnome manager, et qu'il me démarre donc VCN-server. Ainsi, je pourrai me connecter au pc grace à vnc-viewer, et là je ferai les opérations nécessaires...

Je ne sais donc pas s'il existe un moyen de faire ca via SSH... Ce serait pour moi la situation idéale smile Quoi qu'il en soi, ca ne m'avance donc à rien d'ouvrir mes logiciels graphiques via ssh wink

Merci encore pour votre aide !

110

#2 Re : -1 »  Se servir de SSH pour connecter une session graphique? » Le 20/08/2007, à 12:12

[110]
Réponses : 8

Merci pour vos réponses smile

En effet lefred21, lancer l'application même avec & ne fonctionne pas si ensuite on coupe ssh ou putty, il faut lancer via screen.

Je n'avais pas pensé à démarrer la machine via un terminal, mais c'est vrai que l'idée est bonne, bien que moins pratique.

Par ailleurs, impossible de vous dire si ca fonctionne avant demain, car là, le pc distant ne répond même plus par SHH 8-) Qui a dit que Linux, c'est stable lol

#3 -1 »  Créer un lanceur de commandes dans le terminal » Le 10/02/2007, à 21:34

[110]
Réponses : 2

Bonjour,

Je désirerais trouver le moyen de créer un petit exécutable qui me permettrait d'exécuter des commandes toutes faites dans un terminal (j'ai 2 commandes à effectuer en fait)

Il faudrait si possible qu'il les lance directement dans un terminal (étant donné qu'il y a plusieurs confirmations à effectuer ou mots de passe à entrer). Par ailleurs, le truc idéal pour moi serait d'en faire un espèce d'exécutable sur lequel il suffit de double-cliquer (l'utilisateur pour qui je désire créer cela n'a aucune connaissance, et surtout pas d'un terminal :-))

Je suis par ailleurs moi-même un parfait utilisateur Lambda dans ce domaine :-)

Avez-vous une idée? (ca doit etre tout simple je suppose)

Merci d'avance,

110

#4 -1 »  [Résolu] Bête question à propos de localhost » Le 01/07/2006, à 01:05

[110]
Réponses : 4

Bonjour,

Je 'débute' dans le php et mysql et j'ai installé une série de programmes via synaptic destinés à me donner un serveur web sur mon pc.

Ainsi, je réussis sans problème à me connecter à http://127.0.0.1/ et j'y trouve actuellement phpmyadmin et apache2-default. Mais je souhaitais savoir où se cachaient ces dossiers dans mon pc, et aussi comment ajouter le site désiré qui se situe actuellement dans un dossier sur mon bureau?

(je sais c'est assez basique comme question... mais il faut bien commencer par le début :d)

#5 Re : -1 »  [Résolu] Bête question à propos de localhost » Le 01/07/2006, à 12:02

[110]
Réponses : 4

Je viens en effet de trouver à l'instant ce répertoire, merci wink

Apparemment il y a moyen de créer des raccourcis placés dans ce dossier qui dirigent vers n'importe quel répertoire.

PS Sorry, je pense que le topic était placé dans la mauvaise section sad Mais de toute façon le voilà résolu roll

#6 Re : -1 »  [Résolu] Bête question à propos de localhost » Le 01/07/2006, à 12:05

[110]
Réponses : 4

Arf j'étais justement en train de le faire smile
Enfin soit, encore merci wink

#7 Re : -1 »  Expérience de migration vers Dapper » Le 11/06/2006, à 11:22

[110]
Réponses : 1

Ton expérience maura bien servie, car j'ai eu quelquesproblèmes similaires à propos de Xorg sur un des ordinateurs qui a connu une mise à jour...

Merci bcp pour l'aide implicite wink

#8 -1 »  Restaurer le noyau de base » Le 06/06/2006, à 22:55

[110]
Réponses : 3

Bonjour à tous,

Bon avant je préfère préciser que j'y connais pas grand grand chose dans le domaine :-)

J'ai voulu, pour permettre à mon ACER 1694 de gérer la batterie, installer un nouveau dsdt comme expliqué sur ce topic http://doc.ubuntu-fr.org/materiel/batterie_acpi, mais qui malheureusement a planté... Tout ca c'était y environ 3 semaines sous breezy, et seule la version du noyau qui tournait encore était la 2.6.9-5-386, mais bref tant que le pc démarrait je n'ai pas cherché à en savoir plus...

Le hic, c'est depuis que j'ai voulu faire le mise à jour Dapper... Outre le fait que cette version, visiblement d'une immentissime stabilité, m'a fait planter respectivement le son (il ne détecte plus de carte son, non réglé), l'écran (c'était marrant j'avais 8 mini écrans pour le prix d'un big_smile, réglé), le Wireless (ne détecte plus, non réglé) et l'accélération graphique (pas important je réinstallerai après, non réglé), lors de mes nombreuses tentatives de réparation du son j'ai du faire une bêtise, car lorsque j'ai voulu redémarrer... tous mes noyaux plantaient...

En gros, c'est pour chacun la même chose : il a le temps de marquer 2-3 lignes, puis au lieu de lancer l'affichage de chargement, il me fige l'écran avec des lignes verticales noires et bleues et ne fait plus rien...
Je n'ai donc plus aucun noyau qui démarre, pas meme les recovery (ou un truc comme ca de mémoire)...
Ainsi je voulais savoir si il y avait un moyen depuis le live-cd de restaurer ces fameux noyaux en remettant un original ou que sais-je...
(Petit détail toutefois : en démarrant un live CD j'ai un écran noir car Xorg n'est pas configuré valablement... Donc il me faudra travailler en ligne de commande si possibilité de travailler il y a :-))

Merci d'avance à tous ceux qui seraint susceptibles de m'aider à sauver Willy... euh mon ordi :-D

#9 Re : -1 »  Restaurer le noyau de base » Le 07/06/2006, à 11:04

[110]
Réponses : 3

Personne n'a une toute petite idée? sad

#10 Re : -1 »  Restaurer le noyau de base » Le 07/06/2006, à 18:09

[110]
Réponses : 3

Bah formater est bien évidemment la dernière chose que j'ai envie de faire, car je perdrais justement toutes mes données...

Puis pr régler le problème d'écran via un live-cd c'est impossible (xorg est en lecture seul sur le live-cd...) et en version normale ca le problème est réglé depuis longtemps wink

Ce qui m'arrangerait serait tt simplement de savoir remettre uniquement le noyau de base, mais visiblement ca ne doit pas être des plus faciles...

#11 -1 »  Problème de configuraiton internet (1er lancement) Acer 1694 » Le 16/05/2006, à 22:28

[110]
Réponses : 2

Bonjour,

Je viens d'installer ubuntu Breezy sur mon acer 1694...
Après quelques déboires, j'ai réussi à configurer la carte graphique, mais me voici à nouveau confronté à un problème (et non des moindres) : il refuse de se connecter à internet...

Je n'ai pas encoe osé essayé le wireless (pas de réseau où je suis), mais par contre il refuse de me connecter sur mon serveur réseau (via la prise réseau)... Cette prise va très bien (elle fonctionne nickel en DHCP qd je suis sous windows), mais sous linux, il m'a activé ma carte réseau, je l'ai configurée (DHCP), et puis après plusieurs minutes à réfléchir l'écran "réseau" s'est quitté, mais internet ne fonctionne pas.

J'ai, via mon icone "réseau" (les 2 petits écrans superposés près de l'horloge) pu remarquer qu'il ne voulait pas me permettre de sélectionner "eth1" (qui est le nom de ma carte réseau selon ce que j'ai cru comprendre), et qu'il me montrait juste "lo1".

J'ai, pour réussir à l'installer, mis "noapic nolapic acpi=off"

Je n'y connais absolument rien sous linux à peu de choses près, donc, sivous avez une idée, tentez de ne pas etre trop trop technique et précisez ce que je dois faire smile

Merci d'avance !

#12 Re : -1 »  Problème de configuraiton internet (1er lancement) Acer 1694 » Le 16/05/2006, à 23:12

[110]
Réponses : 2

J'ai réussi à résoudre le problème...

En fait, il me fallait désactiver l'option de démarrage "acpi=off" afin que ma carte réseau soit reconnue...
Il s'gaissait donc plutot visiblement d'un problème Hardware.

Merci bcp kvb pour t'être penché sur le problème :-)