Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 25

#0 Re : -1 »  Lecteur Xiring Carte Vitale » Le 05/11/2012, à 23:18

SunWukong
Réponses : 10

Bonsoir tout le monde,

Je viens de réussir à brancher mon lecteur Xiring Vital'Act sur mon pingouin :-)
Olivier y est presque arrivé ;-)

Voici ce que j'ai fait :
lsusb renvoie les infos suivantes :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0f14:0005  
Bus 002 Device 003: ID 2001:f103 D-Link Corp. DUB-H7 7-port USB 2.0 hub
Bus 005 Device 002: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 002 Device 004: ID 046d:0826 Logitech, Inc. 
Bus 002 Device 005: ID 06a3:8012 Saitek PLC 

Là, j'avoue que ça ne se voit pas trop, mais le lecteur Xiring se cache derrière la ligne Bus 004 Device 003: ID 0f14:0005
Pour s'en convaincre, il faut éplucher le rapport complet, produit par lsusb -v

Le driver à utiliser est bien usbserial

Et au final, la commande suivante m'a créé un nouveau périphérique /dev/ttyUSB0

# modprobe usbserial vendor=0x0f14 product=0x0005

ça marche chez vous ?

Edit:
Au cas où, pour charger le driver automatiquement, on pourra suivre les indications suivantes.

#1 -1 »  Digikam et Mysql » Le 05/09/2010, à 22:33

SunWukong
Réponses : 2

Bonsoir tout le monde,

J'essaie en vain de configurer Digikam pour qu'il utilise une base de données Mysql.
Les différentes versions sont celles d'une Kubuntu 10.04 à jour.

Mysql server est installé et opérationnel. J'ai créé un utilisateur 'digikam' et une base de données du même nom.
En ligne de commande,

mysql --user=digikam --password=digikam

me connecte bien à la base.

Quand je lance Digikam la première fois, il est par défaut configuré pour utiliser une base SQLite. Je change donc ces paramètres pour qu'il se connecte à ma base Mysql, puis je vérifie en cliquant sur le bouton "Vérifier la connexion à la base de données". => Connexion réussie. Preuve en est, depuis le client en ligne de commande, je vois bien que digikam a bien créé dans sa base toutes les tables de son modèle de données. Je clique alors sur OK.

Et là, rien n'y fait, digkam utilise pourtant toujours SQLite. Si je reviens sur l'écran de config, je vois "SQLite". Si je rechange ces valeurs, elles ne sont pas prises en compte : SQLite reste là. Et pourtant, dans le fichier ~/.kde/share/config/digikamrc les paramètres "database settings" indiquent bien MySQL.

Je ne sais plus quoi faire sad

Merci pour vos idées

#2 Re : -1 »  Digikam et Mysql » Le 08/09/2010, à 21:11

SunWukong
Réponses : 2

up up up ! :-)

Je sais, je sais… le sujet est passionnant wink

#3 Re : -1 »  "Canonical is watching you !" Un espion dans Ubuntu. » Le 10/08/2010, à 12:09

SunWukong
Réponses : 134

Salut !

Ce paquet est aussi présent pour Lucid depuis ce matin. Toutefois, il ne s'installe pas par défaut. Sous Lucid donc, c'est un acte volontaire qui est nécessaire pour activer cette fonction. Qu'en est-il sous Maverick ?

@Fiskilleur : Ce n'est pas parce qu'une société dépense du temps et de l'argent pour faire un logiciel, qu'elle a le droit d'espionner les gens qui utilisent ce logiciel à leur insu.

#4 Re : -1 »  [résolu] ipod + ubuntu 9.10 » Le 12/11/2009, à 20:04

SunWukong
Réponses : 2

Salut,


J'ai à priori le même problème sur deux machines, avec le même ipod nano 2ème génération.
Par contre, en ce qui me concerne et sur les 2 machines, l'iPod n'est pas monté. Je n'en vois d'ailleurs aucune trace dans la log /var/log/dmesg

A+

#5 Re : -1 »  [RESOLU] Kubuntu 9.04 + KDE 4.3 : Akonadi serveur erreur au démarrage » Le 26/10/2009, à 23:51

SunWukong
Réponses : 27

Bonsoir tout le monde, salut Bruno :-)

Je viens de mettre à jour jaunty avec karmic rc et constate le même problème. Alors je m'abonne au fil pour suivre l'évolution.

Ça m'ennuie un peu d'installer un serveur MySQL car j'utilise par ailleurs PostgreSQL. J'essaierai de voir si on peut remplacer une base MySQL par une base SQLite.
À suivre tongue

Quelques infos :


le rapport d'erreurs :

Akonadi Server Self-Test Report
===============================

Test 1:  SUCCESS
--------

Database driver found.
Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration.
The following drivers are installed: QSQLITE, QSQLITE2, QMYSQL3, QMYSQL, QODBC3, QODBC, QPSQL7, QPSQL.
Make sure the required driver is installed.

File content of '/home/stephan/.config/akonadi/akonadiserverrc':
[%General]
Driver=QMYSQL
SizeThreshold=4096
ExternalPayload=false

[QMYSQL]
Name=akonadi
User=
Password=
Options="UNIX_SOCKET=/home/stephan/.local/share/akonadi/db_misc/mysql.socket"
ServerPath=/usr/sbin/mysqld-akonadi
StartServer=true

[Debug]
Tracer=null


Test 2:  SUCCESS
--------

MySQL server found.
Details: You currently have configured Akonadi to use the MySQL server '/usr/sbin/mysqld-akonadi'.
Make sure you have the MySQL server installed, set the correct path and ensure you have the necessary read and execution rights on the server executable. The server executable is typically called 'mysqld', its locations varies depending on the distribution.

Test 3:  SUCCESS
--------

MySQL server is executable.
Details: MySQL server found: /usr/sbin/mysqld-akonadi  Ver 5.1.37-1ubuntu5 for debian-linux-gnu on i486 ((Ubuntu))


Test 4:  ERROR
--------

MySQL server log contains errors.
Details: The MySQL server error log file &apos;<a href='/home/stephan/.local/share/akonadi/db_data/mysql.err'>/home/stephan/.local/share/akonadi/db_data/mysql.err</a>&apos; contains errors.

File content of '/home/stephan/.local/share/akonadi/db_data/mysql.err':
091026 23:22:55 [Note] Plugin 'FEDERATED' is disabled.
091026 23:22:55  InnoDB: Started; log sequence number 0 1286330
091026 23:22:55 [ERROR] Aborting

091026 23:22:55  InnoDB: Starting shutdown...
091026 23:22:56  InnoDB: Shutdown completed; log sequence number 0 1286330
091026 23:22:56 [Warning] Forcing shutdown of 1 plugins
091026 23:22:56 [Note] 


Test 5:  SUCCESS
--------

MySQL server default configuration found.
Details: The default configuration for the MySQL server was found and is readable at <a href='/etc/akonadi/mysql-global.conf'>/etc/akonadi/mysql-global.conf</a>.

File content of '/etc/akonadi/mysql-global.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 6:  SKIP
--------

MySQL server custom configuration not available.
Details: The custom configuration for the MySQL server was not found but is optional.

Test 7:  SUCCESS
--------

MySQL server configuration is usable.
Details: The MySQL server configuration was found at <a href='/home/stephan/.local/share/akonadi/mysql.conf'>/home/stephan/.local/share/akonadi/mysql.conf</a> and is readable.

File content of '/home/stephan/.local/share/akonadi/mysql.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 8:  SUCCESS
--------

akonadictl found and usable
Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully.
Result:
Akonadi 1.2.1


Test 9:  ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 10:  ERROR
--------

Akonadi server process not registered at D-Bus.
Details: The Akonadi server process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 11:  SKIP
--------

Protocol version check not possible.
Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements.

Test 12:  ERROR
--------

No resource agents found.
Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents /usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/share:/usr/local/share', make sure this includes all paths where Akonadi agents are installed to.

Directory listing of '/usr/share/akonadi/agents':
birthdaysresource.desktop
distlistresource.desktop
gcalresource.desktop
googledataresource.desktop
icalresource.desktop
imapresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
kolabproxyresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
microblog.desktop
nepomukcontactfeeder.desktop
nepomukemailfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
notesresource.desktop
strigifeeder.desktop
vcarddirresource.desktop
vcardresource.desktop
Directory listing of '/usr/share/akonadi/agents':
birthdaysresource.desktop
distlistresource.desktop
gcalresource.desktop
googledataresource.desktop
icalresource.desktop
imapresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
kolabproxyresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
microblog.desktop
nepomukcontactfeeder.desktop
nepomukemailfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
notesresource.desktop
strigifeeder.desktop
vcarddirresource.desktop
vcardresource.desktop

Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/share:/usr/local/share'

Test 13:  ERROR
--------

Current Akonadi server error log found.
Details: The Akonadi server did report error during startup into <a href='/home/stephan/.local/share/akonadi/akonadiserver.error'>/home/stephan/.local/share/akonadi/akonadiserver.error</a>.

File content of '/home/stephan/.local/share/akonadi/akonadiserver.error':
Database process exited unexpectedly during initial connection! 
executable: "/usr/sbin/mysqld-akonadi" 
arguments: ("--defaults-file=/home/stephan/.local/share/akonadi//mysql.conf", "--datadir=/home/stephan/.local/share/akonadi/db_data/", "--socket=/home/stephan/.local/share/akonadi/db_misc/mysql.socket") 
stdout: "" 
stderr: "091026 23:22:55 [Warning] The syntax '--log_slow_queries' is deprecated and will be removed in MySQL 7.0. Please use '--slow_query_log'/'--slow_query_log_file' instead.
091026 23:22:55 [ERROR] Error message file '/usr/share/mysql/english/errmsg.sys' had only 480 error messages,
but it should contain at least 637 error messages.
Check that the above file is the right version for this program!
" 
exit code: 1 
process error: "Process operation timed out" 
"[
0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f25]
1: akonadiserver [0x80523f6]
2: [0x2a1400]
3: [0x2a1422]
4: /lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0xddc4d1]
5: /lib/tls/i686/cmov/libc.so.6(abort+0x182) [0xddf932]
6: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x8c) [0x4def8c]
7: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8052f54]
8: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x85) [0x5710d5]
9: /usr/lib/libQtCore.so.4 [0x57fed5]
10: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x68) [0x581298]
11: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804dbf3]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x1ab8) [0xa80a48]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x70) [0xa83030]
14: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0xa843c8]
15: akonadiserver(main+0x362) [0x804d032]
16: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0xdc8b56]
17: akonadiserver [0x804cc01]
]
" 


Test 14:  ERROR
--------

Previous Akonadi server error log found.
Details: The Akonadi server did report error during its previous startup into <a href='/home/stephan/.local/share/akonadi/akonadiserver.error.old'>/home/stephan/.local/share/akonadi/akonadiserver.error.old</a>.

File content of '/home/stephan/.local/share/akonadi/akonadiserver.error.old':
Database process exited unexpectedly during initial connection! 
executable: "/usr/sbin/mysqld-akonadi" 
arguments: ("--defaults-file=/home/stephan/.local/share/akonadi//mysql.conf", "--datadir=/home/stephan/.local/share/akonadi/db_data/", "--socket=/home/stephan/.local/share/akonadi/db_misc/mysql.socket") 
stdout: "" 
stderr: "091026 23:22:53 [Warning] The syntax '--log_slow_queries' is deprecated and will be removed in MySQL 7.0. Please use '--slow_query_log'/'--slow_query_log_file' instead.
091026 23:22:53 [ERROR] Error message file '/usr/share/mysql/english/errmsg.sys' had only 480 error messages,
but it should contain at least 637 error messages.
Check that the above file is the right version for this program!
" 
exit code: 1 
process error: "Process operation timed out" 
"[
0: akonadiserver(_Z11akBacktracev+0x35) [0x8051f25]
1: akonadiserver [0x80523f6]
2: [0xd09400]
3: [0xd09422]
4: /lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0x62a4d1]
5: /lib/tls/i686/cmov/libc.so.6(abort+0x182) [0x62d932]
6: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x8c) [0x2a1f8c]
7: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc4) [0x8052f54]
8: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x85) [0x3340d5]
9: /usr/lib/libQtCore.so.4 [0x342ed5]
10: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x68) [0x344298]
11: akonadiserver(_ZN6QDebugD1Ev+0x43) [0x804dbf3]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x1ab8) [0x157a48]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x70) [0x15a030]
14: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x58) [0x15b3c8]
15: akonadiserver(main+0x362) [0x804d032]
16: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x616b56]
17: akonadiserver [0x804cc01]
]
" 


Test 15:  SUCCESS
--------

No current Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its current startup.

Test 16:  SUCCESS
--------

No previous Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its previous startup.

La première erreur chronologiquement parlant est la n°4 me renvoyant vers une log MySQL qui ne contient que les lignes suivantes :

091026 23:22:55 [Note] Plugin 'FEDERATED' is disabled.
091026 23:22:55  InnoDB: Started; log sequence number 0 1286330
091026 23:22:55 [ERROR] Aborting

091026 23:22:55  InnoDB: Starting shutdown...
091026 23:22:56  InnoDB: Shutdown completed; log sequence number 0 1286330
091026 23:22:56 [Warning] Forcing shutdown of 1 plugins
091026 23:22:56 [Note]

C'est plutôt maigre :-(

#6 Re : -1 »  [RESOLU] Kubuntu 9.04 + KDE 4.3 : Akonadi serveur erreur au démarrage » Le 29/10/2009, à 23:07

SunWukong
Réponses : 27

Bonne nouvelle :-)

Le bug est connu et corrigé. Il est en effet dans le LaunchPad ici :
https://bugs.launchpad.net/ubuntu/+source/akonadi/+bug/459741

Pour les anglophobes, il suffit d'installer le paquet mysql-server et le problème sera réglé.

Enfin presque, en ce qui me concerne, le serveur démarre mais avec des erreurs. Mais Akonadi a l'air opérationnel.

#7 Re : -1 »  [RESOLU] Kubuntu 9.04 + KDE 4.3 : Akonadi serveur erreur au démarrage » Le 30/10/2009, à 19:55

SunWukong
Réponses : 27

La commande :
rm -rf /opt/lampp

ne désinstalle pas vraiment Xampp. Elle efface purement et simplement tous les fichiers présents dans cette arborescence. Si des fichiers de config sont présents dans /etc ou si des bases de données sont dans /var, alors ils sont toujours. En gros, c'est crade ;-) C'est pour cela qu'il est vraiment conseillé d'utiliser un gestionnaire de paquets.

mysql-server est un méta-paquet qui met à jour le serveur MySQL à chaque fois qu'une nouvelle version est disponible dans les dépôts. En ce qui me concerne, de mémoire, j'avais sous Jaunty une 5.0 qui est restée en 5.0 lors du passage sous Karmic. L'installation de du méta-paquet a alors forcé la mise à jour vers 5.1, nécessaire pour akonadi.

Par contre, j'ai toujours un problème car akonadi ne trouve pas certaines tables dans sa base de données. Pourtant, je l'ai forcé à tout reconstruire en supprimant ~/.local/akonadi. Il a bien tout reconstruit mais mal, comme si akonadi n'embarquait pas les bons scripts de création de sa base de données (genre une ancienne version)

La discussion se fait aussi sur ce fil :
http://forum.kde.org/viewtopic.php?f=20&t=79717&start=10

#8 Re : -1 »  [RESOLU] Kubuntu 9.04 + KDE 4.3 : Akonadi serveur erreur au démarrage » Le 03/11/2009, à 20:36

SunWukong
Réponses : 27

Akonadi, tu l'écrivais, a été choisi pour être au cœur du gestionnaire de contact (sûrement entre autres choses). Difficile d'imaginer dès lors que l'on puisse s'en passer si l'on compte utiliser toutes les applis qui s'appuieront dessus. Maintenant, c'est un peu nouveau, il faut que ça se rode. Toujours le même truc : s'il y avait plus des tests, ce serait mieux fini :-) Akonadi n'est pas destiné aux développeurs.

Ensuite,  Akonadi s'appuie sur une base de données, comme par ex. Firefox qui s'appuie sur SQLite. Léger, rapide, facile et invisible à l'utilisateur lambda. Toutefois, si akonadi semble pouvoir s'appuyer sur SQLite, les performance sont vraisemblablement meilleures avec MySQL qui a été choisi par Canonical (ou KDE ?).

L'activation ou pas de Nepomuk est aussi un choix de Canonical j'imagine.

Je n'utilise pas KWord mais ce que tu dis me parait bizarre : KWord doit, j'imagine, utiliser les polices True Type présentes dans le système. Et il doit les rendre visuellement en utilisant les mêmes routines que le reste de KDE. Il ne devrait donc pas y avoir de différences. Curieux…

Pour en revenir au sujet du post, quelqu'un a posté une message sur le site de KDE que je mentionnais plus haut et sa contribution a résolu mon problème. J'espère qu'il en sera de même pour toi :-)

Le problème venait du fait que la base de données appelée mysql, une base normallement créée par défaut lors de l'installation du serveur MySQL, cette base donc n'était pas créée. Il suffit donc de la créer, en utilisant la commande suivante :

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

Bonne chance ;-)

#9 Re : -1 »  [RESOLU] Kubuntu 9.04 + KDE 4.3 : Akonadi serveur erreur au démarrage » Le 10/01/2010, à 18:18

SunWukong
Réponses : 27

et bien Akonadi utilise un serveur embarqué. Donc il y a une base par utilisateur (un processus serveur par utilisateur connecté je pense).

Si tu as installé un "vrai" serveur MySql, il y a un processus serveur (pour les puristes, je généralise) et la base que tu as créée et dans laquelle les infos de chaque utilisateur seront stockées.

#10 Re : -1 »  problème avec Akonadi Server » Le 29/10/2009, à 22:54

SunWukong
Réponses : 2

Salut,

Il y a déjà un autre fil de discussion sur ce problème. Autant centraliser les efforts :-)
http://forum.ubuntu-fr.org/viewtopic.php?id=333433

#11 Re : -1 »  probleme de deplacement de la souris » Le 02/07/2009, à 23:09

SunWukong
Réponses : 6

Salut,


Voilà toujours la solution : j'ai mis un bon moment avant de trouver alors j'imagine qu'elle servira à plus d'un ;-)

Il faut initialiser une variable d'environnement :

# Règle le problème de souris dans les jeux OpenGL
export SDL_VIDEO_X11_DGAMOUSE=0

Seul utilisateur de ma machine, j'ai ajouté ce paramétrage dans les fichiers
~/.profile
~/.bashrc
S'il y a plusieurs utilisateurs, un paramétrage plus global est peut-être préférable. En tout cas, ça marche ;-)

A+

#12 -1 »  [Résolu] Problème CURLFTPFS et Boitier HD de la Freebox » Le 02/08/2008, à 17:22

SunWukong
Réponses : 2

Bonjour à tous,

J'utilise Hardy à jour, version Kubuntu (KDE 3.5.9)
Noyau 2.6.24-19-generic

J'ai installé le paquet curlftpfs et ses dépendances pour pouvoir monter de façon transparente dans le système de fichiers local des systèmes de fichiers distants accessibles via FTP.

En l'occurrence, je voudrais ainsi monter le disque dur qui équipe le boitierHD fourni par le FAI Free.

J'ai ajouté la ligne suivante dans

/etc/fstab
# Montage de la Freebox via FUSE
curlftpfs#freebox:@hd1.freebox.fr /media/FreeboxHD fuse rw,uid=500,user,auto    0       0

Mais quand je tente de monter ce volume (appelons-le comme ça) avec :

sudo mount /media/FreeboxHD

le volume n'est pas monté, le dossier /media contient l'entrée suivante :

drwxr-xr-x 2 root root 4096 2008-05-01 16:57 floppy0
d????????? ? ?    ?       ?                ? FreeboxHD

le tout sans le moindre message d'erreur. Rien non plus dans les journaux auxquels j'ai pu penser (user.log, kern.log, syslog, messages, le canard enchaîné,…)

Le démontage du volume se fait tout aussi silencieusement, sans message d'erreur, et le dossier /media retrouve son apparence habituel :

drwxr-xr-x 2 root root 4096 2008-05-01 16:57 floppy0
drwxrwxr-x 2 root fuse 4096 2008-07-13 20:15 FreeboxHD

Dernières précisions :
* mon login fait partie du groupe « fuse »
* le compte ftp du serveur embarqué dans le boitier HD n'a pas de mot de passe
* j'ai exactement le même comportement en utilisant un compte ftp sur une machine distante nécessitant un mot de passe.

Merci pour votre aide :-)

A+

PS : Par ailleurs, la commande suivante fonctionne très bien :

curlftpfs ftp://hd1.freebox.fr /media/FreeboxHD/ -o user=freebox:

mais j'aurais voulu que le montage se fasse automatiquement grâce aux infos dans fstab

#13 Re : -1 »  [Résolu] Problème CURLFTPFS et Boitier HD de la Freebox » Le 18/08/2008, à 21:23

SunWukong
Réponses : 2

Grandiose ! :-)

Merci beaucoup !

#14 Re : -1 »  [Résolu] Pourquoi Firefox a une police de caractere minuscule???? » Le 09/11/2007, à 12:02

SunWukong
Réponses : 18

Salut

Je n'ai pas d'idées mais te propose de confirmer que tu as bien mis à jour ton poste (et pas une installation fraîche de gutsy)

A+

#15 -1 »  Disques USB non montés au boot » Le 15/10/2007, à 18:31

SunWukong
Réponses : 14

Bonjour,

j'ai un souci avec deux disques dur USB qui ne se montent pas automatiquement au boot. Pour les faire reconnaître après le boot, il faut que je les débranche du port USB pour les rebrancher aussitôt.

Au niveau matériel, il n'y a pas de soucis car tout cela fonctionnait très bien sous Feisty. Mais c'est depuis mon passage à Kubuntu Gutsy beta 64 bits que le problème est apparue. À noter que je n'ai pas fait de mise à jour et que j'ai procédé à une résintallation from scratch.

Les disques USB :
1 disque = une partition 60Go vfat
1 disque = 3 partitions (2Go ext2, 1Go vfat, 300Go ext2)

Le système est lui installé sur 2 disques de 80Go identifiés /dev/sdb et /dev/sdc
Et on vient de me donner un disque de 160Go qui se retrouve en /dev/sda

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc /proc proc defaults 0 0
# /dev/sdb6
UUID=394f2d3e-3d08-4a1f-900e-977a334cfc0a / xfs nouser,defaults,atime,auto,rw,dev,exec,suid 0 1
# /dev/sdb1
UUID=3ca10332-ce40-496b-b848-9fa6bb9e4b34 /boot ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
# /dev/sdc1
UUID=b43a0100-acfe-47e1-af8f-70d75c3d9c2c /home xfs nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
# /dev/sda1
UUID=e4e8b100-c27e-433c-aa08-acc8a3a99957 /media/Extras ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
# /dev/sdb2
UUID=3cbc8170-77fa-43b9-b521-23960dc3b15c /usr xfs nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
# /dev/sdb5
UUID=1f0c0526-0afe-4cd4-a7f2-c254f5753dca none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,atime,noauto,rw,dev,exec,suid 0 0
# UNCONFIGURED FSTAB FOR BASE SYSTEM

et

voici /etc/mtab

/dev/sdb6 / xfs rw 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.22-12-generic/volatile tmpfs rw 0 0
/dev/sdb1 /boot ext3 rw 0 0
/dev/sdc1 /home xfs rw 0 0
/dev/sda1 /media/Livres ext3 rw 0 0
/dev/sdb2 /usr xfs rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0

on notera une partition securityfs de 4Go. À priori, elle n'est pas active (je n'ai pas encore regardé ce point, mais ce n'est pas le sujet ;-) )

Dans le journal du boot, je trouve ceci :

[   88.476212] usb-storage: device scan complete
[   88.476270] usb-storage: device scan complete
[   88.476875] scsi 5:0:0:0: Direct-Access     USB 2.0  Storage Device   0100 PQ: 0 ANSI: 0 CCS
[   88.511562] scsi 4:0:0:0: Direct-Access     WD       3200JB External  0107 PQ: 0 ANSI: 0
[   88.512671] sd 4:0:0:0: [sdd] 625142448 512-byte hardware sectors (320073 MB)
[   88.513547] sd 4:0:0:0: [sdd] Write Protect is off
[   88.513548] sd 4:0:0:0: [sdd] Mode Sense: 03 00 00 00
[   88.513550] sd 4:0:0:0: [sdd] Assuming drive cache: write through
[   88.514418] sd 4:0:0:0: [sdd] 625142448 512-byte hardware sectors (320073 MB)
[   88.515295] sd 4:0:0:0: [sdd] Write Protect is off
[   88.515297] sd 4:0:0:0: [sdd] Mode Sense: 03 00 00 00
[   88.515298] sd 4:0:0:0: [sdd] Assuming drive cache: write through
[   88.515301]  sdd: sdd1 sdd2 sdd3
[   88.515970] sd 4:0:0:0: [sdd] Attached SCSI disk
[   88.515996] sd 4:0:0:0: Attached scsi generic sg4 type 0
[   88.516831] sd 5:0:0:0: [sde] 117210240 512-byte hardware sectors (60012 MB)
[   88.517454] sd 5:0:0:0: [sde] Write Protect is off
[   88.517456] sd 5:0:0:0: [sde] Mode Sense: 08 00 00 00
[   88.517458] sd 5:0:0:0: [sde] Assuming drive cache: write through
[   88.518331] sd 5:0:0:0: [sde] 117210240 512-byte hardware sectors (60012 MB)
[   88.518955] sd 5:0:0:0: [sde] Write Protect is off
[   88.518956] sd 5:0:0:0: [sde] Mode Sense: 08 00 00 00
[   88.518958] sd 5:0:0:0: [sde] Assuming drive cache: write through
[   88.518960]  sde: sde1
[   88.878645] sd 5:0:0:0: [sde] Attached SCSI disk
[   88.878697] sd 5:0:0:0: Attached scsi generic sg5 type 0

Mais voilà... je n'ai plus d'idées et je n'ai pas trouvé la cause de ce dysfonctionnement.
merci pour votre aide.

la commande lsusb me retourne :

Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 002: ID 045e:00e5 Microsoft Corp.
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 08e6:3437 Gemplus GemPC Twin SmartCard Reader
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 003: ID 0402:5637 ALi Corp. M5637 IDE Controller
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 1058:0901 Western Digital Technologies, Inc.
Bus 001 Device 001: ID 0000:0000

où l'on voit bien les deux disques (ALi Corp et Western Digital).


A+

#16 Re : -1 »  Disques USB non montés au boot » Le 15/10/2007, à 23:35

SunWukong
Réponses : 14

Oui, effectivement, c'est hal Hardware Abstraction Layer qui est en charge de découvrir et de monter les périphériques USB. Mais ce paquet est installé automatiquement par défaut. J'ai tout de même vérifié et hal est bien là.
Le problème reste entier…

#17 Re : -1 »  Disques USB non montés au boot » Le 16/10/2007, à 17:09

SunWukong
Réponses : 14

Chouette, du monde ! :-)

Voici le résultat d'un
sudo fdisk -l

....à noter que cette commande est lancée présentement avec les disques USB montés (pour rappel, les disques ne sont anormalement pas montés lors du boot, (ou peut-être plutôt au lancement de la session KDE ???) mais en les rebranchant à chaud, tout se passe bien, idem en passant par l'interface admin de KDE)

Disque /dev/sda: 80.0 Go, 80026361856 octets
255 heads, 63 sectors/track, 9729 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0x29982997

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1          62      497983+  83  Linux
/dev/sda2              63        3101    24410767+  83  Linux
/dev/sda3            3102        4074     7815622+  83  Linux
/dev/sda4            4075        9729    45423787+   5  Extended
/dev/sda5            4075        4439     2931831   82  Linux swap / Solaris
/dev/sda6            4440        9729    42491893+  83  Linux

Disque /dev/sdb: 80.0 Go, 80026361856 octets
255 heads, 63 sectors/track, 9729 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000c6d01

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1   *           1        9203    73923066   83  Linux
/dev/sdb2            9204        9729     4225095   83  Linux

Disque /dev/sdc: 160.0 Go, 160000000000 octets
255 heads, 63 sectors/track, 19452 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc934c934

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1               1       19452   156248158+  83  Linux

Disque /dev/sdd: 320.0 Go, 320072933376 octets
255 heads, 63 sectors/track, 38913 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8f9c798a

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdd1               1          65      522081   16  Hidden FAT16
/dev/sdd2              66         196     1052257+  83  Linux
/dev/sdd3             197       38913   310994302+  83  Linux

Disque /dev/sde: 60.0 Go, 60011642880 octets
255 heads, 63 sectors/track, 7296 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0xde59de59

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sde1               1        7295    58597056    b  W95 FAT32


??????????????????????????????????????????????????????????????????????

ALORS ÇA !!! roll
Dans les traces antérieures que j'ai reportées, le disque système était /dev/sdb
Sur la présente, il est devenu /dev/sda !!!!
J'ai rebooté entre temps, c'est certain, mais le périphérique a changé !!!
De la même façon, /dev/sdc est devenu /dev/sdb
et le "nouveau" disque de 160Go qui était /dev/sda est devenu /dev/sdc

Je sèche vraiment…

#19 Re : -1 »  Disques USB non montés au boot » Le 06/11/2007, à 13:37

SunWukong
Réponses : 14

Salut Jajax,

Oui, il tombe à pic mais je m'en serais bien passé :-D

J'ai suivi tes déboires sur la liste de diffusion et te remercie pour ton retour d'info ici :-)

Hier soir, avant d'éteindre la machine, j'ai suivi tes indications.

Ce matin, le verdict est tombé : même punition ! ;-) ça n'a pas marché.

Comme Fredolerouge, j'ai opté pour une ligne en dur dans fstab. Mais les autres partitions du WD myBook ne sont pas montées, ni l'autre disque (ALi Corp) de 60Go. Mais j'aimerais bien que ça tourne souplement.

A+

#21 Re : -1 »  Disques USB non montés au boot » Le 07/11/2007, à 01:28

SunWukong
Réponses : 14

euh... oui ? je crois. Je vérifierai à tout hasard.

Tout marchait bien sous Feisty.
Lors de l'install Gutsy (from scratch), ce disque était débranché.

A+

#22 Re : -1 »  Marseille : Install Party Gutsy Gibbon le 20 octobre » Le 11/10/2007, à 18:48

SunWukong
Réponses : 10

Du retard ? Sans certitude aucune, ni référence, une fois je crois. Maintenant le compteur officiel affiche J-7 alors on peut être tranquille ;-) D'autant plus que ce n'est pas Noël Forgeard qui dirige le projet ! lol

Ben oui c'est balot, mais en même temps, si on doit passer chez tout le monde, l'un après l'autre, avec notre tour, notre serveur (avec un miroir du dépôt) et un rétro-projecteur, c'est encore plus balot big_smile

Moi j'y serai cool
Y aura aussi d'autres habitués du PLUG (Provence Linux User Group) http://plugfr.org/

#23 Re : -1 »  Marseille : Install Party Gutsy Gibbon le 20 octobre » Le 13/10/2007, à 15:18

SunWukong
Réponses : 10

Super :-)

N'hésitez pas à envoyer un mail sur contact _CHEZ_ plugfr _POINT_ org pour qu'on ai une estimation du nombre de visiteurs, en nous disant si vous venez avec votre bécane pour une install, ou juste en curieux :-)

À bientôt
SW

#24 Re : -1 »  Ubuntu 7.04 et double écran » Le 15/10/2007, à 18:11

SunWukong
Réponses : 4

Oui, Ubuntu (et Linux) gère le double écran depuis des années.

Pour ma part, j'étais sous Feisty en double écran depuis Noel en gros. Présentement, je viens de passer sous Gutsy. ça marche aussi.

Auparavant, la configuration se faisait à la mano. Aujourd'hui, les outils (KDE pour ma part) le gère.