Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ? » Le 01/04/2016, à 12:52

nany
Réponses : 54
draco31.fr a écrit :

Je ne pense pas que ce paragraphe ait été ajouté à la doc sans test préalable.

Eh bien, s’il y a eu un test préalable, le protocole de test était probablement mauvais.
Mon test montre bien que ça ne fait rien à cause du verrou et que, sans ce problème de verrou, la dernière version du noyau fraîchement installée serait désinstallée.

Est-ce que kclean n'a pas changé son fonctionnement ?

Depuis la toute première version, je ne sais pas. Mais je dirais que le fonctionnement est le même depuis au moins la version 3.0.

En bref, pour que kclean fonctionne correctement après une mise à jour de noyau, il faut d’abord redémarrer sur la nouvelle version du noyau.

#1 Re : -1 »  Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ? » Le 07/04/2016, à 21:21

nany
Réponses : 54

Oui, c’est le bug #1440608.
J’avoue que cette histoire de double redémarrage me dépasse un peu car je n’ai jamais pu constater ce bug chez moi (il faut dire que je ne m’empresse pas de faire un autoremove dès que je vois passer une mise à jour de noyau).
Néanmoins je sais qu’il existe et j’en parle en #3 sans y faire référence (je vais donc éditer pour ajouter cette référence) :

À ce stade le processus d’automatisation de marquage des deux dernières versions de noyau peut ne pas avoir été effectué.

Puis les quelques lignes qui suivent pour y remédier.

J’ajoute que le script autoremove n’est pas le seul que j’ai mis dans /etc/cron.weekly. Il y a aussi le script apt-mark-auto-kernels qui est exécuté avant (le choix des noms n’est pas anodin) et qui est justement là pour prévenir ce bug ainsi que le bug #1175637.

P.S. ; un test qui peut être effectué avec au moins trois versions de noyau :

sudo apt-get -s install

pour voir la liste des paquets suggérés en autoremove ; si cette liste est incorrecte,

sudo /etc/kernel/postinst.d/apt-auto-removal $(dpkg -l | awk '/linux-image-[0-9]/{k=$2}END{sub(/linux-image-/,"",k);print k}')

puis à nouveau

sudo apt-get -s install

#2 Re : -1 »  [RÉSOLU] Impossible de mettre à jour ! » Le 06/04/2016, à 19:09

nany
Réponses : 64

Bonjour,

Pimprelune a écrit :

Alors où puis-je trouver l'indication de la "remplitude" de mon disque

Donne les retours de ces commandes :

df -h
df -i
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
uname -r
find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;


Si j’ai bien compris, le problème de remplissage de la partition /boot était déjà apparu et il avait été résolu par AXUL. Mais le même message d’erreur est maintenant revenu. C’est bien ça ?

Aussi, un système d’automatisation de nettoyage des versions de noyau a été mis en place. Il semble donc que ce système soit inefficace.
Ce serait bien de savoir ce qui a été mis en place exactement.

#3 Re : -1 »  [RÉSOLU] Impossible de mettre à jour ! » Le 06/04/2016, à 19:59

nany
Réponses : 64

C’est donc une partition /boot séparée. On le voit grâce à cette ligne :

/dev/sda2          473M    400M   49M  90% /boot

Elle fait 473 Mo et on peut voir aussi qu’il ne reste plus que 49 Mo disponibles. Le problème reviendra donc fatalement.

Je te propose donc de passer toutes ces commandes :

[[ $(apt-mark showmanual | egrep 'linux-.*[0-9]') ]] && sudo apt-mark auto $(apt-mark showmanual | egrep linux-.*[0-9])
sudo /etc/kernel/postinst.d/apt-auto-removal $(dpkg -l | awk '/linux-image-[0-9]/{k=$2}END{sub(/linux-image-/,"",k);print k}')
sudo apt-get autoremove --purge -y
[[ $(dpkg -l | grep ^rc) ]] && sudo dpkg -P $(dpkg -l | awk '/^rc/{print $2}')
echo -e "#\x21/bin/bash\n\nif [[ \$(apt-mark showmanual | egrep linux-.*[0-9]) ]]; then\n  apt-mark auto \$(apt-mark showmanual | egrep linux-.*[0-9])\nfi\n/etc/kernel/postinst.d/apt-auto-removal \\\\\n\$(dpkg -l | awk '/linux-image-[0-9]/{k=\$2}\\\\\nEND{sub(/linux-image-/,\"\",k);print k}')\n\nexit 0" | sudo tee /etc/cron.weekly/apt-mark-auto-kernels
sudo chmod -v +x /etc/cron.weekly/apt-mark-auto-kernels
echo -e "#\x21/bin/bash\n\napt-get autoremove --purge -y\n\nexit 0" | sudo tee /etc/cron.weekly/autoremove
sudo chmod -v +x /etc/cron.weekly/autoremove
echo -e "#\x21/bin/bash\n\nif [[ \$(dpkg -l | grep ^rc) ]]; then\n  dpkg -P \$(dpkg -l | awk '/^rc/{print \$2}')\nfi\n\nexit 0" | sudo tee /etc/cron.weekly/purge-rc
sudo chmod -v +x /etc/cron.weekly/purge-rc

#4 Re : -1 »  [RÉSOLU] Impossible de mettre à jour ! » Le 06/04/2016, à 20:48

nany
Réponses : 64
Pimprelune a écrit :

Je vais essayer de ne pas me gourer

Eh bien tu n’as fait aucune erreur. wink
Je peux te dire que ta partition /boot est maintenant plus à l’aise. Pour t’en convaincre, tu peux passer à nouveau cette commande :

df -h

Et, comme tu as bien passé toutes les commandes, tu as maintenant trois petits scripts qui seront exécutés une fois par semaine et qui se chargeront de gérer les versions de noyau et de purger les désinstallations qui auraient pu être effectuées sans purge. Tu n’as donc même plus à te soucier de kclean.

#5 Re : -1 »  Plus de mises à jour du noyau… » Le 06/04/2016, à 19:13

nany
Réponses : 12

Bonjour,

francois_c a écrit :

Est-ce dû au fait que 14.04 LTS arrive en fin de carrière, ou aurais-je désactivé quelque chose sans m'en apercevoir ?

14.04 LTS ne sera en fin de carrière qu’en 2019. Je penche donc pour la deuxième explication. Il est possible que le méta-paquet responsable des mises à jour du noyau ait disparu.
Pour le savoir, donne le retour de cette commande :

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"

#6 Re : -1 »  Plus de mises à jour du noyau… » Le 07/04/2016, à 10:38

nany
Réponses : 12
nany a écrit :

Il est possible que le méta-paquet responsable des mises à jour du noyau ait disparu.

C’est donc bien ça.
Il faut donc le réinstaller :

sudo apt-get install -y linux-lowlatency

francois_c a écrit :

J'ai fait l'essai d'installer linux-image-lowlatency et les trois paquets de noyau qui semblaient s'imposer alors (3.13.0-85) mais j'ai eu au redémarrage un affichage basse définition sans arrière-plan de bureau (mon image, calculée juste pour le format d'affichage 1920x1080 devenant sans doute trop grande), et pourtant les pilotes graphiques propriétaires Nvidia semblaient toujours là.

Je pense que c’est dû au fait que tu n’as pas installé le paquet linux-headers qui va avec. Le méta-paquet linux-lowlatency installe les dépendance nécessaires.

francois_c a écrit :

mais je craignais que ça me prive du noyau lowlatency

Oui, c’est bien le méta-paquet linux-lowlentency qui se trouve dans Ubuntu-Studio et non linux-generic.

#7 Re : -1 »  Plus de mises à jour du noyau… » Le 07/04/2016, à 11:25

nany
Réponses : 12
jplemoine a écrit :

C'était donc une 1/2 bêtise... smile

nany a écrit :

Oui, c’est bien le méta-paquet linux-lowlentency qui se trouve dans Ubuntu-Studio et non linux-generic.

Si j'ai bien suivi (rien n'est moins sûr), c'est pas plutôt linux-lowlatency ? (comme dans la ligne de commande au dessus)

Voui voui, c’est une faute de frappe de ma part et je n’ai pas relu avant de poster.
Fort heureusement, la ligne de commande était correcte, elle.

#8 Re : -1 »  Impossible d'éteindre mon ordinateur portable (Lubuntu) » Le 29/03/2016, à 19:15

nany
Réponses : 44
Dussumier a écrit :

Cette commande ne change rien.

Dans ce cas renversons la vapeur :

sudo sed -i 's/splash acpi=force/splash/' /etc/default/grub && sudo update-grub

Il reste à suivre la piste de grandtoubab.

#9 Re : -1 »  Ubuntu 15.10 : Problème de mise à jour des dépôts, universe, main. » Le 31/03/2016, à 22:47

nany
Réponses : 3

Bonjour,

Tristan07 a écrit :

Auriez-vous observé la même chose ? L'accès url me donne un 404.

C’est pareil chez moi. C’est un problème du serveur. Il faudra réessayer plus tard.

Tristan07 a écrit :

mais je n'ai pas la même chose en graphique, j'avais normalement supprimé des dépôts:

La suppression des PPAs en graphique efface les lignes dans les fichiers mais ne supprime pas ces fichiers.

#10 Re : -1 »  clef USB est en [READ-only file system] besoins d'aide ! [Résolu] » Le 31/03/2016, à 12:17

nany
Réponses : 11

Bonjour,

Lapinooss a écrit :

la clef est peut être morte ?

On peut dire que oui. C’est un problème récurent avec ce modèle de clé.
Voir ici ou et le support en français.

#11 Re : -1 »  probleme sur apt-get update » Le 01/04/2016, à 12:00

nany
Réponses : 1

Bonjour,

c’est un problème du serveur pour la France rencontré effectivement hier soir et aussi il y a quelques jours.
Il faut donc soit patienter soit essayer un autre serveur.

#12 Re : -1 »  Disque dur plein, alors qu'il est presque vide » Le 31/03/2016, à 21:28

nany
Réponses : 44

Bonjour,

αjet a écrit :

Sur la doc ubuntu (en), il est propose une méthode pour supprimer les noyaux automatiquement : https://help.ubuntu.com/community/Lubun … aintenance
Je n'ai pas essaye, vous en pensez quoi ?

Moi j’en pense que c’est foireux à cause des paquets qui peuvent être marqués comme installés manuellement alors qu’il ne le devraient pas. Voir entre autres ce bug (vers la fin).
Mon truc pour être tranquille avec les noyaux en attendant que les différents bugs soient résolus.

@Pascoul74 : il faut appuyer sur la touche [Entrée] pour répondre non.

#13 Re : -1 »  [Résolu] Logithèque disparue » Le 30/03/2016, à 20:39

nany
Réponses : 14

Bonjour,

descoquesauxnoix a écrit :

Le dépôt méga ? Je n'ai rien installé sous le nom de méga.

Le dépôt a été installé automatiquement en installant MEGA Sync Client à partir d’un .deb téléchargé ici. wink

#14 Re : -1 »  [Résolu] Logithèque disparue » Le 30/03/2016, à 20:46

nany
Réponses : 14

Si tu utilises les services de MEGA, il n’y a aucune raison de le supprimer.

#15 Re : -1 »  [Résolu] Logithèque disparue » Le 31/03/2016, à 10:39

nany
Réponses : 14

Plus direct :

sudo dpkg -P megasync

#16 Re : -1 »  [Résolu] Logithèque disparue » Le 31/03/2016, à 17:03

nany
Réponses : 14

Si tous les megasync-xUbuntu*.deb sont construits comme celui-ci que j’ai téléchargé pour regarder son contenu, oui.

Contenu du fichier postrm dans le .deb :

#!/bin/bash

if [ -f  /etc/apt/sources.list.d/megasync.list ]; then
    rm -f /etc/apt/sources.list.d/megasync.list 2> /dev/null || true
fi

# kill running MEGAsync instance
killall megasync 2> /dev/null || true

#17 Re : -1 »  Assault Cube problème fichier .sh » Le 30/03/2016, à 00:08

nany
Réponses : 8

Bonjour,

ce n’était pas la peine de déplacer dans la section jeux car c’est en fait un problème de Nautilus.

Calysan a écrit :

Sauf que là, en double cliquant dessus, le fichier s'ouvre forcément dans un éditeur de texte, pas comme avant où on me demandait si je voulais le "lancer".

Pour retrouver ce comportement dans Nautilus :
Éditions → Préférences → onglet Comportement → dans la section Fichiers texte exécutables, choisir Demander à chaque fois.

Quant au script en lui-même, il faut le Lancer dans un terminal. Il fait alors des vérifications pour voir si tout ce qui lui est nécessaire est correctement installé avant de lancer le jeu. Il faut donc suivre les instructions qu’il affichera dans le terminal si le jeu ne se lance pas.

#18 Re : -1 »  Logitheque UBUNTU bloquee » Le 29/03/2016, à 18:17

nany
Réponses : 26

Bonjour,

cqfd93 a écrit :

Je n'avais jamais eu à traiter ce genre d'erreur jusqu'à aujourd'hui donc je suis en terre inconnue.

Je dirais simplement que les lignes 57 et 58 n’ont pas été supprimées. Je propose donc ceci :

sudo sed -i '/kranich/d' /etc/apt/sources.list ; nl -ba /etc/apt/sources.list

#19 Re : -1 »  Logitheque UBUNTU bloquee » Le 29/03/2016, à 19:11

nany
Réponses : 26
CHBOZE a écrit :

J'ai vu passer "cinnamon" dans les lignes à supprimer. L'utilisation de cet environnement que j'ai installé est il problématique ?

Non, du tout. C’est plutôt tes différentes tentatives pour ajouter le dépôt qui étaient problématiques. Mais c’est maintenant nettoyé.

cqfd93 a écrit :
nany a écrit :

Je dirais simplement que les lignes 57 et 58 n’ont pas été supprimées. Je propose donc ceci :

Elles ont bien été supprimées (il n'y avait plus de « duplicate sources.list entry »)

Regarde bien ces deux lignes dans le retour initial. Il y avait ppa/launchpad.net au lieu de ppa.launchpad.net. C’est cette erreur d’url qui provoquait l’erreur.

cqfd93 a écrit :

Le retour de apt-key list ne me dit pas grand chose, si quelqu'un a une idée, il est le bienvenu !

Les clés sont correctement installées. Il y a même la clé pour le dépôt des drivers Epson qui a disparu dans la bataille.

Donc, @CHBOZE : est-ce que ton imprimante fonctionne ?

#20 Re : -1 »  [résolu]Impossibilité de cocher une MAJ dans le gestionnaire » Le 23/03/2016, à 13:12

nany
Réponses : 36

Avec de l’intel, ça va simplifier les choses.
Donne les retours de :

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa
ls -l /etc/apt/sources.list.d /etc/apt/trusted.gpg.d

#21 Re : -1 »  [résolu]Impossibilité de cocher une MAJ dans le gestionnaire » Le 23/03/2016, à 19:19

nany
Réponses : 36

Eh bien voilà, au milieu de la bataille de cette purge, libgbm1 a été mis à jour. Problème résolu. wink
Allez, une dernière salve pour effacer toutes les traces du ppa :

sudo rm -v /etc/apt/sources.list.d/*edgers*.list* /etc/apt/trusted.gpg.d/*edgers*.gpg*
sudo apt-get autoremove --purge -y

#22 Re : -1 »  [résolu]Impossibilité de cocher une MAJ dans le gestionnaire » Le 24/03/2016, à 20:44

nany
Réponses : 36

Rien d’étrange à mes yeux. Donc allons y pour l’explication.

Tout d’abord, on a pu voir en #27 que, pour libgbm1, il y avait une version des pôts officiels et une version du ppa pouvant être choisies pour la mise à jour. La version du ppa étant plus élevée, c’est celle-ci qui était choisie.
Or, on a pu mettre en évidence en #29 que cette version ne pouvait être installée pour un problème de dépendance qui ne colle pas avec lts-vivid.
On a donc choisi de supprimer le ppa. Je te l’ai fait faire avec ppa-purge. Voilà ce qu’il fait :

  • il fait la liste des paquets proposés par le ppa ;

  • à partir de cette liste, il fait la liste des paquets installés sur le système (quelle que soit la version) ;

  • dans cette nouvelle liste, il marque les paquets soit à supprimer (s’il n’y a pas de version dans les dépôts officiels) soit à installer depuis les dépôts officiels ;

  • enfin il désactive le ppa et lance le processus d’installation.

On voit le résultat de ce processus d’installation en #33. La version la plus élevée est recherchée. Pour les cas où la version installée correspond, on peut voir les lignes avec « est déjà la plus récente version disponible ». Pour les autres cas, on a les lignes avec « Version choisie ». Pour ces versions choisies, l’installation est faite avec, dans la majorité des cas, une ligne avec « avertissement : dégradation » sauf pour libgbm1 où la version choisie était supérieure à la version installée et où c’est donc une mise à jour qui a été effectuée.

#23 Re : -1 »  libre office fait planter mon PC » Le 25/03/2016, à 14:40

nany
Réponses : 21

Bonjour,

nam1962 a écrit :

Merci.. parle de tes croyances, je parle de mes constatations.

Puisqu’il faut parler de constatations, alors constatons.
Je constate que mon notebook (Core2 Duo P9400 2.40GHz et 2Go de RAM) fait tourner convenablement Ubuntu (Unity, oui oui) 15.10 64 bits avec LO.
Je constate également que moko138 constate que LO tourne avec 1.5Go de RAM.

Les symptôme de ce fil sont des symptômes de saturation de processeur ou de mémoire.

Certes, mais au vu des constatations ci-dessus, il n’y a pas de raisons d’incriminer une incompatibilité de la configuration matérielle avec la configuration logicielle choisie. Je ne vois donc pas de justification pour proposer Xubuntu à la place d’Ubuntu-GNOME (personnellement, je n’apprécie pas Gnome-Shell mais je respecte ce choix). tongue

Si ce que je propose ne le fait pas, on pourra regarder autre chose..

Alors je propose de regarder tout de suite cette autre chose en attirant l’attention sur les messages #11 et #12.
Faut-il comprendre que LO ET AOO sont installés ensemble.
Si tel est bien le cas, je cite cette page de wiki.

https://wiki.ubuntu.com/LibreOffice/fr a écrit :

Veuillez noter que OpenOffice.org et LibreOffice ne coexistent pas.

La page est certes un peu vieillotte puisqu’elle date de l’époque du fork mais cette affirmation me semble toujours d’actualité. J’en veux pour preuve ce tuto pris au hasard où on commence par désinstaller LO avant d’installer AOO.
Bref, l’un casserait l’autre et vice-versa. Il est, je crois, essentiellement question de /usr/bin/soffice que les deux utiliseraient (soffice étant probablement un héritage historique de StarOffice).
De là à dire que cette double installation est susceptible de planter le système (segfault ?), je ne sais pas car je n’ai jamais expérimenté ce cas de figure. Mais mes soupçons se tournent tout de même de ce côté.
En conclusion,

moko138 a écrit :

En revanche, malmsteen, tu aurais intérêt à désinstaller et purger libreoffice avant de le réinstaller.

je dirais même purger LO ET AOO avant de faire un choix pour réinstaller l’un ou l’autre mais pas les deux.

#24 Re : -1 »  Quel commande ou variable donne le nom l'environnement graphique ? » Le 22/03/2016, à 20:51

nany
Réponses : 1

Bonjour,

printenv

te donnera les variables d’environnement disponibles. Chez moi, en 15.10, il y en a quatre intéressantes :

printenv GDMSESSION DESKTOP_SESSION XDG_SESSION_DESKTOP XDG_CURRENT_DESKTOP