Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Caméra de l'ISS » Le 23/05/2015, à 16:27

Pacifick_FR42
Réponses : 11

Petit up pour vois si quelqu'un aurait de meilleurs sources, car les caméra utilisé sont pas terrible, dommage...

#1 Re : -1 »  Odoo et moi » Le 15/03/2015, à 23:56

Pacifick_FR42
Réponses : 5

Salut, pour le serveur SMTP quelque soit le nombre 'utilisateur, un seul serveur suffit... ce n'est pas "nominatif"  tu peux bien y mettre un serveur smtp Orange que ça ne change rien...

#2 -1 »  Let's Encrypt enfin du https gratos... » Le 08/03/2015, à 20:38

Pacifick_FR42
Réponses : 22

Bonjour à tous !

Depuis peu, la fondation Mozilla (entre autre)  met à disposition une application opensource  lets-encrypt nous permettant d'utiliser le protocole https validé sans achat au préalable de licence...

Malheureusement, je suis pas parvenu a le faire fonctionner (mon anglais est pas très bon, mais à priori, c'est une version pre-view)

Si de votre coté vous êtes arrivé à le faire fonctionne, ou simplement me donner votre avis wink

Merci de votre retour ! smile

#3 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 09/03/2015, à 09:59

Pacifick_FR42
Réponses : 22

Merci beaucoup de ces précisions !
Tu as une idée de quand ça sera actif ?

#4 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 09/03/2015, à 22:35

Pacifick_FR42
Réponses : 22

Vous pouvez m'expliquer la différence entre un certificat basic et les autrs (j'y connais rien, dans ce dommaine, une vrait burne... wink )

#5 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 10/03/2015, à 15:43

Pacifick_FR42
Réponses : 22

Chouette il me faut au moins un classe 3...
Bon... des conseilles rapport qualité prix ? wink

#6 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 10/03/2015, à 20:44

Pacifick_FR42
Réponses : 22

Si je me fie à ton lin (Wiki)
Class 3 for servers and software signing, for which independent verification and checking of identity and authority is done by the issuing certificate authority.

C'est effectivement pour un serveur, avec site + applications.

#7 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 10/03/2015, à 21:39

Pacifick_FR42
Réponses : 22

Merci pour toutes ces infos, vous avez un 'fournisseurs" à conseiller, de préférence un fournisseur qui bosse pas pour la NSA wink

#8 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 13/03/2015, à 15:44

Pacifick_FR42
Réponses : 22

Bonjour tiramiseb

Je comprends pas ta dernière question,
Ce qui m' permis de débogué, c'est le fait d'inscrire le .crt & .key en dur dans le fichier vhost, ce qui m'ennuie, c'est que ISPconfig ne semble pas fonctionner concernant la gestion des des certificat (ou, j'ai pas su faire) wink

#9 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 13/03/2015, à 01:37

Pacifick_FR42
Réponses : 22

Bon pour l'instant, et histoire de me faire les dents, j'ai pris un nom de domaine chez Gandi, et je bénéficie donc d'un certificat simple pour un an.
J'utilise ISPConfig, mais même en suivant différent tuto, j'arrive pas à faire fonctionner le https...
Au mieux, j'ai ce message :

Une erreur est survenue pendant une connexion à fm-it.international. SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée. (Code d'erreur : ssl_error_rx_record_too_long)

Dans le champs Key, j'ai copié la clé, dans le champs CSR, le CSR, et dans le champs CRT, le certificat de Gandi, généré.
Dans le champs Bundle, je vois pas...

Le https (auto signé) du serveur --> ispconfig est fonctionnel

Des idées ?

RÉSOLU : http://forum.ubuntu-fr.org/viewtopic.php?id=1764801&p=1 par contre, je dois générer le fichier domaine.ltd-ssl.vhost à la main, ce n'est pas ispconfig qui gère ça, dommage.

Merci à tous !! wink

Quant à l'appli... à suivre... de près !

#10 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 13/03/2015, à 16:18

Pacifick_FR42
Réponses : 22

oui, mais quant tu dois gérer plusieurs dizaines de site... ça devient problématique (créa user, BDD, cota, mail,etc...) sad

#11 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 13/03/2015, à 21:48

Pacifick_FR42
Réponses : 22

Si tu fait le choix d'utiliser une interface graphique, c'est justement pour éviter de perdre du temps à tous faire à la main wink

#12 Re : -1 »  Let's Encrypt enfin du https gratos... » Le 14/03/2015, à 23:01

Pacifick_FR42
Réponses : 22

L'un empêche pas l'autre, l'utilisation d'une interface graphique rends les taches plus confortable, mais ça n'empêche pas de savoir aussi configurer à la main, bien au contraire.
Par contre, j'ai compris pourquoi ispconfig & SSL fonctionnait pas, c'était un conflit suexec/fastCGI ( j'avais garder un vieux et mauvais reflex de travailler sous www-data...) wink

#15 -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 00:53

Pacifick_FR42
Réponses : 19

Bonjour à tous smile

J'ai fait un script qui fonctionne très bien, celui-ci utilise aplay et sox.
Par contre, ce script est destiné à être appeler par un crontab, et là, pas moyen, ces 2 appli ne fonctionne plus.

Quelqu'un aurait une idée du pourquoi ?
J'ai bien fait des recherche sur les variables d’environnement, mais j'ai rien trouvé de probant.

Merci de vos coup de main wink

#16 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 15:00

Pacifick_FR42
Réponses : 19

Bonjour et merci à tous !

Alors, non, j'ai pas d'utilisation graphiques, uniquement en Bash
voici les passages en question :

sound=$1
time0=`/usr/bin/sox --i $sound | grep Duration`
echo "time0 : "$time0
time1=`echo $time0 |awk '{print $3}'`
echo "time1 : "$time1
time2=`echo $time1 | cut -d':' -f 3`
echo "time2 : "$time2
Duration=`echo "($time2+2.5)/1" | bc`
echo "Fichier son : "$sound
echo "Longeur du fichier son : "$Duration" Secondes"
/usr/bin/aplay "$sound"

#17 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 19:35

Pacifick_FR42
Réponses : 19

Bonjour,
J'ai activé le log, hélas aucun message d'erreur...
En dehors des action echo que j'ai mis

#18 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 21:07

Pacifick_FR42
Réponses : 19

Merci de ton aide,

Si sox avait bien fonctionné, j'airais les résultats ($Duration)

Il nous faut le script entier (le shebang, en tout cas, est important),

Tu peux préciser "Shibang" ?

#19 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 21:53

Pacifick_FR42
Réponses : 19
time0 : 
time1 : 
time2 : 
Fichier son : Serveur_1.wav
Longeur du fichier son :  Secondes
Longeur du fichier son :  Secondes

Là, c''est le log, rappel du code concerné :

#!/bin/bash

sound=$1
time0=`/usr/bin/sox --i $sound | grep Duration`
echo "time0 : "$time0
time1=`echo $time0 |awk '{print $3}'`
echo "time1 : "$time1
time2=`echo $time1 | cut -d':' -f 3`
echo "time2 : "$time2
Duration=`echo "($time2+2.5)/1" | bc`
echo "Fichier son : "$sound
echo "Longeur du fichier son : "$Duration" Secondes"
/usr/bin/aplay "$sound"

Edit : le rajout de set -x sous le shebang ne change rien aux fichiers logs.

#20 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 22:25

Pacifick_FR42
Réponses : 19

J'ai donc rediriger les sortie :

0,10,20,30,40,50 * * * *  /home/ciso/dossier/appli.sh > /home/ciso/dossier/appli.log 2>&1 

Le fichier Serveur_1.wav est à la racine de appli.sh et, est renvoyé par $1

#21 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 22:31

Pacifick_FR42
Réponses : 19

@Watael : Bienvu !

/usr/bin/sox FAIL formats: can't open input file `Serveur_1.wav': No such file or directory

Ok, avec cron rajouter le path wink

Par contre, c'est marrant, car sous cron, ça fonctionne, mais en directe, non, ce qui déconne c'est ça :

sound=$Path$1

#22 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 23:10

Pacifick_FR42
Réponses : 19

Oui, enfin, merci à tous, ça avance... wink smile

je ne vois pas d'argument, sur cette ligne, qui sera substitué à $1 sad

C'est à dire ?

#23 Re : -1 »  Problème script utilisant aplay et sox appelé par cron [RÉSOLU] » Le 26/01/2015, à 23:24

Pacifick_FR42
Réponses : 19

Tout est ok, quand j'avais fait mes tests en directe, j'avais oublié de lui envoyé le nom du fichier son ($1)
Reste plus qu'a tester que sous cron, que je reçois bien l'appel sur mon tel portable wink...

Merci à tous !! smile

#24 Re : -1 »  [Resolu]Probleme configuration lamp » Le 08/01/2015, à 22:43

Pacifick_FR42
Réponses : 13

C'était un plaisir, mais je pense pas que ce soit plus sécurisé que /var/www/html, mais avec ta config, ça permet d'héberger plusieurs sites (vhost)

Meilleurs Vœux ! smile