Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  [Résolu] Problème mises à jour wordpress local » Le 08/04/2015, à 04:06

chefdelegion
Réponses : 12

Salut, donner les droits ecritures pour :
sudo chmod -R 775 wp-content

#1 Re : -1 »  [Résolu] Problème mises à jour wordpress local » Le 08/04/2015, à 11:58

chefdelegion
Réponses : 12

Donc tu n'as  pas fait les groupes et toussa ... bon il faut simplement faire :
Ajoute ton user au groupe www-data :

sudo usermod -a -G www-data  (tonuser)

Verifie si ton user est bien dans le groupe www-data :

groups tonuser

Puis donne l'autorisation du groupe www-data a ton repertoire :

sudo chgrp -R www-data /usr/share/wordpress

Puis refait le chmod :

sudo chmod -R 775  /usr/share/wordpress/wp-content

#2 Re : -1 »  [Résolu] Problème mises à jour wordpress local » Le 08/04/2015, à 12:26

chefdelegion
Réponses : 12

et un : sudo chmod -R 775  /usr/share/wordpress/wp-content/ ?

#3 Re : -1 »  [Résolu] Problème mises à jour wordpress local » Le 08/04/2015, à 14:34

chefdelegion
Réponses : 12

fait moi la commande ls -la  dans ton dossier wordpress

#4 Re : -1 »  [Résolu] Problème mises à jour wordpress local » Le 08/04/2015, à 16:54

chefdelegion
Réponses : 12

comment cela fait que ils ont tous le ww-data comme user ?
pourquoi il ya un /etc/wordpress ?

Je pense qu'il serait mieux de desinstaller le paquer et de l'installer depuis ici, faire un serveur simple pour le moment :
Purge :

sudo apt-get purge wordpress && sudo apt-get autoremove --purge

Installation de apache2, mysql, php5 :

sudo apt-get install apache2 mysql-server php5 php5-mysql php5-gd 

Telechargement de wordpress dans  /var/www

cd /var/www && sudo wget http://wordpress.org/latest.tar.gz
sudo tar -xzvf latest.tar.gz

Creation de la base de donner que tu peux le faire avec une interface graphique avec phpmyadmin plus tard :

mysql -u root -p

Creation de la base :

CREATE DATABASE wpdatabase;
Query OK, 1 row affected (0.00 sec)

( tu peux mettre le nom,user,mdp comme tu veux)

Creation de l'user :

CREATE USER wpuser@localhost;
Query OK, 0 rows affected (0.00 sec)

Ajout d'un mdp de l'utilisateur :

SET PASSWORD FOR wpuser@localhost= PASSWORD("mettre-un-mot-de-passe-ici");
Query OK, 0 rows affected (0.00 sec)

Donner les droits de l'user pour la table :

GRANT ALL PRIVILEGES ON wpdatabase.* TO 
wpuser@localhost IDENTIFIED BY 'ton-mot-de-passe';
Query OK, 0 rows affected (0.00 sec)

Refresh mysql :

FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.00 sec)

Quitte Mysql :

quit;

Va dans ton repertoire wordpress :

sudo cd /var/www/
sudo chgrp -R www-data wordpress
sudo chmod -R 775 wordpress/

ensuite fait un http://tonip/wordpress
Ou alors faire :

sudo nano /etc/apache2/sites-available/default

Modifie et ajoute dans le default :

<VirtualHost *:80>
ServerAdmin my@email.com
DocumentRoot /var/www/wordpress
ServerName tondomaine ou ip
	<Directory /var/www/wordpress>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride All
		Order allow,deny
		allow from all
	</Directory>
</VirtualHost>

Puis un :

sudo service apache2 reload

Oui c'est du simple comme cela mais cela te permet d'apprendre les petites bases pour un hebergenent smile .

#5 -1 »  ACPI conflicts with OpRegion » Le 14/07/2015, à 12:00

chefdelegion
Réponses : 1

Salut,

J'ai un serveur qui tourne sous Ubuntu serveur 14.04 avec le noyau OpenVZ + KVM.

Depuis un moment le serveur crash avec une alerte ACPI conflicts with OpRegion

Dans la commande dsmeg j'ai ceci :

ACPI Warning: SystemIO range 0x0000000000005000-0x000000000000501f conflicts with OpRegion 0x0000000000005000-0x000000000000500f (\_SB_.PCI0.SBUS.SMBI) (20090903/utaddress-254)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000047f (\PMIO) (20090903/utaddress-254)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x000000000000053f (\GPRL) (20090903/utaddress-254)
ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x00000000000008ff (\GPR_) (20090903/utaddress-254)
ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x000000000000052f (\_SI_.SIOR) (20090903/utaddress-254)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Puis avec lsusb :

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046b:ff10 American Megatrends, Inc. Virtual Keyboard and Mouse
Bus 003 Device 004: ID 04d9:1603 Holtek Semiconductor, Inc. Keyboard
Bus 003 Device 002: ID 03f0:1017 Hewlett-Packard LaserJet 1300
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

J'ai mis acpi=off via grub mais rien ne se fait. Quelqu'un a une idee ? merci

#6 Re : -1 »  Stabilité UBUNTU 14.04 » Le 14/04/2015, à 04:04

chefdelegion
Réponses : 25

J'utilise Xubuntu sur tous les ordi, meme des ordi avec 1GB il tourne bien plus vite que un vulgaire windows.

#7 Re : -1 »  Virus » Le 18/04/2015, à 13:35

chefdelegion
Réponses : 19

cela depend ce que tu fais, si tu installes tes logiciels dans les depots et non via internet, tu n'as pas de risque.
un anti virus sous linux est quand meme utile, pour detecter des fichiers infecte si tu as un systeme windows, clamav est suffisant, j'ai deja detecter des fichiers php infecter.
Ah une fois une dizaine d'ordinateur sous Ubuntu etaient infecter dans une entreprise, leurs sysadmin avait installer un logiciel bizare depuis internet qui avait un keyloger et rootkit.

#8 Re : -1 »  Problème de droit fichier serveur web » Le 17/04/2015, à 05:58

chefdelegion
Réponses : 16

tu utilises quoi comme logiciel de serveur ftp ?

#9 Re : -1 »  Problème de droit fichier serveur web » Le 17/04/2015, à 08:48

chefdelegion
Réponses : 16

comment as-tu configurer proftpd ?

#10 Re : -1 »  Problème de droit fichier serveur web » Le 17/04/2015, à 09:50

chefdelegion
Réponses : 16

tu devrais faire plutot utilise ssh au lieu d'un ftp qui n'est pas securise.

Mysecureshell permet de te faire un SFTP avec ssh :

Rajoutez ceci dans ton fichier /etc/apt/sources.list :

deb http://mysecureshell.free.fr/repository/index.php/ubuntu/12.04 testing main
deb-src http://mysecureshell.free.fr/repository/index.php/ubuntu/12.04 testing main

Pour importer la signature GPG du repository, il faut exécuter les commandes suivantes:

gpg --keyserver hkp://pool.sks-keyservers.net --recv-keys E328F22B; gpg --export E328F22B | sudo apt-key add -

SI cela ne marche pas :

gpg --keyserver hkp://pool.sks-keyservers.net --recv-keys E328F22B; sudo gpg --export E328F22B | sudo apt-key add -

Puis :

sudo apt-get update

Et installe :

sudo apt-get install mysecureshell

Tu crees ton user :

sudo adduser --home /home/toto --shell /bin/MySecureShell toto

Puis tu modifies le fichier :

sudo nano /etc/ssh/sftp_config 

Par exemple :

<User tonusers>
Home /home/www/tonsite
StayAtHome true
VirtualChroot    true
HideNoAccess     false
DefaultRights 0664 0775
IgnoreHidden     false
#Shell           /bin/bash
</User>

Puis un :

sudo service mysecureshell restart

Apres met les droits :

sudo usermod -a -G www-data tonuser
sudo chmod -R tonuser:www-data /home/www/tonsite
sudo chmod -R 775 /home/www/tonsite 

#11 Re : -1 »  Problème de droit fichier serveur web » Le 18/04/2015, à 11:30

chefdelegion
Réponses : 16

as tu desinstaller proftpd ?

Si non :

sudo apt-get purge proftpd && suto apt-get autoremove --purge

affiche moi les droits de ton dossier :

ls -la tonddossier-web

Affiche moi les groupes de ton utilisateur :

sudo groups azralth

Verifie la gestion de l'umask dans le profile utilisateur :

nano /home/azralth/.profile

#umask 022

par

umask 002 

Pour les ID ton site est gerer via une base de donner ?
Si oui,tu as installe mariadb/mysql ?

#12 Re : -1 »  Problème de droit fichier serveur web » Le 18/04/2015, à 12:24

chefdelegion
Réponses : 16

Il faudrait que tu vides ton caches en premier lieu

#13 Re : -1 »  Problème de droit fichier serveur web » Le 18/04/2015, à 12:31

chefdelegion
Réponses : 16

le 002 permet d'avoir un chmod 775.
pour le cache dans ce cas met lui un chown -R www:data:www-data tondossiercache

#14 Re : -1 »  Problème de droit fichier serveur web » Le 18/04/2015, à 12:40

chefdelegion
Réponses : 16

erreur de frappe de ma part :

chown -R www-data:www-data tondossiercache

#15 Re : -1 »  Problème de droit fichier serveur web » Le 18/04/2015, à 13:31

chefdelegion
Réponses : 16

C'est le user et le groupe qui ont le droit a lecriture,lecture etc ... je recommanderais meme en 770 mais je connais pas bien dotclear donc la je peux pas vraiment resoudre ton probleme.

#16 Re : -1 »  vulnérable flash player » Le 17/04/2015, à 11:30

chefdelegion
Réponses : 11

Tu peux utiliser chromium avec pepperflash :

sudo apt-get install chromium-browser pepperflashplugin-nonfree

Il va avoir un pepper flash pour firefox bientot, il s'appellera Shumway

#17 Re : -1 »  .htaccess ignoré avec virtualHost » Le 07/04/2015, à 14:24

chefdelegion
Réponses : 18

dans ce cas :

sudo apt-get install apache2-utils

(si tu l'as pas installer)

<VirtualHost *:80>
	ServerAdmin xxxx@xxx.fr
	ServerName tondomaine.fr/Appli_Vpn
	
	DocumentRoot /var/www/Appli_Vpn

<Directory /var/www/Appli_Vpn/>
    Options Indexes FollowSymLinks MultiViews ExecCGI
    AuthType Basic
    AuthName "Private Documentation Repository"
    AuthUserFile /var/www/Appli_Vpn/.htpasswd
    Require valid-user
    AllowOverride None
    Order allow,deny
    allow from all
  </Directory>
	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

</VirtualHost>

Puis faire :

htpasswd /var/www/Appli_Vpn/.htpasswd (tonuser)
New password:
Re-type new password:

Et puis :

sudo apt-get apache2 reload

si sa marche rajoute dans ton vhost en dessous de Options Indexes FollowSymLinks MultiViews ExecCGI :

<Files .htpasswd>
Order Allow,Deny
Deny from all
</Files>

#18 Re : -1 »  .htaccess ignoré avec virtualHost » Le 07/04/2015, à 16:35

chefdelegion
Réponses : 18

hum etrange ...

dans ce cas la suit la methode ici :

http://www.xenetis.org/a_26_proteger_un … lenny.html

#19 Re : -1 »  [Résolu]Proftpd droit d'envoyer » Le 09/04/2015, à 04:15

chefdelegion
Réponses : 3

a tous mis en place les droits sur le dossier du ftp avec ton utilisateur ?

comment as-tu mis en place ton ftp ?

#20 Re : -1 »  Ubuntu 14.10 sur un serveur ? » Le 09/04/2015, à 04:26

chefdelegion
Réponses : 6

Pour une Debian Wheezy tu peux installer le php5.6 via les depots suivent :

echo "deb http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list
echo "deb-src http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list

La cle :

wget http://www.dotdeb.org/dotdeb.gpg -O- |apt-key add -

Puis un update :

apt-get update

#21 Re : -1 »  NAS4FREE le meilleur FS pour compatibilité linux facile ? » Le 09/04/2015, à 04:19

chefdelegion
Réponses : 3

J'utilise Nas4Free pour un serveur ayant 1 GB de RAM. Je te recommande d'utilise UFS et non ext4 etc ...

RAID1 te fait bien un mirroire et dans la doc ils expliquent bien comment faire pour retirer et ajouter un autre HDD. De base il est toujours utile de faire un backup du fichier xml de nas4free en cas de pepin.

#22 Re : -1 »  Wifi carte BCM4313 reste désactivé après installation du pilote » Le 08/04/2015, à 03:59

chefdelegion
Réponses : 3

1. Desinstalle le pilote "Broadcom Sta" dans pilote supplementaire.

2. Supprimer la ligne "Blacklist B43" : (Pour ca tapez dans le terminal) :

sudo gedit /etc/modprobe.d/blacklist.conf

(supprimer la ligne "Blacklist B43" se trouvant dans le fichier qui s'y trouve).
ET
ajoute a la fin du fichier ces deux lignes :

blacklist bcma
blacklist brcmsmac

(enregistrer et quittez).

3. Desinstaller bcmwl-kernel-source : (tapez dans le terminal)

sudo apt-get remove --purge bcmwl-kernel-source

3 - redemarre le pc

4 - reinstalle  bcmwl-kernel-source (tapez dans le terminal, une à la fois ces lignes)

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

5 - redemarre le PC

6. Active le Pilote "Broadcom STA" dans pilote proprietaire.

#23 Re : -1 »  [Résolus] Erreur lors de l'installation de Mysql » Le 08/04/2015, à 06:05

chefdelegion
Réponses : 4

Salut,

Tape cette commande :

sudo apt-get purge libdbd-mysql-perl libmysqlclient18 mysql-client-5.6 mysql-client-core-5.6 mysql-common  mysql-common-5.6 mysql-server-core-5.6 mysql-server-5.6

Puis installe mariadb a la place de mysql (pour la version de ubuntu 14.04) :

sudo apt-get install software-properties-common
sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xcbcb082a1bb943db
sudo add-apt-repository 'deb http://ftp.igh.cnrs.fr/pub/mariadb/repo/10.0/ubuntu trusty main'
sudo apt-get update
sudo apt-get install mariadb-server

#24 Re : -1 »  [Résolus] Erreur lors de l'installation de Mysql » Le 08/04/2015, à 08:54

chefdelegion
Réponses : 4

Mariadb est un fork de Mysql qui reste 100% compatible avec Mysql smile