Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 23/07/2015, à 11:38

PounkyM
Réponses : 11

Up ! L’URL que j’utilise est la suivante : http://server.org/dav.server.org/html/c … me/default si jamais ça peut aider…

#1 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 27/07/2015, à 09:37

PounkyM
Réponses : 11

Personne n’aurait d’idées ? Au moins pour essayer de déterminer si mon problème vient de mon server CalDav ou de mon client CalDav (Lightning) ?

#2 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 27/07/2015, à 11:53

PounkyM
Réponses : 11

Salut src, et merci de prendre le temps de t’intéresser à mon problème ! smile

Quand j’essaye d’accéder à http://server.org/dav.server.org/html/cal.php, j’obtiens la page suivante :

<d:error>
<s:exception>Sabre\DAV\Exception\NotImplemented</s:exception>
<s:message>GET is only implemented on File objects</s:message>
<s:sabredav-version>1.8.7</s:sabredav-version>
</d:error>

Mais c’est censé être le résultat attendu d’après cette remarque : http://stackoverflow.com/questions/1372 … a%C3%AFkal

J’ai essayé d’installer un client web (caldavzap) mais je n’arrive pas à le faire marcher à cause d’un problème de crossDomain que je n’arrive pas à résoudre…

#3 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 27/07/2015, à 13:13

PounkyM
Réponses : 11

Oh, tu utilises aussi Baikal et Lightning ? Comme ce problème fait suite à une mise-à-jour de ma debian (notamment les paquets nginx, php, etc.), est-ce que tu penses que ça viendrait d’un de ces paquets ?

#4 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 27/07/2015, à 14:31

PounkyM
Réponses : 11

Voici les erreurs de la console de Thunderbird que j’obtiens lorsque j’essaye de synchroniser :

[JavaScript Warning: "There has been an error reading data for calendar: Calendar.
However, this error is believed to be minor, so the program will attempt to continue.
Error code: DAV_NOT_DAV.
Description: The resource at http://server.org/dav.server.org/html/cal.php/calendars/username/default is either not a DAV collection or not available"]
[JavaScript Warning: "There has been an error reading data for calendar: Calendar.
However, this error is believed to be minor, so the program will attempt to continue.
Error code: READ_FAILED.
Description: "]

#7 Re : -1 »  Problème entre serveur Caldav et Thunderbird + Lightning » Le 05/08/2015, à 09:36

PounkyM
Réponses : 11

Toujours pas d’idées pour débugguer ce problème ?

#8 -1 »  [Résolu] 502 Bad Gateway avec Nginx + php5-fpm » Le 22/07/2015, à 14:15

PounkyM
Réponses : 3

Bonjour à tous,

Je n’arrive pas à accéder à mes pages web gérées par un serveur nginx + php5-fpm, je tombe toujours sur une erreur 502 Bad Gateway.

Voici ce que contient mon /etc/php5/fpm/pool.d/www.conf :

% cat /etc/php5/fpm/pool.d/www.conf
[...]
listen = /var/run/php5-fpm.sock
[...]
listen.owner = www-data
listen.group = www-data
listen.mode = 0660
[...]

Mon netstat :

% sudo netstat -tlpn      
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      2511/dovecot    
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      397/rpcbind     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      3566/nginx -g daemo
tcp        0      0 0.0.0.0:34963           0.0.0.0:*               LISTEN      406/rpc.statd   
tcp        0      0 0.0.0.0:5269            0.0.0.0:*               LISTEN      1017/lua5.1     
tcp        0      0 0.0.0.0:51413           0.0.0.0:*               LISTEN      428/transmission-da
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      425/sshd        
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      2728/master     
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      3566/nginx -g daemo
tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      2511/dovecot    
tcp        0      0 0.0.0.0:9091            0.0.0.0:*               LISTEN      428/transmission-da
tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      1017/lua5.1     
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      1028/mysqld     
tcp6       0      0 :::143                  :::*                    LISTEN      2511/dovecot    
tcp6       0      0 :::111                  :::*                    LISTEN      397/rpcbind     
tcp6       0      0 :::80                   :::*                    LISTEN      3566/nginx -g daemo
tcp6       0      0 :::5269                 :::*                    LISTEN      1017/lua5.1     
tcp6       0      0 :::51413                :::*                    LISTEN      428/transmission-da
tcp6       0      0 :::22                   :::*                    LISTEN      425/sshd        
tcp6       0      0 :::25                   :::*                    LISTEN      2728/master     
tcp6       0      0 :::47487                :::*                    LISTEN      406/rpc.statd   
tcp6       0      0 :::993                  :::*                    LISTEN      2511/dovecot    
tcp6       0      0 :::5222                 :::*                    LISTEN      1017/lua5.1     

Ainsi que les processus greppés avec php :

%  ps -eF | grep php           
root      3610     1  0 22874  7696   0 10:58 ?        00:00:01 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)                    
www-data  3612  3610  0 22874  2436   0 10:58 ?        00:00:00 php-fpm: pool www                                                       
www-data  3613  3610  0 22957  3812   0 10:58 ?        00:00:00 php-fpm: pool www

Nginx et php5-fpm restartent sans erreurs… Donc j’avoue que je ne sais pas où chercher, tout me semble OK.

Avez-vous des idées ? smile

#9 Re : -1 »  [Résolu] 502 Bad Gateway avec Nginx + php5-fpm » Le 22/07/2015, à 15:27

PounkyM
Réponses : 3

Salut bobe,

Voici un extrait de mon /etc/nginx/sites-available/serveur :

location ~ \.php$ {
 include /etc/nginx/fastcgi_params;
 fastcgi_param   SCRIPT_FILENAME  $document_root$fastcgi_script_name;
 fastcgi_pass    127.0.0.1:9000;
}

location ~ [^/]\.php(/|$) {
         fastcgi_split_path_info ^(.+?\.php)(/.*)$;
         if (!-f $document_root$fastcgi_script_name) {
            return 404;
         }
         #try_files $fastcgi_script_name =404;
         fastcgi_pass unix:/var/run/php5-fpm.sock;
         fastcgi_index index.php;
         fastcgi_param  PATH_INFO $fastcgi_path_info;
         include fastcgi_params;
}

#10 Re : -1 »  [Résolu] 502 Bad Gateway avec Nginx + php5-fpm » Le 22/07/2015, à 15:29

PounkyM
Réponses : 3

Oh, je suis trop con !

J’ai remplacé :

fastcgi_pass    127.0.0.1:9000;

par :

fastcgi_pass unix:/var/run/php5-fpm.sock;

et ça a marché !

#11 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 21/07/2015, à 23:51

PounkyM
Réponses : 24

Hello J5012 et merci pour ta réponse smile

Je suis un peu novice dans ce domaine… pourrais-tu détailler un chouillas ou me donner des pistes sur où aller ?

#12 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:07

PounkyM
Réponses : 24

Oh, je crois que j’ai compris pourquoi il n’arrive pas à se synchroniser.

Je n’arrive pas à pinger l’extérieur !

% ping 66.249.64.0
connect: Network is unreachable

#13 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:17

PounkyM
Réponses : 24

Est-ce que quelqu’un a une idée pourquoi ? Si ça peut vous aider, voici mon /etc/network/interfaces :

% cat /etc/network/interfaces
# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
# /usr/share/doc/ifupdown/examples for more information.

# auto lo

# iface lo inet loopback
# iface eth0 inet dhcp

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.0.12
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
#NetworkManager#iface eth0 inet dhcp

#14 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:18

PounkyM
Réponses : 24

@J5012 : est-ce que je suis vraiment obligé de passer par là ? Ça m’a l’air bien compliqué… sad

#15 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:23

PounkyM
Réponses : 24

Je pense qu’il faut déjà que j’arrive à pouvoir de nouveau accéder à « l’extérieur » :

% ping 66.249.64.0
connect: Network is unreachable

#16 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:26

PounkyM
Réponses : 24

Oh ok… Mais comme mon serveur est sur une carte raspberry pi, c’est compliqué d’accéder au grub… puis j'ai peur de tout casser avec recovery et fsck ):

#17 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:31

PounkyM
Réponses : 24

Sauf que j'ai mis une partie (/var) sur ma SD et /home sur un DD externe…

Et désolé de ne pas avoir les bases… C'est gentil de m'aider quand même.

#18 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 00:32

PounkyM
Réponses : 24
J5012 a écrit :

tu la fsck avec un autre linux

Je peux faire ça en montant la carte SD sur un ordinateur sous linux ?

#19 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 07:34

PounkyM
Réponses : 24

@MicP : merci de ta réponse, j’ai regardé sur ma carte raspberry pi mais je n’ai pas l’impression qu’elle contienne une pile du BIOS…

#20 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 07:38

PounkyM
Réponses : 24

Mais vous pensez vraiment que le problème de « Network is unreachable », vient du fait que mon disque est complètement cassé suite à la coupure de courant ?

#21 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 07:43

PounkyM
Réponses : 24

Par ailleurs, voici mes routes :

% route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

Pensez-vous qu’elle est bonne (je ne suis pas certain pour la gateway, j’hésite à mettre l’IP de mon routeur (= ma box)) et pensez-vous que cette seule route suffit ?

EDIT : j'ai ajouté la route vers mon routeur, et maintenant, je ping l’extérieur !

#22 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 08:07

PounkyM
Réponses : 24

Ces trois commandes m’ont permis de me mettre à l'heure :

sudo /etc/init.d/ntp stop
sudo ntpdate -s time.nist.gov
sudo /etc/init.d/ntp start

#23 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 08:12

PounkyM
Réponses : 24

@bruno : un grand merci pour ta réponse, mon problème est réglé ! je vais essayer d’ajouter par défaut le lancement de dhclient eth0 à chaque redémarrage pour éviter ce problème à nouveau…

Par contre, je sais que c’est « hors-sujet » concernant ce topic, mais suite à cette coupure de courant, il semble que j’ai perdu mes mails arrivés pendant cette coupure de courant (serveur postfix + dovecot), pensez-vous que c’est normal ? Et existe-t-il un moyen de les récupérer ?

#24 Re : -1 »  [Résolu] Serveur bloqué le 1er janvier 1970 » Le 22/07/2015, à 14:05

PounkyM
Réponses : 24

@bruno : merci, j’ai reçu tous mes mails maintenant !