Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Démarrage bloqué sur le GRUB » Le 30/07/2015, à 19:13

side
Réponses : 11

Bonjour.

Au démarrage dans Options avancées il devrait y avoir un menu : Ubuntu, Linux ..... (upstart)

En choisissant ce menu tu devrais pouvoir démarrer.

#1 Re : -1 »  Démarrage bloqué sur le GRUB » Le 30/07/2015, à 21:40

side
Réponses : 11
Anard a écrit :

Je peux lui nettoyer tout ça pour qu'il n'ait plus que le nécessaire ?

Tu as sans doute un soucis avec ta carte graphique.

Dans un terminal :

juste pour voir c'est quoi ta carte :

lspci | grep "VGA compatible controller"

Si c'est du nvidiaGT, regarde ici : https://forum.ubuntu-fr.org/viewtopic.php?pid=19911451

Plusieurs topics disent d'utiliser le noyau 4.1 et le problème est réglé. Avant de faire ça, vérifie si ce qui suit fonctionne :

cat /etc/X11/default-display-manager

doit te renvoyer un truc comme : /usr/sbin/machindm
exemple :

/usr/sbin/ssdm

Du coup tenter :

sudo systemctl enable sddm.service -f

Et redémarrer normalement.


Pour fstab j'ai besoin de le voir.

cat  /etc/fstab

#2 Re : -1 »  Démarrage bloqué sur le GRUB » Le 31/07/2015, à 17:43

side
Réponses : 11

Peux-tu me renvoyer le résultat de :

sudo fdisk -l

et à nouveau de

cat /etc/fstab

histoire d'y voir un peu plus clair.

#3 Re : -1 »  Démarrage bloqué sur le GRUB » Le 31/07/2015, à 01:08

side
Réponses : 11
Anard a écrit :

Je pense que 'Medias' devrait être remplacé par 'Medias1'. Les deux disques sont en HFS+ parce qu'ils sont aussi utilisés par OS X (sur la partition principale du SSD). Le dual-boot fonctionnait très bien avant réinstallation d'Ubuntu.
Maintenant que j'ai le chemin (/etc/fstab), est-ce que je peux ouvrir le fichier dans gedit et le modifier comme j'ai besoin (rajouter un 1 derrière Medias) ?

Oui mais il faut que tu modifies la dénomination de tes disques en utilisant l'UUID. C'est plus propre ainsi et ça évite de faire l'erreur suivante :

/dev/sdc /media/anard/Medias hfsplus rw,nosuid,nodev,relatime,umask=22,uid=0,gid=0,nls=utf8 0 0

Il manque le numéro de partition à /dev/sdcX

Donc pour faire plus propre tongue

Pour tes deux partitions media

sudo blkid /dev/sdd2

Ca vas te donner une réponse du genre

/dev/sdd2  UUID="a92afeff-bf4c-325f-a277-01f5c6ba9b14" Type="hfsplus"

Tu modifies la ligne

/dev/sdd2 /media/anard/Saver hfsplus ro,nosuid,nodev,relatime,umask=22,uid=0,gid=0,nls=utf8 0 0

en effaçant /dev/sdd2 et à la place tu tapes UUID=la-série-de chiifres-que-tu-as-eu
Attention à ne pas copier les guillemets. Compare avec les lignes d'au-dessus ^^

Pareil pour ta partition /media/Anard/Medias.

sudo blkid /dev/sdcX

Sauf qu'il faut savoir quel numéro de partition c'est.
Si tu ne sais pas, utilise gparted pour retrouver.

------------


Anard a écrit :

Pour les doubles options du GRUB, je me demande si ça ne vient pas du fait qu'il ait installé 2 fois de suite le grub sur la partition EFI du disque suite à la réinstall. Pourtant, dans cette partition, je ne trouve qu'une fois les fichiers dédiés à Ubuntu.

A priori il y a un bug avec lightdm et systemd qui remplace upstart pour le lancement des services, et donc du boot.

Vu que ça demarre bien avec upstart pour toi, c'est possible de changer systemd par upstart mais c'est faire "un pas en arrière" par rapport à l’évolution d'ubuntu.
M'enfin si le soucis persiste malgré plusieurs mises à jour et que tu en as marre de devoir aller dans les menu pour démarrer :

sudo apt-get install upstart-sysv

il va te dire qu'il doit supprimer deux paquets.
systemd-sysv et ubuntu-standard. S'il veut supprimer autre chose, il faut refuser l'installation.

Et finir par

sudo update-initramfs -u

Au reboot Entrée sur démarrer ubuntu devrait fonctionner et le menu Options avancées aura changé, à la ligne avec (upstart) il y aura (systemd).

source en anglais : https://wiki.ubuntu.com/SystemdForUpstartUsers

#4 Re : -1 »  Démarrage bloqué sur le GRUB » Le 31/07/2015, à 14:37

side
Réponses : 11
Anard a écrit :

Alors, il ne veut pas modifier fstab directement depuis gedit (enfin, il veut bien modifier, mais pas enregistrer...)

Il faut que tu lances gedit en tant que superutilisateur : https://doc.ubuntu-fr.org/tutoriel/comm … un_fichier

Avec gedit :

appuyez sur Alt–F2, puis saisissez « gksudo gedit ». Saisissez votre mot de passe.
Une fois Gedit ouvert, ouvrez le fichier (Fichier → Ouvrir ou Ctrl–o) à modifier, faites ce que vous avez à faire, enregistrez le fichier (Fichier → Enregistrer ou Ctrl–s) et quittez.

Anard a écrit :

PS : En fait, le port SATA de ma CM n'avait pas grillé. J'ai inversé les câbles du SSD et du disque Utilisateurs et il boote à nouveau normalement en utilisant les ports dans l'ordre normal (0:SSD, 1:Users, 2:Medias, 3:Sauvegardes et 4:lecteur CD). Bizarre mais ça marche...

Si dans cet ordre là, tout fonctionne bien, alors n'y touche plus et modifie simplement ton fstab.

Pas la peine de faire une réinstall.

#5 Re : -1 »  [résolu] serveur mysql qui ne demarre plus » Le 30/07/2015, à 18:48

side
Réponses : 16

Bonjour.

yolbi a écrit :

Le dossier /var/run/mysqld/ est vide
Pas de fichier "mysqld.sock"

Tu peux essayer :

sudo mysqld_safe

et relancer mysql.

#6 Re : -1 »  [résolu] serveur mysql qui ne demarre plus » Le 30/07/2015, à 21:45

side
Réponses : 16

Vérifie ce que tu as dans /var/run/mysqld ??

Parce que là il dit que c'est ok.

#7 Re : -1 »  [résolu] serveur mysql qui ne demarre plus » Le 30/07/2015, à 22:26

side
Réponses : 16

Essayes d’accéder à mysql directement en ligne de commande pour voir.

mysql -h 127.0.0.1 -P 3306 -u root -p
mysql> quit

pour sortir.

#8 Re : -1 »  [résolu] serveur mysql qui ne demarre plus » Le 31/07/2015, à 01:39

side
Réponses : 16
sudo touch /var/run/mysqld/mysqld.sock

puis

sudo chown -R mysql /var/run/mysqld/

et tester

sudo service mysql start

#9 Re : -1 »  qui oserait et comment on pourrait nous manipuler » Le 09/07/2015, à 19:25

side
Réponses : 316

On joue ?

Le bidonville d'Ivry (Val-de-Marne) a été évacué par les forces de police sur ordre du Préfet Thierry Leleu, jeudi 9 juin, dès 4 heures du matin. Sorti de terre en 2011, sur un terrain vague de la rue Truillot appartenant à l’Assistance Publique-Hôpitaux de Paris (AP-HP), il a hébergé plus de 300 personnes. Bon nombre d'entre elles ont quitté leurs habitations avant l'expulsion.

1436462522.jpg
1436462544.jpg
1436462570.jpg
1436462598.jpg


Sans tricher avec un moteur de recherche web, en quelques mots, interpréter et donner son sentiment sur la dernière photo que voici :

1436462621.jpg


tongue

#11 Re : -1 »  Raspberry-pi et Ubuntu » Le 21/01/2015, à 12:24

side
Réponses : 16

Salut.

Pas trop grave j’espère.
Bon courage pour la suite.


smile

#12 Re : -1 »  Xibo sur raspberry » Le 30/01/2015, à 00:07

side
Réponses : 7

Bonjour.

Le type qui as fait l'image dis :

hellbender a écrit :

It out boots into LXDE and runs the xibo client in fullscreen ( which is forced 1920x1080 ). If people have trouble booting in such a high resolution please edit the config.txt on the image to the resolution you need ( don't forget to tell Xibo the same in the site.cfg).

Ici : http://www.raspberrypi.org/forums/viewt … &start=375

Et apparemment la résolution pose effectivement problème à pas mal de gens.
Donc si ce n'est pas fait faut commencer par essayer ça. tongue

#13 Re : -1 »  [RESOLU] samba limite 2Go » Le 09/12/2014, à 13:47

side
Réponses : 11

Bonjour.

Pourrais-tu donner le contenu de ton fstab ?

Si le montage samba est automatique, tu dois avoir une ligne qui s'y réfère.

#14 Re : -1 »  minidlna et version ubuntu 14.04 RESOLU » Le 23/12/2014, à 23:22

side
Réponses : 28

Bonjour.

gassel a écrit :

j'ai télécharger minidlna

Téléchargé ou installé ?

Normalement si on suit la doc minidlna ça ne pose pas de problème.

Il ne faut pas oublier d'activer uPnP dans la box.

#15 Re : -1 »  minidlna et version ubuntu 14.04 RESOLU » Le 24/12/2014, à 18:59

side
Réponses : 28

Bonjour.

Donc en effet minidlna n'est pas installé.

Pour faire simple il vaut mieux installer la version des dépôts.
Mais ça :

E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.

par contre ce n'est pas normal.

Ouvre un terminal de commande et tapes :

sudo apt-get update

Si tu as toujours les messages d'erreurs, tapes :

sudo rm -rf /var/lib/apt/lists/lock

puis refait

sudo apt-get update

puis

sudo apt-get upgrade

et enfin

sudo apt-get install minidlna

Ensuite tu pourra faire la configuration.

Edit : Sinon évite d'écrire en majuscules parce que ça donne l'impression que TU NOUS CRIES DESSUS COMME UN OURS !

#16 Re : -1 »  [résolu] Ajouter commandes permanentes au démarrage » Le 21/12/2014, à 23:36

side
Réponses : 4

Bonjour.

Peux-tu nous donner le résultat de la commande :

 tail -n 15  /etc/init.d/rc.local

#17 Re : -1 »  [résolu] Ajouter commandes permanentes au démarrage » Le 22/12/2014, à 14:44

side
Réponses : 4

Bonjour.

Comme expliqué dans la doc il faut rajouter

echo "2001 330D" | tee /sys/bus/usb/drivers/rtl8192cu/new_id

dans ce fichier.


Alors :

sudo nano  /etc/init.d/rc.local

Tout en bas du fichier repérer

echo "Usage: $0 start|stop" >&2
        exit 3
        ;;
esac

et rajouter la commande comme suit :

echo "Usage: $0 start|stop" >&2
echo "2001 330D" | tee /sys/bus/usb/drivers/rtl8192cu/new_id
        exit 3
        ;;
esac

Sauvegarder avec Ctrl+O, sortir Ctrl+X

redémarrer l'ordi. Ca devrait être ok.

#18 Re : -1 »  [résolu]connexion ssh (terminal et graphique ) impossible avec windows » Le 09/12/2014, à 13:28

side
Réponses : 18

Bonjour.

Comme le dit tiramiseb il faut déjà avoir un accès ssh avant de commencer.

zébulon841 a écrit :

au bout d' 1 certain temps putty m 'indique que le temps est dépassé et il se déconnecte.

As-tu rediriger le port ssh à partir de ta box ?

Si ce n'est pas fait tu ne pourra pas accéder à ton serveur de l'extérieur.

Ca doit ressembler à un truc comme ça : https://craym.eu/tutoriels/utilitaires/ … ml#neufbox

Quand tu te retrouve dans le NAT tu rediriges le port 22 et le port 6000 (par défaut si tu n'as pas changé les ports d’écoute) vers ton poste ubuntu, les deux en TCP.

#19 Re : -1 »  [résolu]connexion ssh (terminal et graphique ) impossible avec windows » Le 09/12/2014, à 14:09

side
Réponses : 18
tiramiseb a écrit :

Quand tu te retrouve dans le NAT tu rediriges le port 22 et le port 6000 (par défaut si tu n'as pas changé les ports d’écoute) vers ton poste ubuntu

Non, on ne touche pas au port 6000, il ne nous concerne pas là.

Dans la doc du X Forwarding ils disent que c'est le port par défaut du serveur X.

#20 Re : -1 »  [résolu]connexion ssh (terminal et graphique ) impossible avec windows » Le 09/12/2014, à 14:13

side
Réponses : 18
tiramiseb a écrit :

Oui mais on ne fait rien passer par le serveur X sur Linux : le flux X est encapsulé dans le flux SSH.
Relis la première moitié de ma réponse #5.

Oui. J'ai pas l'habitude du forwarding ssh.

#21 Re : -1 »  Casque Logitech USB sans fil » Le 19/12/2014, à 02:11

side
Réponses : 6

Bonsoir.
Tu peux tenter d'éteindre le port usb utilisé. Pour voir.

ça se fait avec une commande du genre :

sudo sh -c "echo 0 > /sys/bus/usb/devices/12-2/authorized"

Pour savoir quel devices est le bon il faut fouiller.
lsusb permet de retrouver le premier chiffre suivant devices/, c'est le numéro de bus.
Pour être sur du port usb, on vérifie idVendor et idProduct donné par lsusb.

lsusb
...
Bus 007 Device 002: ID 046d:0a29 Logitech, Inc. 

Bus 007
idVendor c'est 046d
idProduct c'est 0a29

donc le bon port usb est celui qui renvoi

cat /sys/bus/usb/devices/7-X/idVendor
046d

et

cat /sys/bus/usb/devices/7-X/idProduct
0a29

Ensuite

sudo sh -c "echo 0 > /sys/bus/usb/devices/7-X/authorized"

ça éteint le port usb.

enchaîner avec

sudo halt

croiser les doigts.


En cas de soucis :

sudo sh -c "echo 1 > /sys/bus/usb/devices/7-X/authorized"

rallume le port usb.

Sinon débrancher/rebrancher ou reboot.

#22 Re : -1 »  SAMBA repertoire Home » Le 10/12/2014, à 18:27

side
Réponses : 4

Bonjour.

anduriltdm a écrit :

Ici, l'user1 et l'user2 ont accès à leur répertoire avec les droits de lecture-écriture-modification-suppression, je voudrais qu'ils aient seulement le droit de lecture,écriture,modification.

Alors ça risque d'être très compliqué, voir impossible sous GNU/Linux.

Pour faire ce genre de chose il faut gérer les droits avec acl + sticky bit, mais je ne suis pas sûr que tu puisses parvenir à ce que tu souhaites.


anduriltdm a écrit :

L'utilisateur admin a quant à lui accès aux répertoires de l'user1 et l'user2 mais sans droits. Je voudrais qu'il ai tous les droits sur les partages de l'user1 et l'user2, c'est à dire lecture-écriture-modification-suppression.

Il faut que admin soit le propriétaire des dossiers.

sudo chown admin /user1 /user2

#23 Re : -1 »  [Seafile] - Débutant total. » Le 09/12/2014, à 14:05

side
Réponses : 6

Bonjour.
Monter un serveur de cloud n'est pas du tout un "petit problème".

Normalement pour Seafile tu n'a pas besoin d'apache, ni de nginx ou autres serveurs web puisqu'il y a une serveur web en python qui tourne direct à l’installation.

si ton installation s'est passé correctement tu devrais pouvoir y accéder : http://ton_ip:8000.

Seulement il faut que seahub ai été bien installé, pour accéder de l’extérieur il faut que ton routeur (ta *box) redirige le port 8000 vers ta machine serveur. Sion en local pour vérifier que tout est ok : http://ip_locale:8000

Sinon https, c'est mieux, pas besoin de payer un certificat, il est généré dans ton serveur mais non reconnu par les navigateurs. Sinon oui, il y a des précautions à prendre quand on met en accès un serveur.

#24 Re : -1 »  [Seafile] - Débutant total. » Le 10/12/2014, à 18:35

side
Réponses : 6
Stuffboxinou a écrit :

Le problème de l'HTTPS, c'est qu'à chaque fois que quelqu'un se connectera à mon serveur Seafile, il aura une page de "This site is not sure", quelque chose du genre, non ?

Sauf s'il demande à son navigateur de se souvenir du certificat.

Stuffboxinou a écrit :

Qu'est-ce que je peux faire pour sécuriser tout ça ? smile

> Utiliser iptables afin de n'ouvrir que les ports intéressés ?

Utilise plutôt ta box pour ce genre de chose.

Stuffboxinou a écrit :

> Changer les ports ?

Si c'est possible, oui.
Par exemple si tu utilises ssh sur le port 22, il est préférable de changer celui-ci.

Stuffboxinou a écrit :

> Sécuriser SSH (juste en local, changement de ports)

Si tu utilise ssh juste en local alors ça ne pose pas de problème.


Stuffboxinou a écrit :

Par exemple, dans mes logs, j'ai ça (depuis ce matin, une trentaine de fois, alors que je n'ai rien fait sur le serveur en  SSH) : /var/log/auth.log

Dec  9 17:17:01 seafile CRON[3723]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec  9 17:17:01 seafile CRON[3723]: pam_unix(cron:session): session closed for user root

Ca c'est normal.

Stuffboxinou a écrit :
Dec  9 17:09:01 seafile /USR/SBIN/CRON[3712]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -x /usr/lib/php5/sessionclean ] && [ -d /var/lib/php5 ] && /usr/lib/php5/sessionclean /var/lib/php5 $(/usr/lib/php5/maxlifetime))

Merci pour tes conseils ! Ça m'aide bien ! smile

Ca, ça à l'air normal aussi.