Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 -1 »  Impossible d'installer php5-ffmpeg » Le 07/06/2016, à 07:20

alfirdaous
Réponses : 2

Bonjour,

Je trouve une difficulté d'installer php5-ffmpeg, j'obtiens cette erreur:

php5-ffmpeg : Depends: phpapi-20090626
E: Unable to correct problems, you have held broken packages.

# apt-get install php5-ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-ffmpeg : Depends: phpapi-20090626
E: Unable to correct problems, you have held broken packages.

J'ai aussi essayé de télécharger le package en zip, avec la commande phpize, je reçois:

# phpize
Configuring for:
PHP Api Version:         20121113
Zend Module Api No:      20121212
Zend Extension Api No:   220121212
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Merci d'avance

#1 Re : -1 »  Impossible d'installer php5-ffmpeg » Le 14/06/2016, à 06:57

alfirdaous
Réponses : 2

voici le résultat:

Reading package lists... Done                                                                                                     
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
E: Sub-process /usr/bin/dpkg returned an error code (1)

#2 -1 »  Détection du problème sur mon serveur » Le 09/06/2016, à 07:23

alfirdaous
Réponses : 8

Bonjour,

J'ai reçu un message d'OVH qu'ils ont détectés un problème sur mon serveur:

Vous pouvez également vous connecter en SSH à votre serveur (IP)
avec les paramètres suivants:
  - user : root
  - mot de passe : MDP

Vous pouvez dès à présent effectuer les opérations de maintenance
nécessaires au rétablissement de votre serveur, à titre d'exemple,
vous pouvez:
  - vérifier et mettre à jour vos fichiers de configuration réseau,
  - vérifier et éventuellement désactiver votre firewall,
  - vérifier et mettre à jour votre LILO (ou bien configurer un autre
    boot via le réseau : http://guides.ovh.com/KernelNetboot/
  - procéder à la vérification manuelle de votre système de fichiers,
  - effectuer une sauvegarde ou une restauration de données,
  - etc.


Si vous pensez avoir identifié l'origine du problème et souhaitez
redémarrer votre serveur normalement, vous devez configurer le
'netboot' de votre serveur sur le disque dur ou sur un noyau OVH:
http://guides.ovh.com/KernelNetboot/ puis rebooter votre serveur
en SOFT (évitez de rebooter via le manager).

Comment puis-je savoir la nature du problème, et je ne peux pas accéder au serveur via SSH en utilisant root et le MDP donnés.

Merci à vous

#3 Re : -1 »  Détection du problème sur mon serveur » Le 10/06/2016, à 01:49

alfirdaous
Réponses : 8

Est ce que dans ce cas mes données se sont perdues?

Voici un e-mail qui précède celui que j'ai posté:

Our monitoring system, has just detected a defect on your server KIMSUFI. This defect was noted at 2016-06-06 04:06:07

Our technicians, who work 24 hours a day, have also received  this alert. However, they may be conducting another intervention and we are unable to give you a precise time.

You will be informed at the beginning of the intervention by email.

While waiting for the intervention of our teams, you always have the possibility
of hardware reboot in the manager.

Logs:
----------------------
PING KIMSUFI (IP) from 213.186.33.13 : 56(84) bytes of data.
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable

--- IP ping statistics ---
10 packets transmitted, 0 packets received, +6 errors, 100% packet loss

#4 Re : -1 »  Détection du problème sur mon serveur » Le 13/06/2016, à 01:54

alfirdaous
Réponses : 8

Oui, j'attends toujours, je veux pas le redémarrer, j'ai déjà posé la question sur kimsufi, mais je la trouve pas, peu etre supprimée, c'est pour cela je suis venu ici, peut être quelqu'un a déjà rencontré ce genre de problème

#5 -1 »  Problème du iptables-persistent lors de ma mise à jour » Le 06/04/2016, à 03:53

alfirdaous
Réponses : 2

Bonjour,

J'essais de mettre mon seveur à jour, et j'obtiens le message suivant:

FATAL: Could not load /lib/modules/3.8.13-xxxx-std-ipv6-64/modules.dep: No such file or directory
dpkg: error processing iptables-persistent (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 iptables-persistent

Je précise que j'ai même supprimé le package et je l'ai réinstallé, et je rencontre la même erreur.

Merci a vous

#6 Re : -1 »  Problème du iptables-persistent lors de ma mise à jour » Le 12/04/2016, à 02:16

alfirdaous
Réponses : 2
bruno a écrit :

Bonjour,

FATAL: Could not load /lib/modules/3.8.13-xxxx-std-ipv6-64/modules.dep: No such file or directory

Ce n'est pas un noyau officiel Ubuntu mais celui d'un fournisseur de serveur dédié (noyaux généralement compilés sans la prise en charge des modules). Il faut voir avec leur assistance technique.

Merci bruno, je dois voir avec le fournisseur du serveur?

#7 -1 »  [RESOLU]Installation du php5-ffmpeg » Le 18/01/2016, à 10:23

alfirdaous
Réponses : 7

Bonjour,

J'essais d'installer le package php5-ffmpeg, mais je recois cette erreur:

# sudo apt-get install php5-ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 php5-ffmpeg : Depends: phpapi-20090626
E: Unable to correct problems, you have held broken packages.

Quelques informations utiles:

# whereis ffmpeg
ffmpeg: /bin/ffmpeg /usr/bin/ffmpeg /usr/bin/X11/ffmpeg /usr/share/man/man1/ffmpeg.1.gz
# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.5 LTS
Release:        12.04
Codename:       precise
# apache2 -v
Server version: Apache/2.4.16 (Ubuntu)
Server built:   

Merci pour votre aide

#8 Re : -1 »  [RESOLU]Installation du php5-ffmpeg » Le 18/01/2016, à 13:43

alfirdaous
Réponses : 7

voici le contenu de sources.list

# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://de.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://de.archive.ubuntu.com/ubuntu/ precise universe
deb http://de.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://de.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://de.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

# Webmin:
deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib

Merci

#9 Re : -1 »  [RESOLU]Installation du php5-ffmpeg » Le 19/01/2016, à 05:05

alfirdaous
Réponses : 7

J'ai presque tous les paquets installés, voici le resultat de la commande:

# apt-get install libapache2-mod-php5 libapache2-mod-php5filter php5-cgi php5-cli php5-fpm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-cgi is already the newest version.
php5-cli is already the newest version.
libapache2-mod-php5 is already the newest version.
php5-fpm is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libapache2-mod-php5 : Conflicts: libapache2-mod-php5filter but 5.5.31+dfsg-2+deb.sury.org~precise+1 is to be installed
 libapache2-mod-php5filter : Conflicts: libapache2-mod-php5 but 5.5.31+dfsg-2+deb.sury.org~precise+1 is to be installed
E: Unable to correct problems, you have held broken packages.

#10 Re : -1 »  [RESOLU]Installation du php5-ffmpeg » Le 20/01/2016, à 03:40

alfirdaous
Réponses : 7

Je pense que la meilleur solution c'est:

- Au niveau terminal (CLI) utiliser le package FFMPEG et AVCONV.
- Au niveau PHP, on peut obtenir plus d'informations avec gedit3 que php5-ffmpeg

#11 -1 »  Détecteur de scaner » Le 09/12/2015, à 02:14

alfirdaous
Réponses : 0

Bonjour,

Je consulte les access des visiteur, et je trouve des données de user_agent comme suite:

masscan/1.0 (https://github.com/robertdavidgraham/masscan)

Je pense que c'est un scaner, mais je sais pas si c'est bon ou non.

Merci pour votre conseil

#12 -1 »  Serveur trop long » Le 03/12/2015, à 06:08

alfirdaous
Réponses : 7

Bonjour,

Parfois je me connecte a site et ca se recharge pendent des secondes, voire plus d'une minute, et cela pendant plusieurs fois par jour, la connexion est bien sur d'autres sites, ainsi que j'arrive a me connecter au serveur SSH facilement, sur les logs je trouve ca:

error.log:

105.151.122.22 - - [25/Nov/2015:07:08:21 +0300] "-" 408 0 "-" "-"
105.151.122.22 - - [25/Nov/2015:07:08:21 +0300] "-" 408 0 "-" "-"
105.151.122.22 - - [25/Nov/2015:07:08:22 +0300] "-" 408 0 "-" "-"
105.151.122.22 - - [25/Nov/2015:07:08:22 +0300] "-" 408 0 "-" "-"
105.151.122.22 - - [25/Nov/2015:07:08:22 +0300] "-" 408 0 "-" "-"
::1 - - [25/Nov/2015:07:08:25 +0300] "OPTIONS * HTTP/1.0" 200 110 "-" "Apache/2.4.12 (Ubuntu) (internal dummy connection)"

access.log:

[Wed Nov 25 07:09:13.008575 2015] [:error] [pid 14972] [client 105.151.122.22:55678] PHP Stack trace:
[Wed Nov 25 07:09:13.008608 2015] [:error] [pid 14972] [client 105.151.122.22:55678] PHP   1. {main}() /home/alfirdaouscom/www/index.php:0
[Wed Nov 25 07:09:13.008645 2015] [:error] [pid 14972] [client 105.151.122.22:55678] PHP   2. require_once() /home/alfirdaouscom/www/index.php:6170

et voici la version:

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.5 LTS
Release:        12.04
Codename:       precise

Merci a vous, si vous avez une idée sur ca.

#13 Re : -1 »  Serveur trop long » Le 04/12/2015, à 06:36

alfirdaous
Réponses : 7
tiramiseb a écrit :

Salut,

On dirait que c'est un problème dans ton code PHP. Mais je ne saurais pas en dire plus...

Merci tiramiseb, je frequente cette erreyr meme au niveau du PHPMyAdmin

#14 Re : -1 »  Serveur trop long » Le 05/12/2015, à 04:56

alfirdaous
Réponses : 7

Merci bruno, j'ai cherché la ligne 6170 sur index.php, j'ai trouvé que c'est une classe, alors j'ai supprimé et j'ai utilisé une fonction simple, dans l'attente de voir si ca va se reproduire une autre fois

#15 Re : -1 »  Serveur trop long » Le 07/12/2015, à 05:01

alfirdaous
Réponses : 7

J'ai constaté ça sur phpmyadmin, sans utiliser le site web, je pense une chose qui cloche au niveau de apache2, ou quelque part au serveur

#16 -1 »  [RESOLU]Mon site ne s'affiche pas » Le 09/09/2015, à 12:09

alfirdaous
Réponses : 5

Bonjour,

J'ai un site sur 2 serveurs, ces derniers jours, tout va bien, sauf aujourd'hui, le site ne s'affiche pas sur le premier serveur. Les logs ne montrent rien d'anormale:

error.log:

[Wed Sep 09 13:02:12.136725 2015] [:error] [pid 5444] [client 157.55.39.196:46733] PHP Notice:  Undefined variable: cat_ar in /home/alfirdaouscom/www/Included_Files/Mapping.php on line 131
[Wed Sep 09 13:02:12.136816 2015] [:error] [pid 5444] [client 157.55.39.196:46733] PHP Stack trace:
[Wed Sep 09 13:02:12.136849 2015] [:error] [pid 5444] [client 157.55.39.196:46733] PHP   1. {main}() /home/alfirdaouscom/www/index.php:0
[Wed Sep 09 13:02:12.136875 2015] [:error] [pid 5444] [client 157.55.39.196:46733] PHP   2. require_once() /home/alfirdaouscom/www/index.php:6170
[Wed Sep 09 13:02:12.136900 2015] [:error] [pid 5444] [client 157.55.39.196:46733] PHP   3. require_once() /home/alfirdaouscom/www/site.php:127

access.log

::1 - - [09/Sep/2015:13:16:48 +0300] "OPTIONS * HTTP/1.0" 200 110 "-" "Apache/2.4.12 (Ubuntu) (internal dummy connection)"
41.252.219.187 - - [09/Sep/2015:13:16:49 +0300] "POST /Admins/minutesrefresh.php HTTP/1.1" 200 377 "http://www.alfirdaous.com/Sawtiyat/Quoran/TilawatSheikhs.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36"

Merci d'avance

#17 Re : -1 »  [RESOLU]Mon site ne s'affiche pas » Le 09/09/2015, à 22:06

alfirdaous
Réponses : 5
Vysserk3 a écrit :

Salut,

Undefined variable: cat_ar

c'est pas ça peut-être ? C'est une erreur qui peut bloquer la suite de l'interprétation non ?

Non c'est pas ca, je pense que quelque chose d'autre

#18 Re : -1 »  [RESOLU]Mon site ne s'affiche pas » Le 13/09/2015, à 00:20

alfirdaous
Réponses : 5
Vysserk3 a écrit :

Quand tu dis qu'il ne s'affiche pas....qu'as tu exactement dans le navigateur ? Une page vide ?
Inspecte la requête HTTP dans un outils de debug pour voir le code de retour HTTP.

C'est la meme page comme si le site web ne se trouve pas

T'as essayé de redémarrer ou reloader le serveur apache ?

C'est ce que j'ai fait, mais j'ai redemarré tout le serveur, maintenant ca marche

Merci a vous

#19 -1 »  Trouver le dossier Original » Le 02/07/2015, à 19:16

alfirdaous
Réponses : 6

Bonjour,

Je cherche une commande pour chercher le dossier "Original" dans l'emplacement suivant qui a plus de 50 MO et afficher la taille:

find -iname *Original* -type d -size +50M -exec du -h {} \; | sort -n

Cette commande ne me retourne rien.

Merci

#20 Re : -1 »  Trouver le dossier Original » Le 02/07/2015, à 19:49

alfirdaous
Réponses : 6

Non, il exists des dossier de 800 MO et plus

#21 Re : -1 »  Trouver le dossier Original » Le 03/07/2015, à 13:05

alfirdaous
Réponses : 6

Oui j'ai bien compris, merci Tewis, j'ai aussi trouvé cette commande:

find . -name "*Original*" -type d -exec du -m {} \; | awk '{ if ( $1 > 50 ) {print $0} }' | sort -n

#22 Re : -1 »  [RESOLU] Mise a jour apache et PHP5 » Le 26/06/2015, à 15:41

alfirdaous
Réponses : 7

voici la commande que j'ai saisis:

sudo apt-get install php-pear php5-cli php5-common php5-curl php5-dev php5-gd php5-mcrypt php5-mysql php5-pgsql php5-xdebug

apres j'ai pas resolu avec:

mv /etc/apache2/sites-available/site.com /etc/apache2/sites-available/site.com.conf

mais maintenant je recois cette erreur:

Forbidden

You don't have permission to access / on this server.

#23 Re : -1 »  [RESOLU] Mise a jour apache et PHP5 » Le 26/06/2015, à 16:21

alfirdaous
Réponses : 7
<VirtualHost *:80>
    # Adresse email à contacter en cas de problemes
    ServerAdmin monsite@gmail.com
    # Nom de domaine avec les www
    ServerName www.alfirdoaus.com
    # Les différents alias du site, généralement le NDD sans les www
    ServerAlias alfirdaous.com
    # La où sont stocké les données du site
    DocumentRoot /home/monsite/www
#    SuexecUserGroup monsite monsite
    <Directory />
        # Des options : ici suivre les liens symboliques
        Options FollowSymLinks
        # Autoriser l'override, autrement dit les .htaccess
        AllowOverride All
    </Directory>
    <Directory /home/monsite/www>
        # Encore des options : multiviews peut être pratique
        # Si on essaye d'accéder à site.com/index
        # Et que index n'existe pas, le serveur va rechercher index.*
        # Autrement dit : index.php, index.html etc...
        Options FollowSymLinks MultiViews
        # Autorise les htaccess
        AllowOverride All
        Order allow,deny
        allow from all
   # New directive needed in Apache 2.4.3: 
        Require all granted
    </Directory>
    # Log pour les erreurs
#    ErrorLog ${APACHE_LOG_DIR}/error.log
    ErrorLog ${APACHE_LOG_DIR}/monsite/error.log

    LogLevel warn
    # Log des connexion au site
#    CustomLog ${APACHE_LOG_DIR}/access.log combined
    CustomLog ${APACHE_LOG_DIR}/monsite/access.log combined
</VirtualHost>

voici le fichier .conf, maintenant le site marche sauf que phpmyadmin montre 404:

le nom du fichier est: phpmyadmin et non phpmyadmin.conf:

<VirtualHost *:80>
    # Adresse email à contacter en cas de problemes
    ServerAdmin alfirdoauscom@gmail.com
    # Nom de domaine avec les www
    ServerName www.alfirdoaus.com/phpmyadmin
    # Les différents alias du site, généralement le NDD sans les www
    ServerAlias alfirdaous.com/phpmyadmin
    # La où sont stocké les données du site
    DocumentRoot /home/phpmyadmin/www
    SuexecUserGroup phpmyadmin phpmyadmin
    <Directory />
        # Des options : ici suivre les liens symboliques
        Options FollowSymLinks
        # Autoriser l'override, autrement dit les .htaccess
        AllowOverride All
    </Directory>
    <Directory /home/phpmyadmin/www>
        # Encore des options : multiviews peut être pratique
        # Si on essaye d'accéder à site.com/index
        # Et que index n'existe pas, le serveur va rechercher index.*
        # Autrement dit : index.php, index.html etc...
        Options FollowSymLinks MultiViews
        # Autorise les htaccess
        AllowOverride All
        Order allow,deny
        allow from all
   # New directive needed in Apache 2.4.3:
   Require all granted
    </Directory>
    # Log pour les erreurs
    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn
    # Log des connexion au site
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

les logs:

error.log:

[Fri Jun 26 17:16:51.105105 2015] [mpm_prefork:notice] [pid 1965] AH00169: caught SIGTERM, shutting down
[Fri Jun 26 17:16:52.476716 2015] [mpm_prefork:notice] [pid 2161] AH00163: Apache/2.4.12 (Ubuntu) configured -- resuming normal operations
[Fri Jun 26 17:16:52.476902 2015] [core:notice] [pid 2161] AH00094: Command line: '/usr/sbin/apache2'

EDIT: voici une autre partie de error.log:

[Fri Jun 26 17:27:54.763155 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP Warning:  get_browser(): browscap ini directive not set in /home/alfirdaouscom/www/Idara/Statistics/full_stat.php on line 268, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html
[Fri Jun 26 17:27:54.764696 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP Stack trace:, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html
[Fri Jun 26 17:27:54.764793 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP   1. {main}() /home/alfirdaouscom/www/index.php:0, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html
[Fri Jun 26 17:27:54.764857 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP   2. require_once() /home/alfirdaouscom/www/index.php:6168, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html
[Fri Jun 26 17:27:54.764916 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP   3. require_once() /home/alfirdaouscom/www/site.php:54, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html
[Fri Jun 26 17:27:54.764974 2015] [:error] [pid 2165] [client 41.250.188.223:49415] PHP   4. get_browser() /home/alfirdaouscom/www/Idara/Statistics/full_stat.php:268, referer: http://www.monsite.com/HolyQuran/TahfeedAlQuran.html

#24 Re : -1 »  [RESOLU] Mise a jour apache et PHP5 » Le 26/06/2015, à 16:35

alfirdaous
Réponses : 7

Explication des erreurs et solutions apres upgrade d'apache2 vers 2.4:

Not Found

The requested URL / was not found on this server.

Le site "monsite.com" sur la directive doit etre renome vers "monsite.com.conf" mais phpmyadmin on ne le nomme pas:

# cd /etc/apache2/sites-available/
# /etc/apache2/sites-available# ls
monsite.com.conf default-ssl.conf  phpmyadmin

et on l'active:

a2ensite monsite.com.conf 

L'erreur 403:

Forbidden

You don't have permission to access / on this server.

Dans le fichier de configuration de "monsite.com.conf", on doit ajouter cette ligne:

Require all granted

ce qui va mener notre code a:

<Directory /home/monsite.com/www>
        Options FollowSymLinks MultiViews
        # Autorise les htaccess 
        AllowOverride All
        Order allow,deny
        allow from all
   # New directive needed in Apache 2.4.3:  
        Require all granted
    </Directory>

Pour l'erreur 404 de phpmyadmin:
Le dossier de configuration d'apache2 a changé de conf.d vers conf-available, on copie le fichier phpmyadmin vers le nouveau dossier:

sudo cp /etc/apache2/conf.d/phpmyadmin.conf /etc/apache2/conf-available/

et on redemarre apache2:

service apache2 restart