Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Carte USB 3 Transcend non reconnue » Le 17/11/2013, à 00:18

wysiwyg31
Réponses : 1

Hello, c'est bien tard mais si ca peut aider d'autre personnes...
J'ai eu le meme soucis jusqu'à ce que je coupe le pc!!
pas juste le bouton en facade mais une vrai coupure de la prise.
Le pci comporte des alims permanentes, J'aurai du débrancher avant de mettre la carte mais j'ai oublié.
Elle a du mal s'initialiser.
Je ne sais pas si c'est le meme soucis que tu as eu, mais meme symptômes, rien sous lspci.
Pas testé sous windows, j'ai pas.

#1 Re : -1 »  Bricoler un serveur à partir d'un client leger ?? » Le 09/12/2012, à 21:06

wysiwyg31
Réponses : 19

Hello !!

je déterre le sujet, mais oui, c'est exactement ca !!

je voudrais prendre un thin client et en faire un petit serveur

#2 Re : -1 »  Bricoler un serveur à partir d'un client leger ?? » Le 10/12/2012, à 17:23

wysiwyg31
Réponses : 19

Je vais peut etre tenter le coup, il y a pas mal de futro s400 (fujitsu siemens) qui trainent sur ebay pour pas trop cher.

J'ai trouvé un tuto (mais pas hyper complet) sur le sujet.

#3 Re : -1 »  Bricoler un serveur à partir d'un client leger ?? » Le 17/12/2012, à 12:53

wysiwyg31
Réponses : 19

Je sais, j'en ai un en commande! :-)
Je vais l'utiliser ma petite station météo, il sera tout seul dans son coin, et ca m'évitera de mettre en l'air ma station quand je me rate sur mon serveur "pour jouer".

Pour ce serveur, je cherchais un truc un brin plus standard (comprendre x86 32 ou mieux 64bits) pour y installer une ubuntu serveur complete.

Sur le raspberri pi, j'aurai une raspbian (debian speciale pour raspberri pi), c'est très bien pour ce que je veux faire, mais pour bidouiller, j'aime autant rester dans le "mainstream" plutot que jouer avec des distributions et des architectures un peu plus confidentielles.

#4 Re : -1 »  Bricoler un serveur à partir d'un client leger ?? » Le 27/03/2013, à 20:19

wysiwyg31
Réponses : 19

update: j'ai pu installer ubuntu serveur sur une fujitsu siemens futro s450 sans probleme !

#5 Re : -1 »  Bricoler un serveur à partir d'un client leger ?? » Le 28/03/2013, à 00:04

wysiwyg31
Réponses : 19

Oh my god! Oui big_smile

Disons que c'est une idée qui a fait son chemin.
J'avais fait autrement entre temps.

#6 -1 »  Reconnexion automatique avec WPA supplicant » Le 12/03/2013, à 14:02

wysiwyg31
Réponses : 9

Hello !

J'ai un raspberry pi sous raspbian connecté en réseau par wifi (je pense que la config est similaire sur ce point à un ubuntu serveur).

J'ai suivi les explications ici http://doc.ubuntu-fr.org/wpa  pour connecter la bouzin à la freebox en wpa.

Quand je reboote le raspberry, aucun soucis, il se reconnecte tout seul au wifi.

Par contre, si je reboote la box (freebox v5 non degroupé, ca met assez longtemps,plusieurs minutes), le raspberry ne recupere pas tout seul le wifi.

Comme c'est une machine headless (pas d'ecran, pas de clavier), il ne reste plus qu'à faire un hard reset pour la reconnecter au reseau...

Y a til un autre moyen ??

#7 Re : -1 »  Reconnexion automatique avec WPA supplicant » Le 12/03/2013, à 15:48

wysiwyg31
Réponses : 9

Bonjour, Oui, désolé ! j'attendais qu'on me reboote la machine pour pouvoir y aller en ssh et recuperer le contenu des fichiers de config, les voici:

/etc/network/interface:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface default inet dhcp

auto wlan0
iface wlan0 inet dhcp
   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

J'ai ajouté les 3 dernières lignes. J'avoue que ce fichier ne m'est pas très parlant.
/etc/wpa_supplicant/wpa_supplicant.conf :

ctrl_interface=/var/run/wpa_supplicant
ap_scan=1

network={
    ssid="monhotspot"
    scan_ssid=1 # nécessaire quand le ssid n'est pas diffusé
    proto=WPA RSN
    key_mgmt=WPA-PSK
    psk="monpassword"
}

(avec"monhostpot" et "monpassword" paramétré correctement, la connexion fonctionne d'ailleurs, sans quoi, je n'aurais pas pu vous copier coller le contenu de ces fichiers.)


J'ai jeté un oeil au syslog, une douzaine de ligne en quelques secondes, mais rien apres:

Mar 12 08:55:05 raspberrypi ifplugd(wlan0)[1599]: Link beat lost.
Mar 12 08:55:07 raspberrypi wpa_supplicant[1605]: wlan0: CTRL-EVENT-DISCONNECTED bssid=36:e0:1d:51:62:00 reason=0
Mar 12 08:55:15 raspberrypi ifplugd(wlan0)[1599]: Executing '/etc/ifplugd/ifplugd.action wlan0 down'.
Mar 12 08:55:16 raspberrypi dhclient: Internet Systems Consortium DHCP Client 4.2.2
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: Internet Systems Consortium DHCP Client 4.2.2
Mar 12 08:55:16 raspberrypi dhclient: Copyright 2004-2011 Internet Systems Consortium.
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: Copyright 2004-2011 Internet Systems Consortium.
Mar 12 08:55:16 raspberrypi dhclient: All rights reserved.
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: All rights reserved.
Mar 12 08:55:16 raspberrypi dhclient: For info, please visit https://www.isc.org/software/dhcp/
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: For info, please visit https://www.isc.org/software/dhcp/
Mar 12 08:55:16 raspberrypi dhclient:
Mar 12 08:55:16 raspberrypi dhclient: Listening on LPF/wlan0/a0:f3:d6:62:09:c1
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: Listening on LPF/wlan0/a0:f3:d6:62:09:c1
Mar 12 08:55:16 raspberrypi dhclient: Sending on   LPF/wlan0/a0:f3:d6:62:09:c1
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: Sending on   LPF/wlan0/a0:f3:d6:62:09:c1
Mar 12 08:55:16 raspberrypi dhclient: Sending on   Socket/fallback
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: Sending on   Socket/fallback
Mar 12 08:55:16 raspberrypi dhclient: DHCPRELEASE on wlan0 to 192.168.0.254 port 67
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: client: DHCPRELEASE on wlan0 to 192.168.0.254 port 67
Mar 12 08:55:16 raspberrypi wpa_supplicant[1605]: wlan0: CTRL-EVENT-TERMINATING - signal 15 received
Mar 12 08:55:16 raspberrypi ifplugd(wlan0)[1599]: Program executed successfully.

#8 Re : -1 »  Reconnexion automatique avec WPA supplicant » Le 12/03/2013, à 15:51

wysiwyg31
Réponses : 9

J'oubliais: j'ai suivi la méthode §3.4 2# Méthode Complète et Propre :
http://doc.ubuntu-fr.org/wpa#methode_complete_et_propre

#9 Re : -1 »  Reconnexion automatique avec WPA supplicant » Le 27/03/2013, à 20:20

wysiwyg31
Réponses : 9

Pas de solution ?

Je me disais: peut etre qu'une ou deux instruction bien placées dans un fichier cron pour forcer une reconnexion de temps en temps si on la perd ??

#10 Re : -1 »  Reconnexion automatique avec WPA supplicant » Le 27/03/2013, à 20:36

wysiwyg31
Réponses : 9

ca n'a pas l'air très different de ma config, le truc c'est que si je reboote la machine ca marche bien, mais si je reboote la box, la machine ne se reconnecte pas toute seule.

J'ai trouvé une piste ici (je ne suis pas le seul apparement) :

Ils proposent un script comme ceci:

#!/bin/bash

while true ; do
   if ifconfig wlan0 | grep -q "inet addr:" ; then
      sleep 60
   else
      echo "Network connection down! Attempting reconnection."
      ifup --force wlan0
      sleep 10
   fi
done

Il faut l'adapter un peu pour le mettre dans un cron toutes les 5 minutes par ex, je pensais à ca (j'enleve le while et les sleeps):

#!/bin/bash

   if ifconfig wlan0 | grep -q "inet addr:" ; then
      echo"Network ok";
   else
      echo "Network connection down! Attempting reconnection."
      ifup --force wlan0

   fi
done

#11 Re : -1 »  Ultrabook pr ubuntu ? » Le 26/02/2013, à 17:31

wysiwyg31
Réponses : 5

Tiens, c'est étrange, mais il y a pas mal de news pour dire que justement le XPS13 ubuntu sort bientot en europe ?!   (ex : http://www.journaldunet.com/developpeur … 0213.shtml

Ca fourmille d'articles du même genre ces derniers jours (après des mois sans infos!)

Il serait passé en HD pour l'occasion.

Tu as une info contraire ?? hmm

Pour l'instant je n'ai pas pu trouver d'info de prix (juste un site qui disait que la version avec le même hardware mais en windows etait à 1300€).




La page ubuntu.com :  http://www.ubuntu.com/partners/dell/dellxps
"Also available across Europe"  (une question de jours? d'heures?....qui vivra verra)

#12 Re : -1 »  Ultrabook pr ubuntu ? » Le 26/02/2013, à 17:55

wysiwyg31
Réponses : 5

J'avais regardé le hp probook 4340s à une époque (avant noel :-))
Pas exactement un "ultrabook" (au sens asus zenbook et autre ultrafins..), mais une machine pas trop chère, gamme pro (plus solide?).
Je crois qu'il se vend avec Suse linux dans certains pays et je n'avais pas trouvé de soucis particuliers avec linux dans mes recherches (mais je n'ai rien testé par moi même!)

#13 Re : -1 »  [NAS] ptite question » Le 17/12/2012, à 15:09

wysiwyg31
Réponses : 14

Hello !

Je m'interesse aussi au sujet !! En effet, ces ?#!*é fabricants parlent de fiabilité avec le raid, mais si le NAS est mort....

J'ai trouvé une page interessante ici: (qui ne répond pas à tout, mais apporte quelques éléments):

http://www.raid-recovery-guide.com/nas-recovery.aspx

#14 -1 »  NAS, raid1 et ubuntu » Le 17/12/2012, à 09:03

wysiwyg31
Réponses : 3

Bonjour,

J'ai un NAS de chez netgear (readynas duo).
Celui ci propose 2 configs de RAID:
- RAID 1 standard
- X-RAID (techno netgear)

(je ne parle pas du RAID0 car je cherche un backup fiable).

Dans les deux cas (Raid1 et Xraid), si un disque meurt, je peux le changer et il se re synchronise...par contre si c'est le NAS qui meurt ...?

Pour le Xraid, ca me parait tendu, sauf à racheter un nas de chez netgear

Pour le Raid1 standard, si je branche un disque sur un PC, pourrais-je acceder sans soucis à mes fichiers? Ou bien faut-il le brancher à une carte mère avec du RAID ?

#15 Re : -1 »  NAS, raid1 et ubuntu » Le 17/12/2012, à 12:47

wysiwyg31
Réponses : 3

En effet, oups pour le doublon...

#16 -1 »  Installer grub2 sur une carte compact flash pour un autre PC ? » Le 10/12/2012, à 16:19

wysiwyg31
Réponses : 2

Bonjour,

J'ai un petit projet d'installer un ubuntu server sur un client leger (afin d'en faire un mini serveur perso)

Ce client léger utilise une compact flash comme disque dur.

J'ai dans l'idée de suivre le tutoriel Netboot install from internet

Mais le pré-requis est d'avoir grub installé.

D'où ma question: comment installer grub sur une compact flash ?

Dans l'idéal j'aimerais bien faire ca sur ma station de travail, mais je ne voudrais pas casser la config de la machine en lancant des commandes grubs sans être sur de ce qu'elles font ...

Je résume ce que je veux faire: je veux préparer une carte compact flash sur mon desktop pour l'inserer ensuite dans mon "mini-server" et lancer une install "netboot".


Une idée ?

#17 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 01/12/2012, à 10:05

wysiwyg31
Réponses : 19

Hello,
Merci de la réponse !
J'avais pensé à la même chose entre temps (l'appel à un ami pour tester la connexion). J'attend sa confirmation.

Pour freewifi, en effet, je pense que qu'il y a certains bridage, mais sur la 3G il ne devrait pas y en avoir...bizarre.

Je vais regarder pour l'écoute locale du serveur ssh

#18 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 01/12/2012, à 12:20

wysiwyg31
Réponses : 19

rogntudjû !

J'ai trouvé!! big_smile

Ca avait marché un peu l'autre jour, mais ca avait stoppé ensuite, et j'ai trouvé pourquoi (même si je ne me l'explique pas).

J'avais ouvert le port 22 de mon serveur il y a longtemps  avec quelque chose du genre :

sudo ufw allow 22/tcp

Il y a quelques jours, sur une page concernant ufw, je tombe sur ca:

sudo ufw allow ssh

Je nagais à ce moment là dans des problemes d'authentification par clé (au lieu de mot de passe) et une partition crypté (ecryptfs) et j'ai essayé pas mal de choses
bref, ce n'est pas le sujet ici.

Résultat, j'avais 2 regles dans ufw:

22/tcp                     ALLOW IN    Anywhere
22                         ALLOW IN    Anywhere

J'ai supprimé la premiere (que j'avais fait à la main) pour ne garder que celle du  "ufw allow ssh"

Et....ca marche !!!!

Pourquoi les deux règles causaient ce problème, d'autant que ca marchait en local avec les 2 ip (locale 192.168.xxx et internet 78.xxx), je ne sais pas... j'ai tendance à penser que la seconde incluait la première et que ça ne devrait pas poser de soucis, mais enlever la première  m'a permis de me connecter par 3G

Je passe le sujet en résolu (car il l'est), mais si quelqu'un a une explication, je reste curieux !

maxpoulin64: j'ai testé un traceroute sur mon ip "internet" depuis mon reseau local, pour voir: en fait, je crois que ca sort bien du routeur: ca va au DSLAM et ca revient (1 seule étape dans le traceroute, ya le nom de mon dslam dedans)

#19 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 01/12/2012, à 12:34

wysiwyg31
Réponses : 19

Par défaut connectbot utilise le port 22
Il peut en utiliser un autre si on le précise évidemment.

J'avais testé les deux : un port xx et le port 22  (xx car j'ai souvent vu qu'il etait recommandé de ne pas prendre le port par défaut par sécurité), je suis passé au 22 ensuite car quand on a des soucis, il est parfois bon de revenir aux bases et limiter le risque de mélanger plusieurs problemes).

Maintenant que ca marche, j'ai supprimé la redirection du port 22 de ma box pour ne garder que xx.

le 443 est normalement pour autre chose (https ?), ca peut etre utile de passer du SSH par là si on est sur une connexion bridée, mais c'est censé ne pas être le cas sur freemobile.

Sur quel opérateur es tu ?

#20 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 01/12/2012, à 15:46

wysiwyg31
Réponses : 19

bon...en fait le problème n'est pas si résolu que ca !!

Je reteste à l'instant... impossible de se connecter à mon serveur depuis la 3G
Je verifie le log d'ufw, (/var/log/ufw.log) sur le serveur : la connexion depuis mon téléphone est bloquée !!!! c'est bien à ce niveau que ca coince

si je fais un :

sudo ufw status verbose

J'ai bien:

22                         ALLOW IN    Anywhere

de rage, je teste :

sudo ufw delete allow ssh

la ligne "22                         ALLOW IN    Anywhere" disparait quand je fais un verbose
je refais un :

sudo ufw allow ssh

la ligne "22                         ALLOW IN    Anywhere" re-apparait quand je fais un verbose

Et miracle, ca remarche !!!! (jusqu'à quand ??)

=> je répond à ma question: ca marche jusqu'au prochain reboot du serveur
après reboot la regle est toujours là, mais ne semble pas prise en compte...  sad

#21 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 02/12/2012, à 20:04

wysiwyg31
Réponses : 19

Bonne idée!
Je viens de tester, apres avoir faire un restart d'ufw ca fonctionne.
Ca semble donc venir du démarrage d'ufw au boot.

Par contre,rien de particulier dans les logs que j'ai regardé (syslog, ufw.log)

Un solution (pas très propre) pourrait etre de faire un restart en fin de démarrage (il me semble qu'il existe un endroit pour ca)

Mais bon, ca regle le probleme sans trouver la cause

#22 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 02/12/2012, à 22:08

wysiwyg31
Réponses : 19

Je pense pas, mais je n'en mettrai pas ma main à couper...

C'est un serveur qui me sert aussi à apprendre smile

S'il y a un tel script comment le trouver ?

#23 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 05/12/2012, à 10:49

wysiwyg31
Réponses : 19

Hum
J'ai soupsonné webmin de poser quelques soucis !
Sous webmin, je retrouve bien ufw dans mon firewall, mais dans les user rules, je n'ai pas ma regle sur le port 22.
J'ai voulu l'ajouter, mais un clic malencontreux sur "reinitialise firewall" m'a tout cassé.  (je pensais que c'etait pour reinitialiser avec ce que j'avais rentré).
...ca m'a viré ufw (de webmin) pour me remettre iptable tout seul et en config par défaut.... (super!)

Bref, je retourne sur ssh:  ufw disbled!
je l'active, il me repond que c'est activé et qu'il redémarrera au prochain boot
je reboote...ufw disabled !!
je desinstall webmin, reactive ufw..pas mieux.

une âme sensible ce ufw ! il boude je crois

#24 Re : -1 »  Ubuntu server,SSH, freemobile, freebox V6 & autre connectbot! » Le 05/12/2012, à 12:19

wysiwyg31
Réponses : 19

Je l'ai supprimé (je m'en servais pas plus que ca, il semble en passe de devenir obsolete, il m'a bien gavé hier)
Il a l'air de trainer encore quelques fichier ceci dit (dans les rcX.d)

existe t il des alternatives plus légères ? (c'etait assez sympa au moins pour consulter des infos sur sa machine)