Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Soucis Vhost Apache 2 » Le 30/01/2013, à 06:27

Totof08170
Réponses : 1

Bonjour tout le monde,

Voila j'ai un petit soucis, je ne trouve pas la réponse pour le moment.
J'ai installer apache2 sur mon serveur, dans le dossier /var/www j'ai un dossier default-site et un thomassciot
Dans sites-available j'ai mon default, default-ssl et thomassciot.net

Le fichier default est :

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/default-site
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/default-site>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

et le fichier thomassciot est donc

<VirtualHost *:80>
        ServerAdmin postmaster@thomassciot.net
        ServerName www.thomassciot.net
        ServerAlias *.thomassciot.net
        DocumentRoot /var/www/thomassciot/
        <Directory /var/www/thomassciot/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        </Directory>
        ServerSignature Off
</VirtualHost>

Bien sur je n'ai pas oublier les commandes

a2ensite thomassciot.net
apache2ctl restart

Lorsque que je tape l'ip du serveur, je tombe directement dans la page it's work ( ah oui j'ai déplacer le fichier html de base de apache dans le dossier /var/www/default-site ) donc je suppose que pour le moment tout est normale.

Seul soucis, dans l'url lorsque je tape thomassciot.net la je ne tombe sur rien.

J'ai modifier le fichier host de ma machine cliente en ajoutant :
thomassciot.net ip_du_server

Et sur le serveur j'ai rajouter dans httpd.conf :
ServerName 127.0.0.1

671809capture.jpg

Et la on vois bien que mon client fait une demande pour le nom, mais pas de réponse.

Quelqu'un pourrais me donner une petite piste?

#1 Re : -1 »  Soucis Vhost Apache 2 » Le 30/01/2013, à 07:56

Totof08170
Réponses : 1

Je viens de mettre bind sur le serveur, histoire d'y arriver un peut mieux, par contre j'obtiens ceci :

root [/etc/bind] > nano db.thomassciot.net.inv
root [/etc/bind] > named-checkzone thomassciot.net /etc/bind/db.thomassciot.net
zone thomassciot.net/IN: loaded serial 2
OK
root [/etc/bind] > named-checkzone thomassciot.net /etc/bind/db.thomassciot.net.inv
/etc/bind/db.thomassciot.net.inv:4: no TTL specified; using SOA MINTTL instead
zone thomassciot.net/IN: loaded serial 1
OK
root [/etc/bind] > named-checkzone /etc/bind/named.conf
usage: named-checkzone [-djqvD] [-c class] [-f inputformat] [-F outputformat] [-t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] [-m (ignore|warn|fail)] [-r (ignore|warn|fail)] [-i (full|full-sibling|local|local-sibling|none)] [-M (ignore|warn|fail)] [-S (ignore|warn|fail)] [-W (ignore|warn)] [-o filename] zonename filename
root [/etc/bind] > named-checkzone /etc/bind/named.conf.options
usage: named-checkzone [-djqvD] [-c class] [-f inputformat] [-F outputformat] [-t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] [-m (ignore|warn|fail)] [-r (ignore|warn|fail)] [-i (full|full-sibling|local|local-sibling|none)] [-M (ignore|warn|fail)] [-S (ignore|warn|fail)] [-W (ignore|warn)] [-o filename] zonename filename

Fichier db.thomassciot.net :

; BIND data file for eth0 interface
;
$TTL    604800
@   IN  SOA dns01.thomassciot.net. root.thomassciot.net. (
                              2     ; Serial
                         604800     ; Refresh
                          86400     ; Retry
                        2419200     ; Expire
                         604800 )   ; Negative Cache TTL
;
@   IN  NS  dns01.thomassciot.net.

dns01  IN  A   192.168.1.58

Fichier db.thomas.sciot.inv :

;
; BIND reverse data file for eth0 interface
; $TTL  604800
@   IN  SOA     dns01.thomassciot.net. root.thomassciot.net. (
                              1 ; Serial
                         604800 ; Refresh
                          86400 ; Retry
                        2419200 ; Expire
                         604800 )       ; Negative Cache TTL
;
@ IN    NS      dns01.
230     IN      PTR     dns01.thomassciot.net

Fichier named.conf.default-zones :

// prime the server with knowledge of the root servers
zone "." {
        type hint;
        file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
        type master;
        file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
        type master;
        file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
        type master;
        file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
        type master;
        file "/etc/bind/db.255";
};

zone "thomassciot.net" {
       type master;
       file "/etc/bind/db.thomassciot.net";
       forwarders{};
};

zone "1.168.192.in-addr.arpa" {
     type master;
     file "/etc/bind/db.thomassciot.net.inv";
     forwarders{};
};

y aurait-il un soucis de ce coté la ?

PS : Pour le DNS apparement j'ai réussi a résoudre le soucis, en faite ma machine s'appelais debian, du coup j'ai modifier les dns01 en debian

C:\Users\Totof>nslookup debian.thomassciot.net
58.1.168.192.in-addr.arpa
        primary name server = debian.thomassciot.net
        responsible mail addr = root.thomassciot.net
        serial  = 1
        refresh = 604800 (7 days)
        retry   = 86400 (1 day)
        expire  = 2419200 (28 days)
        default TTL = 604800 (7 days)
Serveur :   UnKnown
Address:  192.168.1.58

Nom :    debian.thomassciot.net
Address:  192.168.1.58

Me reste plus cas regler le soucis pour pouvoir acceder au serveur apache avec le nom de domaine thomassciot.net

PS : ça y est ça fonctionne, dans la vhost j'ai préciser thomassciot.net:80 et ça fonctionne bien

#2 -1 »  Ubuntu 12.10 et le Raid 1 » Le 07/11/2012, à 19:56

Totof08170
Réponses : 7

Bonjour tout le monde,

Voila j'ai vraiment besoin d'aide je deviens fou, je vous explique.
J'avais fait un Raid 1 avec 2 Disques de 2To, qui fonctionnais très bien, j'étais sous Ubuntu 12.04.
Ensuite je fais une réinstalle compléte, je réinstall mdadm pour le raid, et voila que j'ai un soucis.
Je vais vraiment vous détaillez les étapes que j'ai fait pour recrée la grappe.

(J'ai deux disque de 2To pour les data, un de 160 pour ubuntu et un de 250 pour seven)

 fdisk -l
Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sda » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000c7555

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *          63  3907024064  1953512001   fd  RAID Linux autodétecté

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sdb » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000034c8

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *          63  3907024064  1953512001   fd  RAID Linux autodétecté

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sdc » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sdc: 160.0 GB, 160041885696 bytes
255 têtes, 63 secteurs/piste, 19457 cylindres, total 312581808 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1               1   312581807   156290903+  ee  GPT

Disk /dev/sdd: 250.1 GB, 250059350016 bytes
255 têtes, 63 secteurs/piste, 30401 cylindres, total 488397168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x825b1f64

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdd1   *        2048   488394751   244196352    7  HPFS/NTFS/exFAT

Création du Raid

 mdadm --create /dev/md0 --level=1 --raid-devices=2 /dev/sd[ab]1
mdadm: /dev/sda1 appears to contain an ext2fs file system
    size=1953512000K  mtime=Thu Jan  1 01:00:00 1970
mdadm: /dev/sda1 appears to be part of a raid array:
    level=raid1 devices=2 ctime=Mon Nov  5 11:59:09 2012
mdadm: Note: this array has metadata at the start and
    may not be suitable as a boot device.  If you plan to
    store '/boot' on this device please ensure that
    your boot-loader understands md/v1.x metadata, or use
    --metadata=0.90
mdadm: /dev/sdb1 appears to contain an ext2fs file system
    size=1953512000K  mtime=Thu Jan  1 01:00:00 1970
mdadm: /dev/sdb1 appears to be part of a raid array:
    level=raid1 devices=2 ctime=Mon Nov  5 11:59:09 2012
Continue creating array? y
mdadm: Defaulting to version 1.2 metadata
mdadm: array /dev/md0 started.

Détails de mdadm sur md0

 mdadm --detail /dev/md0
/dev/md0:
        Version : 1.2
  Creation Time : Wed Nov  7 11:41:33 2012
     Raid Level : raid1
     Array Size : 1953380736 (1862.89 GiB 2000.26 GB)
  Used Dev Size : 1953380736 (1862.89 GiB 2000.26 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Wed Nov  7 11:41:33 2012
          State : clean, resyncing
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

  Resync Status : 0% complete

           Name : arya:0  (local to host arya)
           UUID : bee4dfe2:9c1d1028:0286d553:326b8516
         Events : 0

    Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       1       8       17        1      active sync   /dev/sdb1

Syncro en cours !

Every 2,0s: cat /proc/mdstat                                                                                                                    Wed Nov  7 11:43:24 2012

Personalities : [raid1]
md0 : active raid1 sdb1[1] sda1[0]
      1953380736 blocks super 1.2 [2/2] [UU]
      [>....................]  resync =  0.5% (11694848/1953380736) finish=289.2min speed=111864K/sec

unused devices: <none>

Syncro fini

Every 2,0s: cat /proc/mdstat                            Wed Nov  7 18:47:58 2012

Personalities : [raid1]
md0 : active raid1 sdb1[1] sda1[0]
      1953380736 blocks super 1.2 [2/2] [UU]

unused devices: <none>

Essaie de monter la grappe

mount -t ext4 /dev/md0 /media/RAID
mount : mauvais type de système de fichiers, option erronée, superbloc
        erroné sur /dev/md0, page de code ou aide manquante, ou autre erreur
       Dans quelques cas certaines informations sont utiles dans syslog - essayez
       dmesg | tail  ou quelque chose du genre

Reboot de la machine, on retente

 mount -t ext4 /dev/md127 /media/RAID/
mount : mauvais type de système de fichiers, option erronée, superbloc
        erroné sur /dev/md127, page de code ou aide manquante, ou autre erreur
       Dans quelques cas certaines informations sont utiles dans syslog - essayez
       dmesg | tail  ou quelque chose du genre
dmesg | tail
[   13.870532] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   13.870671] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   17.426180] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[   17.426497] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   78.033910] EXT3-fs (md127): error: can't find ext3 filesystem on dev md127.
[   78.036706] EXT4-fs (md127): VFS: Can't find ext4 filesystem
[   78.036978] FAT-fs (md127): invalid media value (0x00)
[   78.036979] FAT-fs (md127): Can't find a valid FAT filesystem
[   85.950996] EXT4-fs (md127): VFS: Can't find ext4 filesystem
[   99.436525] [drm] nouveau 0000:01:00.0: PFIFO_DMA_PUSHER - Ch 2 Get 0x002003299c Put 0x0020032a38 IbGet 0x00000fce IbPut 0x00000fcf State 0x80000020 (err: INVALID_CMD) Push 0x00400040

details md127

 mdadm --detail /dev/md127
/dev/md127:
        Version : 1.2
  Creation Time : Wed Nov  7 11:41:33 2012
     Raid Level : raid1
     Array Size : 1953380736 (1862.89 GiB 2000.26 GB)
  Used Dev Size : 1953380736 (1862.89 GiB 2000.26 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Wed Nov  7 18:50:01 2012
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           Name : arya:0  (local to host arya)
           UUID : bee4dfe2:9c1d1028:0286d553:326b8516
         Events : 19

    Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       1       8       17        1      active sync   /dev/sdb1

Franchement la je ne sais pas du tout quoi faire, si quelqu'un a une idée... car si je perds les données ça vas pas trop le faire

#3 Re : -1 »  Ubuntu 12.10 et le Raid 1 » Le 07/11/2012, à 20:38

Totof08170
Réponses : 7

Bonjour slasher-fun

Je n'ai pas compris ce que tu voulais dire, ( le raid fonctionnais bien avant que je change d'os a moins que l'installation les à modifier...)
Peut-on récupéré les données qui étaient présente?

#4 Re : -1 »  Ubuntu 12.10 et le Raid 1 » Le 07/11/2012, à 22:00

Totof08170
Réponses : 7

Voila le retour de la commande

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sda » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000c7555

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *          63  3907024064  1953512001   fd  RAID Linux autodétecté

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sdb » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000034c8

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *          63  3907024064  1953512001   fd  RAID Linux autodétecté

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sdc » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sdc: 160.0 GB, 160041885696 bytes
255 têtes, 63 secteurs/piste, 19457 cylindres, total 312581808 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1               1   312581807   156290903+  ee  GPT

Disk /dev/sdd: 250.1 GB, 250059350016 bytes
255 têtes, 63 secteurs/piste, 30401 cylindres, total 488397168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x825b1f64

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdd1   *        2048   488394751   244196352    7  HPFS/NTFS/exFAT

Disk /dev/md127: 2000.3 GB, 2000261873664 bytes
2 têtes, 4 secteurs/piste, 488345184 cylindres, total 3906761472 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Le disque /dev/md127 ne contient pas une table de partitions valable

#5 Re : -1 »  Ubuntu 12.10 et le Raid 1 » Le 07/11/2012, à 22:11

Totof08170
Réponses : 7

Bah ouai je sais, mais lorsque le Raid fonctionnait j'avais aussi cela qui était indiquer, j'avais un pote qui ma parler de testdisk qui pourrais sans doute rattraper le coup, mais je sais pas trop.

Du coup la les données, a mon avis je peux m’asseoir dessus...

#6 Re : -1 »  Ubuntu 12.10 et le Raid 1 » Le 08/11/2012, à 00:13

Totof08170
Réponses : 7

Ca ma souler, j'ai supprimer tout de tout mes disques, j'ai refais tout à zéro, j'ai refais un raid, et voila ce que j'ai comme précédent, sauf que la le raid fonctionne. Malgrès le "Le disque /dev/md0 ne contient pas une table de partitions valable"

Disk /dev/md0: 2000.3 GB, 2000263512064 bytes
2 têtes, 4 secteurs/piste, 488345584 cylindres, total 3906764672 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Le disque /dev/md0 ne contient pas une table de partitions valable
totof@arya:~$ sudo mkdir /media/raid
totof@arya:~$ sudo mount -t ext4 /dev/md0 /media/raid/
totof@arya:~$ cd /media/raid/
totof@arya:/media/raid$ ls
lost+found

#7 -1 »  Guild Wars 2 et linux? » Le 25/09/2012, à 17:18

Totof08170
Réponses : 1

Salut tout le monde,


Petite question sur les jeux, je ne joue plus depuis un moment, mais j'ai bien envie de me mettre a guild wars 2 pour passer le temps.
Le seul soucis, je me demande si il passe bien sous linux ou pas?
Et niveau config, j'ai :
Proc : i5 2500k sandybrige
Ram : 8Go DDR3
Carte graphique : Nvidia Geforce G210 1Go DDR3

Je tourne sous ubuntu 12.04, et j'ai pas trop envie d'installer un 7 a coter juste pour jouer.

Cordialement

#8 -1 »  FTP ou autre service? » Le 07/09/2012, à 13:45

Totof08170
Réponses : 6

Bonjour tout le monde,


Voila j'aimerais bien mettre en place un service de partage de fichier pour plusieurs de mes amis.
Par contre je ne sais pas trop quoi mettre en place, j'ai essayer proftpd, mysecureshell,

Voila donc j'ai un Disque en RAID qui contient un répertoire Partage, et dans ce répertoire il y a un répertoire pour chaque users
Mais j'aimerais aussi que mes utilisateurs puissent avoir un accès en lecture au dossier Musiques de mon RAID.
J'ai essayer avec un lien symbolique avec proftpd mais ça n'a pas l'air de fonctionner a première vue.


Quelqu'un aurait une petite idée de ce que je pourrais mettre en place ?

#9 Re : -1 »  FTP ou autre service? » Le 07/09/2012, à 15:50

Totof08170
Réponses : 6
Kooothor a écrit :

Salut totof,

Quand tu dis : un disque en RAID, tu veux dire quoi ?
Parce que dit comme ça, ça ne signifie rien...
T'as un NAS ?
Tu peux t'y connecter de l'extérieur ?

Mon conseil : oublie FTP et mysecureshell.
Apprend à utiliser SSH/SFTP (man sshd), c'est ce qui te permettra de faire vraiment ce que tu veux au niveau des permissions (groupe ou user), et les gens pourront se connecter soit avec un mot de passe, soit avec une clé SSH-RSA (mieux).
De plus, ça te permettra d'en apprendre un peu plus wink Et puis t'as rien à installer, puisque openssh est déjà là !

Perso je préfère toujours utiliser les véritables outils GNU plutôt qu'un wrapper (mysecureshell) ou une alternative dépréciée (FTP).

@+
~ktr

Effectivement je me suis mal expliquer, j'ai deux disque de 2TO en RAID 1
Sur mon serveur j'ai deja un serveur ssh, j'avais déjà regarder pour le sftp, mais si je me trompe pas, il faut chrooter les users etc non?




@Yzeew ce n'est pas du partage pour des clients léger, c'est pour partager mes données avec des amis.

J'avais voulu faire un FTP, mais avec proftpd comme je l'ai dis au dessus, les iens symbolique n'avais pas l'air de fonctionner.

L'idéal que je voudrais ça serait ça
Grappe RAID
      - Partage
            - user1
            - user2
      - Musique
     
J'aimerais bien que l'user 1 puisse avoir accès en lecture/écriture dans son home, mais aussi lecture sur musique. Dans le dossier de chaque user, je voulais mettre un lien symbolique de musique par exemple, pour rendre ça un peut plus facile pour les utilisateurs.

#10 Re : -1 »  FTP ou autre service? » Le 07/09/2012, à 16:33

Totof08170
Réponses : 6

@koooothor http://www.ericstockwell.com/?p=54
Ce tuto la te parait bien?
Je vais tester ça sur un serveur virtuelle dans la journée,

#11 -1 »  Connexion ssh dans un script shell » Le 19/07/2012, à 07:40

Totof08170
Réponses : 0

Bonjour tout le monde,

Je vous explique mon petit soucis,

J'ai un serveur sous Ubuntu 12.04 avec virtualbox d'installer et quelques machines pour le moment
Je suis en train de faire un script shell avec une boite de dialogue zenity pour pouvoir démarrer des machines en mode headless depuis mon pc portable ( parce que j'ai aussi mon media center XBMC qui tourne en pleine écran, histoire que la fenêtre ne vienne pas devant )

Donc mon script ressemble à cela ( ce n'est qu'un tout début il y aura beaucoup de chose a modifier par la suite )

#! /bin/bash

## Script de lancement de Vbox a distance ##

## Variable contenant les UUID des VBOX ##
Ubuntu_12_04_dsk="6461ed16-5b88-4c1e-a64c-d1a908226d9f"
Ubuntu_12_04_srv="483a66d1-2973-4b6e-bae6-36f4c34113b1"
Windows_2008="4faa7c4b-8d3a-41fa-b701-a9c2b95c1406"
Windows_7="198580e2-57bd-4c8e-aa86-a0b28f2ba6fa"
Debian_Sqeeze="a3ca333f-2c21-4155-9c1b-02e1a0ae2b20"
Debian_Squeeze_srv="2c2d6227-b80a-400e-be9a-ec092d5b6bc9"

## Boite de dialogue Zénity avec choix des OS #
reponse=`zenity --list --checklist \
--text "Choisire une Vbox à lancer" \
--column="Choix" \
--column="OS" \
--print-column="2,4" \
FALSAE Ubuntu-12.04-dsk . Ubuntu-12.04-srv FALSE Windows-2008 . Windows-7 FALSE Debian-Sqeeze . Debian-Squeeze-srv \
`
## Boite de dialogue zénity avec l'os + info de l'os ( IP etc )
zenity --info \
--text "Vous avez choisi $reponse"

## Connexion SSH @ Arya

$(ssh 192.168.1.100)



## Lancement de la VBox mode headless ##
if $reponse [ $reponse="Ubuntu-12.04-dsk" ]
    then
        $(VBoxManage startvm $Ubuntu_12_04_dsk --type headless)
fi

if $reponse [ $reponse="Ubuntu-12.04-srv" ]
    then
        $(VBoxManage startvm $Ubuntu_12_04_srv --type headless)
fi

if $reponse [ $reponse="Windows-2008" ]
    then
        $(VBoxManage startvm $Windows_2008 --type headless)
fi

if $reponse [ $reponse="Windows-7" ]
    then
        $(VBoxManage startvm $Windows_7 --type headless)
fi

if $reponse [ $reponse="Debian-Sqeeze" ]
    then
        $(VBoxManage startvm $Debian_Sqeeze --type headless)
fi

if $reponse [ $reponse="Debian-Squeeze-srv" ]
    then
        $(VBoxManage startvm $Debian_Squeeze_srv --type headless)
fi

En faite, j'aimerais bien que après le choix de la Vbox a démarrer, le script se connecte avec mon compte en ssh pour pouvoir éffectuer la commande VBoxManage startvm VBOX --type headless

Mais je coince un peut à ce niveau la

Quelqu'un aurait une idée pour moi?

Merci


EDIT :

Avec la commande

ssh 192.168.1.100 VBoxManage startvm UUID --type headless

et en modifiant la condition comme cela

if [ $reponse="Ubuntu-12.04-dsk" ]
    then
        echo $reponse
        $(ssh 192.168.1.100 VBoxManage startvm $Ubuntu_12_04_dsk --type headless)

ça marche tout seul big_smile

Si le début du script intéresse quelqu'un dites le moi, je pourrais vous l'envoyer quand j'aurais modifier tout

#12 -1 »  Lancer machine virtuelle en tache de fond » Le 08/07/2012, à 23:16

Totof08170
Réponses : 1

Bonsoir,

Voila j'ai une ubuntu 12.04 qui est brancher en hdmi, avec XBMC en plein écran,
Je voulais savoir si on pouvais lancer une machine virtuelle en tache de fond pour éviter que la fenêtre de la machine virtuelle apparaissent devant XBMC

Merci !

#13 -1 »  Connexion impossible phphvirtualbox » Le 01/05/2012, à 14:39

Totof08170
Réponses : 11

Bonjour tout le monde,

J'ai un petit soucis avec phpvirtualbox, je vais vous donnez le maximum d'info possible

Mon linux tourne sous Ubuntu 12.04
Virtualbox en version 4.1.14

J'ai télécharger le zip de phpvirtualbox et je l'ai mis dans un dossier /media/RAID

Les droits du dossier  :

drwxr-xr-x 9 www-data totof 4096 mai    1 14:02 phpvirtualbox

La commande vboxwebsrv me retourne

Oracle VM VirtualBox web service version 4.1.14
(C) 2005-2012 Oracle Corporation
All rights reserved.
VirtualBox web service 4.1.14 r77440 linux.amd64 (Apr 26 2012 02:49:52) release log
00:00:00.000 main     Log opened 2012-05-01T12:36:23.699224000Z
00:00:00.000 main     OS Product: Linux
00:00:00.000 main     OS Release: 3.2.0-24-generic
00:00:00.000 main     OS Version: #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012
00:00:00.001 main     OS Service Pack: #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012
00:00:00.001 main     Executable: /usr/lib/virtualbox/vboxwebsrv
00:00:00.001 main     Process ID: 23907
00:00:00.001 main     Package type: LINUX_64BITS_UBUNTU_11_10
00:00:00.009 SQPmp    Socket connection successful: host = default (localhost), port = 18083, master socket = 8

J'accède bien a la page d'auth de virtualbox, mais ça me renvois l'erreur suivante :

Could not connect to host (http://192.168.1.100:18083/)

Exception Object
(
    [message:protected] => Could not connect to host (http://192.168.1.100:18083/)
    [string:Exception:private] => 
    [code:protected] => 64
    [file:protected] => /media/RAID/www/Reseau/Monitoring/phpvirtualbox/lib/vboxconnector.php
    [line:protected] => 188
    [trace:Exception:private] => Array
        (
            [0] => Array
                (
                    [file] => /media/RAID/www/Reseau/Monitoring/phpvirtualbox/lib/auth/Builtin.php
                    [line] => 45
                    [function] => connect
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

            [1] => Array
                (
                    [file] => /media/RAID/www/Reseau/Monitoring/phpvirtualbox/lib/ajax.php
                    [line] => 119
                    [function] => login
                    [class] => phpvbAuthBuiltin
                    [type] => ->
                    [args] => Array
                        (
                            [0] => USERS
                            [1] => MDP
                        )

                )

        )

    [previous:Exception:private] => 
)

Dans le fichier config.php l'user et le mdp sont bien renseigner.

Quelqu'un aurait une petite idée de ce qui ne vas pas?

Cordialement

#14 Re : -1 »  Connexion impossible phphvirtualbox » Le 02/05/2012, à 11:55

Totof08170
Réponses : 11
<?php
/**
 * phpVirtualBox example configuration. 
 * @version $Id: config.php-example 366 2011-12-01 19:56:57Z imooreyahoo@gmail.com $
 *
 * rename to config.php and edit as needed.
 *
 */
class phpVBoxConfig {

/* Username / Password for system user that runs VirtualBox */
var $username = '****';
var $password = '****';

/* SOAP URL of vboxwebsrv (not phpVirtualBox's URL) */
var $location = 'http://127.0.0.1:18083/';

/* Default language. See languages folder for more language options.
 * Can also be changed in File -> Preferences -> Language in
 * phpVirtualBox.
 */
var $language = 'fr';

users et mdp j'ai mis les identifiants de mon compte je sais pas si je devrais mettre root ou un autre

#15 Re : -1 »  Connexion impossible phphvirtualbox » Le 02/05/2012, à 12:52

Totof08170
Réponses : 11

J'ai ça :

sudo cat /etc/group | grep vboxusers
vboxusers:x:127:totof

#16 Re : -1 »  Connexion impossible phphvirtualbox » Le 02/05/2012, à 13:25

Totof08170
Réponses : 11
sudo service vboxweb-service status
Checking for VBox Web Service ...not running

ça c'est bizarre, le premier poste que j'avais mis la commande me retourne pas d'erreur le soucis dois venir de la je pense

#17 Re : -1 »  Connexion impossible phphvirtualbox » Le 02/05/2012, à 13:32

Totof08170
Réponses : 11

Je viens de trouver ce script : http://www.virtualbox.org/svn/vbox/trun … vice.sh.in
C'est peut être celui la qu'il me manque, je l'ai lancer mais apparemment cela n'a rien fais,

Truc bizarre aussi :

ps aux | grep vbox
totof     7106  0.0  0.0 472788  7868 pts/1    Sl+  13:24   0:00 /usr/lib/virtualbox/vboxwebsrv
totof     7417  0.0  0.0   9436   932 pts/2    S+   13:33   0:00 grep --color=auto vbox

J'ai trouver ce tuto : http://www.upubuntu.com/2011/08/how-to- … buntu.html



On est obliger de le mettre dans public_html? vue que je veux mettre phpvirtualbox pour pouvoir géré mes machines de l'exterieur etc

#18 Re : -1 »  Connexion impossible phphvirtualbox » Le 02/05/2012, à 14:31

Totof08170
Réponses : 11

ouai fin si j'arriverais à le faire marcher ça serait top quand même

#19 -1 »  Changement du disque système et RAID » Le 15/01/2012, à 04:52

Totof08170
Réponses : 11

Bonjours tout le monde,


J'avais une petite question :

J'ai un ubuntu serveur sur un disque de 250Go, et deux disque de 2To en RAID1
Mon disque système va me lacher et je vais devoir le changer, si j'installe un ubuntu serveur sur un disque neuf, est-ce que le RAID fonctionnerais si j'installe mdadm sur le nouveau disque? Histoire que je ne perde pas mes données j'en ai plutôt beaucoup.

Cordialement

#20 -1 »  Monter des grappes RAID 1 au démarrage » Le 18/09/2011, à 19:37

Totof08170
Réponses : 1

Bonjour tout le monde,

Voila j'ai un petit soucis, je viens de commander un nouveau pc et j'ai donc mis ubuntu, j'ai fais du Raid1 sur deux disques dur de 2TO a l'installation de ubuntu. Le raid1 est bien fait

/dev/md0:
        Version : 1.2
  Creation Time : Wed Sep 14 21:30:38 2011
     Raid Level : raid1
     Array Size : 1953513382 (1863.02 GiB 2000.40 GB)
  Used Dev Size : 1953513382 (1863.02 GiB 2000.40 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Sun Sep 18 19:18:36 2011
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           Name : Arya:0  (local to host Arya)
           UUID : 797140aa:ac1685ee:c0c7d482:63cdcf73
         Events : 24

    Number   Major   Minor   RaidDevice State
       0       8       17        0      active sync   /dev/sdb1
       1       8       33        1      active sync   /dev/sdc1

Mais je voudrais monter mes grappes au démarrage, j'ai vue le topic qui traite ce sujet ici

J'avais aussi une erreur au démarrage, mais la commande : sudo update-initramfs -u -k all à résolu ce souci, mais maitnenant je n'arrive pas a le monter automatiquement, j'ai éditer le fichier fstab et je me retrouve avec l'erreur que j'avais juste avant.

Lorsque je monte la grappe à la main je tape : sudo mount /dev/md0p1 /media/HDDRAID et je n'ai pas de souci la grappe est bien monter

Donc dans mon fstab je rajoute :
UUID=797140aa:ac1685ee:c0c7d482:63cdcf73 /dev/md0p1 /media/HDDRAID ext4 0 0

Mais j'ai encore l'erreur

Quelqu'un aurait une solution?

#21 -1 »  Intel HD graphic 64Mo » Le 17/09/2011, à 03:58

Totof08170
Réponses : 0

Bonjour,


Je viens de m'acheter le Asus X52F-SX1377V, caractéristique :
Ordinateur portable blanc avec écran 15,6" LED - Processeur Intel® Pentium™ P6200 - Mémoire 4096 Mo - 640 Go - Chipset graphique Intel - Sortie HDMI - Graveur de DVD - Lecteur cartes 3 en 1 - Wifi 802.11 b/g/n - Clavier AZERTY chicklet

J'ai bien sur retirer windows 7 pour mettre ubuntu 11.04, j'avais une petite question je voulais tester un jeux et il me dis que je n'ai pas assez de mémoire graphique, 64Mo alors qu'il demande mini 128Mo.

totof@totof-K52F:~$  lspci | grep "VGA"
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

Après quelque recherche j'ai vue que le processeur gérait les graphisme.
Y a t-il moyen d'augmenter l'allocation de la mémoire vidéo pour pouvoir tester le jeux?

Merci, cordialement Totof

#22 -1 »  Serveur VPN » Le 25/07/2011, à 04:24

Totof08170
Réponses : 4

Bonjours tous le monde


J'essai de faire un petit serveur VPN, j'ai suivit un tuto mais j'ai une petite erreur que je ne trouve pas

root@totof-1005HA:/var/log# /etc/init.d/openvpn restart
 * Stopping virtual private network daemon(s)...                                                                             *   No VPN is running.
 * Starting virtual private network daemon(s)...                                                                             *   Autostarting VPN 'server'                                                                                       [fail] 
root@totof-1005HA:/var/log# 

J'ai regarder dans les logs j'ai ces messages la :

Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: OpenVPN 2.1.0 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 12 2010
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: NOTE: when bridging your LAN adapter with the TAP adapter, note that the new bridge adapter will often take on its own IP address that is different from what the LAN adapter was previously set to
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: NOTE: your local LAN uses the extremely common subnet address 192.168.0.x or 192.168.1.x.  Be aware that this might create routing conflicts if you connect to the VPN server from public locations such as internet cafes that use the same subnet.
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: Diffie-Hellman initialized with 1024 bit key
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: /usr/bin/openssl-vulnkey -q -b 1024 -m <modulus omitted>
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: TLS-Auth MTU parms [ L:1574 D:166 EF:66 EB:0 ET:0 EL:0 ]
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: RESOLVE: Cannot resolve host address: <totof-1005HA>: [HOST_NOT_FOUND] The specified host is unknown.
Jul 25 04:22:04 totof-1005HA ovpn-server[6528]: Exiting


Et voila mon fichier de config VPN :

mode server
tls-server

local <totof-1005HA> ## ip/hostname of server
port 1194 ## default openvpn port
proto udp

#bridging directive
dev tap0 ## If you need multiple tap devices, add them here
up "/etc/openvpn/up.sh br0 tap0 1500"
down "/etc/openvpn/down.sh br0 tap0"

persist-key
persist-tun

#certificates and encryption
ca ca.crt
cert server.crt
key server.key  # This file should be kept secret
dh dh1024.pem
tls-auth ta.key 0 # This file is secret

cipher BF-CBC        # Blowfish (default)
comp-lzo

#DHCP Information
ifconfig-pool-persist ipp.txt
server-bridge 192.168.1.100 255.255.255.0 192.168.1.100 192.168.1.110
push "dhcp-option DNS 192.168.1.1"
push "dhcp-option DOMAIN 192.168.1.100"
max-clients 10 ## set this to the max number of clients that should be connected at a time

#log and security
user nobody
group nogroup
keepalive 10 120
status openvpn-status.log
verb 3

Quelqu'un pourrais me donner un coup de main?

Merci

#23 Re : -1 »  Serveur VPN » Le 25/07/2011, à 18:36

Totof08170
Réponses : 4
192.168.1.100   totof-1005HA    # Added by NetworkManager
127.0.0.1       localhost.localdomain   localhost
::1     totof-1005HA    localhost6.localdomain6 localhost6
127.0.1.1       totof-1005HA

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


Pourtant le fichier est bien renseigner...

#24 Re : -1 »  Serveur VPN » Le 27/07/2011, à 04:50

Totof08170
Réponses : 4

quelqu'un à une idée?