Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 6

#0 -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 26/03/2013, à 22:23

Harkann
Réponses : 9

Bonsoir ,
je voudrais me lancer dans la création de vidéos sur des jeux , et pour enregistrer j'utilise RecordmyDesktop
jusque là tout va bien , le fichier .ogv est parfait , mais lorsque je veut le convertir en .avi , le son se retrouve décalé par rapport à la vidéo
j'ai testé avec ffmpeg , mencoder (euh je crois qu'il s'appelle comme ça) et avec plein de commandess différentes trouvées sur le net ,pas moyen d'avoir quelque chose de correct , et je n'ai rien trouvé concernant un tel probleme ailleurs .
Voila ce que le terminal m'affiche a la sortie d'une conversion :

Converting 1 files !
converting out.ogv
MEncoder svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
success: format: 0  data: 0x0 - 0x787251
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
libavformat file format detected.
[ogg @ 0xb6bb1120]max_analyze_duration reached
[lavf] stream 1: video (theora), -vid 0
[lavf] stream 2: audio (vorbis), -aid 0
VIDEO:  [theo]  1312x752  0bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:44  fourcc:0x6F656874  size:1312x752  fps:25.000  ftime:=0.0400
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
AUDIO: 22050 Hz, 1 ch, s16le, 90.0 kbit/25.51% (ratio: 11248->44100)
Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis)
==========================================================================
xvid: using library version 1.3.2 (build xvid-1.3.2)
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [fftheora] vfm: ffmpeg (FFmpeg Theora)
==========================================================================
MP3 audio selected.
Movie-Aspect is 1.74:1 - prescaling to correct movie aspect.
videocodec: XviD (1312x752 fourcc=44495658 [XVID])
xvid: par=0/0 (vga11), displayed=1312x752, sampled=1312x752
xvid: 2Pass Rate Control -- 1st pass
Writing header...
ODML: vprp aspect is 16384:9390.
Setting audio delay to 0.052s.
Writing header...
ODML: vprp aspect is 16384:9390.
Setting audio delay to 0.052s.
Pos:   0.1s      2f (16%)  0.00fps Trem:   0min   1mb  A-V:0.004 [0:0]
[VD_FFMPEG] DRI failure.
Pos:   3.1s     77f (16%) 51.47fps Trem:   0min   4mb  A-V:-0.084 [1888:72]
1 duplicate frame(s)!
Pos:   3.5s     87f (16%) 50.91fps Trem:   0min   4mb  A-V:-0.084 [1679:71]
1 duplicate frame(s)!
Pos:   4.0s     97f (16%) 51.08fps Trem:   0min   4mb  A-V:-0.084 [1512:71]
1 duplicate frame(s)!
Pos:   4.4s    107f (16%) 50.64fps Trem:   0min   5mb  A-V:-0.084 [1693:72]
1 duplicate frame(s)!
Pos:   4.8s    117f (16%) 51.16fps Trem:   0min   5mb  A-V:-0.084 [1579:72]
1 duplicate frame(s)!
Pos:   5.3s    127f (16%) 50.68fps Trem:   0min   7mb  A-V:-0.084 [1941:72]
1 duplicate frame(s)!
Pos:   5.7s    137f (16%) 50.82fps Trem:   0min   7mb  A-V:-0.084 [1818:73]
1 duplicate frame(s)!
Pos:   6.2s    147f (18%) 51.02fps Trem:   0min   7mb  A-V:-0.084 [1920:74]
1 duplicate frame(s)!
Pos:   6.6s    157f (22%) 50.63fps Trem:   0min   7mb  A-V:-0.084 [2190:74]
1 duplicate frame(s)!
Pos:   7.0s    167f (23%) 50.41fps Trem:   0min   8mb  A-V:-0.084 [2261:74]
1 duplicate frame(s)!
Pos:   7.5s    177f (23%) 50.56fps Trem:   0min   8mb  A-V:-0.084 [2145:74]
1 duplicate frame(s)!
Pos:   7.9s    187f (25%) 49.72fps Trem:   0min   8mb  A-V:-0.084 [2357:75]
1 duplicate frame(s)!
Pos:   8.4s    197f (26%) 49.70fps Trem:   0min   9mb  A-V:-0.084 [2399:75]
1 duplicate frame(s)!
Pos:   8.8s    207f (26%) 49.78fps Trem:   0min   9mb  A-V:-0.084 [2289:75]
1 duplicate frame(s)!
Pos:   9.2s    217f (29%) 49.83fps Trem:   0min   8mb  A-V:-0.084 [2195:75]
1 duplicate frame(s)!
Pos:   9.7s    227f (29%) 50.10fps Trem:   0min   8mb  A-V:-0.084 [2114:75]
1 duplicate frame(s)!
Pos:  10.1s    237f (42%) 48.52fps Trem:   0min   8mb  A-V:-0.084 [2819:75]
1 duplicate frame(s)!
Pos:  10.6s    247f (50%) 47.44fps Trem:   0min   8mb  A-V:-0.084 [3406:75]
1 duplicate frame(s)!
Pos:  11.0s    257f (63%) 46.45fps Trem:   0min   8mb  A-V:-0.084 [4030:75]
1 duplicate frame(s)!
Pos:  11.4s    267f (71%) 45.82fps Trem:   0min   8mb  A-V:-0.084 [4322:75]
1 duplicate frame(s)!
Pos:  11.9s    277f (78%) 45.42fps Trem:   0min   8mb  A-V:-0.084 [4371:76]
1 duplicate frame(s)!
Pos:  12.3s    287f (90%) 44.70fps Trem:   0min   8mb  A-V:-0.084 [4834:75]
1 duplicate frame(s)!
Pos:  12.8s    297f (99%) 44.12fps Trem:   0min   8mb  A-V:-0.084 [5234:76]
1 duplicate frame(s)!
Pos:  13.2s    307f (100%) 44.29fps Trem:   0min   8mb  A-V:-0.084 [5075:76]
1 duplicate frame(s)!
Pos:  13.6s    317f (100%) 44.32fps Trem:   0min   8mb  A-V:-0.084 [4919:76]
1 duplicate frame(s)!
Pos:  13.8s    319f (100%) 44.34fps Trem:   0min   8mb  A-V:-0.052 [4887:76][/i]

[i]Flushing video frames.
Writing index...
Writing header...
ODML: vprp aspect is 16384:9390.
Setting audio delay to 0.052s.[/i]

Video stream: 4888.586 kbit/s  (611073 B/s)  size: 8408369 bytes  13.760 secs  319 frames

Audio stream:   76.465 kbit/s  (9558 B/s)  size: 136327 bytes  14.263 secs

Et la , le flux audio est plus long que le flux vidéo O.o
Quelqu'un pourrais t'il m'aider s'il vous plait ?
Bonne soirée

#1 Re : -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 26/03/2013, à 23:10

Harkann
Réponses : 9

Merci Haleth
mais bon , moi et la compilation ça fait deux ,et vu la longueur du tuto que j'ai trouvé  je testerais ça demain ....
Et sinon ya pas une méthode plus ... simple wink ?

#2 Re : -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 26/03/2013, à 23:17

Harkann
Réponses : 9

Ok, et en fait en lisant en detail c'est vrai que c'est pas compliqué ^^
Je te tiens au courant de mes résultats

#3 Re : -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 27/03/2013, à 00:35

Harkann
Réponses : 9

alors c'est bon , sauf que avec ta commande je n'ai pas de son et il me manque une partie de la video ,
par contre avec :

ffmpeg -i file.ogv file.avi

ça fonctionne mais l'image est de moins bonne qualité (quelques endroits flous)
je vais me coucher , je lirais la(les) réponse(s) demain
Bonne nuit

Edit:OMG les fautes d'orthographe

#4 Re : -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 27/03/2013, à 13:58

Harkann
Réponses : 9

Voila ce que me renvoie ta commande f.x0 :

MEncoder svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
Option xvidencopts: Unknown suboption -o
Error parsing option on the command line: -xvidencopts

Exiting... (error parsing command line)

#5 Re : -1 »  [RESOLU]probleme de son , conversion ogv en avi » Le 27/03/2013, à 14:17

Harkann
Réponses : 9

Euréka j'ai trouvé

mencoder "film.ogv" -ovc x264 -oac mp3lame -o "film.avi"

ça me donne exactement le résultat voulu !!!
merci pour vos réponses qui m'on été bien utiles pour avancer, je crois que je peut mettre ce post [résolu]
Bonne journée